]> git.pld-linux.org Git - packages/wl.git/commitdiff
- fix prep and rediff patches auto/th/wl-6.30.223.271-13
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 25 Feb 2021 19:06:53 +0000 (20:06 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 25 Feb 2021 19:06:53 +0000 (20:06 +0100)
- rel 13

kernel-4.14.patch
kernel-5.10.patch
linux-4.12.patch
wl.spec

index 44befc1501cd8f1da15fffe79a212b7b0f3e6b55..2f8b08391f7e4e273518071ee8614e647a0b82f0 100644 (file)
@@ -1,6 +1,7 @@
---- a/src/shared/linux_osl.c
-+++ b/src/shared/linux_osl.c
-@@ -1080,7 +1080,11 @@ osl_os_get_image_block(char *buf, int le
+diff -urNp -x '*.orig' wl-6.30.223.271.org/src/shared/linux_osl.c wl-6.30.223.271/src/shared/linux_osl.c
+--- wl-6.30.223.271.org/src/shared/linux_osl.c 2021-02-25 20:01:38.664328984 +0100
++++ wl-6.30.223.271/src/shared/linux_osl.c     2021-02-25 20:01:38.797662636 +0100
+@@ -1063,7 +1063,11 @@ osl_os_get_image_block(char *buf, int le
        if (!image)
                return 0;
  
index bb5d723350ad083bfaca9dae9f33107c4e66b2fc..d14de84c381af0fc1970321a514f881ece3a98c0 100644 (file)
@@ -1,30 +1,7 @@
-From: Joan Bruguera <joanbrugueram@gmail.com>
-Date: Sun, 13 Sep 2020 07:33:32 +0200
-Subject: Get rid of get_fs/set_fs calls in Broadcom WL driver.
-Origin: https://gist.github.com/joanbm/5c640ac074d27fd1d82c74a5b67a1290
-
-Fixes linux-next where get_fs/set_fs is already removed for some architectures.
-
-NB: Some checks in wlc_ioctl_internal are likely superfluous,
-    but I'm not familiar enough with the driver to remove them with confidence.
-
-See also: https://lwn.net/Articles/722267/
-          https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/commit/arch/x86/include/asm/uaccess.h?h=next-20200911&id=47058bb54b57962b3958a936ddbc59355e4c5504
-          https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/commit/include/linux/uaccess.h?h=next-20200911&id=5e6e9852d6f76e01b2e6803c74258afa5b432bc5
-
-Signed-off-by: Joan Bruguera <joanbrugueram@gmail.com>
----
- src/wl/sys/wl_cfg80211_hybrid.c | 29 ++-----------------------
- src/wl/sys/wl_iw.c              | 25 ++--------------------
- src/wl/sys/wl_linux.c           | 40 ++++++++++++++++++++++++++++++-----
- src/wl/sys/wl_linux.h           |  2 ++
- src/wl/sys/wlc_pub.h            |  1 +
- 5 files changed, 42 insertions(+), 55 deletions(-)
-
-diff -rup a/src/wl/sys/wl_cfg80211_hybrid.c b/src/wl/sys/wl_cfg80211_hybrid.c
---- a/src/wl/sys/wl_cfg80211_hybrid.c  2020-11-13 08:38:56.883599679 +0100
-+++ b/src/wl/sys/wl_cfg80211_hybrid.c  2020-11-13 08:42:07.944320760 +0100
-@@ -38,6 +38,7 @@
+diff -urNp -x '*.orig' wl-6.30.223.271.org/src/wl/sys/wl_cfg80211_hybrid.c wl-6.30.223.271/src/wl/sys/wl_cfg80211_hybrid.c
+--- wl-6.30.223.271.org/src/wl/sys/wl_cfg80211_hybrid.c        2021-02-25 20:01:39.220996979 +0100
++++ wl-6.30.223.271/src/wl/sys/wl_cfg80211_hybrid.c    2021-02-25 20:01:39.354330631 +0100
+@@ -41,6 +41,7 @@
  #include <wlioctl.h>
  #include <proto/802.11.h>
  #include <wl_cfg80211_hybrid.h>
@@ -32,7 +9,7 @@ diff -rup a/src/wl/sys/wl_cfg80211_hybrid.c b/src/wl/sys/wl_cfg80211_hybrid.c
  
  #define EVENT_TYPE(e) dtoh32((e)->event_type)
  #define EVENT_FLAGS(e) dtoh16((e)->flags)
-@@ -436,30 +437,8 @@ static void key_endian_to_host(struct wl
+@@ -449,30 +450,8 @@ static void key_endian_to_host(struct wl
  static s32
  wl_dev_ioctl(struct net_device *dev, u32 cmd, void *arg, u32 len)
  {
@@ -63,10 +40,10 @@ diff -rup a/src/wl/sys/wl_cfg80211_hybrid.c b/src/wl/sys/wl_cfg80211_hybrid.c
 +      return wlc_ioctl_internal(dev, cmd, arg, len);
  }
  
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 12, 0)
-diff -rup a/src/wl/sys/wl_iw.c b/src/wl/sys/wl_iw.c
---- a/src/wl/sys/wl_iw.c       2020-11-13 08:38:56.891599715 +0100
-+++ b/src/wl/sys/wl_iw.c       2020-11-13 08:40:14.803914270 +0100
+ static s32
+diff -urNp -x '*.orig' wl-6.30.223.271.org/src/wl/sys/wl_iw.c wl-6.30.223.271/src/wl/sys/wl_iw.c
+--- wl-6.30.223.271.org/src/wl/sys/wl_iw.c     2015-09-19 00:47:15.000000000 +0200
++++ wl-6.30.223.271/src/wl/sys/wl_iw.c 2021-02-25 20:01:39.354330631 +0100
 @@ -37,6 +37,7 @@ typedef const struct si_pub  si_t;
  
  #include <wl_dbg.h>
@@ -75,7 +52,7 @@ diff -rup a/src/wl/sys/wl_iw.c b/src/wl/sys/wl_iw.c
  
  extern bool wl_iw_conn_status_str(uint32 event_type, uint32 status,
        uint32 reason, char* stringBuf, uint buflen);
-@@ -106,29 +107,7 @@ dev_wlc_ioctl(
+@@ -103,29 +104,7 @@ dev_wlc_ioctl(
        int len
  )
  {
@@ -106,10 +83,10 @@ diff -rup a/src/wl/sys/wl_iw.c b/src/wl/sys/wl_iw.c
  }
  
  static int
-diff -rup a/src/wl/sys/wl_linux.c b/src/wl/sys/wl_linux.c
---- a/src/wl/sys/wl_linux.c    2020-11-13 08:39:05.659639371 +0100
-+++ b/src/wl/sys/wl_linux.c    2020-11-13 08:40:14.803914270 +0100
-@@ -1649,10 +1649,7 @@ wl_ioctl(struct net_device *dev, struct
+diff -urNp -x '*.orig' wl-6.30.223.271.org/src/wl/sys/wl_linux.c wl-6.30.223.271/src/wl/sys/wl_linux.c
+--- wl-6.30.223.271.org/src/wl/sys/wl_linux.c  2021-02-25 20:01:39.220996979 +0100
++++ wl-6.30.223.271/src/wl/sys/wl_linux.c      2021-02-25 20:01:39.354330631 +0100
+@@ -1662,10 +1662,7 @@ wl_ioctl(struct net_device *dev, struct
                goto done2;
        }
  
@@ -121,7 +98,7 @@ diff -rup a/src/wl/sys/wl_linux.c b/src/wl/sys/wl_linux.c
                if (!(buf = (void *) MALLOC(wl->osh, MAX(ioc.len, WLC_IOCTL_MAXLEN)))) {
                        bcmerror = BCME_NORESOURCE;
                        goto done2;
-@@ -1673,7 +1670,7 @@ wl_ioctl(struct net_device *dev, struct
+@@ -1686,7 +1683,7 @@ wl_ioctl(struct net_device *dev, struct
        WL_UNLOCK(wl);
  
  done1:
@@ -130,7 +107,7 @@ diff -rup a/src/wl/sys/wl_linux.c b/src/wl/sys/wl_linux.c
                if (copy_to_user(ioc.buf, buf, ioc.len))
                        bcmerror = BCME_BADADDR;
                MFREE(wl->osh, buf, MAX(ioc.len, WLC_IOCTL_MAXLEN));
-@@ -1683,6 +1680,39 @@ done2:
+@@ -1696,6 +1693,39 @@ done2:
        ASSERT(VALID_BCMERROR(bcmerror));
        if (bcmerror != 0)
                wl->pub->bcmerror = bcmerror;
@@ -170,9 +147,9 @@ diff -rup a/src/wl/sys/wl_linux.c b/src/wl/sys/wl_linux.c
        return (OSL_ERROR(bcmerror));
  }
  
-diff -rup a/src/wl/sys/wl_linux.h b/src/wl/sys/wl_linux.h
---- a/src/wl/sys/wl_linux.h    2015-09-19 00:47:30.000000000 +0200
-+++ b/src/wl/sys/wl_linux.h    2020-11-13 08:40:14.803914270 +0100
+diff -urNp -x '*.orig' wl-6.30.223.271.org/src/wl/sys/wl_linux.h wl-6.30.223.271/src/wl/sys/wl_linux.h
+--- wl-6.30.223.271.org/src/wl/sys/wl_linux.h  2015-09-19 00:47:15.000000000 +0200
++++ wl-6.30.223.271/src/wl/sys/wl_linux.h      2021-02-25 20:01:39.354330631 +0100
 @@ -22,6 +22,7 @@
  #define _wl_linux_h_
  
@@ -189,9 +166,9 @@ diff -rup a/src/wl/sys/wl_linux.h b/src/wl/sys/wl_linux.h
  extern struct net_device * wl_netdev_get(wl_info_t *wl);
  
  #endif 
-diff -rup a/src/wl/sys/wlc_pub.h b/src/wl/sys/wlc_pub.h
---- a/src/wl/sys/wlc_pub.h     2015-09-19 00:47:30.000000000 +0200
-+++ b/src/wl/sys/wlc_pub.h     2020-11-13 08:40:14.803914270 +0100
+diff -urNp -x '*.orig' wl-6.30.223.271.org/src/wl/sys/wlc_pub.h wl-6.30.223.271/src/wl/sys/wlc_pub.h
+--- wl-6.30.223.271.org/src/wl/sys/wlc_pub.h   2015-09-19 00:47:15.000000000 +0200
++++ wl-6.30.223.271/src/wl/sys/wlc_pub.h       2021-02-25 20:01:39.354330631 +0100
 @@ -24,6 +24,7 @@
  
  #include <wlc_types.h>
index 8abc73db4db119ff9b99954678fcf33ccf057e65..61aa293522998f324012e5f638352a1211152f84 100644 (file)
@@ -1,8 +1,7 @@
-diff --git a/src/wl/sys/wl_cfg80211_hybrid.c b/src/wl/sys/wl_cfg80211_hybrid.c
-index da36405..d3741eb 100644
---- a/src/wl/sys/wl_cfg80211_hybrid.c
-+++ b/src/wl/sys/wl_cfg80211_hybrid.c
-@@ -53,7 +53,11 @@ u32 wl_dbg_level = WL_DBG_ERR;
+diff -urNp -x '*.orig' wl-6.30.223.271.org/src/wl/sys/wl_cfg80211_hybrid.c wl-6.30.223.271/src/wl/sys/wl_cfg80211_hybrid.c
+--- wl-6.30.223.271.org/src/wl/sys/wl_cfg80211_hybrid.c        2021-02-25 20:01:38.124327695 +0100
++++ wl-6.30.223.271/src/wl/sys/wl_cfg80211_hybrid.c    2021-02-25 20:01:38.250994664 +0100
+@@ -60,7 +60,11 @@ u32 wl_dbg_level = WL_DBG_ERR;
  #endif
  
  static s32 wl_cfg80211_change_iface(struct wiphy *wiphy, struct net_device *ndev,
@@ -14,7 +13,7 @@ index da36405..d3741eb 100644
  #if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 6, 0)
  static s32
  wl_cfg80211_scan(struct wiphy *wiphy,
-@@ -466,7 +470,11 @@ wl_dev_ioctl(struct net_device *dev, u32 cmd, void *arg, u32 len)
+@@ -473,7 +477,11 @@ wl_dev_ioctl(struct net_device *dev, u32
  
  static s32
  wl_cfg80211_change_iface(struct wiphy *wiphy, struct net_device *ndev,
@@ -26,7 +25,7 @@ index da36405..d3741eb 100644
     struct vif_params *params)
  {
        struct wl_cfg80211_priv *wl = wiphy_to_wl(wiphy);
-@@ -2361,6 +2369,20 @@ wl_bss_roaming_done(struct wl_cfg80211_priv *wl, struct net_device *ndev,
+@@ -2394,6 +2402,20 @@ wl_bss_roaming_done(struct wl_cfg80211_p
                      const wl_event_msg_t *e, void *data)
  {
        struct wl_cfg80211_connect_info *conn_info = wl_to_conn(wl);
@@ -46,10 +45,10 @@ index da36405..d3741eb 100644
 +#endif
        s32 err = 0;
  
-       wl_get_assoc_ies(wl);
-@@ -2368,12 +2390,17 @@ wl_bss_roaming_done(struct wl_cfg80211_priv *wl, struct net_device *ndev,
-       memcpy(&wl->bssid, &e->addr, ETHER_ADDR_LEN);
-       wl_update_bss_info(wl);
+       err = wl_get_assoc_ies(wl);
+@@ -2408,12 +2430,17 @@ wl_bss_roaming_done(struct wl_cfg80211_p
+               return err;
        cfg80211_roamed(ndev,
 +#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 12, 0)
 +                      &roam_info,
diff --git a/wl.spec b/wl.spec
index 33ab3dd320c4a87c0ae535c61f743f6b1578a80e..49c9553e4b5cd57ac9e54496d582f03e55ff5774 100644 (file)
--- a/wl.spec
+++ b/wl.spec
@@ -18,7 +18,7 @@ exit 1
 
 %define                _duplicate_files_terminate_build        0
 
-%define                rel     12
+%define                rel     13
 %define                pname   wl
 %define                file_ver        %(echo %{version} | tr . _)
 Summary:       Broadcom 802.11 a/b/g/n hybrid Linux networking device driver
@@ -126,7 +126,7 @@ EOF\
 %else
 %define src 0
 %endif
-%setup -c -T -q -n %{pname}-%{version} -b%{src}
+%setup -c -q -n %{pname}-%{version} -a %{src}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
This page took 0.119781 seconds and 4 git commands to generate.