]> git.pld-linux.org Git - packages/wl.git/commitdiff
- updated to 6.30.223.248
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 8 Nov 2014 08:18:03 +0000 (09:18 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 8 Nov 2014 08:18:03 +0000 (09:18 +0100)
broadcom-sta-6.30.223.141-kernel-3.10.patch [deleted file]
wl.spec

diff --git a/broadcom-sta-6.30.223.141-kernel-3.10.patch b/broadcom-sta-6.30.223.141-kernel-3.10.patch
deleted file mode 100644 (file)
index c575f28..0000000
+++ /dev/null
@@ -1,102 +0,0 @@
-diff -Naur bcmwl-6.30.223.30+bdcom.orig/src/src/wl/sys/wl_linux.c bcmwl-6.30.223.30+bdcom/src/src/wl/sys/wl_linux.c
---- bcmwl-6.30.223.30+bdcom.orig/src/src/wl/sys/wl_linux.c     2013-04-23 12:31:31.011588881 +0200
-+++ bcmwl-6.30.223.30+bdcom/src/src/wl/sys/wl_linux.c  2013-05-20 18:27:18.830187333 +0200
-@@ -3229,7 +3229,12 @@
- wl_tkip_printstats(wl_info_t *wl, bool group_key)
- {
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 14)
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 10, 0)
-+      struct seq_file sfile;
-+      struct seq_file *debug_buf = &sfile;    
-+#else
-       char debug_buf[512];
-+#endif
-       int idx;
-       if (wl->tkipmodops) {
-               if (group_key) {
-@@ -3242,7 +3247,11 @@
-                       wl->tkipmodops->print_stats(debug_buf, wl->tkip_ucast_data);
-               else
-                       return;
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 10, 0)
-+              printk("%s: TKIP stats from module: %s\n", debug_buf->buf, group_key?"Bcast":"Ucast");
-+#else
-               printk("%s: TKIP stats from module: %s\n", debug_buf, group_key?"Bcast":"Ucast");
-+#endif
-       }
- #endif 
- }
-@@ -3401,17 +3410,24 @@
-       return 0;
- }
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 10, 0)
- static int
- wl_proc_read(char *buffer, char **start, off_t offset, int length, int *eof, void *data)
-+#else
-+static ssize_t 
-+wl_proc_read (struct file *filp, char __user *buffer, size_t length, loff_t *data)
-+#endif
- {
-       wl_info_t * wl = (wl_info_t *)data;
-       int bcmerror, to_user;
-       int len;
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 10, 0)
-       if (offset > 0) {
-               *eof = 1;
-               return 0;
-       }
-+#endif
-       if (!length) {
-               WL_ERROR(("%s: Not enough return buf space\n", __FUNCTION__));
-@@ -3424,8 +3440,13 @@
-       return len;
- }
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 10, 0)
- static int
- wl_proc_write(struct file *filp, const char *buff, unsigned long length, void *data)
-+#else
-+static ssize_t 
-+wl_proc_write (struct file *filp, const char __user *buff, size_t length, loff_t *data)
-+#endif
- {
-       wl_info_t * wl = (wl_info_t *)data;
-       int from_user = 0;
-@@ -3455,19 +3476,34 @@
-       return length;
- }
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 10, 0)
-+static const struct file_operations wl_fops = {
-+     .owner   = THIS_MODULE,
-+     .read    = wl_proc_read,
-+     .write   = wl_proc_write,
-+};
-+#endif
-+
- static int
- wl_reg_proc_entry(wl_info_t *wl)
- {
-       char tmp[32];
-       sprintf(tmp, "%s%d", HYBRID_PROC, wl->pub->unit);
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 10, 0)
-       if ((wl->proc_entry = create_proc_entry(tmp, 0644, NULL)) == NULL) {
-               WL_ERROR(("%s: create_proc_entry %s failed\n", __FUNCTION__, tmp));
-+#else
-+      if ((wl->proc_entry = proc_create(tmp, 0644, NULL, &wl_fops)) == NULL) {
-+              WL_ERROR(("%s: proc_create %s failed\n", __FUNCTION__, tmp));
-+#endif
-               ASSERT(0);
-               return -1;
-       }
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 10, 0)
-       wl->proc_entry->read_proc = wl_proc_read;
-       wl->proc_entry->write_proc = wl_proc_write;
-       wl->proc_entry->data = wl;
-+#endif
-       return 0;
- }
- #ifdef WLOFFLD
diff --git a/wl.spec b/wl.spec
index cbc391a8f36a3e147fe5f480e4e3beae83c9e887..2d47beffba90d0381c74650b033555aa8d5fd510 100644 (file)
--- a/wl.spec
+++ b/wl.spec
@@ -30,14 +30,14 @@ exit 1
 %define                file_ver        %(echo %{version} | tr . _)
 Summary:       Broadcom 802.11 a/b/g/n hybrid Linux networking device driver
 Name:          %{pname}%{_alt_kernel}
-Version:       6.30.223.141
+Version:       6.30.223.248
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 License:       other
 Group:         Base/Kernel
 Source0:       http://www.broadcom.com/docs/linux_sta/hybrid-v35-nodebug-pcoem-%{file_ver}.tar.gz
-# Source0-md5: f4809d9149e8e60ef95021ae93a4bf21
+# Source0-md5: e048154b3f4c7ad6bee36cab5b37486d
 Source1:       http://www.broadcom.com/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-%{file_ver}.tar.gz
-# Source1-md5: 039f33d2a3ff2890e42717092d1eb0c4
+# Source1-md5: 0237917f75d121589ec16a44eac5f5b0
 Source2:       http://www.broadcom.com/docs/linux_sta/README.txt
 # Source2-md5: 8a6e8708a5e00ab6d841cde51d70eb1b
 Source3:       dkms.conf
@@ -122,7 +122,7 @@ EOF\
 %define src 0
 %endif
 %setup -c -T -q -n %{pname}-%{version} -b%{src}
-%patch0 -p2
+#%patch0 -p2
 
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
This page took 0.143168 seconds and 4 git commands to generate.