]> git.pld-linux.org Git - packages/wl.git/commitdiff
- 3.14 already uses gcc 4.9 features auto/th/wl-6.30.223.248-3
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 11 Dec 2014 20:45:38 +0000 (21:45 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 11 Dec 2014 20:45:38 +0000 (21:45 +0100)
- rel 3

gcc-4.9.patch
wl.spec

index d50535551d5834ce10b2e3e4a211bc4c38da72aa..d085f866a20d7685caa2afbdf4c1c627945da7ba 100644 (file)
@@ -4,12 +4,12 @@
                WL_ALL_PASSIVE_ENAB(wl) ?  ", Passive Mode" : "", EPI_VERSION_STR);
  
  #ifdef BCMDBG
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 15, 0)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 14, 0)
 +#pragma GCC diagnostic push
 +#pragma GCC diagnostic ignored "-Wdate-time"
 +#endif
        printf(" (Compiled in " SRCBASE " at " __TIME__ " on " __DATE__ ")");
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 15, 0)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 14, 0)
 +#pragma GCC diagnostic pop
 +#endif
  #endif 
  void
  wl_dump_ver(wl_info_t *wl, struct bcmstrbuf *b)
  {
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 15, 0)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 14, 0)
 +#pragma GCC diagnostic push
 +#pragma GCC diagnostic ignored "-Wdate-time"
 +#endif
        bcm_bprintf(b, "wl%d: %s %s version %s\n", wl->pub->unit,
                __DATE__, __TIME__, EPI_VERSION_STR);
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 15, 0)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 14, 0)
 +#pragma GCC diagnostic pop
 +#endif
  }
diff --git a/wl.spec b/wl.spec
index c2bff4d9b74ef028f1fb725c0e7d83c9fd19e320..5d57ac68968640242e2a2cb728b96f8dc2364c49 100644 (file)
--- a/wl.spec
+++ b/wl.spec
@@ -25,7 +25,7 @@ exit 1
 %define                kpkg    %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%kernel_pkg ; done)
 %define                bkpkg   %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%build_kernel_pkg ; done)
 
-%define                rel     2
+%define                rel     3
 %define                pname   wl
 %define                file_ver        %(echo %{version} | tr . _)
 Summary:       Broadcom 802.11 a/b/g/n hybrid Linux networking device driver
This page took 0.128144 seconds and 4 git commands to generate.