]> git.pld-linux.org Git - packages/wl.git/commitdiff
- fix building with kerbel 4.11 auto/th/wl-6.30.223.271-6
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 9 May 2017 22:49:59 +0000 (00:49 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 9 May 2017 22:49:59 +0000 (00:49 +0200)
- rel 6

linux-4.11.patch [new file with mode: 0644]
wl.spec

diff --git a/linux-4.11.patch b/linux-4.11.patch
new file mode 100644 (file)
index 0000000..6ac1b48
--- /dev/null
@@ -0,0 +1,24 @@
+--- wl-6.30.223.271/src/wl/sys/wl_linux.c~     2017-05-10 00:45:38.000000000 +0200
++++ wl-6.30.223.271/src/wl/sys/wl_linux.c      2017-05-10 00:46:16.265195806 +0200
+@@ -2929,7 +2929,9 @@
+       if (skb == NULL) return;
+       skb->dev = wl->monitor_dev;
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 11, 0)
+       skb->dev->last_rx = jiffies;
++#endif
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 22)
+       skb_reset_mac_header(skb);
+ #else
+--- wl-6.30.223.271/src/wl/sys/wl_cfg80211_hybrid.c~   2017-05-10 00:48:08.000000000 +0200
++++ wl-6.30.223.271/src/wl/sys/wl_cfg80211_hybrid.c    2017-05-10 00:49:17.837333867 +0200
+@@ -30,6 +30,9 @@
+ #include <linux/kthread.h>
+ #include <linux/netdevice.h>
+ #include <linux/ieee80211.h>
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
++#include <linux/sched/signal.h>
++#endif
+ #include <net/cfg80211.h>
+ #include <linux/nl80211.h>
+ #include <net/rtnetlink.h>
diff --git a/wl.spec b/wl.spec
index 525978ae1da9539884eeb8f3c0d2654fe78683ad..be51f5fcc7b31bdef988cad6f3bceaaba5356868 100644 (file)
--- a/wl.spec
+++ b/wl.spec
@@ -18,7 +18,7 @@ exit 1
 
 %define                _duplicate_files_terminate_build        0
 
-%define                rel     5
+%define                rel     6
 %define                pname   wl
 %define                file_ver        %(echo %{version} | tr . _)
 Summary:       Broadcom 802.11 a/b/g/n hybrid Linux networking device driver
@@ -41,6 +41,7 @@ Patch2:               no-dead-code.patch
 Patch3:                linux-4.7.patch
 Patch4:                linux-4.8.patch
 Patch5:                17-fix-kernel-warnings.patch
+Patch6:                linux-4.11.patch
 URL:           http://www.broadcom.com/support/802.11
 BuildRequires: rpmbuild(macros) >= 1.701
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
@@ -127,6 +128,7 @@ EOF\
 %patch3 -p1
 %patch4 -p1
 %patch5 -p2
+%patch6 -p1
 
 mkdir wl
 mv lib src Makefile wl/
This page took 0.035128 seconds and 4 git commands to generate.