]> git.pld-linux.org Git - packages/wl.git/commitdiff
- rel 7 auto/th/wl-6.30.223.271-7
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 31 Jul 2017 21:48:11 +0000 (23:48 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 31 Jul 2017 21:48:11 +0000 (23:48 +0200)
- fix building with kernel 4.12

linux-4.12.patch [new file with mode: 0644]
wl.spec

diff --git a/linux-4.12.patch b/linux-4.12.patch
new file mode 100644 (file)
index 0000000..8abc73d
--- /dev/null
@@ -0,0 +1,68 @@
+diff --git a/src/wl/sys/wl_cfg80211_hybrid.c b/src/wl/sys/wl_cfg80211_hybrid.c
+index da36405..d3741eb 100644
+--- a/src/wl/sys/wl_cfg80211_hybrid.c
++++ b/src/wl/sys/wl_cfg80211_hybrid.c
+@@ -53,7 +53,11 @@ u32 wl_dbg_level = WL_DBG_ERR;
+ #endif
+ static s32 wl_cfg80211_change_iface(struct wiphy *wiphy, struct net_device *ndev,
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 12, 0)
++           enum nl80211_iftype type, struct vif_params *params);
++#else
+            enum nl80211_iftype type, u32 *flags, struct vif_params *params);
++#endif
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 6, 0)
+ static s32
+ wl_cfg80211_scan(struct wiphy *wiphy,
+@@ -466,7 +470,11 @@ wl_dev_ioctl(struct net_device *dev, u32 cmd, void *arg, u32 len)
+ static s32
+ wl_cfg80211_change_iface(struct wiphy *wiphy, struct net_device *ndev,
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 12, 0)
++                         enum nl80211_iftype type,
++#else
+                          enum nl80211_iftype type, u32 *flags,
++#endif
+    struct vif_params *params)
+ {
+       struct wl_cfg80211_priv *wl = wiphy_to_wl(wiphy);
+@@ -2361,6 +2369,20 @@ wl_bss_roaming_done(struct wl_cfg80211_priv *wl, struct net_device *ndev,
+                     const wl_event_msg_t *e, void *data)
+ {
+       struct wl_cfg80211_connect_info *conn_info = wl_to_conn(wl);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 12, 0)
++      struct cfg80211_bss *bss;
++      struct wlc_ssid *ssid;
++      ssid = &wl->profile->ssid;
++      bss = cfg80211_get_bss(wl_to_wiphy(wl), NULL, (s8 *)&wl->bssid,
++      ssid->SSID, ssid->SSID_len, WLAN_CAPABILITY_ESS, WLAN_CAPABILITY_ESS);
++      struct cfg80211_roam_info roam_info = {
++              .bss = bss,
++              .req_ie = conn_info->req_ie,
++              .req_ie_len = conn_info->req_ie_len,
++              .resp_ie = conn_info->resp_ie,
++              .resp_ie_len = conn_info->resp_ie_len,
++      };
++#endif
+       s32 err = 0;
+       wl_get_assoc_ies(wl);
+@@ -2368,12 +2390,17 @@ wl_bss_roaming_done(struct wl_cfg80211_priv *wl, struct net_device *ndev,
+       memcpy(&wl->bssid, &e->addr, ETHER_ADDR_LEN);
+       wl_update_bss_info(wl);
+       cfg80211_roamed(ndev,
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 12, 0)
++                      &roam_info,
++#else
+ #if LINUX_VERSION_CODE > KERNEL_VERSION(2, 6, 39)
+                       &wl->conf->channel,      
+ #endif
+                       (u8 *)&wl->bssid,
+                       conn_info->req_ie, conn_info->req_ie_len,
+-                      conn_info->resp_ie, conn_info->resp_ie_len, GFP_KERNEL);
++                      conn_info->resp_ie, conn_info->resp_ie_len,
++#endif
++                      GFP_KERNEL);
+       WL_DBG(("Report roaming result\n"));
+       set_bit(WL_STATUS_CONNECTED, &wl->status);
diff --git a/wl.spec b/wl.spec
index be51f5fcc7b31bdef988cad6f3bceaaba5356868..654ce3e80e6b265ded1d8aa33c8d20b98dddae09 100644 (file)
--- a/wl.spec
+++ b/wl.spec
@@ -18,7 +18,7 @@ exit 1
 
 %define                _duplicate_files_terminate_build        0
 
 
 %define                _duplicate_files_terminate_build        0
 
-%define                rel     6
+%define                rel     7
 %define                pname   wl
 %define                file_ver        %(echo %{version} | tr . _)
 Summary:       Broadcom 802.11 a/b/g/n hybrid Linux networking device driver
 %define                pname   wl
 %define                file_ver        %(echo %{version} | tr . _)
 Summary:       Broadcom 802.11 a/b/g/n hybrid Linux networking device driver
@@ -42,6 +42,7 @@ Patch3:               linux-4.7.patch
 Patch4:                linux-4.8.patch
 Patch5:                17-fix-kernel-warnings.patch
 Patch6:                linux-4.11.patch
 Patch4:                linux-4.8.patch
 Patch5:                17-fix-kernel-warnings.patch
 Patch6:                linux-4.11.patch
+Patch7:                linux-4.12.patch
 URL:           http://www.broadcom.com/support/802.11
 BuildRequires: rpmbuild(macros) >= 1.701
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
 URL:           http://www.broadcom.com/support/802.11
 BuildRequires: rpmbuild(macros) >= 1.701
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
@@ -129,6 +130,7 @@ EOF\
 %patch4 -p1
 %patch5 -p2
 %patch6 -p1
 %patch4 -p1
 %patch5 -p2
 %patch6 -p1
+%patch7 -p1
 
 mkdir wl
 mv lib src Makefile wl/
 
 mkdir wl
 mv lib src Makefile wl/
This page took 0.120074 seconds and 4 git commands to generate.