]> git.pld-linux.org Git - packages/wl.git/commitdiff
- build fix for kernel 5.17, rel 15 auto/th/wl-6.30.223.271-15
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 2 Apr 2022 20:10:56 +0000 (22:10 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 2 Apr 2022 20:10:56 +0000 (22:10 +0200)
kernel-5.17.patch [new file with mode: 0644]
wl.spec

diff --git a/kernel-5.17.patch b/kernel-5.17.patch
new file mode 100644 (file)
index 0000000..9753eaa
--- /dev/null
@@ -0,0 +1,26 @@
+--- wl-6.30.223.271/wl/src/wl/sys/wl_linux.c~  2022-04-02 21:59:42.000000000 +0200
++++ wl-6.30.223.271/wl/src/wl/sys/wl_linux.c   2022-04-02 22:09:00.597044484 +0200
+@@ -3313,7 +3313,11 @@
+ static ssize_t
+ wl_proc_read(struct file *filp, char __user *buffer, size_t length, loff_t *offp)
+ {
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 17, 0)
+       wl_info_t * wl = PDE_DATA(file_inode(filp));
++#else
++      wl_info_t * wl = pde_data(file_inode(filp));
++#endif
+ #endif
+       int bcmerror, len;
+       int to_user = 0;
+@@ -3370,7 +3374,11 @@
+ static ssize_t
+ wl_proc_write(struct file *filp, const char __user *buff, size_t length, loff_t *offp)
+ {
++#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 10, 0)
+       wl_info_t * wl = PDE_DATA(file_inode(filp));
++#else
++      wl_info_t * wl = pde_data(file_inode(filp));
++#endif
+ #endif
+       int from_user = 0;
+       int bcmerror;
diff --git a/wl.spec b/wl.spec
index 2bb3a12dff6e6fdc63c3ed046057f5d2d8631e48..c7dc4ad6fdf9a62eab04f39620e09e47a2ce5585 100644 (file)
--- a/wl.spec
+++ b/wl.spec
@@ -18,7 +18,7 @@ exit 1
 
 %define                _duplicate_files_terminate_build        0
 
-%define                rel     14
+%define                rel     15
 %define                pname   wl
 %define                file_ver        %(echo %{version} | tr . _)
 Summary:       Broadcom 802.11 a/b/g/n hybrid Linux networking device driver
@@ -47,6 +47,7 @@ Patch8:               008-linux415.patch
 Patch9:                kernel-4.14.patch
 Patch10:       linux-5.6.patch
 Patch11:       kernel-5.10.patch
+Patch12:       kernel-5.17.patch
 URL:           http://www.broadcom.com/support/802.11
 BuildRequires: rpmbuild(macros) >= 1.701
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
@@ -137,6 +138,7 @@ EOF\
 %patch9 -p1
 %patch10 -p2
 %patch11 -p1
+%patch12 -p2
 
 mkdir wl
 mv lib src Makefile wl/
This page took 0.047771 seconds and 4 git commands to generate.