]> git.pld-linux.org Git - packages/wine.git/blobdiff - wine.spec
- rel 3; enable 64bit wine
[packages/wine.git] / wine.spec
index 59beb52bc97b2439924ce6c021b801959e95e72e..ff8c11310312b12ba31a969c85d73097ce61da59 100644 (file)
--- a/wine.spec
+++ b/wine.spec
@@ -1,14 +1,14 @@
 #
 # Conditional build:
 %bcond_without alsa            # don't build ALSA mm driver
+%bcond_with    esd             # build ESD mm driver
 %bcond_without jack            # don't build JACK mm driver
 %bcond_without nas             # don't build NAS mm driver
 %bcond_without sane            # don't build TWAIN DLL with scanning support (through SANE)
 %bcond_without cups            # without CUPS printing support in winspool,wineps DLLs
 #
-# NOTE:        wineconsole is a bit broken: try wineconsole cmd to see what will happen
-#      As a workaroound use `wineconsole --backend=user cmd' (works fine)
-#      ref: http://bugs.winehq.org/show_bug.cgi?id=8069
+# TODO:
+# - support for CAPI (ISDN support; --with-capi)
 #
 # NOTE: wine detects the following SONAMES for dlopen at build time:
 #   libcrypto,libssl (wininet.dll)
 %if %{without alsa}
 %undefine      with_jack
 %endif
+
 Summary:       Program that lets you launch Win applications
 Summary(es.UTF-8):     Ejecuta programas Windows en Linux
 Summary(pl.UTF-8):     Program pozwalający uruchamiać aplikacje Windows
 Summary(pt_BR.UTF-8):  Executa programas Windows no Linux
 Name:          wine
-Version:       0.9.51
-Release:       1
+Version:       1.2.2
+Release:       3
 Epoch:         1
 License:       LGPL
 Group:         Applications/Emulators
 Source0:       http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
-# Source0-md5: 1cf4fddfe2432f43f8461a0f064d34c5
+# Source0-md5: e976d64688e0833061e79efa3eac5d2c
+Source1:       http://downloads.sourceforge.net/wine/%{name}_gecko-1.0.0-x86.cab
+# Source1-md5: 9c5c335fc077c0558561afaf25a09e51
+Source2:       %{name}-uninstaller.desktop
 Patch0:                %{name}-fontcache.patch
 Patch1:                %{name}-makedep.patch
 Patch2:                %{name}-ncurses.patch
-Patch3:                %{name}-bug9177_workaround.patch
-#PatchX:               %{name}-dga.patch
+Patch4:                %{name}-disable-valgrind.patch
+Patch5:                %{name}-ca_certificates.patch
+Patch6:                %{name}-notarget.patch
+Patch7:                %{name}-manpaths.patch
+Patch8:                desktop.patch
+#PatchX:       %{name}-dga.patch
 URL:           http://www.winehq.org/
+BuildRequires: OpenAL-devel >= 1.1
 BuildRequires: OpenGL-GLU-devel
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
 %{?with_arts:BuildRequires:    artsc-devel}
@@ -52,36 +61,59 @@ BuildRequires:      bison
 %{?with_cups:BuildRequires:    cups-devel}
 BuildRequires: docbook-dtd31-sgml
 BuildRequires: docbook-utils
+%{?with_esd:BuildRequires:     esound-devel}
 BuildRequires: flex
 BuildRequires: fontconfig-devel
 BuildRequires: fontforge
 BuildRequires: freetype-devel >= 2.0.5
 BuildRequires: giflib-devel
+BuildRequires: gnutls-devel
+BuildRequires: hal-devel
+BuildRequires: icoutils
 %{?with_jack:BuildRequires:    jack-audio-connection-kit-devel}
+BuildRequires: lcms-devel
+BuildRequires: libgphoto2-devel
+BuildRequires: libgsm-devel
 BuildRequires: libjpeg-devel
+BuildRequires: libmpg123-devel >= 1.5.0
 BuildRequires: libtool
+BuildRequires: libv4l-devel
+BuildRequires: libxslt-devel
 %{?with_nas:BuildRequires:     nas-devel}
 BuildRequires: ncurses-devel
 # db2* failed previously - probably openjade or opensp bug
 BuildRequires: openjade >= 1:1.3.3-0.pre1
-BuildRequires: openldap-devel >= 2.4.6
+BuildRequires: openldap-devel
 BuildRequires: opensp >= 1:1.5.1
 BuildRequires: openssl-devel >= 0.9.7d
+BuildRequires: pkgconfig
 %{?with_sane:BuildRequires:    sane-backends-devel}
-BuildRequires: valgrind
+BuildRequires: unixODBC-devel >= 2.2.12-2
+#BuildRequires:        valgrind
+BuildRequires: xorg-lib-libXcomposite-devel
+BuildRequires: xorg-lib-libXcursor-devel
 BuildRequires: xorg-lib-libXi-devel
+BuildRequires: xorg-lib-libXinerama-devel
 BuildRequires: xorg-lib-libXmu-devel
+BuildRequires: xorg-lib-libXrandr-devel
 BuildRequires: xorg-lib-libXrender-devel
 BuildRequires: xorg-lib-libXxf86dga-devel
 BuildRequires: xorg-lib-libXxf86vm-devel
+Requires:      libfreetype.so.6
 Suggests:      binfmt-detector
-# For winelauncher
+Suggests:      ca-certificates
+Conflicts:     ca-certificates < 20080809-4
+# for printing needs lpr
+Suggests:      cups-clients
+# for winelauncher
 Suggests:      xorg-app-xmessage
+# for ntlm_auth
+Suggests:      samba-common >= 1:3.0.25
 # link to wine/ntdll.dll.so, without any SONAME
 Provides:      libntdll.dll.so
 Obsoletes:     wine-doc-pdf
 Obsoletes:     wine-drv-arts
-ExclusiveArch: %{ix86}
+ExclusiveArch: %{ix86} %{x8664}
 ExcludeArch:   i386
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -235,40 +267,71 @@ Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
-
-# turn off compilation of some tools
-sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
-#sed -i -e "s|avitools||" programs/Makefile.in
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
 
 %build
+icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
+mv -f oic_winlogo_*.png %{name}.png
+
 %{__autoconf}
 %{__autoheader}
 %configure \
-       %{!?debug:--disable-debug} \
-       %{!?debug:--disable-trace} \
-       --enable-curses \
-       --enable-opengl \
+%ifarch %{x8664}
+       --enable-win64 \
+%endif
+       --with%{!?with_alsa:out}-alsa \
+       --with-audioio \
+       --without-capi \
+       --with-cms \
+       --with-coreaudio \
+       --with%{!?with_cups:out}-cups \
+       --with-curses \
+       --with%{!?with_esd:out}-esd \
+       --with-fontconfig \
+       --with-freetype \
+       --with-glu \
+       --with-gnutls \
+       --with-gphoto \
+       --with-gsm \
+       --with-hal \
+       --with%{!?with_jack:out}-jack \
+       --with-jpeg \
+       --with-ldap \
+       --with-mpg123 \
+       --with%{!?with_nas:out}-nas \
+       --with-opengl \
+       --with-openssl \
+       --with-oss \
+       --with-png \
+       --with-pthread \
+       --with%{!?with_sane:out}-sane \
+       --with-xcomposite \
+       --with-xcursor \
+       --with-xinerama \
+       --with-xinput \
+       --with-xml \
+       --with-xrandr \
+       --with-xrender \
+       --with-xshape \
+       --with-xshm \
+       --with-xslt \
+       --with-xxf86vm \
        --with-x
 %{__make} depend
 %{__make}
-%{__make} -C programs
-#%{__make} -C programs/regapi
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
-
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%{__make} -C programs install \
-       DESTDIR=$RPM_BUILD_ROOT
-
-install tools/fnt2bdf                  $RPM_BUILD_ROOT%{_bindir}
-
-install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
-#mv -f $RPM_BUILD_ROOT{/usr/X11R6/share/aclocal,%{_aclocaldir}}/wine.m4
+install -p tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
+cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
 
 install -d \
        $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
@@ -281,7 +344,7 @@ touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
 
-cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
+cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
 [mci]
 cdaudio=mcicda.drv
 sequencer=mciseq.drv
@@ -309,28 +372,36 @@ fi
 
 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
 
-programs="notepad progman regedit regsvr32 uninstaller wineconsole winefile winemine winepath winhelp"
-
-BZZZ=`pwd`
-rm -f files.so;                touch files.so
-rm -f files.programs;  touch files.programs
+dir=$(pwd)
+> files.so
+> files.programs
 cd $RPM_BUILD_ROOT%{_libdir}/wine
 for f in *.so; do
        case $f in
-               d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
-                       ;;
-               *)
-                       echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
+       d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
+               ;;
+       *)
+               echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
        esac
 done
 cd -
+
+programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
 for p in $programs; do
        echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
        echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
+       echo "%{_mandir}/man1/$p.1*" >> files.programs
        grep -v "$p\.exe\.so$" files.so > files.so.
        mv -f files.so. files.so
 done
 
+install -d $RPM_BUILD_ROOT%{_winedir}/gecko
+cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
+
+install -d $RPM_BUILD_ROOT%{_pixmapsdir}
+cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
+cp -a %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -345,39 +416,63 @@ fi
 
 %files -f files.so
 %defattr(644,root,root,755)
-%doc README ChangeLog AUTHORS ANNOUNCE
+%doc README documentation/ChangeLog* AUTHORS ANNOUNCE
 %lang(de) %doc documentation/README.de
 %lang(es) %doc documentation/README.es
 %lang(fr) %doc documentation/README.fr
+%lang(hu) %doc documentation/README.hu
 %lang(it) %doc documentation/README.it
 %lang(ko) %doc documentation/README.ko
 %lang(nb) %doc documentation/README.no
 %lang(pt) %doc documentation/README.pt
 %lang(pt_BR) %doc documentation/README.pt_br
+%lang(ru) %doc documentation/README.ru
+%lang(sv) %doc documentation/README.sv
+%lang(tr) %doc documentation/README.tr
 %attr(755,root,root) %{_bindir}/msiexec
-%attr(755,root,root) %{_bindir}/wine
 %attr(755,root,root) %{_bindir}/wineboot
-%attr(755,root,root) %{_bindir}/winebrowser
-%attr(755,root,root) %{_bindir}/winecfg
 %attr(755,root,root) %{_bindir}/winedbg
-%attr(755,root,root) %{_bindir}/wine-kthread
-%attr(755,root,root) %{_bindir}/winelauncher
-%attr(755,root,root) %{_bindir}/wineprefixcreate
-%attr(755,root,root) %{_bindir}/wine-preloader
-%attr(755,root,root) %{_bindir}/wine-pthread
+%attr(755,root,root) %{_bindir}/winecfg
 %attr(755,root,root) %{_bindir}/wineserver
-%attr(755,root,root) %{_bindir}/wineshelllink
+%ifarch %{x8664}
+%attr(755,root,root) %{_bindir}/wine64
+%else
+%attr(755,root,root) %{_bindir}/wine
+%attr(755,root,root) %{_bindir}/wine-preloader
+%endif
 %attr(755,root,root) %{_libdir}/*.so*
 %dir %{_libdir}/wine
-%{_libdir}/wine/*.dll16
-%{_libdir}/wine/*.drv16
-%{_libdir}/wine/*.exe16
+%dir %{_libdir}/wine/fakedlls
+%{_libdir}/wine/fakedlls/*.acm
+%{_libdir}/wine/fakedlls/*.cpl
+%{_libdir}/wine/fakedlls/*.dll
+%{_libdir}/wine/fakedlls/*.drv
+%{_libdir}/wine/fakedlls/*.ds
+%{_libdir}/wine/fakedlls/*.exe
+%{_libdir}/wine/fakedlls/*.ocx
+%{_libdir}/wine/fakedlls/*.sys
+%{_libdir}/wine/fakedlls/*.tlb
+%ifarch %{ix86}
+%{_libdir}/wine/fakedlls/*.dll16
+%{_libdir}/wine/fakedlls/*.drv16
+%{_libdir}/wine/fakedlls/*.exe16
+%{_libdir}/wine/fakedlls/*.mod16
+%{_libdir}/wine/fakedlls/*.vxd
+%endif
 %{_mandir}/man1/wine.1*
+%{_mandir}/man1/msiexec.1*
+%{_mandir}/man1/wineboot.1*
+%{_mandir}/man1/winecfg.1*
+%lang(de) %{_mandir}/de/man1/wine.1*
+%lang(fr) %{_mandir}/fr/man1/wine.1*
 %{_mandir}/man1/winedbg.1*
-%{_mandir}/man1/wineprefixcreate.1*
 %{_mandir}/man1/wineserver.1*
+%lang(de) %{_mandir}/de/man1/wineserver.1*
+%lang(fr) %{_mandir}/fr/man1/wineserver.1*
 %{_winedir}
 %{_desktopdir}/wine.desktop
+%{_desktopdir}/wine-uninstaller.desktop
+%{_pixmapsdir}/%{name}.png
 
 %files programs -f files.programs
 %defattr(644,root,root,755)
@@ -393,22 +488,26 @@ fi
 %attr(755,root,root) %{_bindir}/winegcc
 %attr(755,root,root) %{_bindir}/winemaker
 %attr(755,root,root) %{_bindir}/winecpp
-#%attr(755,root,root) %{_bindir}/winewrap
 %attr(755,root,root) %{_bindir}/wmc
 %attr(755,root,root) %{_bindir}/wrc
 %{_libdir}/wine/lib*.def
 # no shared variants, so not separated
 %{_libdir}/wine/lib*.def.a
+%{_libdir}/wine/libadsiid.a
 %{_libdir}/wine/libdx*.a
 %{_libdir}/wine/libstrmiids.a
 %{_libdir}/wine/libuuid.a
 %{_libdir}/wine/libwinecrt0.a
 %{_includedir}/wine
 %{_mandir}/man1/widl.1*
+%{_mandir}/man1/winebuild.1*
+%{_mandir}/man1/winecpp.1*
 %{_mandir}/man1/winedump.1*
 %{_mandir}/man1/winegcc.1*
+%{_mandir}/man1/wineg++.1*
 %{_mandir}/man1/winemaker.1*
-%{_mandir}/man1/winebuild.1*
+%lang(de) %{_mandir}/de/man1/winemaker.1*
+%lang(fr) %{_mandir}/fr/man1/winemaker.1*
 %{_mandir}/man1/wmc.1*
 %{_mandir}/man1/wrc.1*
 %{_aclocaldir}/*.m4
@@ -417,7 +516,6 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
-%attr(755,root,root) %{_libdir}/wine/d3dx8.dll.so
 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
 
 %files dll-gl
This page took 0.098093 seconds and 4 git commands to generate.