]> git.pld-linux.org Git - packages/wine.git/blobdiff - wine.spec
- reenable debuginfo, builds/works for me.
[packages/wine.git] / wine.spec
index 4a9c97de9106668cdb74cb3187a5f4ea952941e5..f9673697ca57f30442e29a7cf11872ded7f9cfb7 100644 (file)
--- a/wine.spec
+++ b/wine.spec
 #   libfreetype (wineps.dll.so,gdi32.dll.so)
 #   libGL (x11drv.dll.so,ddraw.dll.so)
 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
+#   libpng (windowscodecs.dll: SONAME_LIBPNG in dlls/windowscodecs/pngformat.c)
 # thus requires rebuild after change of any of the above.
-#
+
+# library qualifier in rpm generated deps
+%ifarch %{x8664} ia64 ppc64 s390x sparc64
+%define        libqual ()(64bit)
+%else
+%define        libqual %{nil}
+%endif
+
 %define                gecko_ver       1.4
 Summary:       Program that lets you launch Win applications
 Summary(es.UTF-8):     Ejecuta programas Windows en Linux
@@ -58,6 +66,7 @@ BuildRequires:        flex
 BuildRequires: fontconfig-devel
 BuildRequires: fontforge
 BuildRequires: freetype-devel >= 2.0.5
+BuildRequires: fslint
 BuildRequires: gettext-devel
 BuildRequires: giflib-devel
 BuildRequires: gnutls-devel
@@ -73,6 +82,7 @@ BuildRequires:        libv4l-devel
 BuildRequires: libxslt-devel
 BuildRequires: ncurses-devel
 # db2* failed previously - probably openjade or opensp bug
+BuildRequires: libpng-devel >= 1.5
 BuildRequires: openjade >= 1:1.3.3-0.pre1
 %{?with_ldap:BuildRequires:    openldap-devel}
 BuildRequires: opensp >= 1:1.5.1
@@ -91,7 +101,8 @@ BuildRequires:       xorg-lib-libXrandr-devel
 BuildRequires: xorg-lib-libXrender-devel
 BuildRequires: xorg-lib-libXxf86dga-devel
 BuildRequires: xorg-lib-libXxf86vm-devel
-Requires:      libfreetype.so.6
+Requires:      libfreetype.so.6%{libqual}
+Requires:      libpng15.so.15%{libqual}
 Requires(post):        /sbin/ldconfig
 Suggests:      binfmt-detector
 Suggests:      ca-certificates
@@ -120,7 +131,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
 
-%undefine      debuginfocflags
+#undefine      debuginfocflags
 
 %description
 Wine is a program which allows running Microsoft Windows programs
@@ -232,7 +243,7 @@ TWAIN implementation DLL for Wine (through SANE).
 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
 
 %package dll-ldap
-Summary:       Win32 LDAP API DLL for Wine.
+Summary:       Win32 LDAP API DLL for Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
@@ -252,7 +263,7 @@ ALSA driver for WINE mm.dll (multimedia system) implementation.
 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
 
 %prep
-%setup -q -n %{name}-%{version}
+%setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -314,6 +325,8 @@ install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+findup -m $RPM_BUILD_ROOT%{_winedir}/fakedlls
+
 install -p tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
 
@@ -339,21 +352,6 @@ vcr=mciviscd.drv
 MPEGVideo=mciqtz.drv
 EOF
 
-%if %{?debug:0}%{!?debug:1}
-echo "Strip executable binaries and shared object files."
-filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
-elfexelist=`echo $filelist | xargs -r file | \
-       awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
-elfsharedlist=`echo $filelist | xargs -r file | \
-       awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
-if [ -n "$elfexelist" ]; then \
-       strip -R .note -R .comment $elfexelist
-fi
-if [ -n "$elfsharedlist" ]; then
-       strip --strip-unneeded -R .note -R .comment $elfsharedlist
-fi
-%endif
-
 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
 
 dir=$(pwd)
@@ -381,20 +379,20 @@ done
 
 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
 %ifnarch %{x8664}
-cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
 %else
-cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
 %endif
 
 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
-cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
-cp -a %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
+cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
+cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
- /sbin/ldconfig
+/sbin/ldconfig
 %update_desktop_database
 
 %postun -p /sbin/ldconfig
@@ -463,7 +461,7 @@ fi
 %{_mandir}/man1/wine.1*
 %lang(de) %{_mandir}/de/man1/wine*.1*
 %lang(fr) %{_mandir}/fr/man1/wine*.1*
-%lang(pl) %{_mandir}/pl/man1/wine*.1*
+#%lang(pl) %{_mandir}/pl/man1/wine*.1*
 %{_mandir}/man1/msiexec.1*
 %{_mandir}/man1/wineboot.1*
 %{_mandir}/man1/winecfg.1*
This page took 0.179736 seconds and 4 git commands to generate.