]> git.pld-linux.org Git - packages/wine.git/blobdiff - wine.spec
- up to 7.16
[packages/wine.git] / wine.spec
index 79ef693c0ff4b03b7edc94eeca37ab032d6ea370..b3d45e19a61060107d03eedccdc944a172805228 100644 (file)
--- a/wine.spec
+++ b/wine.spec
 #
+# todo:
+# libvkd3d https://wiki.winehq.org/Vkd3d
+#
 # Conditional build:
-%bcond_without alsa            # don't build ALSA mm driver
-%bcond_with    esd             # build ESD mm driver
-%bcond_without jack            # don't build JACK mm driver
-%bcond_without nas             # don't build NAS mm driver
+%bcond_with    capi            # don't build CAPI 2.0 (ISDN) support
+%bcond_without gstreamer       # don't build GStreamer filters support
 %bcond_without sane            # don't build TWAIN DLL with scanning support (through SANE)
 %bcond_without ldap            # don't build LDAP DLL
 %bcond_without cups            # without CUPS printing support in winspool,wineps DLLs
-#
-# TODO:
-# - support for CAPI (ISDN support; --with-capi)
+%bcond_without netapi          # don't use the Samba NetAPI library
 #
 # NOTE: wine detects the following SONAMES for dlopen at build time:
-#   libcrypto,libssl (wininet.dll)
-#   libcups (winspool.dll.so,wineps.dll.so)
-#   libcurses/libncurses (wineconsole program)
+#   libGL (winex11.drv.so)
+#   libOSMesa (gdi32.dll.so)
+#   libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
+#   libcapi20 (capi2032.dll.so)
+#   libcups (winspool.drv.so)
+#   libdbus (mountmgr.sys.so)
 #   libfontconfig (gdi32.dll.so)
-#   libfreetype (wineps.dll.so,gdi32.dll.so)
-#   libGL (x11drv.dll.so,ddraw.dll.so)
-#   libjack (winejack.drv.so - explicit dependency in subpackage)
-#   libX11, libXext, libXi, libXrender (x11drv.dll.so)
+#   libfreetype (gdi32.dll.so)
+#   libgnutls (secur32.dll.so)
+#   libncurses (kernel32.dll.so)
+#   libodbc (odbc32.dll.so)
+#   libsane (sane.ds.so)
+#   libtiff (windowscodecs.dll.so)
 # thus requires rebuild after change of any of the above.
-#
-# JACK requires ALSA
-%if %{without alsa}
-%undefine      with_jack
+
+# library qualifier in rpm generated deps
+%ifarch %{x8664} ia64 ppc64 s390x sparc64
+%define        libqual ()(64bit)
+%else
+%define        libqual %{nil}
+%endif
+
+%ifarch %{x8664}
+%define        winelib x86_64
+%else
+%define        winelib i386
 %endif
 
+%define                gecko_ver       2.47.2
 Summary:       Program that lets you launch Win applications
 Summary(es.UTF-8):     Ejecuta programas Windows en Linux
 Summary(pl.UTF-8):     Program pozwalający uruchamiać aplikacje Windows
 Summary(pt_BR.UTF-8):  Executa programas Windows no Linux
 Name:          wine
-Version:       1.2.3
-Release:       3
+Version:       7.16
+Release:       1
 Epoch:         1
 License:       LGPL
 Group:         Applications/Emulators
-Source0:       http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
-# Source0-md5: a18ca677d1e01d1596d6692a8f3997e5
-Source1:       http://downloads.sourceforge.net/wine/%{name}_gecko-1.0.0-x86.cab
-# Source1-md5: 9c5c335fc077c0558561afaf25a09e51
-Source2:       %{name}-uninstaller.desktop
-Patch0:                %{name}-fontcache.patch
+Source0:       https://dl.winehq.org/wine/source/7.x/%{name}-%{version}.tar.xz
+# Source0-md5: 684a3517b1ab850106d2b0ea87ea877d
+Source1:       https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86.msi
+# Source1-md5: e0a26e37397961b2c7f624575590ef66
+Source2:       https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86_64.msi
+# Source2-md5: ff7168b08fa901516fbaa8a66aa3cee6
+Source3:       %{name}-uninstaller.desktop
+Patch0:                %{name}-gphoto2_bool.patch
 Patch1:                %{name}-makedep.patch
 Patch2:                %{name}-ncurses.patch
 Patch4:                %{name}-disable-valgrind.patch
 Patch5:                %{name}-ca_certificates.patch
-Patch6:                %{name}-manpaths.patch
-Patch7:                desktop.patch
-#PatchX:       %{name}-dga.patch
+Patch6:                desktop.patch
+Patch7:                %{name}-wine64_man.patch
 URL:           http://www.winehq.org/
+BuildRequires: Mesa-libOSMesa-devel
 BuildRequires: OpenAL-devel >= 1.1
+BuildRequires: OpenCL-devel
 BuildRequires: OpenGL-GLU-devel
-%{?with_alsa:BuildRequires:    alsa-lib-devel}
+BuildRequires: SDL2-devel
+BuildRequires: alsa-lib-devel
 %{?with_arts:BuildRequires:    artsc-devel}
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.62
 BuildRequires: automake
 BuildRequires: bison
+%{?with_capi:BuildRequires:    capi4k-utils-devel}
+BuildRequires: clang
 %{?with_cups:BuildRequires:    cups-devel}
-BuildRequires: docbook-dtd31-sgml
-BuildRequires: docbook-utils
-%{?with_esd:BuildRequires:     esound-devel}
-BuildRequires: flex
+BuildRequires: dbus-devel
+BuildRequires: flex >= 2.5.33
 BuildRequires: fontconfig-devel
-BuildRequires: fontforge
 BuildRequires: freetype-devel >= 2.0.5
-BuildRequires: giflib-devel
+BuildRequires: gettext-devel
+%ifarch %{x8664}
+BuildRequires: gcc >= 6:4.4
+%endif
+BuildRequires: gettext-tools
 BuildRequires: gnutls-devel
-BuildRequires: icoutils
-%{?with_jack:BuildRequires:    jack-audio-connection-kit-devel}
-BuildRequires: lcms-devel
+%{?with_gstreamer:BuildRequires:       gstreamer-devel >= 1.0}
+%{?with_gstreamer:BuildRequires:       gstreamer-plugins-base-devel >= 1.0}
+# for icotool used in build
+BuildRequires: icoutils >= 0.29.0
+BuildRequires: lcms2-devel >= 2
+BuildRequires: libcap-devel
+BuildRequires: libglvnd-libEGL-devel
 BuildRequires: libgphoto2-devel
-BuildRequires: libgsm-devel
-BuildRequires: libjpeg-devel
-BuildRequires: libmpg123-devel >= 1.5.0
-BuildRequires: libtool
+BuildRequires: libpcap-devel
 BuildRequires: libv4l-devel
-BuildRequires: libxslt-devel
-%{?with_nas:BuildRequires:     nas-devel}
-BuildRequires: ncurses-devel
-# db2* failed previously - probably openjade or opensp bug
-BuildRequires: openjade >= 1:1.3.3-0.pre1
+BuildRequires: lld
 %{?with_ldap:BuildRequires:    openldap-devel}
-BuildRequires: opensp >= 1:1.5.1
-BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: pkgconfig
+BuildRequires: pulseaudio-devel
+BuildRequires: samba-devel
 %{?with_sane:BuildRequires:    sane-backends-devel}
-BuildRequires: unixODBC-devel >= 2.2.12-2
-#BuildRequires:        valgrind
+BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXcomposite-devel
 BuildRequires: xorg-lib-libXcursor-devel
+BuildRequires: xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXi-devel
 BuildRequires: xorg-lib-libXinerama-devel
-BuildRequires: xorg-lib-libXmu-devel
 BuildRequires: xorg-lib-libXrandr-devel
 BuildRequires: xorg-lib-libXrender-devel
-BuildRequires: xorg-lib-libXxf86dga-devel
 BuildRequires: xorg-lib-libXxf86vm-devel
-%ifarch %{x8664}
-Requires:      libfreetype.so.6()(64bit)
-%else
-Requires:      libfreetype.so.6
-%endif
+BuildConflicts:        crossmingw32-gcc
+BuildConflicts:        crossmingw64-gcc
+Requires:      OpenGL
+Requires:      libfreetype.so.6%{libqual}
+Requires:      libpng16.so.16%{libqual}
 Requires(post):        /sbin/ldconfig
 Suggests:      binfmt-detector
 Suggests:      ca-certificates
+Suggests:      cabextract
 Conflicts:     ca-certificates < 20080809-4
 # for printing needs lpr
 Suggests:      cups-clients
@@ -115,21 +131,23 @@ Suggests: xorg-app-xmessage
 Suggests:      samba-common >= 1:3.0.25
 # link to wine/ntdll.dll.so, without any SONAME
 Provides:      libntdll.dll.so
-Obsoletes:     wine-doc-pdf
-Obsoletes:     wine-drv-arts
-ExclusiveArch: %{ix86} %{x8664}
+Obsoletes:     wine-dll-d3d < 1:7.7-2
+Obsoletes:     wine-dll-gl < 1:7.7-2
+Obsoletes:     wine-doc-pdf < 1:7.7-2
+Obsoletes:     wine-drv-alsa < 1:7.7-2
+Obsoletes:     wine-drv-arts < 1:7.7-2
+Obsoletes:     wine-drv-jack < 1:7.7-2
+Obsoletes:     wine-drv-nas < 1:7.7-2
+Obsoletes:     wine-programs < 1:7.7-2
+ExclusiveArch: %{ix86} %{x8664} arm
 ExcludeArch:   i386
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreqdep           libGL.so.1 libGLU.so.1
 %define                no_install_post_strip   1
+%define                _noautoprov     elf\\\\(buildid\\\\)
 
 %define                _winedir                %{_datadir}/%{name}
 
-%define                getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
-
-%undefine      debuginfocflags
-
 %description
 Wine is a program which allows running Microsoft Windows programs
 (including DOS, Windows 3.x and Win32 executables) on Unix. It
@@ -176,43 +194,17 @@ Wine - pliki nagłówkowe.
 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
 WINE.
 
-%package programs
-Summary:       Wine - programs
-Summary(pl.UTF-8):     Wine - programy
-Group:         Applications
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-
-%description programs
-Wine - programs.
-
-%description programs -l pl.UTF-8
-Wine - programy.
-
-%package dll-d3d
-Summary:       Direct3D implementation DLLs for Wine
-Summary(pl.UTF-8):     Biblioteki DLL z implementacją Direct3D dla Wine
+%package dll-capi
+Summary:       CAPI 2.0 (ISDN) implementation DLLs for Wine
+Summary(pl.UTF-8):     Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      OpenGL
-
-%description dll-d3d
-Direct3D implementation DLLs for Wine (through OpenGL).
-
-%description dll-d3d -l pl.UTF-8
-Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
-
-%package dll-gl
-Summary:       OpenGL implementation DLLs for Wine
-Summary(pl.UTF-8):     Biblioteki DLL z implementacją OpenGL dla Wine
-Group:         Applications/Emulators
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      OpenGL
 
-%description dll-gl
-OpenGL implementation DLLs for Wine.
+%description dll-capi
+CAPI 2.0 (ISDN) implementation DLLs for Wine.
 
-%description dll-gl -l pl.UTF-8
-Biblioteki DLL z implementacją OpenGL dla Wine.
+%description dll-capi -l pl.UTF-8
+Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
 
 %package dll-twain
 Summary:       TWAIN implementation DLL for Wine
@@ -227,70 +219,34 @@ TWAIN implementation DLL for Wine (through SANE).
 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
 
 %package dll-ldap
-Summary:       Win32 LDAP API DLL for Wine.
+Summary:       Win32 LDAP API DLL for Wine
+Summary(pl.UTF-8):     Biblioteka DLL z implementacją API Win32 LDAP dla Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description dll-ldap
-Lightweight Directory Access Protocol Library.
+Lightweight Directory Access Protocol Library for Wine.
 
-%package drv-alsa
-Summary:       ALSA driver for WINE mm.dll implementation
-Summary(pl.UTF-8):     Sterownik ALSA dla implementacji mm.dll w Wine
-Group:         Applications/Emulators
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-
-%description drv-alsa
-ALSA driver for WINE mm.dll (multimedia system) implementation.
-
-%description drv-alsa -l pl.UTF-8
-Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
-
-%package drv-jack
-Summary:       JACK driver for WINE mm.dll implementation
-Summary(pl.UTF-8):     Sterownik JACK-a dla implementacji mm.dll w Wine
-Group:         Applications/Emulators
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      jack-audio-connection-kit
-# dlopened by SONAME detected at build time
-%ifarch %{x8664}
-%{?with_jack:Requires:  %{getsoname /usr/%{_lib}/libjack.so}()(64bit)}
-%else
-%{?with_jack:Requires: %{getsoname /usr/%{_lib}/libjack.so}}
-%endif
-
-%description drv-jack
-JACK driver for WINE mm.dll (multimedia system) implementation.
-
-%description drv-jack -l pl.UTF-8
-Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
-Wine.
-
-%package drv-nas
-Summary:       NAS driver for WINE mm.dll implementation
-Summary(pl.UTF-8):     Sterownik NAS dla implementacji mm.dll w Wine
-Group:         Applications/Emulators
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-
-%description drv-nas
-NAS driver for WINE mm.dll (multimedia system) implementation.
-
-%description drv-nas -l pl.UTF-8
-Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
+%description dll-ldap -l pl.UTF-8
+Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
 
 %prep
 %setup -q
-%patch0 -p1
+#%patch0 -p1
 %patch1 -p1
-%patch2 -p1
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%ifarch %{x8664}
 %patch7 -p1
+%endif
 
 %build
-icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
-mv -f oic_winlogo_*.png %{name}.png
+
+#workaround for icon extraction error.
+icotool -x -o . dlls/user32/resources/oic_winlogo.ico
+mv -f oic_winlogo_*32x32x32.png %{name}.png
+rm -f oic_winlogo_*.png
 
 %{__autoconf}
 %{__autoheader}
@@ -298,43 +254,38 @@ mv -f oic_winlogo_*.png %{name}.png
 %ifarch %{x8664}
        --enable-win64 \
 %endif
-       --with%{!?with_alsa:out}-alsa \
-       --with-audioio \
-       --without-capi \
-       --with-cms \
+       --with-alsa \
+       --with-capi%{!?with_capi:=no} \
        --with-coreaudio \
-       --with%{!?with_cups:out}-cups \
-       --with-curses \
-       --with%{!?with_esd:out}-esd \
+       --with-cups%{!?with_cups:=no} \
+       --with-dbus \
        --with-fontconfig \
        --with-freetype \
-       --with-glu \
-       --with-gnutls \
        --with-gphoto \
-       --with-gsm \
-       --with%{!?with_jack:out}-jack \
-       --with-jpeg \
-       --with%{!?with_ldap:out}-ldap \
-       --with-mpg123 \
-       --with%{!?with_nas:out}-nas \
+       --with-gnutls \
+       %{__with_without gstreamer} \
+       --with-ldap%{!?with_ldap:=no} \
+       --with%{!?with_netapi:out}-netapi \
+       --with-openal \
+       --with-opencl \
        --with-opengl \
-       --with-openssl \
-       --with-oss \
-       --with-png \
+       --with-osmesa \
+       --with-pcap \
        --with-pthread \
+       --with-pulse \
        --with%{!?with_sane:out}-sane \
        --with-xcomposite \
        --with-xcursor \
        --with-xinerama \
        --with-xinput \
-       --with-xml \
+       --with-xinput2 \
        --with-xrandr \
        --with-xrender \
        --with-xshape \
        --with-xshm \
-       --with-xslt \
        --with-xxf86vm \
        --with-x
+
 %{__make} depend
 %{__make}
 
@@ -344,7 +295,7 @@ install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install -p tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
+install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
 
 install -d \
@@ -369,58 +320,42 @@ vcr=mciviscd.drv
 MPEGVideo=mciqtz.drv
 EOF
 
-%if %{?debug:0}%{!?debug:1}
-echo "Strip executable binaries and shared object files."
-filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
-elfexelist=`echo $filelist | xargs -r file | \
-       awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
-elfsharedlist=`echo $filelist | xargs -r file | \
-       awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
-if [ -n "$elfexelist" ]; then \
-       strip -R .note -R .comment $elfexelist
-fi
-if [ -n "$elfsharedlist" ]; then
-       strip --strip-unneeded -R .note -R .comment $elfsharedlist
-fi
-%endif
-
 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
 
-dir=$(pwd)
-> files.so
-> files.programs
-cd $RPM_BUILD_ROOT%{_libdir}/wine
-for f in *.so; do
-       case $f in
-       d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so|wldap32.dll.so)
-               ;;
-       *)
-               echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
-       esac
+for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
+       mv "$dir" "${dir%.UTF-8}"
+done
+
+%ifarch %{x8664}
+cp -p loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
+for lang in de fr pl ; do
+install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
+cp -p loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
 done
-cd -
-
-programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
-for p in $programs; do
-       echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
-       echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
-       echo "%{_mandir}/man1/$p.1*" >> files.programs
-       grep -v "$p\.exe\.so$" files.so > files.so.
-       mv -f files.so. files.so
+%else
+cp -p loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
+for lang in de fr pl ; do
+install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
+cp -p loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
 done
+%endif
 
 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
-cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
+%ifnarch %{x8664}
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
+%else
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
+%endif
 
 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
-cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
-cp -a %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
+cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
+cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
- /sbin/ldconfig
+/sbin/ldconfig
 %update_desktop_database
 
 %postun -p /sbin/ldconfig
@@ -431,9 +366,9 @@ if [ -x /sbin/chkconfig ]; then
        /sbin/chkconfig --del wine
 fi
 
-%files -f files.so
+%files
 %defattr(644,root,root,755)
-%doc README documentation/ChangeLog* AUTHORS ANNOUNCE
+%doc README AUTHORS ANNOUNCE
 %lang(de) %doc documentation/README.de
 %lang(es) %doc documentation/README.es
 %lang(fr) %doc documentation/README.fr
@@ -446,43 +381,95 @@ fi
 %lang(ru) %doc documentation/README.ru
 %lang(sv) %doc documentation/README.sv
 %lang(tr) %doc documentation/README.tr
+%attr(755,root,root) %{_bindir}/msidb
 %attr(755,root,root) %{_bindir}/msiexec
+%attr(755,root,root) %{_bindir}/notepad
+%attr(755,root,root) %{_bindir}/regedit
+%attr(755,root,root) %{_bindir}/regsvr32
+%ifnarch %{x8664}
+%attr(755,root,root) %{_bindir}/wine
+%else
+%attr(755,root,root) %{_bindir}/wine64
+%endif
 %attr(755,root,root) %{_bindir}/wineboot
-%attr(755,root,root) %{_bindir}/winedbg
 %attr(755,root,root) %{_bindir}/winecfg
-%attr(755,root,root) %{_bindir}/wineserver
-%ifarch %{x8664}
-%attr(755,root,root) %{_bindir}/wine64
-%else
-%attr(755,root,root) %{_bindir}/wine
+%attr(755,root,root) %{_bindir}/wineconsole
+%attr(755,root,root) %{_bindir}/winedbg
+%attr(755,root,root) %{_bindir}/winefile
+%attr(755,root,root) %{_bindir}/winemine
+%attr(755,root,root) %{_bindir}/winepath
+%ifnarch %{x8664}
 %attr(755,root,root) %{_bindir}/wine-preloader
+%else
+%attr(755,root,root) %{_bindir}/wine64-preloader
 %endif
-%attr(755,root,root) %{_libdir}/*.so*
+%attr(755,root,root) %{_bindir}/wineserver
 %dir %{_libdir}/wine
-%dir %{_libdir}/wine/fakedlls
-%{_libdir}/wine/fakedlls/*.acm
-%{_libdir}/wine/fakedlls/*.cpl
-%{_libdir}/wine/fakedlls/*.dll
-%{_libdir}/wine/fakedlls/*.drv
-%{_libdir}/wine/fakedlls/*.ds
-%{_libdir}/wine/fakedlls/*.exe
-%{_libdir}/wine/fakedlls/*.ocx
-%{_libdir}/wine/fakedlls/*.sys
-%{_libdir}/wine/fakedlls/*.tlb
+%dir %{_libdir}/wine/%{winelib}-unix
+%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/*.so*
+%dir %{_libdir}/wine/%{winelib}-windows
+%{_libdir}/wine/%{winelib}-windows/*.acm
+%{_libdir}/wine/%{winelib}-windows/*.ax
+%{_libdir}/wine/%{winelib}-windows/*.com
+%{_libdir}/wine/%{winelib}-windows/*.cpl
+%{_libdir}/wine/%{winelib}-windows/*.dll
 %ifarch %{ix86}
-%{_libdir}/wine/fakedlls/*.dll16
-%{_libdir}/wine/fakedlls/*.drv16
-%{_libdir}/wine/fakedlls/*.exe16
-%{_libdir}/wine/fakedlls/*.mod16
-%{_libdir}/wine/fakedlls/*.vxd
+%{_libdir}/wine/%{winelib}-windows/*.dll16
+%endif
+%{_libdir}/wine/%{winelib}-windows/*.drv
+%ifarch %{ix86}
+%{_libdir}/wine/%{winelib}-windows/*.drv16
+%endif
+%{_libdir}/wine/%{winelib}-windows/*.ds
+%{_libdir}/wine/%{winelib}-windows/*.exe
+%ifarch %{ix86}
+%{_libdir}/wine/%{winelib}-windows/*.exe16
+%{_libdir}/wine/%{winelib}-windows/*.mod16
+%endif
+%{_libdir}/wine/%{winelib}-windows/*.msstyles
+%{_libdir}/wine/%{winelib}-windows/*.ocx
+%{_libdir}/wine/%{winelib}-windows/*.sys
+%{_libdir}/wine/%{winelib}-windows/*.tlb
+%ifarch %{ix86}
+%{_libdir}/wine/%{winelib}-windows/*.vxd
+%endif
+%if %{with capi}
+%exclude %{_libdir}/wine/%{winelib}-windows/capi2032.dll
+%exclude %{_libdir}/wine/%{winelib}-unix/capi2032.so
+%endif
+%if %{with sane}
+%exclude %{_libdir}/wine/%{winelib}-unix/sane.so
+%exclude %{_libdir}/wine/%{winelib}-windows/twain*.dll
+%ifarch %{ix86}
+%exclude %{_libdir}/wine/%{winelib}-windows/twain*.dll16
+%endif
+%endif
+%if %{with ldap}
+%exclude %{_libdir}/wine/%{winelib}-unix/wldap*.so
+%exclude %{_libdir}/wine/%{winelib}-windows/wldap*.dll
 %endif
-%{_mandir}/man1/wine.1*
 %{_mandir}/man1/msiexec.1*
-%{_mandir}/man1/wineboot.1*
-%{_mandir}/man1/winecfg.1*
+%{_mandir}/man1/notepad.1*
+%{_mandir}/man1/regedit.1*
+%{_mandir}/man1/regsvr32.1*
+%ifnarch %{x8664}
+%{_mandir}/man1/wine.1*
 %lang(de) %{_mandir}/de/man1/wine.1*
 %lang(fr) %{_mandir}/fr/man1/wine.1*
+%lang(pl) %{_mandir}/pl/man1/wine.1*
+%else
+%{_mandir}/man1/wine64.1*
+%lang(de) %{_mandir}/de/man1/wine64.1*
+%lang(fr) %{_mandir}/fr/man1/wine64.1*
+%lang(pl) %{_mandir}/pl/man1/wine64.1*
+%endif
+%{_mandir}/man1/wineboot.1*
+%{_mandir}/man1/winecfg.1*
+%{_mandir}/man1/wineconsole.1*
 %{_mandir}/man1/winedbg.1*
+%{_mandir}/man1/winefile.1*
+%{_mandir}/man1/winemine.1*
+%{_mandir}/man1/winepath.1*
 %{_mandir}/man1/wineserver.1*
 %lang(de) %{_mandir}/de/man1/wineserver.1*
 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
@@ -491,12 +478,9 @@ fi
 %{_desktopdir}/wine-uninstaller.desktop
 %{_pixmapsdir}/%{name}.png
 
-%files programs -f files.programs
-%defattr(644,root,root,755)
-
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/fnt2bdf
+%attr(755,root,root) %{_bindir}/sfnt2fon
 %attr(755,root,root) %{_bindir}/function_grep.pl
 %attr(755,root,root) %{_bindir}/widl
 %attr(755,root,root) %{_bindir}/winebuild
@@ -507,14 +491,9 @@ fi
 %attr(755,root,root) %{_bindir}/winecpp
 %attr(755,root,root) %{_bindir}/wmc
 %attr(755,root,root) %{_bindir}/wrc
-%{_libdir}/wine/lib*.def
 # no shared variants, so not separated
-%{_libdir}/wine/lib*.def.a
-%{_libdir}/wine/libadsiid.a
-%{_libdir}/wine/libdx*.a
-%{_libdir}/wine/libstrmiids.a
-%{_libdir}/wine/libuuid.a
-%{_libdir}/wine/libwinecrt0.a
+%{_libdir}/wine/%{winelib}-unix/lib*.a
+%{_libdir}/wine/%{winelib}-windows/lib*.a
 %{_includedir}/wine
 %{_mandir}/man1/widl.1*
 %{_mandir}/man1/winebuild.1*
@@ -529,49 +508,30 @@ fi
 %{_mandir}/man1/wrc.1*
 %{_aclocaldir}/*.m4
 
-%files dll-d3d
+%if %{with capi}
+%files dll-capi
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
-%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
-%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
-
-%files dll-gl
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
-%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
+%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/capi2032.dll
+%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/capi2032.so
+%endif
 
 %if %{with sane}
 %files dll-twain
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/wine/sane.ds.so
-%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
+%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/sane.so
+%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/twain*.dll
+%ifarch %{ix86}
+%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/twain*.dll16
+%endif
 %endif
 
 %if %{with ldap}
 %files dll-ldap
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
-%endif
-
-%if %{with alsa}
-%files drv-alsa
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
-%endif
-
-%if %{with jack}
-%files drv-jack
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/wine/winejack.drv.so
-%endif
-
-%if %{with nas}
-%files drv-nas
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/wine/winenas.drv.so
+%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/wldap*.so
+%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/wldap*.dll
 %endif
 
 # additional dependencies in *.so not separated (yet?) from main package
-#   ddraw.dll.so,x11drv.dll.so depend on X11 libs
-#   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
-#   ttydrv.dll.so depends on ncurses
+#   ddraw.dll.so,winex11.drv.so depend on X11 libs
+#   ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.111164 seconds and 4 git commands to generate.