]> git.pld-linux.org Git - packages/wine.git/blobdiff - wine.spec
- up to 7.16
[packages/wine.git] / wine.spec
index 2d28a0a83a043fd4aa4e179aefb287af2ee9e585..b3d45e19a61060107d03eedccdc944a172805228 100644 (file)
--- a/wine.spec
+++ b/wine.spec
@@ -1,12 +1,14 @@
 #
+# todo:
+# libvkd3d https://wiki.winehq.org/Vkd3d
+#
 # Conditional build:
-%bcond_without alsa            # ALSA mm driver
-%bcond_without capi            # CAPI 2.0 (ISDN) support
-%bcond_without gstreamer       # GStreamer filters support
-%bcond_without sane            # TWAIN DLL with scanning support (through SANE)
-%bcond_with    hal             # HAL dynamic device support [deprecated]
-%bcond_without ldap            # LDAP DLL
-%bcond_without cups            # CUPS printing support in winspool,wineps DLLs
+%bcond_with    capi            # don't build CAPI 2.0 (ISDN) support
+%bcond_without gstreamer       # don't build GStreamer filters support
+%bcond_without sane            # don't build TWAIN DLL with scanning support (through SANE)
+%bcond_without ldap            # don't build LDAP DLL
+%bcond_without cups            # without CUPS printing support in winspool,wineps DLLs
+%bcond_without netapi          # don't use the Samba NetAPI library
 #
 # NOTE: wine detects the following SONAMES for dlopen at build time:
 #   libGL (winex11.drv.so)
 #   libfontconfig (gdi32.dll.so)
 #   libfreetype (gdi32.dll.so)
 #   libgnutls (secur32.dll.so)
-#   libhal (mountmgr.sys.so)
-#   libjpeg (gphoto2.ds.so windowscodecs.dll.so)
 #   libncurses (kernel32.dll.so)
 #   libodbc (odbc32.dll.so)
-#   libpng (windowscodecs.dll.so)
 #   libsane (sane.ds.so)
 #   libtiff (windowscodecs.dll.so)
-#   libv4l1 (qcap.dll.so)
-#   libxslt (msxml3.dll.so)
 # thus requires rebuild after change of any of the above.
 
 # library qualifier in rpm generated deps
 %define        libqual %{nil}
 %endif
 
-%define                gecko_ver       2.21
+%ifarch %{x8664}
+%define        winelib x86_64
+%else
+%define        winelib i386
+%endif
+
+%define                gecko_ver       2.47.2
 Summary:       Program that lets you launch Win applications
 Summary(es.UTF-8):     Ejecuta programas Windows en Linux
 Summary(pl.UTF-8):     Program pozwalający uruchamiać aplikacje Windows
 Summary(pt_BR.UTF-8):  Executa programas Windows no Linux
 Name:          wine
-# 1.6.x – stable
-# 1.7.x – development (DEVEL branch)
-Version:       1.6.2
-Release:       2
+Version:       7.16
+Release:       1
 Epoch:         1
 License:       LGPL
 Group:         Applications/Emulators
-Source0:       http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
-# Source0-md5: 0f6c56f86befe38e219090915f81f48a
-Source1:       http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
-# Source1-md5: 432eb3a2d05c3f07df67864f53c87c60
-Source2:       http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
-# Source2-md5: 580bbabde1ec99ba9caa439c2dbca3f6
+Source0:       https://dl.winehq.org/wine/source/7.x/%{name}-%{version}.tar.xz
+# Source0-md5: 684a3517b1ab850106d2b0ea87ea877d
+Source1:       https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86.msi
+# Source1-md5: e0a26e37397961b2c7f624575590ef66
+Source2:       https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86_64.msi
+# Source2-md5: ff7168b08fa901516fbaa8a66aa3cee6
 Source3:       %{name}-uninstaller.desktop
 Patch0:                %{name}-gphoto2_bool.patch
 Patch1:                %{name}-makedep.patch
 Patch2:                %{name}-ncurses.patch
 Patch4:                %{name}-disable-valgrind.patch
 Patch5:                %{name}-ca_certificates.patch
-Patch6:                %{name}-manpaths.patch
-Patch7:                desktop.patch
-Patch8:                %{name}-wine64_man.patch
+Patch6:                desktop.patch
+Patch7:                %{name}-wine64_man.patch
 URL:           http://www.winehq.org/
 BuildRequires: Mesa-libOSMesa-devel
 BuildRequires: OpenAL-devel >= 1.1
 BuildRequires: OpenCL-devel
 BuildRequires: OpenGL-GLU-devel
-BuildRequires: OpenGL-GLX-devel
-%{?with_alsa:BuildRequires:    alsa-lib-devel}
+BuildRequires: SDL2-devel
+BuildRequires: alsa-lib-devel
 %{?with_arts:BuildRequires:    artsc-devel}
 BuildRequires: autoconf >= 2.62
 BuildRequires: automake
 BuildRequires: bison
 %{?with_capi:BuildRequires:    capi4k-utils-devel}
+BuildRequires: clang
 %{?with_cups:BuildRequires:    cups-devel}
 BuildRequires: dbus-devel
-BuildRequires: docbook-dtd31-sgml
-BuildRequires: docbook-utils
 BuildRequires: flex >= 2.5.33
 BuildRequires: fontconfig-devel
-BuildRequires: fontforge
 BuildRequires: freetype-devel >= 2.0.5
-# for findup used after make install
-BuildRequires: fslint
+BuildRequires: gettext-devel
 %ifarch %{x8664}
 BuildRequires: gcc >= 6:4.4
 %endif
 BuildRequires: gettext-tools
-BuildRequires: giflib-devel
 BuildRequires: gnutls-devel
-%{?with_gstreamer:BuildRequires:       gstreamer0.10-devel >= 0.10}
-%{?with_gstreamer:BuildRequires:       gstreamer0.10-plugins-base-devel >= 0.10}
-%{?with_hal:BuildRequires:     hal-devel}
+%{?with_gstreamer:BuildRequires:       gstreamer-devel >= 1.0}
+%{?with_gstreamer:BuildRequires:       gstreamer-plugins-base-devel >= 1.0}
 # for icotool used in build
 BuildRequires: icoutils >= 0.29.0
 BuildRequires: lcms2-devel >= 2
+BuildRequires: libcap-devel
+BuildRequires: libglvnd-libEGL-devel
 BuildRequires: libgphoto2-devel
-BuildRequires: libgsm-devel
-BuildRequires: libjpeg-devel
-BuildRequires: libmpg123-devel >= 1.5.0
-BuildRequires: libpng-devel >= 1.5
-BuildRequires: libtiff-devel
-BuildRequires: libtool
+BuildRequires: libpcap-devel
 BuildRequires: libv4l-devel
-BuildRequires: libxml2-devel >= 2.0
-BuildRequires: libxslt-devel
-BuildRequires: ncurses-devel
-# db2* failed previously - probably openjade or opensp bug
-BuildRequires: openjade >= 1:1.3.3-0.pre1
+BuildRequires: lld
 %{?with_ldap:BuildRequires:    openldap-devel}
-BuildRequires: opensp >= 1:1.5.1
 BuildRequires: pkgconfig
-BuildRequires: prelink
+BuildRequires: pulseaudio-devel
+BuildRequires: samba-devel
 %{?with_sane:BuildRequires:    sane-backends-devel}
-BuildRequires: unixODBC-devel >= 2.2.12-2
-#BuildRequires:        valgrind
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXcomposite-devel
 BuildRequires: xorg-lib-libXcursor-devel
@@ -127,7 +113,9 @@ BuildRequires:      xorg-lib-libXinerama-devel
 BuildRequires: xorg-lib-libXrandr-devel
 BuildRequires: xorg-lib-libXrender-devel
 BuildRequires: xorg-lib-libXxf86vm-devel
-BuildRequires: zlib-devel
+BuildConflicts:        crossmingw32-gcc
+BuildConflicts:        crossmingw64-gcc
+Requires:      OpenGL
 Requires:      libfreetype.so.6%{libqual}
 Requires:      libpng16.so.16%{libqual}
 Requires(post):        /sbin/ldconfig
@@ -143,15 +131,20 @@ Suggests: xorg-app-xmessage
 Suggests:      samba-common >= 1:3.0.25
 # link to wine/ntdll.dll.so, without any SONAME
 Provides:      libntdll.dll.so
-Obsoletes:     wine-doc-pdf
-Obsoletes:     wine-drv-arts
-Obsoletes:     wine-drv-jack
-Obsoletes:     wine-drv-nas
+Obsoletes:     wine-dll-d3d < 1:7.7-2
+Obsoletes:     wine-dll-gl < 1:7.7-2
+Obsoletes:     wine-doc-pdf < 1:7.7-2
+Obsoletes:     wine-drv-alsa < 1:7.7-2
+Obsoletes:     wine-drv-arts < 1:7.7-2
+Obsoletes:     wine-drv-jack < 1:7.7-2
+Obsoletes:     wine-drv-nas < 1:7.7-2
+Obsoletes:     wine-programs < 1:7.7-2
 ExclusiveArch: %{ix86} %{x8664} arm
 ExcludeArch:   i386
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                no_install_post_strip   1
+%define                _noautoprov     elf\\\\(buildid\\\\)
 
 %define                _winedir                %{_datadir}/%{name}
 
@@ -201,18 +194,6 @@ Wine - pliki nagłówkowe.
 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
 WINE.
 
-%package programs
-Summary:       Wine - programs
-Summary(pl.UTF-8):     Wine - programy
-Group:         Applications
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-
-%description programs
-Wine - programs.
-
-%description programs -l pl.UTF-8
-Wine - programy.
-
 %package dll-capi
 Summary:       CAPI 2.0 (ISDN) implementation DLLs for Wine
 Summary(pl.UTF-8):     Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
@@ -225,32 +206,6 @@ CAPI 2.0 (ISDN) implementation DLLs for Wine.
 %description dll-capi -l pl.UTF-8
 Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
 
-%package dll-d3d
-Summary:       Direct3D implementation DLLs for Wine
-Summary(pl.UTF-8):     Biblioteki DLL z implementacją Direct3D dla Wine
-Group:         Applications/Emulators
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      OpenGL
-
-%description dll-d3d
-Direct3D implementation DLLs for Wine (through OpenGL).
-
-%description dll-d3d -l pl.UTF-8
-Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
-
-%package dll-gl
-Summary:       OpenGL implementation DLLs for Wine
-Summary(pl.UTF-8):     Biblioteki DLL z implementacją OpenGL dla Wine
-Group:         Applications/Emulators
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      OpenGL
-
-%description dll-gl
-OpenGL implementation DLLs for Wine.
-
-%description dll-gl -l pl.UTF-8
-Biblioteki DLL z implementacją OpenGL dla Wine.
-
 %package dll-twain
 Summary:       TWAIN implementation DLL for Wine
 Summary(pl.UTF-8):     Biblioteka DLL z implementacją TWAIN dla Wine
@@ -275,34 +230,23 @@ Lightweight Directory Access Protocol Library for Wine.
 %description dll-ldap -l pl.UTF-8
 Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
 
-%package drv-alsa
-Summary:       ALSA driver for WINE mm.dll implementation
-Summary(pl.UTF-8):     Sterownik ALSA dla implementacji mm.dll w Wine
-Group:         Applications/Emulators
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-
-%description drv-alsa
-ALSA driver for WINE mm.dll (multimedia system) implementation.
-
-%description drv-alsa -l pl.UTF-8
-Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
-
 %prep
 %setup -q
-%patch0 -p1
+#%patch0 -p1
 %patch1 -p1
-%patch2 -p1
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
-%patch7 -p1
 %ifarch %{x8664}
-%patch8 -p1
+%patch7 -p1
 %endif
 
 %build
-icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
-mv -f oic_winlogo_*.png %{name}.png
+
+#workaround for icon extraction error.
+icotool -x -o . dlls/user32/resources/oic_winlogo.ico
+mv -f oic_winlogo_*32x32x32.png %{name}.png
+rm -f oic_winlogo_*.png
 
 %{__autoconf}
 %{__autoheader}
@@ -310,40 +254,38 @@ mv -f oic_winlogo_*.png %{name}.png
 %ifarch %{x8664}
        --enable-win64 \
 %endif
-       --with-alsa%{!?with_alsa:=no} \
+       --with-alsa \
        --with-capi%{!?with_capi:=no} \
-       --with-cms \
        --with-coreaudio \
        --with-cups%{!?with_cups:=no} \
-       --with-curses \
+       --with-dbus \
        --with-fontconfig \
        --with-freetype \
-       --with-glu \
-       --with-gnutls \
        --with-gphoto \
-       --with-gsm \
-       --with-gstreamer%{!?with_gstreamer:=no} \
-       --with-hal%{!?with_hal:=no} \
-       --with-jpeg \
+       --with-gnutls \
+       %{__with_without gstreamer} \
        --with-ldap%{!?with_ldap:=no} \
-       --with-mpg123 \
+       --with%{!?with_netapi:out}-netapi \
+       --with-openal \
+       --with-opencl \
        --with-opengl \
-       --with-oss \
-       --with-png \
+       --with-osmesa \
+       --with-pcap \
        --with-pthread \
-       --with-sane%{!?with_sane:=no} \
+       --with-pulse \
+       --with%{!?with_sane:out}-sane \
        --with-xcomposite \
        --with-xcursor \
        --with-xinerama \
        --with-xinput \
-       --with-xml \
+       --with-xinput2 \
        --with-xrandr \
        --with-xrender \
        --with-xshape \
        --with-xshm \
-       --with-xslt \
        --with-xxf86vm \
        --with-x
+
 %{__make} depend
 %{__make}
 
@@ -353,9 +295,7 @@ install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-findup -m $RPM_BUILD_ROOT%{_winedir}/fakedlls
-
-install -p tools/fnt2fon $RPM_BUILD_ROOT%{_bindir}
+install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
 
 install -d \
@@ -382,32 +322,21 @@ EOF
 
 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
 
-dir=$(pwd)
-> files.so
-> files.programs
-cd $RPM_BUILD_ROOT%{_libdir}/wine
-for f in *.so; do
-       case $f in
-       capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
-               ;;
-       *)
-               echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
-       esac
-done
-cd -
-
-programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
-for p in $programs; do
-       echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
-       echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
-       echo "%{_mandir}/man1/$p.1*" >> files.programs
-       grep -v "$p\.exe\.so$" files.so > files.so.
-       mv -f files.so. files.so
+for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
+       mv "$dir" "${dir%.UTF-8}"
 done
 
 %ifarch %{x8664}
-for langdir in "" de/ fr/ pl/ ; do
-mv $RPM_BUILD_ROOT%{_mandir}/${langdir}man1/{wine,wine64}.1
+cp -p loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
+for lang in de fr pl ; do
+install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
+cp -p loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
+done
+%else
+cp -p loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
+for lang in de fr pl ; do
+install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
+cp -p loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
 done
 %endif
 
@@ -437,7 +366,7 @@ if [ -x /sbin/chkconfig ]; then
        /sbin/chkconfig --del wine
 fi
 
-%files -f files.so
+%files
 %defattr(644,root,root,755)
 %doc README AUTHORS ANNOUNCE
 %lang(de) %doc documentation/README.de
@@ -452,46 +381,77 @@ fi
 %lang(ru) %doc documentation/README.ru
 %lang(sv) %doc documentation/README.sv
 %lang(tr) %doc documentation/README.tr
+%attr(755,root,root) %{_bindir}/msidb
 %attr(755,root,root) %{_bindir}/msiexec
+%attr(755,root,root) %{_bindir}/notepad
+%attr(755,root,root) %{_bindir}/regedit
+%attr(755,root,root) %{_bindir}/regsvr32
 %ifnarch %{x8664}
 %attr(755,root,root) %{_bindir}/wine
 %else
 %attr(755,root,root) %{_bindir}/wine64
 %endif
 %attr(755,root,root) %{_bindir}/wineboot
-%attr(755,root,root) %{_bindir}/winedbg
 %attr(755,root,root) %{_bindir}/winecfg
+%attr(755,root,root) %{_bindir}/wineconsole
+%attr(755,root,root) %{_bindir}/winedbg
+%attr(755,root,root) %{_bindir}/winefile
+%attr(755,root,root) %{_bindir}/winemine
+%attr(755,root,root) %{_bindir}/winepath
 %ifnarch %{x8664}
 %attr(755,root,root) %{_bindir}/wine-preloader
 %else
 %attr(755,root,root) %{_bindir}/wine64-preloader
 %endif
 %attr(755,root,root) %{_bindir}/wineserver
-%attr(755,root,root) %{_libdir}/*.so*
 %dir %{_libdir}/wine
-%dir %{_libdir}/wine/fakedlls
-%{_libdir}/wine/fakedlls/*.acm
-%{_libdir}/wine/fakedlls/*.cpl
-%{_libdir}/wine/fakedlls/*.dll
+%dir %{_libdir}/wine/%{winelib}-unix
+%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/*.so*
+%dir %{_libdir}/wine/%{winelib}-windows
+%{_libdir}/wine/%{winelib}-windows/*.acm
+%{_libdir}/wine/%{winelib}-windows/*.ax
+%{_libdir}/wine/%{winelib}-windows/*.com
+%{_libdir}/wine/%{winelib}-windows/*.cpl
+%{_libdir}/wine/%{winelib}-windows/*.dll
 %ifarch %{ix86}
-%{_libdir}/wine/fakedlls/*.dll16
+%{_libdir}/wine/%{winelib}-windows/*.dll16
 %endif
-%{_libdir}/wine/fakedlls/*.drv
+%{_libdir}/wine/%{winelib}-windows/*.drv
 %ifarch %{ix86}
-%{_libdir}/wine/fakedlls/*.drv16
+%{_libdir}/wine/%{winelib}-windows/*.drv16
 %endif
-%{_libdir}/wine/fakedlls/*.ds
-%{_libdir}/wine/fakedlls/*.exe
+%{_libdir}/wine/%{winelib}-windows/*.ds
+%{_libdir}/wine/%{winelib}-windows/*.exe
 %ifarch %{ix86}
-%{_libdir}/wine/fakedlls/*.exe16
-%{_libdir}/wine/fakedlls/*.mod16
+%{_libdir}/wine/%{winelib}-windows/*.exe16
+%{_libdir}/wine/%{winelib}-windows/*.mod16
 %endif
-%{_libdir}/wine/fakedlls/*.ocx
-%{_libdir}/wine/fakedlls/*.sys
-%{_libdir}/wine/fakedlls/*.tlb
+%{_libdir}/wine/%{winelib}-windows/*.msstyles
+%{_libdir}/wine/%{winelib}-windows/*.ocx
+%{_libdir}/wine/%{winelib}-windows/*.sys
+%{_libdir}/wine/%{winelib}-windows/*.tlb
 %ifarch %{ix86}
-%{_libdir}/wine/fakedlls/*.vxd
+%{_libdir}/wine/%{winelib}-windows/*.vxd
+%endif
+%if %{with capi}
+%exclude %{_libdir}/wine/%{winelib}-windows/capi2032.dll
+%exclude %{_libdir}/wine/%{winelib}-unix/capi2032.so
+%endif
+%if %{with sane}
+%exclude %{_libdir}/wine/%{winelib}-unix/sane.so
+%exclude %{_libdir}/wine/%{winelib}-windows/twain*.dll
+%ifarch %{ix86}
+%exclude %{_libdir}/wine/%{winelib}-windows/twain*.dll16
+%endif
+%endif
+%if %{with ldap}
+%exclude %{_libdir}/wine/%{winelib}-unix/wldap*.so
+%exclude %{_libdir}/wine/%{winelib}-windows/wldap*.dll
 %endif
+%{_mandir}/man1/msiexec.1*
+%{_mandir}/man1/notepad.1*
+%{_mandir}/man1/regedit.1*
+%{_mandir}/man1/regsvr32.1*
 %ifnarch %{x8664}
 %{_mandir}/man1/wine.1*
 %lang(de) %{_mandir}/de/man1/wine.1*
@@ -503,10 +463,13 @@ fi
 %lang(fr) %{_mandir}/fr/man1/wine64.1*
 %lang(pl) %{_mandir}/pl/man1/wine64.1*
 %endif
-%{_mandir}/man1/msiexec.1*
 %{_mandir}/man1/wineboot.1*
 %{_mandir}/man1/winecfg.1*
+%{_mandir}/man1/wineconsole.1*
 %{_mandir}/man1/winedbg.1*
+%{_mandir}/man1/winefile.1*
+%{_mandir}/man1/winemine.1*
+%{_mandir}/man1/winepath.1*
 %{_mandir}/man1/wineserver.1*
 %lang(de) %{_mandir}/de/man1/wineserver.1*
 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
@@ -515,12 +478,9 @@ fi
 %{_desktopdir}/wine-uninstaller.desktop
 %{_pixmapsdir}/%{name}.png
 
-%files programs -f files.programs
-%defattr(644,root,root,755)
-
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/fnt2fon
+%attr(755,root,root) %{_bindir}/sfnt2fon
 %attr(755,root,root) %{_bindir}/function_grep.pl
 %attr(755,root,root) %{_bindir}/widl
 %attr(755,root,root) %{_bindir}/winebuild
@@ -531,15 +491,9 @@ fi
 %attr(755,root,root) %{_bindir}/winecpp
 %attr(755,root,root) %{_bindir}/wmc
 %attr(755,root,root) %{_bindir}/wrc
-%{_libdir}/wine/lib*.def
 # no shared variants, so not separated
-%{_libdir}/wine/lib*.def.a
-%{_libdir}/wine/libadsiid.a
-%{_libdir}/wine/libdx*.a
-%{_libdir}/wine/libstrmbase.a
-%{_libdir}/wine/libstrmiids.a
-%{_libdir}/wine/libuuid.a
-%{_libdir}/wine/libwinecrt0.a
+%{_libdir}/wine/%{winelib}-unix/lib*.a
+%{_libdir}/wine/%{winelib}-windows/lib*.a
 %{_includedir}/wine
 %{_mandir}/man1/widl.1*
 %{_mandir}/man1/winebuild.1*
@@ -554,38 +508,28 @@ fi
 %{_mandir}/man1/wrc.1*
 %{_aclocaldir}/*.m4
 
+%if %{with capi}
 %files dll-capi
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
-
-%files dll-d3d
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
-%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
-%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
-
-%files dll-gl
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
-%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
+%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/capi2032.dll
+%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/capi2032.so
+%endif
 
 %if %{with sane}
 %files dll-twain
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/wine/sane.ds.so
-%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
+%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/sane.so
+%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/twain*.dll
+%ifarch %{ix86}
+%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/twain*.dll16
+%endif
 %endif
 
 %if %{with ldap}
 %files dll-ldap
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
-%endif
-
-%if %{with alsa}
-%files drv-alsa
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
+%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/wldap*.so
+%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/wldap*.dll
 %endif
 
 # additional dependencies in *.so not separated (yet?) from main package
This page took 0.0589 seconds and 4 git commands to generate.