]> git.pld-linux.org Git - packages/wine.git/blobdiff - wine.spec
- updated BRs, disable hal
[packages/wine.git] / wine.spec
index 73899fc4d2ba94888775929cb6afd975fe0be256..81efb8b06f5d2cc14d0bd6f193a8dc66b5f8e20b 100644 (file)
--- a/wine.spec
+++ b/wine.spec
@@ -1,21 +1,32 @@
 #
 # Conditional build:
-%bcond_without alsa            # don't build ALSA mm driver
-%bcond_without capi            # don't build CAPI 2.0 (ISDN) support
-%bcond_without gstreamer       # don't build GStreamer filters support
-%bcond_without sane            # don't build TWAIN DLL with scanning support (through SANE)
-%bcond_without ldap            # don't build LDAP DLL
-%bcond_without cups            # without CUPS printing support in winspool,wineps DLLs
+%bcond_without alsa            # ALSA mm driver
+%bcond_without capi            # CAPI 2.0 (ISDN) support
+%bcond_without gstreamer       # GStreamer filters support
+%bcond_without sane            # TWAIN DLL with scanning support (through SANE)
+%bcond_with    hal             # HAL dynamic device support [deprecated]
+%bcond_without ldap            # LDAP DLL
+%bcond_without cups            # CUPS printing support in winspool,wineps DLLs
 #
 # NOTE: wine detects the following SONAMES for dlopen at build time:
-#   libcrypto,libssl (wininet.dll)
-#   libcups (winspool.dll.so,wineps.dll.so)
-#   libcurses/libncurses (wineconsole program)
+#   libGL (winex11.drv.so)
+#   libOSMesa (gdi32.dll.so)
+#   libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
+#   libcapi20 (capi2032.dll.so)
+#   libcups (winspool.drv.so)
+#   libdbus (mountmgr.sys.so)
 #   libfontconfig (gdi32.dll.so)
-#   libfreetype (wineps.dll.so,gdi32.dll.so)
-#   libGL (x11drv.dll.so,ddraw.dll.so)
-#   libX11, libXext, libXi, libXrender (x11drv.dll.so)
-#   libpng (windowscodecs.dll: SONAME_LIBPNG in dlls/windowscodecs/pngformat.c)
+#   libfreetype (gdi32.dll.so)
+#   libgnutls (secur32.dll.so)
+#   libhal (mountmgr.sys.so)
+#   libjpeg (gphoto2.ds.so windowscodecs.dll.so)
+#   libncurses (kernel32.dll.so)
+#   libodbc (odbc32.dll.so)
+#   libpng (windowscodecs.dll.so)
+#   libsane (sane.ds.so)
+#   libtiff (windowscodecs.dll.so)
+#   libv4l1 (qcap.dll.so)
+#   libxslt (msxml3.dll.so)
 # thus requires rebuild after change of any of the above.
 
 # library qualifier in rpm generated deps
 %define        libqual %{nil}
 %endif
 
-%define                gecko_ver       1.4
+%define                gecko_ver       2.21
 Summary:       Program that lets you launch Win applications
 Summary(es.UTF-8):     Ejecuta programas Windows en Linux
 Summary(pl.UTF-8):     Program pozwalający uruchamiać aplikacje Windows
 Summary(pt_BR.UTF-8):  Executa programas Windows no Linux
 Name:          wine
-Version:       1.4.1
-Release:       4
+# 1.6.x – stable
+# 1.7.x – development (DEVEL branch)
+Version:       1.6.2
+Release:       1
 Epoch:         1
 License:       LGPL
 Group:         Applications/Emulators
 Source0:       http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
-# Source0-md5: 0c28702ed478df7a1c097f3a9c4cabd6
+# Source0-md5: 0f6c56f86befe38e219090915f81f48a
 Source1:       http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
-# Source1-md5: 700aaa08724be1992cffed7b87e79a44
+# Source1-md5: 432eb3a2d05c3f07df67864f53c87c60
 Source2:       http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
-# Source2-md5: 7b4811f667fd01d300fdff68420a9c72
+# Source2-md5: 580bbabde1ec99ba9caa439c2dbca3f6
 Source3:       %{name}-uninstaller.desktop
-Patch0:                %{name}-fontcache.patch
+Patch0:                %{name}-gphoto2_bool.patch
 Patch1:                %{name}-makedep.patch
 Patch2:                %{name}-ncurses.patch
 Patch4:                %{name}-disable-valgrind.patch
 Patch5:                %{name}-ca_certificates.patch
 Patch6:                %{name}-manpaths.patch
 Patch7:                desktop.patch
-Patch8:                wine-gnutls.patch
+Patch8:                %{name}-wine64_man.patch
 URL:           http://www.winehq.org/
+BuildRequires: Mesa-libOSMesa-devel
 BuildRequires: OpenAL-devel >= 1.1
+BuildRequires: OpenCL-devel
 BuildRequires: OpenGL-GLU-devel
+BuildRequires: OpenGL-GLX-devel
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
 %{?with_arts:BuildRequires:    artsc-devel}
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.62
 BuildRequires: automake
 BuildRequires: bison
 %{?with_capi:BuildRequires:    capi4k-utils-devel}
 %{?with_cups:BuildRequires:    cups-devel}
+BuildRequires: dbus-devel
 BuildRequires: docbook-dtd31-sgml
 BuildRequires: docbook-utils
-BuildRequires: flex
+BuildRequires: flex >= 2.5.33
 BuildRequires: fontconfig-devel
 BuildRequires: fontforge
 BuildRequires: freetype-devel >= 2.0.5
+# for findup used after make install
 BuildRequires: fslint
+%ifarch %{x8664}
+BuildRequires: gcc >= 6:4.4
+%endif
 BuildRequires: gettext-devel
 BuildRequires: giflib-devel
 BuildRequires: gnutls-devel
-%{?with_gstreamer:BuildRequires:       gstreamer-plugins-base-devel}
-BuildRequires: icoutils
-BuildRequires: lcms-devel
+%{?with_gstreamer:BuildRequires:       gstreamer0.10-devel >= 0.10}
+%{?with_gstreamer:BuildRequires:       gstreamer0.10-plugins-base-devel >= 0.10}
+%{?with_hal:BuildRequires:     hal-devel}
+# for icotool used in build
+BuildRequires: icoutils >= 0.29.0
+BuildRequires: lcms2-devel >= 2
 BuildRequires: libgphoto2-devel
 BuildRequires: libgsm-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libmpg123-devel >= 1.5.0
+BuildRequires: libpng-devel >= 1.5
+BuildRequires: libtiff-devel
 BuildRequires: libtool
 BuildRequires: libv4l-devel
+BuildRequires: libxml2-devel >= 2.0
 BuildRequires: libxslt-devel
 BuildRequires: ncurses-devel
 # db2* failed previously - probably openjade or opensp bug
-BuildRequires: libpng-devel >= 1.5
 BuildRequires: openjade >= 1:1.3.3-0.pre1
 %{?with_ldap:BuildRequires:    openldap-devel}
 BuildRequires: opensp >= 1:1.5.1
-BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: pkgconfig
 BuildRequires: prelink
 %{?with_sane:BuildRequires:    sane-backends-devel}
 BuildRequires: unixODBC-devel >= 2.2.12-2
 #BuildRequires:        valgrind
+BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXcomposite-devel
 BuildRequires: xorg-lib-libXcursor-devel
+BuildRequires: xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXi-devel
 BuildRequires: xorg-lib-libXinerama-devel
-BuildRequires: xorg-lib-libXmu-devel
 BuildRequires: xorg-lib-libXrandr-devel
 BuildRequires: xorg-lib-libXrender-devel
-BuildRequires: xorg-lib-libXxf86dga-devel
 BuildRequires: xorg-lib-libXxf86vm-devel
+BuildRequires: zlib-devel
 Requires:      libfreetype.so.6%{libqual}
-Requires:      libpng15.so.15%{libqual}
+Requires:      libpng16.so.16%{libqual}
 Requires(post):        /sbin/ldconfig
 Suggests:      binfmt-detector
 Suggests:      ca-certificates
@@ -121,11 +147,10 @@ Obsoletes:        wine-doc-pdf
 Obsoletes:     wine-drv-arts
 Obsoletes:     wine-drv-jack
 Obsoletes:     wine-drv-nas
-ExclusiveArch: %{ix86} %{x8664}
+ExclusiveArch: %{ix86} %{x8664} arm
 ExcludeArch:   i386
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreqdep           libGL.so.1 libGLU.so.1
 %define                no_install_post_strip   1
 
 %define                _winedir                %{_datadir}/%{name}
@@ -268,7 +293,9 @@ Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%ifarch %{x8664}
 %patch8 -p1
+%endif
 
 %build
 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
@@ -280,11 +307,11 @@ mv -f oic_winlogo_*.png %{name}.png
 %ifarch %{x8664}
        --enable-win64 \
 %endif
-       --with%{!?with_alsa:out}-alsa \
-       --with%{!?with_capi:out}-capi \
+       --with-alsa%{!?with_alsa:=no} \
+       --with-capi%{!?with_capi:=no} \
        --with-cms \
        --with-coreaudio \
-       --with%{!?with_cups:out}-cups \
+       --with-cups%{!?with_cups:=no} \
        --with-curses \
        --with-fontconfig \
        --with-freetype \
@@ -292,16 +319,16 @@ mv -f oic_winlogo_*.png %{name}.png
        --with-gnutls \
        --with-gphoto \
        --with-gsm \
-       --with%{!?with_gstreamer:out}-gstreamer \
+       --with-gstreamer%{!?with_gstreamer:=no} \
+       --with-hal%{!?with_hal:=no} \
        --with-jpeg \
-       --with%{!?with_ldap:out}-ldap \
+       --with-ldap%{!?with_ldap:=no} \
        --with-mpg123 \
        --with-opengl \
-       --with-openssl \
        --with-oss \
        --with-png \
        --with-pthread \
-       --with%{!?with_sane:out}-sane \
+       --with-sane%{!?with_sane:=no} \
        --with-xcomposite \
        --with-xcursor \
        --with-xinerama \
@@ -325,7 +352,7 @@ install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
 
 findup -m $RPM_BUILD_ROOT%{_winedir}/fakedlls
 
-install -p tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
+install -p tools/fnt2fon $RPM_BUILD_ROOT%{_bindir}
 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
 
 install -d \
@@ -375,6 +402,12 @@ for p in $programs; do
        mv -f files.so. files.so
 done
 
+%ifarch %{x8664}
+for langdir in "" de/ fr/ pl/ ; do
+mv $RPM_BUILD_ROOT%{_mandir}/${langdir}man1/{wine,wine64}.1
+done
+%endif
+
 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
 %ifnarch %{x8664}
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
@@ -403,7 +436,7 @@ fi
 
 %files -f files.so
 %defattr(644,root,root,755)
-%doc README documentation/ChangeLog* AUTHORS ANNOUNCE
+%doc README AUTHORS ANNOUNCE
 %lang(de) %doc documentation/README.de
 %lang(es) %doc documentation/README.es
 %lang(fr) %doc documentation/README.fr
@@ -456,7 +489,17 @@ fi
 %ifarch %{ix86}
 %{_libdir}/wine/fakedlls/*.vxd
 %endif
+%ifnarch %{x8664}
 %{_mandir}/man1/wine.1*
+%lang(de) %{_mandir}/de/man1/wine.1*
+%lang(fr) %{_mandir}/fr/man1/wine.1*
+%lang(pl) %{_mandir}/pl/man1/wine.1*
+%else
+%{_mandir}/man1/wine64.1*
+%lang(de) %{_mandir}/de/man1/wine64.1*
+%lang(fr) %{_mandir}/fr/man1/wine64.1*
+%lang(pl) %{_mandir}/pl/man1/wine64.1*
+%endif
 %{_mandir}/man1/msiexec.1*
 %{_mandir}/man1/wineboot.1*
 %{_mandir}/man1/winecfg.1*
@@ -474,7 +517,7 @@ fi
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/fnt2bdf
+%attr(755,root,root) %{_bindir}/fnt2fon
 %attr(755,root,root) %{_bindir}/function_grep.pl
 %attr(755,root,root) %{_bindir}/widl
 %attr(755,root,root) %{_bindir}/winebuild
This page took 0.076681 seconds and 4 git commands to generate.