]> git.pld-linux.org Git - packages/wine.git/blobdiff - wine.spec
- rel 2;
[packages/wine.git] / wine.spec
index e6d40a96309dc31049ca532e690df3f29c286e6e..4af2d082387a5e62f7381ab10db1f3c5f4de0336 100644 (file)
--- a/wine.spec
+++ b/wine.spec
@@ -4,18 +4,30 @@
 %bcond_without capi            # don't build CAPI 2.0 (ISDN) support
 %bcond_without gstreamer       # don't build GStreamer filters support
 %bcond_without sane            # don't build TWAIN DLL with scanning support (through SANE)
+%bcond_with    hal             # HAL dynamic device support [deprecated]
 %bcond_without ldap            # don't build LDAP DLL
 %bcond_without cups            # without CUPS printing support in winspool,wineps DLLs
+%bcond_without netapi          # don't use the Samba NetAPI library
 #
 # NOTE: wine detects the following SONAMES for dlopen at build time:
-#   libcrypto,libssl (wininet.dll)
-#   libcups (winspool.dll.so,wineps.dll.so)
-#   libcurses/libncurses (wineconsole program)
+#   libGL (winex11.drv.so)
+#   libOSMesa (gdi32.dll.so)
+#   libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
+#   libcapi20 (capi2032.dll.so)
+#   libcups (winspool.drv.so)
+#   libdbus (mountmgr.sys.so)
 #   libfontconfig (gdi32.dll.so)
-#   libfreetype (wineps.dll.so,gdi32.dll.so)
-#   libGL (x11drv.dll.so,ddraw.dll.so)
-#   libX11, libXext, libXi, libXrender (x11drv.dll.so)
-#   libpng (windowscodecs.dll: SONAME_LIBPNG in dlls/windowscodecs/pngformat.c)
+#   libfreetype (gdi32.dll.so)
+#   libgnutls (secur32.dll.so)
+#   libhal (mountmgr.sys.so)
+#   libjpeg (gphoto2.ds.so windowscodecs.dll.so)
+#   libncurses (kernel32.dll.so)
+#   libodbc (odbc32.dll.so)
+#   libpng (windowscodecs.dll.so)
+#   libsane (sane.ds.so)
+#   libtiff (windowscodecs.dll.so)
+#   libv4l1 (qcap.dll.so)
+#   libxslt (msxml3.dll.so)
 # thus requires rebuild after change of any of the above.
 
 # library qualifier in rpm generated deps
 %define        libqual %{nil}
 %endif
 
-%define                gecko_ver       2.21
+%define                gecko_ver       2.24
 Summary:       Program that lets you launch Win applications
 Summary(es.UTF-8):     Ejecuta programas Windows en Linux
 Summary(pl.UTF-8):     Program pozwalający uruchamiać aplikacje Windows
 Summary(pt_BR.UTF-8):  Executa programas Windows no Linux
 Name:          wine
-Version:       1.6
-Release:       4
+# 1.8.x – stable
+# 1.9.x – development
+Version:       1.8
+Release:       2
 Epoch:         1
 License:       LGPL
 Group:         Applications/Emulators
 Source0:       http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
-# Source0-md5: 47cf1e121d395e9c8ca1a4ab88f1e658
+# Source0-md5: 96b51a2f2ae727802d71095354e69fef
 Source1:       http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
-# Source1-md5: 432eb3a2d05c3f07df67864f53c87c60
+# Source1-md5: 766bb034172f7f0a97443951a02a0df8
 Source2:       http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
-# Source2-md5: 580bbabde1ec99ba9caa439c2dbca3f6
+# Source2-md5: 1912fd191872c72d5f562283e44e8ab4
 Source3:       %{name}-uninstaller.desktop
-Patch0:                %{name}-bison3.patch
+Patch0:                %{name}-gphoto2_bool.patch
 Patch1:                %{name}-makedep.patch
 Patch2:                %{name}-ncurses.patch
 Patch4:                %{name}-disable-valgrind.patch
 Patch5:                %{name}-ca_certificates.patch
-Patch6:                %{name}-manpaths.patch
-Patch7:                desktop.patch
-Patch8:                %{name}-wine64_man.patch
+Patch6:                desktop.patch
+Patch7:                %{name}-wine64_man.patch
 URL:           http://www.winehq.org/
+BuildRequires: Mesa-libOSMesa-devel
 BuildRequires: OpenAL-devel >= 1.1
+BuildRequires: OpenCL-devel
 BuildRequires: OpenGL-GLU-devel
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
 %{?with_arts:BuildRequires:    artsc-devel}
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.62
 BuildRequires: automake
 BuildRequires: bison
 %{?with_capi:BuildRequires:    capi4k-utils-devel}
 %{?with_cups:BuildRequires:    cups-devel}
-BuildRequires: docbook-dtd31-sgml
-BuildRequires: docbook-utils
-BuildRequires: flex
+BuildRequires: dbus-devel
+BuildRequires: flex >= 2.5.33
 BuildRequires: fontconfig-devel
-BuildRequires: fontforge
 BuildRequires: freetype-devel >= 2.0.5
+# for findup used after make install
 BuildRequires: fslint
 BuildRequires: gettext-devel
-BuildRequires: giflib-devel
+%ifarch %{x8664}
+BuildRequires: gcc >= 6:4.4
+%endif
+BuildRequires: gettext-tools
 BuildRequires: gnutls-devel
-%{?with_gstreamer:BuildRequires:       gstreamer-plugins-base-devel}
-BuildRequires: icoutils
-BuildRequires: lcms-devel
+%{?with_gstreamer:BuildRequires:       gstreamer0.10-devel >= 0.10}
+%{?with_gstreamer:BuildRequires:       gstreamer0.10-plugins-base-devel >= 0.10}
+%{?with_hal:BuildRequires:     hal-devel}
+# for icotool used in build
+BuildRequires: icoutils >= 0.29.0
+BuildRequires: lcms2-devel >= 2
+BuildRequires: libcap-devel
 BuildRequires: libgphoto2-devel
 BuildRequires: libgsm-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libmpg123-devel >= 1.5.0
-BuildRequires: libtool
+BuildRequires: libpcap-devel
+BuildRequires: libpng-devel >= 1.5
+BuildRequires: libtiff-devel
 BuildRequires: libv4l-devel
+BuildRequires: libxml2-devel >= 2.0
 BuildRequires: libxslt-devel
 BuildRequires: ncurses-devel
-# db2* failed previously - probably openjade or opensp bug
-BuildRequires: libpng-devel >= 1.5
-BuildRequires: openjade >= 1:1.3.3-0.pre1
 %{?with_ldap:BuildRequires:    openldap-devel}
-BuildRequires: opensp >= 1:1.5.1
-BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: pkgconfig
-BuildRequires: prelink
+BuildRequires: pulseaudio-devel
+BuildRequires: samba-devel
 %{?with_sane:BuildRequires:    sane-backends-devel}
-BuildRequires: unixODBC-devel >= 2.2.12-2
-#BuildRequires:        valgrind
+BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXcomposite-devel
 BuildRequires: xorg-lib-libXcursor-devel
+BuildRequires: xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXi-devel
 BuildRequires: xorg-lib-libXinerama-devel
-BuildRequires: xorg-lib-libXmu-devel
 BuildRequires: xorg-lib-libXrandr-devel
 BuildRequires: xorg-lib-libXrender-devel
-BuildRequires: xorg-lib-libXxf86dga-devel
 BuildRequires: xorg-lib-libXxf86vm-devel
+BuildRequires: zlib-devel
 Requires:      libfreetype.so.6%{libqual}
-Requires:      libpng15.so.15%{libqual}
+Requires:      libpng16.so.16%{libqual}
 Requires(post):        /sbin/ldconfig
 Suggests:      binfmt-detector
 Suggests:      ca-certificates
@@ -121,11 +140,10 @@ Obsoletes:        wine-doc-pdf
 Obsoletes:     wine-drv-arts
 Obsoletes:     wine-drv-jack
 Obsoletes:     wine-drv-nas
-ExclusiveArch: %{ix86} %{x8664}
+ExclusiveArch: %{ix86} %{x8664} arm
 ExcludeArch:   i386
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreqdep           libGL.so.1 libGLU.so.1
 %define                no_install_post_strip   1
 
 %define                _winedir                %{_datadir}/%{name}
@@ -195,11 +213,10 @@ Group:            Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description dll-capi
-CAPI 2.0 (ISDN) implementation DLLs for Wine (through OpenGL).
+CAPI 2.0 (ISDN) implementation DLLs for Wine.
 
 %description dll-capi -l pl.UTF-8
-Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine (poprzez
-OpenGL).
+Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
 
 %package dll-d3d
 Summary:       Direct3D implementation DLLs for Wine
@@ -241,11 +258,15 @@ Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
 
 %package dll-ldap
 Summary:       Win32 LDAP API DLL for Wine
+Summary(pl.UTF-8):     Biblioteka DLL z implementacją API Win32 LDAP dla Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description dll-ldap
-Lightweight Directory Access Protocol Library.
+Lightweight Directory Access Protocol Library for Wine.
+
+%description dll-ldap -l pl.UTF-8
+Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
 
 %package drv-alsa
 Summary:       ALSA driver for WINE mm.dll implementation
@@ -267,9 +288,8 @@ Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
-%patch7 -p1
 %ifarch %{x8664}
-%patch8 -p1
+%patch7 -p1
 %endif
 
 %build
@@ -282,32 +302,42 @@ mv -f oic_winlogo_*.png %{name}.png
 %ifarch %{x8664}
        --enable-win64 \
 %endif
-       --with%{!?with_alsa:out}-alsa \
-       --with%{!?with_capi:out}-capi \
+       --with-alsa%{!?with_alsa:=no} \
+       --with-capi%{!?with_capi:=no} \
        --with-cms \
        --with-coreaudio \
-       --with%{!?with_cups:out}-cups \
+       --with-cups%{!?with_cups:=no} \
        --with-curses \
+       --with-dbus \
        --with-fontconfig \
        --with-freetype \
+       --with-gphoto \
        --with-glu \
        --with-gnutls \
-       --with-gphoto \
        --with-gsm \
-       --with%{!?with_gstreamer:out}-gstreamer \
+       %{__with_without gstreamer} \
+       %{__with_without hal} \
        --with-jpeg \
-       --with%{!?with_ldap:out}-ldap \
+       --with-ldap%{!?with_ldap:=no} \
        --with-mpg123 \
+       --with%{!?with_netapi:out}-netapi \
+       --with-openal \
+       --with-opencl \
        --with-opengl \
-       --with-openssl \
+       --with-osmesa \
        --with-oss \
+       --with-pcap \
        --with-png \
        --with-pthread \
+       --with-pulse \
        --with%{!?with_sane:out}-sane \
+       --with-tiff \
+       --with-v4l \
        --with-xcomposite \
        --with-xcursor \
        --with-xinerama \
        --with-xinput \
+       --with-xinput2 \
        --with-xml \
        --with-xrandr \
        --with-xrender \
@@ -315,7 +345,8 @@ mv -f oic_winlogo_*.png %{name}.png
        --with-xshm \
        --with-xslt \
        --with-xxf86vm \
-       --with-x
+       --with-x \
+       --with-zlib
 %{__make} depend
 %{__make}
 
@@ -325,9 +356,7 @@ install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-findup -m $RPM_BUILD_ROOT%{_winedir}/fakedlls
-
-install -p tools/fnt2fon $RPM_BUILD_ROOT%{_bindir}
+install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
 
 install -d \
@@ -377,9 +406,21 @@ for p in $programs; do
        mv -f files.so. files.so
 done
 
+for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
+       mv "$dir" "${dir%.UTF-8}"
+done
+
 %ifarch %{x8664}
-for langdir in "" de/ fr/ pl/ ; do
-mv $RPM_BUILD_ROOT%{_mandir}/${langdir}man1/{wine,wine64}.1
+install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
+for lang in de fr pl ; do
+install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
+install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
+done
+%else
+install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
+for lang in de fr pl ; do
+install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
+install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
 done
 %endif
 
@@ -492,7 +533,7 @@ fi
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/fnt2fon
+%attr(755,root,root) %{_bindir}/sfnt2fon
 %attr(755,root,root) %{_bindir}/function_grep.pl
 %attr(755,root,root) %{_bindir}/widl
 %attr(755,root,root) %{_bindir}/winebuild
@@ -561,6 +602,5 @@ fi
 %endif
 
 # additional dependencies in *.so not separated (yet?) from main package
-#   ddraw.dll.so,x11drv.dll.so depend on X11 libs
-#   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
-#   ttydrv.dll.so depends on ncurses
+#   ddraw.dll.so,winex11.drv.so depend on X11 libs
+#   ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.173684 seconds and 4 git commands to generate.