]> git.pld-linux.org Git - packages/wine.git/blobdiff - wine-ncurses.patch
- up to 7.6, adapterize
[packages/wine.git] / wine-ncurses.patch
index 96fb545e96930d62308647dd61af421c69a1df8b..37a52e6580c69f52901f891c9d54930a594b10f2 100644 (file)
@@ -1,25 +1,73 @@
---- wine-0.9.28/configure.ac.orig      2006-12-22 17:17:47.000000000 +0100
-+++ wine-0.9.28/configure.ac   2006-12-24 03:10:15.504363300 +0100
-@@ -194,6 +194,7 @@
-       machine/soundcard.h \
+diff -dur wine-1.8.orig/configure.ac wine-1.8/configure.ac
+--- wine-1.8.orig/configure.ac 2015-12-19 16:57:44.000000000 +0100
++++ wine-1.8/configure.ac      2016-01-09 18:16:41.889401226 +0100
+@@ -450,6 +450,7 @@
+       machine/sysarch.h \
        mntent.h \
        ncurses.h \
 +      ncurses/ncurses.h \
        netdb.h \
        netinet/in.h \
        netinet/in_systm.h \
-@@ -519,7 +520,7 @@
+@@ -1274,9 +1275,12 @@
  
  dnl **** Check which curses lib to use ***
- CURSESLIBS=""
+ CURSES_LIBS=""
 -if test "$ac_cv_header_ncurses_h" = "yes"
 +if test "$ac_cv_header_ncurses_h" = "yes" || test "$ac_cv_header_ncurses_ncurses_h" = "yes"
  then
-     AC_CHECK_LIB(ncurses,waddch,[CURSESLIBS="-lncurses"])
+     WINE_CHECK_SONAME(ncurses,waddch,[CURSES_LIBS="-lncurses"],,,[[libncursesw\\{0,1\\}]])
++    if test "x$ac_cv_lib_soname_ncurses" = "x"; then
++        WINE_CHECK_SONAME(ncursesw,waddch,[CURSESLIBS="-lncursesw"])
++    fi
  elif test "$ac_cv_header_curses_h" = "yes"
---- wine-0.9.41/programs/wineconsole/curses.c.old      2007-07-14 22:00:49.124363079 +0200
-+++ wine-0.9.41/programs/wineconsole/curses.c  2007-07-14 22:07:46.714791368 +0200
-@@ -39,6 +39,8 @@
+ then
+     WINE_CHECK_SONAME(curses,waddch,[CURSES_LIBS="-lcurses"])
+@@ -1285,8 +1289,8 @@
+ LIBS="$LIBS $CURSES_LIBS"
+ AC_CHECK_FUNCS(mousemask)
+ LIBS="$ac_save_LIBS"
+-WINE_NOTICE_WITH(curses,[test "x$ac_cv_lib_soname_curses$ac_cv_lib_soname_ncurses" = "x"],
+-                 [lib(n)curses ${notice_platform}development files not found, curses won't be supported.])
++WINE_NOTICE_WITH(curses,[test "x$ac_cv_lib_soname_curses$ac_cv_lib_soname_ncurses$ac_cv_lib_soname_ncursesw" = "x"],
++                 [lib(n)curses(w) ${notice_platform}development files not found, curses won't be supported.])
+ dnl **** Check for SANE ****
+ if test "x$with_sane" != "xno"
+diff -dur wine-1.8.orig/dlls/kernel32/term.c wine-1.8/dlls/kernel32/term.c
+--- wine-1.8.orig/dlls/kernel32/term.c 2015-12-19 16:57:44.000000000 +0100
++++ wine-1.8/dlls/kernel32/term.c      2016-01-09 18:15:39.868921555 +0100
+@@ -27,6 +27,8 @@
+ # include <ncurses.h>
+ #elif defined(HAVE_CURSES_H)
+ # include <curses.h>
++#elif defined(HAVE_NCURSES_NCURSES_H)
++# include <ncurses/ncurses.h>
+ #endif
+ /* avoid redefinition warnings */
+ #undef KEY_EVENT
+@@ -34,6 +36,8 @@
+ #if defined(HAVE_CURSES_H) || defined(HAVE_NCURSES_H)
+ #include <term.h>
++#elif defined(HAVE_NCURSES_NCURSES_H)
++#include <ncurses/term.h>
+ #endif
+ #include <windef.h>
+@@ -148,7 +152,7 @@
+ #if defined(SONAME_LIBCURSES) || defined(SONAME_LIBNCURSES)
+-#ifdef HAVE_NCURSES_H
++#ifdef HAVE_NCURSES_H || defined(HAVE_NCURSES_NCURSES_H)
+ # define CURSES_NAME "ncurses"
+ #else
+ # define CURSES_NAME "curses"
+diff -dur wine-1.8.orig/programs/wineconsole/curses.c wine-1.8/programs/wineconsole/curses.c
+--- wine-1.8.orig/programs/wineconsole/curses.c        2015-12-19 16:57:44.000000000 +0100
++++ wine-1.8/programs/wineconsole/curses.c     2016-01-09 18:15:39.872254915 +0100
+@@ -40,6 +40,8 @@
  # include <ncurses.h>
  #elif defined(HAVE_CURSES_H)
  # include <curses.h>
@@ -28,7 +76,7 @@
  #endif
  /* avoid redefinition warnings */
  #undef KEY_EVENT
-@@ -62,7 +64,7 @@
+@@ -64,7 +66,7 @@
  
  #if defined(SONAME_LIBCURSES) || defined(SONAME_LIBNCURSES)
  
This page took 0.064701 seconds and 4 git commands to generate.