]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
Release 2 (by relup.sh)
[packages/wine.git] / wine.spec
1 #
2 # todo:
3 # libvkd3d https://wiki.winehq.org/Vkd3d
4 #
5 # Conditional build:
6 %bcond_without  alsa            # don't build ALSA mm driver
7 %bcond_with     capi            # don't build CAPI 2.0 (ISDN) support
8 %bcond_without  gstreamer       # don't build GStreamer filters support
9 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
10 %bcond_without  ldap            # don't build LDAP DLL
11 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
12 %bcond_without  netapi          # don't use the Samba NetAPI library
13 #
14 # NOTE: wine detects the following SONAMES for dlopen at build time:
15 #   libGL (winex11.drv.so)
16 #   libOSMesa (gdi32.dll.so)
17 #   libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
18 #   libcapi20 (capi2032.dll.so)
19 #   libcups (winspool.drv.so)
20 #   libdbus (mountmgr.sys.so)
21 #   libfontconfig (gdi32.dll.so)
22 #   libfreetype (gdi32.dll.so)
23 #   libgnutls (secur32.dll.so)
24 #   libncurses (kernel32.dll.so)
25 #   libodbc (odbc32.dll.so)
26 #   libsane (sane.ds.so)
27 #   libtiff (windowscodecs.dll.so)
28 # thus requires rebuild after change of any of the above.
29
30 # library qualifier in rpm generated deps
31 %ifarch %{x8664} ia64 ppc64 s390x sparc64
32 %define libqual ()(64bit)
33 %else
34 %define libqual %{nil}
35 %endif
36
37 %ifarch %{x8664} 
38 %define winelib x86_64
39 %else
40 %define winelib i386
41 %endif
42
43 %define         gecko_ver       2.47.2
44 Summary:        Program that lets you launch Win applications
45 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
46 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
47 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
48 Name:           wine
49 Version:        7.3
50 Release:        2
51 Epoch:          1
52 License:        LGPL
53 Group:          Applications/Emulators
54 Source0:        https://dl.winehq.org/wine/source/7.x/%{name}-%{version}.tar.xz
55 # Source0-md5:  5a52776788f27cb4181dda24fc5eaf45
56 Source1:        https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86.msi
57 # Source1-md5:  e0a26e37397961b2c7f624575590ef66
58 Source2:        https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86_64.msi
59 # Source2-md5:  ff7168b08fa901516fbaa8a66aa3cee6
60 Source3:        %{name}-uninstaller.desktop
61 Patch0:         %{name}-gphoto2_bool.patch
62 Patch1:         %{name}-makedep.patch
63 Patch2:         %{name}-ncurses.patch
64 Patch4:         %{name}-disable-valgrind.patch
65 Patch5:         %{name}-ca_certificates.patch
66 Patch6:         desktop.patch
67 Patch7:         %{name}-wine64_man.patch
68 URL:            http://www.winehq.org/
69 BuildConflicts: crossmingw32-gcc
70 BuildConflicts: crossmingw64-gcc
71 BuildRequires:  Mesa-libOSMesa-devel
72 BuildRequires:  OpenAL-devel >= 1.1
73 BuildRequires:  OpenCL-devel
74 BuildRequires:  OpenGL-GLU-devel
75 %{?with_alsa:BuildRequires:     alsa-lib-devel}
76 %{?with_arts:BuildRequires:     artsc-devel}
77 BuildRequires:  autoconf >= 2.62
78 BuildRequires:  automake
79 BuildRequires:  bison
80 %{?with_capi:BuildRequires:     capi4k-utils-devel}
81 BuildRequires:  clang
82 %{?with_cups:BuildRequires:     cups-devel}
83 BuildRequires:  dbus-devel
84 BuildRequires:  flex >= 2.5.33
85 BuildRequires:  fontconfig-devel
86 BuildRequires:  freetype-devel >= 2.0.5
87 BuildRequires:  gettext-devel
88 %ifarch %{x8664}
89 BuildRequires:  gcc >= 6:4.4
90 %endif
91 BuildRequires:  gettext-tools
92 BuildRequires:  gnutls-devel
93 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 1.0}
94 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-base-devel >= 1.0}
95 # for icotool used in build
96 BuildRequires:  icoutils >= 0.29.0
97 BuildRequires:  lcms2-devel >= 2
98 BuildRequires:  libcap-devel
99 BuildRequires:  libgphoto2-devel
100 BuildRequires:  libpcap-devel
101 %{?with_ldap:BuildRequires:     openldap-devel}
102 BuildRequires:  pkgconfig
103 BuildRequires:  pulseaudio-devel
104 BuildRequires:  samba-devel
105 %{?with_sane:BuildRequires:     sane-backends-devel}
106 BuildRequires:  xorg-lib-libX11-devel
107 BuildRequires:  xorg-lib-libXcomposite-devel
108 BuildRequires:  xorg-lib-libXcursor-devel
109 BuildRequires:  xorg-lib-libXext-devel
110 BuildRequires:  xorg-lib-libXi-devel
111 BuildRequires:  xorg-lib-libXinerama-devel
112 BuildRequires:  xorg-lib-libXrandr-devel
113 BuildRequires:  xorg-lib-libXrender-devel
114 BuildRequires:  xorg-lib-libXxf86vm-devel
115 Requires:       libfreetype.so.6%{libqual}
116 Requires:       libpng16.so.16%{libqual}
117 Requires(post): /sbin/ldconfig
118 Suggests:       binfmt-detector
119 Suggests:       ca-certificates
120 Suggests:       cabextract
121 Conflicts:      ca-certificates < 20080809-4
122 # for printing needs lpr
123 Suggests:       cups-clients
124 # for winelauncher
125 Suggests:       xorg-app-xmessage
126 # for ntlm_auth
127 Suggests:       samba-common >= 1:3.0.25
128 # link to wine/ntdll.dll.so, without any SONAME
129 Provides:       libntdll.dll.so
130 Obsoletes:      wine-doc-pdf
131 Obsoletes:      wine-drv-arts
132 Obsoletes:      wine-drv-jack
133 Obsoletes:      wine-drv-nas
134 ExclusiveArch:  %{ix86} %{x8664} arm
135 ExcludeArch:    i386
136 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
137
138 %define         no_install_post_strip   1
139 %define         _noautoprov     elf\\\\(buildid\\\\)
140
141 %define         _winedir                %{_datadir}/%{name}
142
143 %description
144 Wine is a program which allows running Microsoft Windows programs
145 (including DOS, Windows 3.x and Win32 executables) on Unix. It
146 consists of a program loader which loads and executes a Microsoft
147 Windows binary, and a library that implements Windows API calls using
148 their Unix or X11 equivalents. The library may also be used for
149 porting Win32 code into native Unix executables.
150
151 %description -l es.UTF-8
152 Ejecuta programas Windows en Linux.
153
154 %description -l pl.UTF-8
155 Wine jest programem dzięki któremu można uruchamiać programy napisane
156 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
157 loadera, który pozwala wczytywać i uruchamiać programy w formacie
158 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
159 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
160 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
161
162 %description -l pt_BR.UTF-8
163 O Wine é um programa que permite rodar programas MS-Windows no X11.
164 Ele consiste de um carregador de programa, que carrega e executa um
165 binário MS-Windows, e de uma biblioteca de emulação que traduz as
166 chamadas da API para as equivalentes Unix/X11.
167
168 %package devel
169 Summary:        Wine - header files
170 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
171 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
172 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
173 Group:          Development/Libraries
174 Requires:       %{name} = %{epoch}:%{version}-%{release}
175
176 %description devel
177 Wine - header files.
178
179 %description devel -l es.UTF-8
180 Biblioteca de desarrollo de wine.
181
182 %description devel -l pl.UTF-8
183 Wine - pliki nagłówkowe.
184
185 %description devel -l pt_BR.UTF-8
186 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
187 WINE.
188
189 %package programs
190 Summary:        Wine - programs
191 Summary(pl.UTF-8):      Wine - programy
192 Group:          Applications
193 Requires:       %{name} = %{epoch}:%{version}-%{release}
194
195 %description programs
196 Wine - programs.
197
198 %description programs -l pl.UTF-8
199 Wine - programy.
200
201 %package dll-capi
202 Summary:        CAPI 2.0 (ISDN) implementation DLLs for Wine
203 Summary(pl.UTF-8):      Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
204 Group:          Applications/Emulators
205 Requires:       %{name} = %{epoch}:%{version}-%{release}
206
207 %description dll-capi
208 CAPI 2.0 (ISDN) implementation DLLs for Wine.
209
210 %description dll-capi -l pl.UTF-8
211 Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
212
213 %package dll-d3d
214 Summary:        Direct3D implementation DLLs for Wine
215 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
216 Group:          Applications/Emulators
217 Requires:       %{name} = %{epoch}:%{version}-%{release}
218 Requires:       OpenGL
219
220 %description dll-d3d
221 Direct3D implementation DLLs for Wine (through OpenGL).
222
223 %description dll-d3d -l pl.UTF-8
224 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
225
226 %package dll-gl
227 Summary:        OpenGL implementation DLLs for Wine
228 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
229 Group:          Applications/Emulators
230 Requires:       %{name} = %{epoch}:%{version}-%{release}
231 Requires:       OpenGL
232
233 %description dll-gl
234 OpenGL implementation DLLs for Wine.
235
236 %description dll-gl -l pl.UTF-8
237 Biblioteki DLL z implementacją OpenGL dla Wine.
238
239 %package dll-twain
240 Summary:        TWAIN implementation DLL for Wine
241 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
242 Group:          Applications/Emulators
243 Requires:       %{name} = %{epoch}:%{version}-%{release}
244
245 %description dll-twain
246 TWAIN implementation DLL for Wine (through SANE).
247
248 %description dll-twain -l pl.UTF-8
249 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
250
251 %package dll-ldap
252 Summary:        Win32 LDAP API DLL for Wine
253 Summary(pl.UTF-8):      Biblioteka DLL z implementacją API Win32 LDAP dla Wine
254 Group:          Applications/Emulators
255 Requires:       %{name} = %{epoch}:%{version}-%{release}
256
257 %description dll-ldap
258 Lightweight Directory Access Protocol Library for Wine.
259
260 %description dll-ldap -l pl.UTF-8
261 Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
262
263 %package drv-alsa
264 Summary:        ALSA driver for WINE mm.dll implementation
265 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
266 Group:          Applications/Emulators
267 Requires:       %{name} = %{epoch}:%{version}-%{release}
268
269 %description drv-alsa
270 ALSA driver for WINE mm.dll (multimedia system) implementation.
271
272 %description drv-alsa -l pl.UTF-8
273 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
274
275 %prep
276 %setup -q
277 #%patch0 -p1
278 %patch1 -p1
279 %patch4 -p1
280 %patch5 -p1
281 %patch6 -p1
282 %ifarch %{x8664}
283 %patch7 -p1
284 %endif
285
286 %build
287
288 #workaround for icon extraction error.
289 icotool -x -o . dlls/user32/resources/oic_winlogo.ico
290 mv -f oic_winlogo_*32x32x32.png %{name}.png
291 rm -f oic_winlogo_*.png
292
293 %{__autoconf}
294 %{__autoheader}
295 %configure \
296 %ifarch %{x8664}
297         --enable-win64 \
298 %endif
299         --with-alsa%{!?with_alsa:=no} \
300         --with-capi%{!?with_capi:=no} \
301         --with-coreaudio \
302         --with-cups%{!?with_cups:=no} \
303         --with-dbus \
304         --with-fontconfig \
305         --with-freetype \
306         --with-gphoto \
307         --with-gnutls \
308         %{__with_without gstreamer} \
309         --with-ldap%{!?with_ldap:=no} \
310         --with%{!?with_netapi:out}-netapi \
311         --with-openal \
312         --with-opencl \
313         --with-opengl \
314         --with-osmesa \
315         --with-pcap \
316         --with-pthread \
317         --with-pulse \
318         --with%{!?with_sane:out}-sane \
319         --with-xcomposite \
320         --with-xcursor \
321         --with-xinerama \
322         --with-xinput \
323         --with-xinput2 \
324         --with-xrandr \
325         --with-xrender \
326         --with-xshape \
327         --with-xshm \
328         --with-xxf86vm \
329         --with-x
330         
331 %{__make} depend
332 %{__make}
333
334 %install
335 rm -rf $RPM_BUILD_ROOT
336 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
337 %{__make} install \
338         DESTDIR=$RPM_BUILD_ROOT
339
340 install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
341 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
342
343 install -d \
344         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
345         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
346         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
347         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
348         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
349
350 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
351 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
352 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
353
354 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
355 [mci]
356 cdaudio=mcicda.drv
357 sequencer=mciseq.drv
358 waveaudio=mciwave.drv
359 avivideo=mciavi.drv
360 videodisc=mcipionr.drv
361 vcr=mciviscd.drv
362 MPEGVideo=mciqtz.drv
363 EOF
364
365 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
366
367 dir=$(pwd)
368 > files.so
369 > files.programs
370
371 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
372 for p in $programs; do
373         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
374         echo "%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/$p.exe" >> files.programs
375         echo "%{_mandir}/man1/$p.1*" >> files.programs
376 #       grep -v "$p\.exe\.so$" files.so > files.so.
377 #       mv -f files.so. files.so
378 done
379
380 for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
381         mv "$dir" "${dir%.UTF-8}"
382 done
383
384 %ifarch %{x8664}
385 install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
386 for lang in de fr pl ; do
387 install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
388 install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
389 done
390 %else
391 install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
392 for lang in de fr pl ; do
393 install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
394 install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
395 done
396 %endif
397
398 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
399 %ifnarch %{x8664}
400 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
401 %else
402 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
403 %endif
404
405 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
406 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
407 cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
408
409 %clean
410 rm -rf $RPM_BUILD_ROOT
411
412 %post
413 /sbin/ldconfig
414 %update_desktop_database
415
416 %postun -p /sbin/ldconfig
417
418 %triggerpostun -- wine < 1:0.9.12-1.9
419 rm -f /var/lock/subsys/wine
420 if [ -x /sbin/chkconfig ]; then
421         /sbin/chkconfig --del wine
422 fi
423
424 %files 
425 %defattr(644,root,root,755)
426 %doc README AUTHORS ANNOUNCE
427 %lang(de) %doc documentation/README.de
428 %lang(es) %doc documentation/README.es
429 %lang(fr) %doc documentation/README.fr
430 %lang(hu) %doc documentation/README.hu
431 %lang(it) %doc documentation/README.it
432 %lang(ko) %doc documentation/README.ko
433 %lang(nb) %doc documentation/README.no
434 %lang(pt) %doc documentation/README.pt
435 %lang(pt_BR) %doc documentation/README.pt_br
436 %lang(ru) %doc documentation/README.ru
437 %lang(sv) %doc documentation/README.sv
438 %lang(tr) %doc documentation/README.tr
439 %attr(755,root,root) %{_bindir}/msidb
440 %attr(755,root,root) %{_bindir}/msiexec
441 %ifnarch %{x8664}
442 %attr(755,root,root) %{_bindir}/wine
443 %else
444 %attr(755,root,root) %{_bindir}/wine64
445 %endif
446 %attr(755,root,root) %{_bindir}/wineboot
447 %attr(755,root,root) %{_bindir}/winedbg
448 %attr(755,root,root) %{_bindir}/winecfg
449 %ifnarch %{x8664}
450 %attr(755,root,root) %{_bindir}/wine-preloader
451 %else
452 %attr(755,root,root) %{_bindir}/wine64-preloader
453 %endif
454 %attr(755,root,root) %{_bindir}/wineserver
455 %dir %{_libdir}/wine
456 %dir %{_libdir}/wine/%{winelib}-unix
457 %attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/*.so*
458 %dir %{_libdir}/wine/%{winelib}-windows
459 %{_libdir}/wine/%{winelib}-windows/*.acm
460 %{_libdir}/wine/%{winelib}-windows/*.ax
461 %{_libdir}/wine/%{winelib}-windows/*.com
462 %{_libdir}/wine/%{winelib}-windows/*.cpl
463 %{_libdir}/wine/%{winelib}-windows/*.dll
464 %ifarch %{ix86}
465 %{_libdir}/wine/%{winelib}-windows/*.dll16
466 %endif
467 %{_libdir}/wine/%{winelib}-windows/*.drv
468 %ifarch %{ix86}
469 %{_libdir}/wine/%{winelib}-windows/*.drv16
470 %endif
471 %{_libdir}/wine/%{winelib}-windows/*.ds
472 %{_libdir}/wine/%{winelib}-windows/*.exe
473 %ifarch %{ix86}
474 %{_libdir}/wine/%{winelib}-windows/*.exe16
475 %{_libdir}/wine/%{winelib}-windows/*.mod16
476 %endif
477 %{_libdir}/wine/%{winelib}-windows/*.msstyles
478 %{_libdir}/wine/%{winelib}-windows/*.ocx
479 %{_libdir}/wine/%{winelib}-windows/*.sys
480 %{_libdir}/wine/%{winelib}-windows/*.tlb
481 %ifarch %{ix86}
482 %{_libdir}/wine/%{winelib}-windows/*.vxd
483 %endif
484 %ifnarch %{x8664}
485 %{_mandir}/man1/wine.1*
486 %lang(de) %{_mandir}/de/man1/wine.1*
487 %lang(fr) %{_mandir}/fr/man1/wine.1*
488 %lang(pl) %{_mandir}/pl/man1/wine.1*
489 %else
490 %{_mandir}/man1/wine64.1*
491 %lang(de) %{_mandir}/de/man1/wine64.1*
492 %lang(fr) %{_mandir}/fr/man1/wine64.1*
493 %lang(pl) %{_mandir}/pl/man1/wine64.1*
494 %endif
495 %{_mandir}/man1/msiexec.1*
496 %{_mandir}/man1/wineboot.1*
497
498 %{_mandir}/man1/winecfg.1*
499 %{_mandir}/man1/winedbg.1*
500 %{_mandir}/man1/wineserver.1*
501 %lang(de) %{_mandir}/de/man1/wineserver.1*
502 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
503 %{_winedir}
504 %{_desktopdir}/wine.desktop
505 %{_desktopdir}/wine-uninstaller.desktop
506 %{_pixmapsdir}/%{name}.png
507
508 %files programs -f files.programs
509 %defattr(644,root,root,755)
510
511 %files devel
512 %defattr(644,root,root,755)
513 %attr(755,root,root) %{_bindir}/sfnt2fon
514 %attr(755,root,root) %{_bindir}/function_grep.pl
515 %attr(755,root,root) %{_bindir}/widl
516 %attr(755,root,root) %{_bindir}/winebuild
517 %attr(755,root,root) %{_bindir}/winedump
518 %attr(755,root,root) %{_bindir}/wineg++
519 %attr(755,root,root) %{_bindir}/winegcc
520 %attr(755,root,root) %{_bindir}/winemaker
521 %attr(755,root,root) %{_bindir}/winecpp
522 %attr(755,root,root) %{_bindir}/wmc
523 %attr(755,root,root) %{_bindir}/wrc
524 # no shared variants, so not separated
525 %{_libdir}/wine/%{winelib}-unix/lib*.a
526 %{_libdir}/wine/%{winelib}-windows/lib*.a
527 %{_includedir}/wine
528 %{_mandir}/man1/widl.1*
529 %{_mandir}/man1/winebuild.1*
530 %{_mandir}/man1/winecpp.1*
531 %{_mandir}/man1/winedump.1*
532 %{_mandir}/man1/winegcc.1*
533 %{_mandir}/man1/wineg++.1*
534 %{_mandir}/man1/winemaker.1*
535 %lang(de) %{_mandir}/de/man1/winemaker.1*
536 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
537 %{_mandir}/man1/wmc.1*
538 %{_mandir}/man1/wrc.1*
539 %{_aclocaldir}/*.m4
540
541 %if %{with capi}
542 %files dll-capi
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/capi2032.dll
545 %attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/capi2032.so
546 %endif
547
548 %files dll-d3d
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d8.dll
551 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d8thk.dll
552 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d9.dll
553 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d10*.dll
554 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d11.dll
555 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/wined3d.dll
556 %attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/wined3d.dll.so
557
558 %files dll-gl
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/glu32.dll
561 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/opengl32.dll
562
563 %if %{with sane}
564 %files dll-twain
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/sane.so
567 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/twain*.dll
568 %ifarch %{ix86}
569 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/twain*.dll16
570 %endif
571 %endif
572
573 %if %{with ldap}
574 %files dll-ldap
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/wldap*.so
577 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/wldap*.dll
578 %endif
579
580 %if %{with alsa}
581 %files drv-alsa
582 %defattr(644,root,root,755)
583 %attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/winealsa.drv.so
584 %endif
585
586 # additional dependencies in *.so not separated (yet?) from main package
587 #   ddraw.dll.so,winex11.drv.so depend on X11 libs
588 #   ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.107383 seconds and 3 git commands to generate.