]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- clang and lld are required if not using crossgcc
[packages/wine.git] / wine.spec
1 #
2 # todo:
3 # libvkd3d https://wiki.winehq.org/Vkd3d
4 #
5 # Conditional build:
6 %bcond_without  alsa            # don't build ALSA mm driver
7 %bcond_with     capi            # don't build CAPI 2.0 (ISDN) support
8 %bcond_without  gstreamer       # don't build GStreamer filters support
9 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
10 %bcond_without  ldap            # don't build LDAP DLL
11 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
12 %bcond_without  netapi          # don't use the Samba NetAPI library
13 #
14 # NOTE: wine detects the following SONAMES for dlopen at build time:
15 #   libGL (winex11.drv.so)
16 #   libOSMesa (gdi32.dll.so)
17 #   libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
18 #   libcapi20 (capi2032.dll.so)
19 #   libcups (winspool.drv.so)
20 #   libdbus (mountmgr.sys.so)
21 #   libfontconfig (gdi32.dll.so)
22 #   libfreetype (gdi32.dll.so)
23 #   libgnutls (secur32.dll.so)
24 #   libncurses (kernel32.dll.so)
25 #   libodbc (odbc32.dll.so)
26 #   libsane (sane.ds.so)
27 #   libtiff (windowscodecs.dll.so)
28 # thus requires rebuild after change of any of the above.
29
30 # library qualifier in rpm generated deps
31 %ifarch %{x8664} ia64 ppc64 s390x sparc64
32 %define libqual ()(64bit)
33 %else
34 %define libqual %{nil}
35 %endif
36
37 %ifarch %{x8664}
38 %define winelib x86_64
39 %else
40 %define winelib i386
41 %endif
42
43 %define         gecko_ver       2.47.2
44 Summary:        Program that lets you launch Win applications
45 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
46 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
47 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
48 Name:           wine
49 Version:        7.6
50 Release:        1
51 Epoch:          1
52 License:        LGPL
53 Group:          Applications/Emulators
54 Source0:        https://dl.winehq.org/wine/source/7.x/%{name}-%{version}.tar.xz
55 # Source0-md5:  2a15c22b7a7f56503291381a9f608ecb
56 Source1:        https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86.msi
57 # Source1-md5:  e0a26e37397961b2c7f624575590ef66
58 Source2:        https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86_64.msi
59 # Source2-md5:  ff7168b08fa901516fbaa8a66aa3cee6
60 Source3:        %{name}-uninstaller.desktop
61 Patch0:         %{name}-gphoto2_bool.patch
62 Patch1:         %{name}-makedep.patch
63 Patch2:         %{name}-ncurses.patch
64 Patch4:         %{name}-disable-valgrind.patch
65 Patch5:         %{name}-ca_certificates.patch
66 Patch6:         desktop.patch
67 Patch7:         %{name}-wine64_man.patch
68 URL:            http://www.winehq.org/
69 BuildRequires:  Mesa-libOSMesa-devel
70 BuildRequires:  OpenAL-devel >= 1.1
71 BuildRequires:  OpenCL-devel
72 BuildRequires:  OpenGL-GLU-devel
73 BuildRequires:  SDL2-devel
74 %{?with_alsa:BuildRequires:     alsa-lib-devel}
75 %{?with_arts:BuildRequires:     artsc-devel}
76 BuildRequires:  autoconf >= 2.62
77 BuildRequires:  automake
78 BuildRequires:  bison
79 BuildRequires:  clang
80 %{?with_capi:BuildRequires:     capi4k-utils-devel}
81 %{?with_cups:BuildRequires:     cups-devel}
82 BuildRequires:  dbus-devel
83 BuildRequires:  flex >= 2.5.33
84 BuildRequires:  fontconfig-devel
85 BuildRequires:  freetype-devel >= 2.0.5
86 BuildRequires:  gettext-devel
87 %ifarch %{x8664}
88 BuildRequires:  gcc >= 6:4.4
89 %endif
90 BuildRequires:  gettext-tools
91 BuildRequires:  gnutls-devel
92 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 1.0}
93 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-base-devel >= 1.0}
94 # for icotool used in build
95 BuildRequires:  icoutils >= 0.29.0
96 BuildRequires:  lcms2-devel >= 2
97 BuildRequires:  libcap-devel
98 BuildRequires:  libglvnd-libEGL-devel
99 BuildRequires:  libgphoto2-devel
100 BuildRequires:  libpcap-devel
101 BuildRequires:  libv4l-devel
102 BuildRequires:  lld
103 %{?with_ldap:BuildRequires:     openldap-devel}
104 BuildRequires:  pkgconfig
105 BuildRequires:  pulseaudio-devel
106 BuildRequires:  samba-devel
107 %{?with_sane:BuildRequires:     sane-backends-devel}
108 BuildRequires:  xorg-lib-libX11-devel
109 BuildRequires:  xorg-lib-libXcomposite-devel
110 BuildRequires:  xorg-lib-libXcursor-devel
111 BuildRequires:  xorg-lib-libXext-devel
112 BuildRequires:  xorg-lib-libXi-devel
113 BuildRequires:  xorg-lib-libXinerama-devel
114 BuildRequires:  xorg-lib-libXrandr-devel
115 BuildRequires:  xorg-lib-libXrender-devel
116 BuildRequires:  xorg-lib-libXxf86vm-devel
117 BuildConflicts: crossmingw32-gcc
118 BuildConflicts: crossmingw64-gcc
119 Requires:       libfreetype.so.6%{libqual}
120 Requires:       libpng16.so.16%{libqual}
121 Requires(post): /sbin/ldconfig
122 Suggests:       binfmt-detector
123 Suggests:       ca-certificates
124 Suggests:       cabextract
125 Conflicts:      ca-certificates < 20080809-4
126 # for printing needs lpr
127 Suggests:       cups-clients
128 # for winelauncher
129 Suggests:       xorg-app-xmessage
130 # for ntlm_auth
131 Suggests:       samba-common >= 1:3.0.25
132 # link to wine/ntdll.dll.so, without any SONAME
133 Provides:       libntdll.dll.so
134 Obsoletes:      wine-doc-pdf
135 Obsoletes:      wine-drv-arts
136 Obsoletes:      wine-drv-jack
137 Obsoletes:      wine-drv-nas
138 ExclusiveArch:  %{ix86} %{x8664} arm
139 ExcludeArch:    i386
140 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
141
142 %define         no_install_post_strip   1
143 %define         _noautoprov     elf\\\\(buildid\\\\)
144
145 %define         _winedir                %{_datadir}/%{name}
146
147 %description
148 Wine is a program which allows running Microsoft Windows programs
149 (including DOS, Windows 3.x and Win32 executables) on Unix. It
150 consists of a program loader which loads and executes a Microsoft
151 Windows binary, and a library that implements Windows API calls using
152 their Unix or X11 equivalents. The library may also be used for
153 porting Win32 code into native Unix executables.
154
155 %description -l es.UTF-8
156 Ejecuta programas Windows en Linux.
157
158 %description -l pl.UTF-8
159 Wine jest programem dzięki któremu można uruchamiać programy napisane
160 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
161 loadera, który pozwala wczytywać i uruchamiać programy w formacie
162 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
163 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
164 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
165
166 %description -l pt_BR.UTF-8
167 O Wine é um programa que permite rodar programas MS-Windows no X11.
168 Ele consiste de um carregador de programa, que carrega e executa um
169 binário MS-Windows, e de uma biblioteca de emulação que traduz as
170 chamadas da API para as equivalentes Unix/X11.
171
172 %package devel
173 Summary:        Wine - header files
174 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
175 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
176 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
177 Group:          Development/Libraries
178 Requires:       %{name} = %{epoch}:%{version}-%{release}
179
180 %description devel
181 Wine - header files.
182
183 %description devel -l es.UTF-8
184 Biblioteca de desarrollo de wine.
185
186 %description devel -l pl.UTF-8
187 Wine - pliki nagłówkowe.
188
189 %description devel -l pt_BR.UTF-8
190 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
191 WINE.
192
193 %package programs
194 Summary:        Wine - programs
195 Summary(pl.UTF-8):      Wine - programy
196 Group:          Applications
197 Requires:       %{name} = %{epoch}:%{version}-%{release}
198
199 %description programs
200 Wine - programs.
201
202 %description programs -l pl.UTF-8
203 Wine - programy.
204
205 %package dll-capi
206 Summary:        CAPI 2.0 (ISDN) implementation DLLs for Wine
207 Summary(pl.UTF-8):      Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
208 Group:          Applications/Emulators
209 Requires:       %{name} = %{epoch}:%{version}-%{release}
210
211 %description dll-capi
212 CAPI 2.0 (ISDN) implementation DLLs for Wine.
213
214 %description dll-capi -l pl.UTF-8
215 Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
216
217 %package dll-d3d
218 Summary:        Direct3D implementation DLLs for Wine
219 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
220 Group:          Applications/Emulators
221 Requires:       %{name} = %{epoch}:%{version}-%{release}
222 Requires:       OpenGL
223
224 %description dll-d3d
225 Direct3D implementation DLLs for Wine (through OpenGL).
226
227 %description dll-d3d -l pl.UTF-8
228 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
229
230 %package dll-gl
231 Summary:        OpenGL implementation DLLs for Wine
232 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
233 Group:          Applications/Emulators
234 Requires:       %{name} = %{epoch}:%{version}-%{release}
235 Requires:       OpenGL
236
237 %description dll-gl
238 OpenGL implementation DLLs for Wine.
239
240 %description dll-gl -l pl.UTF-8
241 Biblioteki DLL z implementacją OpenGL dla Wine.
242
243 %package dll-twain
244 Summary:        TWAIN implementation DLL for Wine
245 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
246 Group:          Applications/Emulators
247 Requires:       %{name} = %{epoch}:%{version}-%{release}
248
249 %description dll-twain
250 TWAIN implementation DLL for Wine (through SANE).
251
252 %description dll-twain -l pl.UTF-8
253 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
254
255 %package dll-ldap
256 Summary:        Win32 LDAP API DLL for Wine
257 Summary(pl.UTF-8):      Biblioteka DLL z implementacją API Win32 LDAP dla Wine
258 Group:          Applications/Emulators
259 Requires:       %{name} = %{epoch}:%{version}-%{release}
260
261 %description dll-ldap
262 Lightweight Directory Access Protocol Library for Wine.
263
264 %description dll-ldap -l pl.UTF-8
265 Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
266
267 %package drv-alsa
268 Summary:        ALSA driver for WINE mm.dll implementation
269 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
270 Group:          Applications/Emulators
271 Requires:       %{name} = %{epoch}:%{version}-%{release}
272
273 %description drv-alsa
274 ALSA driver for WINE mm.dll (multimedia system) implementation.
275
276 %description drv-alsa -l pl.UTF-8
277 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
278
279 %prep
280 %setup -q
281 #%patch0 -p1
282 %patch1 -p1
283 %patch4 -p1
284 %patch5 -p1
285 %patch6 -p1
286 %ifarch %{x8664}
287 %patch7 -p1
288 %endif
289
290 %build
291
292 #workaround for icon extraction error.
293 icotool -x -o . dlls/user32/resources/oic_winlogo.ico
294 mv -f oic_winlogo_*32x32x32.png %{name}.png
295 rm -f oic_winlogo_*.png
296
297 %{__autoconf}
298 %{__autoheader}
299 %configure \
300 %ifarch %{x8664}
301         --enable-win64 \
302 %endif
303         --with-alsa%{!?with_alsa:=no} \
304         --with-capi%{!?with_capi:=no} \
305         --with-coreaudio \
306         --with-cups%{!?with_cups:=no} \
307         --with-dbus \
308         --with-fontconfig \
309         --with-freetype \
310         --with-gphoto \
311         --with-gnutls \
312         %{__with_without gstreamer} \
313         --with-ldap%{!?with_ldap:=no} \
314         --with%{!?with_netapi:out}-netapi \
315         --with-openal \
316         --with-opencl \
317         --with-opengl \
318         --with-osmesa \
319         --with-pcap \
320         --with-pthread \
321         --with-pulse \
322         --with%{!?with_sane:out}-sane \
323         --with-xcomposite \
324         --with-xcursor \
325         --with-xinerama \
326         --with-xinput \
327         --with-xinput2 \
328         --with-xrandr \
329         --with-xrender \
330         --with-xshape \
331         --with-xshm \
332         --with-xxf86vm \
333         --with-x
334
335 %{__make} depend
336 %{__make}
337
338 %install
339 rm -rf $RPM_BUILD_ROOT
340 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
341 %{__make} install \
342         DESTDIR=$RPM_BUILD_ROOT
343
344 install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
345 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
346
347 install -d \
348         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
349         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
350         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
351         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
352         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
353
354 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
355 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
356 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
357
358 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
359 [mci]
360 cdaudio=mcicda.drv
361 sequencer=mciseq.drv
362 waveaudio=mciwave.drv
363 avivideo=mciavi.drv
364 videodisc=mcipionr.drv
365 vcr=mciviscd.drv
366 MPEGVideo=mciqtz.drv
367 EOF
368
369 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
370
371 dir=$(pwd)
372 > files.so
373 > files.programs
374
375 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
376 for p in $programs; do
377         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
378         echo "%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/$p.exe" >> files.programs
379         echo "%{_mandir}/man1/$p.1*" >> files.programs
380 #       grep -v "$p\.exe\.so$" files.so > files.so.
381 #       mv -f files.so. files.so
382 done
383
384 for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
385         mv "$dir" "${dir%.UTF-8}"
386 done
387
388 %ifarch %{x8664}
389 cp -p loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
390 for lang in de fr pl ; do
391 install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
392 cp -p loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
393 done
394 %else
395 cp -p loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
396 for lang in de fr pl ; do
397 install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
398 cp -p loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
399 done
400 %endif
401
402 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
403 %ifnarch %{x8664}
404 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
405 %else
406 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
407 %endif
408
409 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
410 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
411 cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
412
413 %clean
414 rm -rf $RPM_BUILD_ROOT
415
416 %post
417 /sbin/ldconfig
418 %update_desktop_database
419
420 %postun -p /sbin/ldconfig
421
422 %triggerpostun -- wine < 1:0.9.12-1.9
423 rm -f /var/lock/subsys/wine
424 if [ -x /sbin/chkconfig ]; then
425         /sbin/chkconfig --del wine
426 fi
427
428 %files
429 %defattr(644,root,root,755)
430 %doc README AUTHORS ANNOUNCE
431 %lang(de) %doc documentation/README.de
432 %lang(es) %doc documentation/README.es
433 %lang(fr) %doc documentation/README.fr
434 %lang(hu) %doc documentation/README.hu
435 %lang(it) %doc documentation/README.it
436 %lang(ko) %doc documentation/README.ko
437 %lang(nb) %doc documentation/README.no
438 %lang(pt) %doc documentation/README.pt
439 %lang(pt_BR) %doc documentation/README.pt_br
440 %lang(ru) %doc documentation/README.ru
441 %lang(sv) %doc documentation/README.sv
442 %lang(tr) %doc documentation/README.tr
443 %attr(755,root,root) %{_bindir}/msidb
444 %attr(755,root,root) %{_bindir}/msiexec
445 %ifnarch %{x8664}
446 %attr(755,root,root) %{_bindir}/wine
447 %else
448 %attr(755,root,root) %{_bindir}/wine64
449 %endif
450 %attr(755,root,root) %{_bindir}/wineboot
451 %attr(755,root,root) %{_bindir}/winedbg
452 %attr(755,root,root) %{_bindir}/winecfg
453 %ifnarch %{x8664}
454 %attr(755,root,root) %{_bindir}/wine-preloader
455 %else
456 %attr(755,root,root) %{_bindir}/wine64-preloader
457 %endif
458 %attr(755,root,root) %{_bindir}/wineserver
459 %dir %{_libdir}/wine
460 %dir %{_libdir}/wine/%{winelib}-unix
461 %attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/*.so*
462 %dir %{_libdir}/wine/%{winelib}-windows
463 %{_libdir}/wine/%{winelib}-windows/*.acm
464 %{_libdir}/wine/%{winelib}-windows/*.ax
465 %{_libdir}/wine/%{winelib}-windows/*.com
466 %{_libdir}/wine/%{winelib}-windows/*.cpl
467 %{_libdir}/wine/%{winelib}-windows/*.dll
468 %ifarch %{ix86}
469 %{_libdir}/wine/%{winelib}-windows/*.dll16
470 %endif
471 %{_libdir}/wine/%{winelib}-windows/*.drv
472 %ifarch %{ix86}
473 %{_libdir}/wine/%{winelib}-windows/*.drv16
474 %endif
475 %{_libdir}/wine/%{winelib}-windows/*.ds
476 %{_libdir}/wine/%{winelib}-windows/*.exe
477 %ifarch %{ix86}
478 %{_libdir}/wine/%{winelib}-windows/*.exe16
479 %{_libdir}/wine/%{winelib}-windows/*.mod16
480 %endif
481 %{_libdir}/wine/%{winelib}-windows/*.msstyles
482 %{_libdir}/wine/%{winelib}-windows/*.ocx
483 %{_libdir}/wine/%{winelib}-windows/*.sys
484 %{_libdir}/wine/%{winelib}-windows/*.tlb
485 %ifarch %{ix86}
486 %{_libdir}/wine/%{winelib}-windows/*.vxd
487 %endif
488 %ifnarch %{x8664}
489 %{_mandir}/man1/wine.1*
490 %lang(de) %{_mandir}/de/man1/wine.1*
491 %lang(fr) %{_mandir}/fr/man1/wine.1*
492 %lang(pl) %{_mandir}/pl/man1/wine.1*
493 %else
494 %{_mandir}/man1/wine64.1*
495 %lang(de) %{_mandir}/de/man1/wine64.1*
496 %lang(fr) %{_mandir}/fr/man1/wine64.1*
497 %lang(pl) %{_mandir}/pl/man1/wine64.1*
498 %endif
499 %{_mandir}/man1/msiexec.1*
500 %{_mandir}/man1/wineboot.1*
501
502 %{_mandir}/man1/winecfg.1*
503 %{_mandir}/man1/winedbg.1*
504 %{_mandir}/man1/wineserver.1*
505 %lang(de) %{_mandir}/de/man1/wineserver.1*
506 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
507 %{_winedir}
508 %{_desktopdir}/wine.desktop
509 %{_desktopdir}/wine-uninstaller.desktop
510 %{_pixmapsdir}/%{name}.png
511
512 %files programs -f files.programs
513 %defattr(644,root,root,755)
514
515 %files devel
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{_bindir}/sfnt2fon
518 %attr(755,root,root) %{_bindir}/function_grep.pl
519 %attr(755,root,root) %{_bindir}/widl
520 %attr(755,root,root) %{_bindir}/winebuild
521 %attr(755,root,root) %{_bindir}/winedump
522 %attr(755,root,root) %{_bindir}/wineg++
523 %attr(755,root,root) %{_bindir}/winegcc
524 %attr(755,root,root) %{_bindir}/winemaker
525 %attr(755,root,root) %{_bindir}/winecpp
526 %attr(755,root,root) %{_bindir}/wmc
527 %attr(755,root,root) %{_bindir}/wrc
528 # no shared variants, so not separated
529 %{_libdir}/wine/%{winelib}-unix/lib*.a
530 #%{_libdir}/wine/%{winelib}-windows/lib*.a
531 %{_includedir}/wine
532 %{_mandir}/man1/widl.1*
533 %{_mandir}/man1/winebuild.1*
534 %{_mandir}/man1/winecpp.1*
535 %{_mandir}/man1/winedump.1*
536 %{_mandir}/man1/winegcc.1*
537 %{_mandir}/man1/wineg++.1*
538 %{_mandir}/man1/winemaker.1*
539 %lang(de) %{_mandir}/de/man1/winemaker.1*
540 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
541 %{_mandir}/man1/wmc.1*
542 %{_mandir}/man1/wrc.1*
543 %{_aclocaldir}/*.m4
544
545 %if %{with capi}
546 %files dll-capi
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/capi2032.dll
549 %attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/capi2032.so
550 %endif
551
552 %files dll-d3d
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d8.dll
555 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d8thk.dll
556 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d9.dll
557 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d10*.dll
558 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d11.dll
559 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/wined3d.dll
560 %attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/wined3d.dll.so
561
562 %files dll-gl
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/glu32.dll
565 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/opengl32.dll
566
567 %if %{with sane}
568 %files dll-twain
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/sane.so
571 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/twain*.dll
572 %ifarch %{ix86}
573 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/twain*.dll16
574 %endif
575 %endif
576
577 %if %{with ldap}
578 %files dll-ldap
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/wldap*.so
581 %attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/wldap*.dll
582 %endif
583
584 %if %{with alsa}
585 %files drv-alsa
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/winealsa.drv.so
588 %endif
589
590 # additional dependencies in *.so not separated (yet?) from main package
591 #   ddraw.dll.so,winex11.drv.so depend on X11 libs
592 #   ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.114791 seconds and 3 git commands to generate.