]> git.pld-linux.org Git - packages/wine.git/blame_incremental - wine.spec
- updated to the currently stable 1.4 (taken from DEVEL)
[packages/wine.git] / wine.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without alsa # don't build ALSA mm driver
4%bcond_without capi # don't build CAPI 2.0 (ISDN) support
5%bcond_without gstreamer # don't build GStreamer filters support
6%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
7%bcond_without ldap # don't build LDAP DLL
8%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
9#
10# NOTE: wine detects the following SONAMES for dlopen at build time:
11# libcrypto,libssl (wininet.dll)
12# libcups (winspool.dll.so,wineps.dll.so)
13# libcurses/libncurses (wineconsole program)
14# libfontconfig (gdi32.dll.so)
15# libfreetype (wineps.dll.so,gdi32.dll.so)
16# libGL (x11drv.dll.so,ddraw.dll.so)
17# libX11, libXext, libXi, libXrender (x11drv.dll.so)
18# thus requires rebuild after change of any of the above.
19#
20%define gecko_ver 1.4
21Summary: Program that lets you launch Win applications
22Summary(es.UTF-8): Ejecuta programas Windows en Linux
23Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
24Summary(pt_BR.UTF-8): Executa programas Windows no Linux
25Name: wine
26Version: 1.4
27Release: 1
28Epoch: 1
29License: LGPL
30Group: Applications/Emulators
31Source0: http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
32# Source0-md5: 6594ab86a4b1fb2c09dadfb4ea7fc4af
33Source1: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
34# Source1-md5: 700aaa08724be1992cffed7b87e79a44
35Source2: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
36# Source2-md5: 7b4811f667fd01d300fdff68420a9c72
37Source3: %{name}-uninstaller.desktop
38Patch0: %{name}-fontcache.patch
39Patch1: %{name}-makedep.patch
40Patch2: %{name}-ncurses.patch
41Patch4: %{name}-disable-valgrind.patch
42Patch5: %{name}-ca_certificates.patch
43Patch6: %{name}-manpaths.patch
44Patch7: desktop.patch
45URL: http://www.winehq.org/
46BuildRequires: OpenAL-devel >= 1.1
47BuildRequires: OpenGL-GLU-devel
48%{?with_alsa:BuildRequires: alsa-lib-devel}
49%{?with_arts:BuildRequires: artsc-devel}
50BuildRequires: autoconf
51BuildRequires: automake
52BuildRequires: bison
53%{?with_capi:BuildRequires: capi4k-utils-devel}
54%{?with_cups:BuildRequires: cups-devel}
55BuildRequires: docbook-dtd31-sgml
56BuildRequires: docbook-utils
57BuildRequires: flex
58BuildRequires: fontconfig-devel
59BuildRequires: fontforge
60BuildRequires: freetype-devel >= 2.0.5
61BuildRequires: gettext-devel
62BuildRequires: giflib-devel
63BuildRequires: gnutls-devel
64%{?with_gstreamer:BuildRequires: gstreamer-plugins-base-devel}
65BuildRequires: icoutils
66BuildRequires: lcms-devel
67BuildRequires: libgphoto2-devel
68BuildRequires: libgsm-devel
69BuildRequires: libjpeg-devel
70BuildRequires: libmpg123-devel >= 1.5.0
71BuildRequires: libtool
72BuildRequires: libv4l-devel
73BuildRequires: libxslt-devel
74BuildRequires: ncurses-devel
75# db2* failed previously - probably openjade or opensp bug
76BuildRequires: openjade >= 1:1.3.3-0.pre1
77%{?with_ldap:BuildRequires: openldap-devel}
78BuildRequires: opensp >= 1:1.5.1
79BuildRequires: openssl-devel >= 0.9.7d
80BuildRequires: pkgconfig
81BuildRequires: prelink
82%{?with_sane:BuildRequires: sane-backends-devel}
83BuildRequires: unixODBC-devel >= 2.2.12-2
84#BuildRequires: valgrind
85BuildRequires: xorg-lib-libXcomposite-devel
86BuildRequires: xorg-lib-libXcursor-devel
87BuildRequires: xorg-lib-libXi-devel
88BuildRequires: xorg-lib-libXinerama-devel
89BuildRequires: xorg-lib-libXmu-devel
90BuildRequires: xorg-lib-libXrandr-devel
91BuildRequires: xorg-lib-libXrender-devel
92BuildRequires: xorg-lib-libXxf86dga-devel
93BuildRequires: xorg-lib-libXxf86vm-devel
94Requires: libfreetype.so.6
95Requires(post): /sbin/ldconfig
96Suggests: binfmt-detector
97Suggests: ca-certificates
98Suggests: cabextract
99Conflicts: ca-certificates < 20080809-4
100# for printing needs lpr
101Suggests: cups-clients
102# for winelauncher
103Suggests: xorg-app-xmessage
104# for ntlm_auth
105Suggests: samba-common >= 1:3.0.25
106# link to wine/ntdll.dll.so, without any SONAME
107Provides: libntdll.dll.so
108Obsoletes: wine-doc-pdf
109Obsoletes: wine-drv-arts
110Obsoletes: wine-drv-jack
111Obsoletes: wine-drv-nas
112ExclusiveArch: %{ix86} %{x8664}
113ExcludeArch: i386
114BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
115
116%define _noautoreqdep libGL.so.1 libGLU.so.1
117%define no_install_post_strip 1
118
119%define _winedir %{_datadir}/%{name}
120
121%define getsoname() %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
122
123%undefine debuginfocflags
124
125%description
126Wine is a program which allows running Microsoft Windows programs
127(including DOS, Windows 3.x and Win32 executables) on Unix. It
128consists of a program loader which loads and executes a Microsoft
129Windows binary, and a library that implements Windows API calls using
130their Unix or X11 equivalents. The library may also be used for
131porting Win32 code into native Unix executables.
132
133%description -l es.UTF-8
134Ejecuta programas Windows en Linux.
135
136%description -l pl.UTF-8
137Wine jest programem dzięki któremu można uruchamiać programy napisane
138dla Microsoft Windows pod systemami uniksowymi. Składa się on z
139loadera, który pozwala wczytywać i uruchamiać programy w formacie
140Microsoft Windows, oraz z biblioteki, która implementuje API Windows
141przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
142także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
143
144%description -l pt_BR.UTF-8
145O Wine é um programa que permite rodar programas MS-Windows no X11.
146Ele consiste de um carregador de programa, que carrega e executa um
147binário MS-Windows, e de uma biblioteca de emulação que traduz as
148chamadas da API para as equivalentes Unix/X11.
149
150%package devel
151Summary: Wine - header files
152Summary(es.UTF-8): Biblioteca de desarrollo de wine
153Summary(pl.UTF-8): Wine - pliki nagłowkowe
154Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
155Group: Development/Libraries
156Requires: %{name} = %{epoch}:%{version}-%{release}
157
158%description devel
159Wine - header files.
160
161%description devel -l es.UTF-8
162Biblioteca de desarrollo de wine.
163
164%description devel -l pl.UTF-8
165Wine - pliki nagłówkowe.
166
167%description devel -l pt_BR.UTF-8
168Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
169WINE.
170
171%package programs
172Summary: Wine - programs
173Summary(pl.UTF-8): Wine - programy
174Group: Applications
175Requires: %{name} = %{epoch}:%{version}-%{release}
176
177%description programs
178Wine - programs.
179
180%description programs -l pl.UTF-8
181Wine - programy.
182
183%package dll-capi
184Summary: CAPI 2.0 (ISDN) implementation DLLs for Wine
185Summary(pl.UTF-8): Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
186Group: Applications/Emulators
187Requires: %{name} = %{epoch}:%{version}-%{release}
188
189%description dll-capi
190CAPI 2.0 (ISDN) implementation DLLs for Wine (through OpenGL).
191
192%description dll-capi -l pl.UTF-8
193Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine (poprzez
194OpenGL).
195
196%package dll-d3d
197Summary: Direct3D implementation DLLs for Wine
198Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
199Group: Applications/Emulators
200Requires: %{name} = %{epoch}:%{version}-%{release}
201Requires: OpenGL
202
203%description dll-d3d
204Direct3D implementation DLLs for Wine (through OpenGL).
205
206%description dll-d3d -l pl.UTF-8
207Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
208
209%package dll-gl
210Summary: OpenGL implementation DLLs for Wine
211Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
212Group: Applications/Emulators
213Requires: %{name} = %{epoch}:%{version}-%{release}
214Requires: OpenGL
215
216%description dll-gl
217OpenGL implementation DLLs for Wine.
218
219%description dll-gl -l pl.UTF-8
220Biblioteki DLL z implementacją OpenGL dla Wine.
221
222%package dll-twain
223Summary: TWAIN implementation DLL for Wine
224Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
225Group: Applications/Emulators
226Requires: %{name} = %{epoch}:%{version}-%{release}
227
228%description dll-twain
229TWAIN implementation DLL for Wine (through SANE).
230
231%description dll-twain -l pl.UTF-8
232Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
233
234%package dll-ldap
235Summary: Win32 LDAP API DLL for Wine.
236Group: Applications/Emulators
237Requires: %{name} = %{epoch}:%{version}-%{release}
238
239%description dll-ldap
240Lightweight Directory Access Protocol Library.
241
242%package drv-alsa
243Summary: ALSA driver for WINE mm.dll implementation
244Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
245Group: Applications/Emulators
246Requires: %{name} = %{epoch}:%{version}-%{release}
247
248%description drv-alsa
249ALSA driver for WINE mm.dll (multimedia system) implementation.
250
251%description drv-alsa -l pl.UTF-8
252Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
253
254%prep
255%setup -q -n %{name}-%{version}
256%patch0 -p1
257%patch1 -p1
258%patch2 -p1
259%patch4 -p1
260%patch5 -p1
261%patch6 -p1
262%patch7 -p1
263
264%build
265icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
266mv -f oic_winlogo_*.png %{name}.png
267
268%{__autoconf}
269%{__autoheader}
270%configure \
271%ifarch %{x8664}
272 --enable-win64 \
273%endif
274 --with%{!?with_alsa:out}-alsa \
275 --with%{!?with_capi:out}-capi \
276 --with-cms \
277 --with-coreaudio \
278 --with%{!?with_cups:out}-cups \
279 --with-curses \
280 --with-fontconfig \
281 --with-freetype \
282 --with-glu \
283 --with-gnutls \
284 --with-gphoto \
285 --with-gsm \
286 --with%{!?with_gstreamer:out}-gstreamer \
287 --with-jpeg \
288 --with%{!?with_ldap:out}-ldap \
289 --with-mpg123 \
290 --with-opengl \
291 --with-openssl \
292 --with-oss \
293 --with-png \
294 --with-pthread \
295 --with%{!?with_sane:out}-sane \
296 --with-xcomposite \
297 --with-xcursor \
298 --with-xinerama \
299 --with-xinput \
300 --with-xml \
301 --with-xrandr \
302 --with-xrender \
303 --with-xshape \
304 --with-xshm \
305 --with-xslt \
306 --with-xxf86vm \
307 --with-x
308%{__make} depend
309%{__make}
310
311%install
312rm -rf $RPM_BUILD_ROOT
313install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
314%{__make} install \
315 DESTDIR=$RPM_BUILD_ROOT
316
317install -p tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
318cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
319
320install -d \
321 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
322 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
323 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
324 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
325 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
326
327touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
328touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
329touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
330
331cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
332[mci]
333cdaudio=mcicda.drv
334sequencer=mciseq.drv
335waveaudio=mciwave.drv
336avivideo=mciavi.drv
337videodisc=mcipionr.drv
338vcr=mciviscd.drv
339MPEGVideo=mciqtz.drv
340EOF
341
342%if %{?debug:0}%{!?debug:1}
343echo "Strip executable binaries and shared object files."
344filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
345elfexelist=`echo $filelist | xargs -r file | \
346 awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
347elfsharedlist=`echo $filelist | xargs -r file | \
348 awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
349if [ -n "$elfexelist" ]; then \
350 strip -R .note -R .comment $elfexelist
351fi
352if [ -n "$elfsharedlist" ]; then
353 strip --strip-unneeded -R .note -R .comment $elfsharedlist
354fi
355%endif
356
357# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
358
359dir=$(pwd)
360> files.so
361> files.programs
362cd $RPM_BUILD_ROOT%{_libdir}/wine
363for f in *.so; do
364 case $f in
365 d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wldap32.dll.so)
366 ;;
367 *)
368 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
369 esac
370done
371cd -
372
373programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
374for p in $programs; do
375 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
376 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
377 echo "%{_mandir}/man1/$p.1*" >> files.programs
378 grep -v "$p\.exe\.so$" files.so > files.so.
379 mv -f files.so. files.so
380done
381
382install -d $RPM_BUILD_ROOT%{_winedir}/gecko
383%ifnarch %{x8664}
384cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
385%else
386cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
387%endif
388
389install -d $RPM_BUILD_ROOT%{_pixmapsdir}
390cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
391cp -a %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
392
393%clean
394rm -rf $RPM_BUILD_ROOT
395
396%post
397 /sbin/ldconfig
398%update_desktop_database
399
400%postun -p /sbin/ldconfig
401
402%triggerpostun -- wine < 1:0.9.12-1.9
403rm -f /var/lock/subsys/wine
404if [ -x /sbin/chkconfig ]; then
405 /sbin/chkconfig --del wine
406fi
407
408%files -f files.so
409%defattr(644,root,root,755)
410%doc README documentation/ChangeLog* AUTHORS ANNOUNCE
411%lang(de) %doc documentation/README.de
412%lang(es) %doc documentation/README.es
413%lang(fr) %doc documentation/README.fr
414%lang(hu) %doc documentation/README.hu
415%lang(it) %doc documentation/README.it
416%lang(ko) %doc documentation/README.ko
417%lang(nb) %doc documentation/README.no
418%lang(pt) %doc documentation/README.pt
419%lang(pt_BR) %doc documentation/README.pt_br
420%lang(ru) %doc documentation/README.ru
421%lang(sv) %doc documentation/README.sv
422%lang(tr) %doc documentation/README.tr
423%attr(755,root,root) %{_bindir}/msiexec
424%ifnarch %{x8664}
425%attr(755,root,root) %{_bindir}/wine
426%else
427%attr(755,root,root) %{_bindir}/wine64
428%endif
429%attr(755,root,root) %{_bindir}/wineboot
430%attr(755,root,root) %{_bindir}/winedbg
431%attr(755,root,root) %{_bindir}/winecfg
432%ifnarch %{x8664}
433%attr(755,root,root) %{_bindir}/wine-preloader
434%else
435%attr(755,root,root) %{_bindir}/wine64-preloader
436%endif
437%attr(755,root,root) %{_bindir}/wineserver
438%attr(755,root,root) %{_libdir}/*.so*
439%dir %{_libdir}/wine
440%dir %{_libdir}/wine/fakedlls
441%{_libdir}/wine/fakedlls/*.acm
442%{_libdir}/wine/fakedlls/*.cpl
443%{_libdir}/wine/fakedlls/*.dll
444%ifarch %{ix86}
445%{_libdir}/wine/fakedlls/*.dll16
446%endif
447%{_libdir}/wine/fakedlls/*.drv
448%ifarch %{ix86}
449%{_libdir}/wine/fakedlls/*.drv16
450%endif
451%{_libdir}/wine/fakedlls/*.ds
452%{_libdir}/wine/fakedlls/*.exe
453%ifarch %{ix86}
454%{_libdir}/wine/fakedlls/*.exe16
455%{_libdir}/wine/fakedlls/*.mod16
456%endif
457%{_libdir}/wine/fakedlls/*.ocx
458%{_libdir}/wine/fakedlls/*.sys
459%{_libdir}/wine/fakedlls/*.tlb
460%ifarch %{ix86}
461%{_libdir}/wine/fakedlls/*.vxd
462%endif
463%{_mandir}/man1/wine.1*
464%lang(de) %{_mandir}/de/man1/wine*.1*
465%lang(fr) %{_mandir}/fr/man1/wine*.1*
466%lang(pl) %{_mandir}/pl/man1/wine*.1*
467%{_mandir}/man1/msiexec.1*
468%{_mandir}/man1/wineboot.1*
469%{_mandir}/man1/winecfg.1*
470%{_mandir}/man1/winedbg.1*
471%{_mandir}/man1/wineserver.1*
472%{_winedir}
473%{_desktopdir}/wine.desktop
474%{_desktopdir}/wine-uninstaller.desktop
475%{_pixmapsdir}/%{name}.png
476
477%files programs -f files.programs
478%defattr(644,root,root,755)
479
480%files devel
481%defattr(644,root,root,755)
482%attr(755,root,root) %{_bindir}/fnt2bdf
483%attr(755,root,root) %{_bindir}/function_grep.pl
484%attr(755,root,root) %{_bindir}/widl
485%attr(755,root,root) %{_bindir}/winebuild
486%attr(755,root,root) %{_bindir}/winedump
487%attr(755,root,root) %{_bindir}/wineg++
488%attr(755,root,root) %{_bindir}/winegcc
489%attr(755,root,root) %{_bindir}/winemaker
490%attr(755,root,root) %{_bindir}/winecpp
491%attr(755,root,root) %{_bindir}/wmc
492%attr(755,root,root) %{_bindir}/wrc
493%{_libdir}/wine/lib*.def
494# no shared variants, so not separated
495%{_libdir}/wine/lib*.def.a
496%{_libdir}/wine/libadsiid.a
497%{_libdir}/wine/libdx*.a
498%{_libdir}/wine/libstrmbase.a
499%{_libdir}/wine/libstrmiids.a
500%{_libdir}/wine/libuuid.a
501%{_libdir}/wine/libwinecrt0.a
502%{_includedir}/wine
503%{_mandir}/man1/widl.1*
504%{_mandir}/man1/winebuild.1*
505%{_mandir}/man1/winecpp.1*
506%{_mandir}/man1/winedump.1*
507%{_mandir}/man1/winegcc.1*
508%{_mandir}/man1/wineg++.1*
509%{_mandir}/man1/winemaker.1*
510%lang(de) %{_mandir}/de/man1/winemaker.1*
511%lang(fr) %{_mandir}/fr/man1/winemaker.1*
512%{_mandir}/man1/wmc.1*
513%{_mandir}/man1/wrc.1*
514%{_aclocaldir}/*.m4
515
516%files dll-capi
517%defattr(644,root,root,755)
518%attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
519
520%files dll-d3d
521%defattr(644,root,root,755)
522%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
523%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
524%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
525
526%files dll-gl
527%defattr(644,root,root,755)
528%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
529%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
530
531%if %{with sane}
532%files dll-twain
533%defattr(644,root,root,755)
534%attr(755,root,root) %{_libdir}/wine/sane.ds.so
535%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
536%endif
537
538%if %{with ldap}
539%files dll-ldap
540%defattr(644,root,root,755)
541%attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
542%endif
543
544%if %{with alsa}
545%files drv-alsa
546%defattr(644,root,root,755)
547%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
548%endif
549
550# additional dependencies in *.so not separated (yet?) from main package
551# ddraw.dll.so,x11drv.dll.so depend on X11 libs
552# ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
553# ttydrv.dll.so depends on ncurses
This page took 0.072403 seconds and 4 git commands to generate.