]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
- clang is not needed and lld-link can't produce wined3d.dll.so
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
0be89e87
BZ
2# todo:
3# libvkd3d https://wiki.winehq.org/Vkd3d
4#
7a30e9d7 5# Conditional build:
931f130b 6%bcond_without alsa # don't build ALSA mm driver
8e674d62 7%bcond_with capi # don't build CAPI 2.0 (ISDN) support
beafc810 8%bcond_without gstreamer # don't build GStreamer filters support
16e36f25 9%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
9d6715c4 10%bcond_without ldap # don't build LDAP DLL
16e36f25 11%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
d7296a19 12%bcond_without netapi # don't use the Samba NetAPI library
7a30e9d7 13#
546bbb82 14# NOTE: wine detects the following SONAMES for dlopen at build time:
5b49e814
JB
15# libGL (winex11.drv.so)
16# libOSMesa (gdi32.dll.so)
17# libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
18# libcapi20 (capi2032.dll.so)
19# libcups (winspool.drv.so)
20# libdbus (mountmgr.sys.so)
16e36f25 21# libfontconfig (gdi32.dll.so)
5b49e814
JB
22# libfreetype (gdi32.dll.so)
23# libgnutls (secur32.dll.so)
5b49e814
JB
24# libncurses (kernel32.dll.so)
25# libodbc (odbc32.dll.so)
5b49e814
JB
26# libsane (sane.ds.so)
27# libtiff (windowscodecs.dll.so)
546bbb82 28# thus requires rebuild after change of any of the above.
db80a28e 29
4ce8abe1
ER
30# library qualifier in rpm generated deps
31%ifarch %{x8664} ia64 ppc64 s390x sparc64
32%define libqual ()(64bit)
33%else
34%define libqual %{nil}
35%endif
36
fe2412f1 37%ifarch %{x8664}
2c7f2af5
BZ
38%define winelib x86_64
39%else
40%define winelib i386
41%endif
42
3e4a4fb9 43%define gecko_ver 2.47.2
698e86e7 44Summary: Program that lets you launch Win applications
93e41e44
ER
45Summary(es.UTF-8): Ejecuta programas Windows en Linux
46Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
47Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 48Name: wine
fe2412f1
KM
49Version: 7.6
50Release: 1
46114a9a 51Epoch: 1
528c1138 52License: LGPL
5c4ec57b 53Group: Applications/Emulators
e9d09a3b 54Source0: https://dl.winehq.org/wine/source/7.x/%{name}-%{version}.tar.xz
fe2412f1 55# Source0-md5: 2a15c22b7a7f56503291381a9f608ecb
3e4a4fb9
BZ
56Source1: https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86.msi
57# Source1-md5: e0a26e37397961b2c7f624575590ef66
58Source2: https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86_64.msi
59# Source2-md5: ff7168b08fa901516fbaa8a66aa3cee6
beafc810 60Source3: %{name}-uninstaller.desktop
55061442 61Patch0: %{name}-gphoto2_bool.patch
a0ff0658 62Patch1: %{name}-makedep.patch
a4a10255 63Patch2: %{name}-ncurses.patch
8b4bf701 64Patch4: %{name}-disable-valgrind.patch
5312a936 65Patch5: %{name}-ca_certificates.patch
a26a3859
JK
66Patch6: desktop.patch
67Patch7: %{name}-wine64_man.patch
1b3d8891 68URL: http://www.winehq.org/
5b49e814 69BuildRequires: Mesa-libOSMesa-devel
0aac4f59 70BuildRequires: OpenAL-devel >= 1.1
5b49e814 71BuildRequires: OpenCL-devel
489ca66c 72BuildRequires: OpenGL-GLU-devel
fe2412f1 73BuildRequires: SDL2-devel
6547534c
KK
74%{?with_alsa:BuildRequires: alsa-lib-devel}
75%{?with_arts:BuildRequires: artsc-devel}
5b49e814 76BuildRequires: autoconf >= 2.62
c7af491d 77BuildRequires: automake
d3c41437 78BuildRequires: bison
beafc810 79%{?with_capi:BuildRequires: capi4k-utils-devel}
5715e1d1 80%{?with_cups:BuildRequires: cups-devel}
5b49e814 81BuildRequires: dbus-devel
5b49e814 82BuildRequires: flex >= 2.5.33
16e36f25 83BuildRequires: fontconfig-devel
5fc34681 84BuildRequires: freetype-devel >= 2.0.5
05596b04 85BuildRequires: gettext-devel
5b49e814
JB
86%ifarch %{x8664}
87BuildRequires: gcc >= 6:4.4
88%endif
1f0c428e 89BuildRequires: gettext-tools
c57a98fe 90BuildRequires: gnutls-devel
f73ad4b6
JP
91%{?with_gstreamer:BuildRequires: gstreamer-devel >= 1.0}
92%{?with_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 1.0}
5b49e814
JB
93# for icotool used in build
94BuildRequires: icoutils >= 0.29.0
95BuildRequires: lcms2-devel >= 2
3d0989c1 96BuildRequires: libcap-devel
fe2412f1 97BuildRequires: libglvnd-libEGL-devel
beb8121e 98BuildRequires: libgphoto2-devel
05596b04 99BuildRequires: libpcap-devel
fe2412f1 100BuildRequires: libv4l-devel
9d6715c4 101%{?with_ldap:BuildRequires: openldap-devel}
beb8121e 102BuildRequires: pkgconfig
3d0989c1 103BuildRequires: pulseaudio-devel
d7296a19 104BuildRequires: samba-devel
5715e1d1 105%{?with_sane:BuildRequires: sane-backends-devel}
5b49e814 106BuildRequires: xorg-lib-libX11-devel
beb8121e 107BuildRequires: xorg-lib-libXcomposite-devel
108BuildRequires: xorg-lib-libXcursor-devel
5b49e814 109BuildRequires: xorg-lib-libXext-devel
c66c3406 110BuildRequires: xorg-lib-libXi-devel
beb8121e 111BuildRequires: xorg-lib-libXinerama-devel
beb8121e 112BuildRequires: xorg-lib-libXrandr-devel
c66c3406 113BuildRequires: xorg-lib-libXrender-devel
c66c3406 114BuildRequires: xorg-lib-libXxf86vm-devel
d1385401
JR
115BuildConflicts: crossmingw32-gcc
116BuildConflicts: crossmingw64-gcc
117BuildConflicts: lld-link
4ce8abe1 118Requires: libfreetype.so.6%{libqual}
a85c8746 119Requires: libpng16.so.16%{libqual}
8df63af6 120Requires(post): /sbin/ldconfig
ae42c99e 121Suggests: binfmt-detector
be70b824 122Suggests: ca-certificates
beafc810 123Suggests: cabextract
a2f68044 124Conflicts: ca-certificates < 20080809-4
b3d3861d 125# for printing needs lpr
126Suggests: cups-clients
f96e197b 127# for winelauncher
3bddfbf2 128Suggests: xorg-app-xmessage
f96e197b 129# for ntlm_auth
14e95129 130Suggests: samba-common >= 1:3.0.25
52b6007b
JB
131# link to wine/ntdll.dll.so, without any SONAME
132Provides: libntdll.dll.so
7212da21 133Obsoletes: wine-doc-pdf
93b34e12 134Obsoletes: wine-drv-arts
beafc810
MM
135Obsoletes: wine-drv-jack
136Obsoletes: wine-drv-nas
5b49e814 137ExclusiveArch: %{ix86} %{x8664} arm
206eed29 138ExcludeArch: i386
0403821a 139BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 140
e8f81a0a 141%define no_install_post_strip 1
b955dc60 142%define _noautoprov elf\\\\(buildid\\\\)
e8f81a0a 143
e8f81a0a 144%define _winedir %{_datadir}/%{name}
6731627f 145
5c4ec57b 146%description
6731627f 147Wine is a program which allows running Microsoft Windows programs
a519bc4f 148(including DOS, Windows 3.x and Win32 executables) on Unix. It
149consists of a program loader which loads and executes a Microsoft
150Windows binary, and a library that implements Windows API calls using
151their Unix or X11 equivalents. The library may also be used for
152porting Win32 code into native Unix executables.
5c4ec57b 153
c967e47d 154%description -l es.UTF-8
f33a1517 155Ejecuta programas Windows en Linux.
156
c967e47d
JR
157%description -l pl.UTF-8
158Wine jest programem dzięki któremu można uruchamiać programy napisane
159dla Microsoft Windows pod systemami uniksowymi. Składa się on z
160loadera, który pozwala wczytywać i uruchamiać programy w formacie
161Microsoft Windows, oraz z biblioteki, która implementuje API Windows
162przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
163także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 164
c967e47d
JR
165%description -l pt_BR.UTF-8
166O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 167Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 168binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 169chamadas da API para as equivalentes Unix/X11.
170
5c4ec57b 171%package devel
7a050f82 172Summary: Wine - header files
93e41e44
ER
173Summary(es.UTF-8): Biblioteca de desarrollo de wine
174Summary(pl.UTF-8): Wine - pliki nagłowkowe
175Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 176Group: Development/Libraries
46114a9a 177Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 178
5c4ec57b 179%description devel
180Wine - header files.
181
c967e47d 182%description devel -l es.UTF-8
f33a1517 183Biblioteca de desarrollo de wine.
184
c967e47d
JR
185%description devel -l pl.UTF-8
186Wine - pliki nagłówkowe.
5c4ec57b 187
c967e47d
JR
188%description devel -l pt_BR.UTF-8
189Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 190WINE.
191
e8f81a0a 192%package programs
193Summary: Wine - programs
93e41e44 194Summary(pl.UTF-8): Wine - programy
e8f81a0a 195Group: Applications
46114a9a 196Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 197
198%description programs
0a7c5d50 199Wine - programs.
e8f81a0a 200
c967e47d 201%description programs -l pl.UTF-8
0a7c5d50 202Wine - programy.
e8f81a0a 203
beafc810
MM
204%package dll-capi
205Summary: CAPI 2.0 (ISDN) implementation DLLs for Wine
206Summary(pl.UTF-8): Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
207Group: Applications/Emulators
208Requires: %{name} = %{epoch}:%{version}-%{release}
209
210%description dll-capi
b1df4aa7 211CAPI 2.0 (ISDN) implementation DLLs for Wine.
beafc810
MM
212
213%description dll-capi -l pl.UTF-8
b1df4aa7 214Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
beafc810 215
16e36f25
JB
216%package dll-d3d
217Summary: Direct3D implementation DLLs for Wine
93e41e44 218Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 219Group: Applications/Emulators
46114a9a 220Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
221Requires: OpenGL
222
223%description dll-d3d
224Direct3D implementation DLLs for Wine (through OpenGL).
225
c967e47d
JR
226%description dll-d3d -l pl.UTF-8
227Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
228
229%package dll-gl
230Summary: OpenGL implementation DLLs for Wine
93e41e44 231Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 232Group: Applications/Emulators
46114a9a 233Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
234Requires: OpenGL
235
236%description dll-gl
237OpenGL implementation DLLs for Wine.
238
c967e47d
JR
239%description dll-gl -l pl.UTF-8
240Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
241
242%package dll-twain
243Summary: TWAIN implementation DLL for Wine
93e41e44 244Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 245Group: Applications/Emulators
46114a9a 246Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
247
248%description dll-twain
249TWAIN implementation DLL for Wine (through SANE).
250
c967e47d
JR
251%description dll-twain -l pl.UTF-8
252Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25 253
9d6715c4 254%package dll-ldap
db80a28e 255Summary: Win32 LDAP API DLL for Wine
b1df4aa7 256Summary(pl.UTF-8): Biblioteka DLL z implementacją API Win32 LDAP dla Wine
9d6715c4
ER
257Group: Applications/Emulators
258Requires: %{name} = %{epoch}:%{version}-%{release}
259
260%description dll-ldap
b1df4aa7
JB
261Lightweight Directory Access Protocol Library for Wine.
262
263%description dll-ldap -l pl.UTF-8
264Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
9d6715c4 265
16e36f25
JB
266%package drv-alsa
267Summary: ALSA driver for WINE mm.dll implementation
93e41e44 268Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 269Group: Applications/Emulators
46114a9a 270Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
271
272%description drv-alsa
273ALSA driver for WINE mm.dll (multimedia system) implementation.
274
c967e47d
JR
275%description drv-alsa -l pl.UTF-8
276Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 277
5c4ec57b 278%prep
fec39f21 279%setup -q
f67e874d 280#%patch0 -p1
2fbbb535 281%patch1 -p1
8b4bf701 282%patch4 -p1
5312a936 283%patch5 -p1
3bfef0cd 284%patch6 -p1
f6cf693b 285%ifarch %{x8664}
a26a3859 286%patch7 -p1
f6cf693b 287%endif
591d55ba 288
5c4ec57b 289%build
ebbd62c0
GP
290
291#workaround for icon extraction error.
292icotool -x -o . dlls/user32/resources/oic_winlogo.ico
293mv -f oic_winlogo_*32x32x32.png %{name}.png
294rm -f oic_winlogo_*.png
887fffcf 295
2fbbb535 296%{__autoconf}
103d8328 297%{__autoheader}
9d6a128d 298%configure \
f829f028
AM
299%ifarch %{x8664}
300 --enable-win64 \
301%endif
5b49e814
JB
302 --with-alsa%{!?with_alsa:=no} \
303 --with-capi%{!?with_capi:=no} \
d0d61ce7 304 --with-coreaudio \
5b49e814 305 --with-cups%{!?with_cups:=no} \
d7296a19 306 --with-dbus \
c504380e 307 --with-fontconfig \
308 --with-freetype \
d7296a19 309 --with-gphoto \
d0d61ce7 310 --with-gnutls \
8ec65640 311 %{__with_without gstreamer} \
5b49e814 312 --with-ldap%{!?with_ldap:=no} \
d7296a19
JK
313 --with%{!?with_netapi:out}-netapi \
314 --with-openal \
315 --with-opencl \
c504380e 316 --with-opengl \
d7296a19 317 --with-osmesa \
c54d2750 318 --with-pcap \
d0d61ce7 319 --with-pthread \
c54d2750 320 --with-pulse \
c504380e 321 --with%{!?with_sane:out}-sane \
beb8121e 322 --with-xcomposite \
323 --with-xcursor \
324 --with-xinerama \
325 --with-xinput \
d7296a19 326 --with-xinput2 \
beb8121e 327 --with-xrandr \
c504380e 328 --with-xrender \
329 --with-xshape \
330 --with-xshm \
beb8121e 331 --with-xxf86vm \
0be89e87 332 --with-x
fe2412f1 333
05eb066b 334%{__make} depend
4aafdd81 335%{__make}
e8f81a0a 336
5c4ec57b 337%install
338rm -rf $RPM_BUILD_ROOT
ffb676e0 339install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
c7af491d
JB
340%{__make} install \
341 DESTDIR=$RPM_BUILD_ROOT
342
a26a3859 343install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
887fffcf 344cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
0b87866b 345
2a437456 346install -d \
65c325f6 347 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
348 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 349 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
350 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
351 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
352
a91c2692 353touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
354touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
355touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
356
76055aa1 357cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
a91c2692 358[mci]
359cdaudio=mcicda.drv
360sequencer=mciseq.drv
361waveaudio=mciwave.drv
362avivideo=mciavi.drv
363videodisc=mcipionr.drv
364vcr=mciviscd.drv
365MPEGVideo=mciqtz.drv
5c4ec57b 366EOF
367
80496098 368# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 369
887fffcf
ER
370dir=$(pwd)
371> files.so
372> files.programs
887fffcf
ER
373
374programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
2f6853f9 375for p in $programs; do
8d493411 376 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
3092e49c 377 echo "%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/$p.exe" >> files.programs
da274952 378 echo "%{_mandir}/man1/$p.1*" >> files.programs
3092e49c
BZ
379# grep -v "$p\.exe\.so$" files.so > files.so.
380# mv -f files.so. files.so
55a96819 381done
55a96819 382
a26a3859
JK
383for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
384 mv "$dir" "${dir%.UTF-8}"
385done
386
f6cf693b 387%ifarch %{x8664}
fe2412f1 388cp -p loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
c54d2750
JK
389for lang in de fr pl ; do
390install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
fe2412f1 391cp -p loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
c54d2750
JK
392done
393%else
fe2412f1 394cp -p loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
c54d2750
JK
395for lang in de fr pl ; do
396install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
fe2412f1 397cp -p loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
f6cf693b
JK
398done
399%endif
400
f7357f09 401install -d $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 402%ifnarch %{x8664}
db80a28e 403cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 404%else
db80a28e 405cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 406%endif
f7357f09 407
887fffcf 408install -d $RPM_BUILD_ROOT%{_pixmapsdir}
db80a28e
ER
409cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
410cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
76055aa1 411
5c4ec57b 412%clean
413rm -rf $RPM_BUILD_ROOT
414
8df63af6 415%post
db80a28e 416/sbin/ldconfig
8df63af6
ER
417%update_desktop_database
418
f1f3af79
JB
419%postun -p /sbin/ldconfig
420
d142aa07 421%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 422rm -f /var/lock/subsys/wine
d142aa07
JB
423if [ -x /sbin/chkconfig ]; then
424 /sbin/chkconfig --del wine
425fi
426
fe2412f1 427%files
5c4ec57b 428%defattr(644,root,root,755)
47bd64d5 429%doc README AUTHORS ANNOUNCE
12b1296e 430%lang(de) %doc documentation/README.de
431%lang(es) %doc documentation/README.es
432%lang(fr) %doc documentation/README.fr
0aac4f59 433%lang(hu) %doc documentation/README.hu
12b1296e 434%lang(it) %doc documentation/README.it
7b9e958b 435%lang(ko) %doc documentation/README.ko
58a0e5f4 436%lang(nb) %doc documentation/README.no
12b1296e 437%lang(pt) %doc documentation/README.pt
74de5921 438%lang(pt_BR) %doc documentation/README.pt_br
0aac4f59
KK
439%lang(ru) %doc documentation/README.ru
440%lang(sv) %doc documentation/README.sv
441%lang(tr) %doc documentation/README.tr
3092e49c 442%attr(755,root,root) %{_bindir}/msidb
82432451 443%attr(755,root,root) %{_bindir}/msiexec
beafc810
MM
444%ifnarch %{x8664}
445%attr(755,root,root) %{_bindir}/wine
446%else
447%attr(755,root,root) %{_bindir}/wine64
448%endif
d479f953 449%attr(755,root,root) %{_bindir}/wineboot
55a96819 450%attr(755,root,root) %{_bindir}/winedbg
0aac4f59 451%attr(755,root,root) %{_bindir}/winecfg
beafc810 452%ifnarch %{x8664}
f829f028 453%attr(755,root,root) %{_bindir}/wine-preloader
beafc810
MM
454%else
455%attr(755,root,root) %{_bindir}/wine64-preloader
f829f028 456%endif
beafc810 457%attr(755,root,root) %{_bindir}/wineserver
861238d3 458%dir %{_libdir}/wine
3092e49c
BZ
459%dir %{_libdir}/wine/%{winelib}-unix
460%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/*.so*
461%dir %{_libdir}/wine/%{winelib}-windows
462%{_libdir}/wine/%{winelib}-windows/*.acm
463%{_libdir}/wine/%{winelib}-windows/*.ax
464%{_libdir}/wine/%{winelib}-windows/*.com
465%{_libdir}/wine/%{winelib}-windows/*.cpl
466%{_libdir}/wine/%{winelib}-windows/*.dll
beafc810 467%ifarch %{ix86}
3092e49c 468%{_libdir}/wine/%{winelib}-windows/*.dll16
beafc810 469%endif
3092e49c 470%{_libdir}/wine/%{winelib}-windows/*.drv
beafc810 471%ifarch %{ix86}
3092e49c 472%{_libdir}/wine/%{winelib}-windows/*.drv16
beafc810 473%endif
3092e49c
BZ
474%{_libdir}/wine/%{winelib}-windows/*.ds
475%{_libdir}/wine/%{winelib}-windows/*.exe
beafc810 476%ifarch %{ix86}
3092e49c
BZ
477%{_libdir}/wine/%{winelib}-windows/*.exe16
478%{_libdir}/wine/%{winelib}-windows/*.mod16
beafc810 479%endif
3092e49c
BZ
480%{_libdir}/wine/%{winelib}-windows/*.msstyles
481%{_libdir}/wine/%{winelib}-windows/*.ocx
482%{_libdir}/wine/%{winelib}-windows/*.sys
483%{_libdir}/wine/%{winelib}-windows/*.tlb
f829f028 484%ifarch %{ix86}
3092e49c 485%{_libdir}/wine/%{winelib}-windows/*.vxd
f829f028 486%endif
f6cf693b 487%ifnarch %{x8664}
b86f1c34 488%{_mandir}/man1/wine.1*
47bd64d5
JK
489%lang(de) %{_mandir}/de/man1/wine.1*
490%lang(fr) %{_mandir}/fr/man1/wine.1*
491%lang(pl) %{_mandir}/pl/man1/wine.1*
f6cf693b
JK
492%else
493%{_mandir}/man1/wine64.1*
494%lang(de) %{_mandir}/de/man1/wine64.1*
495%lang(fr) %{_mandir}/fr/man1/wine64.1*
496%lang(pl) %{_mandir}/pl/man1/wine64.1*
497%endif
da274952
AG
498%{_mandir}/man1/msiexec.1*
499%{_mandir}/man1/wineboot.1*
3092e49c 500
da274952 501%{_mandir}/man1/winecfg.1*
72ede285 502%{_mandir}/man1/winedbg.1*
b86f1c34 503%{_mandir}/man1/wineserver.1*
ad4623a1
AM
504%lang(de) %{_mandir}/de/man1/wineserver.1*
505%lang(fr) %{_mandir}/fr/man1/wineserver.1*
a91c2692 506%{_winedir}
a6c536e0 507%{_desktopdir}/wine.desktop
76055aa1 508%{_desktopdir}/wine-uninstaller.desktop
887fffcf 509%{_pixmapsdir}/%{name}.png
5c4ec57b 510
55a96819 511%files programs -f files.programs
e8f81a0a 512%defattr(644,root,root,755)
e8f81a0a 513
5c4ec57b 514%files devel
515%defattr(644,root,root,755)
a26a3859 516%attr(755,root,root) %{_bindir}/sfnt2fon
d479f953 517%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 518%attr(755,root,root) %{_bindir}/widl
55a96819 519%attr(755,root,root) %{_bindir}/winebuild
55a96819 520%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 521%attr(755,root,root) %{_bindir}/wineg++
d479f953 522%attr(755,root,root) %{_bindir}/winegcc
523%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 524%attr(755,root,root) %{_bindir}/winecpp
55a96819 525%attr(755,root,root) %{_bindir}/wmc
d479f953 526%attr(755,root,root) %{_bindir}/wrc
7265d9f2 527# no shared variants, so not separated
3092e49c 528%{_libdir}/wine/%{winelib}-unix/lib*.a
fe2412f1 529#%{_libdir}/wine/%{winelib}-windows/lib*.a
5c4ec57b 530%{_includedir}/wine
34f03014 531%{_mandir}/man1/widl.1*
0aac4f59 532%{_mandir}/man1/winebuild.1*
da274952 533%{_mandir}/man1/winecpp.1*
34f03014 534%{_mandir}/man1/winedump.1*
bff06719 535%{_mandir}/man1/winegcc.1*
5ec7e550 536%{_mandir}/man1/wineg++.1*
34f03014 537%{_mandir}/man1/winemaker.1*
0aac4f59 538%lang(de) %{_mandir}/de/man1/winemaker.1*
6ebf503e 539%lang(fr) %{_mandir}/fr/man1/winemaker.1*
34f03014
JB
540%{_mandir}/man1/wmc.1*
541%{_mandir}/man1/wrc.1*
2b5050a8 542%{_aclocaldir}/*.m4
f18f723c 543
ba28a7b8 544%if %{with capi}
beafc810
MM
545%files dll-capi
546%defattr(644,root,root,755)
3092e49c
BZ
547%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/capi2032.dll
548%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/capi2032.so
ba28a7b8 549%endif
beafc810 550
16e36f25
JB
551%files dll-d3d
552%defattr(644,root,root,755)
3092e49c
BZ
553%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d8.dll
554%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d8thk.dll
555%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d9.dll
556%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d10*.dll
557%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d11.dll
558%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/wined3d.dll
559%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/wined3d.dll.so
16e36f25
JB
560
561%files dll-gl
562%defattr(644,root,root,755)
3092e49c
BZ
563%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/glu32.dll
564%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/opengl32.dll
16e36f25
JB
565
566%if %{with sane}
567%files dll-twain
568%defattr(644,root,root,755)
3092e49c
BZ
569%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/sane.so
570%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/twain*.dll
571%ifarch %{ix86}
572%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/twain*.dll16
573%endif
16e36f25
JB
574%endif
575
9d6715c4
ER
576%if %{with ldap}
577%files dll-ldap
578%defattr(644,root,root,755)
3092e49c
BZ
579%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/wldap*.so
580%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/wldap*.dll
9d6715c4
ER
581%endif
582
16e36f25
JB
583%if %{with alsa}
584%files drv-alsa
585%defattr(644,root,root,755)
3092e49c 586%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/winealsa.drv.so
16e36f25
JB
587%endif
588
16e36f25 589# additional dependencies in *.so not separated (yet?) from main package
b1df4aa7
JB
590# ddraw.dll.so,winex11.drv.so depend on X11 libs
591# ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.24764 seconds and 4 git commands to generate.