]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
- fix capi bcond
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
0be89e87
BZ
2# todo:
3# libvkd3d https://wiki.winehq.org/Vkd3d
4#
7a30e9d7 5# Conditional build:
931f130b 6%bcond_without alsa # don't build ALSA mm driver
8e674d62 7%bcond_with capi # don't build CAPI 2.0 (ISDN) support
beafc810 8%bcond_without gstreamer # don't build GStreamer filters support
16e36f25 9%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
9d6715c4 10%bcond_without ldap # don't build LDAP DLL
16e36f25 11%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
d7296a19 12%bcond_without netapi # don't use the Samba NetAPI library
7a30e9d7 13#
546bbb82 14# NOTE: wine detects the following SONAMES for dlopen at build time:
5b49e814
JB
15# libGL (winex11.drv.so)
16# libOSMesa (gdi32.dll.so)
17# libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
18# libcapi20 (capi2032.dll.so)
19# libcups (winspool.drv.so)
20# libdbus (mountmgr.sys.so)
16e36f25 21# libfontconfig (gdi32.dll.so)
5b49e814
JB
22# libfreetype (gdi32.dll.so)
23# libgnutls (secur32.dll.so)
5b49e814
JB
24# libncurses (kernel32.dll.so)
25# libodbc (odbc32.dll.so)
5b49e814
JB
26# libsane (sane.ds.so)
27# libtiff (windowscodecs.dll.so)
546bbb82 28# thus requires rebuild after change of any of the above.
db80a28e 29
4ce8abe1
ER
30# library qualifier in rpm generated deps
31%ifarch %{x8664} ia64 ppc64 s390x sparc64
32%define libqual ()(64bit)
33%else
34%define libqual %{nil}
35%endif
36
2c7f2af5
BZ
37%ifarch %{x8664}
38%define winelib x86_64
39%else
40%define winelib i386
41%endif
42
3e4a4fb9 43%define gecko_ver 2.47.2
698e86e7 44Summary: Program that lets you launch Win applications
93e41e44
ER
45Summary(es.UTF-8): Ejecuta programas Windows en Linux
46Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
47Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 48Name: wine
e9d09a3b 49Version: 7.3
8e674d62 50Release: 1
46114a9a 51Epoch: 1
528c1138 52License: LGPL
5c4ec57b 53Group: Applications/Emulators
e9d09a3b
BZ
54Source0: https://dl.winehq.org/wine/source/7.x/%{name}-%{version}.tar.xz
55# Source0-md5: 5a52776788f27cb4181dda24fc5eaf45
3e4a4fb9
BZ
56Source1: https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86.msi
57# Source1-md5: e0a26e37397961b2c7f624575590ef66
58Source2: https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86_64.msi
59# Source2-md5: ff7168b08fa901516fbaa8a66aa3cee6
beafc810 60Source3: %{name}-uninstaller.desktop
55061442 61Patch0: %{name}-gphoto2_bool.patch
a0ff0658 62Patch1: %{name}-makedep.patch
a4a10255 63Patch2: %{name}-ncurses.patch
8b4bf701 64Patch4: %{name}-disable-valgrind.patch
5312a936 65Patch5: %{name}-ca_certificates.patch
a26a3859
JK
66Patch6: desktop.patch
67Patch7: %{name}-wine64_man.patch
1b3d8891 68URL: http://www.winehq.org/
2c7f2af5
BZ
69BuildConflicts: crossmingw32-gcc
70BuildConflicts: crossmingw64-gcc
5b49e814 71BuildRequires: Mesa-libOSMesa-devel
0aac4f59 72BuildRequires: OpenAL-devel >= 1.1
5b49e814 73BuildRequires: OpenCL-devel
489ca66c 74BuildRequires: OpenGL-GLU-devel
6547534c
KK
75%{?with_alsa:BuildRequires: alsa-lib-devel}
76%{?with_arts:BuildRequires: artsc-devel}
5b49e814 77BuildRequires: autoconf >= 2.62
c7af491d 78BuildRequires: automake
d3c41437 79BuildRequires: bison
beafc810 80%{?with_capi:BuildRequires: capi4k-utils-devel}
2c7f2af5 81BuildRequires: clang
5715e1d1 82%{?with_cups:BuildRequires: cups-devel}
5b49e814 83BuildRequires: dbus-devel
5b49e814 84BuildRequires: flex >= 2.5.33
16e36f25 85BuildRequires: fontconfig-devel
5fc34681 86BuildRequires: freetype-devel >= 2.0.5
05596b04 87BuildRequires: gettext-devel
5b49e814
JB
88%ifarch %{x8664}
89BuildRequires: gcc >= 6:4.4
90%endif
1f0c428e 91BuildRequires: gettext-tools
c57a98fe 92BuildRequires: gnutls-devel
f73ad4b6
JP
93%{?with_gstreamer:BuildRequires: gstreamer-devel >= 1.0}
94%{?with_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 1.0}
5b49e814
JB
95# for icotool used in build
96BuildRequires: icoutils >= 0.29.0
97BuildRequires: lcms2-devel >= 2
3d0989c1 98BuildRequires: libcap-devel
beb8121e 99BuildRequires: libgphoto2-devel
05596b04 100BuildRequires: libpcap-devel
9d6715c4 101%{?with_ldap:BuildRequires: openldap-devel}
beb8121e 102BuildRequires: pkgconfig
3d0989c1 103BuildRequires: pulseaudio-devel
d7296a19 104BuildRequires: samba-devel
5715e1d1 105%{?with_sane:BuildRequires: sane-backends-devel}
5b49e814 106BuildRequires: xorg-lib-libX11-devel
beb8121e 107BuildRequires: xorg-lib-libXcomposite-devel
108BuildRequires: xorg-lib-libXcursor-devel
5b49e814 109BuildRequires: xorg-lib-libXext-devel
c66c3406 110BuildRequires: xorg-lib-libXi-devel
beb8121e 111BuildRequires: xorg-lib-libXinerama-devel
beb8121e 112BuildRequires: xorg-lib-libXrandr-devel
c66c3406 113BuildRequires: xorg-lib-libXrender-devel
c66c3406 114BuildRequires: xorg-lib-libXxf86vm-devel
4ce8abe1 115Requires: libfreetype.so.6%{libqual}
a85c8746 116Requires: libpng16.so.16%{libqual}
8df63af6 117Requires(post): /sbin/ldconfig
ae42c99e 118Suggests: binfmt-detector
be70b824 119Suggests: ca-certificates
beafc810 120Suggests: cabextract
a2f68044 121Conflicts: ca-certificates < 20080809-4
b3d3861d 122# for printing needs lpr
123Suggests: cups-clients
f96e197b 124# for winelauncher
3bddfbf2 125Suggests: xorg-app-xmessage
f96e197b 126# for ntlm_auth
14e95129 127Suggests: samba-common >= 1:3.0.25
52b6007b
JB
128# link to wine/ntdll.dll.so, without any SONAME
129Provides: libntdll.dll.so
7212da21 130Obsoletes: wine-doc-pdf
93b34e12 131Obsoletes: wine-drv-arts
beafc810
MM
132Obsoletes: wine-drv-jack
133Obsoletes: wine-drv-nas
5b49e814 134ExclusiveArch: %{ix86} %{x8664} arm
206eed29 135ExcludeArch: i386
0403821a 136BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 137
e8f81a0a 138%define no_install_post_strip 1
b955dc60 139%define _noautoprov elf\\\\(buildid\\\\)
e8f81a0a 140
e8f81a0a 141%define _winedir %{_datadir}/%{name}
6731627f 142
5c4ec57b 143%description
6731627f 144Wine is a program which allows running Microsoft Windows programs
a519bc4f 145(including DOS, Windows 3.x and Win32 executables) on Unix. It
146consists of a program loader which loads and executes a Microsoft
147Windows binary, and a library that implements Windows API calls using
148their Unix or X11 equivalents. The library may also be used for
149porting Win32 code into native Unix executables.
5c4ec57b 150
c967e47d 151%description -l es.UTF-8
f33a1517 152Ejecuta programas Windows en Linux.
153
c967e47d
JR
154%description -l pl.UTF-8
155Wine jest programem dzięki któremu można uruchamiać programy napisane
156dla Microsoft Windows pod systemami uniksowymi. Składa się on z
157loadera, który pozwala wczytywać i uruchamiać programy w formacie
158Microsoft Windows, oraz z biblioteki, która implementuje API Windows
159przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
160także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 161
c967e47d
JR
162%description -l pt_BR.UTF-8
163O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 164Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 165binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 166chamadas da API para as equivalentes Unix/X11.
167
5c4ec57b 168%package devel
7a050f82 169Summary: Wine - header files
93e41e44
ER
170Summary(es.UTF-8): Biblioteca de desarrollo de wine
171Summary(pl.UTF-8): Wine - pliki nagłowkowe
172Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 173Group: Development/Libraries
46114a9a 174Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 175
5c4ec57b 176%description devel
177Wine - header files.
178
c967e47d 179%description devel -l es.UTF-8
f33a1517 180Biblioteca de desarrollo de wine.
181
c967e47d
JR
182%description devel -l pl.UTF-8
183Wine - pliki nagłówkowe.
5c4ec57b 184
c967e47d
JR
185%description devel -l pt_BR.UTF-8
186Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 187WINE.
188
e8f81a0a 189%package programs
190Summary: Wine - programs
93e41e44 191Summary(pl.UTF-8): Wine - programy
e8f81a0a 192Group: Applications
46114a9a 193Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 194
195%description programs
0a7c5d50 196Wine - programs.
e8f81a0a 197
c967e47d 198%description programs -l pl.UTF-8
0a7c5d50 199Wine - programy.
e8f81a0a 200
beafc810
MM
201%package dll-capi
202Summary: CAPI 2.0 (ISDN) implementation DLLs for Wine
203Summary(pl.UTF-8): Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
204Group: Applications/Emulators
205Requires: %{name} = %{epoch}:%{version}-%{release}
206
207%description dll-capi
b1df4aa7 208CAPI 2.0 (ISDN) implementation DLLs for Wine.
beafc810
MM
209
210%description dll-capi -l pl.UTF-8
b1df4aa7 211Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
beafc810 212
16e36f25
JB
213%package dll-d3d
214Summary: Direct3D implementation DLLs for Wine
93e41e44 215Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 216Group: Applications/Emulators
46114a9a 217Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
218Requires: OpenGL
219
220%description dll-d3d
221Direct3D implementation DLLs for Wine (through OpenGL).
222
c967e47d
JR
223%description dll-d3d -l pl.UTF-8
224Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
225
226%package dll-gl
227Summary: OpenGL implementation DLLs for Wine
93e41e44 228Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 229Group: Applications/Emulators
46114a9a 230Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
231Requires: OpenGL
232
233%description dll-gl
234OpenGL implementation DLLs for Wine.
235
c967e47d
JR
236%description dll-gl -l pl.UTF-8
237Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
238
239%package dll-twain
240Summary: TWAIN implementation DLL for Wine
93e41e44 241Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 242Group: Applications/Emulators
46114a9a 243Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
244
245%description dll-twain
246TWAIN implementation DLL for Wine (through SANE).
247
c967e47d
JR
248%description dll-twain -l pl.UTF-8
249Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25 250
9d6715c4 251%package dll-ldap
db80a28e 252Summary: Win32 LDAP API DLL for Wine
b1df4aa7 253Summary(pl.UTF-8): Biblioteka DLL z implementacją API Win32 LDAP dla Wine
9d6715c4
ER
254Group: Applications/Emulators
255Requires: %{name} = %{epoch}:%{version}-%{release}
256
257%description dll-ldap
b1df4aa7
JB
258Lightweight Directory Access Protocol Library for Wine.
259
260%description dll-ldap -l pl.UTF-8
261Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
9d6715c4 262
16e36f25
JB
263%package drv-alsa
264Summary: ALSA driver for WINE mm.dll implementation
93e41e44 265Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 266Group: Applications/Emulators
46114a9a 267Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
268
269%description drv-alsa
270ALSA driver for WINE mm.dll (multimedia system) implementation.
271
c967e47d
JR
272%description drv-alsa -l pl.UTF-8
273Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 274
5c4ec57b 275%prep
fec39f21 276%setup -q
f67e874d 277#%patch0 -p1
2fbbb535 278%patch1 -p1
8b4bf701 279%patch4 -p1
5312a936 280%patch5 -p1
3bfef0cd 281%patch6 -p1
f6cf693b 282%ifarch %{x8664}
a26a3859 283%patch7 -p1
f6cf693b 284%endif
591d55ba 285
5c4ec57b 286%build
ebbd62c0
GP
287
288#workaround for icon extraction error.
289icotool -x -o . dlls/user32/resources/oic_winlogo.ico
290mv -f oic_winlogo_*32x32x32.png %{name}.png
291rm -f oic_winlogo_*.png
887fffcf 292
2fbbb535 293%{__autoconf}
103d8328 294%{__autoheader}
9d6a128d 295%configure \
f829f028
AM
296%ifarch %{x8664}
297 --enable-win64 \
298%endif
5b49e814
JB
299 --with-alsa%{!?with_alsa:=no} \
300 --with-capi%{!?with_capi:=no} \
d0d61ce7 301 --with-coreaudio \
5b49e814 302 --with-cups%{!?with_cups:=no} \
d7296a19 303 --with-dbus \
c504380e 304 --with-fontconfig \
305 --with-freetype \
d7296a19 306 --with-gphoto \
d0d61ce7 307 --with-gnutls \
8ec65640 308 %{__with_without gstreamer} \
5b49e814 309 --with-ldap%{!?with_ldap:=no} \
d7296a19
JK
310 --with%{!?with_netapi:out}-netapi \
311 --with-openal \
312 --with-opencl \
c504380e 313 --with-opengl \
d7296a19 314 --with-osmesa \
c54d2750 315 --with-pcap \
d0d61ce7 316 --with-pthread \
c54d2750 317 --with-pulse \
c504380e 318 --with%{!?with_sane:out}-sane \
beb8121e 319 --with-xcomposite \
320 --with-xcursor \
321 --with-xinerama \
322 --with-xinput \
d7296a19 323 --with-xinput2 \
beb8121e 324 --with-xrandr \
c504380e 325 --with-xrender \
326 --with-xshape \
327 --with-xshm \
beb8121e 328 --with-xxf86vm \
0be89e87
BZ
329 --with-x
330
05eb066b 331%{__make} depend
4aafdd81 332%{__make}
e8f81a0a 333
5c4ec57b 334%install
335rm -rf $RPM_BUILD_ROOT
ffb676e0 336install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
c7af491d
JB
337%{__make} install \
338 DESTDIR=$RPM_BUILD_ROOT
339
a26a3859 340install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
887fffcf 341cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
0b87866b 342
2a437456 343install -d \
65c325f6 344 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
345 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 346 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
347 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
348 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
349
a91c2692 350touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
351touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
352touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
353
76055aa1 354cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
a91c2692 355[mci]
356cdaudio=mcicda.drv
357sequencer=mciseq.drv
358waveaudio=mciwave.drv
359avivideo=mciavi.drv
360videodisc=mcipionr.drv
361vcr=mciviscd.drv
362MPEGVideo=mciqtz.drv
5c4ec57b 363EOF
364
80496098 365# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 366
887fffcf
ER
367dir=$(pwd)
368> files.so
369> files.programs
887fffcf
ER
370
371programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
2f6853f9 372for p in $programs; do
8d493411 373 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
3092e49c 374 echo "%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/$p.exe" >> files.programs
da274952 375 echo "%{_mandir}/man1/$p.1*" >> files.programs
3092e49c
BZ
376# grep -v "$p\.exe\.so$" files.so > files.so.
377# mv -f files.so. files.so
55a96819 378done
55a96819 379
a26a3859
JK
380for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
381 mv "$dir" "${dir%.UTF-8}"
382done
383
f6cf693b 384%ifarch %{x8664}
c54d2750
JK
385install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
386for lang in de fr pl ; do
387install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
388install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
389done
390%else
391install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
392for lang in de fr pl ; do
393install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
394install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
f6cf693b
JK
395done
396%endif
397
f7357f09 398install -d $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 399%ifnarch %{x8664}
db80a28e 400cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 401%else
db80a28e 402cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 403%endif
f7357f09 404
887fffcf 405install -d $RPM_BUILD_ROOT%{_pixmapsdir}
db80a28e
ER
406cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
407cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
76055aa1 408
5c4ec57b 409%clean
410rm -rf $RPM_BUILD_ROOT
411
8df63af6 412%post
db80a28e 413/sbin/ldconfig
8df63af6
ER
414%update_desktop_database
415
f1f3af79
JB
416%postun -p /sbin/ldconfig
417
d142aa07 418%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 419rm -f /var/lock/subsys/wine
d142aa07
JB
420if [ -x /sbin/chkconfig ]; then
421 /sbin/chkconfig --del wine
422fi
423
3092e49c 424%files
5c4ec57b 425%defattr(644,root,root,755)
47bd64d5 426%doc README AUTHORS ANNOUNCE
12b1296e 427%lang(de) %doc documentation/README.de
428%lang(es) %doc documentation/README.es
429%lang(fr) %doc documentation/README.fr
0aac4f59 430%lang(hu) %doc documentation/README.hu
12b1296e 431%lang(it) %doc documentation/README.it
7b9e958b 432%lang(ko) %doc documentation/README.ko
58a0e5f4 433%lang(nb) %doc documentation/README.no
12b1296e 434%lang(pt) %doc documentation/README.pt
74de5921 435%lang(pt_BR) %doc documentation/README.pt_br
0aac4f59
KK
436%lang(ru) %doc documentation/README.ru
437%lang(sv) %doc documentation/README.sv
438%lang(tr) %doc documentation/README.tr
3092e49c 439%attr(755,root,root) %{_bindir}/msidb
82432451 440%attr(755,root,root) %{_bindir}/msiexec
beafc810
MM
441%ifnarch %{x8664}
442%attr(755,root,root) %{_bindir}/wine
443%else
444%attr(755,root,root) %{_bindir}/wine64
445%endif
d479f953 446%attr(755,root,root) %{_bindir}/wineboot
55a96819 447%attr(755,root,root) %{_bindir}/winedbg
0aac4f59 448%attr(755,root,root) %{_bindir}/winecfg
beafc810 449%ifnarch %{x8664}
f829f028 450%attr(755,root,root) %{_bindir}/wine-preloader
beafc810
MM
451%else
452%attr(755,root,root) %{_bindir}/wine64-preloader
f829f028 453%endif
beafc810 454%attr(755,root,root) %{_bindir}/wineserver
861238d3 455%dir %{_libdir}/wine
3092e49c
BZ
456%dir %{_libdir}/wine/%{winelib}-unix
457%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/*.so*
458%dir %{_libdir}/wine/%{winelib}-windows
459%{_libdir}/wine/%{winelib}-windows/*.acm
460%{_libdir}/wine/%{winelib}-windows/*.ax
461%{_libdir}/wine/%{winelib}-windows/*.com
462%{_libdir}/wine/%{winelib}-windows/*.cpl
463%{_libdir}/wine/%{winelib}-windows/*.dll
beafc810 464%ifarch %{ix86}
3092e49c 465%{_libdir}/wine/%{winelib}-windows/*.dll16
beafc810 466%endif
3092e49c 467%{_libdir}/wine/%{winelib}-windows/*.drv
beafc810 468%ifarch %{ix86}
3092e49c 469%{_libdir}/wine/%{winelib}-windows/*.drv16
beafc810 470%endif
3092e49c
BZ
471%{_libdir}/wine/%{winelib}-windows/*.ds
472%{_libdir}/wine/%{winelib}-windows/*.exe
beafc810 473%ifarch %{ix86}
3092e49c
BZ
474%{_libdir}/wine/%{winelib}-windows/*.exe16
475%{_libdir}/wine/%{winelib}-windows/*.mod16
beafc810 476%endif
3092e49c
BZ
477%{_libdir}/wine/%{winelib}-windows/*.msstyles
478%{_libdir}/wine/%{winelib}-windows/*.ocx
479%{_libdir}/wine/%{winelib}-windows/*.sys
480%{_libdir}/wine/%{winelib}-windows/*.tlb
f829f028 481%ifarch %{ix86}
3092e49c 482%{_libdir}/wine/%{winelib}-windows/*.vxd
f829f028 483%endif
f6cf693b 484%ifnarch %{x8664}
b86f1c34 485%{_mandir}/man1/wine.1*
47bd64d5
JK
486%lang(de) %{_mandir}/de/man1/wine.1*
487%lang(fr) %{_mandir}/fr/man1/wine.1*
488%lang(pl) %{_mandir}/pl/man1/wine.1*
f6cf693b
JK
489%else
490%{_mandir}/man1/wine64.1*
491%lang(de) %{_mandir}/de/man1/wine64.1*
492%lang(fr) %{_mandir}/fr/man1/wine64.1*
493%lang(pl) %{_mandir}/pl/man1/wine64.1*
494%endif
da274952
AG
495%{_mandir}/man1/msiexec.1*
496%{_mandir}/man1/wineboot.1*
3092e49c 497
da274952 498%{_mandir}/man1/winecfg.1*
72ede285 499%{_mandir}/man1/winedbg.1*
b86f1c34 500%{_mandir}/man1/wineserver.1*
ad4623a1
AM
501%lang(de) %{_mandir}/de/man1/wineserver.1*
502%lang(fr) %{_mandir}/fr/man1/wineserver.1*
a91c2692 503%{_winedir}
a6c536e0 504%{_desktopdir}/wine.desktop
76055aa1 505%{_desktopdir}/wine-uninstaller.desktop
887fffcf 506%{_pixmapsdir}/%{name}.png
5c4ec57b 507
55a96819 508%files programs -f files.programs
e8f81a0a 509%defattr(644,root,root,755)
e8f81a0a 510
5c4ec57b 511%files devel
512%defattr(644,root,root,755)
a26a3859 513%attr(755,root,root) %{_bindir}/sfnt2fon
d479f953 514%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 515%attr(755,root,root) %{_bindir}/widl
55a96819 516%attr(755,root,root) %{_bindir}/winebuild
55a96819 517%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 518%attr(755,root,root) %{_bindir}/wineg++
d479f953 519%attr(755,root,root) %{_bindir}/winegcc
520%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 521%attr(755,root,root) %{_bindir}/winecpp
55a96819 522%attr(755,root,root) %{_bindir}/wmc
d479f953 523%attr(755,root,root) %{_bindir}/wrc
7265d9f2 524# no shared variants, so not separated
3092e49c
BZ
525%{_libdir}/wine/%{winelib}-unix/lib*.a
526%{_libdir}/wine/%{winelib}-windows/lib*.a
5c4ec57b 527%{_includedir}/wine
34f03014 528%{_mandir}/man1/widl.1*
0aac4f59 529%{_mandir}/man1/winebuild.1*
da274952 530%{_mandir}/man1/winecpp.1*
34f03014 531%{_mandir}/man1/winedump.1*
bff06719 532%{_mandir}/man1/winegcc.1*
5ec7e550 533%{_mandir}/man1/wineg++.1*
34f03014 534%{_mandir}/man1/winemaker.1*
0aac4f59 535%lang(de) %{_mandir}/de/man1/winemaker.1*
6ebf503e 536%lang(fr) %{_mandir}/fr/man1/winemaker.1*
34f03014
JB
537%{_mandir}/man1/wmc.1*
538%{_mandir}/man1/wrc.1*
2b5050a8 539%{_aclocaldir}/*.m4
f18f723c 540
ba28a7b8 541%if %{with capi}
beafc810
MM
542%files dll-capi
543%defattr(644,root,root,755)
3092e49c
BZ
544%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/capi2032.dll
545%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/capi2032.so
ba28a7b8 546%endif
beafc810 547
16e36f25
JB
548%files dll-d3d
549%defattr(644,root,root,755)
3092e49c
BZ
550%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d8.dll
551%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d8thk.dll
552%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d9.dll
553%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d10*.dll
554%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d11.dll
555%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/wined3d.dll
556%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/wined3d.dll.so
16e36f25
JB
557
558%files dll-gl
559%defattr(644,root,root,755)
3092e49c
BZ
560%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/glu32.dll
561%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/opengl32.dll
16e36f25
JB
562
563%if %{with sane}
564%files dll-twain
565%defattr(644,root,root,755)
3092e49c
BZ
566%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/sane.so
567%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/twain*.dll
568%ifarch %{ix86}
569%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/twain*.dll16
570%endif
16e36f25
JB
571%endif
572
9d6715c4
ER
573%if %{with ldap}
574%files dll-ldap
575%defattr(644,root,root,755)
3092e49c
BZ
576%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/wldap*.so
577%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/wldap*.dll
9d6715c4
ER
578%endif
579
16e36f25
JB
580%if %{with alsa}
581%files drv-alsa
582%defattr(644,root,root,755)
3092e49c 583%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/winealsa.drv.so
16e36f25
JB
584%endif
585
16e36f25 586# additional dependencies in *.so not separated (yet?) from main package
b1df4aa7
JB
587# ddraw.dll.so,winex11.drv.so depend on X11 libs
588# ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.271775 seconds and 4 git commands to generate.