]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
- versioned obsoletes
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
0be89e87
BZ
2# todo:
3# libvkd3d https://wiki.winehq.org/Vkd3d
4#
7a30e9d7 5# Conditional build:
8e674d62 6%bcond_with capi # don't build CAPI 2.0 (ISDN) support
beafc810 7%bcond_without gstreamer # don't build GStreamer filters support
16e36f25 8%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
9d6715c4 9%bcond_without ldap # don't build LDAP DLL
16e36f25 10%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
d7296a19 11%bcond_without netapi # don't use the Samba NetAPI library
7a30e9d7 12#
546bbb82 13# NOTE: wine detects the following SONAMES for dlopen at build time:
5b49e814
JB
14# libGL (winex11.drv.so)
15# libOSMesa (gdi32.dll.so)
16# libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
17# libcapi20 (capi2032.dll.so)
18# libcups (winspool.drv.so)
19# libdbus (mountmgr.sys.so)
16e36f25 20# libfontconfig (gdi32.dll.so)
5b49e814
JB
21# libfreetype (gdi32.dll.so)
22# libgnutls (secur32.dll.so)
5b49e814
JB
23# libncurses (kernel32.dll.so)
24# libodbc (odbc32.dll.so)
5b49e814
JB
25# libsane (sane.ds.so)
26# libtiff (windowscodecs.dll.so)
546bbb82 27# thus requires rebuild after change of any of the above.
db80a28e 28
4ce8abe1
ER
29# library qualifier in rpm generated deps
30%ifarch %{x8664} ia64 ppc64 s390x sparc64
31%define libqual ()(64bit)
32%else
33%define libqual %{nil}
34%endif
35
fe2412f1 36%ifarch %{x8664}
2c7f2af5
BZ
37%define winelib x86_64
38%else
39%define winelib i386
40%endif
41
3e4a4fb9 42%define gecko_ver 2.47.2
698e86e7 43Summary: Program that lets you launch Win applications
93e41e44
ER
44Summary(es.UTF-8): Ejecuta programas Windows en Linux
45Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
46Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 47Name: wine
b8361e26 48Version: 7.7
dd8ee46d 49Release: 2
46114a9a 50Epoch: 1
528c1138 51License: LGPL
5c4ec57b 52Group: Applications/Emulators
e9d09a3b 53Source0: https://dl.winehq.org/wine/source/7.x/%{name}-%{version}.tar.xz
b8361e26 54# Source0-md5: da2a85204a962a173ae0af03533961b4
3e4a4fb9
BZ
55Source1: https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86.msi
56# Source1-md5: e0a26e37397961b2c7f624575590ef66
57Source2: https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86_64.msi
58# Source2-md5: ff7168b08fa901516fbaa8a66aa3cee6
beafc810 59Source3: %{name}-uninstaller.desktop
55061442 60Patch0: %{name}-gphoto2_bool.patch
a0ff0658 61Patch1: %{name}-makedep.patch
a4a10255 62Patch2: %{name}-ncurses.patch
8b4bf701 63Patch4: %{name}-disable-valgrind.patch
5312a936 64Patch5: %{name}-ca_certificates.patch
a26a3859
JK
65Patch6: desktop.patch
66Patch7: %{name}-wine64_man.patch
1b3d8891 67URL: http://www.winehq.org/
5b49e814 68BuildRequires: Mesa-libOSMesa-devel
0aac4f59 69BuildRequires: OpenAL-devel >= 1.1
5b49e814 70BuildRequires: OpenCL-devel
489ca66c 71BuildRequires: OpenGL-GLU-devel
fe2412f1 72BuildRequires: SDL2-devel
dd8ee46d 73BuildRequires: alsa-lib-devel
6547534c 74%{?with_arts:BuildRequires: artsc-devel}
5b49e814 75BuildRequires: autoconf >= 2.62
c7af491d 76BuildRequires: automake
d3c41437 77BuildRequires: bison
beafc810 78%{?with_capi:BuildRequires: capi4k-utils-devel}
dd8ee46d 79BuildRequires: clang
5715e1d1 80%{?with_cups:BuildRequires: cups-devel}
5b49e814 81BuildRequires: dbus-devel
5b49e814 82BuildRequires: flex >= 2.5.33
16e36f25 83BuildRequires: fontconfig-devel
5fc34681 84BuildRequires: freetype-devel >= 2.0.5
05596b04 85BuildRequires: gettext-devel
5b49e814
JB
86%ifarch %{x8664}
87BuildRequires: gcc >= 6:4.4
88%endif
1f0c428e 89BuildRequires: gettext-tools
c57a98fe 90BuildRequires: gnutls-devel
f73ad4b6
JP
91%{?with_gstreamer:BuildRequires: gstreamer-devel >= 1.0}
92%{?with_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 1.0}
5b49e814
JB
93# for icotool used in build
94BuildRequires: icoutils >= 0.29.0
95BuildRequires: lcms2-devel >= 2
3d0989c1 96BuildRequires: libcap-devel
fe2412f1 97BuildRequires: libglvnd-libEGL-devel
beb8121e 98BuildRequires: libgphoto2-devel
05596b04 99BuildRequires: libpcap-devel
fe2412f1 100BuildRequires: libv4l-devel
af5ae18a 101BuildRequires: lld
9d6715c4 102%{?with_ldap:BuildRequires: openldap-devel}
beb8121e 103BuildRequires: pkgconfig
3d0989c1 104BuildRequires: pulseaudio-devel
d7296a19 105BuildRequires: samba-devel
5715e1d1 106%{?with_sane:BuildRequires: sane-backends-devel}
5b49e814 107BuildRequires: xorg-lib-libX11-devel
beb8121e 108BuildRequires: xorg-lib-libXcomposite-devel
109BuildRequires: xorg-lib-libXcursor-devel
5b49e814 110BuildRequires: xorg-lib-libXext-devel
c66c3406 111BuildRequires: xorg-lib-libXi-devel
beb8121e 112BuildRequires: xorg-lib-libXinerama-devel
beb8121e 113BuildRequires: xorg-lib-libXrandr-devel
c66c3406 114BuildRequires: xorg-lib-libXrender-devel
c66c3406 115BuildRequires: xorg-lib-libXxf86vm-devel
d1385401
JR
116BuildConflicts: crossmingw32-gcc
117BuildConflicts: crossmingw64-gcc
dd8ee46d 118Requires: OpenGL
4ce8abe1 119Requires: libfreetype.so.6%{libqual}
a85c8746 120Requires: libpng16.so.16%{libqual}
8df63af6 121Requires(post): /sbin/ldconfig
ae42c99e 122Suggests: binfmt-detector
be70b824 123Suggests: ca-certificates
beafc810 124Suggests: cabextract
a2f68044 125Conflicts: ca-certificates < 20080809-4
b3d3861d 126# for printing needs lpr
127Suggests: cups-clients
f96e197b 128# for winelauncher
3bddfbf2 129Suggests: xorg-app-xmessage
f96e197b 130# for ntlm_auth
14e95129 131Suggests: samba-common >= 1:3.0.25
52b6007b
JB
132# link to wine/ntdll.dll.so, without any SONAME
133Provides: libntdll.dll.so
78e6e4d9
JR
134Obsoletes: wine-dll-d3d < 1:7.7-2
135Obsoletes: wine-dll-gl < 1:7.7-2
136Obsoletes: wine-doc-pdf < 1:7.7-2
137Obsoletes: wine-drv-alsa < 1:7.7-2
138Obsoletes: wine-drv-arts < 1:7.7-2
139Obsoletes: wine-drv-jack < 1:7.7-2
140Obsoletes: wine-drv-nas < 1:7.7-2
141Obsoletes: wine-programs < 1:7.7-2
5b49e814 142ExclusiveArch: %{ix86} %{x8664} arm
206eed29 143ExcludeArch: i386
0403821a 144BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 145
e8f81a0a 146%define no_install_post_strip 1
b955dc60 147%define _noautoprov elf\\\\(buildid\\\\)
e8f81a0a 148
e8f81a0a 149%define _winedir %{_datadir}/%{name}
6731627f 150
5c4ec57b 151%description
6731627f 152Wine is a program which allows running Microsoft Windows programs
a519bc4f 153(including DOS, Windows 3.x and Win32 executables) on Unix. It
154consists of a program loader which loads and executes a Microsoft
155Windows binary, and a library that implements Windows API calls using
156their Unix or X11 equivalents. The library may also be used for
157porting Win32 code into native Unix executables.
5c4ec57b 158
c967e47d 159%description -l es.UTF-8
f33a1517 160Ejecuta programas Windows en Linux.
161
c967e47d
JR
162%description -l pl.UTF-8
163Wine jest programem dzięki któremu można uruchamiać programy napisane
164dla Microsoft Windows pod systemami uniksowymi. Składa się on z
165loadera, który pozwala wczytywać i uruchamiać programy w formacie
166Microsoft Windows, oraz z biblioteki, która implementuje API Windows
167przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
168także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 169
c967e47d
JR
170%description -l pt_BR.UTF-8
171O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 172Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 173binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 174chamadas da API para as equivalentes Unix/X11.
175
5c4ec57b 176%package devel
7a050f82 177Summary: Wine - header files
93e41e44
ER
178Summary(es.UTF-8): Biblioteca de desarrollo de wine
179Summary(pl.UTF-8): Wine - pliki nagłowkowe
180Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 181Group: Development/Libraries
46114a9a 182Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 183
5c4ec57b 184%description devel
185Wine - header files.
186
c967e47d 187%description devel -l es.UTF-8
f33a1517 188Biblioteca de desarrollo de wine.
189
c967e47d
JR
190%description devel -l pl.UTF-8
191Wine - pliki nagłówkowe.
5c4ec57b 192
c967e47d
JR
193%description devel -l pt_BR.UTF-8
194Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 195WINE.
196
beafc810
MM
197%package dll-capi
198Summary: CAPI 2.0 (ISDN) implementation DLLs for Wine
199Summary(pl.UTF-8): Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
200Group: Applications/Emulators
201Requires: %{name} = %{epoch}:%{version}-%{release}
202
203%description dll-capi
b1df4aa7 204CAPI 2.0 (ISDN) implementation DLLs for Wine.
beafc810
MM
205
206%description dll-capi -l pl.UTF-8
b1df4aa7 207Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
beafc810 208
16e36f25
JB
209%package dll-twain
210Summary: TWAIN implementation DLL for Wine
93e41e44 211Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 212Group: Applications/Emulators
46114a9a 213Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
214
215%description dll-twain
216TWAIN implementation DLL for Wine (through SANE).
217
c967e47d
JR
218%description dll-twain -l pl.UTF-8
219Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25 220
9d6715c4 221%package dll-ldap
db80a28e 222Summary: Win32 LDAP API DLL for Wine
b1df4aa7 223Summary(pl.UTF-8): Biblioteka DLL z implementacją API Win32 LDAP dla Wine
9d6715c4
ER
224Group: Applications/Emulators
225Requires: %{name} = %{epoch}:%{version}-%{release}
226
227%description dll-ldap
b1df4aa7
JB
228Lightweight Directory Access Protocol Library for Wine.
229
230%description dll-ldap -l pl.UTF-8
231Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
9d6715c4 232
5c4ec57b 233%prep
fec39f21 234%setup -q
f67e874d 235#%patch0 -p1
2fbbb535 236%patch1 -p1
8b4bf701 237%patch4 -p1
5312a936 238%patch5 -p1
3bfef0cd 239%patch6 -p1
f6cf693b 240%ifarch %{x8664}
a26a3859 241%patch7 -p1
f6cf693b 242%endif
591d55ba 243
5c4ec57b 244%build
ebbd62c0
GP
245
246#workaround for icon extraction error.
247icotool -x -o . dlls/user32/resources/oic_winlogo.ico
248mv -f oic_winlogo_*32x32x32.png %{name}.png
249rm -f oic_winlogo_*.png
887fffcf 250
2fbbb535 251%{__autoconf}
103d8328 252%{__autoheader}
9d6a128d 253%configure \
f829f028
AM
254%ifarch %{x8664}
255 --enable-win64 \
256%endif
dd8ee46d 257 --with-alsa \
5b49e814 258 --with-capi%{!?with_capi:=no} \
d0d61ce7 259 --with-coreaudio \
5b49e814 260 --with-cups%{!?with_cups:=no} \
d7296a19 261 --with-dbus \
c504380e 262 --with-fontconfig \
263 --with-freetype \
d7296a19 264 --with-gphoto \
d0d61ce7 265 --with-gnutls \
8ec65640 266 %{__with_without gstreamer} \
5b49e814 267 --with-ldap%{!?with_ldap:=no} \
d7296a19
JK
268 --with%{!?with_netapi:out}-netapi \
269 --with-openal \
270 --with-opencl \
c504380e 271 --with-opengl \
d7296a19 272 --with-osmesa \
c54d2750 273 --with-pcap \
d0d61ce7 274 --with-pthread \
c54d2750 275 --with-pulse \
c504380e 276 --with%{!?with_sane:out}-sane \
beb8121e 277 --with-xcomposite \
278 --with-xcursor \
279 --with-xinerama \
280 --with-xinput \
d7296a19 281 --with-xinput2 \
beb8121e 282 --with-xrandr \
c504380e 283 --with-xrender \
284 --with-xshape \
285 --with-xshm \
beb8121e 286 --with-xxf86vm \
0be89e87 287 --with-x
fe2412f1 288
05eb066b 289%{__make} depend
4aafdd81 290%{__make}
e8f81a0a 291
5c4ec57b 292%install
293rm -rf $RPM_BUILD_ROOT
ffb676e0 294install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
c7af491d
JB
295%{__make} install \
296 DESTDIR=$RPM_BUILD_ROOT
297
a26a3859 298install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
887fffcf 299cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
0b87866b 300
2a437456 301install -d \
65c325f6 302 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
303 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 304 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
305 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
306 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
307
a91c2692 308touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
309touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
310touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
311
76055aa1 312cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
a91c2692 313[mci]
314cdaudio=mcicda.drv
315sequencer=mciseq.drv
316waveaudio=mciwave.drv
317avivideo=mciavi.drv
318videodisc=mcipionr.drv
319vcr=mciviscd.drv
320MPEGVideo=mciqtz.drv
5c4ec57b 321EOF
322
80496098 323# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 324
a26a3859
JK
325for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
326 mv "$dir" "${dir%.UTF-8}"
327done
328
f6cf693b 329%ifarch %{x8664}
fe2412f1 330cp -p loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
c54d2750
JK
331for lang in de fr pl ; do
332install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
fe2412f1 333cp -p loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
c54d2750
JK
334done
335%else
fe2412f1 336cp -p loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
c54d2750
JK
337for lang in de fr pl ; do
338install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
fe2412f1 339cp -p loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
f6cf693b
JK
340done
341%endif
342
f7357f09 343install -d $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 344%ifnarch %{x8664}
db80a28e 345cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 346%else
db80a28e 347cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 348%endif
f7357f09 349
887fffcf 350install -d $RPM_BUILD_ROOT%{_pixmapsdir}
db80a28e
ER
351cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
352cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
76055aa1 353
5c4ec57b 354%clean
355rm -rf $RPM_BUILD_ROOT
356
8df63af6 357%post
db80a28e 358/sbin/ldconfig
8df63af6
ER
359%update_desktop_database
360
f1f3af79
JB
361%postun -p /sbin/ldconfig
362
d142aa07 363%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 364rm -f /var/lock/subsys/wine
d142aa07
JB
365if [ -x /sbin/chkconfig ]; then
366 /sbin/chkconfig --del wine
367fi
368
fe2412f1 369%files
5c4ec57b 370%defattr(644,root,root,755)
47bd64d5 371%doc README AUTHORS ANNOUNCE
12b1296e 372%lang(de) %doc documentation/README.de
373%lang(es) %doc documentation/README.es
374%lang(fr) %doc documentation/README.fr
0aac4f59 375%lang(hu) %doc documentation/README.hu
12b1296e 376%lang(it) %doc documentation/README.it
7b9e958b 377%lang(ko) %doc documentation/README.ko
58a0e5f4 378%lang(nb) %doc documentation/README.no
12b1296e 379%lang(pt) %doc documentation/README.pt
74de5921 380%lang(pt_BR) %doc documentation/README.pt_br
0aac4f59
KK
381%lang(ru) %doc documentation/README.ru
382%lang(sv) %doc documentation/README.sv
383%lang(tr) %doc documentation/README.tr
3092e49c 384%attr(755,root,root) %{_bindir}/msidb
82432451 385%attr(755,root,root) %{_bindir}/msiexec
dd8ee46d
JR
386%attr(755,root,root) %{_bindir}/notepad
387%attr(755,root,root) %{_bindir}/regedit
388%attr(755,root,root) %{_bindir}/regsvr32
beafc810
MM
389%ifnarch %{x8664}
390%attr(755,root,root) %{_bindir}/wine
391%else
392%attr(755,root,root) %{_bindir}/wine64
393%endif
d479f953 394%attr(755,root,root) %{_bindir}/wineboot
0aac4f59 395%attr(755,root,root) %{_bindir}/winecfg
dd8ee46d
JR
396%attr(755,root,root) %{_bindir}/wineconsole
397%attr(755,root,root) %{_bindir}/winedbg
398%attr(755,root,root) %{_bindir}/winefile
399%attr(755,root,root) %{_bindir}/winemine
400%attr(755,root,root) %{_bindir}/winepath
beafc810 401%ifnarch %{x8664}
f829f028 402%attr(755,root,root) %{_bindir}/wine-preloader
beafc810
MM
403%else
404%attr(755,root,root) %{_bindir}/wine64-preloader
f829f028 405%endif
beafc810 406%attr(755,root,root) %{_bindir}/wineserver
861238d3 407%dir %{_libdir}/wine
3092e49c
BZ
408%dir %{_libdir}/wine/%{winelib}-unix
409%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/*.so*
410%dir %{_libdir}/wine/%{winelib}-windows
411%{_libdir}/wine/%{winelib}-windows/*.acm
412%{_libdir}/wine/%{winelib}-windows/*.ax
413%{_libdir}/wine/%{winelib}-windows/*.com
414%{_libdir}/wine/%{winelib}-windows/*.cpl
415%{_libdir}/wine/%{winelib}-windows/*.dll
beafc810 416%ifarch %{ix86}
3092e49c 417%{_libdir}/wine/%{winelib}-windows/*.dll16
beafc810 418%endif
3092e49c 419%{_libdir}/wine/%{winelib}-windows/*.drv
beafc810 420%ifarch %{ix86}
3092e49c 421%{_libdir}/wine/%{winelib}-windows/*.drv16
beafc810 422%endif
3092e49c
BZ
423%{_libdir}/wine/%{winelib}-windows/*.ds
424%{_libdir}/wine/%{winelib}-windows/*.exe
beafc810 425%ifarch %{ix86}
3092e49c
BZ
426%{_libdir}/wine/%{winelib}-windows/*.exe16
427%{_libdir}/wine/%{winelib}-windows/*.mod16
beafc810 428%endif
3092e49c
BZ
429%{_libdir}/wine/%{winelib}-windows/*.msstyles
430%{_libdir}/wine/%{winelib}-windows/*.ocx
431%{_libdir}/wine/%{winelib}-windows/*.sys
432%{_libdir}/wine/%{winelib}-windows/*.tlb
f829f028 433%ifarch %{ix86}
3092e49c 434%{_libdir}/wine/%{winelib}-windows/*.vxd
f829f028 435%endif
dd8ee46d
JR
436%if %{with capi}
437%exclude %{_libdir}/wine/%{winelib}-windows/capi2032.dll
438%exclude %{_libdir}/wine/%{winelib}-unix/capi2032.so
439%endif
440%if %{with sane}
441%exclude %{_libdir}/wine/%{winelib}-unix/sane.so
442%exclude %{_libdir}/wine/%{winelib}-windows/twain*.dll
443%ifarch %{ix86}
444%exclude %{_libdir}/wine/%{winelib}-windows/twain*.dll16
445%endif
446%endif
447%if %{with ldap}
448%exclude %{_libdir}/wine/%{winelib}-unix/wldap*.so
449%exclude %{_libdir}/wine/%{winelib}-windows/wldap*.dll
450%endif
451%{_mandir}/man1/msiexec.1*
452%{_mandir}/man1/notepad.1*
453%{_mandir}/man1/regedit.1*
454%{_mandir}/man1/regsvr32.1*
f6cf693b 455%ifnarch %{x8664}
b86f1c34 456%{_mandir}/man1/wine.1*
47bd64d5
JK
457%lang(de) %{_mandir}/de/man1/wine.1*
458%lang(fr) %{_mandir}/fr/man1/wine.1*
459%lang(pl) %{_mandir}/pl/man1/wine.1*
f6cf693b
JK
460%else
461%{_mandir}/man1/wine64.1*
462%lang(de) %{_mandir}/de/man1/wine64.1*
463%lang(fr) %{_mandir}/fr/man1/wine64.1*
464%lang(pl) %{_mandir}/pl/man1/wine64.1*
465%endif
da274952
AG
466%{_mandir}/man1/wineboot.1*
467%{_mandir}/man1/winecfg.1*
dd8ee46d 468%{_mandir}/man1/wineconsole.1*
72ede285 469%{_mandir}/man1/winedbg.1*
dd8ee46d
JR
470%{_mandir}/man1/winefile.1*
471%{_mandir}/man1/winemine.1*
472%{_mandir}/man1/winepath.1*
b86f1c34 473%{_mandir}/man1/wineserver.1*
ad4623a1
AM
474%lang(de) %{_mandir}/de/man1/wineserver.1*
475%lang(fr) %{_mandir}/fr/man1/wineserver.1*
a91c2692 476%{_winedir}
a6c536e0 477%{_desktopdir}/wine.desktop
76055aa1 478%{_desktopdir}/wine-uninstaller.desktop
887fffcf 479%{_pixmapsdir}/%{name}.png
5c4ec57b 480
481%files devel
482%defattr(644,root,root,755)
a26a3859 483%attr(755,root,root) %{_bindir}/sfnt2fon
d479f953 484%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 485%attr(755,root,root) %{_bindir}/widl
55a96819 486%attr(755,root,root) %{_bindir}/winebuild
55a96819 487%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 488%attr(755,root,root) %{_bindir}/wineg++
d479f953 489%attr(755,root,root) %{_bindir}/winegcc
490%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 491%attr(755,root,root) %{_bindir}/winecpp
55a96819 492%attr(755,root,root) %{_bindir}/wmc
d479f953 493%attr(755,root,root) %{_bindir}/wrc
7265d9f2 494# no shared variants, so not separated
3092e49c 495%{_libdir}/wine/%{winelib}-unix/lib*.a
dd8ee46d 496%{_libdir}/wine/%{winelib}-windows/lib*.a
5c4ec57b 497%{_includedir}/wine
34f03014 498%{_mandir}/man1/widl.1*
0aac4f59 499%{_mandir}/man1/winebuild.1*
da274952 500%{_mandir}/man1/winecpp.1*
34f03014 501%{_mandir}/man1/winedump.1*
bff06719 502%{_mandir}/man1/winegcc.1*
5ec7e550 503%{_mandir}/man1/wineg++.1*
34f03014 504%{_mandir}/man1/winemaker.1*
0aac4f59 505%lang(de) %{_mandir}/de/man1/winemaker.1*
6ebf503e 506%lang(fr) %{_mandir}/fr/man1/winemaker.1*
34f03014
JB
507%{_mandir}/man1/wmc.1*
508%{_mandir}/man1/wrc.1*
2b5050a8 509%{_aclocaldir}/*.m4
f18f723c 510
ba28a7b8 511%if %{with capi}
beafc810
MM
512%files dll-capi
513%defattr(644,root,root,755)
3092e49c
BZ
514%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/capi2032.dll
515%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/capi2032.so
ba28a7b8 516%endif
beafc810 517
16e36f25
JB
518%if %{with sane}
519%files dll-twain
520%defattr(644,root,root,755)
3092e49c
BZ
521%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/sane.so
522%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/twain*.dll
523%ifarch %{ix86}
524%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/twain*.dll16
525%endif
16e36f25
JB
526%endif
527
9d6715c4
ER
528%if %{with ldap}
529%files dll-ldap
530%defattr(644,root,root,755)
3092e49c
BZ
531%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/wldap*.so
532%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/wldap*.dll
9d6715c4
ER
533%endif
534
16e36f25 535# additional dependencies in *.so not separated (yet?) from main package
b1df4aa7
JB
536# ddraw.dll.so,winex11.drv.so depend on X11 libs
537# ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.337786 seconds and 4 git commands to generate.