]> git.pld-linux.org Git - packages/widelands.git/commitdiff
- up to 1.2 master auto/th/widelands-1.2-1
authorKrzysztof Mrozowicz <mrozowik@pld-linux.org>
Sat, 30 Mar 2024 12:05:11 +0000 (12:05 +0000)
committerKrzysztof Mrozowicz <mrozowik@pld-linux.org>
Sat, 30 Mar 2024 12:05:11 +0000 (12:05 +0000)
gcc13.patch [deleted file]
widelands-pld.patch
widelands.spec

diff --git a/gcc13.patch b/gcc13.patch
deleted file mode 100644 (file)
index 6514d67..0000000
+++ /dev/null
@@ -1,155 +0,0 @@
-From 5b5553fb90f17ad67fcdebfa05aa4b042834449d Mon Sep 17 00:00:00 2001
-From: Heiko Becker <heirecka@exherbo.org>
-Date: Wed, 25 Jan 2023 23:42:42 +0100
-Subject: [PATCH] Fix build with gcc 13 by including <cstdint>
-
-Like other versions before, gcc 13 moved some includes around and as a
-result <cstdint> is no longer transitively included. Explicitly include
-it for uint*_t.
----
- src/base/md5.h                    | 1 +
- src/base/random.h                 | 1 +
- src/base/time_string.h            | 1 +
- src/build_info.h                  | 1 +
- src/graphic/align.h               | 1 +
- src/graphic/text/textstream.h     | 1 +
- src/logic/generic_save_handler.h  | 1 +
- src/logic/map_revision.h          | 1 +
- src/logic/save_handler.h          | 1 +
- src/map_io/map_elemental_packet.h | 1 +
- src/scripting/persistence.h       | 2 ++
- 11 files changed, 12 insertions(+)
-
-diff --git a/src/base/md5.h b/src/base/md5.h
-index a11966ab81c..29a60b4bf87 100644
---- a/src/base/md5.h
-+++ b/src/base/md5.h
-@@ -21,6 +21,7 @@
- #define WL_BASE_MD5_H
- #include <cassert>
-+#include <cstdint>
- #include <cstring>
- #include <string>
-diff --git a/src/base/random.h b/src/base/random.h
-index 5030805244a..76774bc3665 100644
---- a/src/base/random.h
-+++ b/src/base/random.h
-@@ -20,6 +20,7 @@
- #define WL_BASE_RANDOM_H
- #include <cassert>
-+#include <cstdint>
- #include <string>
- extern const uint32_t rng_sbox[256];
-diff --git a/src/base/time_string.h b/src/base/time_string.h
-index 0246b190958..47767732e76 100644
---- a/src/base/time_string.h
-+++ b/src/base/time_string.h
-@@ -19,6 +19,7 @@
- #ifndef WL_BASE_TIME_STRING_H
- #define WL_BASE_TIME_STRING_H
-+#include <cstdint>
- #include <string>
- /// Get a string representation conforming to ISO 8601 of the current time (in
-diff --git a/src/build_info.h b/src/build_info.h
-index 5afecc13e82..88a382c19ce 100644
---- a/src/build_info.h
-+++ b/src/build_info.h
-@@ -19,6 +19,7 @@
- #ifndef WL_BUILD_INFO_H
- #define WL_BUILD_INFO_H
-+#include <cstdint>
- #include <string>
- constexpr uint16_t kWidelandsCopyrightStart = 2002;
-diff --git a/src/graphic/align.h b/src/graphic/align.h
-index 205a0bd0d25..f76c5040e35 100644
---- a/src/graphic/align.h
-+++ b/src/graphic/align.h
-@@ -19,6 +19,7 @@
- #ifndef WL_GRAPHIC_ALIGN_H
- #define WL_GRAPHIC_ALIGN_H
-+#include <cstdint>
- #include <string>
- #include "base/rect.h"
-diff --git a/src/graphic/text/textstream.h b/src/graphic/text/textstream.h
-index b2af46ee8e4..7fe027b8655 100644
---- a/src/graphic/text/textstream.h
-+++ b/src/graphic/text/textstream.h
-@@ -19,6 +19,7 @@
- #ifndef WL_GRAPHIC_TEXT_TEXTSTREAM_H
- #define WL_GRAPHIC_TEXT_TEXTSTREAM_H
-+#include <cstdint>
- #include <string>
- namespace RT {
-diff --git a/src/logic/generic_save_handler.h b/src/logic/generic_save_handler.h
-index 15147293c4a..97bc7544ef0 100644
---- a/src/logic/generic_save_handler.h
-+++ b/src/logic/generic_save_handler.h
-@@ -19,6 +19,7 @@
- #ifndef WL_LOGIC_GENERIC_SAVE_HANDLER_H
- #define WL_LOGIC_GENERIC_SAVE_HANDLER_H
-+#include <cstdint>
- #include <functional>
- #include "io/filesystem/filesystem.h"
-diff --git a/src/logic/map_revision.h b/src/logic/map_revision.h
-index b685a8a032e..27b0d5c40fe 100644
---- a/src/logic/map_revision.h
-+++ b/src/logic/map_revision.h
-@@ -19,6 +19,7 @@
- #ifndef WL_LOGIC_MAP_REVISION_H
- #define WL_LOGIC_MAP_REVISION_H
-+#include <cstdint>
- #include <string>
- namespace Widelands {
-diff --git a/src/logic/save_handler.h b/src/logic/save_handler.h
-index 6e6956ae654..e01503b8cba 100644
---- a/src/logic/save_handler.h
-+++ b/src/logic/save_handler.h
-@@ -19,6 +19,7 @@
- #ifndef WL_LOGIC_SAVE_HANDLER_H
- #define WL_LOGIC_SAVE_HANDLER_H
-+#include <cstdint>
- #include "io/filesystem/filesystem.h"
- namespace Widelands {
-diff --git a/src/map_io/map_elemental_packet.h b/src/map_io/map_elemental_packet.h
-index 4aa1e987e19..a20e649c01d 100644
---- a/src/map_io/map_elemental_packet.h
-+++ b/src/map_io/map_elemental_packet.h
-@@ -19,6 +19,7 @@
- #ifndef WL_MAP_IO_MAP_ELEMENTAL_PACKET_H
- #define WL_MAP_IO_MAP_ELEMENTAL_PACKET_H
-+#include <cstdint>
- #include <string>
- #include <vector>
-diff --git a/src/scripting/persistence.h b/src/scripting/persistence.h
-index 3ab3f14ec18..dbcaec15c43 100644
---- a/src/scripting/persistence.h
-+++ b/src/scripting/persistence.h
-@@ -19,6 +19,8 @@
- #ifndef WL_SCRIPTING_PERSISTENCE_H
- #define WL_SCRIPTING_PERSISTENCE_H
-+#include <cstdint>
-+
- #include "scripting/lua.h"
- class FileRead;
index 23d025d266d116c2f94bddad484b8b0981beb120..9d64e20fb787e5888a4c09da5801e690c7beddd5 100644 (file)
@@ -1,7 +1,7 @@
---- widelands-1.1/CMakeLists.txt~      2022-10-22 11:51:16.000000000 +0000
-+++ widelands-1.1/CMakeLists.txt       2023-02-04 16:06:13.829565579 +0000
-@@ -251,6 +251,10 @@
-   endif()
+--- widelands-1.2/CMakeLists.txt~      2024-03-28 10:12:05.000000000 +0000
++++ widelands-1.2/CMakeLists.txt       2024-03-30 10:51:23.584411957 +0000
+@@ -200,6 +200,10 @@
+   option(OPTION_ASAN "Build with AddressSanitizer" OFF)
  elseif(CMAKE_BUILD_TYPE STREQUAL "None")
    message(STATUS "Not setting any default flags.")
 +elseif(CMAKE_BUILD_TYPE STREQUAL "PLD")
  else()
    message(FATAL_ERROR "Unknown CMAKE_BUILD_TYPE: ${CMAKE_BUILD_TYPE}")
  endif()
-@@ -372,7 +376,7 @@
+@@ -328,7 +332,7 @@
  endif()
  
  if(NOT MSVC)
 -  if(CMAKE_BUILD_TYPE STREQUAL "Release")
-+      if( (CMAKE_BUILD_TYPE STREQUAL "PLD") OR (CMAKE_BUILD_TYPE STREQUAL "Release") )
++  if( (CMAKE_BUILD_TYPE STREQUAL "PLD") OR (CMAKE_BUILD_TYPE STREQUAL "Release") )
      message(STATUS "Compiler warnings will be ignored.")
-   elseif(("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU") AND 
-          (NOT (CMAKE_CXX_COMPILER_VERSION VERSION_LESS 12.0)) AND (CMAKE_CXX_COMPILER_VERSION VERSION_LESS 12.2))
-@@ -500,7 +504,6 @@
+   elseif(("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU") AND (
+          ((NOT (CMAKE_CXX_COMPILER_VERSION VERSION_LESS 12.0)) AND (CMAKE_CXX_COMPILER_VERSION VERSION_LESS 12.2))
+@@ -482,7 +486,6 @@
  install (
    FILES ${CMAKE_CURRENT_BINARY_DIR}/VERSION
    DESTINATION ${WL_INSTALL_BASEDIR}
@@ -28,7 +28,7 @@
    COMPONENT CoreVersionFile
  )
  
-@@ -516,7 +519,6 @@
+@@ -498,7 +501,6 @@
    FILES
      data/datadirversion
    DESTINATION ${WL_INSTALL_DATADIR}
@@ -36,7 +36,7 @@
    COMPONENT VersionFile
  )
  
-@@ -533,7 +535,6 @@
+@@ -515,7 +517,6 @@
      data/txts
      data/world
    DESTINATION ${WL_INSTALL_DATADIR}
@@ -44,7 +44,7 @@
    COMPONENT CoreDataFiles
  )
  
-@@ -541,7 +542,6 @@
+@@ -523,7 +524,6 @@
    DIRECTORY
      data/maps
    DESTINATION ${WL_INSTALL_DATADIR}
@@ -52,7 +52,7 @@
    COMPONENT MapFiles
  )
  
-@@ -550,7 +550,6 @@
+@@ -532,7 +532,6 @@
      data/music
      data/sound
    DESTINATION ${WL_INSTALL_DATADIR}
@@ -60,7 +60,7 @@
    COMPONENT MusicFiles
  )
  
-@@ -560,7 +559,6 @@
+@@ -542,7 +541,6 @@
      CREDITS
      ChangeLog
    DESTINATION ${WL_INSTALL_BASEDIR}
@@ -68,7 +68,7 @@
    COMPONENT CoreLicenseFiles
  )
  
-@@ -579,7 +577,6 @@
+@@ -561,7 +559,6 @@
      DIRECTORY
        ${CMAKE_CURRENT_BINARY_DIR}/locale/
      DESTINATION ${WL_INSTALL_DATADIR}/locale
index b52f9cff5e0982f92f262e69893b7e131b205d03..745641af71838a1ad2f3270e24bc1ce001a25260 100644 (file)
@@ -5,15 +5,14 @@
 Summary:       A real-time build-up strategy game
 Summary(pl.UTF-8):     Gra strategiczna czasu rzeczywistego z budowaniem
 Name:          widelands
-Version:       1.1
-Release:       3
+Version:       1.2
+Release:       1
 License:       GPL v2+
 Group:         X11/Applications/Games
 #Source0Download: https://wl.widelands.org/wiki/Download/#release
 Source0:       https://github.com/widelands/widelands/archive/refs/tags/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 04d84445a479a976c6d82a032b685822
+# Source0-md5: 0c52ea59b7822616f10cfe36860e2642
 Patch0:                %{name}-pld.patch
-Patch1:                gcc13.patch
 URL:           https://wl.widelands.org/
 BuildRequires: Mesa-libGL-devel
 BuildRequires: SDL2-devel >= 2
@@ -29,7 +28,7 @@ BuildRequires:        gettext-tools
 BuildRequires: glew-devel
 BuildRequires: graphviz
 BuildRequires: libicu-devel
-BuildRequires: libpng-devel
+BuildRequires: libpng-devel >= 1.6
 BuildRequires: libstdc++-devel >= 6:4.8
 BuildRequires: minizip-devel
 BuildRequires: python >= 2
@@ -90,7 +89,6 @@ potrzebny do normalnej pracy.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 
 %build
 install -d build
This page took 0.160226 seconds and 4 git commands to generate.