]> git.pld-linux.org Git - packages/widelands.git/blame - widelands.spec
split 136mb data to subpackage
[packages/widelands.git] / widelands.spec
CommitLineData
7764f64d 1# TODO:
11907a39 2# - create bcond for ggz
abdefe8d 3# - check locales
7764f64d 4#
abdefe8d 5%define buildver 16
325beb53 6Summary: Game like Settlers II
bf6aa356 7Summary(pl.UTF-8): Remake gry Settlers II
325beb53 8Name: widelands
48449069 9Version: 0.build%{buildver}
945184ed 10Release: 10
11907a39 11License: GPL v2+
325beb53 12Group: X11/Applications/Games
509c89d9 13Source0: http://launchpad.net/widelands/build%{buildver}/build%{buildver}/+download/%{name}-build%{buildver}-src.tar.bz2
abdefe8d 14# Source0-md5: 3d8c28e145b73c64d8ed1625319d25a2
325beb53 15Source1: %{name}.desktop
13357d0d 16Patch0: %{name}-libpng15.patch
325beb53 17URL: http://widelands.sourceforge.net/
7764f64d 18BuildRequires: SDL-devel >= 1.2.11
68f512a6 19BuildRequires: SDL_gfx-devel
325beb53 20BuildRequires: SDL_image-devel
00129253 21BuildRequires: SDL_mixer-devel >= 1.2.7
325beb53 22BuildRequires: SDL_net-devel
7764f64d 23BuildRequires: SDL_ttf-devel >= 2.0.0
48449069 24BuildRequires: boost-devel >= 1.35
509c89d9 25BuildRequires: cmake
acb61c96 26BuildRequires: gettext-tools
abdefe8d 27BuildRequires: glew-devel
5cf69a76 28BuildRequires: ggz-client-libs-devel
509c89d9 29BuildRequires: libjpeg-devel
929f8735 30BuildRequires: libpng-devel
325beb53 31BuildRequires: libstdc++-devel
509c89d9 32BuildRequires: libtiff-devel
15cde85f 33BuildRequires: lua51-devel
34BuildRequires: python
35BuildRequires: python-modules
abdefe8d 36BuildRequires: rpmbuild(macros) >= 1.600
945184ed 37Requires: %{name}-data = %{version}-%{release}
48449069 38Requires: SDL_image >= 1.2.10
325beb53
AG
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
42In Widelands, you are the regent of a small tribe. You start out with
43nothing but your headquarters, a kind of castle in which all your
44resources are stored. Every member of your tribe will do his or her
45part to produce more resources - wood, food, iron, gold and more - to
46further this growth. But you are not alone in the world, and you will
47meet other tribes sooner or later. Some of them may be friendly and
48trade with you. However, if you want to rule the world, you will have
49to train soldiers and fight.
50
d71c4d09
JR
51%description -l pl.UTF-8
52W grze Widelands jesteś regentem niewielkiego plemienia. Rozpoczynasz
53grę tylko z kwaterą główną, czymś w rodzaju zamku, w której
54przechowywane są wszystkie Twoje zasoby. Każdy członek plemienia
55wykona swoje zadanie w procesie produkcji tychże zasobów - drewna,
56żywności, żelaza, złota i wielu innych - aby zapewnić rozwój. Jednak
57nie jesteś sam na tym świecie i wcześniej lub później będziesz musiał
58spotkać się z innymi plemionami. Niektóre z nich mogą być przyjaźnie
59nastawione i rozpocząć z Tobą handel. Jednak, jeśli chcesz rządzić
60światem, będziesz musiał wyszkolić żołnierzy i walczyć.
325beb53 61
945184ed
ER
62%package data
63Summary: Game like Settlers II - data files
64License: GPL v2+
65Group: X11/Applications/Games
66%if "%{_rpmversion}" >= "5"
67BuildArch: noarch
68%endif
69
70%description data
71Game like Settlers II - data files.
72
325beb53 73%prep
509c89d9 74%setup -q -n %{name}-build%{buildver}-src
13357d0d 75%patch0 -p1
325beb53
AG
76
77%build
509c89d9 78install -d build
79cd build
80%cmake \
509c89d9 81 -DWL_INSTALL_BINDIR=%{_bindir} \
82 -DWL_INSTALL_DATADIR=%{_datadir}/games/%{name} \
83 -DWL_INSTALL_LOCALEDIR=%{_datadir}/games/%{name}/locale \
509c89d9 84 ..
85
86%{__make}
abdefe8d 87%{__make} lang
325beb53
AG
88
89%install
90rm -rf $RPM_BUILD_ROOT
509c89d9 91%{__make} -C build install \
92 DESTDIR=$RPM_BUILD_ROOT
bb198b26 93
abdefe8d 94install -d $RPM_BUILD_ROOT{%{_datadir}/games/%{name},%{_desktopdir},%{_pixmapsdir}}
325beb53 95
abdefe8d 96# install data
97cp -a campaigns fonts global maps music pics scripting sound tribes txts worlds $RPM_BUILD_ROOT%{_datadir}/games/%{name}
98
99# locales
100cp -a build/locale $RPM_BUILD_ROOT%{_datadir}/games/%{name}
101
102# unsupported locales
103%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/games/%{name}/locale/en_AU
104%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/games/%{name}/locale/en_CA
105
106# desktop and icon
945184ed
ER
107cp -p pics/wl-ico-128.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
108cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
325beb53
AG
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%files
114%defattr(644,root,root,755)
48449069 115%doc ChangeLog CREDITS
bb198b26 116%attr(755,root,root) %{_bindir}/%{name}
945184ed
ER
117%{_desktopdir}/%{name}.desktop
118%{_pixmapsdir}/%{name}.png
119
120%files data
121%defattr(644,root,root,755)
48449069 122%dir %{_datadir}/games/%{name}
48449069 123%{_datadir}/games/%{name}/campaigns
124%{_datadir}/games/%{name}/fonts
125%{_datadir}/games/%{name}/global
126%{_datadir}/games/%{name}/maps
127%{_datadir}/games/%{name}/music
128%{_datadir}/games/%{name}/pics
abdefe8d 129%{_datadir}/games/%{name}/scripting
48449069 130%{_datadir}/games/%{name}/sound
131%{_datadir}/games/%{name}/tribes
132%{_datadir}/games/%{name}/txts
133%{_datadir}/games/%{name}/worlds
134%dir %{_datadir}/games/%{name}/locale
509c89d9 135%lang(ar) %{_datadir}/games/%{name}/locale/ar
abdefe8d 136%lang(ast) %{_datadir}/games/%{name}/locale/ast
509c89d9 137%lang(ca) %{_datadir}/games/%{name}/locale/ca
138%lang(cs) %{_datadir}/games/%{name}/locale/cs
139%lang(da) %{_datadir}/games/%{name}/locale/da
140%lang(de) %{_datadir}/games/%{name}/locale/de
141%lang(en_GB) %{_datadir}/games/%{name}/locale/en_GB
142%lang(eo) %{_datadir}/games/%{name}/locale/eo
143%lang(es) %{_datadir}/games/%{name}/locale/es
abdefe8d 144%lang(et) %{_datadir}/games/%{name}/locale/et
509c89d9 145%lang(eu) %{_datadir}/games/%{name}/locale/eu
abdefe8d 146%lang(fa) %{_datadir}/games/%{name}/locale/fa
509c89d9 147%lang(fi) %{_datadir}/games/%{name}/locale/fi
148%lang(fr) %{_datadir}/games/%{name}/locale/fr
149%lang(gl) %{_datadir}/games/%{name}/locale/gl
150%lang(he) %{_datadir}/games/%{name}/locale/he
151%lang(hu) %{_datadir}/games/%{name}/locale/hu
152%lang(ia) %{_datadir}/games/%{name}/locale/ia
153%lang(id) %{_datadir}/games/%{name}/locale/id
154%lang(it) %{_datadir}/games/%{name}/locale/it
155%lang(ja) %{_datadir}/games/%{name}/locale/ja
abdefe8d 156%lang(ko) %{_datadir}/games/%{name}/locale/ko
509c89d9 157%lang(la) %{_datadir}/games/%{name}/locale/la
abdefe8d 158%lang(ms) %{_datadir}/games/%{name}/locale/ms
159%lang(nb) %{_datadir}/games/%{name}/locale/nb
509c89d9 160%lang(nl) %{_datadir}/games/%{name}/locale/nl
161%lang(nn) %{_datadir}/games/%{name}/locale/nn
abdefe8d 162%lang(oc) %{_datadir}/games/%{name}/locale/oc
509c89d9 163%lang(pl) %{_datadir}/games/%{name}/locale/pl
abdefe8d 164%lang(pt) %{_datadir}/games/%{name}/locale/pt
509c89d9 165%lang(pt_BR) %{_datadir}/games/%{name}/locale/pt_BR
166%lang(ru) %{_datadir}/games/%{name}/locale/ru
167%lang(si) %{_datadir}/games/%{name}/locale/si
168%lang(sk) %{_datadir}/games/%{name}/locale/sk
169%lang(sl) %{_datadir}/games/%{name}/locale/sl
170%lang(sr) %{_datadir}/games/%{name}/locale/sr
171%lang(sv) %{_datadir}/games/%{name}/locale/sv
abdefe8d 172%lang(tr) %{_datadir}/games/%{name}/locale/tr
173%lang(uk) %{_datadir}/games/%{name}/locale/uk
174%lang(vi) %{_datadir}/games/%{name}/locale/vi
175%lang(zh_CN) %{_datadir}/games/%{name}/locale/zh_CN
This page took 0.084782 seconds and 4 git commands to generate.