]> git.pld-linux.org Git - packages/wget.git/blobdiff - wget.spec
- updated to 1.20.3 (solves CVE-2019-5953)
[packages/wget.git] / wget.spec
index 3879a893e4f7cabdb5cf4da314e5211408e0bfc7..a569c47ddffd8dedbee6e251892e7df2736c1d05 100644 (file)
--- a/wget.spec
+++ b/wget.spec
@@ -5,8 +5,10 @@
 # - add http://article.gmane.org/gmane.comp.web.wget.patches/2333
 #
 # Conditional build:
+%bcond_without tests   # check target
+%bcond_without metalink # build without metalink support
 %bcond_with    gnutls  # use GnuTLS (wget default) instead of OpenSSL
-#
+
 Summary:       A utility for retrieving files using the HTTP or FTP protocols
 Summary(es.UTF-8):     Cliente en línea de comando para bajar archivos WWW/FTP con recursión opcional
 Summary(fr.UTF-8):     Un utilitaire pour recuperer des fichiers en utilisant les protocoles HTTP ou FTP
@@ -16,32 +18,49 @@ Summary(ru.UTF-8):  Утилита для получения файлов по п
 Summary(uk.UTF-8):     Утиліта для отримання файлів по протоколам HTTP та FTP
 Summary(zh_CN.UTF-8):  [通讯]功能强大的下载程序,支持断点续传
 Name:          wget
-Version:       1.14
-Release:       5
+Version:       1.20.3
+Release:       1
 License:       GPL v3+ with OpenSSL exception
 Group:         Networking/Utilities
-Source0:       http://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.xz
-# Source0-md5: 316f6f59292c9098ad81fd54f658c579
+Source0:       http://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.lz
+# Source0-md5: 3bc242eb69165247b1793dd0b794ff52
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: d8b2b56ec7461606c22edbafaf8a418f
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-wgetrc_path.patch
 Patch2:                %{name}-home_etc.patch
 Patch3:                %{name}-ssl-certs.patch
-Patch4:                %{name}-pod.patch
-Patch5:                %{name}-ssl-timeout.patch
+Patch4:                user.xdg.origin.url.patch
 URL:           http://www.gnu.org/software/wget/
-BuildRequires: autoconf >= 2.61
+BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.9
-BuildRequires: gettext-devel >= 0.17
-%{?with_gnutls:BuildRequires:  gnutls-devel}
-BuildRequires: libidn-devel
-%{!?with_gnutls:BuildRequires: openssl-devel >= 0.9.7m}
+BuildRequires: gettext-tools >= 0.19.8
+# >= 3.6.3 for TLSv1.3
+%{?with_gnutls:BuildRequires:  gnutls-devel >= 3.0.16}
+%{?with_metalink:BuildRequires:        gpgme-devel >= 0.4.2}
+BuildRequires: libidn2-devel
+%{?with_metalink:BuildRequires:        libmetalink-devel}
+BuildRequires: libpsl-devel >= 0.16.0
+BuildRequires: libuuid-devel
+# >= 1.1.0 for TLSv1.3
+%{!?with_gnutls:BuildRequires: openssl-devel >= 1.0.1}
+BuildRequires: pcre2-8-devel
 BuildRequires: perl-devel
+BuildRequires: pkgconfig
 BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo
 BuildRequires: xz
+BuildRequires: zlib-devel
+%if %{with tests}
+BuildRequires: perl-HTTP-Daemon
+BuildRequires: perl-HTTP-Message
+BuildRequires: perl-IO-Socket-SSL
+BuildRequires: python3-modules >= 1:3.0
+%endif
 Provides:      webclient
+%{?with_gnutls:Requires:       gnutls-libs >= 3.0.16}
+%{!?with_gnutls:Requires:      openssl >= 1.0.1}
+Requires:      libpsl >= 0.16.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoreqfiles         %{_bindir}/rmold
@@ -123,7 +142,7 @@ Proxy серверів, настроюваність.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
+
 %{__rm} doc/wget.info doc/sample.wgetrc.munged_for_texi_inclusion po/stamp-po
 
 # temp hack for 1.13.4
@@ -140,13 +159,28 @@ chmod +x build-aux/bzr-version-gen
 %{__autoconf}
 %{__automake}
 %configure \
-       --with-ssl%{!?with_gnutls:=openssl}
+       --enable-digest \
+       --enable-ipv6 \
+       --enable-iri \
+       --enable-largefile \
+       --enable-nls \
+       --enable-ntlm \
+       --enable-opie \
+       --enable-pcre \
+       --disable-silent-rules \
+       --with-libpsl \
+       %{__with_without metalink} \
+       --with-ssl%{!?with_gnutls:=openssl} \
+       --with-zlib \
+       %{nil}
 %{__make}
 tail -n 6 util/README >rmold.README
 
 # 1.13.4 tarball was buggy and produced empty version.
 grep %{version} src/version.c
 
+%{?with_tests:%{__make} check}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
This page took 0.083383 seconds and 4 git commands to generate.