]> git.pld-linux.org Git - packages/wget.git/blobdiff - wget.spec
- release 2 (by relup.sh)
[packages/wget.git] / wget.spec
index 93fc549d11e9e9127cd4f312cafd4bd066470b9b..90f2de3426e585a804c28e1b47fdafbd39f7d32e 100644 (file)
--- a/wget.spec
+++ b/wget.spec
@@ -3,6 +3,10 @@
 #  - http://wget-bugs.ferrara.linux.it/issue9
 #  - or http://osdir.com/ml/web.wget.patches/2005-09/msg00006.html
 # - add http://article.gmane.org/gmane.comp.web.wget.patches/2333
+#
+# Conditional build:
+%bcond_with    gnutls  # use GnuTLS (wget default) instead of OpenSSL
+#
 Summary:       A utility for retrieving files using the HTTP or FTP protocols
 Summary(es.UTF-8):     Cliente en línea de comando para bajar archivos WWW/FTP con recursión opcional
 Summary(fr.UTF-8):     Un utilitaire pour recuperer des fichiers en utilisant les protocoles HTTP ou FTP
@@ -12,28 +16,29 @@ Summary(ru.UTF-8):  Утилита для получения файлов по п
 Summary(uk.UTF-8):     Утиліта для отримання файлів по протоколам HTTP та FTP
 Summary(zh_CN.UTF-8):  [通讯]功能强大的下载程序,支持断点续传
 Name:          wget
-Version:       1.11.4
+Version:       1.15
 Release:       2
-License:       GPL v3+
+License:       GPL v3+ with OpenSSL exception
 Group:         Networking/Utilities
-Source0:       http://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.bz2
-# Source0-md5: f5076a8c2ec2b7f334cb6e3059820f9c
+Source0:       http://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.xz
+# Source0-md5: 7a279d5ac5594919124d5526e7143e28
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: d8b2b56ec7461606c22edbafaf8a418f
 Patch0:                %{name}-info.patch
-Patch1:                %{name}-ac.patch
-Patch2:                %{name}-wgetrc_path.patch
-Patch3:                %{name}-home_etc.patch
-Patch4:                %{name}-noabort.patch
-Patch5:                wget-ssl-certs.patch
+Patch1:                %{name}-wgetrc_path.patch
+Patch2:                %{name}-home_etc.patch
+Patch3:                %{name}-ssl-certs.patch
 URL:           http://www.gnu.org/software/wget/
-BuildRequires: autoconf >= 2.59
-BuildRequires: automake
-BuildRequires: gettext-devel
-BuildRequires: libtool
-BuildRequires: openssl-devel >= 0.9.7m
-BuildRequires: texinfo
+BuildRequires: autoconf >= 2.61
+BuildRequires: automake >= 1:1.9
+BuildRequires: gettext-devel >= 0.17
+%{?with_gnutls:BuildRequires:  gnutls-devel}
+BuildRequires: libidn-devel
+%{!?with_gnutls:BuildRequires: openssl-devel >= 0.9.7m}
 BuildRequires: perl-devel
+BuildRequires: tar >= 1:1.22
+BuildRequires: texinfo
+BuildRequires: xz
 Provides:      webclient
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -115,22 +120,29 @@ Proxy серверів, настроюваність.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
-%patch5 -p1
-rm -f doc/wget.info doc/sample.wgetrc.munged_for_texi_inclusion
+%{__rm} doc/wget.info doc/sample.wgetrc.munged_for_texi_inclusion po/stamp-po
+
+# temp hack for 1.13.4
+test -e build-aux/bzr-version-gen || cat <<EOF > build-aux/bzr-version-gen
+#!/bin/sh
+echo -n %{version}
+EOF
+chmod +x build-aux/bzr-version-gen
 
 %build
-%{__libtoolize}
-cp -f /usr/share/automake/config.* .
 %{__gettextize}
 %{__aclocal} -I m4
 %{__autoheader}
 %{__autoconf}
+%{__automake}
 %configure \
-       --with-ssl
+       --with-ssl%{!?with_gnutls:=openssl}
 %{__make}
 tail -n 6 util/README >rmold.README
 
+# 1.13.4 tarball was buggy and produced empty version.
+grep %{version} src/version.c
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
@@ -139,11 +151,12 @@ install -d $RPM_BUILD_ROOT%{_sysconfdir}
        DESTDIR=$RPM_BUILD_ROOT \
        GETTEXT_PACKAGE=wget
 
-install util/rmold.pl          $RPM_BUILD_ROOT%{_bindir}/rmold
-install doc/sample.wgetrc      $RPM_BUILD_ROOT%{_sysconfdir}/wgetrc
+install -p util/rmold.pl $RPM_BUILD_ROOT%{_bindir}/rmold
+cp -a doc/sample.wgetrc        $RPM_BUILD_ROOT%{_sysconfdir}/wgetrc
 
 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
-rm -f $RPM_BUILD_ROOT%{_mandir}/README*
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/README*
+rm -f $RPM_BUILD_ROOT%{_infodir}/dir
 
 %find_lang %{name}
 
@@ -160,8 +173,9 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README MAILING-LIST rmold.README
 %verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/%{name}rc
-%attr(755,root,root) %{_bindir}/*
-%{_mandir}/man1/*
-%lang(hu) %{_mandir}/hu/man1/*
-%lang(pl) %{_mandir}/pl/man1/*
-%{_infodir}/*.info*
+%attr(755,root,root) %{_bindir}/rmold
+%attr(755,root,root) %{_bindir}/wget
+%{_mandir}/man1/wget.1*
+%{_mandir}/hu/man1/wget.1*
+%{_mandir}/pl/man1/wget.1*
+%{_infodir}/wget.info*
This page took 0.032783 seconds and 4 git commands to generate.