]> git.pld-linux.org Git - packages/wesnoth.git/blobdiff - wesnoth.spec
- release 3 (by relup.sh)
[packages/wesnoth.git] / wesnoth.spec
index d4cd09010208ce35fcf1305b4df9d0c23573ae46..e763299822a456e90d936bb086d9582f99e18778 100644 (file)
@@ -1,5 +1,6 @@
 # TODO
 # - unpackaged language files
+#
 # Conditional build
 %bcond_without server  # without server
 %bcond_without tools   # without tools
@@ -9,17 +10,18 @@ Summary:     Strategy game with a fantasy theme
 Summary(hu.UTF-8):     Fantasy környezetben játszódó stratégiai játék
 Summary(pl.UTF-8):     Strategiczna gra z motywem fantasy
 Name:          wesnoth
-Version:       1.8.5
-Release:       1
+Version:       1.10.3
+Release:       3
 Epoch:         1
 License:       GPL v2+
 Group:         X11/Applications/Games/Strategy
 Source0:       http://downloads.sourceforge.net/wesnoth/%{name}-%{version}.tar.bz2
-# Source0-md5: a800285d1406690755dd0ea22b98b6df
+# Source0-md5: b25354c71d58f82c2c60cc12c6f09c36
 Source1:       %{name}d.init
-Patch0:                %{name}-libpng.patch
-Patch1:                %{name}-desktop.patch
-Patch2:                %{name}-locale_dir.patch
+Source2:       %{name}.tmpfiles
+Patch0:                %{name}-desktop.patch
+Patch1:                %{name}-locale_dir.patch
+Patch2:                boost-1.50.patch
 URL:           http://www.wesnoth.org/
 BuildRequires: SDL-devel >= 1.2.14-4
 BuildRequires: SDL_image-devel >= 1.2
@@ -39,7 +41,7 @@ BuildRequires:        lua51-devel
 BuildRequires: pango-devel
 BuildRequires: pkgconfig
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: rpmbuild(macros) >= 1.600
 BuildRequires: sed >= 4.0
 BuildRequires: zlib-devel
 Requires:      SDL >= 1.2.14-4
@@ -119,15 +121,11 @@ Edytor map i narzędzia do tłumaczeń.
 # don't install locales in %{_datadir}/%{name}
 %{__sed} -i 's,${DATADIR}/${LOCALEDIR},${LOCALEDIR},' CMakeLists.txt
 
-# link using libpng instead of libpng12
-%{__sed} -i 's,png12,png,' src/CMakeLists.txt
-
 %build
 install -d build
 cd build
-%cmake .. \
-       -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
-       -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+%cmake \
+       .. \
        -DENABLE_STRICT_COMPILATION="off" \
        -DBINDIR="%{_bindir}" \
        -DMANDIR="%{_mandir}" \
@@ -136,16 +134,14 @@ cd build
        %{?with_server:-DENABLE_CAMPAIGN_SERVER="on"} \
        %{!?with_tools:-DENABLE_EDITOR="off"} \
        %{?with_tools:-DENABLE_TOOLS="on"} \
-       %{!?with_fribidi:-DENABLE_FRIBIDI="off"} \
-%if "%{_lib}" == "lib64"
-       -DLIB_SUFFIX=64
-%endif
+       %{!?with_fribidi:-DENABLE_FRIBIDI="off"}
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d,%{_docdir}/%{name}-%{version}}
+install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d} \
+       $RPM_BUILD_ROOT{/usr/lib/tmpfiles.d,%{_docdir}/%{name}-%{version}}
 
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -156,22 +152,26 @@ gzip -9nf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{changelog,README}
 
 %if %{with server}
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
+install %{SOURCE2} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
 %endif
 
 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/nb{_NO,}
 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/fur{_IT,}
 
 # unsupported(?)
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/ca_ES@valencia
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/la
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/racv
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/en@shaw
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavianlatin
-rm -rf $RPM_BUILD_ROOT%{_mandir}/ca_ES@valencia
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ang@latin
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ca_ES@valencia
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/la
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/racv
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/en@shaw
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavianlatin
+%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/ca_ES@valencia
+%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/sr@ijekavian
+%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/sr@ijekavianlatin
 
 # the same as manuals from %{_mandir}/man?
-rm -rf $RPM_BUILD_ROOT%{_mandir}/en_GB
+%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/en_GB
 
 %find_lang %{name} --all-name
 
@@ -201,22 +201,20 @@ fi
 %{_mandir}/man6/wesnoth.6*
 %lang(cs) %{_mandir}/cs/man6/wesnoth.6*
 %lang(de) %{_mandir}/de/man6/wesnoth.6*
-%lang(es) %{_mandir}/es/man6/wesnoth.6*
 %lang(et) %{_mandir}/et/man6/wesnoth.6*
+%lang(es) %{_mandir}/es/man6/wesnoth.6*
 %lang(fi) %{_mandir}/fi/man6/wesnoth.6*
 %lang(fr) %{_mandir}/fr/man6/wesnoth.6*
 %lang(gl) %{_mandir}/gl/man6/wesnoth.6*
 %lang(hu) %{_mandir}/hu/man6/wesnoth.6*
 %lang(id) %{_mandir}/id/man6/wesnoth.6*
 %lang(it) %{_mandir}/it/man6/wesnoth.6*
-%lang(ja) %{_mandir}/ja/man6/wesnoth.6*
 %lang(lt) %{_mandir}/lt/man6/wesnoth.6*
 %lang(pl) %{_mandir}/pl/man6/wesnoth.6*
-%lang(pt_BR) %{_mandir}/pt_BR/man6/wesnoth.6*
+%lang(ru) %{_mandir}/ru/man6/wesnoth.6*
 %lang(sk) %{_mandir}/sk/man6/wesnoth.6*
 %lang(sr) %{_mandir}/sr/man6/wesnoth.6*
 %lang(sr@latin) %{_mandir}/sr@latin/man6/wesnoth.6*
-%lang(tr) %{_mandir}/tr/man6/wesnoth.6*
 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth.6*
 %lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth.6*
 %{_datadir}/%{name}
@@ -244,6 +242,7 @@ fi
 %lang(lt) %{_mandir}/lt/man6/wesnothd.6*
 %lang(pl) %{_mandir}/pl/man6/wesnothd.6*
 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnothd.6*
+%lang(ru) %{_mandir}/ru/man6/wesnothd.6*
 %lang(sk) %{_mandir}/sk/man6/wesnothd.6*
 %lang(sr) %{_mandir}/sr/man6/wesnothd.6*
 %lang(sr@latin) %{_mandir}/sr@latin/man6/wesnothd.6*
@@ -251,6 +250,7 @@ fi
 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnothd.6*
 %lang(zh_TW) %{_mandir}/zh_TW/man6/wesnothd.6*
 %attr(770,wesnothd,wesnothd) %dir /var/run/wesnothd
+/usr/lib/tmpfiles.d/%{name}.conf
 %endif
 
 %if %{with tools}
This page took 0.053293 seconds and 4 git commands to generate.