]> git.pld-linux.org Git - packages/wesnoth.git/blobdiff - wesnoth.spec
- release 3 (by relup.sh)
[packages/wesnoth.git] / wesnoth.spec
index 3d847900308e98d247eefe4d38aaf482e3b05191..e763299822a456e90d936bb086d9582f99e18778 100644 (file)
@@ -1,8 +1,6 @@
 # TODO
-# - rename language files sr@latin to sr@Latn and include them
-# - use desktop file included with project (consider which one are better)
-# - dont know what should I do with sr@latin and racv man pages
 # - unpackaged language files
+#
 # Conditional build
 %bcond_without server  # without server
 %bcond_without tools   # without tools
@@ -12,39 +10,43 @@ Summary:    Strategy game with a fantasy theme
 Summary(hu.UTF-8):     Fantasy környezetben játszódó stratégiai játék
 Summary(pl.UTF-8):     Strategiczna gra z motywem fantasy
 Name:          wesnoth
-Version:       1.6.3
-Release:       1
+Version:       1.10.3
+Release:       3
 Epoch:         1
 License:       GPL v2+
 Group:         X11/Applications/Games/Strategy
-Source0:       http://dl.sourceforge.net/wesnoth/%{name}-%{version}.tar.bz2
-# Source0-md5: 2ffabfbbcbfd2e6c0ab5dac1d314d9e1
-Source1:       %{name}.desktop
-Source2:       %{name}_editor.desktop
-Source3:       %{name}d.init
-Patch0:                %{name}-Makefile.patch
+Source0:       http://downloads.sourceforge.net/wesnoth/%{name}-%{version}.tar.bz2
+# Source0-md5: b25354c71d58f82c2c60cc12c6f09c36
+Source1:       %{name}d.init
+Source2:       %{name}.tmpfiles
+Patch0:                %{name}-desktop.patch
 Patch1:                %{name}-locale_dir.patch
+Patch2:                boost-1.50.patch
 URL:           http://www.wesnoth.org/
-BuildRequires: SDL-devel >= 1.2.7
+BuildRequires: SDL-devel >= 1.2.14-4
 BuildRequires: SDL_image-devel >= 1.2
 BuildRequires: SDL_mixer-devel >= 1.2
 BuildRequires: SDL_net-devel >= 1.2
 BuildRequires: SDL_ttf-devel >= 2.0.8
-BuildRequires: autoconf >= 2.59
-BuildRequires: automake >= 1:1.9
+BuildRequires: asciidoc
 BuildRequires: boost-devel >= 1.33
+BuildRequires: cmake >= 2.4
+BuildRequires: dbus-devel
 %{?with_fribidi:BuildRequires: fribidi-devel}
 BuildRequires: gettext-devel
 BuildRequires: libpng-devel
 BuildRequires: libstdc++-devel
-BuildRequires: libtool >= 2:1.5
 BuildRequires: libvorbis-devel
-BuildRequires: pkg-config
-BuildRequires: python-devel
+BuildRequires: lua51-devel
+BuildRequires: pango-devel
+BuildRequires: pkgconfig
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: rpmbuild(macros) >= 1.600
 BuildRequires: sed >= 4.0
-BuildRequires: zipios++-devel
+BuildRequires: zlib-devel
+Requires:      SDL >= 1.2.14-4
+# sr@Latn vs. sr@latin
+Conflicts:     glibc-misc < 6:2.7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -80,6 +82,10 @@ Requires(postun):    /usr/sbin/userdel
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires:      rc-scripts >= 0.4.0.17
+Provides:      group(wesnothd)
+Provides:      user(wesnothd)
+# sr@Latn vs. sr@latin
+Conflicts:     glibc-misc < 6:2.7
 
 %description server
 Server for playing networked games of Wesnoth.
@@ -110,59 +116,62 @@ Edytor map i narzędzia do tłumaczeń.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%{__sed} -i 's,$PYTHON_PREFIX"/lib/,"%{_libdir}/,g' configure.ac
+%patch2 -p1
+
+# don't install locales in %{_datadir}/%{name}
+%{__sed} -i 's,${DATADIR}/${LOCALEDIR},${LOCALEDIR},' CMakeLists.txt
 
 %build
-%{__gettextize}
-%{__aclocal} -I m4
-%{__autoconf}
-%{__autoheader}
-%{__automake}
-%configure \
-       PYTHON_VERSION=%{py_ver} \
-       %{?with_server:--enable-server} \
-       %{?with_server:--enable-campaign-server} \
-       --enable-python-install \
-       %{?with_tools:--enable-editor} \
-       %{?with_tools:--enable-tools} \
-       --with%{!?with_fribidi:out}-fribidi \
-       --docdir=%{_docdir}/%{name}-%{version} \
-       --with-icondir=%{_pixmapsdir} \
-       --with-zipios
+install -d build
+cd build
+%cmake \
+       .. \
+       -DENABLE_STRICT_COMPILATION="off" \
+       -DBINDIR="%{_bindir}" \
+       -DMANDIR="%{_mandir}" \
+       -DLOCALEDIR="%{_datadir}/locale" \
+       %{!?with_server:-DENABLE_SERVER="off"} \
+       %{?with_server:-DENABLE_CAMPAIGN_SERVER="on"} \
+       %{!?with_tools:-DENABLE_EDITOR="off"} \
+       %{?with_tools:-DENABLE_TOOLS="on"} \
+       %{!?with_fribidi:-DENABLE_FRIBIDI="off"}
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d,%{_docdir}/%{name}-%{version}}
+install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d} \
+       $RPM_BUILD_ROOT{/usr/lib/tmpfiles.d,%{_docdir}/%{name}-%{version}}
 
-%{__make} install \
+%{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
 # install additional docs
 install changelog README  $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
 gzip -9nf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{changelog,README}
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
-install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
 %if %{with server}
-install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
+install %{SOURCE2} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
 %endif
 
-mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{nb_NO,nb}
+mv -f $RPM_BUILD_ROOT%{_datadir}/locale/nb{_NO,}
+mv -f $RPM_BUILD_ROOT%{_datadir}/locale/fur{_IT,}
 
 # unsupported(?)
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/ca_ES@valencia
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/fur_IT
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/la
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/racv
-rm -rf $RPM_BUILD_ROOT%{_mandir}/ca_ES@valencia
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ang@latin
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ca_ES@valencia
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/la
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/racv
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/en@shaw
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavianlatin
+%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/ca_ES@valencia
+%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/sr@ijekavian
+%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/sr@ijekavianlatin
 
 # the same as manuals from %{_mandir}/man?
-rm -rf $RPM_BUILD_ROOT%{_mandir}/en_GB
-
-%py_comp $RPM_BUILD_ROOT%{py_sitedir}
-%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
-%py_postclean
+%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/en_GB
 
 %find_lang %{name} --all-name
 
@@ -191,28 +200,26 @@ fi
 %attr(755,root,root) %{_bindir}/wesnoth
 %{_mandir}/man6/wesnoth.6*
 %lang(cs) %{_mandir}/cs/man6/wesnoth.6*
-#%%lang(da) %{_mandir}/da/man6/wesnoth.6*
 %lang(de) %{_mandir}/de/man6/wesnoth.6*
+%lang(et) %{_mandir}/et/man6/wesnoth.6*
 %lang(es) %{_mandir}/es/man6/wesnoth.6*
 %lang(fi) %{_mandir}/fi/man6/wesnoth.6*
 %lang(fr) %{_mandir}/fr/man6/wesnoth.6*
 %lang(gl) %{_mandir}/gl/man6/wesnoth.6*
 %lang(hu) %{_mandir}/hu/man6/wesnoth.6*
+%lang(id) %{_mandir}/id/man6/wesnoth.6*
 %lang(it) %{_mandir}/it/man6/wesnoth.6*
-#%%lang(ja) %{_mandir}/ja/man6/wesnoth.6*
 %lang(lt) %{_mandir}/lt/man6/wesnoth.6*
-#%%lang(nl) %{_mandir}/nl/man6/wesnoth.6*
 %lang(pl) %{_mandir}/pl/man6/wesnoth.6*
-#%%lang(ru) %{_mandir}/ru/man6/wesnoth.6*
+%lang(ru) %{_mandir}/ru/man6/wesnoth.6*
 %lang(sk) %{_mandir}/sk/man6/wesnoth.6*
 %lang(sr) %{_mandir}/sr/man6/wesnoth.6*
-%lang(sv) %{_mandir}/sv/man6/wesnoth.6*
-%lang(tr) %{_mandir}/tr/man6/wesnoth.6*
+%lang(sr@latin) %{_mandir}/sr@latin/man6/wesnoth.6*
 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth.6*
-#%%lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth.6*
+%lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth.6*
 %{_datadir}/%{name}
-%{_desktopdir}/%{name}.desktop
-%{_pixmapsdir}/%{name}-icon.png
+%{_desktopdir}/*.desktop
+%{_pixmapsdir}/*-icon.png
 
 %if %{with server}
 %files server
@@ -222,25 +229,28 @@ fi
 %attr(754,root,root) /etc/rc.d/init.d/wesnothd
 %{_mandir}/man6/wesnothd.6*
 %lang(cs) %{_mandir}/cs/man6/wesnothd.6*
-#%%lang(da) %{_mandir}/da/man6/wesnothd.6*
 %lang(de) %{_mandir}/de/man6/wesnothd.6*
 %lang(es) %{_mandir}/es/man6/wesnothd.6*
+%lang(et) %{_mandir}/et/man6/wesnothd.6*
 %lang(fi) %{_mandir}/fi/man6/wesnothd.6*
 %lang(fr) %{_mandir}/fr/man6/wesnothd.6*
-#%%lang(gl) %{_mandir}/gl/man6/wesnothd.6*
+%lang(gl) %{_mandir}/gl/man6/wesnothd.6*
 %lang(hu) %{_mandir}/hu/man6/wesnothd.6*
+%lang(id) %{_mandir}/id/man6/wesnothd.6*
 %lang(it) %{_mandir}/it/man6/wesnothd.6*
-#%lang(ja) %{_mandir}/ja/man6/wesnothd.6*
+%lang(ja) %{_mandir}/ja/man6/wesnothd.6*
 %lang(lt) %{_mandir}/lt/man6/wesnothd.6*
-#%%lang(nl) %{_mandir}/nl/man6/wesnothd.6*
 %lang(pl) %{_mandir}/pl/man6/wesnothd.6*
-#%%lang(sk) %{_mandir}/sk/man6/wesnothd.6*
+%lang(pt_BR) %{_mandir}/pt_BR/man6/wesnothd.6*
+%lang(ru) %{_mandir}/ru/man6/wesnothd.6*
+%lang(sk) %{_mandir}/sk/man6/wesnothd.6*
 %lang(sr) %{_mandir}/sr/man6/wesnothd.6*
-%lang(sv) %{_mandir}/sv/man6/wesnothd.6*
+%lang(sr@latin) %{_mandir}/sr@latin/man6/wesnothd.6*
 %lang(tr) %{_mandir}/tr/man6/wesnothd.6*
 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnothd.6*
-#%%lang(zh_TW) %{_mandir}/zh_TW/man6/wesnothd.6*
+%lang(zh_TW) %{_mandir}/zh_TW/man6/wesnothd.6*
 %attr(770,wesnothd,wesnothd) %dir /var/run/wesnothd
+/usr/lib/tmpfiles.d/%{name}.conf
 %endif
 
 %if %{with tools}
@@ -248,32 +258,4 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/cutter
 %attr(755,root,root) %{_bindir}/exploder
-%attr(755,root,root) %{_bindir}/wesnoth_addon_manager
-#%%attr(755,root,root) %{_bindir}/wesnoth_editor
-%attr(755,root,root) %{_bindir}/wmlindent
-%attr(755,root,root) %{_bindir}/wmllint
-%attr(755,root,root) %{_bindir}/wmlscope
-#%%{_mandir}/man6/wesnoth_editor.6*
-#%%lang(cs) %{_mandir}/cs/man6/wesnoth_editor.6*
-#%%lang(da) %{_mandir}/da/man6/wesnoth_editor.6*
-#%%lang(de) %{_mandir}/de/man6/wesnoth_editor.6*
-#%%lang(es) %{_mandir}/es/man6/wesnoth_editor.6*
-#%%lang(fr) %{_mandir}/fr/man6/wesnoth_editor.6*
-#%%lang(gl) %{_mandir}/gl/man6/wesnoth_editor.6*
-#%%lang(hu) %{_mandir}/hu/man6/wesnoth_editor.6*
-#%%lang(it) %{_mandir}/it/man6/wesnoth_editor.6*
-#%%lang(ja) %{_mandir}/ja/man6/wesnoth_editor.6*
-#%%lang(lt) %{_mandir}/lt/man6/wesnoth_editor.6*
-#%%lang(nl) %{_mandir}/nl/man6/wesnoth_editor.6*
-#%%lang(pl) %{_mandir}/pl/man6/wesnoth_editor.6*
-#%%lang(sk) %{_mandir}/sk/man6/wesnoth_editor.6*
-#%%lang(sr) %{_mandir}/sr/man6/wesnoth_editor.6*
-#%%lang(sv) %{_mandir}/sv/man6/wesnoth_editor.6*
-#%%lang(tr) %{_mandir}/tr/man6/wesnoth_editor.6*
-#%%lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth_editor.6*
-#%%lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth_editor.6*
-%{_desktopdir}/%{name}_editor.desktop
-%{_pixmapsdir}/%{name}_editor-icon.png
-%dir %{py_sitedir}/%{name}
-%{py_sitedir}/%{name}/*.py[co]
 %endif
This page took 0.114077 seconds and 4 git commands to generate.