]> git.pld-linux.org Git - packages/wesnoth.git/blobdiff - wesnoth.spec
- up to 1.6.4
[packages/wesnoth.git] / wesnoth.spec
index 796da0b86527ae7abf678074a6620b67bc7f192e..b05c3d34537dd308d3c5eb0954fe061a050ceef4 100644 (file)
@@ -2,33 +2,35 @@
 # - rename language files sr@latin to sr@Latn and include them
 # - use desktop file included with project (consider which one are better)
 # - dont know what should I do with sr@latin man pages
-#
+# - unpackaged language files
 # Conditional build
 %bcond_without server  # without server
 %bcond_without tools   # without tools
 %bcond_without fribidi # without Bidirectional language support
 #
 Summary:       Strategy game with a fantasy theme
+Summary(hu.UTF-8):     Fantasy környezetben játszódó stratégiai játék
 Summary(pl.UTF-8):     Strategiczna gra z motywem fantasy
 Name:          wesnoth
-Version:       1.4.3
+Version:       1.6.4
 Release:       1
 Epoch:         1
 License:       GPL v2+
 Group:         X11/Applications/Games/Strategy
-Source0:       http://www.wesnoth.org/files/%{name}-%{version}.tar.bz2
-# Source0-md5: 6f3fabb79b4f340eb94bd92b083085e5
+Source0:       http://dl.sourceforge.net/wesnoth/%{name}-%{version}.tar.bz2
+# Source0-md5: c8bc4c5b2be28e29563dfe3f89eafd51
 Source1:       %{name}.desktop
 Source2:       %{name}_editor.desktop
 Source3:       %{name}d.init
 Patch0:                %{name}-Makefile.patch
 Patch1:                %{name}-locale_dir.patch
+Patch2:                %{name}-werror.patch
 URL:           http://www.wesnoth.org/
 BuildRequires: SDL-devel >= 1.2.7
 BuildRequires: SDL_image-devel >= 1.2
 BuildRequires: SDL_mixer-devel >= 1.2
 BuildRequires: SDL_net-devel >= 1.2
-BuildRequires: SDL_ttf-devel >= 2.0
+BuildRequires: SDL_ttf-devel >= 2.0.8
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake >= 1:1.9
 BuildRequires: boost-devel >= 1.33
@@ -37,9 +39,12 @@ BuildRequires:       gettext-devel
 BuildRequires: libpng-devel
 BuildRequires: libstdc++-devel
 BuildRequires: libtool >= 2:1.5
+BuildRequires: libvorbis-devel
+BuildRequires: pkg-config
 BuildRequires: python-devel
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: sed >= 4.0
 BuildRequires: zipios++-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -50,6 +55,14 @@ disadvantages in different types of terrains and against different
 types of attacks. Units gain experience and advance levels, and are
 carried over from one scenario to the next campaign.
 
+%description -l hu.UTF-8
+Battle for Wesnoth (Harc Wesnothért) egy fantasy környezetben játszódó
+stratégiai játék. Harc a falvak megszerzéséért, különböző egységek
+felhasználásával, amelyeknek különböző előnyeik és hátrányaik vannak a
+különféle terepeken és a különböző támadási stílusok ellen. Az
+egységek tapasztalatot gyűjtenek, és fejlődnek, amelyek átvihetők a
+következő pályára.
+
 %description -l pl.UTF-8
 Bitwa o Wesnoth jest strategiczną grą fantasy. Batalia o kontrolę nad
 wsiami przy pomocy różnego rodzaju oddziałów, które mają przewagę lub
@@ -59,6 +72,7 @@ przenoszone z jednej scenerii do następnej kampanii.
 
 %package server
 Summary:       Network server for Wesnoth
+Summary(hu.UTF-8):     Hálózati szerver Wesnoth-hoz
 Summary(pl.UTF-8):     Sieciowy serwer dla Wesnoth
 Group:         X11/Applications/Games/Strategy
 Requires(post,preun):  /sbin/chkconfig
@@ -71,11 +85,15 @@ Requires:   rc-scripts >= 0.4.0.17
 %description server
 Server for playing networked games of Wesnoth.
 
+%description server -l hu.UTF-8
+Szerver a Wesnoth hálózati játékához.
+
 %description server -l pl.UTF-8
 Serwer do prowadzenia sieciowych gier Wesnoth.
 
 %package tools
 Summary:       Tools for Wesnoth
+Summary(hu.UTF.8):     Eszközök a Wesnoth-hoz
 Summary(pl.UTF-8):     Narzędzia dla Wesnoth
 Group:         X11/Applications/Games/Strategy
 Requires:      %{name} = %{epoch}:%{version}-%{release}
@@ -83,6 +101,9 @@ Requires:    %{name} = %{epoch}:%{version}-%{release}
 %description tools
 Map editor and translations tools.
 
+%description tools -l hu.UTF-8
+Pályaszerkesztők és fordítási eszközök.
+
 %description tools -l pl.UTF-8
 Edytor map i narzędzia do tłumaczeń.
 
@@ -90,6 +111,8 @@ Edytor map i narzędzia do tłumaczeń.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%{__sed} -i 's,$PYTHON_PREFIX"/lib/,"%{_libdir}/,g' configure.ac
 
 %build
 %{__gettextize}
@@ -98,7 +121,10 @@ Edytor map i narzędzia do tłumaczeń.
 %{__autoheader}
 %{__automake}
 %configure \
+       PYTHON_VERSION=%{py_ver} \
        %{?with_server:--enable-server} \
+       %{?with_server:--enable-campaign-server} \
+       --enable-python-install \
        %{?with_tools:--enable-editor} \
        %{?with_tools:--enable-tools} \
        --with%{!?with_fribidi:out}-fribidi \
@@ -120,20 +146,26 @@ gzip -9nf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{changelog,README}
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
+%if %{with server}
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
+%endif
 
-mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{gl_ES,gl}
 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{nb_NO,nb}
-mv -f $RPM_BUILD_ROOT%{_mandir}/{gl_ES,gl}
 
 # unsupported(?)
 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/ca_ES@valencia
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/fur_IT
 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/la
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/racv
 rm -rf $RPM_BUILD_ROOT%{_mandir}/ca_ES@valencia
 
 # the same as manuals from %{_mandir}/man?
 rm -rf $RPM_BUILD_ROOT%{_mandir}/en_GB
 
+%py_comp $RPM_BUILD_ROOT%{py_sitedir}
+%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
+%py_postclean
+
 %find_lang %{name} --all-name
 
 %clean
@@ -161,22 +193,25 @@ fi
 %attr(755,root,root) %{_bindir}/wesnoth
 %{_mandir}/man6/wesnoth.6*
 %lang(cs) %{_mandir}/cs/man6/wesnoth.6*
-%lang(da) %{_mandir}/da/man6/wesnoth.6*
+#%%lang(da) %{_mandir}/da/man6/wesnoth.6*
 %lang(de) %{_mandir}/de/man6/wesnoth.6*
 %lang(es) %{_mandir}/es/man6/wesnoth.6*
+%lang(fi) %{_mandir}/fi/man6/wesnoth.6*
 %lang(fr) %{_mandir}/fr/man6/wesnoth.6*
 %lang(gl) %{_mandir}/gl/man6/wesnoth.6*
 %lang(hu) %{_mandir}/hu/man6/wesnoth.6*
 %lang(it) %{_mandir}/it/man6/wesnoth.6*
-%lang(ja) %{_mandir}/ja/man6/wesnoth.6*
+#%%lang(ja) %{_mandir}/ja/man6/wesnoth.6*
 %lang(lt) %{_mandir}/lt/man6/wesnoth.6*
-%lang(nl) %{_mandir}/nl/man6/wesnoth.6*
+#%%lang(nl) %{_mandir}/nl/man6/wesnoth.6*
 %lang(pl) %{_mandir}/pl/man6/wesnoth.6*
+#%%lang(ru) %{_mandir}/ru/man6/wesnoth.6*
 %lang(sk) %{_mandir}/sk/man6/wesnoth.6*
 %lang(sr) %{_mandir}/sr/man6/wesnoth.6*
 %lang(sv) %{_mandir}/sv/man6/wesnoth.6*
 %lang(tr) %{_mandir}/tr/man6/wesnoth.6*
 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth.6*
+%lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth.6*
 %{_datadir}/%{name}
 %{_desktopdir}/%{name}.desktop
 %{_pixmapsdir}/%{name}-icon.png
@@ -184,26 +219,29 @@ fi
 %if %{with server}
 %files server
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/campaignd
 %attr(755,root,root) %{_bindir}/wesnothd
 %attr(754,root,root) /etc/rc.d/init.d/wesnothd
 %{_mandir}/man6/wesnothd.6*
 %lang(cs) %{_mandir}/cs/man6/wesnothd.6*
-%lang(da) %{_mandir}/da/man6/wesnothd.6*
+#%%lang(da) %{_mandir}/da/man6/wesnothd.6*
 %lang(de) %{_mandir}/de/man6/wesnothd.6*
 %lang(es) %{_mandir}/es/man6/wesnothd.6*
+%lang(fi) %{_mandir}/fi/man6/wesnothd.6*
 %lang(fr) %{_mandir}/fr/man6/wesnothd.6*
-%lang(gl) %{_mandir}/gl/man6/wesnothd.6*
+#%%lang(gl) %{_mandir}/gl/man6/wesnothd.6*
 %lang(hu) %{_mandir}/hu/man6/wesnothd.6*
 %lang(it) %{_mandir}/it/man6/wesnothd.6*
-%lang(ja) %{_mandir}/ja/man6/wesnothd.6*
+#%lang(ja) %{_mandir}/ja/man6/wesnothd.6*
 %lang(lt) %{_mandir}/lt/man6/wesnothd.6*
-%lang(nl) %{_mandir}/nl/man6/wesnothd.6*
+#%%lang(nl) %{_mandir}/nl/man6/wesnothd.6*
 %lang(pl) %{_mandir}/pl/man6/wesnothd.6*
-%lang(sk) %{_mandir}/sk/man6/wesnothd.6*
+#%%lang(sk) %{_mandir}/sk/man6/wesnothd.6*
 %lang(sr) %{_mandir}/sr/man6/wesnothd.6*
 %lang(sv) %{_mandir}/sv/man6/wesnothd.6*
 %lang(tr) %{_mandir}/tr/man6/wesnothd.6*
 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnothd.6*
+%lang(zh_TW) %{_mandir}/zh_TW/man6/wesnothd.6*
 %attr(770,wesnothd,wesnothd) %dir /var/run/wesnothd
 %endif
 
@@ -212,28 +250,32 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/cutter
 %attr(755,root,root) %{_bindir}/exploder
-%attr(755,root,root) %{_bindir}/wesnoth_editor
+%attr(755,root,root) %{_bindir}/wesnoth_addon_manager
+#%%attr(755,root,root) %{_bindir}/wesnoth_editor
 %attr(755,root,root) %{_bindir}/wmlindent
 %attr(755,root,root) %{_bindir}/wmllint
 %attr(755,root,root) %{_bindir}/wmlscope
-%{_mandir}/man6/wesnoth_editor.6*
-%lang(cs) %{_mandir}/cs/man6/wesnoth_editor.6*
-%lang(da) %{_mandir}/da/man6/wesnoth_editor.6*
-%lang(de) %{_mandir}/de/man6/wesnoth_editor.6*
-%lang(es) %{_mandir}/es/man6/wesnoth_editor.6*
-%lang(fr) %{_mandir}/fr/man6/wesnoth_editor.6*
-%lang(gl) %{_mandir}/gl/man6/wesnoth_editor.6*
-%lang(hu) %{_mandir}/hu/man6/wesnoth_editor.6*
-%lang(it) %{_mandir}/it/man6/wesnoth_editor.6*
-%lang(ja) %{_mandir}/ja/man6/wesnoth_editor.6*
-%lang(lt) %{_mandir}/lt/man6/wesnoth_editor.6*
-%lang(nl) %{_mandir}/nl/man6/wesnoth_editor.6*
-%lang(pl) %{_mandir}/pl/man6/wesnoth_editor.6*
-%lang(sk) %{_mandir}/sk/man6/wesnoth_editor.6*
-%lang(sr) %{_mandir}/sr/man6/wesnoth_editor.6*
-%lang(sv) %{_mandir}/sv/man6/wesnoth_editor.6*
-%lang(tr) %{_mandir}/tr/man6/wesnoth_editor.6*
-%lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth_editor.6*
+#%%{_mandir}/man6/wesnoth_editor.6*
+#%%lang(cs) %{_mandir}/cs/man6/wesnoth_editor.6*
+#%%lang(da) %{_mandir}/da/man6/wesnoth_editor.6*
+#%%lang(de) %{_mandir}/de/man6/wesnoth_editor.6*
+#%%lang(es) %{_mandir}/es/man6/wesnoth_editor.6*
+#%%lang(fr) %{_mandir}/fr/man6/wesnoth_editor.6*
+#%%lang(gl) %{_mandir}/gl/man6/wesnoth_editor.6*
+#%%lang(hu) %{_mandir}/hu/man6/wesnoth_editor.6*
+#%%lang(it) %{_mandir}/it/man6/wesnoth_editor.6*
+#%%lang(ja) %{_mandir}/ja/man6/wesnoth_editor.6*
+#%%lang(lt) %{_mandir}/lt/man6/wesnoth_editor.6*
+#%%lang(nl) %{_mandir}/nl/man6/wesnoth_editor.6*
+#%%lang(pl) %{_mandir}/pl/man6/wesnoth_editor.6*
+#%%lang(sk) %{_mandir}/sk/man6/wesnoth_editor.6*
+#%%lang(sr) %{_mandir}/sr/man6/wesnoth_editor.6*
+#%%lang(sv) %{_mandir}/sv/man6/wesnoth_editor.6*
+#%%lang(tr) %{_mandir}/tr/man6/wesnoth_editor.6*
+#%%lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth_editor.6*
+#%%lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth_editor.6*
 %{_desktopdir}/%{name}_editor.desktop
 %{_pixmapsdir}/%{name}_editor-icon.png
+%dir %{py_sitedir}/%{name}
+%{py_sitedir}/%{name}/*.py[co]
 %endif
This page took 0.072212 seconds and 4 git commands to generate.