]> git.pld-linux.org Git - packages/wesnoth.git/blob - wesnoth.spec
- rebuild with boost 1.71
[packages/wesnoth.git] / wesnoth.spec
1 # TODO
2 # - unpackaged language files
3 #
4 # Conditional build
5 %bcond_without  server  # without server
6 %bcond_without  tools   # without tools
7 %bcond_without  fribidi # without Bidirectional language support
8
9 Summary:        Strategy game with a fantasy theme
10 Summary(hu.UTF-8):      Fantasy környezetben játszódó stratégiai játék
11 Summary(pl.UTF-8):      Strategiczna gra z motywem fantasy
12 Name:           wesnoth
13 Version:        1.10.4
14 Release:        16
15 Epoch:          1
16 License:        GPL v2+
17 Group:          X11/Applications/Games/Strategy
18 Source0:        http://downloads.sourceforge.net/wesnoth/%{name}-%{version}.tar.bz2
19 # Source0-md5:  1a673f12e4521fc66e60ec584fa7c98f
20 Source1:        %{name}d.init
21 Source2:        %{name}.tmpfiles
22 Patch0:         %{name}-desktop.patch
23 Patch1:         %{name}-locale_dir.patch
24 URL:            http://www.wesnoth.org/
25 BuildRequires:  SDL-devel >= 1.2.14-4
26 BuildRequires:  SDL_image-devel >= 1.2
27 BuildRequires:  SDL_mixer-devel >= 1.2
28 BuildRequires:  SDL_net-devel >= 1.2
29 BuildRequires:  SDL_ttf-devel >= 2.0.8
30 BuildRequires:  asciidoc
31 BuildRequires:  boost-devel >= 1.33
32 BuildRequires:  cmake >= 2.4
33 BuildRequires:  dbus-devel
34 %{?with_fribidi:BuildRequires:  fribidi-devel}
35 BuildRequires:  gettext-tools
36 BuildRequires:  libpng-devel
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libvorbis-devel
39 BuildRequires:  lua51-devel
40 BuildRequires:  pango-devel
41 BuildRequires:  pkgconfig
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  rpmbuild(macros) >= 1.600
44 BuildRequires:  sed >= 4.0
45 BuildRequires:  zlib-devel
46 Requires:       %{name}-data = %{epoch}:%{version}
47 Requires:       SDL >= 1.2.14-4
48 # sr@Latn vs. sr@latin
49 Conflicts:      glibc-misc < 6:2.7
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Battle for Wesnoth is a fantasy strategy game. Battle for control of
54 villages, using variety of units which have advantages and
55 disadvantages in different types of terrains and against different
56 types of attacks. Units gain experience and advance levels, and are
57 carried over from one scenario to the next campaign.
58
59 %description -l hu.UTF-8
60 Battle for Wesnoth (Harc Wesnothért) egy fantasy környezetben játszódó
61 stratégiai játék. Harc a falvak megszerzéséért, különböző egységek
62 felhasználásával, amelyeknek különböző előnyeik és hátrányaik vannak a
63 különféle terepeken és a különböző támadási stílusok ellen. Az
64 egységek tapasztalatot gyűjtenek, és fejlődnek, amelyek átvihetők a
65 következő pályára.
66
67 %description -l pl.UTF-8
68 Bitwa o Wesnoth jest strategiczną grą fantasy. Batalia o kontrolę nad
69 wsiami przy pomocy różnego rodzaju oddziałów, które mają przewagę lub
70 jej brak w odmiennym ukształtowaniu terenu i przeciwko różnym sposobom
71 ataku. Oddziały zdobywają doświadczenie i poziomy zaawansowania i są
72 przenoszone z jednej scenerii do następnej kampanii.
73
74 %package server
75 Summary:        Network server for Wesnoth
76 Summary(hu.UTF-8):      Hálózati szerver Wesnoth-hoz
77 Summary(pl.UTF-8):      Sieciowy serwer dla Wesnoth
78 Group:          X11/Applications/Games/Strategy
79 Requires(post,preun):   /sbin/chkconfig
80 Requires(postun):       /usr/sbin/groupdel
81 Requires(postun):       /usr/sbin/userdel
82 Requires(pre):  /usr/sbin/groupadd
83 Requires(pre):  /usr/sbin/useradd
84 Requires:       rc-scripts >= 0.4.0.17
85 Provides:       group(wesnothd)
86 Provides:       user(wesnothd)
87 # sr@Latn vs. sr@latin
88 Conflicts:      glibc-misc < 6:2.7
89
90 %description server
91 Server for playing networked games of Wesnoth.
92
93 %description server -l hu.UTF-8
94 Szerver a Wesnoth hálózati játékához.
95
96 %description server -l pl.UTF-8
97 Serwer do prowadzenia sieciowych gier Wesnoth.
98
99 %package tools
100 Summary:        Tools for Wesnoth
101 Summary(hu.UTF.8):      Eszközök a Wesnoth-hoz
102 Summary(pl.UTF-8):      Narzędzia dla Wesnoth
103 Group:          X11/Applications/Games/Strategy
104 Requires:       %{name} = %{epoch}:%{version}-%{release}
105
106 %description tools
107 Map editor and translations tools.
108
109 %description tools -l hu.UTF-8
110 Pályaszerkesztők és fordítási eszközök.
111
112 %description tools -l pl.UTF-8
113 Edytor map i narzędzia do tłumaczeń.
114
115 %package data
116 Summary:        Strategy game with a fantasy theme
117 Group:          Applications/Games
118 %if "%{_rpmversion}" >= "5"
119 BuildArch:      noarch
120 %endif
121
122 %description data
123 This package contains the data files for Wesnoth.
124
125 %prep
126 %setup -q
127 %patch0 -p1
128 %patch1 -p1
129
130 # don't install locales in %{_datadir}/%{name}
131 %{__sed} -i 's,${DATADIR}/${LOCALEDIR},${LOCALEDIR},' CMakeLists.txt
132
133 %build
134 install -d build
135 cd build
136 %cmake \
137         .. \
138         -DENABLE_STRICT_COMPILATION="off" \
139         -DBINDIR="%{_bindir}" \
140         -DMANDIR="%{_mandir}" \
141         -DLOCALEDIR="%{_localedir}" \
142         %{!?with_server:-DENABLE_SERVER="off"} \
143         %{?with_server:-DENABLE_CAMPAIGN_SERVER="on"} \
144         %{!?with_tools:-DENABLE_EDITOR="off"} \
145         %{?with_tools:-DENABLE_TOOLS="on"} \
146         %{!?with_fribidi:-DENABLE_FRIBIDI="off"}
147
148 %{__make}
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d} \
153         $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{_docdir}/%{name}-%{version}}
154
155 %{__make} -C build install \
156         DESTDIR=$RPM_BUILD_ROOT
157
158 # install additional docs
159 cp -p changelog README  $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
160 gzip -9nf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{changelog,README}
161
162 %if %{with server}
163 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
164 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
165 %endif
166
167 mv -f $RPM_BUILD_ROOT%{_localedir}/nb{_NO,}
168 mv -f $RPM_BUILD_ROOT%{_localedir}/fur{_IT,}
169
170 # unsupported(?)
171 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ang@latin
172 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ca_ES@valencia
173 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/la
174 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/racv
175 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@shaw
176 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sr@ijekavian
177 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sr@ijekavianlatin
178 %{__rm} -r $RPM_BUILD_ROOT%{_mandir}/ca_ES@valencia
179 %{__rm} -r $RPM_BUILD_ROOT%{_mandir}/sr@ijekavian
180 %{__rm} -r $RPM_BUILD_ROOT%{_mandir}/sr@ijekavianlatin
181
182 # the same as manuals from %{_mandir}/man?
183 %{__rm} -r $RPM_BUILD_ROOT%{_mandir}/en_GB
184
185 %find_lang %{name} --all-name
186
187 %clean
188 rm -rf $RPM_BUILD_ROOT
189
190 %pre server
191 %groupadd -P %{name}-server -g 178  wesnothd
192 %useradd -P %{name}-server -u 178 -d /var/run/wesnothd -c "Wesnothd User" -g wesnothd wesnothd
193
194 %post server
195 /sbin/chkconfig --add wesnothd
196 %service wesnothd restart
197
198 %preun server
199 if [ "$1" = "0" ]; then
200         %service wesnothd stop
201         /sbin/chkconfig --del wesnothd
202         %userremove wesnothd
203         %groupremove wesnothd
204 fi
205
206 %files -f %{name}.lang
207 %defattr(644,root,root,755)
208 %doc %{_docdir}/%{name}-%{version}
209 %attr(755,root,root) %{_bindir}/wesnoth
210 %{_mandir}/man6/wesnoth.6*
211 %lang(cs) %{_mandir}/cs/man6/wesnoth.6*
212 %lang(de) %{_mandir}/de/man6/wesnoth.6*
213 %lang(et) %{_mandir}/et/man6/wesnoth.6*
214 %lang(es) %{_mandir}/es/man6/wesnoth.6*
215 %lang(fi) %{_mandir}/fi/man6/wesnoth.6*
216 %lang(fr) %{_mandir}/fr/man6/wesnoth.6*
217 %lang(gl) %{_mandir}/gl/man6/wesnoth.6*
218 %lang(hu) %{_mandir}/hu/man6/wesnoth.6*
219 %lang(id) %{_mandir}/id/man6/wesnoth.6*
220 %lang(it) %{_mandir}/it/man6/wesnoth.6*
221 %lang(lt) %{_mandir}/lt/man6/wesnoth.6*
222 %lang(pl) %{_mandir}/pl/man6/wesnoth.6*
223 %lang(ru) %{_mandir}/ru/man6/wesnoth.6*
224 %lang(sk) %{_mandir}/sk/man6/wesnoth.6*
225 %lang(sr) %{_mandir}/sr/man6/wesnoth.6*
226 %lang(sr@latin) %{_mandir}/sr@latin/man6/wesnoth.6*
227 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth.6*
228 %lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth.6*
229 %{_desktopdir}/*.desktop
230 %{_pixmapsdir}/*-icon.png
231
232 %if %{with server}
233 %files server
234 %defattr(644,root,root,755)
235 %attr(755,root,root) %{_bindir}/campaignd
236 %attr(755,root,root) %{_bindir}/wesnothd
237 %attr(754,root,root) /etc/rc.d/init.d/wesnothd
238 %{_mandir}/man6/wesnothd.6*
239 %lang(cs) %{_mandir}/cs/man6/wesnothd.6*
240 %lang(de) %{_mandir}/de/man6/wesnothd.6*
241 %lang(es) %{_mandir}/es/man6/wesnothd.6*
242 %lang(et) %{_mandir}/et/man6/wesnothd.6*
243 %lang(fi) %{_mandir}/fi/man6/wesnothd.6*
244 %lang(fr) %{_mandir}/fr/man6/wesnothd.6*
245 %lang(gl) %{_mandir}/gl/man6/wesnothd.6*
246 %lang(hu) %{_mandir}/hu/man6/wesnothd.6*
247 %lang(id) %{_mandir}/id/man6/wesnothd.6*
248 %lang(it) %{_mandir}/it/man6/wesnothd.6*
249 %lang(ja) %{_mandir}/ja/man6/wesnothd.6*
250 %lang(lt) %{_mandir}/lt/man6/wesnothd.6*
251 %lang(pl) %{_mandir}/pl/man6/wesnothd.6*
252 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnothd.6*
253 %lang(ru) %{_mandir}/ru/man6/wesnothd.6*
254 %lang(sk) %{_mandir}/sk/man6/wesnothd.6*
255 %lang(sr) %{_mandir}/sr/man6/wesnothd.6*
256 %lang(sr@latin) %{_mandir}/sr@latin/man6/wesnothd.6*
257 %lang(tr) %{_mandir}/tr/man6/wesnothd.6*
258 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnothd.6*
259 %lang(zh_TW) %{_mandir}/zh_TW/man6/wesnothd.6*
260 %attr(770,wesnothd,wesnothd) %dir /var/run/wesnothd
261 %{systemdtmpfilesdir}/%{name}.conf
262 %endif
263
264 %if %{with tools}
265 %files tools
266 %defattr(644,root,root,755)
267 %attr(755,root,root) %{_bindir}/cutter
268 %attr(755,root,root) %{_bindir}/exploder
269 %endif
270
271 %files data
272 %defattr(644,root,root,755)
273 %{_datadir}/%{name}
This page took 0.143705 seconds and 3 git commands to generate.