]> git.pld-linux.org Git - packages/waybar.git/commitdiff
upstream fixes for libfmt 9
authorJan Palus <atler@pld-linux.org>
Thu, 1 Sep 2022 16:51:18 +0000 (18:51 +0200)
committerJan Palus <atler@pld-linux.org>
Thu, 1 Sep 2022 16:51:18 +0000 (18:51 +0200)
libfmt9.patch [new file with mode: 0644]
waybar.spec

diff --git a/libfmt9.patch b/libfmt9.patch
new file mode 100644 (file)
index 0000000..d9a6aae
--- /dev/null
@@ -0,0 +1,180 @@
+From 24a8332b62b5c1c8d480116655ce9c582d1f4516 Mon Sep 17 00:00:00 2001
+From: Aleksei Bavshin <alebastr89@gmail.com>
+Date: Mon, 11 Jul 2022 22:52:33 -0700
+Subject: [PATCH 1/3] fix: adapt to fmt 9.0.0 breaking changes
+
+---
+ include/util/json.hpp    | 8 ++++++++
+ src/client.cpp           | 2 +-
+ src/config.cpp           | 1 -
+ src/modules/sni/host.cpp | 1 -
+ src/modules/sway/bar.cpp | 1 -
+ 5 files changed, 9 insertions(+), 4 deletions(-)
+
+diff --git a/include/util/json.hpp b/include/util/json.hpp
+index cc514e139..7cd43552b 100644
+--- a/include/util/json.hpp
++++ b/include/util/json.hpp
+@@ -1,7 +1,15 @@
+ #pragma once
++#include <fmt/ostream.h>
+ #include <json/json.h>
++#if (FMT_VERSION >= 90000)
++
++template <>
++struct fmt::formatter<Json::Value> : ostream_formatter {};
++
++#endif
++
+ namespace waybar::util {
+ struct JsonParser {
+diff --git a/src/client.cpp b/src/client.cpp
+index be2ec9178..a815e2fe1 100644
+--- a/src/client.cpp
++++ b/src/client.cpp
+@@ -1,12 +1,12 @@
+ #include "client.hpp"
+-#include <fmt/ostream.h>
+ #include <spdlog/spdlog.h>
+ #include <iostream>
+ #include "idle-inhibit-unstable-v1-client-protocol.h"
+ #include "util/clara.hpp"
++#include "util/format.hpp"
+ #include "wlr-layer-shell-unstable-v1-client-protocol.h"
+ waybar::Client *waybar::Client::inst() {
+diff --git a/src/config.cpp b/src/config.cpp
+index 5894cb6b1..dec3b50b2 100644
+--- a/src/config.cpp
++++ b/src/config.cpp
+@@ -1,6 +1,5 @@
+ #include "config.hpp"
+-#include <fmt/ostream.h>
+ #include <spdlog/spdlog.h>
+ #include <unistd.h>
+ #include <wordexp.h>
+diff --git a/src/modules/sni/host.cpp b/src/modules/sni/host.cpp
+index 560d7368b..007862dcc 100644
+--- a/src/modules/sni/host.cpp
++++ b/src/modules/sni/host.cpp
+@@ -1,6 +1,5 @@
+ #include "modules/sni/host.hpp"
+-#include <fmt/ostream.h>
+ #include <spdlog/spdlog.h>
+ namespace waybar::modules::SNI {
+diff --git a/src/modules/sway/bar.cpp b/src/modules/sway/bar.cpp
+index 26234e3b5..f28b05025 100644
+--- a/src/modules/sway/bar.cpp
++++ b/src/modules/sway/bar.cpp
+@@ -1,6 +1,5 @@
+ #include "modules/sway/bar.hpp"
+-#include <fmt/ostream.h>
+ #include <spdlog/spdlog.h>
+ #include <sstream>
+
+From 3117aefdf3e0bcae6671ab4669241c934bc9ec50 Mon Sep 17 00:00:00 2001
+From: Aleksei Bavshin <alebastr89@gmail.com>
+Date: Tue, 12 Jul 2022 22:20:49 -0700
+Subject: [PATCH 2/3] fix: drop conditionals for ancient fmt versions
+
+---
+ include/modules/keyboard_state.hpp | 5 -----
+ include/modules/simpleclock.hpp    | 6 +-----
+ src/modules/clock.cpp              | 9 ++-------
+ 3 files changed, 3 insertions(+), 17 deletions(-)
+
+diff --git a/include/modules/keyboard_state.hpp b/include/modules/keyboard_state.hpp
+index 6af19d145..05fbec131 100644
+--- a/include/modules/keyboard_state.hpp
++++ b/include/modules/keyboard_state.hpp
+@@ -1,11 +1,6 @@
+ #pragma once
+-#include <fmt/format.h>
+-#if FMT_VERSION < 60000
+-#include <fmt/time.h>
+-#else
+ #include <fmt/chrono.h>
+-#endif
+ #include <gtkmm/label.h>
+ #include "AModule.hpp"
+diff --git a/include/modules/simpleclock.hpp b/include/modules/simpleclock.hpp
+index aa9a0a224..5cbee4c6c 100644
+--- a/include/modules/simpleclock.hpp
++++ b/include/modules/simpleclock.hpp
+@@ -1,11 +1,7 @@
+ #pragma once
+-#include <fmt/format.h>
+-#if FMT_VERSION < 60000
+-#include <fmt/time.h>
+-#else
+ #include <fmt/chrono.h>
+-#endif
++
+ #include "ALabel.hpp"
+ #include "util/sleeper_thread.hpp"
+diff --git a/src/modules/clock.cpp b/src/modules/clock.cpp
+index 959cad903..467536e1e 100644
+--- a/src/modules/clock.cpp
++++ b/src/modules/clock.cpp
+@@ -1,15 +1,10 @@
+ #include "modules/clock.hpp"
+-#include <spdlog/spdlog.h>
+-
+-#include <iomanip>
+-#if FMT_VERSION < 60000
+-#include <fmt/time.h>
+-#else
+ #include <fmt/chrono.h>
+-#endif
++#include <spdlog/spdlog.h>
+ #include <ctime>
++#include <iomanip>
+ #include <sstream>
+ #include <type_traits>
+
+From a44622aa9ff4b85c5eeb54663ecf9d7fe617bc08 Mon Sep 17 00:00:00 2001
+From: Aleksei Bavshin <alebastr89@gmail.com>
+Date: Wed, 13 Jul 2022 22:34:29 -0700
+Subject: [PATCH 3/3] fix: fmt 9.x deprecation warning for implicit enum
+ conversions
+
+---
+ src/modules/mpd/state.cpp | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/src/modules/mpd/state.cpp b/src/modules/mpd/state.cpp
+index 4d1e8c91b..aa1a18f8e 100644
+--- a/src/modules/mpd/state.cpp
++++ b/src/modules/mpd/state.cpp
+@@ -10,6 +10,13 @@ namespace waybar::modules {
+ }  // namespace waybar::modules
+ #endif
++#if FMT_VERSION >= 90000
++/* Satisfy fmt 9.x deprecation of implicit conversion of enums to int */
++auto format_as(enum mpd_idle val) {
++  return static_cast<std::underlying_type_t<enum mpd_idle>>(val);
++}
++#endif
++
+ namespace waybar::modules::detail {
+ #define IDLE_RUN_NOIDLE_AND_CMD(...)                                      \
index f4fcde7ac1a2177477ecb5c9f36bc9a6202c9e9d..2ac02ac143c021b952ab5d73c1518d845f44f218 100644 (file)
@@ -6,6 +6,7 @@ License:        MIT
 Group:         Applications
 Source0:       https://github.com/Alexays/Waybar/archive/%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: 85b7c6c8c902aef676360e8b81caadf6
+Patch0:                libfmt9.patch
 URL:           https://github.com/Alexays/Waybar/
 BuildRequires: date-devel
 BuildRequires: glib2-devel
@@ -46,6 +47,7 @@ compositors.
 
 %prep
 %setup -q -n Waybar-%{version}
+%patch0 -p1
 
 %build
 %meson build
This page took 0.279592 seconds and 4 git commands to generate.