]> git.pld-linux.org Git - packages/waf.git/blame_incremental - waf.spec
up to 1.9.13
[packages/waf.git] / waf.spec
... / ...
CommitLineData
1Summary: The Waf build system
2Summary(pl.UTF-8): System budowania Waf
3Name: waf
4Version: 1.9.13
5Release: 1
6# note: waf book is on CC-BY-NC-ND (not included in binary package)
7License: BSD
8Group: Development/Building
9Source0: http://waf.io/%{name}-%{version}.tar.bz2
10# Source0-md5: de812ceb97670fb325dce83ca9d60093
11Patch0: %{name}-path.patch
12URL: http://waf.io/
13BuildRequires: python >= 1:2.6
14BuildRequires: python-modules >= 1:2.6
15BuildRequires: rpm-pythonprov
16BuildRequires: rpmbuild(macros) >= 1.234
17Requires: python(abi) = %{py_ver}
18BuildArch: noarch
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22Waf is a general-purpose build system which was modelled from Scons.
23Though it comes last in the arena of the build systems, we believe
24that Waf is a vastly superior alternative to its competitors
25(Autotools, Scons, Cmake, Ant, etc) for building software,
26
27%description -l pl.UTF-8
28Waf to system budowania ogólnego przeznaczenia opracowany na podstawie
29Scons. Mimo że pojawił się jako ostatni na arenie systemów budowania,
30autorzy wierzą, że przewyższa alternatywne narzędzia (Autotools,
31Scons, Cmake, Ant itp.).
32
33%prep
34%setup -q
35%patch0 -p1
36
37%build
38# check waf-light
39extras=
40for f in waflib/extras/*.py ; do
41 tool=$(basename "$f" .py)
42 if [ "$tool" != "__init__" ]; then
43 extras="${extras:+$extras,}$tool"
44 fi
45done
46./waf-light --make-waf --strip --tools="$extras"
47
48%install
49rm -rf $RPM_BUILD_ROOT
50install -d $RPM_BUILD_ROOT%{_datadir}/waf/waflib/{Tools,extras}
51
52cp -p waflib/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib
53cp -p waflib/Tools/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib/Tools
54cp -p waflib/extras/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib/extras
55
56install -D -p waf-light $RPM_BUILD_ROOT%{_bindir}/waf
57
58%py_comp $RPM_BUILD_ROOT%{_datadir}/waf/waflib
59%py_ocomp $RPM_BUILD_ROOT%{_datadir}/waf/waflib
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%files
65%defattr(644,root,root,755)
66%doc ChangeLog README.md
67%attr(755,root,root) %{_bindir}/waf
68%{_datadir}/waf
This page took 3.1027 seconds and 4 git commands to generate.