]> git.pld-linux.org Git - packages/w3c-libwww.git/commitdiff
- added system-expat patch - use system expat (1.95.x) instead of providing
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 25 Jan 2003 14:40:31 +0000 (14:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  own copies of old expat libraries (libxmltok and libxmlparse)
- release 7

Changed files:
    w3c-libwww-system-expat.patch -> 1.1
    w3c-libwww.spec -> 1.25

w3c-libwww-system-expat.patch [new file with mode: 0644]
w3c-libwww.spec

diff --git a/w3c-libwww-system-expat.patch b/w3c-libwww-system-expat.patch
new file mode 100644 (file)
index 0000000..c11986a
--- /dev/null
@@ -0,0 +1,210 @@
+--- w3c-libwww-5.3.2/modules/Makefile.am.orig  Mon Feb 22 00:56:18 1999
++++ w3c-libwww-5.3.2/modules/Makefile.am       Sat Jan 25 13:51:39 2003
+@@ -5,5 +5,5 @@
+ EXTRA_DIST = \
+       $(DOCS)
+-SUBDIRS = expat md5
++SUBDIRS = md5
+--- w3c-libwww-5.3.2/ComLine/src/Makefile.am.orig      Fri Aug  4 11:48:37 2000
++++ w3c-libwww-5.3.2/ComLine/src/Makefile.am   Sat Jan 25 14:19:18 2003
+@@ -25,8 +25,7 @@
+ SUBDIRS = windows
+ INCLUDES = \
+-      -I$(srcdir)/../../Library/src \
+-      -I$(top_srcdir)/modules/expat/xmlparse
++      -I$(srcdir)/../../Library/src
+ #     .h files are distributed but originally are made from the
+ #     self-documenting hypertext files.
+@@ -64,7 +63,7 @@
+       -rm purify; \
+       purify -cache-dir=$(PURIFY_CACHE) \
+       $(CC) $(LDFLAGS) -o purify $(w3c_OBJECTS) \
+-      -lm \
++      -lm -lexpat \
+       ../../Library/src/.libs/libwwwinit.a \
+       ../../Library/src/.libs/libwwwapp.a \
+       ../../Library/src/.libs/libwwwxml.a \
+@@ -85,7 +84,5 @@
+       ../../Library/src/.libs/libwwwutils.a \
+       ../../Library/src/.libs/libwwwzip.a \
+       ../../modules/md5/.libs/libmd5.a \
+-      ../../modules/expat/xmlparse/.libs/libxmlparse.a \
+-      ../../modules/expat/xmltok/.libs/libxmltok.a \
+       $(LIBS)
+--- w3c-libwww-5.3.2/Robot/src/Makefile.am.orig        Fri Aug  4 11:48:37 2000
++++ w3c-libwww-5.3.2/Robot/src/Makefile.am     Sat Jan 25 14:20:08 2003
+@@ -25,8 +25,7 @@
+ SUBDIRS = windows
+ INCLUDES = \
+-      -I$(srcdir)/../../Library/src \
+-      -I$(top_srcdir)/modules/expat/xmlparse
++      -I$(srcdir)/../../Library/src
+ #     .h files are distributed but originally are made from the
+ #     self-documenting hypertext files.
+@@ -65,11 +64,9 @@
+       -rm purify; \
+       purify -cache-dir=$(PURIFY_CACHE) \
+       $(CC) $(LDFLAGS) -o purify $(webbot_OBJECTS) \
+-      -lm \
++      -lm -lexpat \
+       ../../Library/src/.libs/libwww.a \
+       ../../modules/md5/.libs/libmd5.a \
+-      ../../modules/expat/xmlparse/.libs/libxmlparse.a \
+-      ../../modules/expat/xmltok/.libs/libxmltok.a \
+       $(LIBS)
+--- w3c-libwww-5.3.2/LineMode/src/Makefile.am.orig     Fri Aug  4 11:48:37 2000
++++ w3c-libwww-5.3.2/LineMode/src/Makefile.am  Sat Jan 25 14:21:47 2003
+@@ -27,7 +27,6 @@
+ INCLUDES = \
+       -I$(srcdir)/../../Library/src \
+-      -I$(top_srcdir)/modules/expat/xmlparse \
+       -I$(srcdir)/../../PICS-client/src
+ #     .h files are distributed but originally are made from the
+--- w3c-libwww-5.3.2/Library/src/Makefile.am.orig      Sat Jan 25 13:50:01 2003
++++ w3c-libwww-5.3.2/Library/src/Makefile.am   Sat Jan 25 14:23:51 2003
+@@ -353,12 +353,10 @@
+       HTXML.h \
+       HTXML.c
+-libwwwxml_la_DEPENDENCIES = \
+-      ../../modules/expat/xmltok/libxmltok.la \
+-      ../../modules/expat/xmlparse/libxmlparse.la
+-
+ libwwwxml_la_LDFLAGS = -rpath $(libdir)
++libwwwxml_la_LIBADD = -lexpat
++
+ libwwwzip_la_SOURCES = \
+       WWWZip.h \
+       HTZip.h \
+@@ -379,8 +377,7 @@
+ INCLUDES = \
+       -I/usr/local/include \
+-      -I${top_srcdir}/modules/md5 \
+-      -I${top_srcdir}/modules/expat/xmlparse
++      -I${top_srcdir}/modules/md5
+ BUILT_SOURCES = \
+       wwwsys.h \
+--- w3c-libwww-5.3.2/Library/src/SSL/Makefile.am.orig  Tue Jun 20 13:01:34 2000
++++ w3c-libwww-5.3.2/Library/src/SSL/Makefile.am       Sat Jan 25 14:24:36 2003
+@@ -47,7 +47,6 @@
+ INCLUDES = \
+       -I/usr/local/include \
+       -I${top_srcdir}/modules/md5 \
+-      -I${top_srcdir}/modules/expat/xmlparse \
+       -I$(top_srcdir)/Library/src \
+       @SSLINC@
+--- w3c-libwww-5.3.2/Library/Examples/Makefile.am.orig Thu Aug 17 21:36:57 2000
++++ w3c-libwww-5.3.2/Library/Examples/Makefile.am      Sat Jan 25 14:22:21 2003
+@@ -31,7 +31,6 @@
+ INCLUDES = \
+       -I$(srcdir)/../src \
+-      -I$(top_srcdir)/modules/expat/xmlparse \
+       -I$(srcdir)/../src/SSL
+ DOCS :=       $(wildcard *.html)
+@@ -45,7 +44,7 @@
+       -rm purify; \
+       purify -cache-dir=$(PURIFY_CACHE) \
+       $(CC) $(LDFLAGS) -o purify $(mget_OBJECTS) \
+-      -lm \
++      -lm -lexpat \
+       ../src/.libs/libwwwinit.a \
+       ../src/.libs/libwwwapp.a \
+       ../src/.libs/libwwwxml.a \
+@@ -66,8 +65,6 @@
+       ../src/.libs/libwwwutils.a \
+       ../src/.libs/libwwwzip.a \
+       ../../modules/md5/.libs/libmd5.a \
+-      ../../modules/expat/xmlparse/.libs/libxmlparse.a \
+-      ../../modules/expat/xmltok/.libs/libxmltok.a \
+       $(LIBS)
+--- w3c-libwww-5.3.2/configure.in.orig Sat Jan 25 13:50:01 2003
++++ w3c-libwww-5.3.2/configure.in      Sat Jan 25 14:32:15 2003
+@@ -475,24 +475,24 @@
+     AC_MSG_RESULT(yes)
+     AC_DEFINE(HT_EXPAT)
+     HTXML="HTXML.lo"
+-    HTLIBXML='${top_builddir}/modules/expat/xmlparse/libxmlparse.la ${top_builddir}/modules/expat/xmltok/libxmltok.la'
+-    XMLTOK="libxmltok.la"
+-    XMLPARSE="libxmlparse.la"
++    HTLIBXML='-lexpat'
++    XMLTOK=""
++    XMLPARSE=""
+     WWWXML="libwwwxml.la"
+-    LWWWXML="-lwwwxml -lxmltok -lxmlparse"
+-    LIBWWWXML='${top_builddir}/Library/src/libwwwxml.la ${top_builddir}/modules/expat/xmlparse/libxmlparse.la ${top_builddir}/modules/expat/xmltok/libxmltok.la'
++    LWWWXML="-lwwwxml -lexpat"
++    LIBWWWXML='${top_builddir}/Library/src/libwwwxml.la -lexpat'
+     SHOWXML="showxml ptri stri rdf_parse_file rdf_parse_buffer"
+     ;;
+   esac ],
+   AC_MSG_RESULT(yes)
+   AC_DEFINE(HT_EXPAT)
+   HTXML="HTXML.lo"
+-  HTLIBXML='${top_builddir}/modules/expat/xmlparse/libxmlparse.la ${top_builddir}/modules/expat/xmltok/libxmltok.la'
+-  XMLTOK="libxmltok.la"
+-  XMLPARSE="libxmlparse.la"
++  HTLIBXML='-lexpat'
++  XMLTOK=""
++  XMLPARSE=""
+   WWWXML="libwwwxml.la"
+-  LWWWXML="-lwwwxml -lxmltok -lxmlparse"
+-  LIBWWWXML='${top_builddir}/Library/src/libwwwxml.la ${top_builddir}/modules/expat/xmlparse/libxmlparse.la ${top_builddir}/modules/expat/xmltok/libxmltok.la'
++  LWWWXML="-lwwwxml -lexpat"
++  LIBWWWXML='${top_builddir}/Library/src/libwwwxml.la -lexpat'
+   SHOWXML="showxml ptri stri rdf_parse_file rdf_parse_buffer"
+ )
+ AC_SUBST(HTXML)               # for old style big library
+--- w3c-libwww-5.3.2/Library/src/HTXML.h.orig  Wed Dec 20 12:00:07 2000
++++ w3c-libwww-5.3.2/Library/src/HTXML.h       Sat Jan 25 14:33:46 2003
+@@ -36,7 +36,7 @@
+ #include "SGML.h"
+ #endif /* HT_STRUCT_XML_STREAM */
+-#include <xmlparse.h>
++#include <expat.h>
+ /*
+ .
+--- w3c-libwww-5.3.2/Library/src/HTXML.html.orig       Tue Dec 19 09:53:43 2000
++++ w3c-libwww-5.3.2/Library/src/HTXML.html    Sat Jan 25 14:35:10 2003
+@@ -17,11 +17,7 @@
+ of the <A HREF="http://www.w3.org/Library/"> W3C Sample Code Library</A>.
+ <P>
+ We use <A href="http://www.jclark.com/xml/expat.html">James Clark's expat
+-XML parser</A> which is very neat indeed. As the code doesn't come as a separate
+-library, I included it in the libwww CVS code base where I compile is as
+-two libraries: <CODE>libxmltok.a</CODE> and <CODE>libxmlparse.a</CODE>. See
+-the <A HREF="../External/">external modules that libwww works</A> with for
+-details. Thanks so much to John Punin for writing this code!
++XML parser</A> which is very neat indeed.
+ <PRE>
+ #ifndef HTXML_H
+ #define HTXML_H
+@@ -33,7 +29,7 @@
+ #include "<A HREF="SGML.html">SGML.h</A>"
+ #endif /* HT_STRUCT_XML_STREAM */
+-#include &lt;xmlparse.h&gt;
++#include &lt;expat.h&gt;
+ </PRE>
+ <H2>
+   <A NAME="converter">Libwww Stream Converter</A>
index 41543ecec4760a64eef223a2ab90933cc95e3970..e7449a2cef539b8b28691defcce661e73573ecd7 100644 (file)
@@ -3,12 +3,13 @@ Summary(pl):  Biblioteka wsp
 Summary(pt_BR):        Biblioteca HTTP de uso geral
 Name:          w3c-libwww
 Version:       5.3.2
-Release:       6
+Release:       7
 License:       W3C (see: http://www.w3.org/Consortium/Legal/copyright-software.html)
 Group:         Libraries
 Source0:       http://www.w3.org/Library/Distribution/%{name}-%{version}.tar.gz
 Patch0:                %{name}-ac25x.patch
 Patch1:                %{name}-am15.patch
+Patch2:                %{name}-system-expat.patch
 Icon:          Lib48x.gif
 URL:           http://www.w3.org/Library/
 BuildRequires: autoconf
@@ -119,6 +120,7 @@ exemplo, PUT, POST, etc.)
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 rm -f missing
@@ -153,7 +155,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc documentation/* Icons/*/*.gif
 %attr(755,root,root) %{_libdir}/libwww*.so.*.*
-%attr(755,root,root) %{_libdir}/libxml*.so.*.*
 %attr(755,root,root) %{_libdir}/libmd5.so.*.*
 %attr(755,root,root) %{_libdir}/libpics.so.*.*
 %{_datadir}/w3c-libwww
@@ -168,11 +169,9 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/libwww-config
 %attr(755,root,root) %{_libdir}/libwww*.so
-%attr(755,root,root) %{_libdir}/libxml*.so
 %attr(755,root,root) %{_libdir}/libmd5.so
 %attr(755,root,root) %{_libdir}/libpics.so
 %{_libdir}/libwww*.la
-%{_libdir}/libxml*.la
 %{_libdir}/libmd5.la
 %{_libdir}/libpics.la
 
@@ -182,6 +181,5 @@ rm -rf $RPM_BUILD_ROOT
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libwww*.a
-%{_libdir}/libxml*.a
 %{_libdir}/libmd5.a
 %{_libdir}/libpics.a
This page took 0.068985 seconds and 4 git commands to generate.