]> git.pld-linux.org Git - packages/w3c-libwww.git/blob - w3c-libwww.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/w3c-libwww.git] / w3c-libwww.spec
1 Summary:        HTTP library of common code
2 Summary(pl):    Biblioteka wspólnego kodu HTTP
3 Name:           w3c-libwww
4 Version:        5.3.2
5 Release:        1
6 License:        W3C (see: http://www.w3.org/Consortium/Legal/copyright-software.html)
7 Group:          Libraries
8 Source0:        http://www.w3.org/Library/Distribution/%{name}-%{version}.tar.gz
9 URL:            http://www.w3.org/Library/
10 Icon:           Lib48x.gif
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 Libwww is a general-purpose Web API written in C for Unix and Windows
15 (Win32). With a highly extensible and layered API, it can accommodate
16 many different types of applications including clients, robots, etc.
17 The purpose of libwww is to provide a highly optimized HTTP sample
18 implementation as well as other Internet protocols and to serve as a
19 testbed for protocol experiments.
20
21 %description -l pl
22 Libwww jest bibliotek± WWW ogólnego przeznaczenia napisan± w C dla
23 Uniksów oraz Windows. Z wysoko rozszerzalnym i warstwowym API, mo¿e
24 mieæ zastosowanie w wielu rodzajach aplikacji, w tym klientach,
25 robotach itp. Celem libwww jest dostarczenie dobrze zoptymalizowanej,
26 przyk³adowej implementacji HTTP, a tak¿e innych protoko³ów
27 internetowych, oraz ¶rodowiska testowego do eksperymentów z
28 protoko³ami.
29
30 %package devel
31 Summary:        Header files for programs that use libwww
32 Summary(pl):    Pliki nag³ówkowe dla programów u¿ywaj±cych libwww
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}
35
36 %description devel
37 Header files for libwww, which are available as public libraries.
38
39 %description devel -l pl
40 Pliki nag³ówkowe dla libwww.
41
42 %package static
43 Summary:        Static libwww libraries
44 Summary(pl):    Statyczne biblioteki libwww
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}
47
48 %description static
49 Static libwww libraries.
50
51 %description static -l pl
52 Statyczne biblioteki libwww.
53
54 %package apps
55 Summary:        Applications built using Libwww web library: e.g. Robot, command line tool, etc
56 Summary(pl):    Aplikacje u¿ywaj±ce Libwww: Robot, narzêdzie command-line itp.
57 Group:          Applications/Networking
58 Requires:       %{name} = %{version}
59 Icon:           robot48x.gif
60
61 %description apps
62 Web applications built using Libwww: Robot, Command line tool, line
63 mode browser. The Robot can crawl web sites faster, and with lower
64 load, than any other web walker that we know of, due to its extensive
65 pipelining and use of HTTP/1.1. The command line tool (w3c) is very
66 useful for manipulation of Web sites that implement more than just
67 HTTP GET (e.g. PUT, POST, etc.). The line mode browser is a minimal
68 line mode web browser; often useful to convert to ascii text.
69 Currently unavailable until someone updates it to some new interfaces.
70 (hint, hint...)
71
72 %description apps -l pl
73 Aplikacje sieciowe zbudowane przy u¿yciu libwww: Robot, narzêdzie
74 comman-line, liniowa przegl±darka. Robot mo¿e przechodziæ po stronach
75 szybciej i z mniejszym obci±¿eniem ni¿ inne znane roboty, dziêki
76 wykorzystywaniu pipeliningu i HTTP/1.1. Narzêdzie command-line (w3c)
77 jest u¿yteczne do manipulowania serwisami WWW, które maj±
78 zaimplementowane co¶ wiêcej ni¿ HTTP GET (np. PUT, POST...).
79 Przegl±darka liniowa jest u¿yteczna g³ównie do konwersji do zwyk³ego
80 tekstu. Aktualnie niedostêpna dopóki kto¶ nie przystosuje jej do
81 nowego interfejsu (hint, hint...).
82
83 %prep
84 %setup -q
85
86 %build
87 %configure2_13 \
88         --enable-shared \
89         --with-gnu-ld \
90         --with-regex \
91         --with-zlib
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install DESTDIR=$RPM_BUILD_ROOT
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %doc *.html */*.html */*/*.html Icons/*/*.gif
108 %attr(755,root,root) %{_libdir}/libwww*.so.*.*
109 %attr(755,root,root) %{_libdir}/libxml*.so.*.*
110 %attr(755,root,root) %{_libdir}/libmd5.so.*.*
111 %attr(755,root,root) %{_libdir}/libpics.so.*.*
112 %{_datadir}/w3c-libwww
113
114 %files apps
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_bindir}/webbot
117 %attr(755,root,root) %{_bindir}/w3c
118 %attr(755,root,root) %{_bindir}/www
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_bindir}/libwww-config
123 %attr(755,root,root) %{_libdir}/libwww*.so
124 %attr(755,root,root) %{_libdir}/libxml*.so
125 %attr(755,root,root) %{_libdir}/libmd5.so
126 %attr(755,root,root) %{_libdir}/libpics.so
127 %attr(755,root,root) %{_libdir}/libwww*.la
128 %attr(755,root,root) %{_libdir}/libxml*.la
129 %attr(755,root,root) %{_libdir}/libmd5.la
130 %attr(755,root,root) %{_libdir}/libpics.la
131
132 %{_includedir}/wwwconf.h
133 %{_includedir}/w3c-libwww
134
135 %files static
136 %defattr(644,root,root,755)
137 %{_libdir}/libwww*.a
138 %{_libdir}/libxml*.a
139 %{_libdir}/libmd5.a
140 %{_libdir}/libpics.a
This page took 0.046858 seconds and 4 git commands to generate.