]> git.pld-linux.org Git - packages/w3c-libwww.git/blob - w3c-libwww.spec
- added using %%{__make} macro.
[packages/w3c-libwww.git] / w3c-libwww.spec
1 Summary:        HTTP library of common code
2 Name:           w3c-libwww
3 Version:        5.2.8
4 Release:        5
5 Copyright:      W3C (see: http://www.w3.org/Consortium/Legal/copyright-software.html)
6 Group:          Libraries
7 Source0:        http://www.w3.org/Library/Distribution/%{name}-%{version}.tar.gz
8 Patch0:         w3c-libwww-DESTDIR.patch
9 URL:            http://www.w3.org/Library
10 Icon:           Lib48x.gif
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 Libwww is a general-purpose Web API written in C for Unix and Windows
15 (Win32). With a highly extensible and layered API, it can accommodate
16 many different types of applications including clients, robots, etc.
17 The purpose of libwww is to provide a highly optimized HTTP sample
18 implementation as well as other Internet protocols and to serve as a
19 testbed for protocol experiments.
20
21 %package devel
22 Summary:        Libraries and header files for programs that use libwww
23 Group:          Development/Libraries
24 Group(fr):      Development/Librairies
25 Group(pl):      Programowanie/Biblioteki
26 Requires:       %{name} = %{version}
27
28 %description devel
29 Header files for libwww, which are available as public libraries.
30
31 %package static
32 Summary:        Static libwww libraries
33 Group:          Development/Libraries
34 Group(fr):      Development/Librairies
35 Group(pl):      Programowanie/Biblioteki
36 Requires:       %{name}-devel = %{version}
37
38 %description static
39 Static libwww libraries.
40
41 %package apps
42 Summary:        Applications built using Libwww web library: e.g. Robot, command line tool, etc
43 Group:          Applications/Networking
44 Group(pl):      Aplikacje/Sieciowe
45 Requires:       %{name} = %{version}
46 Icon:           robot48x.gif
47
48 %description apps
49 Web applications built using Libwww: Robot, Command line tool, line
50 mode browser. The Robot can crawl web sites faster, and with lower
51 load, than any other web walker that we know of, due to its extensive
52 pipelining and use of HTTP/1.1. The command line tool (w3c) is very
53 useful for manipulation of Web sites that implement more than just
54 HTTP GET (e.g. PUT, POST, etc.). The line mode browser is a minimal
55 line mode web browser; often useful to convert to ascii text.
56 Currently unavailable until someone updates it to some new interfaces.
57 (hint, hint...)
58
59 %prep
60 %setup -q
61 %patch -p1
62
63 %build
64 automake
65 LDFLAGS="-s"; export LDFLAGS
66 %configure \
67         --enable-shared \
68         --with-gnu-ld \
69         --with-regex \
70         --with-zlib
71 make
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} DESTDIR=$RPM_BUILD_ROOT install
77
78 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post   -p /sbin/ldconfig
83 %postun -p /sbin/ldconfig
84
85 %files
86 %defattr(644,root,root,755)
87 %doc *.html */*.html */*/*.html Icons/*/*.gif
88 %attr(755,root,root) %{_libdir}/libwww*.so.*.*
89 %attr(755,root,root) %{_libdir}/libxml*.so.*.*
90 %attr(755,root,root) %{_libdir}/libmd5.so.*.*
91 %{_datadir}/w3c-libwww
92
93 %files apps
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{_bindir}/webbot
96 %attr(755,root,root) %{_bindir}/w3c
97
98 %files devel
99 %defattr(644,root,root,755)
100 %attr(755,root,root) %{_bindir}/libwww-config
101 %attr(755,root,root) %{_libdir}/libwww*.so
102 %attr(755,root,root) %{_libdir}/libxml*.so
103 %attr(755,root,root) %{_libdir}/libmd5.so
104 %attr(755,root,root) %{_libdir}/libwww*.la
105 %attr(755,root,root) %{_libdir}/libxml*.la
106 %attr(755,root,root) %{_libdir}/libmd5.la
107
108 %{_includedir}/xmlparse.h
109 %{_includedir}/w3c-libwww
110
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/libwww*.a
114 %{_libdir}/libxml*.a
115 %{_libdir}/libmd5.a
This page took 0.071717 seconds and 4 git commands to generate.