]> git.pld-linux.org Git - packages/vtk.git/blobdiff - vtk.spec
- tabs in preamble
[packages/vtk.git] / vtk.spec
index 0a11245343b41570409db6ee203f43dd2db8660f..890da79611362363dbc629c48b730de3c8290aab 100644 (file)
--- a/vtk.spec
+++ b/vtk.spec
 #
 # ToDo:
-# - make it all work 
-# Conditional build
+# - make it all work
 #
+# Conditional build
 %bcond_with    java    # build with Java support (not yet done)
 #
-
-Summary:       Toolkit for 3D computer graphics, image processing, and visualization
-Name:          vtk
-Version:       4.2.2
-Release:       0.1
-License:       BSD
-Group:         Graphics
-Url:           http://public.kitware.com/VTK/
-Source0:       %{name}42Src.tar.bz2
-Source1:       %{name}42Data.tar.bz2
+Summary:       Toolkit for 3D computer graphics, image processing, and visualization
+Summary(pl.UTF-8):     Zestaw narzędzi do trójwymiarowej grafiki, przetwarzania obrazu i wizualizacji
+Name:          vtk
+Version:       4.2.2
+Release:       0.1
+License:       BSD
+Group:         Libraries
+Source0:       http://dl.sourceforge.net/vtk/VTK-4.2-LatestRelease.tar.gz
+# Source0-md5: 41382fb3f8d15e76d7464c11045ee7a5
+Source1:       http://dl.sourceforge.net/vtk/VTKData-4.2.tar.gz
+# Source1-md5: 2bbd1a62884906eac4f279441cbb9cfa
 Patch0:                %{name}-cmakefiles.patch
-BuildRequires:         cmake 
-BuildRequires: python-devel 
-BuildRequires: tcl 
-BuildRequires: XFree86-devel 
+URL:           http://public.kitware.com/VTK/
+BuildRequires: XFree86-devel
+BuildRequires: cmake
 BuildRequires: doxygen
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+BuildRequires: python-devel
+BuildRequires: tcl
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-The Visualization ToolKit (VTK) is an object oriented software system for 3D
-computer graphics, image processing, and visualization. VTK includes a
-textbook, a C++ class library, and several interpreted interface layers
-including Tcl/Tk, Java, and Python. VTK supports a wide variety of
-visualization algorithms including scalar, vector, tensor, texture, and
-volumetric methods. It also supports advanced modeling techniques like
-implicit modeling, polygon reduction, mesh smoothing, cutting, contouring,
-and Delaunay triangulation.  Moreover, dozens of imaging algorithms have been
-integrated into the system. This allows mixing 2D imaging / 3D graphics
-algorithms and data.
-
-NOTE: The java wrapper is not included by default.  You may rebuild the srpm
-      using "--with java" with JDK installed.
-
-NOTE: All patented routines which are part of the package have been removed in
-      this version.
+The Visualization ToolKit (VTK) is an object oriented software system
+for 3D computer graphics, image processing, and visualization. VTK
+includes a textbook, a C++ class library, and several interpreted
+interface layers including Tcl/Tk, Java, and Python. VTK supports a
+wide variety of visualization algorithms including scalar, vector,
+tensor, texture, and volumetric methods. It also supports advanced
+modeling techniques like implicit modeling, polygon reduction, mesh
+smoothing, cutting, contouring, and Delaunay triangulation. Moreover,
+dozens of imaging algorithms have been integrated into the system.
+This allows mixing 2D imaging / 3D graphics algorithms and data.
+
+NOTE: The Java wrapper is not included by default. You may rebuild
+      the srpm using "--with java" with JDK installed.
+
+NOTE: All patented routines which are part of the package have been
+      removed in this version.
+
+%description -l pl.UTF-8
+Visualization TookKit (VTK) to obiektowo zorientowany system
+oprogramowania do trójwymiarowej grafiki komputerowej, przetwarzania
+obrazu i wizualizacji. VTK zawiera książkę, bibliotekę klas C++ oraz
+kilka interpretowanych warstw interfejsów, w tym dla Tcl/Tk, Javy i
+Pythona. VTK obsługuje szeroki zakres algorytmów wizualizacji, w tym
+metody skalarne, wektorowe, tensorowe, teksturowe i wolumetryczne.
+Obsługuje także zaawansowane techniki modelowania, takie jak
+modelowanie implicite, redukcja wielokątów, wygładzanie siatki,
+przycinanie, konturowanie i triangulacja Delaunaya. Co więcej, wiele
+algorytmów obrazowania zostało zintegrowanych z systemem. Pozwala to
+na mieszanie algorytmów obrazowania 2D i grafiki 3D.
+
+UWAGA: wrapper Javy nie został włączony domyślnie. Można przebudować
+       srpm-a z opcją "--with java" przy zainstalowanym JDK.
+
+UWAGA: wszystkie opatentowane procedury będące częścią tego pakietu
+       zostały usunięte w tej wersji.
 
 %package devel
-Summary:  VTK header files for building C++ code.
-Requires: vtk
-Provides: vtk
-Group:    Development/C++
+Summary:       VTK header files for building C++ code
+Summary(pl.UTF-8):     Pliki nagłówkowe VTK dla C++
+Group:         Development
+Requires:      %{name} = %{version}-%{release}
 
-%description devel 
-This provides the VTK header files required to compile C++
-programs that use VTK to do 3D visualisation.
+%description devel
+This provides the VTK header files required to compile C++ programs
+that use VTK to do 3D visualisation.
+
+%description devel -l pl.UTF-8
+Ten pakiet dostarcza pliki nagłówkowe VTK do kompilowania programów
+C++ używających VTK do wizualizacji 3D.
 
 %package tcl
-Summary:  Tcl bindings for VTK.
-Group:    System/Libraries
-Requires: vtk
-Provides: vtk
+Summary:       Tcl bindings for VTK
+Summary(pl.UTF-8):     Dowiązania Tcl do VTK
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
 
 %description tcl
-The Visualization ToolKit (VTK) is an object oriented software system for 3D
-computer graphics, image processing, and visualization. VTK includes a
-textbook, a C++ class library, and several interpreted interface layers
-including Tcl/Tk, Java, and Python. VTK supports a wide variety of
-visualization algorithms including scalar, vector, tensor, texture, and
-volumetric methods. It also supports advanced modeling techniques like
-implicit modeling, polygon reduction, mesh smoothing, cutting, contouring,
-and Delaunay triangulation.  Moreover, dozens of imaging algorithms have been
-integrated into the system. This allows mixing 2D imaging / 3D graphics
-algorithms and data.
-
-This package contains tcl bindings for VTK.
+This package contains Tcl bindings for VTK.
+
+%description tcl -l pl.UTF-8
+Ten pakiet zawiera dowiązania Tcl dla VTK.
 
 %package python
-Summary: Python bindings for VTK.
-Requires: vtk
-Provides: vtk
-Group:    System/Libraries
-
-%description python 
-The Visualization ToolKit (VTK) is an object oriented software system for 3D
-computer graphics, image processing, and visualization. VTK includes a
-textbook, a C++ class library, and several interpreted interface layers
-including Tcl/Tk, Java, and Python. VTK supports a wide variety of
-visualization algorithms including scalar, vector, tensor, texture, and
-volumetric methods. It also supports advanced modeling techniques like
-implicit modeling, polygon reduction, mesh smoothing, cutting, contouring,
-and Delaunay triangulation.  Moreover, dozens of imaging algorithms have been
-integrated into the system. This allows mixing 2D imaging / 3D graphics
-algorithms and data.
-
-This package contains python bindings for VTK.
+Summary:       Python bindings for VTK
+Summary(pl.UTF-8):     Dowiązania Pythona do VTK
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description python
+This package contains Python bindings for VTK.
+
+%description python -l pl.UTF-8
+Ten pakiet zawiera dowiązania Pythona dla VTK.
 
-%if %build_java
 %package java
-Summary: Java bindings for VTK.
-Group:   Development/Java
-Requires: vtk
-Provides: vtk
+Summary:       Java bindings for VTK
+Summary(pl.UTF-8):     Dowiązania Javy do VTK
+Group:         Development/Languages/Java
+Requires:      %{name} = %{version}-%{release}
 
 %description java
-The Visualization ToolKit (VTK) is an object oriented software system for 3D
-computer graphics, image processing, and visualization. VTK includes a
-textbook, a C++ class library, and several interpreted interface layers
-including Tcl/Tk, Java, and Python. VTK supports a wide variety of
-visualization algorithms including scalar, vector, tensor, texture, and
-volumetric methods. It also supports advanced modeling techniques like
-implicit modeling, polygon reduction, mesh smoothing, cutting, contouring,
-and Delaunay triangulation.  Moreover, dozens of imaging algorithms have been
-integrated into the system. This allows mixing 2D imaging / 3D graphics
-algorithms and data.
-
-This package contains java bindings for VTK.
+This package contains Java bindings for VTK.
 
-%endif
+%description java -l pl.UTF-8
+Ten pakiet zawiera dowiązania Javy dla VTK.
 
 %package examples
-Summary:  C++, Tcl and Python example programs/scripts for VTK.
-Group:    Development/Other
-Requires: vtk-data
-Requires: vtk
-Provides: vtk
+Summary:       C++, Tcl and Python example programs/scripts for VTK
+Summary(pl.UTF-8):     Przykładowe programy/skrypty w C++, Tcl-u i Pythonie dla VTK
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-data = %{version}-%{release}
 
 %description examples
-This package contains all the examples from the VTK source.
-To compile the C++ examples you will need to install the vtk-devel
-package as well. The Python and Tcl examples can be run with the
-corresponding packages (vtk-python, vtk-tcl).
+This package contains all the examples from the VTK source. To compile
+the C++ examples you will need to install the vtk-devel package as
+well. The Python and Tcl examples can be run with the corresponding
+packages (vtk-python, vtk-tcl).
+
+%description examples -l pl.UTF-8
+Ten pakiet zawiera wszystkie przykłady ze źródeł VTK. Do skompilowania
+przykładów w C++ trzeba doinstalować pakiet vtk-devel. Przykłady w
+Pythonie i Tcl-u można uruchamiać przy użyciu odpowiednich pakietów
+(vtk-python, vtk-tcl).
 
 %package test-suite
-Summary:  Tests programs for VTK.
-Requires: vtk
-Provides: vtk
-Requires: vtk-data
-Group:    Development/Other
+Summary:       Test programs for VTK
+Summary(pl.UTF-8):     Programy testowe dla VTK
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-data = %{version}-%{release}
 
 %description test-suite
-This package contains all testing programs from the VTK
-source. The source code of these programs can be found in the
-vtk-examples package.
+This package contains all testing programs from the VTK source. The
+source code of these programs can be found in the vtk-examples
+package.
+
+%description test-suite -l pl.UTF-8
+Ten pakiet zawiera wszystkie programy testowe ze źródeł VTK. Kod
+źródłowy tych programów można znaleźć w pakiecie vtk-examples.
 
 %package data
-Summary: Data files for VTK.
-Group:   Development/Libraries
+Summary:       Data files for VTK
+Summary(pl.UTF-8):     Pliki danych dla VTK
+Group:         Development/Libraries
 
-%description data 
-This package contains all the data from the VTKData repository.
-These data are required to run various examples from the examples package.
+%description data
+This package contains all the data from the VTKData repository. These
+data are required to run various examples from the vtk-examples
+package.
+
+%description data -l pl.UTF-8
+Ten pakiet zawiera wszystkie dane z repozytorium VTKData. Dane te są
+potrzebne do uruchamiania różnych przykładów z pakietu vtk-examples.
 
 %prep
-%setup -q -a 1 -n VTK-%version
+%setup -q -n VTK-%{version} -a 1
 cd Hybrid
 %patch0 -p1
 
@@ -209,18 +223,19 @@ cd Hybrid
 #%endif
 cmake \
        -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
-        -DLIBRARY_OUTPUT_PATH:PATH=$RPM_BUILD_DIR/VTK-%version/lib \
-        -DEXECUTABLE_OUTPUT_PATH:PATH=$RPM_BUILD_DIR/VTK-%version/bin  \
+       -DLIBRARY_OUTPUT_PATH:PATH=$RPM_BUILD_DIR/VTK-%{version}/lib \
+       -DEXECUTABLE_OUTPUT_PATH:PATH=$RPM_BUILD_DIR/VTK-%{version}/bin \
        -DCMAKE_SKIP_RPATH:BOOL=ON \
        -DBUILD_EXAMPLES:BOOL=ON \
        -DBUILD_SHARED_LIBS:BOOL=ON \
        -DBUILD_DOCUMENTATION:BOOL=ON \
        -DBUILD_TESTING:BOOL=ON \
        -DCMAKE_BACKWARDS_COMPATIBILITY=1.8 \
-       -DOPENGL_INCLUDE_PATH:PATH=/usr/X11R6/include/GL \
+       -DOPENGL_INCLUDE_PATH:PATH=%{_prefix}/X11R6/include/GL \
        -DPYTHON_INCLUDE_PATH:PATH=%{_includedir}/python2.3 \
-       -DPYTHON_LIBRARY:FILEPATH=$(python -c"import os,sys; print os.path.join(sys.exec_prefix, 'lib', 'python' + sys.version        [:3], 'config/libpython' + sys.version[:3] + '.a')") \
-       -DPYTHON_UTIL_LIBRARY:PATH=/usr/lib/libutil.so \
+       -DPYTHON_LIBRARY:FILEPATH=$(python -c"import os,sys; print os.path.join(sys.exec_prefix, 'lib', 'python' + sys.version
+       [:3], 'config/libpython' + sys.version[:3] + '.a')") \
+       -DPYTHON_UTIL_LIBRARY:PATH=%{_libdir}/libutil.so \
        -DTCL_INCLUDE_PATH:PATH=%{_includedir} \
        -DTCL_LIBRARY:PATH=%{_libdir}/libtcl.so \
        -DTK_INCLUDE_PATH:PATH=%{_includedir} \
@@ -239,7 +254,6 @@ cmake \
        -DCMAKE_LINKER_FLAGS:STRING="%{rpmldflags}" \
        -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON \
 
-
 %{__make}
 
 %install
@@ -249,74 +263,74 @@ rm -rf $RPM_BUILD_ROOT
 export VTKPYTHONPATH=%(python -c"import os,sys; print os.path.join(sys.exec_prefix, 'lib', 'python' + sys.version[:3],'site-packages')")
 
 #install directories
-install -d -m 755 $RPM_BUILD_ROOT%{_bindir}
-install -d -m 755 $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk
-install -d -m 755 $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk/gtk
-install -d -m 755 $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk/qt
-install -d -m 755 $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk/testing
-install -d -m 755 $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk/tk
-install -d -m 755 $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk/util
-install -d -m 755 $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk/wx
-install -d -m 755 $RPM_BUILD_ROOT/$VTKPYTHONPATH
-install -d -m 755 $RPM_BUILD_ROOT/usr/include/vtk
+install -d $RPM_BUILD_ROOT%{_bindir}
+install -d $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk
+install -d $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk/gtk
+install -d $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk/qt
+install -d $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk/testing
+install -d $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk/tk
+install -d $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk/util
+install -d $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk/wx
+install -d $RPM_BUILD_ROOT/$VTKPYTHONPATH
+install -d $RPM_BUILD_ROOT%{_includedir}/vtk
 
 #install libs and tcl
-#%makeinstall_std
+#%%makeinstall_std
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
 chmod 755 $RPM_BUILD_ROOT%{_libdir}/vtk/*.so
 for f in $RPM_BUILD_ROOT%{_libdir}/vtk/libvtk*Python*.so
 do
-  ln -s ../`basename $f` $RPM_BUILD_ROOT%{_libdir}/vtk/python/
+       ln -s ../`basename $f` $RPM_BUILD_ROOT%{_libdir}/vtk/python/
 done
 
 #install binaries
-install  -m 755 bin/* $RPM_BUILD_ROOT%{_bindir}
+install bin/* $RPM_BUILD_ROOT%{_bindir}
 
 #install python
-install  -m 644 Wrapping/Python/*.py $RPM_BUILD_ROOT%{_libdir}/vtk/python
-install  -m 644 Wrapping/Python/vtk/*.py $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk
-install  -m 644 Wrapping/Python/vtk/gtk/*.py $RPM_BUILD_ROOT/usr/lib/vtk/python/vtk/gtk
-install  -m 644 Wrapping/Python/vtk/qt/*.py $RPM_BUILD_ROOT/usr/lib/vtk/python/vtk/qt
-install  -m 644 Wrapping/Python/vtk/tk/*.py $RPM_BUILD_ROOT/usr/lib/vtk/python/vtk/tk
-install  -m 644 Wrapping/Python/vtk/util/*.py $RPM_BUILD_ROOT/usr/lib/vtk/python/vtk/util
-install  -m 644 Wrapping/Python/vtk/wx/*.py $RPM_BUILD_ROOT/usr/lib/vtk/python/vtk/wx
+install Wrapping/Python/*.py $RPM_BUILD_ROOT%{_libdir}/vtk/python
+install Wrapping/Python/vtk/*.py $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk
+install Wrapping/Python/vtk/gtk/*.py $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk/gtk
+install Wrapping/Python/vtk/qt/*.py $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk/qt
+install Wrapping/Python/vtk/tk/*.py $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk/tk
+install Wrapping/Python/vtk/util/*.py $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk/util
+install Wrapping/Python/vtk/wx/*.py $RPM_BUILD_ROOT%{_libdir}/vtk/python/vtk/wx
 cat > $RPM_BUILD_ROOT/$VTKPYTHONPATH/vtkpython.pth <<_EOF
 %{_libdir}/vtk/python
 _EOF
 
 %if %build_java
 #install java
-install -d -m 755 $RPM_BUILD_ROOT%{_libdir}/vtk/java
-install  -m 644 lib/vtk.jar     $RPM_BUILD_ROOT/usr/lib/vtk/java
-install  -m 644 java/vtk/*.java $RPM_BUILD_ROOT%{_libdir}/vtk/java
+install -d $RPM_BUILD_ROOT%{_libdir}/vtk/java
+install lib/vtk.jar $RPM_BUILD_ROOT%{_libdir}/vtk/java
+install java/vtk/*.java $RPM_BUILD_ROOT%{_libdir}/vtk/java
 %endif
 
 #install data
-mkdir -p $RPM_BUILD_ROOT/%_datadir/%name-data
-cp -r VTKData-release-4-2/* $RPM_BUILD_ROOT/%_datadir/%name-data
-rm -fr $RPM_BUILD_ROOT/%_datadir/%name-data/CVS
+install -d $RPM_BUILD_ROOT%{_datadir}/%{name}-data
+cp -r VTKData-release-4-2/* $RPM_BUILD_ROOT%{_datadir}/%{name}-data
+rm -fr $RPM_BUILD_ROOT%{_datadir}/%{name}-data/CVS
 
 #install test-suite and examples
 for d in Common Filtering Graphics Hybrid IO Imaging Parallel Patented Rendering
 do
-       mkdir -p $RPM_BUILD_ROOT/%_datadir/vtk-examples/Testing/$d
-       cp -a $d/Testing/* $RPM_BUILD_ROOT/%_datadir/vtk-examples/Testing/$d
+       install -d $RPM_BUILD_ROOT%{_datadir}/vtk-examples/Testing/$d
+       cp -a $d/Testing/* $RPM_BUILD_ROOT%{_datadir}/vtk-examples/Testing/$d
 done
-cp -a Examples $RPM_BUILD_ROOT/%_datadir/vtk-examples
+cp -a Examples $RPM_BUILD_ROOT%{_datadir}/vtk-examples
 
 # get rid of unwanted files
-find $RPM_BUILD_ROOT/%_datadir/vtk-examples -name "*.o" -exec rm {} \;
-find $RPM_BUILD_ROOT/%_datadir/vtk-examples -name CMakeCache.txt -exec rm {} \;
-find $RPM_BUILD_ROOT/%_datadir/vtk-examples -name Makefile -exec rm {} \;
-find $RPM_BUILD_ROOT/%_datadir/vtk-examples -name DartTestfile.txt -exec rm {} \;
-find $RPM_BUILD_ROOT/%_datadir/vtk-examples -name .NoDartCoverage -exec rm {} \;
-find $RPM_BUILD_ROOT/%_datadir/vtk-examples -name "CMake*" -exec rm {} \;
-find $RPM_BUILD_ROOT/%_datadir/vtk-examples -name "cmake.*" -exec rm {} \;
+find $RPM_BUILD_ROOT%{_datadir}/vtk-examples -name "*.o" -exec rm {} \;
+find $RPM_BUILD_ROOT%{_datadir}/vtk-examples -name CMakeCache.txt -exec rm {} \;
+find $RPM_BUILD_ROOT%{_datadir}/vtk-examples -name Makefile -exec rm {} \;
+find $RPM_BUILD_ROOT%{_datadir}/vtk-examples -name DartTestfile.txt -exec rm {} \;
+find $RPM_BUILD_ROOT%{_datadir}/vtk-examples -name .NoDartCoverage -exec rm {} \;
+find $RPM_BUILD_ROOT%{_datadir}/vtk-examples -name "CMake*" -exec rm {} \;
+find $RPM_BUILD_ROOT%{_datadir}/vtk-examples -name "cmake.*" -exec rm {} \;
 
 # Generate the package testing-progs lists and store them in file-lists
-echo "%defattr (-, root, root)" > testing-progs-list
+echo "%defattr (644,root,root,755)" > testing-progs-list
 %if %build_java
 find ${RPM_BUILD_ROOT}/usr/bin -type f | \
        sed -e "s#^${RPM_BUILD_ROOT}##g" | \
@@ -329,113 +343,91 @@ find ${RPM_BUILD_ROOT}/usr/bin -type f | \
        >> testing-progs-list
 %endif
 
-%post -p /sbin/ldconfig
-%post tcl -p /sbin/ldconfig
-%post python -p /sbin/ldconfig
-%if %build_java
-%post java -p /sbin/ldconfig
-%endif
+%clean
+rm -rf $RPM_BUILD_ROOT
 
+%post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
-%postun tcl -p /sbin/ldconfig
-%postun python -p /sbin/ldconfig 
-%if %build_java
-%postun java -p /sbin/ldconfig
-%endif
+
+%post  tcl -p /sbin/ldconfig
+%postun        tcl -p /sbin/ldconfig
+
+%post  python -p /sbin/ldconfig
+%postun        python -p /sbin/ldconfig
+
+%post  java -p /sbin/ldconfig
+%postun        java -p /sbin/ldconfig
 
 %files
-%defattr(-,root,root)
+%defattr(644,root,root,755)
 %doc README.html vtkLogo.jpg
 %dir %{_libdir}/vtk
-%{_libdir}/vtk/libvtkCommon.so 
-%{_libdir}/vtk/libvtkFiltering.so 
-%{_libdir}/vtk/libvtkGraphics.so
-%{_libdir}/vtk/libvtkHybrid.so
-%{_libdir}/vtk/libvtkImaging.so
-%{_libdir}/vtk/libvtkIO.so
-%{_libdir}/vtk/libvtkParallel.so
-%{_libdir}/vtk/libvtkRendering.so
-%{_libdir}/vtk/libvtkjpeg.so 
-%{_libdir}/vtk/libvtkpng.so 
-%{_libdir}/vtk/libvtkzlib.so
-%{_libdir}/vtk/libvtkexpat.so
-%{_libdir}/vtk/libvtkfreetype.so
-%{_libdir}/vtk/libvtkftgl.so
-%{_libdir}/vtk/libvtktiff.so
+%attr(755,root,root) %{_libdir}/vtk/libvtkCommon.so
+%attr(755,root,root) %{_libdir}/vtk/libvtkFiltering.so
+%attr(755,root,root) %{_libdir}/vtk/libvtkGraphics.so
+%attr(755,root,root) %{_libdir}/vtk/libvtkHybrid.so
+%attr(755,root,root) %{_libdir}/vtk/libvtkImaging.so
+%attr(755,root,root) %{_libdir}/vtk/libvtkIO.so
+%attr(755,root,root) %{_libdir}/vtk/libvtkParallel.so
+%attr(755,root,root) %{_libdir}/vtk/libvtkRendering.so
+%attr(755,root,root) %{_libdir}/vtk/libvtkjpeg.so
+%attr(755,root,root) %{_libdir}/vtk/libvtkpng.so
+%attr(755,root,root) %{_libdir}/vtk/libvtkzlib.so
+%attr(755,root,root) %{_libdir}/vtk/libvtkexpat.so
+%attr(755,root,root) %{_libdir}/vtk/libvtkfreetype.so
+%attr(755,root,root) %{_libdir}/vtk/libvtkftgl.so
+%attr(755,root,root) %{_libdir}/vtk/libvtktiff.so
 
 %files devel
-%defattr(-,root,root)
+%defattr(644,root,root,755)
 %doc %{_libdir}/vtk/doxygen
+%doc Utilities/Upgrading/*
 %{_includedir}/vtk
 %{_libdir}/vtk/CMake
 %{_libdir}/vtk/*.cmake
-%doc Utilities/Upgrading/*
 
 %files test-suite -f testing-progs-list
+%defattr(644,root,root,755)
 
 %files tcl
-%defattr(-,root,root)
-%{_bindir}/vtkWrapTcl
-%{_libdir}/vtk/libvtk*TCL.so 
-%{_bindir}/vtk
-%{_libdir}/vtk/tcl
+%defattr(644,root,root,755)
+%doc README.html vtkLogo.jpg
 %dir %{_libdir}/vtk/testing
+%attr(755,root,root) %{_bindir}/vtkWrapTcl
+%attr(755,root,root) %{_bindir}/vtk
+%attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so
+%{_libdir}/vtk/tcl
 %{_libdir}/vtk/testing/*.tcl
-%doc README.html 
-%doc vtkLogo.jpg
 
 %files python
-%defattr(-,root,root)
-%_bindir/vtkWrapPython
-%_bindir/vtkpython
-%_libdir/vtk/libvtk*Python*.so 
-%_libdir/vtk/python
+%defattr(644,root,root,755)
 %dir %_libdir/vtk/testing
-%_libdir/vtk/testing/*.py
+%attr(755,root,root) %{_bindir}/vtkWrapPython
+%attr(755,root,root) %{_bindir}/vtkpython
+%attr(755,root,root) %{_libdir}/vtk/libvtk*Python*.so
+%{_libdir}/vtk/python
+%{_libdir}/vtk/testing/*.py
 %(python -c"import os,sys; print os.path.join(sys.exec_prefix, 'lib', 'python' + sys.version[:3],'site-packages', 'vtkpython.pth')")
 
 %if %build_java
 %files java
-%defattr(-,root,root)
-%{_bindir}/vtkParseJava
-%{_bindir}/vtkWrapJava
-%{_bindir}/VTKJavaExecutable
-%{_libdir}/vtk/libvtk*Java.so 
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/vtkParseJava
+%attr(755,root,root) %{_bindir}/vtkWrapJava
+%attr(755,root,root) %{_bindir}/VTKJavaExecutable
+%attr(755,root,root) %{_libdir}/vtk/libvtk*Java.so
 %{_libdir}/vtk/java
 %endif
 
 %files examples
-%defattr(-,root,root)
-%dir %_datadir/vtk-examples
-%_datadir/vtk-examples/Examples
-%_datadir/vtk-examples/Testing
+%defattr(644,root,root,755)
+%dir %{_datadir}/vtk-examples
+%{_datadir}/vtk-examples/Examples
+%{_datadir}/vtk-examples/Testing
 
 %files data
-%defattr(-,root,root)
-%dir %_datadir/vtk-data
-%_datadir/vtk-data/Baseline
-%_datadir/vtk-data/Data
-%_datadir/vtk-data/VTKData.readme
-
-%clean 
-rm -rf $RPM_BUILD_ROOT
-
-%changelog
-* Mon Mar 01 2004 Olivier Thauvin <thauvin@aerov.jussieu.fr> 4.2.2-4mdk
-- Own dir (again)
-
-* Sun Feb 29 2004 Olivier Thauvin <thauvin@aerov.jussieu.fr> 4.2.2-3mdk
-- Own dir
-
-* Sat Aug 9 2003 Austin Acton <aacton@yorku.ca> 4.2.2-2mdk
-- python 2.3
-
-* Thu Jul 17 2003 Austin Acton <aacton@yorku.ca> 4.2.2-1mdk
-- 4.2.2
-- some DIRM
-- some removal of some lint
-- some java conditionals
-
-* Sun Feb 2 2003 Austin Acton <aacton@yorku.ca> 4.0-1mdk
-- initial package
-- stole most of specfile from http://www.creatis.insa-lyon.fr/vtk/
+%defattr(644,root,root,755)
+%dir %{_datadir}/vtk-data
+%{_datadir}/vtk-data/Baseline
+%{_datadir}/vtk-data/Data
+%{_datadir}/vtk-data/VTKData.readme
This page took 0.140593 seconds and 4 git commands to generate.