]> git.pld-linux.org Git - packages/vtk.git/blob - vtk.spec
- separated -qt/-qt-devel from base/-devel (wrt. library changes); base no longer...
[packages/vtk.git] / vtk.spec
1 # TODO:
2 # - handle VTK_USE_MPEG2_ENCODER (see CMakeLists.txt)
3 # - handle MPI and VTK_USE_PARALLEL_BGL (Parallel Boost Graph Library, BR: boost >= 1.40)
4 # - more system libraries? (check for VTK_THIRD_PARTY_SUBDIR in Utilities/CMakeLists.txt)
5 #
6 # Conditional build
7 %bcond_without  java            # Java wrappers
8 %bcond_without  ffmpeg          # FFMPEG .avi saving support
9 %bcond_with     OSMesa          # build with OSMesa (https://bugzilla.redhat.com/show_bug.cgi?id=744434)
10 %bcond_with     system_proj     # use system PROJ.4 (needs 4.3 with exposed internals, not ready for 4.4+)
11 #
12 Summary:        Toolkit for 3D computer graphics, image processing, and visualization
13 Summary(pl.UTF-8):      Zestaw narzędzi do trójwymiarowej grafiki, przetwarzania obrazu i wizualizacji
14 Name:           vtk
15 Version:        6.0.0
16 Release:        1
17 License:        BSD
18 Group:          Libraries
19 Source0:        http://www.vtk.org/files/release/6.0/%{name}-%{version}.tar.gz
20 # Source0-md5:  72ede4812c90bdc55172702f0cad02bb
21 Source1:        http://www.vtk.org/files/release/6.0/%{name}data-%{version}.tar.gz
22 # Source1-md5:  f40bcfe92439575ae56aa3f2fcd30149
23 Patch0:         %{name}-system-libs.patch
24 Patch1:         %{name}-install.patch
25 Patch2:         %{name}-chemistry.patch
26 URL:            http://www.vtk.org/
27 %{?with_OSMesa:BuildRequires: Mesa-libOSMesa-devel}
28 BuildRequires:  OpenGL-GLX-devel
29 BuildRequires:  OpenGL-devel
30 BuildRequires:  QtCore-devel >= 4.5.0
31 BuildRequires:  QtGui-devel >= 4.5.0
32 BuildRequires:  QtNetwork-devel >= 4.5.0
33 BuildRequires:  QtOpenGL-devel >= 4.5.0
34 BuildRequires:  QtSql-devel >= 4.5.0
35 BuildRequires:  QtWebKit-devel >= 4.5.0
36 BuildRequires:  QtXmlPatterns-devel >= 4.5.0
37 BuildRequires:  boost-devel >= 1.39
38 BuildRequires:  cmake >= 2.6.3
39 BuildRequires:  doxygen
40 BuildRequires:  eigen >= 2
41 BuildRequires:  expat-devel
42 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
43 BuildRequires:  fontconfig-devel
44 BuildRequires:  freetype-devel >= 2
45 BuildRequires:  gl2ps-devel >= 1.3.8
46 BuildRequires:  gnuplot
47 BuildRequires:  graphviz
48 BuildRequires:  hdf5-devel
49 %if %{with java}
50 BuildRequires:  jdk >= 1.5
51 BuildRequires:  jpackage-utils
52 %endif
53 BuildRequires:  libjpeg-devel
54 BuildRequires:  libogg-devel
55 BuildRequires:  libpng-devel
56 BuildRequires:  libstdc++-devel
57 BuildRequires:  libtheora-devel
58 BuildRequires:  libtiff-devel
59 BuildRequires:  libxml2-devel >= 2
60 BuildRequires:  mysql-devel
61 BuildRequires:  openmotif-devel
62 BuildRequires:  openqube-devel
63 BuildRequires:  postgresql-devel
64 %{?with_system_proj:BuildRequires:      proj-devel >= 4.3, proj-devel < 4.4}
65 BuildRequires:  python-devel
66 BuildRequires:  python-sip-devel
67 BuildRequires:  python-PyQt4-devel
68 BuildRequires:  qt4-build >= 4.5.0
69 BuildRequires:  rpmbuild(macros) >= 1.605
70 BuildRequires:  sip
71 BuildRequires:  tcl-devel
72 BuildRequires:  tk-devel
73 BuildRequires:  wget
74 BuildRequires:  xorg-lib-libICE-devel
75 BuildRequires:  xorg-lib-libSM-devel
76 BuildRequires:  xorg-lib-libX11-devel
77 BuildRequires:  xorg-lib-libXScrnSaver-devel
78 BuildRequires:  xorg-lib-libXext-devel
79 BuildRequires:  xorg-lib-libXft-devel
80 BuildRequires:  xorg-lib-libXt-devel
81 BuildRequires:  zlib-devel
82 Requires:       gl2ps >= 1.3.8
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %define         skip_post_check_so      lib.*Python.*\.so.*
86
87 %description
88 The Visualization ToolKit (VTK) is an object oriented software system
89 for 3D computer graphics, image processing, and visualization. VTK
90 includes a textbook, a C++ class library, and several interpreted
91 interface layers including Tcl/Tk, Java, and Python. VTK supports a
92 wide variety of visualization algorithms including scalar, vector,
93 tensor, texture, and volumetric methods. It also supports advanced
94 modeling techniques like implicit modeling, polygon reduction, mesh
95 smoothing, cutting, contouring, and Delaunay triangulation. Moreover,
96 dozens of imaging algorithms have been integrated into the system.
97 This allows mixing 2D imaging / 3D graphics algorithms and data.
98
99 %description -l pl.UTF-8
100 Visualization TookKit (VTK) to obiektowo zorientowany system
101 oprogramowania do trójwymiarowej grafiki komputerowej, przetwarzania
102 obrazu i wizualizacji. VTK zawiera książkę, bibliotekę klas C++ oraz
103 kilka interpretowanych warstw interfejsów, w tym dla Tcl/Tk, Javy i
104 Pythona. VTK obsługuje szeroki zakres algorytmów wizualizacji, w tym
105 metody skalarne, wektorowe, tensorowe, teksturowe i wolumetryczne.
106 Obsługuje także zaawansowane techniki modelowania, takie jak
107 modelowanie implicite, redukcja wielokątów, wygładzanie siatki,
108 przycinanie, konturowanie i triangulacja Delaunaya. Co więcej, wiele
109 algorytmów obrazowania zostało zintegrowanych z systemem. Pozwala to
110 na mieszanie algorytmów obrazowania 2D i grafiki 3D.
111
112 %package devel
113 Summary:        VTK header files for building C++ code
114 Summary(pl.UTF-8):      Pliki nagłówkowe VTK dla C++
115 Group:          Development
116 Requires:       %{name} = %{version}-%{release}
117 Requires:       libstdc++-devel
118
119 %description devel
120 This provides the VTK header files required to compile C++ programs
121 that use VTK to do 3D visualisation.
122
123 %description devel -l pl.UTF-8
124 Ten pakiet dostarcza pliki nagłówkowe VTK do kompilowania programów
125 C++ używających VTK do wizualizacji 3D.
126
127 %package qt
128 Summary:        Qt bindings and Qt Designer plugin for VTK
129 Summary(pl.UTF-8):      Wiązania Qt oraz wtyczka Qt Designera do VTK
130 Group:          X11/Libraries
131 Requires:       %{name} = %{version}-%{release}
132 Requires:       QtCore >= 4.5.0
133 Requires:       QtGui >= 4.5.0
134 Requires:       QtNetwork >= 4.5.0
135 Requires:       QtOpenGL >= 4.5.0
136 Requires:       QtSql >= 4.5.0
137 Requires:       QtWebKit >= 4.5.0
138
139 %description qt
140 Qt bindings and Qt Designer plugin for VTK.
141
142 %description qt -l pl.UTF-8
143 Wiązania Qt oraz wtyczka Qt Designera do VTK.
144
145 %package qt-devel
146 Summary:        Header files for VTK Qt bindings
147 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Qt do VTK
148 Group:          X11/Development/Libraries
149 Requires:       %{name}-devel = %{version}-%{release}
150 Requires:       %{name}-qt = %{version}-%{release}
151 Requires:       QtCore-devel >= 4.5.0
152 Requires:       QtGui-devel >= 4.5.0
153 Requires:       QtOpenGL-devel >= 4.5.0
154 Requires:       QtSql-devel >= 4.5.0
155
156 %description qt-devel
157 Header files for VTK Qt bindings.
158
159 %description qt-devel -l pl.UTF-8
160 Pliki nagłówkowe wiązań Qt do VTK.
161
162 %package java
163 Summary:        Java bindings for VTK
164 Summary(pl.UTF-8):      Wiązania Javy do VTK
165 Group:          Development/Languages/Java
166 Requires:       %{name} = %{version}-%{release}
167 # or separate qt parts?
168 Requires:       %{name}-qt = %{version}-%{release}
169
170 %description java
171 This package contains Java bindings for VTK.
172
173 %description java -l pl.UTF-8
174 Ten pakiet zawiera wiązania Javy do VTK.
175
176 %package java-devel
177 Summary:        Header files for Java VTK binding
178 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Javy do VTK
179 Group:          Development/Libraries
180 Requires:       %{name}-devel = %{version}-%{release}
181 Requires:       %{name}-java = %{version}-%{release}
182 # <jni.h>
183 Requires:       jdk
184
185 %description java-devel
186 Header files for Java VTK binding.
187
188 %description java-devel -l pl.UTF-8
189 Pliki nagłówkowe wiązania Javy do VTK.
190
191 %package python
192 Summary:        Python bindings for VTK
193 Summary(pl.UTF-8):      Wiązania Pythona do VTK
194 Group:          Libraries
195 Requires:       %{name} = %{version}-%{release}
196 # or separate qt parts again?
197 Requires:       %{name}-qt = %{version}-%{release}
198 Obsoletes:      vtk-python-qt < 6.0.0-1
199 Obsoletes:      vtk-python-sip < 6.0.0-1
200
201 %description python
202 This package contains Python bindings for VTK.
203
204 %description python -l pl.UTF-8
205 Ten pakiet zawiera wiązania Pythona do VTK.
206
207 %package python-devel
208 Summary:        Header files for Python VTK binding
209 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Pythona do VTK
210 Group:          Development/Libraries
211 Requires:       %{name}-devel = %{version}-%{release}
212 Requires:       %{name}-python = %{version}-%{release}
213 Requires:       python-devel
214
215 %description python-devel
216 Header files for Python VTK binding.
217
218 %description python-devel -l pl.UTF-8
219 Pliki nagłówkowe wiązania Pythona do VTK.
220
221 %package tcl
222 Summary:        Tcl bindings for VTK
223 Summary(pl.UTF-8):      Wiązania języka Tcl do VTK
224 Group:          Libraries
225 Requires:       %{name} = %{version}-%{release}
226 # or separate qt parts?
227 Requires:       %{name}-qt = %{version}-%{release}
228
229 %description tcl
230 This package contains Tcl bindings for VTK.
231
232 %description tcl -l pl.UTF-8
233 Ten pakiet zawiera wiązania języka Tcl do VTK.
234
235 %package tcl-devel
236 Summary:        Header files for Tcl VTK bindings
237 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania języka Tcl do VTK
238 Group:          Development/Libraries
239 Requires:       %{name}-devel = %{version}-%{release}
240 Requires:       %{name}-tcl = %{version}-%{release}
241 Requires:       tcl-devel
242 Requires:       tk-devel
243
244 %description tcl-devel
245 Header files for Tcl VTK bindings.
246
247 %description tcl-devel -l pl.UTF-8
248 Pliki nagłówkowe wiązania języka Tcl do VTK.
249
250 %package examples
251 Summary:        C++, Tcl and Python example programs/scripts for VTK
252 Summary(pl.UTF-8):      Przykładowe programy/skrypty w C++, Tcl-u i Pythonie dla VTK
253 Group:          Development/Libraries
254 Requires:       %{name} = %{version}-%{release}
255 Requires:       %{name}-data = %{version}-%{release}
256
257 %description examples
258 This package contains all the examples from the VTK source. To compile
259 the C++ examples you will need to install the vtk-devel package as
260 well. The Python and Tcl examples can be run with the corresponding
261 packages (vtk-python, vtk-tcl).
262
263 %description examples -l pl.UTF-8
264 Ten pakiet zawiera wszystkie przykłady ze źródeł VTK. Do skompilowania
265 przykładów w C++ trzeba doinstalować pakiet vtk-devel. Przykłady w
266 Pythonie i Tcl-u można uruchamiać przy użyciu odpowiednich pakietów
267 (vtk-python, vtk-tcl).
268
269 %package test-suite
270 Summary:        Test programs for VTK
271 Summary(pl.UTF-8):      Programy testowe dla VTK
272 Group:          Development/Libraries
273 Requires:       %{name} = %{version}-%{release}
274 Requires:       %{name}-data = %{version}-%{release}
275
276 %description test-suite
277 This package contains all testing programs from the VTK source. The
278 source code of these programs can be found in the vtk-examples
279 package.
280
281 %description test-suite -l pl.UTF-8
282 Ten pakiet zawiera wszystkie programy testowe ze źródeł VTK. Kod
283 źródłowy tych programów można znaleźć w pakiecie vtk-examples.
284
285 %package data
286 Summary:        Data files for VTK
287 Summary(pl.UTF-8):      Pliki danych dla VTK
288 Group:          Development/Libraries
289 %if "%{_rpmversion}" >= "5"
290 BuildArch:      noarch
291 %endif
292
293 %description data
294 This package contains all the data from the VTKData repository. These
295 data are required to run various examples from the vtk-examples
296 package.
297
298 %description data -l pl.UTF-8
299 Ten pakiet zawiera wszystkie dane z repozytorium VTKData. Dane te są
300 potrzebne do uruchamiania różnych przykładów z pakietu vtk-examples.
301
302 %prep
303 %setup -q -n VTK%{version} -a 1
304 %patch0 -p1
305 %patch1 -p1
306 %patch2 -p1
307
308 # Replace relative path ../../../VTKData with %{_datadir}/vtkdata-%{version}
309 # otherwise it will break on symlinks.
310 grep -rl '\.\./\.\./\.\./\.\./VTKData' . | xargs \
311   perl -pi -e's,\.\./\.\./\.\./\.\./VTKData,%{_datadir}/vtkdata-%{version},g'
312
313 # Save an unbuilt copy of the Example's sources for %doc
314 mkdir vtk-examples
315 cp -a Examples vtk-examples
316 # Don't ship Win32 examples
317 %{__rm} -r vtk-examples/Examples/GUI/Win32
318 find vtk-examples -type f | xargs chmod -R a-x
319
320 %build
321 export CFLAGS="%{rpmcflags} -D_UNICODE"
322 export CXXFLAGS="%{rpmcxxflags} -D_UNICODE"
323 %if %{with java}
324 export JAVA_HOME=%{java_home}
325 %endif
326
327 mkdir build
328 cd build
329 %cmake .. \
330         -DBUILD_DOCUMENTATION:BOOL=ON \
331         -DBUILD_EXAMPLES:BOOL=ON \
332         -DBUILD_SHARED_LIBS:BOOL=ON \
333         -DBUILD_TESTING:BOOL=ON \
334         -DCMAKE_C_COMPILER:PATH="%{__cc}" \
335         -DCMAKE_CXX_COMPILER:PATH="%{__cxx}" \
336         -DCMAKE_SKIP_RPATH:BOOL=ON \
337         -DOPENGL_INCLUDE_PATH:PATH=%{_includedir}/GL \
338         -DPYTHON_INCLUDE_PATH:PATH=%{py_incdir} \
339         -DPYTHON_LIBRARY:FILEPATH=%{_libdir}/libpython%{py_ver}.so \
340         -DPYTHON_UTIL_LIBRARY:PATH=%{_libdir}/libutil.so \
341         -DTCL_INCLUDE_PATH:PATH=%{_includedir} \
342         -DTCL_LIBRARY:PATH=%{_libdir}/libtcl.so \
343         -DTK_INCLUDE_PATH:PATH=%{_includedir} \
344         -DTK_LIBRARY:PATH=%{_libdir}/libtk.so \
345         -DVTK_DATA_ROOT:PATH=%{_datadir}/vtk \
346         -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
347         -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/vtk \
348         -DVTK_INSTALL_INCLUDE_DIR:PATH=include/vtk \
349         -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/vtk \
350         -DVTK_INSTALL_PACKAGE_DIR:PATH=%{_lib}/cmake/vtk \
351         -DVTK_INSTALL_TCL_DIR:PATH=share/tcl%{tcl_version}/vtk \
352         -DVTK_INSTALL_QT_DIR=/%{_lib}/qt4/plugins/designer \
353         %{?with_OSMesa:-DVTK_OPENGL_HAS_OSMESA:BOOL=ON} \
354         -DVTK_WRAP_PYTHON:BOOL=ON \
355         -DVTK_PYTHON_SETUP_ARGS="--prefix=/usr --root=$RPM_BUILD_ROOT" \
356         -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
357         -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
358         -DVTK_USE_RENDERING:BOOL=ON \
359         -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
360         %{!?with_system_proj:-DVTK_USE_SYSTEM_LIBPROJ4:BOOL=OFF} \
361 %if %{with java}
362         -DVTK_WRAP_JAVA:BOOL=ON \
363         -DJAVA_INCLUDE_PATH:PATH=$JAVA_HOME/include \
364         -DJAVA_INCLUDE_PATH2:PATH=$JAVA_HOME/include/linux \
365         -DJAVA_AWT_INCLUDE_PATH:PATH=$JAVA_HOME/include \
366 %else
367         -DVTK_WRAP_JAVA:BOOL=OFF \
368 %endif
369         -DVTK_WRAP_PYTHON:BOOL=ON \
370         %{?with_sip:-DVTK_WRAP_PYTHON_SIP:BOOL=ON} \
371         -DVTK_WRAP_TCL:BOOL=ON \
372         -DVTK_Group_Imaging:BOOL=ON \
373         -DVTK_Group_Qt:BOOL=ON \
374         -DVTK_Group_Rendering:BOOL=ON \
375         -DVTK_Group_StandAlone:BOOL=ON \
376         -DVTK_Group_Tk:BOOL=ON \
377         -DVTK_Group_Views:BOOL=ON \
378         -DModule_vtkFiltersStatisticsGnuR:BOOL=ON
379
380 %{__make}
381
382 %install
383 rm -rf $RPM_BUILD_ROOT
384 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ld.so.conf.d,%{_examplesdir}/%{name}-%{version},%{_datadir}/vtk-data} \
385         $RPM_BUILD_ROOT%{py_sitedir}
386
387 %{__make} -C build install \
388         DESTDIR=$RPM_BUILD_ROOT
389
390 # ld config
391 echo %{_libdir}/vtk > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
392
393 # fix python install path
394 mv $RPM_BUILD_ROOT%{py_sitescriptdir}/* $RPM_BUILD_ROOT%{py_sitedir}
395
396 cp -a VTKDATA%{version}/* $RPM_BUILD_ROOT%{_datadir}/vtk-data
397 cp -a vtk-examples/Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
398
399 # Install utilities
400 install build/bin/lproj $RPM_BUILD_ROOT%{_bindir}
401
402 # Install examples
403 for f in \
404 AmbientSpheres \
405 Arrays \
406 BalloonWidget \
407 BandedContours \
408 Cone \
409 Cone2 \
410 Cone3 \
411 Cone4 \
412 Cone5 \
413 Cone6 \
414 Cube \
415 Cylinder \
416 Delaunay3D \
417 Delaunay3DAlpha \
418 DiffuseSpheres \
419 DumpXMLFile \
420 FilledContours \
421 FixedPointVolumeRayCastMapperCT \
422 GPURenderDemo \
423 Generate2DAMRDataSetWithPulse \
424 Generate3DAMRDataSetWithPulse \
425 GenerateCubesFromLabels \
426 GenerateModelsFromLabels \
427 HierarchicalBoxPipeline \
428 ImageDataLIC2DDemo \
429 ImageSlicing \
430 LabeledMesh \
431 MaterialObjects \
432 Medical1 \
433 Medical2 \
434 Medical3 \
435 MultiBlock \
436 ParticleReader \
437 RGrid \
438 SGrid \
439 Slider \
440 Slider2D \
441 SpecularSpheres \
442 StructuredGridLIC2DDemo \
443 SurfaceLICDemo \
444 TimeRenderer \
445 TimeRenderer2 \
446 TubesWithVaryingRadiusAndColors \
447 finance ; do
448         install build/bin/$f $RPM_BUILD_ROOT%{_bindir}
449 done
450
451 # Install test binaries
452 for f in build/bin/*Tests build/bin/Test* build/bin/VTKBenchMark ; do
453         install $f $RPM_BUILD_ROOT%{_bindir}
454 done
455
456 install build/bin/VTKJavaExecutable $RPM_BUILD_ROOT%{_bindir}
457 install build/bin/vtkpython $RPM_BUILD_ROOT%{_bindir}
458
459 # unwanted doxygen files and misplaced verdict docs
460 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/vtk-6.0/{doxygen,verdict}
461
462 # only *.pyc are built by default, add *.pyo
463 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/vtk
464 %py_postclean
465
466 %clean
467 rm -rf $RPM_BUILD_ROOT
468
469 %post   -p /sbin/ldconfig
470 %postun -p /sbin/ldconfig
471
472 %post   qt -p /sbin/ldconfig
473 %postun qt -p /sbin/ldconfig
474
475 %post   java -p /sbin/ldconfig
476 %postun java -p /sbin/ldconfig
477
478 %post   python -p /sbin/ldconfig
479 %postun python -p /sbin/ldconfig
480
481 %post   tcl -p /sbin/ldconfig
482 %postun tcl -p /sbin/ldconfig
483
484 %files
485 %defattr(644,root,root,755)
486 %doc README.html vtkLogo.jpg vtkBanner.gif Wrapping/Tools/README*
487 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
488 %dir %{_libdir}/vtk
489 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so.1
490 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so.1
491 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so.1
492 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so.1
493 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so.1
494 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so.1
495 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so.1
496 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so.1
497 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so.1
498 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so.1
499 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so.1
500 %attr(755,root,root) %{_libdir}/vtk/libvtkNetCDF.so.1
501 %attr(755,root,root) %{_libdir}/vtk/libvtkNetCDF_cxx.so.1
502 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so.1
503 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so.1
504 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so.1
505 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so.1
506 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so.1
507 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeOpenGL.so.1
508 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PS.so.1
509 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingHybridOpenGL.so.1
510 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so.1
511 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so.1
512 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so.1
513 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL.so.1
514 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so.1
515 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeAMR.so.1
516 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL.so.1
517 %attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so.1
518 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so.1
519 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so.1
520 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so.1
521 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so.1
522 %attr(755,root,root) %{_libdir}/vtk/libvtkalglib.so.1
523 %attr(755,root,root) %{_libdir}/vtk/libvtkexoIIc.so.1
524 %attr(755,root,root) %{_libdir}/vtk/libvtkftgl.so.1
525 %attr(755,root,root) %{_libdir}/vtk/libvtkjsoncpp.so.1
526 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so.1
527 %attr(755,root,root) %{_libdir}/vtk/libvtkproj4.so.1
528 %attr(755,root,root) %{_libdir}/vtk/libvtksqlite.so.1
529 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so.1
530 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so.1
531 %exclude %{_libdir}/vtk/libvtk*Java.so.1
532 %exclude %{_libdir}/vtk/libvtk*Python2?D.so.1
533 %exclude %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
534 %exclude %{_libdir}/vtk/libvtk*TCL.so.1
535
536 %files devel
537 %defattr(644,root,root,755)
538 %doc Utilities/Upgrading/*
539 %attr(755,root,root) %{_bindir}/lproj
540 %attr(755,root,root) %{_bindir}/vtkEncodeString
541 %attr(755,root,root) %{_bindir}/vtkHashSource
542 %attr(755,root,root) %{_bindir}/vtkParseOGLExt
543 %attr(755,root,root) %{_bindir}/vtkProcessShader
544 %attr(755,root,root) %{_bindir}/vtkWrapHierarchy
545 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so
546 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so
547 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so
548 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so
549 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so
550 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so
551 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so
552 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so
553 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so
554 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so
555 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so
556 %attr(755,root,root) %{_libdir}/vtk/libvtkNetCDF.so
557 %attr(755,root,root) %{_libdir}/vtk/libvtkNetCDF_cxx.so
558 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so
559 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so
560 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so
561 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so
562 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so
563 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeOpenGL.so
564 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PS.so
565 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingHybridOpenGL.so
566 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so
567 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so
568 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so
569 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL.so
570 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so
571 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeAMR.so
572 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL.so
573 %attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so
574 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so
575 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so
576 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so
577 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so
578 %attr(755,root,root) %{_libdir}/vtk/libvtkalglib.so
579 %attr(755,root,root) %{_libdir}/vtk/libvtkexoIIc.so
580 %attr(755,root,root) %{_libdir}/vtk/libvtkftgl.so
581 %attr(755,root,root) %{_libdir}/vtk/libvtkjsoncpp.so
582 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so
583 %attr(755,root,root) %{_libdir}/vtk/libvtkproj4.so
584 %attr(755,root,root) %{_libdir}/vtk/libvtksqlite.so
585 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so
586 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so
587 %exclude %{_libdir}/vtk/libvtk*Java.so
588 %exclude %{_libdir}/vtk/libvtk*Python2?D.so
589 %exclude %{_libdir}/vtk/libvtkWrappingPython2?Core.so
590 %exclude %{_libdir}/vtk/libvtk*TCL.so
591 %{_libdir}/vtk/libvtkWrappingTools.a
592 %dir %{_includedir}/vtk
593 %{_includedir}/vtk/DICOM*.h
594 %{_includedir}/vtk/DatabaseSchemaWith2Tables.h
595 %{_includedir}/vtk/JSONCPP
596 %{_includedir}/vtk/LSDyna*.h
597 %{_includedir}/vtk/alglib
598 %{_includedir}/vtk/vtklibproj4
599 %{_includedir}/vtk/vtkmetaio
600 %{_includedir}/vtk/vtknetcdf
601 %{_includedir}/vtk/vtkverdict
602 %{_includedir}/vtk/vtksqlite
603 %{_includedir}/vtk/vtksys
604 %{_includedir}/vtk/vtk*.h
605 %{_includedir}/vtk/vtk*.txx
606 %exclude %{_includedir}/vtk/vtkEventQtSlotConnect.h
607 %exclude %{_includedir}/vtk/vtkGUISupportQt*.h
608 %exclude %{_includedir}/vtk/vtkJavaUtil.h
609 %exclude %{_includedir}/vtk/vtkWrappingJavaModule.h
610 %exclude %{_includedir}/vtk/vtkPython*.h
611 %exclude %{_includedir}/vtk/vtkQImageToImageSource.h
612 %exclude %{_includedir}/vtk/vtkQt*.h
613 %exclude %{_includedir}/vtk/vtkRenderingQtModule.h
614 %exclude %{_includedir}/vtk/vtkTcl*.h
615 %exclude %{_includedir}/vtk/vtkTk*.h
616 %exclude %{_includedir}/vtk/vtkViewsQtModule.h
617 %{_libdir}/cmake/vtk
618
619 %files qt
620 %defattr(644,root,root,755)
621 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so.1
622 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtOpenGL.so.1
623 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so.1
624 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtWebkit.so.1
625 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so.1
626 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so.1
627 %attr(755,root,root) %{_libdir}/qt4/plugins/designer/libQVTKWidgetPlugin.so
628
629 %files qt-devel
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so
632 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtOpenGL.so
633 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so
634 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtWebkit.so
635 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so
636 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so
637 %{_includedir}/vtk/QFilterTreeProxyModel.h
638 %{_includedir}/vtk/QVTK*.h
639 %{_includedir}/vtk/vtkEventQtSlotConnect.h
640 %{_includedir}/vtk/vtkGUISupportQt*.h
641 %{_includedir}/vtk/vtkQImageToImageSource.h
642 %{_includedir}/vtk/vtkQt*.h
643 %{_includedir}/vtk/vtkRenderingQtModule.h
644 %{_includedir}/vtk/vtkViewsQtModule.h
645
646 %if %{with java}
647 %files java
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_bindir}/VTKJavaExecutable
650 %attr(755,root,root) %{_bindir}/vtkParseJava
651 %attr(755,root,root) %{_bindir}/vtkWrapJava
652 # common library
653 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so.1
654 # java modules
655 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCoreJava.so
656 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*Java.so
657 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryJava.so
658 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*Java.so
659 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCoreJava.so
660 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*Java.so
661 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*Java.so
662 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*Java.so
663 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*Java.so
664 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExampleJava.so
665 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCoreJava.so
666 %attr(755,root,root) %{_libdir}/vtk/libvtkRendering*Java.so
667 %attr(755,root,root) %{_libdir}/vtk/libvtkTestingRenderingJava.so
668 %attr(755,root,root) %{_libdir}/vtk/libvtkViews*Java.so
669 %{_libdir}/vtk/vtk.jar
670
671 %files java-devel
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so
674 %{_includedir}/vtk/vtkJavaUtil.h
675 %{_includedir}/vtk/vtkWrappingJavaModule.h
676 %endif
677
678 %files python
679 %defattr(644,root,root,755)
680 %doc Wrapping/Python/README*
681 %attr(755,root,root) %{_bindir}/vtkWrapPython
682 %attr(755,root,root) %{_bindir}/vtkWrapPythonInit
683 %attr(755,root,root) %{_bindir}/vtkpython
684 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so.1
685 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingPythonTkWidgets-6.0.so
686 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
687 %dir %{py_sitedir}/vtk
688 %{py_sitedir}/vtk/*.py[co]
689 %dir %{py_sitedir}/vtk/gtk
690 %{py_sitedir}/vtk/gtk/*.py[co]
691 %dir %{py_sitedir}/vtk/qt4
692 %{py_sitedir}/vtk/qt4/*.py[co]
693 %dir %{py_sitedir}/vtk/test
694 %{py_sitedir}/vtk/test/*.py[co]
695 %dir %{py_sitedir}/vtk/tk
696 %{py_sitedir}/vtk/tk/*.py[co]
697 %dir %{py_sitedir}/vtk/util
698 %{py_sitedir}/vtk/util/*.py[co]
699 %dir %{py_sitedir}/vtk/wx
700 %{py_sitedir}/vtk/wx/*.py[co]
701 %attr(755,root,root) %{py_sitedir}/vtk/vtk*Python.so
702 %{py_sitedir}/VTK-*-py*.egg-info
703
704 %files python-devel
705 %defattr(644,root,root,755)
706 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so
707 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so
708 %{_includedir}/vtk/PyVTK*.h
709 %{_includedir}/vtk/vtkPython*.h
710
711 %files tcl
712 %defattr(644,root,root,755)
713 %doc Wrapping/Tcl/README*
714 %attr(755,root,root) %{_bindir}/vtkWrapTcl
715 %attr(755,root,root) %{_bindir}/vtkWrapTclInit
716 %attr(755,root,root) %{_bindir}/vtk
717 %{_datadir}/tcl8.5/vtk
718 %attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so.1
719
720 %files tcl-devel
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so
723 %{_includedir}/vtk/vtkTcl*.h
724 %{_includedir}/vtk/vtkTk*.h
725
726 %files test-suite
727 %defattr(644,root,root,755)
728 %attr(755,root,root) %{_bindir}/*Tests
729 %attr(755,root,root) %{_bindir}/Test*
730 %attr(755,root,root) %{_bindir}/VTKBenchMark
731
732 %files examples
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{_bindir}/AmbientSpheres
735 %attr(755,root,root) %{_bindir}/Arrays
736 %attr(755,root,root) %{_bindir}/Cone
737 %attr(755,root,root) %{_bindir}/Cone2
738 %attr(755,root,root) %{_bindir}/Cone3
739 %attr(755,root,root) %{_bindir}/Cone4
740 %attr(755,root,root) %{_bindir}/Cone5
741 %attr(755,root,root) %{_bindir}/Cone6
742 %attr(755,root,root) %{_bindir}/Cube
743 %attr(755,root,root) %{_bindir}/Cylinder
744 %attr(755,root,root) %{_bindir}/DiffuseSpheres
745 %attr(755,root,root) %{_bindir}/HierarchicalBoxPipeline
746 %attr(755,root,root) %{_bindir}/Medical1
747 %attr(755,root,root) %{_bindir}/Medical2
748 %attr(755,root,root) %{_bindir}/Medical3
749 %attr(755,root,root) %{_bindir}/MultiBlock
750 %attr(755,root,root) %{_bindir}/RGrid
751 %attr(755,root,root) %{_bindir}/SGrid
752 %attr(755,root,root) %{_bindir}/SpecularSpheres
753 %attr(755,root,root) %{_bindir}/finance
754 %attr(755,root,root) %{_bindir}/BalloonWidget
755 %attr(755,root,root) %{_bindir}/BandedContours
756 %attr(755,root,root) %{_bindir}/Delaunay3D
757 %attr(755,root,root) %{_bindir}/Delaunay3DAlpha
758 %attr(755,root,root) %{_bindir}/DumpXMLFile
759 %attr(755,root,root) %{_bindir}/FilledContours
760 %attr(755,root,root) %{_bindir}/FixedPointVolumeRayCastMapperCT
761 %attr(755,root,root) %{_bindir}/GPURenderDemo
762 %attr(755,root,root) %{_bindir}/Generate2DAMRDataSetWithPulse
763 %attr(755,root,root) %{_bindir}/Generate3DAMRDataSetWithPulse
764 %attr(755,root,root) %{_bindir}/GenerateCubesFromLabels
765 %attr(755,root,root) %{_bindir}/GenerateModelsFromLabels
766 %attr(755,root,root) %{_bindir}/ImageDataLIC2DDemo
767 %attr(755,root,root) %{_bindir}/ImageSlicing
768 %attr(755,root,root) %{_bindir}/LabeledMesh
769 %attr(755,root,root) %{_bindir}/MaterialObjects
770 %attr(755,root,root) %{_bindir}/ParticleReader
771 %attr(755,root,root) %{_bindir}/Slider
772 %attr(755,root,root) %{_bindir}/Slider2D
773 %attr(755,root,root) %{_bindir}/StructuredGridLIC2DDemo
774 %attr(755,root,root) %{_bindir}/SurfaceLICDemo
775 %attr(755,root,root) %{_bindir}/TimeRenderer
776 %attr(755,root,root) %{_bindir}/TimeRenderer2
777 %attr(755,root,root) %{_bindir}/TubesWithVaryingRadiusAndColors
778 %{_examplesdir}/%{name}-%{version}
779
780 %files data
781 %defattr(644,root,root,755)
782 %dir %{_datadir}/vtk-data
783 %{_datadir}/vtk-data/Baseline
784 %{_datadir}/vtk-data/Copyright.txt
785 %{_datadir}/vtk-data/Data
786 %{_datadir}/vtk-data/VERSION
787 %{_datadir}/vtk-data/VTKData.readme
This page took 0.1094 seconds and 4 git commands to generate.