]> git.pld-linux.org Git - packages/vtk.git/blob - vtk.spec
- release 3 (by relup.sh)
[packages/vtk.git] / vtk.spec
1 # TODO:
2 # - handle VTK_USE_MPEG2_ENCODER (see CMakeLists.txt)
3 # - handle MPI and VTK_USE_PARALLEL_BGL (Parallel Boost Graph Library, BR: boost >= 1.40)
4 # - more system libraries? (check for VTK_THIRD_PARTY_SUBDIR in Utilities/CMakeLists.txt)
5 # - CUDA for Accelerators/Piston (on bcond)
6 # - NVCtrlLib for Rendering/OpenGL (on bcond)
7 # - IO/GDAL? (seems not handled by main build system)
8 # - IO/ODBC? (VTK_USE_ODBC=ON)
9 # - Xdmf2? (not build by default?)
10 #
11 # Conditional build
12 %bcond_without  java            # Java wrappers
13 %bcond_without  ffmpeg          # FFMPEG .avi saving support
14 %bcond_with     OSMesa          # build with OSMesa (https://bugzilla.redhat.com/show_bug.cgi?id=744434)
15 %bcond_with     system_proj     # use system PROJ.4 (needs 4.3 with exposed internals, not ready for 4.4+)
16 #
17 Summary:        Toolkit for 3D computer graphics, image processing, and visualization
18 Summary(pl.UTF-8):      Zestaw narzędzi do trójwymiarowej grafiki, przetwarzania obrazu i wizualizacji
19 Name:           vtk
20 Version:        6.0.0
21 Release:        3
22 License:        BSD
23 Group:          Libraries
24 Source0:        http://www.vtk.org/files/release/6.0/%{name}-%{version}.tar.gz
25 # Source0-md5:  72ede4812c90bdc55172702f0cad02bb
26 Source1:        http://www.vtk.org/files/release/6.0/%{name}data-%{version}.tar.gz
27 # Source1-md5:  f40bcfe92439575ae56aa3f2fcd30149
28 Patch0:         %{name}-system-libs.patch
29 Patch1:         %{name}-install.patch
30 Patch2:         %{name}-chemistry.patch
31 URL:            http://www.vtk.org/
32 %{?with_OSMesa:BuildRequires: Mesa-libOSMesa-devel}
33 BuildRequires:  OpenGL-GLX-devel
34 BuildRequires:  OpenGL-devel
35 BuildRequires:  QtCore-devel >= 4.5.0
36 BuildRequires:  QtGui-devel >= 4.5.0
37 BuildRequires:  QtNetwork-devel >= 4.5.0
38 BuildRequires:  QtOpenGL-devel >= 4.5.0
39 BuildRequires:  QtSql-devel >= 4.5.0
40 BuildRequires:  QtWebKit-devel >= 4.5.0
41 BuildRequires:  QtXmlPatterns-devel >= 4.5.0
42 BuildRequires:  R
43 BuildRequires:  boost-devel >= 1.39
44 BuildRequires:  cmake >= 2.8.5
45 BuildRequires:  doxygen
46 BuildRequires:  eigen >= 2
47 BuildRequires:  expat-devel
48 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
49 BuildRequires:  fontconfig-devel
50 BuildRequires:  freetype-devel >= 2
51 BuildRequires:  gl2ps-devel >= 1.3.8
52 BuildRequires:  gnuplot
53 BuildRequires:  graphviz
54 BuildRequires:  hdf5-devel
55 %if %{with java}
56 BuildRequires:  jdk >= 1.5
57 BuildRequires:  jpackage-utils
58 %endif
59 BuildRequires:  libjpeg-devel
60 BuildRequires:  libogg-devel
61 BuildRequires:  libpng-devel
62 BuildRequires:  libstdc++-devel
63 BuildRequires:  libtheora-devel
64 BuildRequires:  libtiff-devel
65 BuildRequires:  libxml2-devel >= 2
66 BuildRequires:  motif-devel
67 BuildRequires:  mysql-devel
68 BuildRequires:  openqube-devel
69 BuildRequires:  postgresql-devel
70 %{?with_system_proj:BuildRequires:      proj-devel >= 4.3, proj-devel < 4.4}
71 BuildRequires:  python-devel
72 BuildRequires:  python-sip-devel
73 BuildRequires:  python-PyQt4-devel
74 BuildRequires:  qt4-build >= 4.5.0
75 BuildRequires:  rpmbuild(macros) >= 1.605
76 BuildRequires:  sip
77 BuildRequires:  tcl-devel
78 BuildRequires:  tk-devel
79 BuildRequires:  wget
80 BuildRequires:  xorg-lib-libICE-devel
81 BuildRequires:  xorg-lib-libSM-devel
82 BuildRequires:  xorg-lib-libX11-devel
83 BuildRequires:  xorg-lib-libXScrnSaver-devel
84 BuildRequires:  xorg-lib-libXext-devel
85 BuildRequires:  xorg-lib-libXft-devel
86 BuildRequires:  xorg-lib-libXt-devel
87 BuildRequires:  zlib-devel
88 Requires:       gl2ps >= 1.3.8
89 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91 %define         skip_post_check_so      lib.*Python.*\.so.*
92
93 %description
94 The Visualization ToolKit (VTK) is an object oriented software system
95 for 3D computer graphics, image processing, and visualization. VTK
96 includes a textbook, a C++ class library, and several interpreted
97 interface layers including Tcl/Tk, Java, and Python. VTK supports a
98 wide variety of visualization algorithms including scalar, vector,
99 tensor, texture, and volumetric methods. It also supports advanced
100 modeling techniques like implicit modeling, polygon reduction, mesh
101 smoothing, cutting, contouring, and Delaunay triangulation. Moreover,
102 dozens of imaging algorithms have been integrated into the system.
103 This allows mixing 2D imaging / 3D graphics algorithms and data.
104
105 %description -l pl.UTF-8
106 Visualization TookKit (VTK) to obiektowo zorientowany system
107 oprogramowania do trójwymiarowej grafiki komputerowej, przetwarzania
108 obrazu i wizualizacji. VTK zawiera książkę, bibliotekę klas C++ oraz
109 kilka interpretowanych warstw interfejsów, w tym dla Tcl/Tk, Javy i
110 Pythona. VTK obsługuje szeroki zakres algorytmów wizualizacji, w tym
111 metody skalarne, wektorowe, tensorowe, teksturowe i wolumetryczne.
112 Obsługuje także zaawansowane techniki modelowania, takie jak
113 modelowanie implicite, redukcja wielokątów, wygładzanie siatki,
114 przycinanie, konturowanie i triangulacja Delaunaya. Co więcej, wiele
115 algorytmów obrazowania zostało zintegrowanych z systemem. Pozwala to
116 na mieszanie algorytmów obrazowania 2D i grafiki 3D.
117
118 %package devel
119 Summary:        VTK header files for building C++ code
120 Summary(pl.UTF-8):      Pliki nagłówkowe VTK dla C++
121 Group:          Development
122 Requires:       %{name} = %{version}-%{release}
123 Requires:       libstdc++-devel
124
125 %description devel
126 This provides the VTK header files required to compile C++ programs
127 that use VTK to do 3D visualisation.
128
129 %description devel -l pl.UTF-8
130 Ten pakiet dostarcza pliki nagłówkowe VTK do kompilowania programów
131 C++ używających VTK do wizualizacji 3D.
132
133 %package qt
134 Summary:        Qt bindings and Qt Designer plugin for VTK
135 Summary(pl.UTF-8):      Wiązania Qt oraz wtyczka Qt Designera do VTK
136 Group:          X11/Libraries
137 Requires:       %{name} = %{version}-%{release}
138 Requires:       QtCore >= 4.5.0
139 Requires:       QtGui >= 4.5.0
140 Requires:       QtNetwork >= 4.5.0
141 Requires:       QtOpenGL >= 4.5.0
142 Requires:       QtSql >= 4.5.0
143 Requires:       QtWebKit >= 4.5.0
144
145 %description qt
146 Qt bindings and Qt Designer plugin for VTK.
147
148 %description qt -l pl.UTF-8
149 Wiązania Qt oraz wtyczka Qt Designera do VTK.
150
151 %package qt-devel
152 Summary:        Header files for VTK Qt bindings
153 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Qt do VTK
154 Group:          X11/Development/Libraries
155 Requires:       %{name}-devel = %{version}-%{release}
156 Requires:       %{name}-qt = %{version}-%{release}
157 Requires:       QtCore-devel >= 4.5.0
158 Requires:       QtGui-devel >= 4.5.0
159 Requires:       QtOpenGL-devel >= 4.5.0
160 Requires:       QtSql-devel >= 4.5.0
161
162 %description qt-devel
163 Header files for VTK Qt bindings.
164
165 %description qt-devel -l pl.UTF-8
166 Pliki nagłówkowe wiązań Qt do VTK.
167
168 %package java
169 Summary:        Java bindings for VTK
170 Summary(pl.UTF-8):      Wiązania Javy do VTK
171 Group:          Development/Languages/Java
172 Requires:       %{name} = %{version}-%{release}
173 # or separate qt parts?
174 Requires:       %{name}-qt = %{version}-%{release}
175
176 %description java
177 This package contains Java bindings for VTK.
178
179 %description java -l pl.UTF-8
180 Ten pakiet zawiera wiązania Javy do VTK.
181
182 %package java-devel
183 Summary:        Header files for Java VTK binding
184 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Javy do VTK
185 Group:          Development/Libraries
186 Requires:       %{name}-devel = %{version}-%{release}
187 Requires:       %{name}-java = %{version}-%{release}
188 # <jni.h>
189 Requires:       jdk
190
191 %description java-devel
192 Header files for Java VTK binding.
193
194 %description java-devel -l pl.UTF-8
195 Pliki nagłówkowe wiązania Javy do VTK.
196
197 %package python
198 Summary:        Python bindings for VTK
199 Summary(pl.UTF-8):      Wiązania Pythona do VTK
200 Group:          Libraries
201 Requires:       %{name} = %{version}-%{release}
202 # or separate qt parts again?
203 Requires:       %{name}-qt = %{version}-%{release}
204 Obsoletes:      vtk-python-qt < 6.0.0-1
205 Obsoletes:      vtk-python-sip < 6.0.0-1
206
207 %description python
208 This package contains Python bindings for VTK.
209
210 %description python -l pl.UTF-8
211 Ten pakiet zawiera wiązania Pythona do VTK.
212
213 %package python-devel
214 Summary:        Header files for Python VTK binding
215 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Pythona do VTK
216 Group:          Development/Libraries
217 Requires:       %{name}-devel = %{version}-%{release}
218 Requires:       %{name}-python = %{version}-%{release}
219 Requires:       python-devel
220
221 %description python-devel
222 Header files for Python VTK binding.
223
224 %description python-devel -l pl.UTF-8
225 Pliki nagłówkowe wiązania Pythona do VTK.
226
227 %package tcl
228 Summary:        Tcl bindings for VTK
229 Summary(pl.UTF-8):      Wiązania języka Tcl do VTK
230 Group:          Libraries
231 Requires:       %{name} = %{version}-%{release}
232 # or separate qt parts?
233 Requires:       %{name}-qt = %{version}-%{release}
234
235 %description tcl
236 This package contains Tcl bindings for VTK.
237
238 %description tcl -l pl.UTF-8
239 Ten pakiet zawiera wiązania języka Tcl do VTK.
240
241 %package tcl-devel
242 Summary:        Header files for Tcl VTK bindings
243 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania języka Tcl do VTK
244 Group:          Development/Libraries
245 Requires:       %{name}-devel = %{version}-%{release}
246 Requires:       %{name}-tcl = %{version}-%{release}
247 Requires:       tcl-devel
248 Requires:       tk-devel
249
250 %description tcl-devel
251 Header files for Tcl VTK bindings.
252
253 %description tcl-devel -l pl.UTF-8
254 Pliki nagłówkowe wiązania języka Tcl do VTK.
255
256 %package examples
257 Summary:        C++, Tcl and Python example programs/scripts for VTK
258 Summary(pl.UTF-8):      Przykładowe programy/skrypty w C++, Tcl-u i Pythonie dla VTK
259 Group:          Development/Libraries
260 Requires:       %{name} = %{version}-%{release}
261 Requires:       %{name}-data = %{version}-%{release}
262
263 %description examples
264 This package contains all the examples from the VTK source. To compile
265 the C++ examples you will need to install the vtk-devel package as
266 well. The Python and Tcl examples can be run with the corresponding
267 packages (vtk-python, vtk-tcl).
268
269 %description examples -l pl.UTF-8
270 Ten pakiet zawiera wszystkie przykłady ze źródeł VTK. Do skompilowania
271 przykładów w C++ trzeba doinstalować pakiet vtk-devel. Przykłady w
272 Pythonie i Tcl-u można uruchamiać przy użyciu odpowiednich pakietów
273 (vtk-python, vtk-tcl).
274
275 %package test-suite
276 Summary:        Test programs for VTK
277 Summary(pl.UTF-8):      Programy testowe dla VTK
278 Group:          Development/Libraries
279 Requires:       %{name} = %{version}-%{release}
280 Requires:       %{name}-data = %{version}-%{release}
281
282 %description test-suite
283 This package contains all testing programs from the VTK source. The
284 source code of these programs can be found in the vtk-examples
285 package.
286
287 %description test-suite -l pl.UTF-8
288 Ten pakiet zawiera wszystkie programy testowe ze źródeł VTK. Kod
289 źródłowy tych programów można znaleźć w pakiecie vtk-examples.
290
291 %package data
292 Summary:        Data files for VTK
293 Summary(pl.UTF-8):      Pliki danych dla VTK
294 Group:          Development/Libraries
295 %if "%{_rpmversion}" >= "5"
296 BuildArch:      noarch
297 %endif
298
299 %description data
300 This package contains all the data from the VTKData repository. These
301 data are required to run various examples from the vtk-examples
302 package.
303
304 %description data -l pl.UTF-8
305 Ten pakiet zawiera wszystkie dane z repozytorium VTKData. Dane te są
306 potrzebne do uruchamiania różnych przykładów z pakietu vtk-examples.
307
308 %prep
309 %setup -q -n VTK%{version} -a 1
310 %patch0 -p1
311 %patch1 -p1
312 %patch2 -p1
313
314 # Replace relative path ../../../VTKData with %{_datadir}/vtkdata-%{version}
315 # otherwise it will break on symlinks.
316 grep -rl '\.\./\.\./\.\./\.\./VTKData' . | xargs \
317   perl -pi -e's,\.\./\.\./\.\./\.\./VTKData,%{_datadir}/vtkdata-%{version},g'
318
319 # Save an unbuilt copy of the Example's sources for %doc
320 mkdir vtk-examples
321 cp -a Examples vtk-examples
322 # Don't ship Win32 examples
323 %{__rm} -r vtk-examples/Examples/GUI/Win32
324 find vtk-examples -type f | xargs chmod -R a-x
325
326 %build
327 export CFLAGS="%{rpmcflags} -D_UNICODE"
328 export CXXFLAGS="%{rpmcxxflags} -D_UNICODE"
329 %if %{with java}
330 export JAVA_HOME=%{java_home}
331 %endif
332
333 mkdir build
334 cd build
335 %cmake .. \
336         -DBUILD_DOCUMENTATION:BOOL=ON \
337         -DBUILD_EXAMPLES:BOOL=ON \
338         -DBUILD_SHARED_LIBS:BOOL=ON \
339         -DBUILD_TESTING:BOOL=ON \
340         -DCMAKE_C_COMPILER:PATH="%{__cc}" \
341         -DCMAKE_CXX_COMPILER:PATH="%{__cxx}" \
342         -DCMAKE_SKIP_RPATH:BOOL=ON \
343         -DOPENGL_INCLUDE_PATH:PATH=%{_includedir}/GL \
344         -DPYTHON_INCLUDE_PATH:PATH=%{py_incdir} \
345         -DPYTHON_LIBRARY:FILEPATH=%{_libdir}/libpython%{py_ver}.so \
346         -DPYTHON_UTIL_LIBRARY:PATH=%{_libdir}/libutil.so \
347         -DTCL_INCLUDE_PATH:PATH=%{_includedir} \
348         -DTCL_LIBRARY:PATH=%{_libdir}/libtcl.so \
349         -DTK_INCLUDE_PATH:PATH=%{_includedir} \
350         -DTK_LIBRARY:PATH=%{_libdir}/libtk.so \
351         -DVTK_DATA_ROOT:PATH=%{_datadir}/vtk \
352         -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
353         -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/vtk \
354         -DVTK_INSTALL_INCLUDE_DIR:PATH=include/vtk \
355         -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/vtk \
356         -DVTK_INSTALL_PACKAGE_DIR:PATH=%{_lib}/cmake/vtk \
357         -DVTK_INSTALL_TCL_DIR:PATH=share/tcl%{tcl_version}/vtk \
358         -DVTK_INSTALL_QT_DIR=/%{_lib}/qt4/plugins/designer \
359         %{?with_OSMesa:-DVTK_OPENGL_HAS_OSMESA:BOOL=ON} \
360         -DVTK_WRAP_PYTHON:BOOL=ON \
361         -DVTK_PYTHON_SETUP_ARGS="--prefix=/usr --root=$RPM_BUILD_ROOT" \
362         -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
363         -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
364         -DVTK_USE_RENDERING:BOOL=ON \
365         -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
366         %{!?with_system_proj:-DVTK_USE_SYSTEM_LIBPROJ4:BOOL=OFF} \
367 %if %{with java}
368         -DVTK_WRAP_JAVA:BOOL=ON \
369         -DJAVA_INCLUDE_PATH:PATH=$JAVA_HOME/include \
370         -DJAVA_INCLUDE_PATH2:PATH=$JAVA_HOME/include/linux \
371         -DJAVA_AWT_INCLUDE_PATH:PATH=$JAVA_HOME/include \
372 %else
373         -DVTK_WRAP_JAVA:BOOL=OFF \
374 %endif
375         -DVTK_WRAP_PYTHON:BOOL=ON \
376         %{?with_sip:-DVTK_WRAP_PYTHON_SIP:BOOL=ON} \
377         -DVTK_WRAP_TCL:BOOL=ON \
378         -DVTK_Group_Imaging:BOOL=ON \
379         -DVTK_Group_Qt:BOOL=ON \
380         -DVTK_Group_Rendering:BOOL=ON \
381         -DVTK_Group_StandAlone:BOOL=ON \
382         -DVTK_Group_Tk:BOOL=ON \
383         -DVTK_Group_Views:BOOL=ON \
384         -DModule_vtkFiltersStatisticsGnuR:BOOL=ON
385
386 %{__make}
387
388 %install
389 rm -rf $RPM_BUILD_ROOT
390 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ld.so.conf.d,%{_examplesdir}/%{name}-%{version},%{_datadir}/vtk-data} \
391         $RPM_BUILD_ROOT%{py_sitedir}
392
393 %{__make} -C build install \
394         DESTDIR=$RPM_BUILD_ROOT
395
396 # ld config
397 echo %{_libdir}/vtk > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
398
399 # fix python install path
400 mv $RPM_BUILD_ROOT%{py_sitescriptdir}/* $RPM_BUILD_ROOT%{py_sitedir}
401
402 cp -a VTKDATA%{version}/* $RPM_BUILD_ROOT%{_datadir}/vtk-data
403 cp -a vtk-examples/Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
404
405 # Install utilities
406 install build/bin/lproj $RPM_BUILD_ROOT%{_bindir}
407
408 # Install examples
409 for f in \
410 AmbientSpheres \
411 Arrays \
412 BalloonWidget \
413 BandedContours \
414 Cone \
415 Cone2 \
416 Cone3 \
417 Cone4 \
418 Cone5 \
419 Cone6 \
420 Cube \
421 Cylinder \
422 Delaunay3D \
423 Delaunay3DAlpha \
424 DiffuseSpheres \
425 DumpXMLFile \
426 FilledContours \
427 FixedPointVolumeRayCastMapperCT \
428 GPURenderDemo \
429 Generate2DAMRDataSetWithPulse \
430 Generate3DAMRDataSetWithPulse \
431 GenerateCubesFromLabels \
432 GenerateModelsFromLabels \
433 HierarchicalBoxPipeline \
434 ImageDataLIC2DDemo \
435 ImageSlicing \
436 LabeledMesh \
437 MaterialObjects \
438 Medical1 \
439 Medical2 \
440 Medical3 \
441 MultiBlock \
442 ParticleReader \
443 RGrid \
444 SGrid \
445 Slider \
446 Slider2D \
447 SpecularSpheres \
448 StructuredGridLIC2DDemo \
449 SurfaceLICDemo \
450 TimeRenderer \
451 TimeRenderer2 \
452 TubesWithVaryingRadiusAndColors \
453 finance ; do
454         install build/bin/$f $RPM_BUILD_ROOT%{_bindir}
455 done
456
457 # Install test binaries
458 for f in build/bin/*Tests build/bin/Test* build/bin/VTKBenchMark ; do
459         install $f $RPM_BUILD_ROOT%{_bindir}
460 done
461
462 install build/bin/VTKJavaExecutable $RPM_BUILD_ROOT%{_bindir}
463 install build/bin/vtkpython $RPM_BUILD_ROOT%{_bindir}
464
465 # unwanted doxygen files and misplaced verdict docs
466 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/vtk-6.0/{doxygen,verdict}
467
468 # only *.pyc are built by default, add *.pyo
469 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/vtk
470 %py_postclean
471
472 %clean
473 rm -rf $RPM_BUILD_ROOT
474
475 %post   -p /sbin/ldconfig
476 %postun -p /sbin/ldconfig
477
478 %post   qt -p /sbin/ldconfig
479 %postun qt -p /sbin/ldconfig
480
481 %post   java -p /sbin/ldconfig
482 %postun java -p /sbin/ldconfig
483
484 %post   python -p /sbin/ldconfig
485 %postun python -p /sbin/ldconfig
486
487 %post   tcl -p /sbin/ldconfig
488 %postun tcl -p /sbin/ldconfig
489
490 %files
491 %defattr(644,root,root,755)
492 %doc README.html vtkLogo.jpg vtkBanner.gif Wrapping/Tools/README*
493 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
494 %dir %{_libdir}/vtk
495 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so.1
496 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so.1
497 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so.1
498 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so.1
499 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so.1
500 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so.1
501 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so.1
502 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so.1
503 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so.1
504 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so.1
505 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so.1
506 %attr(755,root,root) %{_libdir}/vtk/libvtkNetCDF.so.1
507 %attr(755,root,root) %{_libdir}/vtk/libvtkNetCDF_cxx.so.1
508 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so.1
509 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so.1
510 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so.1
511 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so.1
512 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so.1
513 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeOpenGL.so.1
514 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PS.so.1
515 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingHybridOpenGL.so.1
516 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so.1
517 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so.1
518 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so.1
519 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL.so.1
520 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so.1
521 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeAMR.so.1
522 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL.so.1
523 %attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so.1
524 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so.1
525 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so.1
526 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so.1
527 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so.1
528 %attr(755,root,root) %{_libdir}/vtk/libvtkalglib.so.1
529 %attr(755,root,root) %{_libdir}/vtk/libvtkexoIIc.so.1
530 %attr(755,root,root) %{_libdir}/vtk/libvtkftgl.so.1
531 %attr(755,root,root) %{_libdir}/vtk/libvtkjsoncpp.so.1
532 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so.1
533 %attr(755,root,root) %{_libdir}/vtk/libvtkproj4.so.1
534 %attr(755,root,root) %{_libdir}/vtk/libvtksqlite.so.1
535 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so.1
536 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so.1
537 %exclude %{_libdir}/vtk/libvtk*Java.so.1
538 %exclude %{_libdir}/vtk/libvtk*Python2?D.so.1
539 %exclude %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
540 %exclude %{_libdir}/vtk/libvtk*TCL.so.1
541
542 %files devel
543 %defattr(644,root,root,755)
544 %doc Utilities/Upgrading/*
545 %attr(755,root,root) %{_bindir}/lproj
546 %attr(755,root,root) %{_bindir}/vtkEncodeString
547 %attr(755,root,root) %{_bindir}/vtkHashSource
548 %attr(755,root,root) %{_bindir}/vtkParseOGLExt
549 %attr(755,root,root) %{_bindir}/vtkProcessShader
550 %attr(755,root,root) %{_bindir}/vtkWrapHierarchy
551 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so
552 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so
553 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so
554 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so
555 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so
556 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so
557 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so
558 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so
559 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so
560 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so
561 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so
562 %attr(755,root,root) %{_libdir}/vtk/libvtkNetCDF.so
563 %attr(755,root,root) %{_libdir}/vtk/libvtkNetCDF_cxx.so
564 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so
565 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so
566 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so
567 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so
568 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so
569 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeOpenGL.so
570 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PS.so
571 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingHybridOpenGL.so
572 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so
573 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so
574 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so
575 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL.so
576 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so
577 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeAMR.so
578 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL.so
579 %attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so
580 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so
581 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so
582 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so
583 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so
584 %attr(755,root,root) %{_libdir}/vtk/libvtkalglib.so
585 %attr(755,root,root) %{_libdir}/vtk/libvtkexoIIc.so
586 %attr(755,root,root) %{_libdir}/vtk/libvtkftgl.so
587 %attr(755,root,root) %{_libdir}/vtk/libvtkjsoncpp.so
588 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so
589 %attr(755,root,root) %{_libdir}/vtk/libvtkproj4.so
590 %attr(755,root,root) %{_libdir}/vtk/libvtksqlite.so
591 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so
592 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so
593 %exclude %{_libdir}/vtk/libvtk*Java.so
594 %exclude %{_libdir}/vtk/libvtk*Python2?D.so
595 %exclude %{_libdir}/vtk/libvtkWrappingPython2?Core.so
596 %exclude %{_libdir}/vtk/libvtk*TCL.so
597 %{_libdir}/vtk/libvtkWrappingTools.a
598 %dir %{_includedir}/vtk
599 %{_includedir}/vtk/DICOM*.h
600 %{_includedir}/vtk/DatabaseSchemaWith2Tables.h
601 %{_includedir}/vtk/JSONCPP
602 %{_includedir}/vtk/LSDyna*.h
603 %{_includedir}/vtk/alglib
604 %{_includedir}/vtk/vtklibproj4
605 %{_includedir}/vtk/vtkmetaio
606 %{_includedir}/vtk/vtknetcdf
607 %{_includedir}/vtk/vtkverdict
608 %{_includedir}/vtk/vtksqlite
609 %{_includedir}/vtk/vtksys
610 %{_includedir}/vtk/vtk*.h
611 %{_includedir}/vtk/vtk*.txx
612 %exclude %{_includedir}/vtk/vtkEventQtSlotConnect.h
613 %exclude %{_includedir}/vtk/vtkGUISupportQt*.h
614 %exclude %{_includedir}/vtk/vtkJavaUtil.h
615 %exclude %{_includedir}/vtk/vtkWrappingJavaModule.h
616 %exclude %{_includedir}/vtk/vtkPython*.h
617 %exclude %{_includedir}/vtk/vtkQImageToImageSource.h
618 %exclude %{_includedir}/vtk/vtkQt*.h
619 %exclude %{_includedir}/vtk/vtkRenderingQtModule.h
620 %exclude %{_includedir}/vtk/vtkTcl*.h
621 %exclude %{_includedir}/vtk/vtkTk*.h
622 %exclude %{_includedir}/vtk/vtkViewsQtModule.h
623 %{_libdir}/cmake/vtk
624
625 %files qt
626 %defattr(644,root,root,755)
627 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so.1
628 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtOpenGL.so.1
629 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so.1
630 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtWebkit.so.1
631 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so.1
632 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so.1
633 %attr(755,root,root) %{_libdir}/qt4/plugins/designer/libQVTKWidgetPlugin.so
634
635 %files qt-devel
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so
638 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtOpenGL.so
639 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so
640 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtWebkit.so
641 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so
642 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so
643 %{_includedir}/vtk/QFilterTreeProxyModel.h
644 %{_includedir}/vtk/QVTK*.h
645 %{_includedir}/vtk/vtkEventQtSlotConnect.h
646 %{_includedir}/vtk/vtkGUISupportQt*.h
647 %{_includedir}/vtk/vtkQImageToImageSource.h
648 %{_includedir}/vtk/vtkQt*.h
649 %{_includedir}/vtk/vtkRenderingQtModule.h
650 %{_includedir}/vtk/vtkViewsQtModule.h
651
652 %if %{with java}
653 %files java
654 %defattr(644,root,root,755)
655 %attr(755,root,root) %{_bindir}/VTKJavaExecutable
656 %attr(755,root,root) %{_bindir}/vtkParseJava
657 %attr(755,root,root) %{_bindir}/vtkWrapJava
658 # common library
659 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so.1
660 # java modules
661 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCoreJava.so
662 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*Java.so
663 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryJava.so
664 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*Java.so
665 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCoreJava.so
666 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*Java.so
667 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*Java.so
668 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*Java.so
669 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*Java.so
670 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExampleJava.so
671 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCoreJava.so
672 %attr(755,root,root) %{_libdir}/vtk/libvtkRendering*Java.so
673 %attr(755,root,root) %{_libdir}/vtk/libvtkTestingRenderingJava.so
674 %attr(755,root,root) %{_libdir}/vtk/libvtkViews*Java.so
675 %{_libdir}/vtk/vtk.jar
676
677 %files java-devel
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so
680 %{_includedir}/vtk/vtkJavaUtil.h
681 %{_includedir}/vtk/vtkWrappingJavaModule.h
682 %endif
683
684 %files python
685 %defattr(644,root,root,755)
686 %doc Wrapping/Python/README*
687 %attr(755,root,root) %{_bindir}/vtkWrapPython
688 %attr(755,root,root) %{_bindir}/vtkWrapPythonInit
689 %attr(755,root,root) %{_bindir}/vtkpython
690 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so.1
691 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingPythonTkWidgets-6.0.so
692 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
693 %dir %{py_sitedir}/vtk
694 %{py_sitedir}/vtk/*.py[co]
695 %dir %{py_sitedir}/vtk/gtk
696 %{py_sitedir}/vtk/gtk/*.py[co]
697 %dir %{py_sitedir}/vtk/qt4
698 %{py_sitedir}/vtk/qt4/*.py[co]
699 %dir %{py_sitedir}/vtk/test
700 %{py_sitedir}/vtk/test/*.py[co]
701 %dir %{py_sitedir}/vtk/tk
702 %{py_sitedir}/vtk/tk/*.py[co]
703 %dir %{py_sitedir}/vtk/util
704 %{py_sitedir}/vtk/util/*.py[co]
705 %dir %{py_sitedir}/vtk/wx
706 %{py_sitedir}/vtk/wx/*.py[co]
707 %attr(755,root,root) %{py_sitedir}/vtk/vtk*Python.so
708 %{py_sitedir}/VTK-*-py*.egg-info
709
710 %files python-devel
711 %defattr(644,root,root,755)
712 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so
713 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so
714 %{_includedir}/vtk/PyVTK*.h
715 %{_includedir}/vtk/vtkPython*.h
716
717 %files tcl
718 %defattr(644,root,root,755)
719 %doc Wrapping/Tcl/README*
720 %attr(755,root,root) %{_bindir}/vtkWrapTcl
721 %attr(755,root,root) %{_bindir}/vtkWrapTclInit
722 %attr(755,root,root) %{_bindir}/vtk
723 %{_datadir}/tcl8.5/vtk
724 %attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so.1
725
726 %files tcl-devel
727 %defattr(644,root,root,755)
728 %attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so
729 %{_includedir}/vtk/vtkTcl*.h
730 %{_includedir}/vtk/vtkTk*.h
731
732 %files test-suite
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{_bindir}/*Tests
735 %attr(755,root,root) %{_bindir}/Test*
736 %attr(755,root,root) %{_bindir}/VTKBenchMark
737
738 %files examples
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_bindir}/AmbientSpheres
741 %attr(755,root,root) %{_bindir}/Arrays
742 %attr(755,root,root) %{_bindir}/Cone
743 %attr(755,root,root) %{_bindir}/Cone2
744 %attr(755,root,root) %{_bindir}/Cone3
745 %attr(755,root,root) %{_bindir}/Cone4
746 %attr(755,root,root) %{_bindir}/Cone5
747 %attr(755,root,root) %{_bindir}/Cone6
748 %attr(755,root,root) %{_bindir}/Cube
749 %attr(755,root,root) %{_bindir}/Cylinder
750 %attr(755,root,root) %{_bindir}/DiffuseSpheres
751 %attr(755,root,root) %{_bindir}/HierarchicalBoxPipeline
752 %attr(755,root,root) %{_bindir}/Medical1
753 %attr(755,root,root) %{_bindir}/Medical2
754 %attr(755,root,root) %{_bindir}/Medical3
755 %attr(755,root,root) %{_bindir}/MultiBlock
756 %attr(755,root,root) %{_bindir}/RGrid
757 %attr(755,root,root) %{_bindir}/SGrid
758 %attr(755,root,root) %{_bindir}/SpecularSpheres
759 %attr(755,root,root) %{_bindir}/finance
760 %attr(755,root,root) %{_bindir}/BalloonWidget
761 %attr(755,root,root) %{_bindir}/BandedContours
762 %attr(755,root,root) %{_bindir}/Delaunay3D
763 %attr(755,root,root) %{_bindir}/Delaunay3DAlpha
764 %attr(755,root,root) %{_bindir}/DumpXMLFile
765 %attr(755,root,root) %{_bindir}/FilledContours
766 %attr(755,root,root) %{_bindir}/FixedPointVolumeRayCastMapperCT
767 %attr(755,root,root) %{_bindir}/GPURenderDemo
768 %attr(755,root,root) %{_bindir}/Generate2DAMRDataSetWithPulse
769 %attr(755,root,root) %{_bindir}/Generate3DAMRDataSetWithPulse
770 %attr(755,root,root) %{_bindir}/GenerateCubesFromLabels
771 %attr(755,root,root) %{_bindir}/GenerateModelsFromLabels
772 %attr(755,root,root) %{_bindir}/ImageDataLIC2DDemo
773 %attr(755,root,root) %{_bindir}/ImageSlicing
774 %attr(755,root,root) %{_bindir}/LabeledMesh
775 %attr(755,root,root) %{_bindir}/MaterialObjects
776 %attr(755,root,root) %{_bindir}/ParticleReader
777 %attr(755,root,root) %{_bindir}/Slider
778 %attr(755,root,root) %{_bindir}/Slider2D
779 %attr(755,root,root) %{_bindir}/StructuredGridLIC2DDemo
780 %attr(755,root,root) %{_bindir}/SurfaceLICDemo
781 %attr(755,root,root) %{_bindir}/TimeRenderer
782 %attr(755,root,root) %{_bindir}/TimeRenderer2
783 %attr(755,root,root) %{_bindir}/TubesWithVaryingRadiusAndColors
784 %{_examplesdir}/%{name}-%{version}
785
786 %files data
787 %defattr(644,root,root,755)
788 %dir %{_datadir}/vtk-data
789 %{_datadir}/vtk-data/Baseline
790 %{_datadir}/vtk-data/Copyright.txt
791 %{_datadir}/vtk-data/Data
792 %{_datadir}/vtk-data/VERSION
793 %{_datadir}/vtk-data/VTKData.readme
This page took 0.106053 seconds and 4 git commands to generate.