]> git.pld-linux.org Git - packages/vtk.git/blob - vtk.spec
- package more python stuff
[packages/vtk.git] / vtk.spec
1 # TODO:
2 # - handle VTK_USE_MPEG2_ENCODER (see CMakeLists.txt)
3 # - handle MPI and VTK_USE_PARALLEL_BGL (Parallel Boost Graph Library, BR: boost >= 1.40)
4 # - more system libraries? (check for VTK_THIRD_PARTY_SUBDIR in Utilities/CMakeLists.txt)
5 # - CUDA for Accelerators/Piston (on bcond)
6 # - NVCtrlLib for Rendering/OpenGL (on bcond)
7 # - VTK_USE_SYSTEM_XDMF2=ON ? (but our xdmf-devel seems not compatible)
8 # - python bcond?
9 #
10 # Conditional build
11 %bcond_without  java            # Java wrappers
12 %bcond_without  ffmpeg          # FFMPEG .avi saving support
13 %bcond_with     doc             # do not build and package doxygen documentation
14 %bcond_with     OSMesa          # build with OSMesa (https://bugzilla.redhat.com/show_bug.cgi?id=744434)
15 %bcond_with     system_gl2ps    # use system gl2ps (VTK currently is carrying local modifications to gl2ps)
16
17 Summary:        Toolkit for 3D computer graphics, image processing, and visualization
18 Summary(pl.UTF-8):      Zestaw narzędzi do trójwymiarowej grafiki, przetwarzania obrazu i wizualizacji
19 Name:           vtk
20 Version:        8.2.0
21 Release:        0.1
22 License:        BSD
23 Group:          Libraries
24 Source0:        http://www.vtk.org/files/release/8.2/VTK-%{version}.tar.gz
25 # Source0-md5:  8af3307da0fc2ef8cafe4a312b821111
26 Source1:        http://www.vtk.org/files/release/8.2/VTKData-%{version}.tar.gz
27 # Source1-md5:  a6eab7bc02cee1376ee69243dde373ce
28 Patch0:         vtk-abi.patch
29 Patch1:         gcc10.patch
30 Patch2:         proj6_compat.patch
31 Patch3:         qt-5.15.patch
32 Patch4:         python-3.8.patch
33 Patch5:         link.patch
34 URL:            http://www.vtk.org/
35 %{?with_OSMesa:BuildRequires: Mesa-libOSMesa-devel}
36 BuildRequires:  OpenGL-GLX-devel
37 BuildRequires:  OpenGL-devel
38 BuildRequires:  Qt5Core-devel
39 BuildRequires:  Qt5Designer-devel
40 BuildRequires:  Qt5Gui-devel
41 BuildRequires:  Qt5Network-devel
42 BuildRequires:  Qt5OpenGL-devel
43 BuildRequires:  Qt5Sql-devel
44 BuildRequires:  Qt5WebKit-devel
45 BuildRequires:  Qt5X11Extras-devel
46 BuildRequires:  Qt5XmlPatterns-devel
47 BuildRequires:  Qt5UiTools-devel
48 BuildRequires:  R
49 BuildRequires:  boost-devel >= 1.39
50 BuildRequires:  cmake >= 2.8.8
51 %{?with_doc:BuildRequires:      doxygen}
52 BuildRequires:  expat-devel
53 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
54 BuildRequires:  fontconfig-devel
55 BuildRequires:  freetype-devel >= 2
56 BuildRequires:  gdal-devel
57 %{?with_system_gl2ps:BuildRequires:     gl2ps-devel >= 1.3.8}
58 BuildRequires:  gnuplot
59 BuildRequires:  graphviz
60 BuildRequires:  hdf5-devel
61 %if %{with java}
62 BuildRequires:  jdk >= 1.5
63 BuildRequires:  jpackage-utils
64 %endif
65 BuildRequires:  jsoncpp-devel
66 BuildRequires:  libharu-devel
67 BuildRequires:  libjpeg-devel
68 BuildRequires:  libogg-devel
69 BuildRequires:  libpng-devel
70 BuildRequires:  libstdc++-devel
71 BuildRequires:  libtheora-devel
72 BuildRequires:  libtiff-devel
73 BuildRequires:  libxml2-devel >= 2
74 BuildRequires:  lz4-devel
75 BuildRequires:  motif-devel
76 BuildRequires:  mysql-devel
77 BuildRequires:  netcdf-cxx-devel >= 4
78 # some code using it exists (Domains/Chemistry), but is not included in cmakefiles
79 #BuildRequires: openqube-devel
80 BuildRequires:  perl-base
81 BuildRequires:  postgresql-devel
82 BuildRequires:  proj-devel >= 6.0
83 BuildRequires:  python3-devel
84 BuildRequires:  python3-sip-devel
85 BuildRequires:  qt5-build >= 4.5.0
86 BuildRequires:  qt5-qmake >= 4.5.0
87 BuildRequires:  rpmbuild(macros) >= 1.605
88 BuildRequires:  sip
89 BuildRequires:  sip-PyQt5
90 BuildRequires:  tcl-devel
91 BuildRequires:  tk-devel
92 BuildRequires:  unixODBC-devel
93 BuildRequires:  wget
94 BuildRequires:  xorg-lib-libICE-devel
95 BuildRequires:  xorg-lib-libSM-devel
96 BuildRequires:  xorg-lib-libX11-devel
97 BuildRequires:  xorg-lib-libXScrnSaver-devel
98 BuildRequires:  xorg-lib-libXext-devel
99 BuildRequires:  xorg-lib-libXft-devel
100 BuildRequires:  xorg-lib-libXt-devel
101 BuildRequires:  zlib-devel
102 BuildConflicts: libXNVCtrl-devel
103 Obsoletes:      vtk-tcl < 8.2.0-1
104 Obsoletes:      vtk-tcl-devel < 8.2.0-1
105 %{?with_system_gl2ps:Requires:  gl2ps >= 1.3.8}
106 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108 %define         skip_post_check_so      lib.*Python.*\.so.*
109
110 %description
111 The Visualization ToolKit (VTK) is an object oriented software system
112 for 3D computer graphics, image processing, and visualization. VTK
113 includes a textbook, a C++ class library, and several interpreted
114 interface layers including Java, and Python. VTK supports a
115 wide variety of visualization algorithms including scalar, vector,
116 tensor, texture, and volumetric methods. It also supports advanced
117 modeling techniques like implicit modeling, polygon reduction, mesh
118 smoothing, cutting, contouring, and Delaunay triangulation. Moreover,
119 dozens of imaging algorithms have been integrated into the system.
120 This allows mixing 2D imaging / 3D graphics algorithms and data.
121
122 %description -l pl.UTF-8
123 Visualization TookKit (VTK) to obiektowo zorientowany system
124 oprogramowania do trójwymiarowej grafiki komputerowej, przetwarzania
125 obrazu i wizualizacji. VTK zawiera książkę, bibliotekę klas C++ oraz
126 kilka interpretowanych warstw interfejsów, w tym dla Javy i
127 Pythona. VTK obsługuje szeroki zakres algorytmów wizualizacji, w tym
128 metody skalarne, wektorowe, tensorowe, teksturowe i wolumetryczne.
129 Obsługuje także zaawansowane techniki modelowania, takie jak
130 modelowanie implicite, redukcja wielokątów, wygładzanie siatki,
131 przycinanie, konturowanie i triangulacja Delaunaya. Co więcej, wiele
132 algorytmów obrazowania zostało zintegrowanych z systemem. Pozwala to
133 na mieszanie algorytmów obrazowania 2D i grafiki 3D.
134
135 %package devel
136 Summary:        VTK header files for building C++ code
137 Summary(pl.UTF-8):      Pliki nagłówkowe VTK dla C++
138 Group:          Development
139 Requires:       %{name} = %{version}-%{release}
140 Requires:       libstdc++-devel
141
142 %description devel
143 This provides the VTK header files required to compile C++ programs
144 that use VTK to do 3D visualisation.
145
146 %description devel -l pl.UTF-8
147 Ten pakiet dostarcza pliki nagłówkowe VTK do kompilowania programów
148 C++ używających VTK do wizualizacji 3D.
149
150 %package qt
151 Summary:        Qt5 bindings and Qt5 Designer plugin for VTK
152 Summary(pl.UTF-8):      Wiązania Qt5 oraz wtyczka Qt5 Designera do VTK
153 Group:          X11/Libraries
154 Requires:       %{name} = %{version}-%{release}
155 Requires:       Qt5Core >= 4.5.0
156 Requires:       Qt5Gui >= 4.5.0
157 Requires:       Qt5Network >= 4.5.0
158 Requires:       Qt5OpenGL >= 4.5.0
159 Requires:       Qt5Sql >= 4.5.0
160 Requires:       Qt5WebKit >= 4.5.0
161
162 %description qt
163 Qt5 bindings and Qt5 Designer plugin for VTK.
164
165 %description qt -l pl.UTF-8
166 Wiązania Qt5 oraz wtyczka Qt5 Designera do VTK.
167
168 %package qt-devel
169 Summary:        Header files for VTK Qt5 bindings
170 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Qt5` do VTK
171 Group:          X11/Development/Libraries
172 Requires:       %{name}-devel = %{version}-%{release}
173 Requires:       %{name}-qt = %{version}-%{release}
174 Requires:       Qt5Core-devel >= 4.5.0
175 Requires:       Qt5Gui-devel >= 4.5.0
176 Requires:       Qt5OpenGL-devel >= 4.5.0
177 Requires:       Qt5Sql-devel >= 4.5.0
178
179 %description qt-devel
180 Header files for VTK Qt bindings.
181
182 %description qt-devel -l pl.UTF-8
183 Pliki nagłówkowe wiązań Qt do VTK.
184
185 %package java
186 Summary:        Java bindings for VTK
187 Summary(pl.UTF-8):      Wiązania Javy do VTK
188 Group:          Development/Languages/Java
189 Requires:       %{name} = %{version}-%{release}
190 # or separate qt parts?
191 Requires:       %{name}-qt = %{version}-%{release}
192
193 %description java
194 This package contains Java bindings for VTK.
195
196 %description java -l pl.UTF-8
197 Ten pakiet zawiera wiązania Javy do VTK.
198
199 %package java-devel
200 Summary:        Header files for Java VTK binding
201 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Javy do VTK
202 Group:          Development/Libraries
203 Requires:       %{name}-devel = %{version}-%{release}
204 Requires:       %{name}-java = %{version}-%{release}
205 # <jni.h>
206 Requires:       jdk
207
208 %description java-devel
209 Header files for Java VTK binding.
210
211 %description java-devel -l pl.UTF-8
212 Pliki nagłówkowe wiązania Javy do VTK.
213
214 %package python3
215 Summary:        Python 3 bindings for VTK
216 Summary(pl.UTF-8):      Wiązania Pythona 3 do VTK
217 Group:          Libraries
218 Requires:       %{name} = %{version}-%{release}
219 # or separate qt parts again?
220 Requires:       %{name}-qt = %{version}-%{release}
221 Obsoletes:      vtk-python-qt < 6.0.0-1
222 Obsoletes:      vtk-python-sip < 6.0.0-1
223 Obsoletes:      vtk-python < 8.2.0-1
224
225 %description python3
226 This package contains Python 3 bindings for VTK.
227
228 %description python3 -l pl.UTF-8
229 Ten pakiet zawiera wiązania Pythona 3 do VTK.
230
231 %package python3-devel
232 Summary:        Header files for Python 3 VTK binding
233 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Pythona 3 do VTK
234 Group:          Development/Libraries
235 Requires:       %{name}-devel = %{version}-%{release}
236 Requires:       %{name}-python3 = %{version}-%{release}
237 Requires:       python3-devel
238 Obsoletes:      vtk-python-devel < 8.2.0-1
239
240 %description python3-devel
241 Header files for Python 3 VTK binding.
242
243 %description python3-devel -l pl.UTF-8
244 Pliki nagłówkowe wiązania Pythona 3 do VTK.
245
246 %package examples
247 Summary:        C++ and Python example programs/scripts for VTK
248 Summary(pl.UTF-8):      Przykładowe programy/skrypty w C++ i Pythonie dla VTK
249 Group:          Development/Libraries
250 Requires:       %{name} = %{version}-%{release}
251 Requires:       %{name}-data = %{version}-%{release}
252
253 %description examples
254 This package contains all the examples from the VTK source. To compile
255 the C++ examples you will need to install the vtk-devel package as
256 well. The Python examples can be run with the corresponding
257 packages (vtk-python3).
258
259 %description examples -l pl.UTF-8
260 Ten pakiet zawiera wszystkie przykłady ze źródeł VTK. Do skompilowania
261 przykładów w C++ trzeba doinstalować pakiet vtk-devel. Przykłady w
262 Pythonie można uruchamiać przy użyciu odpowiednich pakietów
263 (vtk-python3).
264
265 %package test-suite
266 Summary:        Test programs for VTK
267 Summary(pl.UTF-8):      Programy testowe dla VTK
268 Group:          Development/Libraries
269 Requires:       %{name} = %{version}-%{release}
270 Requires:       %{name}-data = %{version}-%{release}
271
272 %description test-suite
273 This package contains all testing programs from the VTK source. The
274 source code of these programs can be found in the vtk-examples
275 package.
276
277 %description test-suite -l pl.UTF-8
278 Ten pakiet zawiera wszystkie programy testowe ze źródeł VTK. Kod
279 źródłowy tych programów można znaleźć w pakiecie vtk-examples.
280
281 %package data
282 Summary:        Data files for VTK
283 Summary(pl.UTF-8):      Pliki danych dla VTK
284 Group:          Development/Libraries
285 %if "%{_rpmversion}" >= "5"
286 BuildArch:      noarch
287 %endif
288
289 %description data
290 This package contains all the data from the VTKData repository. These
291 data are required to run various examples from the vtk-examples
292 package.
293
294 %description data -l pl.UTF-8
295 Ten pakiet zawiera wszystkie dane z repozytorium VTKData. Dane te są
296 potrzebne do uruchamiania różnych przykładów z pakietu vtk-examples.
297
298 %prep
299 %setup -q -n VTK-%{version} -b 1
300 %patch0 -p1
301 %patch1 -p1
302 %patch2 -p1
303 %patch3 -p1
304 %patch4 -p1
305 %patch5 -p1
306
307 # Replace relative path ../../../VTKData with destination filesystem path
308 grep -Erl '(\.\./)+VTKData' Examples | xargs \
309   perl -pi -e 's,(\.\./)+VTKData,%{_datadir}/vtk-8.1,g'
310
311 # Save an unbuilt copy of the Example's sources for %doc
312 mkdir vtk-examples
313 cp -a Examples vtk-examples
314 # Don't ship Win32 examples
315 %{__rm} -r vtk-examples/Examples/GUI/Win32
316 find vtk-examples -type f | xargs chmod -R a-x
317
318 %build
319 export CFLAGS="%{rpmcflags} -D_UNICODE -DHAVE_UINTPTR_T"
320 export CXXFLAGS="%{rpmcxxflags} -D_UNICODE -DHAVE_UINTPTR_T"
321 %if %{with java}
322 export JAVA_HOME=%{java_home}
323 %ifarch x32
324 # getting "java.lang.OutOfMemoryError: Java heap space" during the build
325 export JAVA_TOOL_OPTIONS=-Xmx2048m
326 %endif
327 %endif
328
329 # handle cmake & ccache
330 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmake
331 # ASM fix: http://lists.busybox.net/pipermail/buildroot/2013-March/069436.html
332 if [[ "%{__cc}" = *ccache* ]]; then
333         cc="%{__cc}"
334         cxx="%{__cxx}"
335         ccache="
336         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
337         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
338         -DCMAKE_ASM_COMPILER="${cc#ccache }" \
339         "
340 else
341         ccache="
342         -DCMAKE_C_COMPILER="%{__cc}" \
343         -DCMAKE_CXX_COMPILER="%{__cxx}" \
344         -DCMAKE_ASM_COMPILER="%{__cc}" \
345         "
346 fi
347
348 mkdir -p build
349 cd build
350 %cmake .. \
351         $ccache \
352         -Wno-dev \
353         %{cmake_on_off doc DBUILD_DOCUMENTATION} \
354         -DBUILD_EXAMPLES:BOOL=ON \
355         -DBUILD_SHARED_LIBS:BOOL=ON \
356         -DBUILD_TESTING:BOOL=ON \
357         -DCMAKE_SKIP_RPATH:BOOL=ON \
358         -DOPENGL_INCLUDE_PATH:PATH=%{_includedir}/GL \
359         -DPYTHON_INCLUDE_PATH:PATH=%{py3_incdir} \
360         -DPYTHON_LIBRARY:FILEPATH=%{_libdir}/libpython%{py3_ver}.so \
361         -DPYTHON_UTIL_LIBRARY:PATH=%{_libdir}/libutil.so \
362         -DTCL_INCLUDE_PATH:PATH=%{_includedir} \
363         -DTCL_LIBRARY:PATH=%{_libdir}/libtcl.so \
364         -DTK_INCLUDE_PATH:PATH=%{_includedir} \
365         -DTK_LIBRARY:PATH=%{_libdir}/libtk.so \
366         -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
367         -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/vtk \
368         -DVTK_INSTALL_INCLUDE_DIR:PATH=include/vtk \
369         -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/vtk \
370         -DVTK_INSTALL_PACKAGE_DIR:PATH=%{_lib}/cmake/vtk \
371         -DVTK_INSTALL_TCL_DIR:PATH=share/tcl%{tcl_version}/vtk \
372         -DVTK_INSTALL_QT_DIR=/%{_lib}/qt5/plugins/designer \
373         -DVTK_INSTALL_PYTHON_MODULES_DIR:PATH=%{py3_sitedir} \
374         -DVTK_FFMPEG_HAS_OLD_HEADER:BOOL=OFF \
375         %{?with_OSMesa:-DVTK_OPENGL_HAS_OSMESA:BOOL=ON} \
376         -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
377         -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
378         -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
379         -DVTK_USE_SYSTEM_XDMF2:BOOL=OFF \
380         -DVTK_USE_SYSTEM_LIBHARU:BOOL=OFF \
381         %{!?with_system_gl2ps:-DVTK_USE_SYSTEM_GL2PS:BOOL=OFF} \
382 %if %{with java}
383         -DVTK_WRAP_JAVA:BOOL=ON \
384         -DJAVA_INCLUDE_PATH:PATH=$JAVA_HOME/include \
385         -DJAVA_INCLUDE_PATH2:PATH=$JAVA_HOME/include/linux \
386         -DJAVA_AWT_INCLUDE_PATH:PATH=$JAVA_HOME/include \
387 %else
388         -DVTK_WRAP_JAVA:BOOL=OFF \
389 %endif
390         -DVTK_WRAP_PYTHON:BOOL=ON \
391         -DVTK_PYTHON_VERSION=3 \
392         %{?with_sip:-DVTK_WRAP_PYTHON_SIP:BOOL=ON} \
393         -DVTK_Group_Imaging:BOOL=ON \
394         -DVTK_Group_Qt:BOOL=ON \
395         -DVTK_Group_Rendering:BOOL=ON \
396         -DVTK_Group_StandAlone:BOOL=ON \
397         -DVTK_Group_Tk:BOOL=ON \
398         -DVTK_Group_Views:BOOL=ON \
399         -DModule_vtkFiltersReebGraph:BOOL=ON \
400         %{?with_ffmpeg:-DModule_vtkIOFFMPEG:BOOL=ON} \
401         -DModule_vtkIOGDAL:BOOL=ON \
402         -DModule_vtkIOGeoJSON:BOOL=ON \
403         -DModule_vtkIOMySQL:BOOL=ON \
404         -DModule_vtkIOODBC:BOOL=ON \
405         -DModule_vtkIOParallelExodus:BOOL=ON \
406         -DModule_vtkIOParallelLSDyna:BOOL=ON \
407         -DModule_vtkIOPostgreSQL:BOOL=ON \
408         -DModule_vtkIOVPIC:BOOL=ON \
409         -DModule_vtkIOXdmf2:BOOL=ON \
410         -DModule_vtkInfovisBoost:BOOL=ON \
411         -DModule_vtkInfovisBoostGraphAlgorithms:BOOL=ON \
412         -DModule_vtkRenderingFreeTypeFontConfig:BOOL=ON \
413         -DModule_vtkRenderingMatplotlib:BOOL=ON \
414         -DModule_vtkRenderingParallel:BOOL=ON
415 # TODO: -DModule_vtkAcceleratorsDax:BOOL=ON (BR: FindDax.cmake, maybe http://www.daxtoolkit.org/ ?)
416 # TODO: -DModule_vtkAcceleratorsPiston:BOOL=ON (on bcond, BR: CUDA)
417 # TODO: -DModule_vtkFiltersParallelFlowPaths:BOOL=ON (BR: MPI)
418 # TODO: -DModule_vtkFiltersParallelStatistics:BOOL=ON (BR: MPI)
419 # TODO: -DModule_vtkInfovisParallel:BOOL=ON (BR: MPI)
420 # TODO: -DModule_vtkRenderingParallelLIC:BOOL=ON (BR: MPI)
421
422 %{__make}
423 %{?with_doc:%{__make} DoxygenDoc}
424
425 %install
426 rm -rf $RPM_BUILD_ROOT
427 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ld.so.conf.d,%{_examplesdir}/%{name}-%{version}}
428
429 %{__make} -C build install \
430         DESTDIR=$RPM_BUILD_ROOT
431
432 # ld config
433 echo %{_libdir}/vtk > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
434
435 for f in $(cd build/ExternalData/Testing ; find Data -type l); do
436         install -Dp build/ExternalData/Testing/$f $RPM_BUILD_ROOT%{_datadir}/vtk-8.1/$f
437 done
438
439 # Install examples
440 for f in \
441 AmbientSpheres \
442 Arrays \
443 BalloonWidget \
444 BandedContours \
445 Cone \
446 Cone2 \
447 Cone3 \
448 Cone4 \
449 Cone5 \
450 Cone6 \
451 Cube \
452 Cylinder \
453 Delaunay3D \
454 Delaunay3DAlpha \
455 DiffuseSpheres \
456 DumpXMLFile \
457 FilledContours \
458 FixedPointVolumeRayCastMapperCT \
459 GPURenderDemo \
460 Generate2DAMRDataSetWithPulse \
461 Generate3DAMRDataSetWithPulse \
462 GenerateCubesFromLabels \
463 GenerateModelsFromLabels \
464 HierarchicalBoxPipeline \
465 ImageSlicing \
466 LabeledMesh \
467 Medical1 \
468 Medical2 \
469 Medical3 \
470 Medical4 \
471 MultiBlock \
472 ParticleReader \
473 RGrid \
474 SGrid \
475 SimpleView \
476 Slider \
477 Slider2D \
478 SpecularSpheres \
479 TubesWithVaryingRadiusAndColors \
480 finance ; do
481         install build/bin/$f $RPM_BUILD_ROOT%{_bindir}
482 done
483
484 # Install test binaries
485 for f in build/bin/*Tests build/bin/Test*; do
486         install $f $RPM_BUILD_ROOT%{_bindir}
487 done
488
489 %if %{with java}
490 install -p build/bin/VTKJavaExecutable $RPM_BUILD_ROOT%{_bindir}
491 %endif
492 install -p build/bin/vtkpython $RPM_BUILD_ROOT%{_bindir}
493
494 # unwanted doxygen files and misplaced verdict docs
495 %{?with_doc:%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/vtk-*/{doxygen,verdict}}
496
497 %clean
498 rm -rf $RPM_BUILD_ROOT
499
500 %post   -p /sbin/ldconfig
501 %postun -p /sbin/ldconfig
502
503 %post   qt -p /sbin/ldconfig
504 %postun qt -p /sbin/ldconfig
505
506 %post   java -p /sbin/ldconfig
507 %postun java -p /sbin/ldconfig
508
509 %post   python3 -p /sbin/ldconfig
510 %postun python3 -p /sbin/ldconfig
511
512 %files
513 %defattr(644,root,root,755)
514 %doc README.md vtkBanner.gif vtkLogo.ico Wrapping/Tools/README*
515 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
516 %dir %{_libdir}/vtk
517 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so.1
518 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so.1
519 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so.1
520 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2.so.1
521 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so.1
522 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so.1
523 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so.1
524 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so.1
525 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so.1
526 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so.1
527 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so.1
528 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so.1
529 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so.1
530 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so.1
531 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so.1
532 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL2.so.1
533 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so.1
534 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so.1
535 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so.1
536 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PSOpenGL2.so.1
537 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so.1
538 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so.1
539 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so.1
540 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL2.so.1
541 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so.1
542 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL2.so.1
543 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so.1
544 %attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so.1
545 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so.1
546 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so.1
547 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so.1
548 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so.1
549 %attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so.1
550 %attr(755,root,root) %{_libdir}/vtk/libvtkgl2ps.so.1
551 %attr(755,root,root) %{_libdir}/vtk/libvtklibharu.so.1
552 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so.1
553 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so.1
554 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so.1
555 %attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so.1
556 %if %{with java}
557 %exclude %{_libdir}/vtk/libvtk*Java.so.1
558 %endif
559 %exclude %{_libdir}/vtk/libvtk*Python3?D.so.1
560 %exclude %{_libdir}/vtk/libvtkWrappingPython3?Core.so.1
561
562 %files devel
563 %defattr(644,root,root,755)
564 %doc Utilities/Upgrading/*
565 %attr(755,root,root) %{_bindir}/vtkWrapHierarchy
566 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so
567 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so
568 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so
569 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2.so
570 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so
571 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so
572 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so
573 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so
574 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so
575 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so
576 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so
577 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so
578 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so
579 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so
580 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so
581 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL2.so
582 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so
583 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so
584 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so
585 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PSOpenGL2.so
586 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so
587 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so
588 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so
589 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL2.so
590 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so
591 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL2.so
592 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so
593 %attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so
594 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so
595 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so
596 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so
597 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so
598 %attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so
599 %attr(755,root,root) %{_libdir}/vtk/libvtkgl2ps.so
600 %attr(755,root,root) %{_libdir}/vtk/libvtklibharu.so
601 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so
602 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so
603 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so
604 %attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so
605 %if %{with java}
606 %exclude %{_libdir}/vtk/libvtk*Java.so
607 %endif
608 %exclude %{_libdir}/vtk/libvtk*Python3?D.so
609 %exclude %{_libdir}/vtk/libvtkWrappingPython3?Core.so
610 %{_libdir}/vtk/libvtkWrappingTools.a
611 %dir %{_includedir}/vtk
612 %{_includedir}/vtk/VPIC
613 %{_includedir}/vtk/DICOM*.h
614 %{_includedir}/vtk/DatabaseSchemaWith2Tables.h
615 %{_includedir}/vtk/vtkgl2ps
616 %{_includedir}/vtk/vtkkwiml
617 %{_includedir}/vtk/vtklibharu
618 %{_includedir}/vtk/vtkmetaio
619 %{_includedir}/vtk/vtksys
620 %{_includedir}/vtk/vtkverdict
621 %{_includedir}/vtk/vtkxdmf2
622 %{_includedir}/vtk/vtk*.h
623 %{_includedir}/vtk/vtk*.txx
624 %exclude %{_includedir}/vtk/vtkEventQtSlotConnect.h
625 %exclude %{_includedir}/vtk/vtkGUISupportQt*.h
626 %if %{with java}
627 %exclude %{_includedir}/vtk/vtkJavaUtil.h
628 %exclude %{_includedir}/vtk/vtkWrappingJavaModule.h
629 %endif
630 %exclude %{_includedir}/vtk/vtkPython*.h
631 %exclude %{_includedir}/vtk/vtkQImageToImageSource.h
632 %exclude %{_includedir}/vtk/vtkQt*.h
633 %exclude %{_includedir}/vtk/vtkRenderingQtModule.h
634 %exclude %{_includedir}/vtk/vtkTk*.h
635 %exclude %{_includedir}/vtk/vtkViewsQtModule.h
636 %{_libdir}/cmake/vtk
637
638 %files qt
639 %defattr(644,root,root,755)
640 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so.1
641 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so.1
642 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so.1
643 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so.1
644 %attr(755,root,root) %{_libdir}/qt5/plugins/designer/libQVTKWidgetPlugin.so
645
646 %files qt-devel
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so
649 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so
650 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so
651 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so
652 %{_includedir}/vtk/QFilterTreeProxyModel.h
653 %{_includedir}/vtk/QVTK*.h
654 %{_includedir}/vtk/vtkEventQtSlotConnect.h
655 %{_includedir}/vtk/vtkGUISupportQt*.h
656 %{_includedir}/vtk/vtkQImageToImageSource.h
657 %{_includedir}/vtk/vtkQt*.h
658 %{_includedir}/vtk/vtkRenderingQtModule.h
659 %{_includedir}/vtk/vtkViewsQtModule.h
660
661 %if %{with java}
662 %files java
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_bindir}/VTKJavaExecutable
665 %attr(755,root,root) %{_bindir}/vtkParseJava
666 %attr(755,root,root) %{_bindir}/vtkWrapJava
667 # common library
668 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so.1
669 # java modules
670 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCoreJava.so
671 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*Java.so
672 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryJava.so
673 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2Java.so
674 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*Java.so
675 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCoreJava.so
676 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*Java.so
677 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*Java.so
678 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*Java.so
679 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*Java.so
680 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExampleJava.so
681 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCoreJava.so
682 %attr(755,root,root) %{_libdir}/vtk/libvtkRendering*Java.so
683 %attr(755,root,root) %{_libdir}/vtk/libvtkTestingRenderingJava.so
684 %attr(755,root,root) %{_libdir}/vtk/libvtkViews*Java.so
685 %{_libdir}/vtk/vtk.jar
686
687 %files java-devel
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so
690 %{_includedir}/vtk/vtkJavaUtil.h
691 %{_includedir}/vtk/vtkWrappingJavaModule.h
692 %endif
693
694 %files python3
695 %defattr(644,root,root,755)
696 %doc Wrapping/Python/README*
697 %attr(755,root,root) %{_bindir}/vtkWrapPython
698 %attr(755,root,root) %{_bindir}/vtkWrapPythonInit
699 %attr(755,root,root) %{_bindir}/vtkpython
700 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python3?D.so.1
701 %attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so.1
702 # RenderingMatplotlib requires PythonInterpreter
703 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so.1
704 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingPythonTkWidgets-8.2.so
705 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython3?Core.so.1
706 %dir %{py3_sitedir}/vtk.py
707 %dir %{py3_sitedir}/__pycache__/*
708 %dir %{py3_sitedir}/vtkmodules
709 %{py3_sitedir}/vtkmodules/*.py
710 %{py3_sitedir}/vtkmodules/__pycache__
711 %dir %{py3_sitedir}/vtkmodules/gtk
712 %{py3_sitedir}/vtkmodules/gtk/*.py
713 %{py3_sitedir}/vtkmodules/gtk/__pycache__
714 %dir %{py3_sitedir}/vtkmodules/numpy_interface
715 %{py3_sitedir}/vtkmodules/numpy_interface/*.py
716 %{py3_sitedir}/vtkmodules/numpy_interface/__pycache__
717 %dir %{py3_sitedir}/vtkmodules/qt
718 %{py3_sitedir}/vtkmodules/qt/*.py
719 %{py3_sitedir}/vtkmodules/qt/__pycache__
720 %dir %{py3_sitedir}/vtkmodules/qt4
721 %{py3_sitedir}/vtkmodules/qt4/*.py
722 %{py3_sitedir}/vtkmodules/qt4/__pycache__
723 %dir %{py3_sitedir}/vtkmodules/test
724 %{py3_sitedir}/vtkmodules/test/*.py
725 %{py3_sitedir}/vtkmodules/test/__pycache__
726 %dir %{py3_sitedir}/vtkmodules/tk
727 %{py3_sitedir}/vtkmodules/tk/__pycache__
728 %{py3_sitedir}/vtkmodules/tk/*.py
729 %dir %{py3_sitedir}/vtkmodules/util
730 %{py3_sitedir}/vtkmodules/util/*.py
731 %{py3_sitedir}/vtkmodules/util/__pycache__
732 %dir %{py3_sitedir}/vtkmodules/wx
733 %{py3_sitedir}/vtkmodules/wx/*.py
734 %{py3_sitedir}/vtkmodules/wx/__pycache__
735 %attr(755,root,root) %{py3_sitedir}/vtkmodules/vtk*Python.so
736
737 %files python3-devel
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python3?D.so
740 %attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so
741 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so
742 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython3?Core.so
743 %{_includedir}/vtk/PyVTK*.h
744 %{_includedir}/vtk/vtkPython*.h
745
746 %files test-suite
747 %defattr(644,root,root,755)
748 %attr(755,root,root) %{_bindir}/*Tests
749 %attr(755,root,root) %{_bindir}/Test*
750
751 %files examples
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_bindir}/AmbientSpheres
754 %attr(755,root,root) %{_bindir}/Arrays
755 %attr(755,root,root) %{_bindir}/Cone
756 %attr(755,root,root) %{_bindir}/Cone2
757 %attr(755,root,root) %{_bindir}/Cone3
758 %attr(755,root,root) %{_bindir}/Cone4
759 %attr(755,root,root) %{_bindir}/Cone5
760 %attr(755,root,root) %{_bindir}/Cone6
761 %attr(755,root,root) %{_bindir}/Cube
762 %attr(755,root,root) %{_bindir}/Cylinder
763 %attr(755,root,root) %{_bindir}/DiffuseSpheres
764 %attr(755,root,root) %{_bindir}/HierarchicalBoxPipeline
765 %attr(755,root,root) %{_bindir}/Medical1
766 %attr(755,root,root) %{_bindir}/Medical2
767 %attr(755,root,root) %{_bindir}/Medical3
768 %attr(755,root,root) %{_bindir}/Medical4
769 %attr(755,root,root) %{_bindir}/MultiBlock
770 %attr(755,root,root) %{_bindir}/RGrid
771 %attr(755,root,root) %{_bindir}/SGrid
772 %attr(755,root,root) %{_bindir}/SimpleView
773 %attr(755,root,root) %{_bindir}/SpecularSpheres
774 %attr(755,root,root) %{_bindir}/finance
775 %attr(755,root,root) %{_bindir}/BalloonWidget
776 %attr(755,root,root) %{_bindir}/BandedContours
777 %attr(755,root,root) %{_bindir}/Delaunay3D
778 %attr(755,root,root) %{_bindir}/Delaunay3DAlpha
779 %attr(755,root,root) %{_bindir}/DumpXMLFile
780 %attr(755,root,root) %{_bindir}/FilledContours
781 %attr(755,root,root) %{_bindir}/FixedPointVolumeRayCastMapperCT
782 %attr(755,root,root) %{_bindir}/GPURenderDemo
783 %attr(755,root,root) %{_bindir}/Generate2DAMRDataSetWithPulse
784 %attr(755,root,root) %{_bindir}/Generate3DAMRDataSetWithPulse
785 %attr(755,root,root) %{_bindir}/GenerateCubesFromLabels
786 %attr(755,root,root) %{_bindir}/GenerateModelsFromLabels
787 %attr(755,root,root) %{_bindir}/ImageSlicing
788 %attr(755,root,root) %{_bindir}/LabeledMesh
789 %attr(755,root,root) %{_bindir}/ParticleReader
790 %attr(755,root,root) %{_bindir}/Slider
791 %attr(755,root,root) %{_bindir}/Slider2D
792 %attr(755,root,root) %{_bindir}/TubesWithVaryingRadiusAndColors
793 %{_examplesdir}/%{name}-%{version}
794
795 %files data
796 %defattr(644,root,root,755)
797 %dir %{_datadir}/vtk-8.1
798 %{_datadir}/vtk-8.1/Data
This page took 0.121998 seconds and 4 git commands to generate.