]> git.pld-linux.org Git - packages/vtk.git/blob - vtk.spec
add few missing deps
[packages/vtk.git] / vtk.spec
1 # TODO:
2 # - handle VTK_USE_MPEG2_ENCODER (see CMakeLists.txt)
3 # - handle MPI and VTK_USE_PARALLEL_BGL (Parallel Boost Graph Library, BR: boost >= 1.40)
4 # - more system libraries? (check for VTK_THIRD_PARTY_SUBDIR in Utilities/CMakeLists.txt)
5 # - CUDA for Accelerators/Piston (on bcond)
6 # - NVCtrlLib for Rendering/OpenGL (on bcond)
7 # - VTK_USE_SYSTEM_XDMF2=ON ? (but our xdmf-devel seems not compatible)
8 # - python bcond?
9 #
10 # Conditional build
11 %bcond_without  java            # Java wrappers
12 %bcond_without  ffmpeg          # FFMPEG .avi saving support
13 %bcond_with     doc             # do not build and package doxygen documentation
14 %bcond_with     OSMesa          # build with OSMesa (https://bugzilla.redhat.com/show_bug.cgi?id=744434)
15 %bcond_with     system_gl2ps    # use system gl2ps (VTK currently is carrying local modifications to gl2ps)
16
17 Summary:        Toolkit for 3D computer graphics, image processing, and visualization
18 Summary(pl.UTF-8):      Zestaw narzędzi do trójwymiarowej grafiki, przetwarzania obrazu i wizualizacji
19 Name:           vtk
20 Version:        8.2.0
21 Release:        0.1
22 License:        BSD
23 Group:          Libraries
24 Source0:        http://www.vtk.org/files/release/8.2/VTK-%{version}.tar.gz
25 # Source0-md5:  8af3307da0fc2ef8cafe4a312b821111
26 Source1:        http://www.vtk.org/files/release/8.2/VTKData-%{version}.tar.gz
27 # Source1-md5:  a6eab7bc02cee1376ee69243dde373ce
28 Patch0:         vtk-abi.patch
29 Patch1:         gcc10.patch
30 Patch2:         proj6_compat.patch
31 Patch3:         qt-5.15.patch
32 Patch4:         python-3.8.patch
33 Patch5:         link.patch
34 URL:            http://www.vtk.org/
35 %{?with_OSMesa:BuildRequires: Mesa-libOSMesa-devel}
36 BuildRequires:  OpenGL-GLX-devel
37 BuildRequires:  OpenGL-devel
38 BuildRequires:  Qt5Core-devel
39 BuildRequires:  Qt5Designer-devel
40 BuildRequires:  Qt5Gui-devel
41 BuildRequires:  Qt5Network-devel
42 BuildRequires:  Qt5OpenGL-devel
43 BuildRequires:  Qt5Sql-devel
44 BuildRequires:  Qt5WebKit-devel
45 BuildRequires:  Qt5X11Extras-devel
46 BuildRequires:  Qt5XmlPatterns-devel
47 BuildRequires:  Qt5UiTools-devel
48 BuildRequires:  R
49 BuildRequires:  boost-devel >= 1.39
50 BuildRequires:  cmake >= 3.3
51 BuildRequires:  double-conversion-devel
52 %{?with_doc:BuildRequires:      doxygen}
53 BuildRequires:  eigen3 >= 2.91.0
54 BuildRequires:  expat-devel
55 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
56 BuildRequires:  fontconfig-devel
57 BuildRequires:  freetype-devel >= 2
58 BuildRequires:  gdal-devel
59 %{?with_system_gl2ps:BuildRequires:     gl2ps-devel >= 1.3.8}
60 BuildRequires:  glew-devel
61 BuildRequires:  gnuplot
62 BuildRequires:  graphviz
63 BuildRequires:  hdf5-devel
64 %if %{with java}
65 BuildRequires:  jdk >= 1.5
66 BuildRequires:  jpackage-utils
67 %endif
68 BuildRequires:  jsoncpp-devel >= 0.7.0
69 BuildRequires:  libharu-devel
70 BuildRequires:  libjpeg-devel
71 BuildRequires:  libogg-devel
72 BuildRequires:  libpng-devel
73 BuildRequires:  libstdc++-devel
74 BuildRequires:  libtheora-devel
75 BuildRequires:  libtiff-devel
76 BuildRequires:  libxml2-devel >= 2
77 BuildRequires:  lz4-devel
78 BuildRequires:  motif-devel
79 BuildRequires:  mysql-devel
80 BuildRequires:  netcdf-cxx-devel >= 4
81 # some code using it exists (Domains/Chemistry), but is not included in cmakefiles
82 #BuildRequires: openqube-devel
83 BuildRequires:  perl-base
84 BuildRequires:  postgresql-devel
85 BuildRequires:  proj-devel >= 6.0
86 BuildRequires:  pugixml-devel
87 BuildRequires:  python3-devel
88 BuildRequires:  python3-sip-devel
89 BuildRequires:  qt5-build >= 4.5.0
90 BuildRequires:  qt5-qmake >= 4.5.0
91 BuildRequires:  rpmbuild(macros) >= 1.605
92 BuildRequires:  sip
93 BuildRequires:  sip-PyQt5
94 BuildRequires:  sqlite3-devel
95 BuildRequires:  tcl-devel
96 BuildRequires:  tk-devel
97 BuildRequires:  unixODBC-devel
98 BuildRequires:  wget
99 BuildRequires:  xorg-lib-libICE-devel
100 BuildRequires:  xorg-lib-libSM-devel
101 BuildRequires:  xorg-lib-libX11-devel
102 BuildRequires:  xorg-lib-libXScrnSaver-devel
103 BuildRequires:  xorg-lib-libXext-devel
104 BuildRequires:  xorg-lib-libXft-devel
105 BuildRequires:  xorg-lib-libXt-devel
106 BuildRequires:  xz-devel
107 BuildRequires:  zlib-devel
108 BuildConflicts: libXNVCtrl-devel
109 Obsoletes:      vtk-tcl < 8.2.0-1
110 Obsoletes:      vtk-tcl-devel < 8.2.0-1
111 %{?with_system_gl2ps:Requires:  gl2ps >= 1.3.8}
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         skip_post_check_so      lib.*Python.*\.so.*
115
116 %description
117 The Visualization ToolKit (VTK) is an object oriented software system
118 for 3D computer graphics, image processing, and visualization. VTK
119 includes a textbook, a C++ class library, and several interpreted
120 interface layers including Java, and Python. VTK supports a
121 wide variety of visualization algorithms including scalar, vector,
122 tensor, texture, and volumetric methods. It also supports advanced
123 modeling techniques like implicit modeling, polygon reduction, mesh
124 smoothing, cutting, contouring, and Delaunay triangulation. Moreover,
125 dozens of imaging algorithms have been integrated into the system.
126 This allows mixing 2D imaging / 3D graphics algorithms and data.
127
128 %description -l pl.UTF-8
129 Visualization TookKit (VTK) to obiektowo zorientowany system
130 oprogramowania do trójwymiarowej grafiki komputerowej, przetwarzania
131 obrazu i wizualizacji. VTK zawiera książkę, bibliotekę klas C++ oraz
132 kilka interpretowanych warstw interfejsów, w tym dla Javy i
133 Pythona. VTK obsługuje szeroki zakres algorytmów wizualizacji, w tym
134 metody skalarne, wektorowe, tensorowe, teksturowe i wolumetryczne.
135 Obsługuje także zaawansowane techniki modelowania, takie jak
136 modelowanie implicite, redukcja wielokątów, wygładzanie siatki,
137 przycinanie, konturowanie i triangulacja Delaunaya. Co więcej, wiele
138 algorytmów obrazowania zostało zintegrowanych z systemem. Pozwala to
139 na mieszanie algorytmów obrazowania 2D i grafiki 3D.
140
141 %package devel
142 Summary:        VTK header files for building C++ code
143 Summary(pl.UTF-8):      Pliki nagłówkowe VTK dla C++
144 Group:          Development
145 Requires:       %{name} = %{version}-%{release}
146 Requires:       libstdc++-devel
147
148 %description devel
149 This provides the VTK header files required to compile C++ programs
150 that use VTK to do 3D visualisation.
151
152 %description devel -l pl.UTF-8
153 Ten pakiet dostarcza pliki nagłówkowe VTK do kompilowania programów
154 C++ używających VTK do wizualizacji 3D.
155
156 %package qt
157 Summary:        Qt5 bindings and Qt5 Designer plugin for VTK
158 Summary(pl.UTF-8):      Wiązania Qt5 oraz wtyczka Qt5 Designera do VTK
159 Group:          X11/Libraries
160 Requires:       %{name} = %{version}-%{release}
161 Requires:       Qt5Core >= 4.5.0
162 Requires:       Qt5Gui >= 4.5.0
163 Requires:       Qt5Network >= 4.5.0
164 Requires:       Qt5OpenGL >= 4.5.0
165 Requires:       Qt5Sql >= 4.5.0
166 Requires:       Qt5WebKit >= 4.5.0
167
168 %description qt
169 Qt5 bindings and Qt5 Designer plugin for VTK.
170
171 %description qt -l pl.UTF-8
172 Wiązania Qt5 oraz wtyczka Qt5 Designera do VTK.
173
174 %package qt-devel
175 Summary:        Header files for VTK Qt5 bindings
176 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Qt5` do VTK
177 Group:          X11/Development/Libraries
178 Requires:       %{name}-devel = %{version}-%{release}
179 Requires:       %{name}-qt = %{version}-%{release}
180 Requires:       Qt5Core-devel >= 4.5.0
181 Requires:       Qt5Gui-devel >= 4.5.0
182 Requires:       Qt5OpenGL-devel >= 4.5.0
183 Requires:       Qt5Sql-devel >= 4.5.0
184
185 %description qt-devel
186 Header files for VTK Qt bindings.
187
188 %description qt-devel -l pl.UTF-8
189 Pliki nagłówkowe wiązań Qt do VTK.
190
191 %package java
192 Summary:        Java bindings for VTK
193 Summary(pl.UTF-8):      Wiązania Javy do VTK
194 Group:          Development/Languages/Java
195 Requires:       %{name} = %{version}-%{release}
196 # or separate qt parts?
197 Requires:       %{name}-qt = %{version}-%{release}
198
199 %description java
200 This package contains Java bindings for VTK.
201
202 %description java -l pl.UTF-8
203 Ten pakiet zawiera wiązania Javy do VTK.
204
205 %package java-devel
206 Summary:        Header files for Java VTK binding
207 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Javy do VTK
208 Group:          Development/Libraries
209 Requires:       %{name}-devel = %{version}-%{release}
210 Requires:       %{name}-java = %{version}-%{release}
211 # <jni.h>
212 Requires:       jdk
213
214 %description java-devel
215 Header files for Java VTK binding.
216
217 %description java-devel -l pl.UTF-8
218 Pliki nagłówkowe wiązania Javy do VTK.
219
220 %package python3
221 Summary:        Python 3 bindings for VTK
222 Summary(pl.UTF-8):      Wiązania Pythona 3 do VTK
223 Group:          Libraries
224 Requires:       %{name} = %{version}-%{release}
225 # or separate qt parts again?
226 Requires:       %{name}-qt = %{version}-%{release}
227 Obsoletes:      vtk-python-qt < 6.0.0-1
228 Obsoletes:      vtk-python-sip < 6.0.0-1
229 Obsoletes:      vtk-python < 8.2.0-1
230
231 %description python3
232 This package contains Python 3 bindings for VTK.
233
234 %description python3 -l pl.UTF-8
235 Ten pakiet zawiera wiązania Pythona 3 do VTK.
236
237 %package python3-devel
238 Summary:        Header files for Python 3 VTK binding
239 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Pythona 3 do VTK
240 Group:          Development/Libraries
241 Requires:       %{name}-devel = %{version}-%{release}
242 Requires:       %{name}-python3 = %{version}-%{release}
243 Requires:       python3-devel
244 Obsoletes:      vtk-python-devel < 8.2.0-1
245
246 %description python3-devel
247 Header files for Python 3 VTK binding.
248
249 %description python3-devel -l pl.UTF-8
250 Pliki nagłówkowe wiązania Pythona 3 do VTK.
251
252 %package examples
253 Summary:        C++ and Python example programs/scripts for VTK
254 Summary(pl.UTF-8):      Przykładowe programy/skrypty w C++ i Pythonie dla VTK
255 Group:          Development/Libraries
256 Requires:       %{name} = %{version}-%{release}
257 Requires:       %{name}-data = %{version}-%{release}
258
259 %description examples
260 This package contains all the examples from the VTK source. To compile
261 the C++ examples you will need to install the vtk-devel package as
262 well. The Python examples can be run with the corresponding
263 packages (vtk-python3).
264
265 %description examples -l pl.UTF-8
266 Ten pakiet zawiera wszystkie przykłady ze źródeł VTK. Do skompilowania
267 przykładów w C++ trzeba doinstalować pakiet vtk-devel. Przykłady w
268 Pythonie można uruchamiać przy użyciu odpowiednich pakietów
269 (vtk-python3).
270
271 %package test-suite
272 Summary:        Test programs for VTK
273 Summary(pl.UTF-8):      Programy testowe dla VTK
274 Group:          Development/Libraries
275 Requires:       %{name} = %{version}-%{release}
276 Requires:       %{name}-data = %{version}-%{release}
277
278 %description test-suite
279 This package contains all testing programs from the VTK source. The
280 source code of these programs can be found in the vtk-examples
281 package.
282
283 %description test-suite -l pl.UTF-8
284 Ten pakiet zawiera wszystkie programy testowe ze źródeł VTK. Kod
285 źródłowy tych programów można znaleźć w pakiecie vtk-examples.
286
287 %package data
288 Summary:        Data files for VTK
289 Summary(pl.UTF-8):      Pliki danych dla VTK
290 Group:          Development/Libraries
291 %if "%{_rpmversion}" >= "5"
292 BuildArch:      noarch
293 %endif
294
295 %description data
296 This package contains all the data from the VTKData repository. These
297 data are required to run various examples from the vtk-examples
298 package.
299
300 %description data -l pl.UTF-8
301 Ten pakiet zawiera wszystkie dane z repozytorium VTKData. Dane te są
302 potrzebne do uruchamiania różnych przykładów z pakietu vtk-examples.
303
304 %prep
305 %setup -q -n VTK-%{version} -b 1
306 %patch0 -p1
307 %patch1 -p1
308 %patch2 -p1
309 %patch3 -p1
310 %patch4 -p1
311 %patch5 -p1
312
313 # Replace relative path ../../../VTKData with destination filesystem path
314 grep -Erl '(\.\./)+VTKData' Examples | xargs \
315   perl -pi -e 's,(\.\./)+VTKData,%{_datadir}/vtk-8.1,g'
316
317 # Save an unbuilt copy of the Example's sources for %doc
318 mkdir vtk-examples
319 cp -a Examples vtk-examples
320 # Don't ship Win32 examples
321 %{__rm} -r vtk-examples/Examples/GUI/Win32
322 find vtk-examples -type f | xargs chmod -R a-x
323
324 %build
325 export CFLAGS="%{rpmcflags} -D_UNICODE -DHAVE_UINTPTR_T"
326 export CXXFLAGS="%{rpmcxxflags} -D_UNICODE -DHAVE_UINTPTR_T"
327 %if %{with java}
328 export JAVA_HOME=%{java_home}
329 %ifarch x32
330 # getting "java.lang.OutOfMemoryError: Java heap space" during the build
331 export JAVA_TOOL_OPTIONS=-Xmx2048m
332 %endif
333 %endif
334
335 # handle cmake & ccache
336 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmake
337 # ASM fix: http://lists.busybox.net/pipermail/buildroot/2013-March/069436.html
338 if [[ "%{__cc}" = *ccache* ]]; then
339         cc="%{__cc}"
340         cxx="%{__cxx}"
341         ccache="
342         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
343         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
344         -DCMAKE_ASM_COMPILER="${cc#ccache }" \
345         "
346 else
347         ccache="
348         -DCMAKE_C_COMPILER="%{__cc}" \
349         -DCMAKE_CXX_COMPILER="%{__cxx}" \
350         -DCMAKE_ASM_COMPILER="%{__cc}" \
351         "
352 fi
353
354 mkdir -p build
355 cd build
356 %cmake .. \
357         $ccache \
358         -Wno-dev \
359         %{cmake_on_off doc DBUILD_DOCUMENTATION} \
360         -DBUILD_EXAMPLES:BOOL=ON \
361         -DBUILD_SHARED_LIBS:BOOL=ON \
362         -DBUILD_TESTING:BOOL=ON \
363         -DCMAKE_SKIP_RPATH:BOOL=ON \
364         -DOPENGL_INCLUDE_PATH:PATH=%{_includedir}/GL \
365         -DPYTHON_INCLUDE_PATH:PATH=%{py3_incdir} \
366         -DPYTHON_LIBRARY:FILEPATH=%{_libdir}/libpython%{py3_ver}.so \
367         -DPYTHON_UTIL_LIBRARY:PATH=%{_libdir}/libutil.so \
368         -DTCL_INCLUDE_PATH:PATH=%{_includedir} \
369         -DTCL_LIBRARY:PATH=%{_libdir}/libtcl.so \
370         -DTK_INCLUDE_PATH:PATH=%{_includedir} \
371         -DTK_LIBRARY:PATH=%{_libdir}/libtk.so \
372         -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
373         -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/vtk \
374         -DVTK_INSTALL_INCLUDE_DIR:PATH=include/vtk \
375         -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/vtk \
376         -DVTK_INSTALL_PACKAGE_DIR:PATH=%{_lib}/cmake/vtk \
377         -DVTK_INSTALL_TCL_DIR:PATH=share/tcl%{tcl_version}/vtk \
378         -DVTK_INSTALL_QT_DIR=/%{_lib}/qt5/plugins/designer \
379         -DVTK_INSTALL_PYTHON_MODULES_DIR:PATH=%{py3_sitedir} \
380         -DVTK_FFMPEG_HAS_OLD_HEADER:BOOL=OFF \
381         %{?with_OSMesa:-DVTK_OPENGL_HAS_OSMESA:BOOL=ON} \
382         -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
383         -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
384         -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
385         -DVTK_USE_SYSTEM_XDMF2:BOOL=OFF \
386         -DVTK_USE_SYSTEM_LIBHARU:BOOL=OFF \
387         %{!?with_system_gl2ps:-DVTK_USE_SYSTEM_GL2PS:BOOL=OFF} \
388 %if %{with java}
389         -DVTK_WRAP_JAVA:BOOL=ON \
390         -DJAVA_INCLUDE_PATH:PATH=$JAVA_HOME/include \
391         -DJAVA_INCLUDE_PATH2:PATH=$JAVA_HOME/include/linux \
392         -DJAVA_AWT_INCLUDE_PATH:PATH=$JAVA_HOME/include \
393 %else
394         -DVTK_WRAP_JAVA:BOOL=OFF \
395 %endif
396         -DVTK_WRAP_PYTHON:BOOL=ON \
397         -DVTK_PYTHON_VERSION=3 \
398         %{?with_sip:-DVTK_WRAP_PYTHON_SIP:BOOL=ON} \
399         -DVTK_Group_Imaging:BOOL=ON \
400         -DVTK_Group_Qt:BOOL=ON \
401         -DVTK_Group_Rendering:BOOL=ON \
402         -DVTK_Group_StandAlone:BOOL=ON \
403         -DVTK_Group_Tk:BOOL=ON \
404         -DVTK_Group_Views:BOOL=ON \
405         -DModule_vtkFiltersReebGraph:BOOL=ON \
406         %{?with_ffmpeg:-DModule_vtkIOFFMPEG:BOOL=ON} \
407         -DModule_vtkIOGDAL:BOOL=ON \
408         -DModule_vtkIOGeoJSON:BOOL=ON \
409         -DModule_vtkIOMySQL:BOOL=ON \
410         -DModule_vtkIOODBC:BOOL=ON \
411         -DModule_vtkIOParallelExodus:BOOL=ON \
412         -DModule_vtkIOParallelLSDyna:BOOL=ON \
413         -DModule_vtkIOPostgreSQL:BOOL=ON \
414         -DModule_vtkIOVPIC:BOOL=ON \
415         -DModule_vtkIOXdmf2:BOOL=ON \
416         -DModule_vtkInfovisBoost:BOOL=ON \
417         -DModule_vtkInfovisBoostGraphAlgorithms:BOOL=ON \
418         -DModule_vtkRenderingFreeTypeFontConfig:BOOL=ON \
419         -DModule_vtkRenderingMatplotlib:BOOL=ON \
420         -DModule_vtkRenderingParallel:BOOL=ON
421 # TODO: -DModule_vtkAcceleratorsDax:BOOL=ON (BR: FindDax.cmake, maybe http://www.daxtoolkit.org/ ?)
422 # TODO: -DModule_vtkAcceleratorsPiston:BOOL=ON (on bcond, BR: CUDA)
423 # TODO: -DModule_vtkFiltersParallelFlowPaths:BOOL=ON (BR: MPI)
424 # TODO: -DModule_vtkFiltersParallelStatistics:BOOL=ON (BR: MPI)
425 # TODO: -DModule_vtkInfovisParallel:BOOL=ON (BR: MPI)
426 # TODO: -DModule_vtkRenderingParallelLIC:BOOL=ON (BR: MPI)
427
428 %{__make}
429 %{?with_doc:%{__make} DoxygenDoc}
430
431 %install
432 rm -rf $RPM_BUILD_ROOT
433 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ld.so.conf.d,%{_examplesdir}/%{name}-%{version}}
434
435 %{__make} -C build install \
436         DESTDIR=$RPM_BUILD_ROOT
437
438 # ld config
439 echo %{_libdir}/vtk > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
440
441 for f in $(cd build/ExternalData/Testing ; find Data -type l); do
442         install -Dp build/ExternalData/Testing/$f $RPM_BUILD_ROOT%{_datadir}/vtk-8.1/$f
443 done
444
445 # Install examples
446 for f in \
447 AmbientSpheres \
448 Arrays \
449 BalloonWidget \
450 BandedContours \
451 Cone \
452 Cone2 \
453 Cone3 \
454 Cone4 \
455 Cone5 \
456 Cone6 \
457 Cube \
458 Cylinder \
459 Delaunay3D \
460 Delaunay3DAlpha \
461 DiffuseSpheres \
462 DumpXMLFile \
463 FilledContours \
464 FixedPointVolumeRayCastMapperCT \
465 GPURenderDemo \
466 Generate2DAMRDataSetWithPulse \
467 Generate3DAMRDataSetWithPulse \
468 GenerateCubesFromLabels \
469 GenerateModelsFromLabels \
470 HierarchicalBoxPipeline \
471 ImageSlicing \
472 LabeledMesh \
473 Medical1 \
474 Medical2 \
475 Medical3 \
476 Medical4 \
477 MultiBlock \
478 ParticleReader \
479 RGrid \
480 SGrid \
481 SimpleView \
482 Slider \
483 Slider2D \
484 SpecularSpheres \
485 TubesWithVaryingRadiusAndColors \
486 finance ; do
487         install build/bin/$f $RPM_BUILD_ROOT%{_bindir}
488 done
489
490 # Install test binaries
491 for f in build/bin/*Tests build/bin/Test*; do
492         install $f $RPM_BUILD_ROOT%{_bindir}
493 done
494
495 %if %{with java}
496 install -p build/bin/VTKJavaExecutable $RPM_BUILD_ROOT%{_bindir}
497 %endif
498 install -p build/bin/vtkpython $RPM_BUILD_ROOT%{_bindir}
499
500 # unwanted doxygen files and misplaced verdict docs
501 %{?with_doc:%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/vtk-*/{doxygen,verdict}}
502
503 %clean
504 rm -rf $RPM_BUILD_ROOT
505
506 %post   -p /sbin/ldconfig
507 %postun -p /sbin/ldconfig
508
509 %post   qt -p /sbin/ldconfig
510 %postun qt -p /sbin/ldconfig
511
512 %post   java -p /sbin/ldconfig
513 %postun java -p /sbin/ldconfig
514
515 %post   python3 -p /sbin/ldconfig
516 %postun python3 -p /sbin/ldconfig
517
518 %files
519 %defattr(644,root,root,755)
520 %doc README.md vtkBanner.gif vtkLogo.ico Wrapping/Tools/README*
521 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
522 %dir %{_libdir}/vtk
523 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so.1
524 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so.1
525 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so.1
526 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2.so.1
527 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so.1
528 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so.1
529 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so.1
530 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so.1
531 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so.1
532 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so.1
533 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so.1
534 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so.1
535 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so.1
536 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so.1
537 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so.1
538 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL2.so.1
539 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so.1
540 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so.1
541 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so.1
542 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PSOpenGL2.so.1
543 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so.1
544 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so.1
545 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so.1
546 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL2.so.1
547 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so.1
548 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL2.so.1
549 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so.1
550 %attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so.1
551 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so.1
552 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so.1
553 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so.1
554 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so.1
555 %attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so.1
556 %attr(755,root,root) %{_libdir}/vtk/libvtkgl2ps.so.1
557 %attr(755,root,root) %{_libdir}/vtk/libvtklibharu.so.1
558 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so.1
559 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so.1
560 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so.1
561 %attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so.1
562 %if %{with java}
563 %exclude %{_libdir}/vtk/libvtk*Java.so.1
564 %endif
565 %exclude %{_libdir}/vtk/libvtk*Python3?D.so.1
566 %exclude %{_libdir}/vtk/libvtkWrappingPython3?Core.so.1
567
568 %files devel
569 %defattr(644,root,root,755)
570 %doc Utilities/Upgrading/*
571 %attr(755,root,root) %{_bindir}/vtkWrapHierarchy
572 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so
573 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so
574 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so
575 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2.so
576 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so
577 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so
578 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so
579 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so
580 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so
581 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so
582 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so
583 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so
584 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so
585 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so
586 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so
587 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL2.so
588 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so
589 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so
590 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so
591 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PSOpenGL2.so
592 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so
593 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so
594 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so
595 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL2.so
596 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so
597 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL2.so
598 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so
599 %attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so
600 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so
601 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so
602 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so
603 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so
604 %attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so
605 %attr(755,root,root) %{_libdir}/vtk/libvtkgl2ps.so
606 %attr(755,root,root) %{_libdir}/vtk/libvtklibharu.so
607 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so
608 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so
609 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so
610 %attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so
611 %if %{with java}
612 %exclude %{_libdir}/vtk/libvtk*Java.so
613 %endif
614 %exclude %{_libdir}/vtk/libvtk*Python3?D.so
615 %exclude %{_libdir}/vtk/libvtkWrappingPython3?Core.so
616 %{_libdir}/vtk/libvtkWrappingTools.a
617 %dir %{_includedir}/vtk
618 %{_includedir}/vtk/VPIC
619 %{_includedir}/vtk/DICOM*.h
620 %{_includedir}/vtk/DatabaseSchemaWith2Tables.h
621 %{_includedir}/vtk/vtkgl2ps
622 %{_includedir}/vtk/vtkkwiml
623 %{_includedir}/vtk/vtklibharu
624 %{_includedir}/vtk/vtkmetaio
625 %{_includedir}/vtk/vtksys
626 %{_includedir}/vtk/vtkverdict
627 %{_includedir}/vtk/vtkxdmf2
628 %{_includedir}/vtk/vtk*.h
629 %{_includedir}/vtk/vtk*.txx
630 %exclude %{_includedir}/vtk/vtkEventQtSlotConnect.h
631 %exclude %{_includedir}/vtk/vtkGUISupportQt*.h
632 %if %{with java}
633 %exclude %{_includedir}/vtk/vtkJavaUtil.h
634 %exclude %{_includedir}/vtk/vtkWrappingJavaModule.h
635 %endif
636 %exclude %{_includedir}/vtk/vtkPython*.h
637 %exclude %{_includedir}/vtk/vtkQImageToImageSource.h
638 %exclude %{_includedir}/vtk/vtkQt*.h
639 %exclude %{_includedir}/vtk/vtkRenderingQtModule.h
640 %exclude %{_includedir}/vtk/vtkTk*.h
641 %exclude %{_includedir}/vtk/vtkViewsQtModule.h
642 %{_libdir}/cmake/vtk
643
644 %files qt
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so.1
647 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so.1
648 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so.1
649 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so.1
650 %attr(755,root,root) %{_libdir}/qt5/plugins/designer/libQVTKWidgetPlugin.so
651
652 %files qt-devel
653 %defattr(644,root,root,755)
654 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so
655 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so
656 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so
657 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so
658 %{_includedir}/vtk/QFilterTreeProxyModel.h
659 %{_includedir}/vtk/QVTK*.h
660 %{_includedir}/vtk/vtkEventQtSlotConnect.h
661 %{_includedir}/vtk/vtkGUISupportQt*.h
662 %{_includedir}/vtk/vtkQImageToImageSource.h
663 %{_includedir}/vtk/vtkQt*.h
664 %{_includedir}/vtk/vtkRenderingQtModule.h
665 %{_includedir}/vtk/vtkViewsQtModule.h
666
667 %if %{with java}
668 %files java
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_bindir}/VTKJavaExecutable
671 %attr(755,root,root) %{_bindir}/vtkParseJava
672 %attr(755,root,root) %{_bindir}/vtkWrapJava
673 # common library
674 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so.1
675 # java modules
676 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCoreJava.so
677 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*Java.so
678 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryJava.so
679 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2Java.so
680 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*Java.so
681 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCoreJava.so
682 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*Java.so
683 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*Java.so
684 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*Java.so
685 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*Java.so
686 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExampleJava.so
687 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCoreJava.so
688 %attr(755,root,root) %{_libdir}/vtk/libvtkRendering*Java.so
689 %attr(755,root,root) %{_libdir}/vtk/libvtkTestingRenderingJava.so
690 %attr(755,root,root) %{_libdir}/vtk/libvtkViews*Java.so
691 %{_libdir}/vtk/vtk.jar
692
693 %files java-devel
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so
696 %{_includedir}/vtk/vtkJavaUtil.h
697 %{_includedir}/vtk/vtkWrappingJavaModule.h
698 %endif
699
700 %files python3
701 %defattr(644,root,root,755)
702 %doc Wrapping/Python/README*
703 %attr(755,root,root) %{_bindir}/vtkWrapPython
704 %attr(755,root,root) %{_bindir}/vtkWrapPythonInit
705 %attr(755,root,root) %{_bindir}/vtkpython
706 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python3?D.so.1
707 %attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so.1
708 # RenderingMatplotlib requires PythonInterpreter
709 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so.1
710 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingPythonTkWidgets-8.2.so
711 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython3?Core.so.1
712 %dir %{py3_sitedir}/vtk.py
713 %dir %{py3_sitedir}/__pycache__/*
714 %dir %{py3_sitedir}/vtkmodules
715 %{py3_sitedir}/vtkmodules/*.py
716 %{py3_sitedir}/vtkmodules/__pycache__
717 %dir %{py3_sitedir}/vtkmodules/gtk
718 %{py3_sitedir}/vtkmodules/gtk/*.py
719 %{py3_sitedir}/vtkmodules/gtk/__pycache__
720 %dir %{py3_sitedir}/vtkmodules/numpy_interface
721 %{py3_sitedir}/vtkmodules/numpy_interface/*.py
722 %{py3_sitedir}/vtkmodules/numpy_interface/__pycache__
723 %dir %{py3_sitedir}/vtkmodules/qt
724 %{py3_sitedir}/vtkmodules/qt/*.py
725 %{py3_sitedir}/vtkmodules/qt/__pycache__
726 %dir %{py3_sitedir}/vtkmodules/qt4
727 %{py3_sitedir}/vtkmodules/qt4/*.py
728 %{py3_sitedir}/vtkmodules/qt4/__pycache__
729 %dir %{py3_sitedir}/vtkmodules/test
730 %{py3_sitedir}/vtkmodules/test/*.py
731 %{py3_sitedir}/vtkmodules/test/__pycache__
732 %dir %{py3_sitedir}/vtkmodules/tk
733 %{py3_sitedir}/vtkmodules/tk/__pycache__
734 %{py3_sitedir}/vtkmodules/tk/*.py
735 %dir %{py3_sitedir}/vtkmodules/util
736 %{py3_sitedir}/vtkmodules/util/*.py
737 %{py3_sitedir}/vtkmodules/util/__pycache__
738 %dir %{py3_sitedir}/vtkmodules/wx
739 %{py3_sitedir}/vtkmodules/wx/*.py
740 %{py3_sitedir}/vtkmodules/wx/__pycache__
741 %attr(755,root,root) %{py3_sitedir}/vtkmodules/vtk*Python.so
742
743 %files python3-devel
744 %defattr(644,root,root,755)
745 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python3?D.so
746 %attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so
747 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so
748 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython3?Core.so
749 %{_includedir}/vtk/PyVTK*.h
750 %{_includedir}/vtk/vtkPython*.h
751
752 %files test-suite
753 %defattr(644,root,root,755)
754 %attr(755,root,root) %{_bindir}/*Tests
755 %attr(755,root,root) %{_bindir}/Test*
756
757 %files examples
758 %defattr(644,root,root,755)
759 %attr(755,root,root) %{_bindir}/AmbientSpheres
760 %attr(755,root,root) %{_bindir}/Arrays
761 %attr(755,root,root) %{_bindir}/Cone
762 %attr(755,root,root) %{_bindir}/Cone2
763 %attr(755,root,root) %{_bindir}/Cone3
764 %attr(755,root,root) %{_bindir}/Cone4
765 %attr(755,root,root) %{_bindir}/Cone5
766 %attr(755,root,root) %{_bindir}/Cone6
767 %attr(755,root,root) %{_bindir}/Cube
768 %attr(755,root,root) %{_bindir}/Cylinder
769 %attr(755,root,root) %{_bindir}/DiffuseSpheres
770 %attr(755,root,root) %{_bindir}/HierarchicalBoxPipeline
771 %attr(755,root,root) %{_bindir}/Medical1
772 %attr(755,root,root) %{_bindir}/Medical2
773 %attr(755,root,root) %{_bindir}/Medical3
774 %attr(755,root,root) %{_bindir}/Medical4
775 %attr(755,root,root) %{_bindir}/MultiBlock
776 %attr(755,root,root) %{_bindir}/RGrid
777 %attr(755,root,root) %{_bindir}/SGrid
778 %attr(755,root,root) %{_bindir}/SimpleView
779 %attr(755,root,root) %{_bindir}/SpecularSpheres
780 %attr(755,root,root) %{_bindir}/finance
781 %attr(755,root,root) %{_bindir}/BalloonWidget
782 %attr(755,root,root) %{_bindir}/BandedContours
783 %attr(755,root,root) %{_bindir}/Delaunay3D
784 %attr(755,root,root) %{_bindir}/Delaunay3DAlpha
785 %attr(755,root,root) %{_bindir}/DumpXMLFile
786 %attr(755,root,root) %{_bindir}/FilledContours
787 %attr(755,root,root) %{_bindir}/FixedPointVolumeRayCastMapperCT
788 %attr(755,root,root) %{_bindir}/GPURenderDemo
789 %attr(755,root,root) %{_bindir}/Generate2DAMRDataSetWithPulse
790 %attr(755,root,root) %{_bindir}/Generate3DAMRDataSetWithPulse
791 %attr(755,root,root) %{_bindir}/GenerateCubesFromLabels
792 %attr(755,root,root) %{_bindir}/GenerateModelsFromLabels
793 %attr(755,root,root) %{_bindir}/ImageSlicing
794 %attr(755,root,root) %{_bindir}/LabeledMesh
795 %attr(755,root,root) %{_bindir}/ParticleReader
796 %attr(755,root,root) %{_bindir}/Slider
797 %attr(755,root,root) %{_bindir}/Slider2D
798 %attr(755,root,root) %{_bindir}/TubesWithVaryingRadiusAndColors
799 %{_examplesdir}/%{name}-%{version}
800
801 %files data
802 %defattr(644,root,root,755)
803 %dir %{_datadir}/vtk-8.1
804 %{_datadir}/vtk-8.1/Data
This page took 0.153287 seconds and 3 git commands to generate.