]> git.pld-linux.org Git - packages/vtk.git/blob - vtk.spec
4195ebd921692222161593c735d3f38b1ca22bce
[packages/vtk.git] / vtk.spec
1 # TODO:
2 # - handle VTK_USE_MPEG2_ENCODER (see CMakeLists.txt)
3 # - handle MPI and VTK_USE_PARALLEL_BGL (Parallel Boost Graph Library, BR: boost >= 1.40)
4 # - more system libraries? (check for VTK_THIRD_PARTY_SUBDIR in Utilities/CMakeLists.txt)
5 # - CUDA for Accelerators/Piston (on bcond)
6 # - NVCtrlLib for Rendering/OpenGL (on bcond)
7 # - VTK_USE_SYSTEM_XDMF2=ON ? (but our xdmf-devel seems not compatible)
8 # - python bcond?
9 #
10 # Conditional build
11 %bcond_without  java            # Java wrappers
12 %bcond_without  ffmpeg          # FFMPEG .avi saving support
13 %bcond_with     doc             # do not build and package doxygen documentation
14 %bcond_with     OSMesa          # build with OSMesa (https://bugzilla.redhat.com/show_bug.cgi?id=744434)
15 %bcond_with     system_gl2ps    # use system gl2ps (VTK currently is carrying local modifications to gl2ps)
16
17 Summary:        Toolkit for 3D computer graphics, image processing, and visualization
18 Summary(pl.UTF-8):      Zestaw narzędzi do trójwymiarowej grafiki, przetwarzania obrazu i wizualizacji
19 Name:           vtk
20 Version:        8.2.0
21 Release:        0.1
22 License:        BSD
23 Group:          Libraries
24 Source0:        http://www.vtk.org/files/release/8.2/VTK-%{version}.tar.gz
25 # Source0-md5:  8af3307da0fc2ef8cafe4a312b821111
26 Source1:        http://www.vtk.org/files/release/8.2/VTKData-%{version}.tar.gz
27 # Source1-md5:  a6eab7bc02cee1376ee69243dde373ce
28 Patch0:         vtk-abi.patch
29 Patch1:         gcc10.patch
30 Patch2:         proj6_compat.patch
31 Patch3:         qt-5.15.patch
32 Patch4:         python-3.8.patch
33 Patch5:         link.patch
34 URL:            http://www.vtk.org/
35 %{?with_OSMesa:BuildRequires: Mesa-libOSMesa-devel}
36 BuildRequires:  OpenGL-GLX-devel
37 BuildRequires:  OpenGL-devel
38 BuildRequires:  Qt5Core-devel
39 BuildRequires:  Qt5Designer-devel
40 BuildRequires:  Qt5Gui-devel
41 BuildRequires:  Qt5Network-devel
42 BuildRequires:  Qt5OpenGL-devel
43 BuildRequires:  Qt5Sql-devel
44 BuildRequires:  Qt5WebKit-devel
45 BuildRequires:  Qt5X11Extras-devel
46 BuildRequires:  Qt5XmlPatterns-devel
47 BuildRequires:  Qt5UiTools-devel
48 BuildRequires:  R
49 BuildRequires:  boost-devel >= 1.39
50 BuildRequires:  cmake >= 3.3
51 BuildRequires:  double-conversion-devel
52 %{?with_doc:BuildRequires:      doxygen}
53 BuildRequires:  eigen3 >= 2.91.0
54 BuildRequires:  expat-devel
55 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
56 BuildRequires:  fontconfig-devel
57 BuildRequires:  freetype-devel >= 2
58 BuildRequires:  gdal-devel
59 %{?with_system_gl2ps:BuildRequires:     gl2ps-devel >= 1.3.8}
60 BuildRequires:  glew-devel
61 BuildRequires:  gnuplot
62 BuildRequires:  graphviz
63 BuildRequires:  hdf5-devel
64 %if %{with java}
65 BuildRequires:  jdk >= 1.5
66 BuildRequires:  jpackage-utils
67 %endif
68 BuildRequires:  jsoncpp-devel >= 0.7.0
69 BuildRequires:  libharu-devel
70 BuildRequires:  libjpeg-devel
71 BuildRequires:  libogg-devel
72 BuildRequires:  libpng-devel
73 BuildRequires:  libstdc++-devel
74 BuildRequires:  libtheora-devel
75 BuildRequires:  libtiff-devel
76 BuildRequires:  libxml2-devel >= 2
77 BuildRequires:  lz4-devel
78 BuildRequires:  motif-devel
79 BuildRequires:  mysql-devel
80 BuildRequires:  netcdf-cxx-devel >= 4
81 # some code using it exists (Domains/Chemistry), but is not included in cmakefiles
82 #BuildRequires: openqube-devel
83 BuildRequires:  perl-base
84 BuildRequires:  postgresql-devel
85 BuildRequires:  proj-devel >= 6.0
86 BuildRequires:  pugixml-devel
87 BuildRequires:  python3-devel
88 BuildRequires:  python3-sip-devel
89 BuildRequires:  qt5-build >= 4.5.0
90 BuildRequires:  qt5-qmake >= 4.5.0
91 BuildRequires:  rpmbuild(macros) >= 1.605
92 BuildRequires:  sip
93 BuildRequires:  sip-PyQt5
94 BuildRequires:  sqlite3-devel
95 BuildRequires:  tcl-devel
96 BuildRequires:  tk-devel
97 BuildRequires:  unixODBC-devel
98 BuildRequires:  wget
99 BuildRequires:  xorg-lib-libICE-devel
100 BuildRequires:  xorg-lib-libSM-devel
101 BuildRequires:  xorg-lib-libX11-devel
102 BuildRequires:  xorg-lib-libXScrnSaver-devel
103 BuildRequires:  xorg-lib-libXext-devel
104 BuildRequires:  xorg-lib-libXft-devel
105 BuildRequires:  xorg-lib-libXt-devel
106 BuildRequires:  xz-devel
107 BuildRequires:  zlib-devel
108 BuildConflicts: libXNVCtrl-devel
109 Obsoletes:      vtk-tcl < 8.2.0-1
110 Obsoletes:      vtk-tcl-devel < 8.2.0-1
111 %{?with_system_gl2ps:Requires:  gl2ps >= 1.3.8}
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         skip_post_check_so      lib.*Python.*\.so.*
115
116 %description
117 The Visualization ToolKit (VTK) is an object oriented software system
118 for 3D computer graphics, image processing, and visualization. VTK
119 includes a textbook, a C++ class library, and several interpreted
120 interface layers including Java, and Python. VTK supports a
121 wide variety of visualization algorithms including scalar, vector,
122 tensor, texture, and volumetric methods. It also supports advanced
123 modeling techniques like implicit modeling, polygon reduction, mesh
124 smoothing, cutting, contouring, and Delaunay triangulation. Moreover,
125 dozens of imaging algorithms have been integrated into the system.
126 This allows mixing 2D imaging / 3D graphics algorithms and data.
127
128 %description -l pl.UTF-8
129 Visualization TookKit (VTK) to obiektowo zorientowany system
130 oprogramowania do trójwymiarowej grafiki komputerowej, przetwarzania
131 obrazu i wizualizacji. VTK zawiera książkę, bibliotekę klas C++ oraz
132 kilka interpretowanych warstw interfejsów, w tym dla Javy i
133 Pythona. VTK obsługuje szeroki zakres algorytmów wizualizacji, w tym
134 metody skalarne, wektorowe, tensorowe, teksturowe i wolumetryczne.
135 Obsługuje także zaawansowane techniki modelowania, takie jak
136 modelowanie implicite, redukcja wielokątów, wygładzanie siatki,
137 przycinanie, konturowanie i triangulacja Delaunaya. Co więcej, wiele
138 algorytmów obrazowania zostało zintegrowanych z systemem. Pozwala to
139 na mieszanie algorytmów obrazowania 2D i grafiki 3D.
140
141 %package devel
142 Summary:        VTK header files for building C++ code
143 Summary(pl.UTF-8):      Pliki nagłówkowe VTK dla C++
144 Group:          Development
145 Requires:       %{name} = %{version}-%{release}
146 Requires:       libstdc++-devel
147
148 %description devel
149 This provides the VTK header files required to compile C++ programs
150 that use VTK to do 3D visualisation.
151
152 %description devel -l pl.UTF-8
153 Ten pakiet dostarcza pliki nagłówkowe VTK do kompilowania programów
154 C++ używających VTK do wizualizacji 3D.
155
156 %package qt
157 Summary:        Qt5 bindings and Qt5 Designer plugin for VTK
158 Summary(pl.UTF-8):      Wiązania Qt5 oraz wtyczka Qt5 Designera do VTK
159 Group:          X11/Libraries
160 Requires:       %{name} = %{version}-%{release}
161 Requires:       Qt5Core >= 4.5.0
162 Requires:       Qt5Gui >= 4.5.0
163 Requires:       Qt5Network >= 4.5.0
164 Requires:       Qt5OpenGL >= 4.5.0
165 Requires:       Qt5Sql >= 4.5.0
166 Requires:       Qt5WebKit >= 4.5.0
167
168 %description qt
169 Qt5 bindings and Qt5 Designer plugin for VTK.
170
171 %description qt -l pl.UTF-8
172 Wiązania Qt5 oraz wtyczka Qt5 Designera do VTK.
173
174 %package qt-devel
175 Summary:        Header files for VTK Qt5 bindings
176 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Qt5` do VTK
177 Group:          X11/Development/Libraries
178 Requires:       %{name}-devel = %{version}-%{release}
179 Requires:       %{name}-qt = %{version}-%{release}
180 Requires:       Qt5Core-devel >= 4.5.0
181 Requires:       Qt5Gui-devel >= 4.5.0
182 Requires:       Qt5OpenGL-devel >= 4.5.0
183 Requires:       Qt5Sql-devel >= 4.5.0
184
185 %description qt-devel
186 Header files for VTK Qt bindings.
187
188 %description qt-devel -l pl.UTF-8
189 Pliki nagłówkowe wiązań Qt do VTK.
190
191 %package java
192 Summary:        Java bindings for VTK
193 Summary(pl.UTF-8):      Wiązania Javy do VTK
194 Group:          Development/Languages/Java
195 Requires:       %{name} = %{version}-%{release}
196 # or separate qt parts?
197 Requires:       %{name}-qt = %{version}-%{release}
198
199 %description java
200 This package contains Java bindings for VTK.
201
202 %description java -l pl.UTF-8
203 Ten pakiet zawiera wiązania Javy do VTK.
204
205 %package java-devel
206 Summary:        Header files for Java VTK binding
207 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Javy do VTK
208 Group:          Development/Libraries
209 Requires:       %{name}-devel = %{version}-%{release}
210 Requires:       %{name}-java = %{version}-%{release}
211 # <jni.h>
212 Requires:       jdk
213
214 %description java-devel
215 Header files for Java VTK binding.
216
217 %description java-devel -l pl.UTF-8
218 Pliki nagłówkowe wiązania Javy do VTK.
219
220 %package python3
221 Summary:        Python 3 bindings for VTK
222 Summary(pl.UTF-8):      Wiązania Pythona 3 do VTK
223 Group:          Libraries
224 Requires:       %{name} = %{version}-%{release}
225 # or separate qt parts again?
226 Requires:       %{name}-qt = %{version}-%{release}
227 Obsoletes:      vtk-python-qt < 6.0.0-1
228 Obsoletes:      vtk-python-sip < 6.0.0-1
229 Obsoletes:      vtk-python < 8.2.0-1
230
231 %description python3
232 This package contains Python 3 bindings for VTK.
233
234 %description python3 -l pl.UTF-8
235 Ten pakiet zawiera wiązania Pythona 3 do VTK.
236
237 %package python3-devel
238 Summary:        Header files for Python 3 VTK binding
239 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Pythona 3 do VTK
240 Group:          Development/Libraries
241 Requires:       %{name}-devel = %{version}-%{release}
242 Requires:       %{name}-python3 = %{version}-%{release}
243 Requires:       python3-devel
244 Obsoletes:      vtk-python-devel < 8.2.0-1
245
246 %description python3-devel
247 Header files for Python 3 VTK binding.
248
249 %description python3-devel -l pl.UTF-8
250 Pliki nagłówkowe wiązania Pythona 3 do VTK.
251
252 %package examples
253 Summary:        C++ and Python example programs/scripts for VTK
254 Summary(pl.UTF-8):      Przykładowe programy/skrypty w C++ i Pythonie dla VTK
255 Group:          Development/Libraries
256 Requires:       %{name} = %{version}-%{release}
257 Requires:       %{name}-data = %{version}-%{release}
258
259 %description examples
260 This package contains all the examples from the VTK source. To compile
261 the C++ examples you will need to install the vtk-devel package as
262 well. The Python examples can be run with the corresponding
263 packages (vtk-python3).
264
265 %description examples -l pl.UTF-8
266 Ten pakiet zawiera wszystkie przykłady ze źródeł VTK. Do skompilowania
267 przykładów w C++ trzeba doinstalować pakiet vtk-devel. Przykłady w
268 Pythonie można uruchamiać przy użyciu odpowiednich pakietów
269 (vtk-python3).
270
271 %package test-suite
272 Summary:        Test programs for VTK
273 Summary(pl.UTF-8):      Programy testowe dla VTK
274 Group:          Development/Libraries
275 Requires:       %{name} = %{version}-%{release}
276 Requires:       %{name}-data = %{version}-%{release}
277
278 %description test-suite
279 This package contains all testing programs from the VTK source. The
280 source code of these programs can be found in the vtk-examples
281 package.
282
283 %description test-suite -l pl.UTF-8
284 Ten pakiet zawiera wszystkie programy testowe ze źródeł VTK. Kod
285 źródłowy tych programów można znaleźć w pakiecie vtk-examples.
286
287 %package data
288 Summary:        Data files for VTK
289 Summary(pl.UTF-8):      Pliki danych dla VTK
290 Group:          Development/Libraries
291 %if "%{_rpmversion}" >= "5"
292 BuildArch:      noarch
293 %endif
294
295 %description data
296 This package contains all the data from the VTKData repository. These
297 data are required to run various examples from the vtk-examples
298 package.
299
300 %description data -l pl.UTF-8
301 Ten pakiet zawiera wszystkie dane z repozytorium VTKData. Dane te są
302 potrzebne do uruchamiania różnych przykładów z pakietu vtk-examples.
303
304 %prep
305 %setup -q -n VTK-%{version} -b 1
306 %patch0 -p1
307 %patch1 -p1
308 %patch2 -p1
309 %patch3 -p1
310 %patch4 -p1
311 %patch5 -p1
312
313 # Replace relative path ../../../VTKData with destination filesystem path
314 grep -Erl '(\.\./)+VTKData' Examples | xargs \
315   perl -pi -e 's,(\.\./)+VTKData,%{_datadir}/vtk-8.1,g'
316
317 # Save an unbuilt copy of the Example's sources for %doc
318 mkdir vtk-examples
319 cp -a Examples vtk-examples
320 # Don't ship Win32 examples
321 %{__rm} -r vtk-examples/Examples/GUI/Win32
322 find vtk-examples -type f | xargs chmod -R a-x
323
324 for x in doubleconversion eigen expat freetype %{?with_system_gl2ps:gl2ps }glew hdf5 jpeg jsoncpp libproj libxml2 lz4 lzma netcdf ogg png pugixml sqlite theora tiff zfp zlib; do
325 %{__rm} -r ThirdParty/*/vtk$x
326 done
327
328 %build
329 export CFLAGS="%{rpmcflags} -D_UNICODE -DHAVE_UINTPTR_T"
330 export CXXFLAGS="%{rpmcxxflags} -D_UNICODE -DHAVE_UINTPTR_T"
331 %if %{with java}
332 export JAVA_HOME=%{java_home}
333 %ifarch x32
334 # getting "java.lang.OutOfMemoryError: Java heap space" during the build
335 export JAVA_TOOL_OPTIONS=-Xmx2048m
336 %endif
337 %endif
338
339 # handle cmake & ccache
340 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmake
341 # ASM fix: http://lists.busybox.net/pipermail/buildroot/2013-March/069436.html
342 if [[ "%{__cc}" = *ccache* ]]; then
343         cc="%{__cc}"
344         cxx="%{__cxx}"
345         ccache="
346         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
347         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
348         -DCMAKE_ASM_COMPILER="${cc#ccache }" \
349         "
350 else
351         ccache="
352         -DCMAKE_C_COMPILER="%{__cc}" \
353         -DCMAKE_CXX_COMPILER="%{__cxx}" \
354         -DCMAKE_ASM_COMPILER="%{__cc}" \
355         "
356 fi
357
358 mkdir -p build
359 cd build
360 %cmake .. \
361         $ccache \
362         -Wno-dev \
363         %{cmake_on_off doc DBUILD_DOCUMENTATION} \
364         -DBUILD_EXAMPLES:BOOL=ON \
365         -DBUILD_SHARED_LIBS:BOOL=ON \
366         -DBUILD_TESTING:BOOL=ON \
367         -DCMAKE_SKIP_RPATH:BOOL=ON \
368         -DOPENGL_INCLUDE_PATH:PATH=%{_includedir}/GL \
369         -DPYTHON_INCLUDE_PATH:PATH=%{py3_incdir} \
370         -DPYTHON_LIBRARY:FILEPATH=%{_libdir}/libpython%{py3_ver}.so \
371         -DPYTHON_UTIL_LIBRARY:PATH=%{_libdir}/libutil.so \
372         -DTCL_INCLUDE_PATH:PATH=%{_includedir} \
373         -DTCL_LIBRARY:PATH=%{_libdir}/libtcl.so \
374         -DTK_INCLUDE_PATH:PATH=%{_includedir} \
375         -DTK_LIBRARY:PATH=%{_libdir}/libtk.so \
376         -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
377         -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/vtk \
378         -DVTK_INSTALL_INCLUDE_DIR:PATH=include/vtk \
379         -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/vtk \
380         -DVTK_INSTALL_PACKAGE_DIR:PATH=%{_lib}/cmake/vtk \
381         -DVTK_INSTALL_TCL_DIR:PATH=share/tcl%{tcl_version}/vtk \
382         -DVTK_INSTALL_QT_DIR=/%{_lib}/qt5/plugins/designer \
383         -DVTK_INSTALL_PYTHON_MODULES_DIR:PATH=%{py3_sitedir} \
384         -DVTK_FFMPEG_HAS_OLD_HEADER:BOOL=OFF \
385         %{?with_OSMesa:-DVTK_OPENGL_HAS_OSMESA:BOOL=ON} \
386         -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
387         -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
388         -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
389         -DVTK_USE_SYSTEM_XDMF2:BOOL=OFF \
390         -DVTK_USE_SYSTEM_LIBHARU:BOOL=OFF \
391         %{!?with_system_gl2ps:-DVTK_USE_SYSTEM_GL2PS:BOOL=OFF} \
392 %if %{with java}
393         -DVTK_WRAP_JAVA:BOOL=ON \
394         -DJAVA_INCLUDE_PATH:PATH=$JAVA_HOME/include \
395         -DJAVA_INCLUDE_PATH2:PATH=$JAVA_HOME/include/linux \
396         -DJAVA_AWT_INCLUDE_PATH:PATH=$JAVA_HOME/include \
397 %else
398         -DVTK_WRAP_JAVA:BOOL=OFF \
399 %endif
400         -DVTK_WRAP_PYTHON:BOOL=ON \
401         -DVTK_PYTHON_VERSION=3 \
402         %{?with_sip:-DVTK_WRAP_PYTHON_SIP:BOOL=ON} \
403         -DVTK_Group_Imaging:BOOL=ON \
404         -DVTK_Group_Qt:BOOL=ON \
405         -DVTK_Group_Rendering:BOOL=ON \
406         -DVTK_Group_StandAlone:BOOL=ON \
407         -DVTK_Group_Tk:BOOL=ON \
408         -DVTK_Group_Views:BOOL=ON \
409         -DModule_vtkFiltersReebGraph:BOOL=ON \
410         %{?with_ffmpeg:-DModule_vtkIOFFMPEG:BOOL=ON} \
411         -DModule_vtkIOGDAL:BOOL=ON \
412         -DModule_vtkIOGeoJSON:BOOL=ON \
413         -DModule_vtkIOMySQL:BOOL=ON \
414         -DModule_vtkIOODBC:BOOL=ON \
415         -DModule_vtkIOParallelExodus:BOOL=ON \
416         -DModule_vtkIOParallelLSDyna:BOOL=ON \
417         -DModule_vtkIOPostgreSQL:BOOL=ON \
418         -DModule_vtkIOVPIC:BOOL=ON \
419         -DModule_vtkIOXdmf2:BOOL=ON \
420         -DModule_vtkInfovisBoost:BOOL=ON \
421         -DModule_vtkInfovisBoostGraphAlgorithms:BOOL=ON \
422         -DModule_vtkRenderingFreeTypeFontConfig:BOOL=ON \
423         -DModule_vtkRenderingMatplotlib:BOOL=ON \
424         -DModule_vtkRenderingParallel:BOOL=ON
425 # TODO: -DModule_vtkAcceleratorsDax:BOOL=ON (BR: FindDax.cmake, maybe http://www.daxtoolkit.org/ ?)
426 # TODO: -DModule_vtkAcceleratorsPiston:BOOL=ON (on bcond, BR: CUDA)
427 # TODO: -DModule_vtkFiltersParallelFlowPaths:BOOL=ON (BR: MPI)
428 # TODO: -DModule_vtkFiltersParallelStatistics:BOOL=ON (BR: MPI)
429 # TODO: -DModule_vtkInfovisParallel:BOOL=ON (BR: MPI)
430 # TODO: -DModule_vtkRenderingParallelLIC:BOOL=ON (BR: MPI)
431
432 %{__make}
433 %{?with_doc:%{__make} DoxygenDoc}
434
435 %install
436 rm -rf $RPM_BUILD_ROOT
437 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ld.so.conf.d,%{_examplesdir}/%{name}-%{version}}
438
439 %{__make} -C build install \
440         DESTDIR=$RPM_BUILD_ROOT
441
442 # ld config
443 echo %{_libdir}/vtk > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
444
445 for f in $(cd build/ExternalData/Testing ; find Data -type l); do
446         install -Dp build/ExternalData/Testing/$f $RPM_BUILD_ROOT%{_datadir}/vtk-8.1/$f
447 done
448
449 # Install examples
450 for f in \
451 AmbientSpheres \
452 Arrays \
453 BalloonWidget \
454 BandedContours \
455 Cone \
456 Cone2 \
457 Cone3 \
458 Cone4 \
459 Cone5 \
460 Cone6 \
461 Cube \
462 Cylinder \
463 Delaunay3D \
464 Delaunay3DAlpha \
465 DiffuseSpheres \
466 DumpXMLFile \
467 FilledContours \
468 FixedPointVolumeRayCastMapperCT \
469 GPURenderDemo \
470 Generate2DAMRDataSetWithPulse \
471 Generate3DAMRDataSetWithPulse \
472 GenerateCubesFromLabels \
473 GenerateModelsFromLabels \
474 HierarchicalBoxPipeline \
475 ImageSlicing \
476 LabeledMesh \
477 Medical1 \
478 Medical2 \
479 Medical3 \
480 Medical4 \
481 MultiBlock \
482 ParticleReader \
483 RGrid \
484 SGrid \
485 SimpleView \
486 Slider \
487 Slider2D \
488 SpecularSpheres \
489 TubesWithVaryingRadiusAndColors \
490 finance ; do
491         install build/bin/$f $RPM_BUILD_ROOT%{_bindir}
492 done
493
494 # Install test binaries
495 for f in build/bin/*Tests build/bin/Test*; do
496         install $f $RPM_BUILD_ROOT%{_bindir}
497 done
498
499 %if %{with java}
500 install -p build/bin/VTKJavaExecutable $RPM_BUILD_ROOT%{_bindir}
501 %endif
502 install -p build/bin/vtkpython $RPM_BUILD_ROOT%{_bindir}
503
504 # unwanted doxygen files and misplaced verdict docs
505 %{?with_doc:%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/vtk-*/{doxygen,verdict}}
506
507 %clean
508 rm -rf $RPM_BUILD_ROOT
509
510 %post   -p /sbin/ldconfig
511 %postun -p /sbin/ldconfig
512
513 %post   qt -p /sbin/ldconfig
514 %postun qt -p /sbin/ldconfig
515
516 %post   java -p /sbin/ldconfig
517 %postun java -p /sbin/ldconfig
518
519 %post   python3 -p /sbin/ldconfig
520 %postun python3 -p /sbin/ldconfig
521
522 %files
523 %defattr(644,root,root,755)
524 %doc README.md vtkBanner.gif vtkLogo.ico Wrapping/Tools/README*
525 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
526 %dir %{_libdir}/vtk
527 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so.1
528 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so.1
529 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so.1
530 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2.so.1
531 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so.1
532 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so.1
533 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so.1
534 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so.1
535 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so.1
536 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so.1
537 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so.1
538 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so.1
539 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so.1
540 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so.1
541 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so.1
542 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL2.so.1
543 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so.1
544 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so.1
545 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so.1
546 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PSOpenGL2.so.1
547 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so.1
548 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so.1
549 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so.1
550 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL2.so.1
551 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so.1
552 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL2.so.1
553 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so.1
554 %attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so.1
555 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so.1
556 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so.1
557 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so.1
558 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so.1
559 %attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so.1
560 %attr(755,root,root) %{_libdir}/vtk/libvtkgl2ps.so.1
561 %attr(755,root,root) %{_libdir}/vtk/libvtklibharu.so.1
562 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so.1
563 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so.1
564 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so.1
565 %attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so.1
566 %if %{with java}
567 %exclude %{_libdir}/vtk/libvtk*Java.so.1
568 %endif
569 %exclude %{_libdir}/vtk/libvtk*Python3?D.so.1
570 %exclude %{_libdir}/vtk/libvtkWrappingPython3?Core.so.1
571
572 %files devel
573 %defattr(644,root,root,755)
574 %doc Utilities/Upgrading/*
575 %attr(755,root,root) %{_bindir}/vtkWrapHierarchy
576 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so
577 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so
578 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so
579 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2.so
580 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so
581 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so
582 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so
583 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so
584 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so
585 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so
586 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so
587 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so
588 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so
589 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so
590 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so
591 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL2.so
592 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so
593 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so
594 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so
595 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PSOpenGL2.so
596 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so
597 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so
598 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so
599 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL2.so
600 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so
601 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL2.so
602 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so
603 %attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so
604 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so
605 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so
606 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so
607 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so
608 %attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so
609 %attr(755,root,root) %{_libdir}/vtk/libvtkgl2ps.so
610 %attr(755,root,root) %{_libdir}/vtk/libvtklibharu.so
611 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so
612 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so
613 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so
614 %attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so
615 %if %{with java}
616 %exclude %{_libdir}/vtk/libvtk*Java.so
617 %endif
618 %exclude %{_libdir}/vtk/libvtk*Python3?D.so
619 %exclude %{_libdir}/vtk/libvtkWrappingPython3?Core.so
620 %{_libdir}/vtk/libvtkWrappingTools.a
621 %dir %{_includedir}/vtk
622 %{_includedir}/vtk/VPIC
623 %{_includedir}/vtk/DICOM*.h
624 %{_includedir}/vtk/DatabaseSchemaWith2Tables.h
625 %{_includedir}/vtk/vtkgl2ps
626 %{_includedir}/vtk/vtkkwiml
627 %{_includedir}/vtk/vtklibharu
628 %{_includedir}/vtk/vtkmetaio
629 %{_includedir}/vtk/vtksys
630 %{_includedir}/vtk/vtkverdict
631 %{_includedir}/vtk/vtkxdmf2
632 %{_includedir}/vtk/vtk*.h
633 %{_includedir}/vtk/vtk*.txx
634 %exclude %{_includedir}/vtk/vtkEventQtSlotConnect.h
635 %exclude %{_includedir}/vtk/vtkGUISupportQt*.h
636 %if %{with java}
637 %exclude %{_includedir}/vtk/vtkJavaUtil.h
638 %exclude %{_includedir}/vtk/vtkWrappingJavaModule.h
639 %endif
640 %exclude %{_includedir}/vtk/vtkPython*.h
641 %exclude %{_includedir}/vtk/vtkQImageToImageSource.h
642 %exclude %{_includedir}/vtk/vtkQt*.h
643 %exclude %{_includedir}/vtk/vtkRenderingQtModule.h
644 %exclude %{_includedir}/vtk/vtkTk*.h
645 %exclude %{_includedir}/vtk/vtkViewsQtModule.h
646 %{_libdir}/cmake/vtk
647
648 %files qt
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so.1
651 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so.1
652 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so.1
653 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so.1
654 %attr(755,root,root) %{_libdir}/qt5/plugins/designer/libQVTKWidgetPlugin.so
655
656 %files qt-devel
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so
659 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so
660 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so
661 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so
662 %{_includedir}/vtk/QFilterTreeProxyModel.h
663 %{_includedir}/vtk/QVTK*.h
664 %{_includedir}/vtk/vtkEventQtSlotConnect.h
665 %{_includedir}/vtk/vtkGUISupportQt*.h
666 %{_includedir}/vtk/vtkQImageToImageSource.h
667 %{_includedir}/vtk/vtkQt*.h
668 %{_includedir}/vtk/vtkRenderingQtModule.h
669 %{_includedir}/vtk/vtkViewsQtModule.h
670
671 %if %{with java}
672 %files java
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_bindir}/VTKJavaExecutable
675 %attr(755,root,root) %{_bindir}/vtkParseJava
676 %attr(755,root,root) %{_bindir}/vtkWrapJava
677 # common library
678 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so.1
679 # java modules
680 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCoreJava.so
681 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*Java.so
682 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryJava.so
683 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2Java.so
684 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*Java.so
685 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCoreJava.so
686 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*Java.so
687 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*Java.so
688 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*Java.so
689 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*Java.so
690 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExampleJava.so
691 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCoreJava.so
692 %attr(755,root,root) %{_libdir}/vtk/libvtkRendering*Java.so
693 %attr(755,root,root) %{_libdir}/vtk/libvtkTestingRenderingJava.so
694 %attr(755,root,root) %{_libdir}/vtk/libvtkViews*Java.so
695 %{_libdir}/vtk/vtk.jar
696
697 %files java-devel
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so
700 %{_includedir}/vtk/vtkJavaUtil.h
701 %{_includedir}/vtk/vtkWrappingJavaModule.h
702 %endif
703
704 %files python3
705 %defattr(644,root,root,755)
706 %doc Wrapping/Python/README*
707 %attr(755,root,root) %{_bindir}/vtkWrapPython
708 %attr(755,root,root) %{_bindir}/vtkWrapPythonInit
709 %attr(755,root,root) %{_bindir}/vtkpython
710 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python3?D.so.1
711 %attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so.1
712 # RenderingMatplotlib requires PythonInterpreter
713 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so.1
714 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingPythonTkWidgets-8.2.so
715 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython3?Core.so.1
716 %dir %{py3_sitedir}/vtk.py
717 %dir %{py3_sitedir}/__pycache__/*
718 %dir %{py3_sitedir}/vtkmodules
719 %{py3_sitedir}/vtkmodules/*.py
720 %{py3_sitedir}/vtkmodules/__pycache__
721 %dir %{py3_sitedir}/vtkmodules/gtk
722 %{py3_sitedir}/vtkmodules/gtk/*.py
723 %{py3_sitedir}/vtkmodules/gtk/__pycache__
724 %dir %{py3_sitedir}/vtkmodules/numpy_interface
725 %{py3_sitedir}/vtkmodules/numpy_interface/*.py
726 %{py3_sitedir}/vtkmodules/numpy_interface/__pycache__
727 %dir %{py3_sitedir}/vtkmodules/qt
728 %{py3_sitedir}/vtkmodules/qt/*.py
729 %{py3_sitedir}/vtkmodules/qt/__pycache__
730 %dir %{py3_sitedir}/vtkmodules/qt4
731 %{py3_sitedir}/vtkmodules/qt4/*.py
732 %{py3_sitedir}/vtkmodules/qt4/__pycache__
733 %dir %{py3_sitedir}/vtkmodules/test
734 %{py3_sitedir}/vtkmodules/test/*.py
735 %{py3_sitedir}/vtkmodules/test/__pycache__
736 %dir %{py3_sitedir}/vtkmodules/tk
737 %{py3_sitedir}/vtkmodules/tk/__pycache__
738 %{py3_sitedir}/vtkmodules/tk/*.py
739 %dir %{py3_sitedir}/vtkmodules/util
740 %{py3_sitedir}/vtkmodules/util/*.py
741 %{py3_sitedir}/vtkmodules/util/__pycache__
742 %dir %{py3_sitedir}/vtkmodules/wx
743 %{py3_sitedir}/vtkmodules/wx/*.py
744 %{py3_sitedir}/vtkmodules/wx/__pycache__
745 %attr(755,root,root) %{py3_sitedir}/vtkmodules/vtk*Python.so
746
747 %files python3-devel
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python3?D.so
750 %attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so
751 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so
752 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython3?Core.so
753 %{_includedir}/vtk/PyVTK*.h
754 %{_includedir}/vtk/vtkPython*.h
755
756 %files test-suite
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{_bindir}/*Tests
759 %attr(755,root,root) %{_bindir}/Test*
760
761 %files examples
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{_bindir}/AmbientSpheres
764 %attr(755,root,root) %{_bindir}/Arrays
765 %attr(755,root,root) %{_bindir}/Cone
766 %attr(755,root,root) %{_bindir}/Cone2
767 %attr(755,root,root) %{_bindir}/Cone3
768 %attr(755,root,root) %{_bindir}/Cone4
769 %attr(755,root,root) %{_bindir}/Cone5
770 %attr(755,root,root) %{_bindir}/Cone6
771 %attr(755,root,root) %{_bindir}/Cube
772 %attr(755,root,root) %{_bindir}/Cylinder
773 %attr(755,root,root) %{_bindir}/DiffuseSpheres
774 %attr(755,root,root) %{_bindir}/HierarchicalBoxPipeline
775 %attr(755,root,root) %{_bindir}/Medical1
776 %attr(755,root,root) %{_bindir}/Medical2
777 %attr(755,root,root) %{_bindir}/Medical3
778 %attr(755,root,root) %{_bindir}/Medical4
779 %attr(755,root,root) %{_bindir}/MultiBlock
780 %attr(755,root,root) %{_bindir}/RGrid
781 %attr(755,root,root) %{_bindir}/SGrid
782 %attr(755,root,root) %{_bindir}/SimpleView
783 %attr(755,root,root) %{_bindir}/SpecularSpheres
784 %attr(755,root,root) %{_bindir}/finance
785 %attr(755,root,root) %{_bindir}/BalloonWidget
786 %attr(755,root,root) %{_bindir}/BandedContours
787 %attr(755,root,root) %{_bindir}/Delaunay3D
788 %attr(755,root,root) %{_bindir}/Delaunay3DAlpha
789 %attr(755,root,root) %{_bindir}/DumpXMLFile
790 %attr(755,root,root) %{_bindir}/FilledContours
791 %attr(755,root,root) %{_bindir}/FixedPointVolumeRayCastMapperCT
792 %attr(755,root,root) %{_bindir}/GPURenderDemo
793 %attr(755,root,root) %{_bindir}/Generate2DAMRDataSetWithPulse
794 %attr(755,root,root) %{_bindir}/Generate3DAMRDataSetWithPulse
795 %attr(755,root,root) %{_bindir}/GenerateCubesFromLabels
796 %attr(755,root,root) %{_bindir}/GenerateModelsFromLabels
797 %attr(755,root,root) %{_bindir}/ImageSlicing
798 %attr(755,root,root) %{_bindir}/LabeledMesh
799 %attr(755,root,root) %{_bindir}/ParticleReader
800 %attr(755,root,root) %{_bindir}/Slider
801 %attr(755,root,root) %{_bindir}/Slider2D
802 %attr(755,root,root) %{_bindir}/TubesWithVaryingRadiusAndColors
803 %{_examplesdir}/%{name}-%{version}
804
805 %files data
806 %defattr(644,root,root,755)
807 %dir %{_datadir}/vtk-8.1
808 %{_datadir}/vtk-8.1/Data
This page took 0.114431 seconds and 2 git commands to generate.