]> git.pld-linux.org Git - packages/vtk.git/blob - vtk.spec
0e01aab58d282b7c2dea19b7772ad1dc63023318
[packages/vtk.git] / vtk.spec
1 # TODO:
2 # - handle VTK_USE_MPEG2_ENCODER (see CMakeLists.txt)
3 # - handle MPI and VTK_USE_PARALLEL_BGL (Parallel Boost Graph Library, BR: boost >= 1.40)
4 # - more system libraries? (check for VTK_THIRD_PARTY_SUBDIR in Utilities/CMakeLists.txt)
5 # - CUDA for Accelerators/Piston (on bcond)
6 # - NVCtrlLib for Rendering/OpenGL (on bcond)
7 # - VTK_USE_SYSTEM_XDMF2=ON ? (but our xdmf-devel seems not compatible)
8 # - python bcond?
9 # - use system exodusii
10 #
11 # Conditional build
12 %bcond_without  java            # Java wrappers
13 %bcond_without  ffmpeg          # FFMPEG .avi saving support
14 %bcond_with     doc             # do not build and package doxygen documentation
15 %bcond_with     OSMesa          # build with OSMesa (https://bugzilla.redhat.com/show_bug.cgi?id=744434)
16 %bcond_with     system_gl2ps    # use system gl2ps (VTK currently is carrying local modifications to gl2ps)
17
18 Summary:        Toolkit for 3D computer graphics, image processing, and visualization
19 Summary(pl.UTF-8):      Zestaw narzędzi do trójwymiarowej grafiki, przetwarzania obrazu i wizualizacji
20 Name:           vtk
21 Version:        8.2.0
22 Release:        0.1
23 License:        BSD
24 Group:          Libraries
25 Source0:        http://www.vtk.org/files/release/8.2/VTK-%{version}.tar.gz
26 # Source0-md5:  8af3307da0fc2ef8cafe4a312b821111
27 Source1:        http://www.vtk.org/files/release/8.2/VTKData-%{version}.tar.gz
28 # Source1-md5:  a6eab7bc02cee1376ee69243dde373ce
29 Patch0:         vtk-abi.patch
30 Patch1:         gcc10.patch
31 Patch2:         proj6_compat.patch
32 Patch3:         qt-5.15.patch
33 Patch4:         python-3.8.patch
34 Patch5:         link.patch
35 Patch6:         system-pugixml.patch
36 URL:            http://www.vtk.org/
37 %{?with_OSMesa:BuildRequires: Mesa-libOSMesa-devel}
38 BuildRequires:  OpenGL-GLX-devel
39 BuildRequires:  OpenGL-devel
40 BuildRequires:  Qt5Core-devel
41 BuildRequires:  Qt5Designer-devel
42 BuildRequires:  Qt5Gui-devel
43 BuildRequires:  Qt5Network-devel
44 BuildRequires:  Qt5OpenGL-devel
45 BuildRequires:  Qt5Sql-devel
46 BuildRequires:  Qt5WebKit-devel
47 BuildRequires:  Qt5X11Extras-devel
48 BuildRequires:  Qt5XmlPatterns-devel
49 BuildRequires:  Qt5UiTools-devel
50 BuildRequires:  R
51 BuildRequires:  boost-devel >= 1.39
52 BuildRequires:  cmake >= 3.3
53 BuildRequires:  double-conversion-devel
54 %{?with_doc:BuildRequires:      doxygen}
55 BuildRequires:  eigen3 >= 2.91.0
56 BuildRequires:  expat-devel
57 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
58 BuildRequires:  fontconfig-devel
59 BuildRequires:  freetype-devel >= 2
60 BuildRequires:  gdal-devel
61 %{?with_system_gl2ps:BuildRequires:     gl2ps-devel >= 1.3.8}
62 BuildRequires:  glew-devel
63 BuildRequires:  gnuplot
64 BuildRequires:  graphviz
65 BuildRequires:  hdf5-devel
66 %if %{with java}
67 BuildRequires:  jdk >= 1.5
68 BuildRequires:  jpackage-utils
69 %endif
70 BuildRequires:  jsoncpp-devel >= 0.7.0
71 BuildRequires:  libharu-devel
72 BuildRequires:  libjpeg-devel
73 BuildRequires:  libogg-devel
74 BuildRequires:  libpng-devel
75 BuildRequires:  libstdc++-devel
76 BuildRequires:  libtheora-devel
77 BuildRequires:  libtiff-devel
78 BuildRequires:  libxml2-devel >= 2
79 BuildRequires:  lz4-devel
80 BuildRequires:  motif-devel
81 BuildRequires:  mysql-devel
82 BuildRequires:  netcdf-cxx-devel >= 4
83 # some code using it exists (Domains/Chemistry), but is not included in cmakefiles
84 #BuildRequires: openqube-devel
85 BuildRequires:  perl-base
86 BuildRequires:  postgresql-devel
87 BuildRequires:  proj-devel >= 6.0
88 BuildRequires:  pugixml-devel
89 BuildRequires:  python3-devel
90 BuildRequires:  python3-sip-devel
91 BuildRequires:  qt5-build >= 4.5.0
92 BuildRequires:  qt5-qmake >= 4.5.0
93 BuildRequires:  rpmbuild(macros) >= 1.605
94 BuildRequires:  sip
95 BuildRequires:  sip-PyQt5
96 BuildRequires:  sqlite3-devel
97 BuildRequires:  tcl-devel
98 BuildRequires:  tk-devel
99 BuildRequires:  unixODBC-devel
100 BuildRequires:  wget
101 BuildRequires:  xorg-lib-libICE-devel
102 BuildRequires:  xorg-lib-libSM-devel
103 BuildRequires:  xorg-lib-libX11-devel
104 BuildRequires:  xorg-lib-libXScrnSaver-devel
105 BuildRequires:  xorg-lib-libXext-devel
106 BuildRequires:  xorg-lib-libXft-devel
107 BuildRequires:  xorg-lib-libXt-devel
108 BuildRequires:  xz-devel
109 BuildRequires:  zlib-devel
110 BuildConflicts: libXNVCtrl-devel
111 Obsoletes:      vtk-tcl < 8.2.0-1
112 Obsoletes:      vtk-tcl-devel < 8.2.0-1
113 %{?with_system_gl2ps:Requires:  gl2ps >= 1.3.8}
114 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
115
116 %define         skip_post_check_so      lib.*Python.*\.so.*
117
118 %description
119 The Visualization ToolKit (VTK) is an object oriented software system
120 for 3D computer graphics, image processing, and visualization. VTK
121 includes a textbook, a C++ class library, and several interpreted
122 interface layers including Java, and Python. VTK supports a
123 wide variety of visualization algorithms including scalar, vector,
124 tensor, texture, and volumetric methods. It also supports advanced
125 modeling techniques like implicit modeling, polygon reduction, mesh
126 smoothing, cutting, contouring, and Delaunay triangulation. Moreover,
127 dozens of imaging algorithms have been integrated into the system.
128 This allows mixing 2D imaging / 3D graphics algorithms and data.
129
130 %description -l pl.UTF-8
131 Visualization TookKit (VTK) to obiektowo zorientowany system
132 oprogramowania do trójwymiarowej grafiki komputerowej, przetwarzania
133 obrazu i wizualizacji. VTK zawiera książkę, bibliotekę klas C++ oraz
134 kilka interpretowanych warstw interfejsów, w tym dla Javy i
135 Pythona. VTK obsługuje szeroki zakres algorytmów wizualizacji, w tym
136 metody skalarne, wektorowe, tensorowe, teksturowe i wolumetryczne.
137 Obsługuje także zaawansowane techniki modelowania, takie jak
138 modelowanie implicite, redukcja wielokątów, wygładzanie siatki,
139 przycinanie, konturowanie i triangulacja Delaunaya. Co więcej, wiele
140 algorytmów obrazowania zostało zintegrowanych z systemem. Pozwala to
141 na mieszanie algorytmów obrazowania 2D i grafiki 3D.
142
143 %package devel
144 Summary:        VTK header files for building C++ code
145 Summary(pl.UTF-8):      Pliki nagłówkowe VTK dla C++
146 Group:          Development
147 Requires:       %{name} = %{version}-%{release}
148 Requires:       libstdc++-devel
149
150 %description devel
151 This provides the VTK header files required to compile C++ programs
152 that use VTK to do 3D visualisation.
153
154 %description devel -l pl.UTF-8
155 Ten pakiet dostarcza pliki nagłówkowe VTK do kompilowania programów
156 C++ używających VTK do wizualizacji 3D.
157
158 %package qt
159 Summary:        Qt5 bindings and Qt5 Designer plugin for VTK
160 Summary(pl.UTF-8):      Wiązania Qt5 oraz wtyczka Qt5 Designera do VTK
161 Group:          X11/Libraries
162 Requires:       %{name} = %{version}-%{release}
163 Requires:       Qt5Core >= 4.5.0
164 Requires:       Qt5Gui >= 4.5.0
165 Requires:       Qt5Network >= 4.5.0
166 Requires:       Qt5OpenGL >= 4.5.0
167 Requires:       Qt5Sql >= 4.5.0
168 Requires:       Qt5WebKit >= 4.5.0
169
170 %description qt
171 Qt5 bindings and Qt5 Designer plugin for VTK.
172
173 %description qt -l pl.UTF-8
174 Wiązania Qt5 oraz wtyczka Qt5 Designera do VTK.
175
176 %package qt-devel
177 Summary:        Header files for VTK Qt5 bindings
178 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Qt5` do VTK
179 Group:          X11/Development/Libraries
180 Requires:       %{name}-devel = %{version}-%{release}
181 Requires:       %{name}-qt = %{version}-%{release}
182 Requires:       Qt5Core-devel >= 4.5.0
183 Requires:       Qt5Gui-devel >= 4.5.0
184 Requires:       Qt5OpenGL-devel >= 4.5.0
185 Requires:       Qt5Sql-devel >= 4.5.0
186
187 %description qt-devel
188 Header files for VTK Qt bindings.
189
190 %description qt-devel -l pl.UTF-8
191 Pliki nagłówkowe wiązań Qt do VTK.
192
193 %package java
194 Summary:        Java bindings for VTK
195 Summary(pl.UTF-8):      Wiązania Javy do VTK
196 Group:          Development/Languages/Java
197 Requires:       %{name} = %{version}-%{release}
198 # or separate qt parts?
199 Requires:       %{name}-qt = %{version}-%{release}
200
201 %description java
202 This package contains Java bindings for VTK.
203
204 %description java -l pl.UTF-8
205 Ten pakiet zawiera wiązania Javy do VTK.
206
207 %package java-devel
208 Summary:        Header files for Java VTK binding
209 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Javy do VTK
210 Group:          Development/Libraries
211 Requires:       %{name}-devel = %{version}-%{release}
212 Requires:       %{name}-java = %{version}-%{release}
213 # <jni.h>
214 Requires:       jdk
215
216 %description java-devel
217 Header files for Java VTK binding.
218
219 %description java-devel -l pl.UTF-8
220 Pliki nagłówkowe wiązania Javy do VTK.
221
222 %package python3
223 Summary:        Python 3 bindings for VTK
224 Summary(pl.UTF-8):      Wiązania Pythona 3 do VTK
225 Group:          Libraries
226 Requires:       %{name} = %{version}-%{release}
227 # or separate qt parts again?
228 Requires:       %{name}-qt = %{version}-%{release}
229 Obsoletes:      vtk-python-qt < 6.0.0-1
230 Obsoletes:      vtk-python-sip < 6.0.0-1
231 Obsoletes:      vtk-python < 8.2.0-1
232
233 %description python3
234 This package contains Python 3 bindings for VTK.
235
236 %description python3 -l pl.UTF-8
237 Ten pakiet zawiera wiązania Pythona 3 do VTK.
238
239 %package python3-devel
240 Summary:        Header files for Python 3 VTK binding
241 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Pythona 3 do VTK
242 Group:          Development/Libraries
243 Requires:       %{name}-devel = %{version}-%{release}
244 Requires:       %{name}-python3 = %{version}-%{release}
245 Requires:       python3-devel
246 Obsoletes:      vtk-python-devel < 8.2.0-1
247
248 %description python3-devel
249 Header files for Python 3 VTK binding.
250
251 %description python3-devel -l pl.UTF-8
252 Pliki nagłówkowe wiązania Pythona 3 do VTK.
253
254 %package examples
255 Summary:        C++ and Python example programs/scripts for VTK
256 Summary(pl.UTF-8):      Przykładowe programy/skrypty w C++ i Pythonie dla VTK
257 Group:          Development/Libraries
258 Requires:       %{name} = %{version}-%{release}
259 Requires:       %{name}-data = %{version}-%{release}
260
261 %description examples
262 This package contains all the examples from the VTK source. To compile
263 the C++ examples you will need to install the vtk-devel package as
264 well. The Python examples can be run with the corresponding
265 packages (vtk-python3).
266
267 %description examples -l pl.UTF-8
268 Ten pakiet zawiera wszystkie przykłady ze źródeł VTK. Do skompilowania
269 przykładów w C++ trzeba doinstalować pakiet vtk-devel. Przykłady w
270 Pythonie można uruchamiać przy użyciu odpowiednich pakietów
271 (vtk-python3).
272
273 %package test-suite
274 Summary:        Test programs for VTK
275 Summary(pl.UTF-8):      Programy testowe dla VTK
276 Group:          Development/Libraries
277 Requires:       %{name} = %{version}-%{release}
278 Requires:       %{name}-data = %{version}-%{release}
279
280 %description test-suite
281 This package contains all testing programs from the VTK source. The
282 source code of these programs can be found in the vtk-examples
283 package.
284
285 %description test-suite -l pl.UTF-8
286 Ten pakiet zawiera wszystkie programy testowe ze źródeł VTK. Kod
287 źródłowy tych programów można znaleźć w pakiecie vtk-examples.
288
289 %package data
290 Summary:        Data files for VTK
291 Summary(pl.UTF-8):      Pliki danych dla VTK
292 Group:          Development/Libraries
293 %if "%{_rpmversion}" >= "5"
294 BuildArch:      noarch
295 %endif
296
297 %description data
298 This package contains all the data from the VTKData repository. These
299 data are required to run various examples from the vtk-examples
300 package.
301
302 %description data -l pl.UTF-8
303 Ten pakiet zawiera wszystkie dane z repozytorium VTKData. Dane te są
304 potrzebne do uruchamiania różnych przykładów z pakietu vtk-examples.
305
306 %prep
307 %setup -q -n VTK-%{version} -b 1
308 %patch0 -p1
309 %patch1 -p1
310 %patch2 -p1
311 %patch3 -p1
312 %patch4 -p1
313 %patch5 -p1
314 %patch6 -p1
315
316 # Replace relative path ../../../VTKData with destination filesystem path
317 grep -Erl '(\.\./)+VTKData' Examples | xargs \
318   perl -pi -e 's,(\.\./)+VTKData,%{_datadir}/vtk-8.1,g'
319
320 # Save an unbuilt copy of the Example's sources for %doc
321 mkdir vtk-examples
322 cp -a Examples vtk-examples
323 # Don't ship Win32 examples
324 %{__rm} -r vtk-examples/Examples/GUI/Win32
325 find vtk-examples -type f | xargs chmod -R a-x
326
327 for x in doubleconversion eigen expat freetype %{?with_system_gl2ps:gl2ps }glew hdf5 jpeg jsoncpp libproj libxml2 lz4 lzma netcdf ogg png pugixml sqlite theora tiff zfp zlib; do
328 %{__rm} -r ThirdParty/*/vtk$x
329 done
330
331 %build
332 export CFLAGS="%{rpmcflags} -D_UNICODE -DHAVE_UINTPTR_T"
333 export CXXFLAGS="%{rpmcxxflags} -D_UNICODE -DHAVE_UINTPTR_T"
334 %if %{with java}
335 export JAVA_HOME=%{java_home}
336 %ifarch x32
337 # getting "java.lang.OutOfMemoryError: Java heap space" during the build
338 export JAVA_TOOL_OPTIONS=-Xmx2048m
339 %endif
340 %endif
341
342 # handle cmake & ccache
343 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmake
344 # ASM fix: http://lists.busybox.net/pipermail/buildroot/2013-March/069436.html
345 if [[ "%{__cc}" = *ccache* ]]; then
346         cc="%{__cc}"
347         cxx="%{__cxx}"
348         ccache="
349         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
350         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
351         -DCMAKE_ASM_COMPILER="${cc#ccache }" \
352         "
353 else
354         ccache="
355         -DCMAKE_C_COMPILER="%{__cc}" \
356         -DCMAKE_CXX_COMPILER="%{__cxx}" \
357         -DCMAKE_ASM_COMPILER="%{__cc}" \
358         "
359 fi
360
361 mkdir -p build
362 cd build
363 %cmake .. \
364         $ccache \
365         -Wno-dev \
366         %{cmake_on_off doc DBUILD_DOCUMENTATION} \
367         -DBUILD_EXAMPLES:BOOL=ON \
368         -DBUILD_SHARED_LIBS:BOOL=ON \
369         -DBUILD_TESTING:BOOL=ON \
370         -DCMAKE_SKIP_RPATH:BOOL=ON \
371         -DOPENGL_INCLUDE_PATH:PATH=%{_includedir}/GL \
372         -DPYTHON_INCLUDE_PATH:PATH=%{py3_incdir} \
373         -DPYTHON_LIBRARY:FILEPATH=%{_libdir}/libpython%{py3_ver}.so \
374         -DPYTHON_UTIL_LIBRARY:PATH=%{_libdir}/libutil.so \
375         -DTCL_INCLUDE_PATH:PATH=%{_includedir} \
376         -DTCL_LIBRARY:PATH=%{_libdir}/libtcl.so \
377         -DTK_INCLUDE_PATH:PATH=%{_includedir} \
378         -DTK_LIBRARY:PATH=%{_libdir}/libtk.so \
379         -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
380         -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/vtk \
381         -DVTK_INSTALL_INCLUDE_DIR:PATH=include/vtk \
382         -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/vtk \
383         -DVTK_INSTALL_PACKAGE_DIR:PATH=%{_lib}/cmake/vtk \
384         -DVTK_INSTALL_TCL_DIR:PATH=share/tcl%{tcl_version}/vtk \
385         -DVTK_INSTALL_QT_DIR=/%{_lib}/qt5/plugins/designer \
386         -DVTK_INSTALL_PYTHON_MODULES_DIR:PATH=%{py3_sitedir} \
387         -DVTK_FFMPEG_HAS_OLD_HEADER:BOOL=OFF \
388         %{?with_OSMesa:-DVTK_OPENGL_HAS_OSMESA:BOOL=ON} \
389         -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
390         -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
391         -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
392         -DVTK_USE_SYSTEM_XDMF2:BOOL=OFF \
393         -DVTK_USE_SYSTEM_LIBHARU:BOOL=OFF \
394         %{!?with_system_gl2ps:-DVTK_USE_SYSTEM_GL2PS:BOOL=OFF} \
395 %if %{with java}
396         -DVTK_WRAP_JAVA:BOOL=ON \
397         -DJAVA_INCLUDE_PATH:PATH=$JAVA_HOME/include \
398         -DJAVA_INCLUDE_PATH2:PATH=$JAVA_HOME/include/linux \
399         -DJAVA_AWT_INCLUDE_PATH:PATH=$JAVA_HOME/include \
400 %else
401         -DVTK_WRAP_JAVA:BOOL=OFF \
402 %endif
403         -DVTK_WRAP_PYTHON:BOOL=ON \
404         -DVTK_PYTHON_VERSION=3 \
405         %{?with_sip:-DVTK_WRAP_PYTHON_SIP:BOOL=ON} \
406         -DVTK_Group_Imaging:BOOL=ON \
407         -DVTK_Group_Qt:BOOL=ON \
408         -DVTK_Group_Rendering:BOOL=ON \
409         -DVTK_Group_StandAlone:BOOL=ON \
410         -DVTK_Group_Tk:BOOL=ON \
411         -DVTK_Group_Views:BOOL=ON \
412         -DModule_vtkFiltersReebGraph:BOOL=ON \
413         %{?with_ffmpeg:-DModule_vtkIOFFMPEG:BOOL=ON} \
414         -DModule_vtkIOGDAL:BOOL=ON \
415         -DModule_vtkIOGeoJSON:BOOL=ON \
416         -DModule_vtkIOMySQL:BOOL=ON \
417         -DModule_vtkIOODBC:BOOL=ON \
418         -DModule_vtkIOParallelExodus:BOOL=ON \
419         -DModule_vtkIOParallelLSDyna:BOOL=ON \
420         -DModule_vtkIOPostgreSQL:BOOL=ON \
421         -DModule_vtkIOVPIC:BOOL=ON \
422         -DModule_vtkIOXdmf2:BOOL=ON \
423         -DModule_vtkInfovisBoost:BOOL=ON \
424         -DModule_vtkInfovisBoostGraphAlgorithms:BOOL=ON \
425         -DModule_vtkRenderingFreeTypeFontConfig:BOOL=ON \
426         -DModule_vtkRenderingMatplotlib:BOOL=ON \
427         -DModule_vtkRenderingParallel:BOOL=ON
428 # TODO: -DModule_vtkAcceleratorsDax:BOOL=ON (BR: FindDax.cmake, maybe http://www.daxtoolkit.org/ ?)
429 # TODO: -DModule_vtkAcceleratorsPiston:BOOL=ON (on bcond, BR: CUDA)
430 # TODO: -DModule_vtkFiltersParallelFlowPaths:BOOL=ON (BR: MPI)
431 # TODO: -DModule_vtkFiltersParallelStatistics:BOOL=ON (BR: MPI)
432 # TODO: -DModule_vtkInfovisParallel:BOOL=ON (BR: MPI)
433 # TODO: -DModule_vtkRenderingParallelLIC:BOOL=ON (BR: MPI)
434
435 %{__make}
436 %{?with_doc:%{__make} DoxygenDoc}
437
438 %install
439 rm -rf $RPM_BUILD_ROOT
440 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ld.so.conf.d,%{_examplesdir}/%{name}-%{version}}
441
442 %{__make} -C build install \
443         DESTDIR=$RPM_BUILD_ROOT
444
445 # ld config
446 echo %{_libdir}/vtk > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
447
448 for f in $(cd build/ExternalData/Testing ; find Data -type l); do
449         install -Dp build/ExternalData/Testing/$f $RPM_BUILD_ROOT%{_datadir}/vtk-8.1/$f
450 done
451
452 # Install examples
453 for f in \
454 AmbientSpheres \
455 Arrays \
456 BalloonWidget \
457 BandedContours \
458 Cone \
459 Cone2 \
460 Cone3 \
461 Cone4 \
462 Cone5 \
463 Cone6 \
464 Cube \
465 Cylinder \
466 Delaunay3D \
467 Delaunay3DAlpha \
468 DiffuseSpheres \
469 DumpXMLFile \
470 FilledContours \
471 FixedPointVolumeRayCastMapperCT \
472 GPURenderDemo \
473 Generate2DAMRDataSetWithPulse \
474 Generate3DAMRDataSetWithPulse \
475 GenerateCubesFromLabels \
476 GenerateModelsFromLabels \
477 HierarchicalBoxPipeline \
478 ImageSlicing \
479 LabeledMesh \
480 Medical1 \
481 Medical2 \
482 Medical3 \
483 Medical4 \
484 MultiBlock \
485 ParticleReader \
486 RGrid \
487 SGrid \
488 SimpleView \
489 Slider \
490 Slider2D \
491 SpecularSpheres \
492 TubesWithVaryingRadiusAndColors \
493 finance ; do
494         install build/bin/$f $RPM_BUILD_ROOT%{_bindir}
495 done
496
497 # Install test binaries
498 for f in build/bin/*Tests build/bin/Test*; do
499         install $f $RPM_BUILD_ROOT%{_bindir}
500 done
501
502 %if %{with java}
503 install -p build/bin/VTKJavaExecutable $RPM_BUILD_ROOT%{_bindir}
504 %endif
505 install -p build/bin/vtkpython $RPM_BUILD_ROOT%{_bindir}
506
507 # unwanted doxygen files and misplaced verdict docs
508 %{?with_doc:%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/vtk-*/{doxygen,verdict}}
509
510 %clean
511 rm -rf $RPM_BUILD_ROOT
512
513 %post   -p /sbin/ldconfig
514 %postun -p /sbin/ldconfig
515
516 %post   qt -p /sbin/ldconfig
517 %postun qt -p /sbin/ldconfig
518
519 %post   java -p /sbin/ldconfig
520 %postun java -p /sbin/ldconfig
521
522 %post   python3 -p /sbin/ldconfig
523 %postun python3 -p /sbin/ldconfig
524
525 %files
526 %defattr(644,root,root,755)
527 %doc README.md vtkBanner.gif vtkLogo.ico Wrapping/Tools/README*
528 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
529 %dir %{_libdir}/vtk
530 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so.1
531 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so.1
532 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so.1
533 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2.so.1
534 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so.1
535 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so.1
536 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so.1
537 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so.1
538 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so.1
539 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so.1
540 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so.1
541 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so.1
542 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so.1
543 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so.1
544 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so.1
545 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL2.so.1
546 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so.1
547 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so.1
548 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so.1
549 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PSOpenGL2.so.1
550 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so.1
551 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so.1
552 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so.1
553 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL2.so.1
554 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so.1
555 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL2.so.1
556 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so.1
557 %attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so.1
558 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so.1
559 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so.1
560 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so.1
561 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so.1
562 %attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so.1
563 %attr(755,root,root) %{_libdir}/vtk/libvtkexodusII.so.1
564 %attr(755,root,root) %{_libdir}/vtk/libvtkgl2ps.so.1
565 %attr(755,root,root) %{_libdir}/vtk/libvtklibharu.so.1
566 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so.1
567 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so.1
568 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so.1
569 %attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so.1
570 %if %{with java}
571 %exclude %{_libdir}/vtk/libvtk*Java.so.1
572 %endif
573 %exclude %{_libdir}/vtk/libvtk*Python3?D.so.1
574 %exclude %{_libdir}/vtk/libvtkWrappingPython3?Core.so.1
575
576 %files devel
577 %defattr(644,root,root,755)
578 %doc Utilities/Upgrading/*
579 %attr(755,root,root) %{_bindir}/vtkWrapHierarchy
580 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so
581 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so
582 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so
583 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2.so
584 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so
585 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so
586 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so
587 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so
588 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so
589 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so
590 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so
591 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so
592 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so
593 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so
594 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so
595 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL2.so
596 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so
597 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so
598 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so
599 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PSOpenGL2.so
600 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so
601 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so
602 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so
603 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL2.so
604 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so
605 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL2.so
606 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so
607 %attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so
608 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so
609 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so
610 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so
611 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so
612 %attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so
613 %attr(755,root,root) %{_libdir}/vtk/libvtkexodusII.so
614 %attr(755,root,root) %{_libdir}/vtk/libvtkgl2ps.so
615 %attr(755,root,root) %{_libdir}/vtk/libvtklibharu.so
616 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so
617 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so
618 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so
619 %attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so
620 %if %{with java}
621 %exclude %{_libdir}/vtk/libvtk*Java.so
622 %endif
623 %exclude %{_libdir}/vtk/libvtk*Python3?D.so
624 %exclude %{_libdir}/vtk/libvtkWrappingPython3?Core.so
625 %{_libdir}/vtk/libvtkWrappingTools.a
626 %dir %{_includedir}/vtk
627 %{_includedir}/vtk/VPIC
628 %{_includedir}/vtk/DICOM*.h
629 %{_includedir}/vtk/DatabaseSchemaWith2Tables.h
630 %{_includedir}/vtk/LSDyna*.h
631 %{_includedir}/vtk/vtkexodusII
632 %{_includedir}/vtk/vtkgl2ps
633 %{_includedir}/vtk/vtkkwiml
634 %{_includedir}/vtk/vtklibharu
635 %{_includedir}/vtk/vtkmetaio
636 %{_includedir}/vtk/vtksys
637 %{_includedir}/vtk/vtkverdict
638 %{_includedir}/vtk/vtkxdmf2
639 %{_includedir}/vtk/vtk*.h
640 %{_includedir}/vtk/vtk*.txx
641 %exclude %{_includedir}/vtk/vtkEventQtSlotConnect.h
642 %exclude %{_includedir}/vtk/vtkGUISupportQt*.h
643 %if %{with java}
644 %exclude %{_includedir}/vtk/vtkJavaUtil.h
645 %exclude %{_includedir}/vtk/vtkWrappingJavaModule.h
646 %endif
647 %exclude %{_includedir}/vtk/vtkPython*.h
648 %exclude %{_includedir}/vtk/vtkQImageToImageSource.h
649 %exclude %{_includedir}/vtk/vtkQt*.h
650 %exclude %{_includedir}/vtk/vtkRenderingQtModule.h
651 %exclude %{_includedir}/vtk/vtkViewsQtModule.h
652 %{_libdir}/cmake/vtk
653
654 %files qt
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so.1
657 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so.1
658 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so.1
659 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so.1
660 %attr(755,root,root) %{_libdir}/qt5/plugins/designer/libQVTKWidgetPlugin.so
661
662 %files qt-devel
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so
665 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so
666 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so
667 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so
668 %{_includedir}/vtk/QFilterTreeProxyModel.h
669 %{_includedir}/vtk/QVTK*.h
670 %{_includedir}/vtk/vtkEventQtSlotConnect.h
671 %{_includedir}/vtk/vtkGUISupportQt*.h
672 %{_includedir}/vtk/vtkQImageToImageSource.h
673 %{_includedir}/vtk/vtkQt*.h
674 %{_includedir}/vtk/vtkRenderingQtModule.h
675 %{_includedir}/vtk/vtkViewsQtModule.h
676
677 %if %{with java}
678 %files java
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_bindir}/VTKJavaExecutable
681 %attr(755,root,root) %{_bindir}/vtkParseJava
682 %attr(755,root,root) %{_bindir}/vtkWrapJava
683 # common library
684 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so.1
685 # java modules
686 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCoreJava.so
687 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*Java.so
688 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryJava.so
689 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2Java.so
690 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*Java.so
691 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCoreJava.so
692 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*Java.so
693 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*Java.so
694 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*Java.so
695 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*Java.so
696 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExampleJava.so
697 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCoreJava.so
698 %attr(755,root,root) %{_libdir}/vtk/libvtkRendering*Java.so
699 %attr(755,root,root) %{_libdir}/vtk/libvtkTestingRenderingJava.so
700 %attr(755,root,root) %{_libdir}/vtk/libvtkViews*Java.so
701 %{_libdir}/vtk/vtk.jar
702
703 %files java-devel
704 %defattr(644,root,root,755)
705 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so
706 %{_includedir}/vtk/vtkJavaUtil.h
707 %{_includedir}/vtk/vtkWrappingJavaModule.h
708 %endif
709
710 %files python3
711 %defattr(644,root,root,755)
712 %doc Wrapping/Python/README*
713 %attr(755,root,root) %{_bindir}/vtkWrapPython
714 %attr(755,root,root) %{_bindir}/vtkWrapPythonInit
715 %attr(755,root,root) %{_bindir}/vtkpython
716 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python3?D.so.1
717 %attr(755,root,root) %{_libdir}/vtk/libvtkPythonContext2D.so.1
718 %attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so.1
719 # RenderingMatplotlib requires PythonInterpreter
720 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so.1
721 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingPythonTkWidgets-8.2.so
722 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython3?Core.so.1
723 %dir %{py3_sitedir}/vtk.py
724 %dir %{py3_sitedir}/vtkmodules
725 %{py3_sitedir}/vtkmodules/*.py
726 %{py3_sitedir}/vtkmodules/__pycache__
727 %dir %{py3_sitedir}/vtkmodules/gtk
728 %{py3_sitedir}/vtkmodules/gtk/*.py
729 %{py3_sitedir}/vtkmodules/gtk/__pycache__
730 %dir %{py3_sitedir}/vtkmodules/numpy_interface
731 %{py3_sitedir}/vtkmodules/numpy_interface/*.py
732 %{py3_sitedir}/vtkmodules/numpy_interface/__pycache__
733 %dir %{py3_sitedir}/vtkmodules/qt
734 %{py3_sitedir}/vtkmodules/qt/*.py
735 %{py3_sitedir}/vtkmodules/qt/__pycache__
736 %dir %{py3_sitedir}/vtkmodules/qt4
737 %{py3_sitedir}/vtkmodules/qt4/*.py
738 %{py3_sitedir}/vtkmodules/qt4/__pycache__
739 %dir %{py3_sitedir}/vtkmodules/test
740 %{py3_sitedir}/vtkmodules/test/*.py
741 %{py3_sitedir}/vtkmodules/test/__pycache__
742 %dir %{py3_sitedir}/vtkmodules/tk
743 %{py3_sitedir}/vtkmodules/tk/__pycache__
744 %{py3_sitedir}/vtkmodules/tk/*.py
745 %dir %{py3_sitedir}/vtkmodules/util
746 %{py3_sitedir}/vtkmodules/util/*.py
747 %{py3_sitedir}/vtkmodules/util/__pycache__
748 %dir %{py3_sitedir}/vtkmodules/wx
749 %{py3_sitedir}/vtkmodules/wx/*.py
750 %{py3_sitedir}/vtkmodules/wx/__pycache__
751 %attr(755,root,root) %{py3_sitedir}/vtkmodules/vtk*Python.so
752
753 %files python3-devel
754 %defattr(644,root,root,755)
755 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python3?D.so
756 %attr(755,root,root) %{_libdir}/vtk/libvtkPythonContext2D.so
757 %attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so
758 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so
759 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython3?Core.so
760 %{_includedir}/vtk/PyVTK*.h
761 %{_includedir}/vtk/vtkPython*.h
762
763 %files test-suite
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_bindir}/*Tests
766 %attr(755,root,root) %{_bindir}/Test*
767
768 %files examples
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{_bindir}/AmbientSpheres
771 %attr(755,root,root) %{_bindir}/Arrays
772 %attr(755,root,root) %{_bindir}/Cone
773 %attr(755,root,root) %{_bindir}/Cone2
774 %attr(755,root,root) %{_bindir}/Cone3
775 %attr(755,root,root) %{_bindir}/Cone4
776 %attr(755,root,root) %{_bindir}/Cone5
777 %attr(755,root,root) %{_bindir}/Cone6
778 %attr(755,root,root) %{_bindir}/Cube
779 %attr(755,root,root) %{_bindir}/Cylinder
780 %attr(755,root,root) %{_bindir}/DiffuseSpheres
781 %attr(755,root,root) %{_bindir}/HierarchicalBoxPipeline
782 %attr(755,root,root) %{_bindir}/Medical1
783 %attr(755,root,root) %{_bindir}/Medical2
784 %attr(755,root,root) %{_bindir}/Medical3
785 %attr(755,root,root) %{_bindir}/Medical4
786 %attr(755,root,root) %{_bindir}/MultiBlock
787 %attr(755,root,root) %{_bindir}/RGrid
788 %attr(755,root,root) %{_bindir}/SGrid
789 %attr(755,root,root) %{_bindir}/SimpleView
790 %attr(755,root,root) %{_bindir}/SpecularSpheres
791 %attr(755,root,root) %{_bindir}/finance
792 %attr(755,root,root) %{_bindir}/BalloonWidget
793 %attr(755,root,root) %{_bindir}/BandedContours
794 %attr(755,root,root) %{_bindir}/Delaunay3D
795 %attr(755,root,root) %{_bindir}/Delaunay3DAlpha
796 %attr(755,root,root) %{_bindir}/DumpXMLFile
797 %attr(755,root,root) %{_bindir}/FilledContours
798 %attr(755,root,root) %{_bindir}/FixedPointVolumeRayCastMapperCT
799 %attr(755,root,root) %{_bindir}/GPURenderDemo
800 %attr(755,root,root) %{_bindir}/Generate2DAMRDataSetWithPulse
801 %attr(755,root,root) %{_bindir}/Generate3DAMRDataSetWithPulse
802 %attr(755,root,root) %{_bindir}/GenerateCubesFromLabels
803 %attr(755,root,root) %{_bindir}/GenerateModelsFromLabels
804 %attr(755,root,root) %{_bindir}/ImageSlicing
805 %attr(755,root,root) %{_bindir}/LabeledMesh
806 %attr(755,root,root) %{_bindir}/ParticleReader
807 %attr(755,root,root) %{_bindir}/Slider
808 %attr(755,root,root) %{_bindir}/Slider2D
809 %attr(755,root,root) %{_bindir}/TubesWithVaryingRadiusAndColors
810 %{_examplesdir}/%{name}-%{version}
811
812 %files data
813 %defattr(644,root,root,755)
814 %dir %{_datadir}/vtk-8.1
815 %{_datadir}/vtk-8.1/Data
This page took 0.143178 seconds and 2 git commands to generate.