]> git.pld-linux.org Git - packages/vtk.git/blame_incremental - vtk.spec
- rebuild with boost 1.63.0
[packages/vtk.git] / vtk.spec
... / ...
CommitLineData
1# TODO:
2# - handle VTK_USE_MPEG2_ENCODER (see CMakeLists.txt)
3# - handle MPI and VTK_USE_PARALLEL_BGL (Parallel Boost Graph Library, BR: boost >= 1.40)
4# - more system libraries? (check for VTK_THIRD_PARTY_SUBDIR in Utilities/CMakeLists.txt)
5# - CUDA for Accelerators/Piston (on bcond)
6# - NVCtrlLib for Rendering/OpenGL (on bcond)
7# - VTK_USE_SYSTEM_XDMF2=ON ? (but our xdmf-devel seems not compatible)
8# - python bcond?
9#
10# Conditional build
11%bcond_without java # Java wrappers
12%bcond_without ffmpeg # FFMPEG .avi saving support
13%bcond_with OSMesa # build with OSMesa (https://bugzilla.redhat.com/show_bug.cgi?id=744434)
14%bcond_with system_proj # use system PROJ.4 (needs 4.3 with exposed internals, not ready for 4.4+)
15%bcond_with system_gl2ps # use system gl2ps (VTK currently is carrying local modifications to gl2ps)
16
17Summary: Toolkit for 3D computer graphics, image processing, and visualization
18Summary(pl.UTF-8): Zestaw narzędzi do trójwymiarowej grafiki, przetwarzania obrazu i wizualizacji
19Name: vtk
20Version: 7.1.0
21Release: 2
22License: BSD
23Group: Libraries
24Source0: http://www.vtk.org/files/release/7.1/VTK-%{version}.tar.gz
25# Source0-md5: a7e814c1db503d896af72458c2d0228f
26Source1: http://www.vtk.org/files/release/7.1/VTKData-%{version}.tar.gz
27# Source1-md5: 551786cdcb59fada678ecf0475cfcf55
28Patch0: vtk-abi.patch
29URL: http://www.vtk.org/
30%{?with_OSMesa:BuildRequires: Mesa-libOSMesa-devel}
31BuildRequires: OpenGL-GLX-devel
32BuildRequires: OpenGL-devel
33BuildRequires: QtCore-devel >= 4.5.0
34BuildRequires: QtDesigner-devel >= 4.5.0
35BuildRequires: QtGui-devel >= 4.5.0
36BuildRequires: QtNetwork-devel >= 4.5.0
37BuildRequires: QtOpenGL-devel >= 4.5.0
38BuildRequires: QtSql-devel >= 4.5.0
39BuildRequires: QtWebKit-devel >= 4.5.0
40BuildRequires: QtXmlPatterns-devel >= 4.5.0
41BuildRequires: R
42BuildRequires: boost-devel >= 1.39
43BuildRequires: cmake >= 2.8.8
44BuildRequires: doxygen
45BuildRequires: expat-devel
46%{?with_ffmpeg:BuildRequires: ffmpeg-devel}
47BuildRequires: fontconfig-devel
48BuildRequires: freetype-devel >= 2
49BuildRequires: gdal-devel
50%{?with_system_gl2ps:BuildRequires: gl2ps-devel >= 1.3.8}
51BuildRequires: gnuplot
52BuildRequires: graphviz
53BuildRequires: hdf5-devel
54%if %{with java}
55BuildRequires: jdk >= 1.5
56BuildRequires: jpackage-utils
57%endif
58BuildRequires: jsoncpp-devel
59BuildRequires: libjpeg-devel
60BuildRequires: libogg-devel
61BuildRequires: libpng-devel
62BuildRequires: libstdc++-devel
63BuildRequires: libtheora-devel
64BuildRequires: libtiff-devel
65BuildRequires: libxml2-devel >= 2
66BuildRequires: motif-devel
67BuildRequires: mysql-devel
68BuildRequires: netcdf-cxx-devel >= 4
69# some code using it exists (Domains/Chemistry), but is not included in cmakefiles
70#BuildRequires: openqube-devel
71BuildRequires: perl-base
72BuildRequires: postgresql-devel
73%{?with_system_proj:BuildRequires: proj-devel >= 4.3, proj-devel < 4.4}
74BuildRequires: python-devel >= 2
75BuildRequires: python-sip-devel
76BuildRequires: qt4-build >= 4.5.0
77BuildRequires: qt4-qmake >= 4.5.0
78BuildRequires: rpmbuild(macros) >= 1.605
79BuildRequires: sip
80BuildRequires: sip-PyQt4
81BuildRequires: tcl-devel
82BuildRequires: tk-devel
83BuildRequires: unixODBC-devel
84BuildRequires: wget
85BuildRequires: xorg-lib-libICE-devel
86BuildRequires: xorg-lib-libSM-devel
87BuildRequires: xorg-lib-libX11-devel
88BuildRequires: xorg-lib-libXScrnSaver-devel
89BuildRequires: xorg-lib-libXext-devel
90BuildRequires: xorg-lib-libXft-devel
91BuildRequires: xorg-lib-libXt-devel
92BuildRequires: zlib-devel
93BuildConflicts: libXNVCtrl-devel
94%{?with_system_gl2ps:Requires: gl2ps >= 1.3.8}
95BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97%define skip_post_check_so lib.*Python.*\.so.*
98
99%description
100The Visualization ToolKit (VTK) is an object oriented software system
101for 3D computer graphics, image processing, and visualization. VTK
102includes a textbook, a C++ class library, and several interpreted
103interface layers including Tcl/Tk, Java, and Python. VTK supports a
104wide variety of visualization algorithms including scalar, vector,
105tensor, texture, and volumetric methods. It also supports advanced
106modeling techniques like implicit modeling, polygon reduction, mesh
107smoothing, cutting, contouring, and Delaunay triangulation. Moreover,
108dozens of imaging algorithms have been integrated into the system.
109This allows mixing 2D imaging / 3D graphics algorithms and data.
110
111%description -l pl.UTF-8
112Visualization TookKit (VTK) to obiektowo zorientowany system
113oprogramowania do trójwymiarowej grafiki komputerowej, przetwarzania
114obrazu i wizualizacji. VTK zawiera książkę, bibliotekę klas C++ oraz
115kilka interpretowanych warstw interfejsów, w tym dla Tcl/Tk, Javy i
116Pythona. VTK obsługuje szeroki zakres algorytmów wizualizacji, w tym
117metody skalarne, wektorowe, tensorowe, teksturowe i wolumetryczne.
118Obsługuje także zaawansowane techniki modelowania, takie jak
119modelowanie implicite, redukcja wielokątów, wygładzanie siatki,
120przycinanie, konturowanie i triangulacja Delaunaya. Co więcej, wiele
121algorytmów obrazowania zostało zintegrowanych z systemem. Pozwala to
122na mieszanie algorytmów obrazowania 2D i grafiki 3D.
123
124%package devel
125Summary: VTK header files for building C++ code
126Summary(pl.UTF-8): Pliki nagłówkowe VTK dla C++
127Group: Development
128Requires: %{name} = %{version}-%{release}
129Requires: libstdc++-devel
130
131%description devel
132This provides the VTK header files required to compile C++ programs
133that use VTK to do 3D visualisation.
134
135%description devel -l pl.UTF-8
136Ten pakiet dostarcza pliki nagłówkowe VTK do kompilowania programów
137C++ używających VTK do wizualizacji 3D.
138
139%package qt
140Summary: Qt bindings and Qt Designer plugin for VTK
141Summary(pl.UTF-8): Wiązania Qt oraz wtyczka Qt Designera do VTK
142Group: X11/Libraries
143Requires: %{name} = %{version}-%{release}
144Requires: QtCore >= 4.5.0
145Requires: QtGui >= 4.5.0
146Requires: QtNetwork >= 4.5.0
147Requires: QtOpenGL >= 4.5.0
148Requires: QtSql >= 4.5.0
149Requires: QtWebKit >= 4.5.0
150
151%description qt
152Qt bindings and Qt Designer plugin for VTK.
153
154%description qt -l pl.UTF-8
155Wiązania Qt oraz wtyczka Qt Designera do VTK.
156
157%package qt-devel
158Summary: Header files for VTK Qt bindings
159Summary(pl.UTF-8): Pliki nagłówkowe wiązań Qt do VTK
160Group: X11/Development/Libraries
161Requires: %{name}-devel = %{version}-%{release}
162Requires: %{name}-qt = %{version}-%{release}
163Requires: QtCore-devel >= 4.5.0
164Requires: QtGui-devel >= 4.5.0
165Requires: QtOpenGL-devel >= 4.5.0
166Requires: QtSql-devel >= 4.5.0
167
168%description qt-devel
169Header files for VTK Qt bindings.
170
171%description qt-devel -l pl.UTF-8
172Pliki nagłówkowe wiązań Qt do VTK.
173
174%package java
175Summary: Java bindings for VTK
176Summary(pl.UTF-8): Wiązania Javy do VTK
177Group: Development/Languages/Java
178Requires: %{name} = %{version}-%{release}
179# or separate qt parts?
180Requires: %{name}-qt = %{version}-%{release}
181
182%description java
183This package contains Java bindings for VTK.
184
185%description java -l pl.UTF-8
186Ten pakiet zawiera wiązania Javy do VTK.
187
188%package java-devel
189Summary: Header files for Java VTK binding
190Summary(pl.UTF-8): Pliki nagłówkowe wiązania Javy do VTK
191Group: Development/Libraries
192Requires: %{name}-devel = %{version}-%{release}
193Requires: %{name}-java = %{version}-%{release}
194# <jni.h>
195Requires: jdk
196
197%description java-devel
198Header files for Java VTK binding.
199
200%description java-devel -l pl.UTF-8
201Pliki nagłówkowe wiązania Javy do VTK.
202
203%package python
204Summary: Python bindings for VTK
205Summary(pl.UTF-8): Wiązania Pythona do VTK
206Group: Libraries
207Requires: %{name} = %{version}-%{release}
208# or separate qt parts again?
209Requires: %{name}-qt = %{version}-%{release}
210Obsoletes: vtk-python-qt < 6.0.0-1
211Obsoletes: vtk-python-sip < 6.0.0-1
212
213%description python
214This package contains Python bindings for VTK.
215
216%description python -l pl.UTF-8
217Ten pakiet zawiera wiązania Pythona do VTK.
218
219%package python-devel
220Summary: Header files for Python VTK binding
221Summary(pl.UTF-8): Pliki nagłówkowe wiązania Pythona do VTK
222Group: Development/Libraries
223Requires: %{name}-devel = %{version}-%{release}
224Requires: %{name}-python = %{version}-%{release}
225Requires: python-devel
226
227%description python-devel
228Header files for Python VTK binding.
229
230%description python-devel -l pl.UTF-8
231Pliki nagłówkowe wiązania Pythona do VTK.
232
233%package tcl
234Summary: Tcl bindings for VTK
235Summary(pl.UTF-8): Wiązania języka Tcl do VTK
236Group: Libraries
237Requires: %{name} = %{version}-%{release}
238# or separate qt parts?
239Requires: %{name}-qt = %{version}-%{release}
240
241%description tcl
242This package contains Tcl bindings for VTK.
243
244%description tcl -l pl.UTF-8
245Ten pakiet zawiera wiązania języka Tcl do VTK.
246
247%package tcl-devel
248Summary: Header files for Tcl VTK bindings
249Summary(pl.UTF-8): Pliki nagłówkowe wiązania języka Tcl do VTK
250Group: Development/Libraries
251Requires: %{name}-devel = %{version}-%{release}
252Requires: %{name}-tcl = %{version}-%{release}
253Requires: tcl-devel
254Requires: tk-devel
255
256%description tcl-devel
257Header files for Tcl VTK bindings.
258
259%description tcl-devel -l pl.UTF-8
260Pliki nagłówkowe wiązania języka Tcl do VTK.
261
262%package examples
263Summary: C++, Tcl and Python example programs/scripts for VTK
264Summary(pl.UTF-8): Przykładowe programy/skrypty w C++, Tcl-u i Pythonie dla VTK
265Group: Development/Libraries
266Requires: %{name} = %{version}-%{release}
267Requires: %{name}-data = %{version}-%{release}
268
269%description examples
270This package contains all the examples from the VTK source. To compile
271the C++ examples you will need to install the vtk-devel package as
272well. The Python and Tcl examples can be run with the corresponding
273packages (vtk-python, vtk-tcl).
274
275%description examples -l pl.UTF-8
276Ten pakiet zawiera wszystkie przykłady ze źródeł VTK. Do skompilowania
277przykładów w C++ trzeba doinstalować pakiet vtk-devel. Przykłady w
278Pythonie i Tcl-u można uruchamiać przy użyciu odpowiednich pakietów
279(vtk-python, vtk-tcl).
280
281%package test-suite
282Summary: Test programs for VTK
283Summary(pl.UTF-8): Programy testowe dla VTK
284Group: Development/Libraries
285Requires: %{name} = %{version}-%{release}
286Requires: %{name}-data = %{version}-%{release}
287
288%description test-suite
289This package contains all testing programs from the VTK source. The
290source code of these programs can be found in the vtk-examples
291package.
292
293%description test-suite -l pl.UTF-8
294Ten pakiet zawiera wszystkie programy testowe ze źródeł VTK. Kod
295źródłowy tych programów można znaleźć w pakiecie vtk-examples.
296
297%package data
298Summary: Data files for VTK
299Summary(pl.UTF-8): Pliki danych dla VTK
300Group: Development/Libraries
301%if "%{_rpmversion}" >= "5"
302BuildArch: noarch
303%endif
304
305%description data
306This package contains all the data from the VTKData repository. These
307data are required to run various examples from the vtk-examples
308package.
309
310%description data -l pl.UTF-8
311Ten pakiet zawiera wszystkie dane z repozytorium VTKData. Dane te są
312potrzebne do uruchamiania różnych przykładów z pakietu vtk-examples.
313
314%prep
315%setup -q -n VTK-%{version} -b 1
316%patch0 -p1
317
318# Replace relative path ../../../VTKData with destination filesystem path
319grep -Erl '(\.\./)+VTKData' Examples | xargs \
320 perl -pi -e 's,(\.\./)+VTKData,%{_datadir}/vtk-7.1,g'
321
322# Save an unbuilt copy of the Example's sources for %doc
323mkdir vtk-examples
324cp -a Examples vtk-examples
325# Don't ship Win32 examples
326%{__rm} -r vtk-examples/Examples/GUI/Win32
327find vtk-examples -type f | xargs chmod -R a-x
328
329%build
330export CFLAGS="%{rpmcflags} -D_UNICODE -DHAVE_UINTPTR_T"
331export CXXFLAGS="%{rpmcxxflags} -D_UNICODE -DHAVE_UINTPTR_T"
332%if %{with java}
333export JAVA_HOME=%{java_home}
334%ifarch x32
335# getting "java.lang.OutOfMemoryError: Java heap space" during the build
336export JAVA_TOOL_OPTIONS=-Xmx2048m
337%endif
338%endif
339
340# handle cmake & ccache
341# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmake
342# ASM fix: http://lists.busybox.net/pipermail/buildroot/2013-March/069436.html
343if [[ "%{__cc}" = *ccache* ]]; then
344 cc="%{__cc}"
345 cxx="%{__cxx}"
346 ccache="
347 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
348 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
349 -DCMAKE_ASM_COMPILER="${cc#ccache }" \
350 "
351else
352 ccache="
353 -DCMAKE_C_COMPILER="%{__cc}" \
354 -DCMAKE_CXX_COMPILER="%{__cxx}" \
355 -DCMAKE_ASM_COMPILER="%{__cc}" \
356 "
357fi
358
359mkdir -p build
360cd build
361%cmake .. \
362 $ccache \
363 -Wno-dev \
364 -DBUILD_DOCUMENTATION:BOOL=ON \
365 -DBUILD_EXAMPLES:BOOL=ON \
366 -DBUILD_SHARED_LIBS:BOOL=ON \
367 -DBUILD_TESTING:BOOL=ON \
368 -DCMAKE_SKIP_RPATH:BOOL=ON \
369 -DOPENGL_INCLUDE_PATH:PATH=%{_includedir}/GL \
370 -DPYTHON_INCLUDE_PATH:PATH=%{py_incdir} \
371 -DPYTHON_LIBRARY:FILEPATH=%{_libdir}/libpython%{py_ver}.so \
372 -DPYTHON_UTIL_LIBRARY:PATH=%{_libdir}/libutil.so \
373 -DTCL_INCLUDE_PATH:PATH=%{_includedir} \
374 -DTCL_LIBRARY:PATH=%{_libdir}/libtcl.so \
375 -DTK_INCLUDE_PATH:PATH=%{_includedir} \
376 -DTK_LIBRARY:PATH=%{_libdir}/libtk.so \
377 -DVTK_DATA_ROOT:PATH=%{_datadir}/vtk-7.1 \
378 -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
379 -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/vtk \
380 -DVTK_INSTALL_INCLUDE_DIR:PATH=include/vtk \
381 -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/vtk \
382 -DVTK_INSTALL_PACKAGE_DIR:PATH=%{_lib}/cmake/vtk \
383 -DVTK_INSTALL_TCL_DIR:PATH=share/tcl%{tcl_version}/vtk \
384 -DVTK_INSTALL_PYTHON_MODULE_DIR:PATH=%{py_sitedir} \
385 -DVTK_INSTALL_QT_DIR=/%{_lib}/qt4/plugins/designer \
386 -DVTK_FFMPEG_HAS_OLD_HEADER:BOOL=OFF \
387 %{?with_OSMesa:-DVTK_OPENGL_HAS_OSMESA:BOOL=ON} \
388 -DVTK_WRAP_PYTHON:BOOL=ON \
389 -DVTK_PYTHON_SETUP_ARGS="--prefix=/usr --root=$RPM_BUILD_ROOT" \
390 -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
391 -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
392 -DVTK_USE_RENDERING:BOOL=ON \
393 -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
394 -DVTK_USE_SYSTEM_XDMF2:BOOL=OFF \
395 %{!?with_system_proj:-DVTK_USE_SYSTEM_LIBPROJ4:BOOL=OFF} \
396 %{!?with_system_gl2ps:-DVTK_USE_SYSTEM_GL2PS:BOOL=OFF} \
397%if %{with java}
398 -DVTK_WRAP_JAVA:BOOL=ON \
399 -DJAVA_INCLUDE_PATH:PATH=$JAVA_HOME/include \
400 -DJAVA_INCLUDE_PATH2:PATH=$JAVA_HOME/include/linux \
401 -DJAVA_AWT_INCLUDE_PATH:PATH=$JAVA_HOME/include \
402%else
403 -DVTK_WRAP_JAVA:BOOL=OFF \
404%endif
405 -DVTK_WRAP_PYTHON:BOOL=ON \
406 %{?with_sip:-DVTK_WRAP_PYTHON_SIP:BOOL=ON} \
407 -DVTK_WRAP_TCL:BOOL=ON \
408 -DVTK_Group_Imaging:BOOL=ON \
409 -DVTK_Group_Qt:BOOL=ON \
410 -DVTK_Group_Rendering:BOOL=ON \
411 -DVTK_Group_StandAlone:BOOL=ON \
412 -DVTK_Group_Tk:BOOL=ON \
413 -DVTK_Group_Views:BOOL=ON \
414 -DModule_vtkFiltersReebGraph:BOOL=ON \
415 -DModule_vtkFiltersStatisticsGnuR:BOOL=ON \
416 %{?with_ffmpeg:-DModule_vtkIOFFMPEG:BOOL=ON} \
417 -DModule_vtkIOGDAL:BOOL=ON \
418 -DModule_vtkIOGeoJSON:BOOL=ON \
419 -DModule_vtkIOMySQL:BOOL=ON \
420 -DModule_vtkIOODBC:BOOL=ON \
421 -DModule_vtkIOParallelExodus:BOOL=ON \
422 -DModule_vtkIOParallelLSDyna:BOOL=ON \
423 -DModule_vtkIOPostgreSQL:BOOL=ON \
424 -DModule_vtkIOVPIC:BOOL=ON \
425 -DModule_vtkIOXdmf2:BOOL=ON \
426 -DModule_vtkInfovisBoost:BOOL=ON \
427 -DModule_vtkInfovisBoostGraphAlgorithms:BOOL=ON \
428 -DModule_vtkRenderingFreeTypeFontConfig:BOOL=ON \
429 -DModule_vtkRenderingMatplotlib:BOOL=ON \
430 -DModule_vtkRenderingParallel:BOOL=ON
431# TODO: -DModule_vtkAcceleratorsDax:BOOL=ON (BR: FindDax.cmake, maybe http://www.daxtoolkit.org/ ?)
432# TODO: -DModule_vtkAcceleratorsPiston:BOOL=ON (on bcond, BR: CUDA)
433# TODO: -DModule_vtkFiltersParallelFlowPaths:BOOL=ON (BR: MPI)
434# TODO: -DModule_vtkFiltersParallelStatistics:BOOL=ON (BR: MPI)
435# TODO: -DModule_vtkInfovisParallel:BOOL=ON (BR: MPI)
436# TODO: -DModule_vtkRenderingParallelLIC:BOOL=ON (BR: MPI)
437
438%{__make}
439
440%install
441rm -rf $RPM_BUILD_ROOT
442install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ld.so.conf.d,%{_examplesdir}/%{name}-%{version}}
443
444%{__make} -C build install \
445 DESTDIR=$RPM_BUILD_ROOT
446
447# ld config
448echo %{_libdir}/vtk > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
449
450for f in $(cd build/ExternalData/Testing ; find Data -type l); do
451 install -Dp build/ExternalData/Testing/$f $RPM_BUILD_ROOT%{_datadir}/vtk-7.1/$f
452done
453
454# Install examples
455for f in \
456AmbientSpheres \
457Arrays \
458BalloonWidget \
459BandedContours \
460Cone \
461Cone2 \
462Cone3 \
463Cone4 \
464Cone5 \
465Cone6 \
466Cube \
467Cylinder \
468Delaunay3D \
469Delaunay3DAlpha \
470DiffuseSpheres \
471DumpXMLFile \
472FilledContours \
473FixedPointVolumeRayCastMapperCT \
474GPURenderDemo \
475Generate2DAMRDataSetWithPulse \
476Generate3DAMRDataSetWithPulse \
477GenerateCubesFromLabels \
478GenerateModelsFromLabels \
479HierarchicalBoxPipeline \
480ImageSlicing \
481LabeledMesh \
482Medical1 \
483Medical2 \
484Medical3 \
485Medical4 \
486MultiBlock \
487ParticleReader \
488RGrid \
489SGrid \
490SimpleView \
491Slider \
492Slider2D \
493SpecularSpheres \
494TubesWithVaryingRadiusAndColors \
495finance ; do
496 install build/bin/$f $RPM_BUILD_ROOT%{_bindir}
497done
498
499# Install test binaries
500for f in build/bin/*Tests build/bin/Test*; do
501 install $f $RPM_BUILD_ROOT%{_bindir}
502done
503
504%if %{with java}
505install -p build/bin/VTKJavaExecutable $RPM_BUILD_ROOT%{_bindir}
506%endif
507install -p build/bin/vtkpython $RPM_BUILD_ROOT%{_bindir}
508
509# unwanted doxygen files and misplaced verdict docs
510%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/vtk-7.1/{doxygen,verdict}
511
512# only *.pyc are built by default, add *.pyo
513%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/vtk
514%py_postclean
515
516%clean
517rm -rf $RPM_BUILD_ROOT
518
519%post -p /sbin/ldconfig
520%postun -p /sbin/ldconfig
521
522%post qt -p /sbin/ldconfig
523%postun qt -p /sbin/ldconfig
524
525%post java -p /sbin/ldconfig
526%postun java -p /sbin/ldconfig
527
528%post python -p /sbin/ldconfig
529%postun python -p /sbin/ldconfig
530
531%post tcl -p /sbin/ldconfig
532%postun tcl -p /sbin/ldconfig
533
534%files
535%defattr(644,root,root,755)
536%doc README.md vtkLogo.jpg vtkBanner.gif Wrapping/Tools/README*
537%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
538%dir %{_libdir}/vtk
539%attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so.1
540%attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so.1
541%attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so.1
542%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2.so.1
543%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so.1
544%attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so.1
545%attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so.1
546%attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so.1
547%attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so.1
548%attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so.1
549%attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so.1
550%attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so.1
551%attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so.1
552%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so.1
553%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so.1
554%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL2.so.1
555%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so.1
556%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so.1
557%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so.1
558%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PSOpenGL2.so.1
559%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so.1
560%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so.1
561%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so.1
562%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL2.so.1
563%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so.1
564%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL2.so.1
565%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so.1
566%attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so.1
567%attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so.1
568%attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so.1
569%attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so.1
570%attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so.1
571%attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so.1
572%attr(755,root,root) %{_libdir}/vtk/libvtkalglib.so.1
573%attr(755,root,root) %{_libdir}/vtk/libvtkexoIIc.so.1
574%attr(755,root,root) %{_libdir}/vtk/libvtkgl2ps.so.1
575%attr(755,root,root) %{_libdir}/vtk/libvtkglew.so.1
576%attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so.1
577%attr(755,root,root) %{_libdir}/vtk/libvtkproj4.so.1
578%attr(755,root,root) %{_libdir}/vtk/libvtksqlite.so.1
579%attr(755,root,root) %{_libdir}/vtk/libvtksys.so.1
580%attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so.1
581%attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so.1
582%if %{with java}
583%exclude %{_libdir}/vtk/libvtk*Java.so.1
584%endif
585%exclude %{_libdir}/vtk/libvtk*Python2?D.so.1
586%exclude %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
587%exclude %{_libdir}/vtk/libvtk*TCL.so.1
588
589%files devel
590%defattr(644,root,root,755)
591%doc Utilities/Upgrading/*
592%attr(755,root,root) %{_bindir}/vtkEncodeString
593%attr(755,root,root) %{_bindir}/vtkHashSource
594%attr(755,root,root) %{_bindir}/vtkWrapHierarchy
595%attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so
596%attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so
597%attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so
598%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2.so
599%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so
600%attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so
601%attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so
602%attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so
603%attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so
604%attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so
605%attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so
606%attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so
607%attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so
608%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so
609%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so
610%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL2.so
611%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so
612%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so
613%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so
614%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PSOpenGL2.so
615%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so
616%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so
617%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so
618%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL2.so
619%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so
620%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL2.so
621%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so
622%attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so
623%attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so
624%attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so
625%attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so
626%attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so
627%attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so
628%attr(755,root,root) %{_libdir}/vtk/libvtkalglib.so
629%attr(755,root,root) %{_libdir}/vtk/libvtkexoIIc.so
630%attr(755,root,root) %{_libdir}/vtk/libvtkgl2ps.so
631%attr(755,root,root) %{_libdir}/vtk/libvtkglew.so
632%attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so
633%attr(755,root,root) %{_libdir}/vtk/libvtkproj4.so
634%attr(755,root,root) %{_libdir}/vtk/libvtksqlite.so
635%attr(755,root,root) %{_libdir}/vtk/libvtksys.so
636%attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so
637%attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so
638%if %{with java}
639%exclude %{_libdir}/vtk/libvtk*Java.so
640%endif
641%exclude %{_libdir}/vtk/libvtk*Python2?D.so
642%exclude %{_libdir}/vtk/libvtkWrappingPython2?Core.so
643%exclude %{_libdir}/vtk/libvtk*TCL.so
644%{_libdir}/vtk/libvtkWrappingTools.a
645%dir %{_includedir}/vtk
646%{_includedir}/vtk/VPIC
647%{_includedir}/vtk/DICOM*.h
648%{_includedir}/vtk/DatabaseSchemaWith2Tables.h
649%{_includedir}/vtk/alglib
650%{_includedir}/vtk/vtkmetaio
651%{_includedir}/vtk/vtkverdict
652%{_includedir}/vtk/vtksqlite
653%{_includedir}/vtk/vtksys
654%{_includedir}/vtk/vtkxdmf2
655%{_includedir}/vtk/vtkgl2ps
656%{_includedir}/vtk/vtkglew
657%{_includedir}/vtk/vtkkwiml
658%{_includedir}/vtk/vtk*.h
659%{_includedir}/vtk/vtk*.txx
660%exclude %{_includedir}/vtk/vtkEventQtSlotConnect.h
661%exclude %{_includedir}/vtk/vtkGUISupportQt*.h
662%if %{with java}
663%exclude %{_includedir}/vtk/vtkJavaUtil.h
664%exclude %{_includedir}/vtk/vtkWrappingJavaModule.h
665%endif
666%exclude %{_includedir}/vtk/vtkPython*.h
667%exclude %{_includedir}/vtk/vtkQImageToImageSource.h
668%exclude %{_includedir}/vtk/vtkQt*.h
669%exclude %{_includedir}/vtk/vtkRenderingQtModule.h
670%exclude %{_includedir}/vtk/vtkTcl*.h
671%exclude %{_includedir}/vtk/vtkTk*.h
672%exclude %{_includedir}/vtk/vtkViewsQtModule.h
673%{_libdir}/cmake/vtk
674
675%files qt
676%defattr(644,root,root,755)
677%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so.1
678%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so.1
679%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so.1
680%attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so.1
681%attr(755,root,root) %{_libdir}/qt4/plugins/designer/libQVTKWidgetPlugin.so
682
683%files qt-devel
684%defattr(644,root,root,755)
685%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so
686%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so
687%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so
688%attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so
689%{_includedir}/vtk/QFilterTreeProxyModel.h
690%{_includedir}/vtk/QVTK*.h
691%{_includedir}/vtk/vtkEventQtSlotConnect.h
692%{_includedir}/vtk/vtkGUISupportQt*.h
693%{_includedir}/vtk/vtkQImageToImageSource.h
694%{_includedir}/vtk/vtkQt*.h
695%{_includedir}/vtk/vtkRenderingQtModule.h
696%{_includedir}/vtk/vtkViewsQtModule.h
697
698%if %{with java}
699%files java
700%defattr(644,root,root,755)
701%attr(755,root,root) %{_bindir}/VTKJavaExecutable
702%attr(755,root,root) %{_bindir}/vtkParseJava
703%attr(755,root,root) %{_bindir}/vtkWrapJava
704# common library
705%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so.1
706# java modules
707%attr(755,root,root) %{_libdir}/vtk/libvtkChartsCoreJava.so
708%attr(755,root,root) %{_libdir}/vtk/libvtkCommon*Java.so
709%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryJava.so
710%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2Java.so
711%attr(755,root,root) %{_libdir}/vtk/libvtkFilters*Java.so
712%attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCoreJava.so
713%attr(755,root,root) %{_libdir}/vtk/libvtkIO*Java.so
714%attr(755,root,root) %{_libdir}/vtk/libvtkImaging*Java.so
715%attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*Java.so
716%attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*Java.so
717%attr(755,root,root) %{_libdir}/vtk/libvtkLocalExampleJava.so
718%attr(755,root,root) %{_libdir}/vtk/libvtkParallelCoreJava.so
719%attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreterJava.so
720%attr(755,root,root) %{_libdir}/vtk/libvtkRendering*Java.so
721%attr(755,root,root) %{_libdir}/vtk/libvtkTestingRenderingJava.so
722%attr(755,root,root) %{_libdir}/vtk/libvtkViews*Java.so
723%{_libdir}/vtk/vtk.jar
724
725%files java-devel
726%defattr(644,root,root,755)
727%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so
728%{_includedir}/vtk/vtkJavaUtil.h
729%{_includedir}/vtk/vtkWrappingJavaModule.h
730%endif
731
732%files python
733%defattr(644,root,root,755)
734%doc Wrapping/Python/README*
735%attr(755,root,root) %{_bindir}/vtkWrapPython
736%attr(755,root,root) %{_bindir}/vtkWrapPythonInit
737%attr(755,root,root) %{_bindir}/vtkpython
738%attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so.1
739%attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so.1
740# RenderingMatplotlib requires PythonInterpreter
741%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so.1
742%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingPythonTkWidgets-7.1.so
743%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
744%dir %{py_sitedir}/vtk
745%{py_sitedir}/vtk/*.py[co]
746%dir %{py_sitedir}/vtk/gtk
747%{py_sitedir}/vtk/gtk/*.py[co]
748%dir %{py_sitedir}/vtk/numpy_interface
749%{py_sitedir}/vtk/numpy_interface/*.py[co]
750%dir %{py_sitedir}/vtk/qt
751%{py_sitedir}/vtk/qt/*.py[co]
752%dir %{py_sitedir}/vtk/qt4
753%{py_sitedir}/vtk/qt4/*.py[co]
754%dir %{py_sitedir}/vtk/test
755%{py_sitedir}/vtk/test/*.py[co]
756%dir %{py_sitedir}/vtk/tk
757%{py_sitedir}/vtk/tk/*.py[co]
758%dir %{py_sitedir}/vtk/util
759%{py_sitedir}/vtk/util/*.py[co]
760%dir %{py_sitedir}/vtk/wx
761%{py_sitedir}/vtk/wx/*.py[co]
762%attr(755,root,root) %{py_sitedir}/vtk/vtk*Python.so
763
764%files python-devel
765%defattr(644,root,root,755)
766%attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so
767%attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so
768%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so
769%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so
770%{_includedir}/vtk/PyVTK*.h
771%{_includedir}/vtk/vtkPython*.h
772
773%files tcl
774%defattr(644,root,root,755)
775%doc Wrapping/Tcl/README*
776%attr(755,root,root) %{_bindir}/vtkWrapTcl
777%attr(755,root,root) %{_bindir}/vtkWrapTclInit
778%attr(755,root,root) %{_bindir}/vtk
779%{_datadir}/tcl%{tcl_version}/vtk
780%attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so.1
781
782%files tcl-devel
783%defattr(644,root,root,755)
784%attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so
785%{_includedir}/vtk/vtkTcl*.h
786%{_includedir}/vtk/vtkTk*.h
787
788%files test-suite
789%defattr(644,root,root,755)
790%attr(755,root,root) %{_bindir}/*Tests
791%attr(755,root,root) %{_bindir}/Test*
792
793%files examples
794%defattr(644,root,root,755)
795%attr(755,root,root) %{_bindir}/AmbientSpheres
796%attr(755,root,root) %{_bindir}/Arrays
797%attr(755,root,root) %{_bindir}/Cone
798%attr(755,root,root) %{_bindir}/Cone2
799%attr(755,root,root) %{_bindir}/Cone3
800%attr(755,root,root) %{_bindir}/Cone4
801%attr(755,root,root) %{_bindir}/Cone5
802%attr(755,root,root) %{_bindir}/Cone6
803%attr(755,root,root) %{_bindir}/Cube
804%attr(755,root,root) %{_bindir}/Cylinder
805%attr(755,root,root) %{_bindir}/DiffuseSpheres
806%attr(755,root,root) %{_bindir}/HierarchicalBoxPipeline
807%attr(755,root,root) %{_bindir}/Medical1
808%attr(755,root,root) %{_bindir}/Medical2
809%attr(755,root,root) %{_bindir}/Medical3
810%attr(755,root,root) %{_bindir}/Medical4
811%attr(755,root,root) %{_bindir}/MultiBlock
812%attr(755,root,root) %{_bindir}/RGrid
813%attr(755,root,root) %{_bindir}/SGrid
814%attr(755,root,root) %{_bindir}/SimpleView
815%attr(755,root,root) %{_bindir}/SpecularSpheres
816%attr(755,root,root) %{_bindir}/finance
817%attr(755,root,root) %{_bindir}/BalloonWidget
818%attr(755,root,root) %{_bindir}/BandedContours
819%attr(755,root,root) %{_bindir}/Delaunay3D
820%attr(755,root,root) %{_bindir}/Delaunay3DAlpha
821%attr(755,root,root) %{_bindir}/DumpXMLFile
822%attr(755,root,root) %{_bindir}/FilledContours
823%attr(755,root,root) %{_bindir}/FixedPointVolumeRayCastMapperCT
824%attr(755,root,root) %{_bindir}/GPURenderDemo
825%attr(755,root,root) %{_bindir}/Generate2DAMRDataSetWithPulse
826%attr(755,root,root) %{_bindir}/Generate3DAMRDataSetWithPulse
827%attr(755,root,root) %{_bindir}/GenerateCubesFromLabels
828%attr(755,root,root) %{_bindir}/GenerateModelsFromLabels
829%attr(755,root,root) %{_bindir}/ImageSlicing
830%attr(755,root,root) %{_bindir}/LabeledMesh
831%attr(755,root,root) %{_bindir}/ParticleReader
832%attr(755,root,root) %{_bindir}/Slider
833%attr(755,root,root) %{_bindir}/Slider2D
834%attr(755,root,root) %{_bindir}/TubesWithVaryingRadiusAndColors
835%{_examplesdir}/%{name}-%{version}
836
837%files data
838%defattr(644,root,root,755)
839%dir %{_datadir}/vtk-7.1
840%{_datadir}/vtk-7.1/Data
This page took 0.053717 seconds and 4 git commands to generate.