]> git.pld-linux.org Git - packages/vtk.git/blame_incremental - vtk.spec
- rel 7
[packages/vtk.git] / vtk.spec
... / ...
CommitLineData
1# TODO:
2# - handle VTK_USE_MPEG2_ENCODER (see CMakeLists.txt)
3# - handle MPI and VTK_USE_PARALLEL_BGL (Parallel Boost Graph Library, BR: boost >= 1.40)
4# - more system libraries? (check for VTK_THIRD_PARTY_SUBDIR in Utilities/CMakeLists.txt)
5# - CUDA for Accelerators/Piston (on bcond)
6# - NVCtrlLib for Rendering/OpenGL (on bcond)
7# - VTK_USE_SYSTEM_XDMF2=ON ? (but our xdmf-devel seems not compatible)
8# - python bcond?
9#
10# Conditional build
11%bcond_without java # Java wrappers
12%bcond_without ffmpeg # FFMPEG .avi saving support
13%bcond_with OSMesa # build with OSMesa (https://bugzilla.redhat.com/show_bug.cgi?id=744434)
14%bcond_with system_proj # use system PROJ.4 (needs 4.3 with exposed internals, not ready for 4.4+)
15
16Summary: Toolkit for 3D computer graphics, image processing, and visualization
17Summary(pl.UTF-8): Zestaw narzędzi do trójwymiarowej grafiki, przetwarzania obrazu i wizualizacji
18Name: vtk
19Version: 6.3.0
20Release: 7
21License: BSD
22Group: Libraries
23Source0: http://www.vtk.org/files/release/6.3/VTK-%{version}.tar.gz
24# Source0-md5: 0231ca4840408e9dd60af48b314c5b6d
25Source1: http://www.vtk.org/files/release/6.3/VTKData-%{version}.tar.gz
26# Source1-md5: b164200226805aeb741703a8168afdda
27Patch0: %{name}-chemistry.patch
28Patch1: gdal2.patch
29Patch2: ffmpeg3.patch
30Patch3: cmake.patch
31URL: http://www.vtk.org/
32%{?with_OSMesa:BuildRequires: Mesa-libOSMesa-devel}
33BuildRequires: OpenGL-GLX-devel
34BuildRequires: OpenGL-devel
35BuildRequires: QtCore-devel >= 4.5.0
36BuildRequires: QtDesigner-devel >= 4.5.0
37BuildRequires: QtGui-devel >= 4.5.0
38BuildRequires: QtNetwork-devel >= 4.5.0
39BuildRequires: QtOpenGL-devel >= 4.5.0
40BuildRequires: QtSql-devel >= 4.5.0
41BuildRequires: QtWebKit-devel >= 4.5.0
42BuildRequires: QtXmlPatterns-devel >= 4.5.0
43BuildRequires: R
44BuildRequires: boost-devel >= 1.39
45BuildRequires: cmake >= 2.8.8
46BuildRequires: doxygen
47BuildRequires: expat-devel
48%{?with_ffmpeg:BuildRequires: ffmpeg-devel}
49BuildRequires: fontconfig-devel
50BuildRequires: freetype-devel >= 2
51BuildRequires: gdal-devel
52BuildRequires: gl2ps-devel >= 1.3.8
53BuildRequires: gnuplot
54BuildRequires: graphviz
55BuildRequires: hdf5-devel
56%if %{with java}
57BuildRequires: jdk >= 1.5
58BuildRequires: jpackage-utils
59%endif
60BuildRequires: jsoncpp-devel
61BuildRequires: libjpeg-devel
62BuildRequires: libogg-devel
63BuildRequires: libpng-devel
64BuildRequires: libstdc++-devel
65BuildRequires: libtheora-devel
66BuildRequires: libtiff-devel
67BuildRequires: libxml2-devel >= 2
68BuildRequires: motif-devel
69BuildRequires: mysql-devel
70BuildRequires: netcdf-cxx-devel >= 4
71# some code using it exists (Domains/Chemistry), but is not included in cmakefiles
72#BuildRequires: openqube-devel
73BuildRequires: perl-base
74BuildRequires: postgresql-devel
75%{?with_system_proj:BuildRequires: proj-devel >= 4.3, proj-devel < 4.4}
76BuildRequires: python-devel >= 2
77BuildRequires: python-sip-devel
78BuildRequires: qt4-build >= 4.5.0
79BuildRequires: qt4-qmake >= 4.5.0
80BuildRequires: rpmbuild(macros) >= 1.605
81BuildRequires: sip
82BuildRequires: sip-PyQt4
83BuildRequires: tcl-devel
84BuildRequires: tk-devel
85BuildRequires: unixODBC-devel
86BuildRequires: wget
87BuildRequires: xorg-lib-libICE-devel
88BuildRequires: xorg-lib-libSM-devel
89BuildRequires: xorg-lib-libX11-devel
90BuildRequires: xorg-lib-libXScrnSaver-devel
91BuildRequires: xorg-lib-libXext-devel
92BuildRequires: xorg-lib-libXft-devel
93BuildRequires: xorg-lib-libXt-devel
94BuildRequires: zlib-devel
95BuildConflicts: libXNVCtrl-devel
96Requires: gl2ps >= 1.3.8
97BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
98
99%define skip_post_check_so lib.*Python.*\.so.*
100
101%description
102The Visualization ToolKit (VTK) is an object oriented software system
103for 3D computer graphics, image processing, and visualization. VTK
104includes a textbook, a C++ class library, and several interpreted
105interface layers including Tcl/Tk, Java, and Python. VTK supports a
106wide variety of visualization algorithms including scalar, vector,
107tensor, texture, and volumetric methods. It also supports advanced
108modeling techniques like implicit modeling, polygon reduction, mesh
109smoothing, cutting, contouring, and Delaunay triangulation. Moreover,
110dozens of imaging algorithms have been integrated into the system.
111This allows mixing 2D imaging / 3D graphics algorithms and data.
112
113%description -l pl.UTF-8
114Visualization TookKit (VTK) to obiektowo zorientowany system
115oprogramowania do trójwymiarowej grafiki komputerowej, przetwarzania
116obrazu i wizualizacji. VTK zawiera książkę, bibliotekę klas C++ oraz
117kilka interpretowanych warstw interfejsów, w tym dla Tcl/Tk, Javy i
118Pythona. VTK obsługuje szeroki zakres algorytmów wizualizacji, w tym
119metody skalarne, wektorowe, tensorowe, teksturowe i wolumetryczne.
120Obsługuje także zaawansowane techniki modelowania, takie jak
121modelowanie implicite, redukcja wielokątów, wygładzanie siatki,
122przycinanie, konturowanie i triangulacja Delaunaya. Co więcej, wiele
123algorytmów obrazowania zostało zintegrowanych z systemem. Pozwala to
124na mieszanie algorytmów obrazowania 2D i grafiki 3D.
125
126%package devel
127Summary: VTK header files for building C++ code
128Summary(pl.UTF-8): Pliki nagłówkowe VTK dla C++
129Group: Development
130Requires: %{name} = %{version}-%{release}
131Requires: libstdc++-devel
132
133%description devel
134This provides the VTK header files required to compile C++ programs
135that use VTK to do 3D visualisation.
136
137%description devel -l pl.UTF-8
138Ten pakiet dostarcza pliki nagłówkowe VTK do kompilowania programów
139C++ używających VTK do wizualizacji 3D.
140
141%package qt
142Summary: Qt bindings and Qt Designer plugin for VTK
143Summary(pl.UTF-8): Wiązania Qt oraz wtyczka Qt Designera do VTK
144Group: X11/Libraries
145Requires: %{name} = %{version}-%{release}
146Requires: QtCore >= 4.5.0
147Requires: QtGui >= 4.5.0
148Requires: QtNetwork >= 4.5.0
149Requires: QtOpenGL >= 4.5.0
150Requires: QtSql >= 4.5.0
151Requires: QtWebKit >= 4.5.0
152
153%description qt
154Qt bindings and Qt Designer plugin for VTK.
155
156%description qt -l pl.UTF-8
157Wiązania Qt oraz wtyczka Qt Designera do VTK.
158
159%package qt-devel
160Summary: Header files for VTK Qt bindings
161Summary(pl.UTF-8): Pliki nagłówkowe wiązań Qt do VTK
162Group: X11/Development/Libraries
163Requires: %{name}-devel = %{version}-%{release}
164Requires: %{name}-qt = %{version}-%{release}
165Requires: QtCore-devel >= 4.5.0
166Requires: QtGui-devel >= 4.5.0
167Requires: QtOpenGL-devel >= 4.5.0
168Requires: QtSql-devel >= 4.5.0
169
170%description qt-devel
171Header files for VTK Qt bindings.
172
173%description qt-devel -l pl.UTF-8
174Pliki nagłówkowe wiązań Qt do VTK.
175
176%package java
177Summary: Java bindings for VTK
178Summary(pl.UTF-8): Wiązania Javy do VTK
179Group: Development/Languages/Java
180Requires: %{name} = %{version}-%{release}
181# or separate qt parts?
182Requires: %{name}-qt = %{version}-%{release}
183
184%description java
185This package contains Java bindings for VTK.
186
187%description java -l pl.UTF-8
188Ten pakiet zawiera wiązania Javy do VTK.
189
190%package java-devel
191Summary: Header files for Java VTK binding
192Summary(pl.UTF-8): Pliki nagłówkowe wiązania Javy do VTK
193Group: Development/Libraries
194Requires: %{name}-devel = %{version}-%{release}
195Requires: %{name}-java = %{version}-%{release}
196# <jni.h>
197Requires: jdk
198
199%description java-devel
200Header files for Java VTK binding.
201
202%description java-devel -l pl.UTF-8
203Pliki nagłówkowe wiązania Javy do VTK.
204
205%package python
206Summary: Python bindings for VTK
207Summary(pl.UTF-8): Wiązania Pythona do VTK
208Group: Libraries
209Requires: %{name} = %{version}-%{release}
210# or separate qt parts again?
211Requires: %{name}-qt = %{version}-%{release}
212Obsoletes: vtk-python-qt < 6.0.0-1
213Obsoletes: vtk-python-sip < 6.0.0-1
214
215%description python
216This package contains Python bindings for VTK.
217
218%description python -l pl.UTF-8
219Ten pakiet zawiera wiązania Pythona do VTK.
220
221%package python-devel
222Summary: Header files for Python VTK binding
223Summary(pl.UTF-8): Pliki nagłówkowe wiązania Pythona do VTK
224Group: Development/Libraries
225Requires: %{name}-devel = %{version}-%{release}
226Requires: %{name}-python = %{version}-%{release}
227Requires: python-devel
228
229%description python-devel
230Header files for Python VTK binding.
231
232%description python-devel -l pl.UTF-8
233Pliki nagłówkowe wiązania Pythona do VTK.
234
235%package tcl
236Summary: Tcl bindings for VTK
237Summary(pl.UTF-8): Wiązania języka Tcl do VTK
238Group: Libraries
239Requires: %{name} = %{version}-%{release}
240# or separate qt parts?
241Requires: %{name}-qt = %{version}-%{release}
242
243%description tcl
244This package contains Tcl bindings for VTK.
245
246%description tcl -l pl.UTF-8
247Ten pakiet zawiera wiązania języka Tcl do VTK.
248
249%package tcl-devel
250Summary: Header files for Tcl VTK bindings
251Summary(pl.UTF-8): Pliki nagłówkowe wiązania języka Tcl do VTK
252Group: Development/Libraries
253Requires: %{name}-devel = %{version}-%{release}
254Requires: %{name}-tcl = %{version}-%{release}
255Requires: tcl-devel
256Requires: tk-devel
257
258%description tcl-devel
259Header files for Tcl VTK bindings.
260
261%description tcl-devel -l pl.UTF-8
262Pliki nagłówkowe wiązania języka Tcl do VTK.
263
264%package examples
265Summary: C++, Tcl and Python example programs/scripts for VTK
266Summary(pl.UTF-8): Przykładowe programy/skrypty w C++, Tcl-u i Pythonie dla VTK
267Group: Development/Libraries
268Requires: %{name} = %{version}-%{release}
269Requires: %{name}-data = %{version}-%{release}
270
271%description examples
272This package contains all the examples from the VTK source. To compile
273the C++ examples you will need to install the vtk-devel package as
274well. The Python and Tcl examples can be run with the corresponding
275packages (vtk-python, vtk-tcl).
276
277%description examples -l pl.UTF-8
278Ten pakiet zawiera wszystkie przykłady ze źródeł VTK. Do skompilowania
279przykładów w C++ trzeba doinstalować pakiet vtk-devel. Przykłady w
280Pythonie i Tcl-u można uruchamiać przy użyciu odpowiednich pakietów
281(vtk-python, vtk-tcl).
282
283%package test-suite
284Summary: Test programs for VTK
285Summary(pl.UTF-8): Programy testowe dla VTK
286Group: Development/Libraries
287Requires: %{name} = %{version}-%{release}
288Requires: %{name}-data = %{version}-%{release}
289
290%description test-suite
291This package contains all testing programs from the VTK source. The
292source code of these programs can be found in the vtk-examples
293package.
294
295%description test-suite -l pl.UTF-8
296Ten pakiet zawiera wszystkie programy testowe ze źródeł VTK. Kod
297źródłowy tych programów można znaleźć w pakiecie vtk-examples.
298
299%package data
300Summary: Data files for VTK
301Summary(pl.UTF-8): Pliki danych dla VTK
302Group: Development/Libraries
303%if "%{_rpmversion}" >= "5"
304BuildArch: noarch
305%endif
306
307%description data
308This package contains all the data from the VTKData repository. These
309data are required to run various examples from the vtk-examples
310package.
311
312%description data -l pl.UTF-8
313Ten pakiet zawiera wszystkie dane z repozytorium VTKData. Dane te są
314potrzebne do uruchamiania różnych przykładów z pakietu vtk-examples.
315
316%prep
317%setup -q -n VTK-%{version} -b 1
318%patch0 -p1
319%patch1 -p1
320%patch2 -p1
321%patch3 -p1
322
323# Replace relative path ../../../VTKData with destination filesystem path
324grep -Erl '(\.\./)+VTKData' Examples | xargs \
325 perl -pi -e 's,(\.\./)+VTKData,%{_datadir}/vtk-6.3,g'
326
327# Save an unbuilt copy of the Example's sources for %doc
328mkdir vtk-examples
329cp -a Examples vtk-examples
330# Don't ship Win32 examples
331%{__rm} -r vtk-examples/Examples/GUI/Win32
332find vtk-examples -type f | xargs chmod -R a-x
333
334%build
335export CFLAGS="%{rpmcflags} -D_UNICODE"
336export CXXFLAGS="%{rpmcxxflags} -D_UNICODE"
337%if %{with java}
338export JAVA_HOME=%{java_home}
339%endif
340
341# handle cmake & ccache
342# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmake
343# ASM fix: http://lists.busybox.net/pipermail/buildroot/2013-March/069436.html
344if [[ "%{__cc}" = *ccache* ]]; then
345 cc="%{__cc}"
346 cxx="%{__cxx}"
347 ccache="
348 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
349 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
350 -DCMAKE_ASM_COMPILER="${cc#ccache }" \
351 "
352else
353 ccache="
354 -DCMAKE_C_COMPILER="%{__cc}" \
355 -DCMAKE_CXX_COMPILER="%{__cxx}" \
356 -DCMAKE_ASM_COMPILER="%{__cc}" \
357 "
358fi
359
360mkdir -p build
361cd build
362%cmake .. \
363 $ccache \
364 -Wno-dev \
365 -DBUILD_DOCUMENTATION:BOOL=ON \
366 -DBUILD_EXAMPLES:BOOL=ON \
367 -DBUILD_SHARED_LIBS:BOOL=ON \
368 -DBUILD_TESTING:BOOL=ON \
369 -DCMAKE_SKIP_RPATH:BOOL=ON \
370 -DOPENGL_INCLUDE_PATH:PATH=%{_includedir}/GL \
371 -DPYTHON_INCLUDE_PATH:PATH=%{py_incdir} \
372 -DPYTHON_LIBRARY:FILEPATH=%{_libdir}/libpython%{py_ver}.so \
373 -DPYTHON_UTIL_LIBRARY:PATH=%{_libdir}/libutil.so \
374 -DTCL_INCLUDE_PATH:PATH=%{_includedir} \
375 -DTCL_LIBRARY:PATH=%{_libdir}/libtcl.so \
376 -DTK_INCLUDE_PATH:PATH=%{_includedir} \
377 -DTK_LIBRARY:PATH=%{_libdir}/libtk.so \
378 -DVTK_DATA_ROOT:PATH=%{_datadir}/vtk-6.3 \
379 -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
380 -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/vtk \
381 -DVTK_INSTALL_INCLUDE_DIR:PATH=include/vtk \
382 -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/vtk \
383 -DVTK_INSTALL_PACKAGE_DIR:PATH=%{_lib}/cmake/vtk \
384 -DVTK_INSTALL_TCL_DIR:PATH=share/tcl%{tcl_version}/vtk \
385 -DVTK_INSTALL_PYTHON_MODULE_DIR:PATH=%{py_sitedir} \
386 -DVTK_INSTALL_QT_DIR=/%{_lib}/qt4/plugins/designer \
387 -DVTK_FFMPEG_HAS_OLD_HEADER:BOOL=OFF \
388 %{?with_OSMesa:-DVTK_OPENGL_HAS_OSMESA:BOOL=ON} \
389 -DVTK_WRAP_PYTHON:BOOL=ON \
390 -DVTK_PYTHON_SETUP_ARGS="--prefix=/usr --root=$RPM_BUILD_ROOT" \
391 -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
392 -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
393 -DVTK_USE_RENDERING:BOOL=ON \
394 -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
395 -DVTK_USE_SYSTEM_XDMF2:BOOL=OFF \
396 %{!?with_system_proj:-DVTK_USE_SYSTEM_LIBPROJ4:BOOL=OFF} \
397%if %{with java}
398 -DVTK_WRAP_JAVA:BOOL=ON \
399 -DJAVA_INCLUDE_PATH:PATH=$JAVA_HOME/include \
400 -DJAVA_INCLUDE_PATH2:PATH=$JAVA_HOME/include/linux \
401 -DJAVA_AWT_INCLUDE_PATH:PATH=$JAVA_HOME/include \
402%else
403 -DVTK_WRAP_JAVA:BOOL=OFF \
404%endif
405 -DVTK_WRAP_PYTHON:BOOL=ON \
406 %{?with_sip:-DVTK_WRAP_PYTHON_SIP:BOOL=ON} \
407 -DVTK_WRAP_TCL:BOOL=ON \
408 -DVTK_Group_Imaging:BOOL=ON \
409 -DVTK_Group_Qt:BOOL=ON \
410 -DVTK_Group_Rendering:BOOL=ON \
411 -DVTK_Group_StandAlone:BOOL=ON \
412 -DVTK_Group_Tk:BOOL=ON \
413 -DVTK_Group_Views:BOOL=ON \
414 -DModule_vtkFiltersReebGraph:BOOL=ON \
415 -DModule_vtkFiltersStatisticsGnuR:BOOL=ON \
416 %{?with_ffmpeg:-DModule_vtkIOFFMPEG:BOOL=ON} \
417 -DModule_vtkIOGDAL:BOOL=ON \
418 -DModule_vtkIOGeoJSON:BOOL=ON \
419 -DModule_vtkIOMySQL:BOOL=ON \
420 -DModule_vtkIOODBC:BOOL=ON \
421 -DModule_vtkIOParallelExodus:BOOL=ON \
422 -DModule_vtkIOParallelLSDyna:BOOL=ON \
423 -DModule_vtkIOPostgreSQL:BOOL=ON \
424 -DModule_vtkIOVPIC:BOOL=ON \
425 -DModule_vtkIOXdmf2:BOOL=ON \
426 -DModule_vtkInfovisBoost:BOOL=ON \
427 -DModule_vtkInfovisBoostGraphAlgorithms:BOOL=ON \
428 -DModule_vtkRenderingFreeTypeFontConfig:BOOL=ON \
429 -DModule_vtkRenderingMatplotlib:BOOL=ON \
430 -DModule_vtkRenderingParallel:BOOL=ON
431# TODO: -DModule_vtkAcceleratorsDax:BOOL=ON (BR: FindDax.cmake, maybe http://www.daxtoolkit.org/ ?)
432# TODO: -DModule_vtkAcceleratorsPiston:BOOL=ON (on bcond, BR: CUDA)
433# TODO: -DModule_vtkFiltersParallelFlowPaths:BOOL=ON (BR: MPI)
434# TODO: -DModule_vtkFiltersParallelStatistics:BOOL=ON (BR: MPI)
435# TODO: -DModule_vtkInfovisParallel:BOOL=ON (BR: MPI)
436# TODO: -DModule_vtkRenderingParallelLIC:BOOL=ON (BR: MPI)
437
438%{__make}
439
440%install
441rm -rf $RPM_BUILD_ROOT
442install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ld.so.conf.d,%{_examplesdir}/%{name}-%{version}}
443
444%{__make} -C build install \
445 DESTDIR=$RPM_BUILD_ROOT
446
447# ld config
448echo %{_libdir}/vtk > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
449
450for f in $(cd build/ExternalData/Testing ; find Data -type l); do
451 install -Dp build/ExternalData/Testing/$f $RPM_BUILD_ROOT%{_datadir}/vtk-6.3/$f
452done
453
454# Install utilities
455install build/bin/lproj $RPM_BUILD_ROOT%{_bindir}
456
457# Install examples
458for f in \
459AmbientSpheres \
460Arrays \
461BalloonWidget \
462BandedContours \
463Cone \
464Cone2 \
465Cone3 \
466Cone4 \
467Cone5 \
468Cone6 \
469Cube \
470Cylinder \
471Delaunay3D \
472Delaunay3DAlpha \
473DiffuseSpheres \
474DumpXMLFile \
475FilledContours \
476FixedPointVolumeRayCastMapperCT \
477GPURenderDemo \
478Generate2DAMRDataSetWithPulse \
479Generate3DAMRDataSetWithPulse \
480GenerateCubesFromLabels \
481GenerateModelsFromLabels \
482HierarchicalBoxPipeline \
483ImageDataLIC2DDemo \
484ImageSlicing \
485LabeledMesh \
486Medical1 \
487Medical2 \
488Medical3 \
489Medical4 \
490MultiBlock \
491ParticleReader \
492RGrid \
493SGrid \
494SimpleView \
495Slider \
496Slider2D \
497SpecularSpheres \
498StructuredGridLIC2DDemo \
499SurfaceLICDemo \
500TimeRenderer \
501TimeRenderer2 \
502TubesWithVaryingRadiusAndColors \
503finance ; do
504 install build/bin/$f $RPM_BUILD_ROOT%{_bindir}
505done
506
507# Install test binaries
508for f in build/bin/*Tests build/bin/Test* build/bin/VTKBenchMark; do
509 install $f $RPM_BUILD_ROOT%{_bindir}
510done
511
512%if %{with java}
513install -p build/bin/VTKJavaExecutable $RPM_BUILD_ROOT%{_bindir}
514%endif
515install -p build/bin/vtkpython $RPM_BUILD_ROOT%{_bindir}
516
517# unwanted doxygen files and misplaced verdict docs
518%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/vtk-6.3/{doxygen,verdict}
519
520# only *.pyc are built by default, add *.pyo
521%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/vtk
522%py_postclean
523
524%clean
525rm -rf $RPM_BUILD_ROOT
526
527%post -p /sbin/ldconfig
528%postun -p /sbin/ldconfig
529
530%post qt -p /sbin/ldconfig
531%postun qt -p /sbin/ldconfig
532
533%post java -p /sbin/ldconfig
534%postun java -p /sbin/ldconfig
535
536%post python -p /sbin/ldconfig
537%postun python -p /sbin/ldconfig
538
539%post tcl -p /sbin/ldconfig
540%postun tcl -p /sbin/ldconfig
541
542%files
543%defattr(644,root,root,755)
544%doc README.md vtkLogo.jpg vtkBanner.gif Wrapping/Tools/README*
545%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
546%dir %{_libdir}/vtk
547%attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so.1
548%attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so.1
549%attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so.1
550%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so.1
551%attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so.1
552%attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so.1
553%attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so.1
554%attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so.1
555%attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so.1
556%attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so.1
557%attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so.1
558%attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so.1
559%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so.1
560%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so.1
561%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL.so.1
562%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so.1
563%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so.1
564%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so.1
565%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PS.so.1
566%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so.1
567%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLIC.so.1
568%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so.1
569%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so.1
570%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL.so.1
571%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so.1
572%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so.1
573%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL.so.1
574%attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so.1
575%attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so.1
576%attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so.1
577%attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so.1
578%attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so.1
579%attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so.1
580%attr(755,root,root) %{_libdir}/vtk/libvtkalglib.so.1
581%attr(755,root,root) %{_libdir}/vtk/libvtkexoIIc.so.1
582%attr(755,root,root) %{_libdir}/vtk/libvtkftgl.so.1
583%attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so.1
584%attr(755,root,root) %{_libdir}/vtk/libvtkproj4.so.1
585%attr(755,root,root) %{_libdir}/vtk/libvtksqlite.so.1
586%attr(755,root,root) %{_libdir}/vtk/libvtksys.so.1
587%attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so.1
588%attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so.1
589%exclude %{_libdir}/vtk/libvtk*Java.so.1
590%exclude %{_libdir}/vtk/libvtk*Python2?D.so.1
591%exclude %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
592%exclude %{_libdir}/vtk/libvtk*TCL.so.1
593
594%files devel
595%defattr(644,root,root,755)
596%doc Utilities/Upgrading/*
597%attr(755,root,root) %{_bindir}/lproj
598%attr(755,root,root) %{_bindir}/vtkEncodeString
599%attr(755,root,root) %{_bindir}/vtkHashSource
600%attr(755,root,root) %{_bindir}/vtkParseOGLExt
601%attr(755,root,root) %{_bindir}/vtkWrapHierarchy
602%attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so
603%attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so
604%attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so
605%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so
606%attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so
607%attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so
608%attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so
609%attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so
610%attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so
611%attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so
612%attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so
613%attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so
614%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so
615%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so
616%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL.so
617%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so
618%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so
619%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so
620%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PS.so
621%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so
622%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLIC.so
623%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so
624%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so
625%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL.so
626%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so
627%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so
628%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL.so
629%attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so
630%attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so
631%attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so
632%attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so
633%attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so
634%attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so
635%attr(755,root,root) %{_libdir}/vtk/libvtkalglib.so
636%attr(755,root,root) %{_libdir}/vtk/libvtkexoIIc.so
637%attr(755,root,root) %{_libdir}/vtk/libvtkftgl.so
638%attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so
639%attr(755,root,root) %{_libdir}/vtk/libvtkproj4.so
640%attr(755,root,root) %{_libdir}/vtk/libvtksqlite.so
641%attr(755,root,root) %{_libdir}/vtk/libvtksys.so
642%attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so
643%attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so
644%exclude %{_libdir}/vtk/libvtk*Java.so
645%exclude %{_libdir}/vtk/libvtk*Python2?D.so
646%exclude %{_libdir}/vtk/libvtkWrappingPython2?Core.so
647%exclude %{_libdir}/vtk/libvtk*TCL.so
648%{_libdir}/vtk/libvtkWrappingTools.a
649%dir %{_includedir}/vtk
650%{_includedir}/vtk/VPIC
651%{_includedir}/vtk/DICOM*.h
652%{_includedir}/vtk/DatabaseSchemaWith2Tables.h
653%{_includedir}/vtk/alglib
654%{_includedir}/vtk/vtklibproj4
655%{_includedir}/vtk/vtkmetaio
656%{_includedir}/vtk/vtkverdict
657%{_includedir}/vtk/vtksqlite
658%{_includedir}/vtk/vtksys
659%{_includedir}/vtk/vtkxdmf2
660%{_includedir}/vtk/vtk*.h
661%{_includedir}/vtk/vtk*.txx
662%exclude %{_includedir}/vtk/vtkEventQtSlotConnect.h
663%exclude %{_includedir}/vtk/vtkGUISupportQt*.h
664%exclude %{_includedir}/vtk/vtkJavaUtil.h
665%exclude %{_includedir}/vtk/vtkWrappingJavaModule.h
666%exclude %{_includedir}/vtk/vtkPython*.h
667%exclude %{_includedir}/vtk/vtkQImageToImageSource.h
668%exclude %{_includedir}/vtk/vtkQt*.h
669%exclude %{_includedir}/vtk/vtkRenderingQtModule.h
670%exclude %{_includedir}/vtk/vtkTcl*.h
671%exclude %{_includedir}/vtk/vtkTk*.h
672%exclude %{_includedir}/vtk/vtkViewsQtModule.h
673%{_libdir}/cmake/vtk
674
675%files qt
676%defattr(644,root,root,755)
677%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so.1
678%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtOpenGL.so.1
679%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so.1
680%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtWebkit.so.1
681%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so.1
682%attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so.1
683%attr(755,root,root) %{_libdir}/qt4/plugins/designer/libQVTKWidgetPlugin.so
684
685%files qt-devel
686%defattr(644,root,root,755)
687%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so
688%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtOpenGL.so
689%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so
690%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtWebkit.so
691%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so
692%attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so
693%{_includedir}/vtk/QFilterTreeProxyModel.h
694%{_includedir}/vtk/QVTK*.h
695%{_includedir}/vtk/vtkEventQtSlotConnect.h
696%{_includedir}/vtk/vtkGUISupportQt*.h
697%{_includedir}/vtk/vtkQImageToImageSource.h
698%{_includedir}/vtk/vtkQt*.h
699%{_includedir}/vtk/vtkRenderingQtModule.h
700%{_includedir}/vtk/vtkViewsQtModule.h
701
702%if %{with java}
703%files java
704%defattr(644,root,root,755)
705%attr(755,root,root) %{_bindir}/VTKJavaExecutable
706%attr(755,root,root) %{_bindir}/vtkParseJava
707%attr(755,root,root) %{_bindir}/vtkWrapJava
708# common library
709%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so.1
710# java modules
711%attr(755,root,root) %{_libdir}/vtk/libvtkChartsCoreJava.so
712%attr(755,root,root) %{_libdir}/vtk/libvtkCommon*Java.so
713%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryJava.so
714%attr(755,root,root) %{_libdir}/vtk/libvtkFilters*Java.so
715%attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCoreJava.so
716%attr(755,root,root) %{_libdir}/vtk/libvtkIO*Java.so
717%attr(755,root,root) %{_libdir}/vtk/libvtkImaging*Java.so
718%attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*Java.so
719%attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*Java.so
720%attr(755,root,root) %{_libdir}/vtk/libvtkLocalExampleJava.so
721%attr(755,root,root) %{_libdir}/vtk/libvtkParallelCoreJava.so
722%attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreterJava.so
723%attr(755,root,root) %{_libdir}/vtk/libvtkRendering*Java.so
724%attr(755,root,root) %{_libdir}/vtk/libvtkTestingRenderingJava.so
725%attr(755,root,root) %{_libdir}/vtk/libvtkViews*Java.so
726%{_libdir}/vtk/vtk.jar
727
728%files java-devel
729%defattr(644,root,root,755)
730%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so
731%{_includedir}/vtk/vtkJavaUtil.h
732%{_includedir}/vtk/vtkWrappingJavaModule.h
733%endif
734
735%files python
736%defattr(644,root,root,755)
737%doc Wrapping/Python/README*
738%attr(755,root,root) %{_bindir}/vtkWrapPython
739%attr(755,root,root) %{_bindir}/vtkWrapPythonInit
740%attr(755,root,root) %{_bindir}/vtkpython
741%attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so.1
742%attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so.1
743# RenderingMatplotlib requires PythonInterpreter
744%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so.1
745%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingPythonTkWidgets-6.3.so
746%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
747%dir %{py_sitedir}/vtk
748%{py_sitedir}/vtk/*.py[co]
749%dir %{py_sitedir}/vtk/gtk
750%{py_sitedir}/vtk/gtk/*.py[co]
751%dir %{py_sitedir}/vtk/numpy_interface
752%{py_sitedir}/vtk/numpy_interface/*.py[co]
753%dir %{py_sitedir}/vtk/qt4
754%{py_sitedir}/vtk/qt4/*.py[co]
755%dir %{py_sitedir}/vtk/test
756%{py_sitedir}/vtk/test/*.py[co]
757%dir %{py_sitedir}/vtk/tk
758%{py_sitedir}/vtk/tk/*.py[co]
759%dir %{py_sitedir}/vtk/util
760%{py_sitedir}/vtk/util/*.py[co]
761%dir %{py_sitedir}/vtk/wx
762%{py_sitedir}/vtk/wx/*.py[co]
763%attr(755,root,root) %{py_sitedir}/vtk/vtk*Python.so
764
765%files python-devel
766%defattr(644,root,root,755)
767%attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so
768%attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so
769%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so
770%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so
771%{_includedir}/vtk/PyVTK*.h
772%{_includedir}/vtk/vtkPython*.h
773
774%files tcl
775%defattr(644,root,root,755)
776%doc Wrapping/Tcl/README*
777%attr(755,root,root) %{_bindir}/vtkWrapTcl
778%attr(755,root,root) %{_bindir}/vtkWrapTclInit
779%attr(755,root,root) %{_bindir}/vtk
780%{_datadir}/tcl%{tcl_version}/vtk
781%attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so.1
782
783%files tcl-devel
784%defattr(644,root,root,755)
785%attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so
786%{_includedir}/vtk/vtkTcl*.h
787%{_includedir}/vtk/vtkTk*.h
788
789%files test-suite
790%defattr(644,root,root,755)
791%attr(755,root,root) %{_bindir}/*Tests
792%attr(755,root,root) %{_bindir}/Test*
793%attr(755,root,root) %{_bindir}/VTKBenchMark
794
795%files examples
796%defattr(644,root,root,755)
797%attr(755,root,root) %{_bindir}/AmbientSpheres
798%attr(755,root,root) %{_bindir}/Arrays
799%attr(755,root,root) %{_bindir}/Cone
800%attr(755,root,root) %{_bindir}/Cone2
801%attr(755,root,root) %{_bindir}/Cone3
802%attr(755,root,root) %{_bindir}/Cone4
803%attr(755,root,root) %{_bindir}/Cone5
804%attr(755,root,root) %{_bindir}/Cone6
805%attr(755,root,root) %{_bindir}/Cube
806%attr(755,root,root) %{_bindir}/Cylinder
807%attr(755,root,root) %{_bindir}/DiffuseSpheres
808%attr(755,root,root) %{_bindir}/HierarchicalBoxPipeline
809%attr(755,root,root) %{_bindir}/Medical1
810%attr(755,root,root) %{_bindir}/Medical2
811%attr(755,root,root) %{_bindir}/Medical3
812%attr(755,root,root) %{_bindir}/Medical4
813%attr(755,root,root) %{_bindir}/MultiBlock
814%attr(755,root,root) %{_bindir}/RGrid
815%attr(755,root,root) %{_bindir}/SGrid
816%attr(755,root,root) %{_bindir}/SimpleView
817%attr(755,root,root) %{_bindir}/SpecularSpheres
818%attr(755,root,root) %{_bindir}/finance
819%attr(755,root,root) %{_bindir}/BalloonWidget
820%attr(755,root,root) %{_bindir}/BandedContours
821%attr(755,root,root) %{_bindir}/Delaunay3D
822%attr(755,root,root) %{_bindir}/Delaunay3DAlpha
823%attr(755,root,root) %{_bindir}/DumpXMLFile
824%attr(755,root,root) %{_bindir}/FilledContours
825%attr(755,root,root) %{_bindir}/FixedPointVolumeRayCastMapperCT
826%attr(755,root,root) %{_bindir}/GPURenderDemo
827%attr(755,root,root) %{_bindir}/Generate2DAMRDataSetWithPulse
828%attr(755,root,root) %{_bindir}/Generate3DAMRDataSetWithPulse
829%attr(755,root,root) %{_bindir}/GenerateCubesFromLabels
830%attr(755,root,root) %{_bindir}/GenerateModelsFromLabels
831%attr(755,root,root) %{_bindir}/ImageDataLIC2DDemo
832%attr(755,root,root) %{_bindir}/ImageSlicing
833%attr(755,root,root) %{_bindir}/LabeledMesh
834%attr(755,root,root) %{_bindir}/ParticleReader
835%attr(755,root,root) %{_bindir}/Slider
836%attr(755,root,root) %{_bindir}/Slider2D
837%attr(755,root,root) %{_bindir}/StructuredGridLIC2DDemo
838%attr(755,root,root) %{_bindir}/SurfaceLICDemo
839%attr(755,root,root) %{_bindir}/TimeRenderer
840%attr(755,root,root) %{_bindir}/TimeRenderer2
841%attr(755,root,root) %{_bindir}/TubesWithVaryingRadiusAndColors
842%{_examplesdir}/%{name}-%{version}
843
844%files data
845%defattr(644,root,root,755)
846%dir %{_datadir}/vtk-6.3
847%{_datadir}/vtk-6.3/Data
848%{_datadir}/vtk-6.3/vtkDomainsChemistry
This page took 0.122275 seconds and 4 git commands to generate.