]> git.pld-linux.org Git - packages/vtk.git/blame_incremental - vtk.spec
- jsoncpp patch no longer needed
[packages/vtk.git] / vtk.spec
... / ...
CommitLineData
1# TODO:
2# - handle VTK_USE_MPEG2_ENCODER (see CMakeLists.txt)
3# - handle MPI and VTK_USE_PARALLEL_BGL (Parallel Boost Graph Library, BR: boost >= 1.40)
4# - more system libraries? (check for VTK_THIRD_PARTY_SUBDIR in Utilities/CMakeLists.txt)
5# - CUDA for Accelerators/Piston (on bcond)
6# - NVCtrlLib for Rendering/OpenGL (on bcond)
7# - VTK_USE_SYSTEM_XDMF2=ON ? (but our xdmf-devel seems not compatible)
8#
9# Conditional build
10%bcond_without java # Java wrappers
11%bcond_without ffmpeg # FFMPEG .avi saving support
12%bcond_with OSMesa # build with OSMesa (https://bugzilla.redhat.com/show_bug.cgi?id=744434)
13%bcond_with system_proj # use system PROJ.4 (needs 4.3 with exposed internals, not ready for 4.4+)
14#
15Summary: Toolkit for 3D computer graphics, image processing, and visualization
16Summary(pl.UTF-8): Zestaw narzędzi do trójwymiarowej grafiki, przetwarzania obrazu i wizualizacji
17Name: vtk
18Version: 6.1.0
19Release: 12
20License: BSD
21Group: Libraries
22Source0: http://www.vtk.org/files/release/6.1/VTK-%{version}.tar.gz
23# Source0-md5: 25e4dfb3bad778722dcaec80cd5dab7d
24Source1: http://www.vtk.org/files/release/6.1/VTKData-%{version}.tar.gz
25# Source1-md5: f82c8fe151279c0422ab8a6cfe991c94
26Patch0: %{name}-system-libs.patch
27Patch1: %{name}-install.patch
28Patch2: %{name}-chemistry.patch
29Patch3: conflicting-types.patch
30URL: http://www.vtk.org/
31%{?with_OSMesa:BuildRequires: Mesa-libOSMesa-devel}
32BuildRequires: OpenGL-GLX-devel
33BuildRequires: OpenGL-devel
34BuildRequires: QtCore-devel >= 4.5.0
35BuildRequires: QtGui-devel >= 4.5.0
36BuildRequires: QtNetwork-devel >= 4.5.0
37BuildRequires: QtOpenGL-devel >= 4.5.0
38BuildRequires: QtSql-devel >= 4.5.0
39BuildRequires: QtWebKit-devel >= 4.5.0
40BuildRequires: QtXmlPatterns-devel >= 4.5.0
41BuildRequires: R
42BuildRequires: boost-devel >= 1.39
43BuildRequires: cmake >= 2.8.8
44BuildRequires: doxygen
45BuildRequires: expat-devel
46%{?with_ffmpeg:BuildRequires: ffmpeg-devel}
47BuildRequires: fontconfig-devel
48BuildRequires: freetype-devel >= 2
49BuildRequires: gdal-devel
50BuildRequires: gl2ps-devel >= 1.3.8
51BuildRequires: gnuplot
52BuildRequires: graphviz
53BuildRequires: hdf5-devel
54%if %{with java}
55BuildRequires: jdk >= 1.5
56BuildRequires: jpackage-utils
57%endif
58BuildRequires: jsoncpp-devel
59BuildRequires: libjpeg-devel
60BuildRequires: libogg-devel
61BuildRequires: libpng-devel
62BuildRequires: libstdc++-devel
63BuildRequires: libtheora-devel
64BuildRequires: libtiff-devel
65BuildRequires: libxml2-devel >= 2
66BuildRequires: motif-devel
67BuildRequires: mysql-devel
68BuildRequires: netcdf-cxx-devel >= 4
69# some code using it exists (Domains/Chemistry), but is not included in cmakefiles
70#BuildRequires: openqube-devel
71BuildRequires: perl-base
72BuildRequires: postgresql-devel
73%{?with_system_proj:BuildRequires: proj-devel >= 4.3, proj-devel < 4.4}
74BuildRequires: python-devel >= 2
75BuildRequires: python-sip-devel
76BuildRequires: qt4-build >= 4.5.0
77BuildRequires: qt4-qmake >= 4.5.0
78BuildRequires: rpmbuild(macros) >= 1.605
79BuildRequires: sip
80BuildRequires: sip-PyQt4
81BuildRequires: tcl-devel
82BuildRequires: tk-devel
83BuildRequires: unixODBC-devel
84BuildRequires: wget
85BuildRequires: xorg-lib-libICE-devel
86BuildRequires: xorg-lib-libSM-devel
87BuildRequires: xorg-lib-libX11-devel
88BuildRequires: xorg-lib-libXScrnSaver-devel
89BuildRequires: xorg-lib-libXext-devel
90BuildRequires: xorg-lib-libXft-devel
91BuildRequires: xorg-lib-libXt-devel
92BuildRequires: zlib-devel
93BuildConflicts: libXNVCtrl-devel
94Requires: gl2ps >= 1.3.8
95BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97%define skip_post_check_so lib.*Python.*\.so.*
98
99%description
100The Visualization ToolKit (VTK) is an object oriented software system
101for 3D computer graphics, image processing, and visualization. VTK
102includes a textbook, a C++ class library, and several interpreted
103interface layers including Tcl/Tk, Java, and Python. VTK supports a
104wide variety of visualization algorithms including scalar, vector,
105tensor, texture, and volumetric methods. It also supports advanced
106modeling techniques like implicit modeling, polygon reduction, mesh
107smoothing, cutting, contouring, and Delaunay triangulation. Moreover,
108dozens of imaging algorithms have been integrated into the system.
109This allows mixing 2D imaging / 3D graphics algorithms and data.
110
111%description -l pl.UTF-8
112Visualization TookKit (VTK) to obiektowo zorientowany system
113oprogramowania do trójwymiarowej grafiki komputerowej, przetwarzania
114obrazu i wizualizacji. VTK zawiera książkę, bibliotekę klas C++ oraz
115kilka interpretowanych warstw interfejsów, w tym dla Tcl/Tk, Javy i
116Pythona. VTK obsługuje szeroki zakres algorytmów wizualizacji, w tym
117metody skalarne, wektorowe, tensorowe, teksturowe i wolumetryczne.
118Obsługuje także zaawansowane techniki modelowania, takie jak
119modelowanie implicite, redukcja wielokątów, wygładzanie siatki,
120przycinanie, konturowanie i triangulacja Delaunaya. Co więcej, wiele
121algorytmów obrazowania zostało zintegrowanych z systemem. Pozwala to
122na mieszanie algorytmów obrazowania 2D i grafiki 3D.
123
124%package devel
125Summary: VTK header files for building C++ code
126Summary(pl.UTF-8): Pliki nagłówkowe VTK dla C++
127Group: Development
128Requires: %{name} = %{version}-%{release}
129Requires: libstdc++-devel
130
131%description devel
132This provides the VTK header files required to compile C++ programs
133that use VTK to do 3D visualisation.
134
135%description devel -l pl.UTF-8
136Ten pakiet dostarcza pliki nagłówkowe VTK do kompilowania programów
137C++ używających VTK do wizualizacji 3D.
138
139%package qt
140Summary: Qt bindings and Qt Designer plugin for VTK
141Summary(pl.UTF-8): Wiązania Qt oraz wtyczka Qt Designera do VTK
142Group: X11/Libraries
143Requires: %{name} = %{version}-%{release}
144Requires: QtCore >= 4.5.0
145Requires: QtGui >= 4.5.0
146Requires: QtNetwork >= 4.5.0
147Requires: QtOpenGL >= 4.5.0
148Requires: QtSql >= 4.5.0
149Requires: QtWebKit >= 4.5.0
150
151%description qt
152Qt bindings and Qt Designer plugin for VTK.
153
154%description qt -l pl.UTF-8
155Wiązania Qt oraz wtyczka Qt Designera do VTK.
156
157%package qt-devel
158Summary: Header files for VTK Qt bindings
159Summary(pl.UTF-8): Pliki nagłówkowe wiązań Qt do VTK
160Group: X11/Development/Libraries
161Requires: %{name}-devel = %{version}-%{release}
162Requires: %{name}-qt = %{version}-%{release}
163Requires: QtCore-devel >= 4.5.0
164Requires: QtGui-devel >= 4.5.0
165Requires: QtOpenGL-devel >= 4.5.0
166Requires: QtSql-devel >= 4.5.0
167
168%description qt-devel
169Header files for VTK Qt bindings.
170
171%description qt-devel -l pl.UTF-8
172Pliki nagłówkowe wiązań Qt do VTK.
173
174%package java
175Summary: Java bindings for VTK
176Summary(pl.UTF-8): Wiązania Javy do VTK
177Group: Development/Languages/Java
178Requires: %{name} = %{version}-%{release}
179# or separate qt parts?
180Requires: %{name}-qt = %{version}-%{release}
181
182%description java
183This package contains Java bindings for VTK.
184
185%description java -l pl.UTF-8
186Ten pakiet zawiera wiązania Javy do VTK.
187
188%package java-devel
189Summary: Header files for Java VTK binding
190Summary(pl.UTF-8): Pliki nagłówkowe wiązania Javy do VTK
191Group: Development/Libraries
192Requires: %{name}-devel = %{version}-%{release}
193Requires: %{name}-java = %{version}-%{release}
194# <jni.h>
195Requires: jdk
196
197%description java-devel
198Header files for Java VTK binding.
199
200%description java-devel -l pl.UTF-8
201Pliki nagłówkowe wiązania Javy do VTK.
202
203%package python
204Summary: Python bindings for VTK
205Summary(pl.UTF-8): Wiązania Pythona do VTK
206Group: Libraries
207Requires: %{name} = %{version}-%{release}
208# or separate qt parts again?
209Requires: %{name}-qt = %{version}-%{release}
210Obsoletes: vtk-python-qt < 6.0.0-1
211Obsoletes: vtk-python-sip < 6.0.0-1
212
213%description python
214This package contains Python bindings for VTK.
215
216%description python -l pl.UTF-8
217Ten pakiet zawiera wiązania Pythona do VTK.
218
219%package python-devel
220Summary: Header files for Python VTK binding
221Summary(pl.UTF-8): Pliki nagłówkowe wiązania Pythona do VTK
222Group: Development/Libraries
223Requires: %{name}-devel = %{version}-%{release}
224Requires: %{name}-python = %{version}-%{release}
225Requires: python-devel
226
227%description python-devel
228Header files for Python VTK binding.
229
230%description python-devel -l pl.UTF-8
231Pliki nagłówkowe wiązania Pythona do VTK.
232
233%package tcl
234Summary: Tcl bindings for VTK
235Summary(pl.UTF-8): Wiązania języka Tcl do VTK
236Group: Libraries
237Requires: %{name} = %{version}-%{release}
238# or separate qt parts?
239Requires: %{name}-qt = %{version}-%{release}
240
241%description tcl
242This package contains Tcl bindings for VTK.
243
244%description tcl -l pl.UTF-8
245Ten pakiet zawiera wiązania języka Tcl do VTK.
246
247%package tcl-devel
248Summary: Header files for Tcl VTK bindings
249Summary(pl.UTF-8): Pliki nagłówkowe wiązania języka Tcl do VTK
250Group: Development/Libraries
251Requires: %{name}-devel = %{version}-%{release}
252Requires: %{name}-tcl = %{version}-%{release}
253Requires: tcl-devel
254Requires: tk-devel
255
256%description tcl-devel
257Header files for Tcl VTK bindings.
258
259%description tcl-devel -l pl.UTF-8
260Pliki nagłówkowe wiązania języka Tcl do VTK.
261
262%package examples
263Summary: C++, Tcl and Python example programs/scripts for VTK
264Summary(pl.UTF-8): Przykładowe programy/skrypty w C++, Tcl-u i Pythonie dla VTK
265Group: Development/Libraries
266Requires: %{name} = %{version}-%{release}
267Requires: %{name}-data = %{version}-%{release}
268
269%description examples
270This package contains all the examples from the VTK source. To compile
271the C++ examples you will need to install the vtk-devel package as
272well. The Python and Tcl examples can be run with the corresponding
273packages (vtk-python, vtk-tcl).
274
275%description examples -l pl.UTF-8
276Ten pakiet zawiera wszystkie przykłady ze źródeł VTK. Do skompilowania
277przykładów w C++ trzeba doinstalować pakiet vtk-devel. Przykłady w
278Pythonie i Tcl-u można uruchamiać przy użyciu odpowiednich pakietów
279(vtk-python, vtk-tcl).
280
281%package test-suite
282Summary: Test programs for VTK
283Summary(pl.UTF-8): Programy testowe dla VTK
284Group: Development/Libraries
285Requires: %{name} = %{version}-%{release}
286Requires: %{name}-data = %{version}-%{release}
287
288%description test-suite
289This package contains all testing programs from the VTK source. The
290source code of these programs can be found in the vtk-examples
291package.
292
293%description test-suite -l pl.UTF-8
294Ten pakiet zawiera wszystkie programy testowe ze źródeł VTK. Kod
295źródłowy tych programów można znaleźć w pakiecie vtk-examples.
296
297%package data
298Summary: Data files for VTK
299Summary(pl.UTF-8): Pliki danych dla VTK
300Group: Development/Libraries
301%if "%{_rpmversion}" >= "5"
302BuildArch: noarch
303%endif
304
305%description data
306This package contains all the data from the VTKData repository. These
307data are required to run various examples from the vtk-examples
308package.
309
310%description data -l pl.UTF-8
311Ten pakiet zawiera wszystkie dane z repozytorium VTKData. Dane te są
312potrzebne do uruchamiania różnych przykładów z pakietu vtk-examples.
313
314%prep
315%setup -q -n VTK-%{version} -b 1
316%patch0 -p1
317%patch1 -p1
318%patch2 -p1
319%patch3 -p1
320
321# Replace relative path ../../../VTKData with destination filesystem path
322grep -Erl '(\.\./)+VTKData' Examples | xargs \
323 perl -pi -e 's,(\.\./)+VTKData,%{_datadir}/vtk-6.1,g'
324
325# Save an unbuilt copy of the Example's sources for %doc
326mkdir vtk-examples
327cp -a Examples vtk-examples
328# Don't ship Win32 examples
329%{__rm} -r vtk-examples/Examples/GUI/Win32
330find vtk-examples -type f | xargs chmod -R a-x
331
332%build
333export CFLAGS="%{rpmcflags} -D_UNICODE"
334export CXXFLAGS="%{rpmcxxflags} -D_UNICODE"
335%if %{with java}
336export JAVA_HOME=%{java_home}
337%endif
338
339mkdir -p build
340cd build
341%cmake .. \
342 -Wno-dev \
343 -DBUILD_DOCUMENTATION:BOOL=ON \
344 -DBUILD_EXAMPLES:BOOL=ON \
345 -DBUILD_SHARED_LIBS:BOOL=ON \
346 -DBUILD_TESTING:BOOL=ON \
347 -DCMAKE_C_COMPILER:PATH="%{__cc}" \
348 -DCMAKE_CXX_COMPILER:PATH="%{__cxx}" \
349 -DCMAKE_SKIP_RPATH:BOOL=ON \
350 -DOPENGL_INCLUDE_PATH:PATH=%{_includedir}/GL \
351 -DPYTHON_INCLUDE_PATH:PATH=%{py_incdir} \
352 -DPYTHON_LIBRARY:FILEPATH=%{_libdir}/libpython%{py_ver}.so \
353 -DPYTHON_UTIL_LIBRARY:PATH=%{_libdir}/libutil.so \
354 -DTCL_INCLUDE_PATH:PATH=%{_includedir} \
355 -DTCL_LIBRARY:PATH=%{_libdir}/libtcl.so \
356 -DTK_INCLUDE_PATH:PATH=%{_includedir} \
357 -DTK_LIBRARY:PATH=%{_libdir}/libtk.so \
358 -DVTK_DATA_ROOT:PATH=%{_datadir}/vtk-6.1 \
359 -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
360 -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/vtk \
361 -DVTK_INSTALL_INCLUDE_DIR:PATH=include/vtk \
362 -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/vtk \
363 -DVTK_INSTALL_PACKAGE_DIR:PATH=%{_lib}/cmake/vtk \
364 -DVTK_INSTALL_TCL_DIR:PATH=share/tcl%{tcl_version}/vtk \
365 -DVTK_INSTALL_PYTHON_MODULE_DIR:PATH=%{py_sitedir} \
366 -DVTK_INSTALL_QT_DIR=/%{_lib}/qt4/plugins/designer \
367 -DVTK_FFMPEG_HAS_OLD_HEADER:BOOL=OFF \
368 %{?with_OSMesa:-DVTK_OPENGL_HAS_OSMESA:BOOL=ON} \
369 -DVTK_WRAP_PYTHON:BOOL=ON \
370 -DVTK_PYTHON_SETUP_ARGS="--prefix=/usr --root=$RPM_BUILD_ROOT" \
371 -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
372 -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
373 -DVTK_USE_RENDERING:BOOL=ON \
374 -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
375 -DVTK_USE_SYSTEM_XDMF2:BOOL=OFF \
376 %{!?with_system_proj:-DVTK_USE_SYSTEM_LIBPROJ4:BOOL=OFF} \
377%if %{with java}
378 -DVTK_WRAP_JAVA:BOOL=ON \
379 -DJAVA_INCLUDE_PATH:PATH=$JAVA_HOME/include \
380 -DJAVA_INCLUDE_PATH2:PATH=$JAVA_HOME/include/linux \
381 -DJAVA_AWT_INCLUDE_PATH:PATH=$JAVA_HOME/include \
382%else
383 -DVTK_WRAP_JAVA:BOOL=OFF \
384%endif
385 -DVTK_WRAP_PYTHON:BOOL=ON \
386 %{?with_sip:-DVTK_WRAP_PYTHON_SIP:BOOL=ON} \
387 -DVTK_WRAP_TCL:BOOL=ON \
388 -DVTK_Group_Imaging:BOOL=ON \
389 -DVTK_Group_Qt:BOOL=ON \
390 -DVTK_Group_Rendering:BOOL=ON \
391 -DVTK_Group_StandAlone:BOOL=ON \
392 -DVTK_Group_Tk:BOOL=ON \
393 -DVTK_Group_Views:BOOL=ON \
394 -DModule_vtkFiltersReebGraph:BOOL=ON \
395 -DModule_vtkFiltersStatisticsGnuR:BOOL=ON \
396 %{?with_ffmpeg:-DModule_vtkIOFFMPEG:BOOL=ON} \
397 -DModule_vtkIOGDAL:BOOL=ON \
398 -DModule_vtkIOGeoJSON:BOOL=ON \
399 -DModule_vtkIOMySQL:BOOL=ON \
400 -DModule_vtkIOODBC:BOOL=ON \
401 -DModule_vtkIOParallelExodus:BOOL=ON \
402 -DModule_vtkIOParallelLSDyna:BOOL=ON \
403 -DModule_vtkIOPostgreSQL:BOOL=ON \
404 -DModule_vtkIOVPIC:BOOL=ON \
405 -DModule_vtkIOXdmf2:BOOL=ON \
406 -DModule_vtkInfovisBoost:BOOL=ON \
407 -DModule_vtkInfovisBoostGraphAlgorithms:BOOL=ON \
408 -DModule_vtkRenderingFreeTypeFontConfig:BOOL=ON \
409 -DModule_vtkRenderingMatplotlib:BOOL=ON \
410 -DModule_vtkRenderingParallel:BOOL=ON
411# TODO: -DModule_vtkAcceleratorsDax:BOOL=ON (BR: FindDax.cmake, maybe http://www.daxtoolkit.org/ ?)
412# TODO: -DModule_vtkAcceleratorsPiston:BOOL=ON (on bcond, BR: CUDA)
413# TODO: -DModule_vtkFiltersParallelFlowPaths:BOOL=ON (BR: MPI)
414# TODO: -DModule_vtkFiltersParallelStatistics:BOOL=ON (BR: MPI)
415# TODO: -DModule_vtkInfovisParallel:BOOL=ON (BR: MPI)
416# TODO: -DModule_vtkRenderingParallelLIC:BOOL=ON (BR: MPI)
417
418%{__make}
419
420%install
421rm -rf $RPM_BUILD_ROOT
422install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ld.so.conf.d,%{_examplesdir}/%{name}-%{version}}
423
424%{__make} -C build install \
425 DESTDIR=$RPM_BUILD_ROOT
426
427# ld config
428echo %{_libdir}/vtk > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
429
430for f in $(cd build/ExternalData/Testing ; find Data -type l); do
431 install -Dp build/ExternalData/Testing/$f $RPM_BUILD_ROOT%{_datadir}/vtk-6.1/$f
432done
433
434# Install utilities
435install build/bin/lproj $RPM_BUILD_ROOT%{_bindir}
436
437# Install examples
438for f in \
439AmbientSpheres \
440Arrays \
441BalloonWidget \
442BandedContours \
443Cone \
444Cone2 \
445Cone3 \
446Cone4 \
447Cone5 \
448Cone6 \
449Cube \
450Cylinder \
451Delaunay3D \
452Delaunay3DAlpha \
453DiffuseSpheres \
454DumpXMLFile \
455FilledContours \
456FixedPointVolumeRayCastMapperCT \
457GPURenderDemo \
458Generate2DAMRDataSetWithPulse \
459Generate3DAMRDataSetWithPulse \
460GenerateCubesFromLabels \
461GenerateModelsFromLabels \
462HierarchicalBoxPipeline \
463ImageDataLIC2DDemo \
464ImageSlicing \
465LabeledMesh \
466Medical1 \
467Medical2 \
468Medical3 \
469Medical4 \
470MultiBlock \
471ParticleReader \
472RGrid \
473SGrid \
474SimpleView \
475Slider \
476Slider2D \
477SpecularSpheres \
478StructuredGridLIC2DDemo \
479SurfaceLICDemo \
480TimeRenderer \
481TimeRenderer2 \
482TubesWithVaryingRadiusAndColors \
483finance ; do
484 install build/bin/$f $RPM_BUILD_ROOT%{_bindir}
485done
486
487# Install test binaries
488for f in build/bin/*Tests build/bin/Test* build/bin/VTKBenchMark ; do
489 install $f $RPM_BUILD_ROOT%{_bindir}
490done
491
492install build/bin/VTKJavaExecutable $RPM_BUILD_ROOT%{_bindir}
493install build/bin/vtkpython $RPM_BUILD_ROOT%{_bindir}
494
495# unwanted doxygen files and misplaced verdict docs
496%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/vtk-6.1/{doxygen,verdict}
497
498# only *.pyc are built by default, add *.pyo
499%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/vtk
500%py_postclean
501
502%clean
503rm -rf $RPM_BUILD_ROOT
504
505%post -p /sbin/ldconfig
506%postun -p /sbin/ldconfig
507
508%post qt -p /sbin/ldconfig
509%postun qt -p /sbin/ldconfig
510
511%post java -p /sbin/ldconfig
512%postun java -p /sbin/ldconfig
513
514%post python -p /sbin/ldconfig
515%postun python -p /sbin/ldconfig
516
517%post tcl -p /sbin/ldconfig
518%postun tcl -p /sbin/ldconfig
519
520%files
521%defattr(644,root,root,755)
522%doc README.html vtkLogo.jpg vtkBanner.gif Wrapping/Tools/README*
523%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
524%dir %{_libdir}/vtk
525%attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so.1
526%attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so.1
527%attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so.1
528%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so.1
529%attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so.1
530%attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so.1
531%attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so.1
532%attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so.1
533%attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so.1
534%attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so.1
535%attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so.1
536%attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so.1
537%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so.1
538%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so.1
539%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so.1
540%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so.1
541%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so.1
542%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeOpenGL.so.1
543%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PS.so.1
544%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so.1
545%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLIC.so.1
546%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so.1
547%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so.1
548%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL.so.1
549%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so.1
550%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so.1
551%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeAMR.so.1
552%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL.so.1
553%attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so.1
554%attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so.1
555%attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so.1
556%attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so.1
557%attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so.1
558%attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so.1
559%attr(755,root,root) %{_libdir}/vtk/libvtkalglib.so.1
560%attr(755,root,root) %{_libdir}/vtk/libvtkexoIIc.so.1
561%attr(755,root,root) %{_libdir}/vtk/libvtkftgl.so.1
562%attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so.1
563%attr(755,root,root) %{_libdir}/vtk/libvtkproj4.so.1
564%attr(755,root,root) %{_libdir}/vtk/libvtksqlite.so.1
565%attr(755,root,root) %{_libdir}/vtk/libvtksys.so.1
566%attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so.1
567%attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so.1
568%exclude %{_libdir}/vtk/libvtk*Java.so.1
569%exclude %{_libdir}/vtk/libvtk*Python2?D.so.1
570%exclude %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
571%exclude %{_libdir}/vtk/libvtk*TCL.so.1
572
573%files devel
574%defattr(644,root,root,755)
575%doc Utilities/Upgrading/*
576%attr(755,root,root) %{_bindir}/lproj
577%attr(755,root,root) %{_bindir}/vtkEncodeString
578%attr(755,root,root) %{_bindir}/vtkHashSource
579%attr(755,root,root) %{_bindir}/vtkParseOGLExt
580%attr(755,root,root) %{_bindir}/vtkWrapHierarchy
581%attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so
582%attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so
583%attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so
584%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so
585%attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so
586%attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so
587%attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so
588%attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so
589%attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so
590%attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so
591%attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so
592%attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so
593%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so
594%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so
595%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so
596%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so
597%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so
598%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeOpenGL.so
599%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PS.so
600%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so
601%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLIC.so
602%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so
603%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so
604%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL.so
605%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so
606%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so
607%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeAMR.so
608%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL.so
609%attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so
610%attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so
611%attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so
612%attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so
613%attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so
614%attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so
615%attr(755,root,root) %{_libdir}/vtk/libvtkalglib.so
616%attr(755,root,root) %{_libdir}/vtk/libvtkexoIIc.so
617%attr(755,root,root) %{_libdir}/vtk/libvtkftgl.so
618%attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so
619%attr(755,root,root) %{_libdir}/vtk/libvtkproj4.so
620%attr(755,root,root) %{_libdir}/vtk/libvtksqlite.so
621%attr(755,root,root) %{_libdir}/vtk/libvtksys.so
622%attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so
623%attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so
624%exclude %{_libdir}/vtk/libvtk*Java.so
625%exclude %{_libdir}/vtk/libvtk*Python2?D.so
626%exclude %{_libdir}/vtk/libvtkWrappingPython2?Core.so
627%exclude %{_libdir}/vtk/libvtk*TCL.so
628%{_libdir}/vtk/libvtkWrappingTools.a
629%dir %{_includedir}/vtk
630%{_includedir}/vtk/VPIC
631%{_includedir}/vtk/DICOM*.h
632%{_includedir}/vtk/DatabaseSchemaWith2Tables.h
633%{_includedir}/vtk/LSDyna*.h
634%{_includedir}/vtk/alglib
635%{_includedir}/vtk/vtklibproj4
636%{_includedir}/vtk/vtkmetaio
637%{_includedir}/vtk/vtkverdict
638%{_includedir}/vtk/vtksqlite
639%{_includedir}/vtk/vtksys
640%{_includedir}/vtk/vtkxdmf2
641%{_includedir}/vtk/vtk*.h
642%{_includedir}/vtk/vtk*.txx
643%exclude %{_includedir}/vtk/vtkEventQtSlotConnect.h
644%exclude %{_includedir}/vtk/vtkGUISupportQt*.h
645%exclude %{_includedir}/vtk/vtkJavaUtil.h
646%exclude %{_includedir}/vtk/vtkWrappingJavaModule.h
647%exclude %{_includedir}/vtk/vtkPython*.h
648%exclude %{_includedir}/vtk/vtkQImageToImageSource.h
649%exclude %{_includedir}/vtk/vtkQt*.h
650%exclude %{_includedir}/vtk/vtkRenderingQtModule.h
651%exclude %{_includedir}/vtk/vtkTcl*.h
652%exclude %{_includedir}/vtk/vtkTk*.h
653%exclude %{_includedir}/vtk/vtkViewsQtModule.h
654%{_libdir}/cmake/vtk
655
656%files qt
657%defattr(644,root,root,755)
658%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so.1
659%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtOpenGL.so.1
660%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so.1
661%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtWebkit.so.1
662%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so.1
663%attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so.1
664%attr(755,root,root) %{_libdir}/qt4/plugins/designer/libQVTKWidgetPlugin.so
665
666%files qt-devel
667%defattr(644,root,root,755)
668%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so
669%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtOpenGL.so
670%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so
671%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtWebkit.so
672%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so
673%attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so
674%{_includedir}/vtk/QFilterTreeProxyModel.h
675%{_includedir}/vtk/QVTK*.h
676%{_includedir}/vtk/vtkEventQtSlotConnect.h
677%{_includedir}/vtk/vtkGUISupportQt*.h
678%{_includedir}/vtk/vtkQImageToImageSource.h
679%{_includedir}/vtk/vtkQt*.h
680%{_includedir}/vtk/vtkRenderingQtModule.h
681%{_includedir}/vtk/vtkViewsQtModule.h
682
683%if %{with java}
684%files java
685%defattr(644,root,root,755)
686%attr(755,root,root) %{_bindir}/VTKJavaExecutable
687%attr(755,root,root) %{_bindir}/vtkParseJava
688%attr(755,root,root) %{_bindir}/vtkWrapJava
689# common library
690%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so.1
691# java modules
692%attr(755,root,root) %{_libdir}/vtk/libvtkChartsCoreJava.so
693%attr(755,root,root) %{_libdir}/vtk/libvtkCommon*Java.so
694%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryJava.so
695%attr(755,root,root) %{_libdir}/vtk/libvtkFilters*Java.so
696%attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCoreJava.so
697%attr(755,root,root) %{_libdir}/vtk/libvtkIO*Java.so
698%attr(755,root,root) %{_libdir}/vtk/libvtkImaging*Java.so
699%attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*Java.so
700%attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*Java.so
701%attr(755,root,root) %{_libdir}/vtk/libvtkLocalExampleJava.so
702%attr(755,root,root) %{_libdir}/vtk/libvtkParallelCoreJava.so
703%attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreterJava.so
704%attr(755,root,root) %{_libdir}/vtk/libvtkRendering*Java.so
705%attr(755,root,root) %{_libdir}/vtk/libvtkTestingRenderingJava.so
706%attr(755,root,root) %{_libdir}/vtk/libvtkViews*Java.so
707%{_libdir}/vtk/vtk.jar
708
709%files java-devel
710%defattr(644,root,root,755)
711%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so
712%{_includedir}/vtk/vtkJavaUtil.h
713%{_includedir}/vtk/vtkWrappingJavaModule.h
714%endif
715
716%files python
717%defattr(644,root,root,755)
718%doc Wrapping/Python/README*
719%attr(755,root,root) %{_bindir}/vtkWrapPython
720%attr(755,root,root) %{_bindir}/vtkWrapPythonInit
721%attr(755,root,root) %{_bindir}/vtkpython
722%attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so.1
723%attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so.1
724# RenderingMatplotlib requires PythonInterpreter
725%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so.1
726%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingPythonTkWidgets-6.1.so
727%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
728%dir %{py_sitedir}/vtk
729%{py_sitedir}/vtk/*.py[co]
730%dir %{py_sitedir}/vtk/gtk
731%{py_sitedir}/vtk/gtk/*.py[co]
732%dir %{py_sitedir}/vtk/qt4
733%{py_sitedir}/vtk/qt4/*.py[co]
734%dir %{py_sitedir}/vtk/test
735%{py_sitedir}/vtk/test/*.py[co]
736%dir %{py_sitedir}/vtk/tk
737%{py_sitedir}/vtk/tk/*.py[co]
738%dir %{py_sitedir}/vtk/util
739%{py_sitedir}/vtk/util/*.py[co]
740%dir %{py_sitedir}/vtk/wx
741%{py_sitedir}/vtk/wx/*.py[co]
742%attr(755,root,root) %{py_sitedir}/vtk/vtk*Python.so
743
744%files python-devel
745%defattr(644,root,root,755)
746%attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so
747%attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so
748%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so
749%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so
750%{_includedir}/vtk/PyVTK*.h
751%{_includedir}/vtk/vtkPython*.h
752
753%files tcl
754%defattr(644,root,root,755)
755%doc Wrapping/Tcl/README*
756%attr(755,root,root) %{_bindir}/vtkWrapTcl
757%attr(755,root,root) %{_bindir}/vtkWrapTclInit
758%attr(755,root,root) %{_bindir}/vtk
759%{_datadir}/tcl%{tcl_version}/vtk
760%attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so.1
761
762%files tcl-devel
763%defattr(644,root,root,755)
764%attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so
765%{_includedir}/vtk/vtkTcl*.h
766%{_includedir}/vtk/vtkTk*.h
767
768%files test-suite
769%defattr(644,root,root,755)
770%attr(755,root,root) %{_bindir}/*Tests
771%attr(755,root,root) %{_bindir}/Test*
772%attr(755,root,root) %{_bindir}/VTKBenchMark
773
774%files examples
775%defattr(644,root,root,755)
776%attr(755,root,root) %{_bindir}/AmbientSpheres
777%attr(755,root,root) %{_bindir}/Arrays
778%attr(755,root,root) %{_bindir}/Cone
779%attr(755,root,root) %{_bindir}/Cone2
780%attr(755,root,root) %{_bindir}/Cone3
781%attr(755,root,root) %{_bindir}/Cone4
782%attr(755,root,root) %{_bindir}/Cone5
783%attr(755,root,root) %{_bindir}/Cone6
784%attr(755,root,root) %{_bindir}/Cube
785%attr(755,root,root) %{_bindir}/Cylinder
786%attr(755,root,root) %{_bindir}/DiffuseSpheres
787%attr(755,root,root) %{_bindir}/HierarchicalBoxPipeline
788%attr(755,root,root) %{_bindir}/Medical1
789%attr(755,root,root) %{_bindir}/Medical2
790%attr(755,root,root) %{_bindir}/Medical3
791%attr(755,root,root) %{_bindir}/Medical4
792%attr(755,root,root) %{_bindir}/MultiBlock
793%attr(755,root,root) %{_bindir}/RGrid
794%attr(755,root,root) %{_bindir}/SGrid
795%attr(755,root,root) %{_bindir}/SimpleView
796%attr(755,root,root) %{_bindir}/SpecularSpheres
797%attr(755,root,root) %{_bindir}/finance
798%attr(755,root,root) %{_bindir}/BalloonWidget
799%attr(755,root,root) %{_bindir}/BandedContours
800%attr(755,root,root) %{_bindir}/Delaunay3D
801%attr(755,root,root) %{_bindir}/Delaunay3DAlpha
802%attr(755,root,root) %{_bindir}/DumpXMLFile
803%attr(755,root,root) %{_bindir}/FilledContours
804%attr(755,root,root) %{_bindir}/FixedPointVolumeRayCastMapperCT
805%attr(755,root,root) %{_bindir}/GPURenderDemo
806%attr(755,root,root) %{_bindir}/Generate2DAMRDataSetWithPulse
807%attr(755,root,root) %{_bindir}/Generate3DAMRDataSetWithPulse
808%attr(755,root,root) %{_bindir}/GenerateCubesFromLabels
809%attr(755,root,root) %{_bindir}/GenerateModelsFromLabels
810%attr(755,root,root) %{_bindir}/ImageDataLIC2DDemo
811%attr(755,root,root) %{_bindir}/ImageSlicing
812%attr(755,root,root) %{_bindir}/LabeledMesh
813%attr(755,root,root) %{_bindir}/ParticleReader
814%attr(755,root,root) %{_bindir}/Slider
815%attr(755,root,root) %{_bindir}/Slider2D
816%attr(755,root,root) %{_bindir}/StructuredGridLIC2DDemo
817%attr(755,root,root) %{_bindir}/SurfaceLICDemo
818%attr(755,root,root) %{_bindir}/TimeRenderer
819%attr(755,root,root) %{_bindir}/TimeRenderer2
820%attr(755,root,root) %{_bindir}/TubesWithVaryingRadiusAndColors
821%{_examplesdir}/%{name}-%{version}
822
823%files data
824%defattr(644,root,root,755)
825%dir %{_datadir}/vtk-6.1
826%{_datadir}/vtk-6.1/Data
827%{_datadir}/vtk-6.1/vtkDomainsChemistry
This page took 0.17767 seconds and 4 git commands to generate.