]> git.pld-linux.org Git - packages/vtk.git/blame_incremental - vtk.spec
- release 6 (by relup.sh)
[packages/vtk.git] / vtk.spec
... / ...
CommitLineData
1# TODO:
2# - handle VTK_USE_MPEG2_ENCODER (see CMakeLists.txt)
3# - handle MPI and VTK_USE_PARALLEL_BGL (Parallel Boost Graph Library, BR: boost >= 1.40)
4# - more system libraries? (check for VTK_THIRD_PARTY_SUBDIR in Utilities/CMakeLists.txt)
5# - CUDA for Accelerators/Piston (on bcond)
6# - NVCtrlLib for Rendering/OpenGL (on bcond)
7# - VTK_USE_SYSTEM_XDMF2=ON ? (but our xdmf-devel seems not compatible)
8# - python bcond?
9#
10# Conditional build
11%bcond_without java # Java wrappers
12%bcond_without ffmpeg # FFMPEG .avi saving support
13%bcond_with OSMesa # build with OSMesa (https://bugzilla.redhat.com/show_bug.cgi?id=744434)
14%bcond_with system_proj # use system PROJ.4 (needs 4.3 with exposed internals, not ready for 4.4+)
15%bcond_with system_gl2ps # use system gl2ps (VTK currently is carrying local modifications to gl2ps)
16
17Summary: Toolkit for 3D computer graphics, image processing, and visualization
18Summary(pl.UTF-8): Zestaw narzędzi do trójwymiarowej grafiki, przetwarzania obrazu i wizualizacji
19Name: vtk
20Version: 8.1.1
21Release: 6
22License: BSD
23Group: Libraries
24Source0: http://www.vtk.org/files/release/8.1/VTK-%{version}.tar.gz
25# Source0-md5: cf078a71c298c76b13707c7c27704248
26Source1: http://www.vtk.org/files/release/8.1/VTKData-%{version}.tar.gz
27# Source1-md5: 6de8c1e3884b805c47dca02e7b049301
28Patch0: vtk-abi.patch
29URL: http://www.vtk.org/
30%{?with_OSMesa:BuildRequires: Mesa-libOSMesa-devel}
31BuildRequires: OpenGL-GLX-devel
32BuildRequires: OpenGL-devel
33BuildRequires: Qt5Core-devel
34BuildRequires: Qt5Designer-devel
35BuildRequires: Qt5Gui-devel
36BuildRequires: Qt5Network-devel
37BuildRequires: Qt5OpenGL-devel
38BuildRequires: Qt5Sql-devel
39BuildRequires: Qt5WebKit-devel
40BuildRequires: Qt5X11Extras-devel
41BuildRequires: Qt5XmlPatterns-devel
42BuildRequires: Qt5UiTools-devel
43BuildRequires: R
44BuildRequires: boost-devel >= 1.39
45BuildRequires: cmake >= 2.8.8
46BuildRequires: doxygen
47BuildRequires: expat-devel
48%{?with_ffmpeg:BuildRequires: ffmpeg-devel}
49BuildRequires: fontconfig-devel
50BuildRequires: freetype-devel >= 2
51BuildRequires: gdal-devel
52%{?with_system_gl2ps:BuildRequires: gl2ps-devel >= 1.3.8}
53BuildRequires: gnuplot
54BuildRequires: graphviz
55BuildRequires: hdf5-devel
56%if %{with java}
57BuildRequires: jdk >= 1.5
58BuildRequires: jpackage-utils
59%endif
60BuildRequires: jsoncpp-devel
61BuildRequires: libjpeg-devel
62BuildRequires: libogg-devel
63BuildRequires: libpng-devel
64BuildRequires: libstdc++-devel
65BuildRequires: libtheora-devel
66BuildRequires: libtiff-devel
67BuildRequires: libxml2-devel >= 2
68BuildRequires: lz4-devel
69BuildRequires: motif-devel
70BuildRequires: mysql-devel
71BuildRequires: netcdf-cxx-devel >= 4
72# some code using it exists (Domains/Chemistry), but is not included in cmakefiles
73#BuildRequires: openqube-devel
74BuildRequires: perl-base
75BuildRequires: postgresql-devel
76%{?with_system_proj:BuildRequires: proj-devel >= 4.3, proj-devel < 4.4}
77BuildRequires: python-devel >= 2
78BuildRequires: python-sip-devel
79BuildRequires: qt5-build >= 4.5.0
80BuildRequires: qt5-qmake >= 4.5.0
81BuildRequires: rpmbuild(macros) >= 1.605
82BuildRequires: sip
83BuildRequires: sip-PyQt5
84BuildRequires: tcl-devel
85BuildRequires: tk-devel
86BuildRequires: unixODBC-devel
87BuildRequires: wget
88BuildRequires: xorg-lib-libICE-devel
89BuildRequires: xorg-lib-libSM-devel
90BuildRequires: xorg-lib-libX11-devel
91BuildRequires: xorg-lib-libXScrnSaver-devel
92BuildRequires: xorg-lib-libXext-devel
93BuildRequires: xorg-lib-libXft-devel
94BuildRequires: xorg-lib-libXt-devel
95BuildRequires: zlib-devel
96BuildConflicts: libXNVCtrl-devel
97%{?with_system_gl2ps:Requires: gl2ps >= 1.3.8}
98BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100%define skip_post_check_so lib.*Python.*\.so.*
101
102%description
103The Visualization ToolKit (VTK) is an object oriented software system
104for 3D computer graphics, image processing, and visualization. VTK
105includes a textbook, a C++ class library, and several interpreted
106interface layers including Tcl/Tk, Java, and Python. VTK supports a
107wide variety of visualization algorithms including scalar, vector,
108tensor, texture, and volumetric methods. It also supports advanced
109modeling techniques like implicit modeling, polygon reduction, mesh
110smoothing, cutting, contouring, and Delaunay triangulation. Moreover,
111dozens of imaging algorithms have been integrated into the system.
112This allows mixing 2D imaging / 3D graphics algorithms and data.
113
114%description -l pl.UTF-8
115Visualization TookKit (VTK) to obiektowo zorientowany system
116oprogramowania do trójwymiarowej grafiki komputerowej, przetwarzania
117obrazu i wizualizacji. VTK zawiera książkę, bibliotekę klas C++ oraz
118kilka interpretowanych warstw interfejsów, w tym dla Tcl/Tk, Javy i
119Pythona. VTK obsługuje szeroki zakres algorytmów wizualizacji, w tym
120metody skalarne, wektorowe, tensorowe, teksturowe i wolumetryczne.
121Obsługuje także zaawansowane techniki modelowania, takie jak
122modelowanie implicite, redukcja wielokątów, wygładzanie siatki,
123przycinanie, konturowanie i triangulacja Delaunaya. Co więcej, wiele
124algorytmów obrazowania zostało zintegrowanych z systemem. Pozwala to
125na mieszanie algorytmów obrazowania 2D i grafiki 3D.
126
127%package devel
128Summary: VTK header files for building C++ code
129Summary(pl.UTF-8): Pliki nagłówkowe VTK dla C++
130Group: Development
131Requires: %{name} = %{version}-%{release}
132Requires: libstdc++-devel
133
134%description devel
135This provides the VTK header files required to compile C++ programs
136that use VTK to do 3D visualisation.
137
138%description devel -l pl.UTF-8
139Ten pakiet dostarcza pliki nagłówkowe VTK do kompilowania programów
140C++ używających VTK do wizualizacji 3D.
141
142%package qt
143Summary: Qt5 bindings and Qt5 Designer plugin for VTK
144Summary(pl.UTF-8): Wiązania Qt5 oraz wtyczka Qt5 Designera do VTK
145Group: X11/Libraries
146Requires: %{name} = %{version}-%{release}
147Requires: Qt5Core >= 4.5.0
148Requires: Qt5Gui >= 4.5.0
149Requires: Qt5Network >= 4.5.0
150Requires: Qt5OpenGL >= 4.5.0
151Requires: Qt5Sql >= 4.5.0
152Requires: Qt5WebKit >= 4.5.0
153
154%description qt
155Qt5 bindings and Qt5 Designer plugin for VTK.
156
157%description qt -l pl.UTF-8
158Wiązania Qt5 oraz wtyczka Qt5 Designera do VTK.
159
160%package qt-devel
161Summary: Header files for VTK Qt5 bindings
162Summary(pl.UTF-8): Pliki nagłówkowe wiązań Qt5` do VTK
163Group: X11/Development/Libraries
164Requires: %{name}-devel = %{version}-%{release}
165Requires: %{name}-qt = %{version}-%{release}
166Requires: Qt5Core-devel >= 4.5.0
167Requires: Qt5Gui-devel >= 4.5.0
168Requires: Qt5OpenGL-devel >= 4.5.0
169Requires: Qt5Sql-devel >= 4.5.0
170
171%description qt-devel
172Header files for VTK Qt bindings.
173
174%description qt-devel -l pl.UTF-8
175Pliki nagłówkowe wiązań Qt do VTK.
176
177%package java
178Summary: Java bindings for VTK
179Summary(pl.UTF-8): Wiązania Javy do VTK
180Group: Development/Languages/Java
181Requires: %{name} = %{version}-%{release}
182# or separate qt parts?
183Requires: %{name}-qt = %{version}-%{release}
184
185%description java
186This package contains Java bindings for VTK.
187
188%description java -l pl.UTF-8
189Ten pakiet zawiera wiązania Javy do VTK.
190
191%package java-devel
192Summary: Header files for Java VTK binding
193Summary(pl.UTF-8): Pliki nagłówkowe wiązania Javy do VTK
194Group: Development/Libraries
195Requires: %{name}-devel = %{version}-%{release}
196Requires: %{name}-java = %{version}-%{release}
197# <jni.h>
198Requires: jdk
199
200%description java-devel
201Header files for Java VTK binding.
202
203%description java-devel -l pl.UTF-8
204Pliki nagłówkowe wiązania Javy do VTK.
205
206%package python
207Summary: Python bindings for VTK
208Summary(pl.UTF-8): Wiązania Pythona do VTK
209Group: Libraries
210Requires: %{name} = %{version}-%{release}
211# or separate qt parts again?
212Requires: %{name}-qt = %{version}-%{release}
213Obsoletes: vtk-python-qt < 6.0.0-1
214Obsoletes: vtk-python-sip < 6.0.0-1
215
216%description python
217This package contains Python bindings for VTK.
218
219%description python -l pl.UTF-8
220Ten pakiet zawiera wiązania Pythona do VTK.
221
222%package python-devel
223Summary: Header files for Python VTK binding
224Summary(pl.UTF-8): Pliki nagłówkowe wiązania Pythona do VTK
225Group: Development/Libraries
226Requires: %{name}-devel = %{version}-%{release}
227Requires: %{name}-python = %{version}-%{release}
228Requires: python-devel
229
230%description python-devel
231Header files for Python VTK binding.
232
233%description python-devel -l pl.UTF-8
234Pliki nagłówkowe wiązania Pythona do VTK.
235
236%package tcl
237Summary: Tcl bindings for VTK
238Summary(pl.UTF-8): Wiązania języka Tcl do VTK
239Group: Libraries
240Requires: %{name} = %{version}-%{release}
241# or separate qt parts?
242Requires: %{name}-qt = %{version}-%{release}
243
244%description tcl
245This package contains Tcl bindings for VTK.
246
247%description tcl -l pl.UTF-8
248Ten pakiet zawiera wiązania języka Tcl do VTK.
249
250%package tcl-devel
251Summary: Header files for Tcl VTK bindings
252Summary(pl.UTF-8): Pliki nagłówkowe wiązania języka Tcl do VTK
253Group: Development/Libraries
254Requires: %{name}-devel = %{version}-%{release}
255Requires: %{name}-tcl = %{version}-%{release}
256Requires: tcl-devel
257Requires: tk-devel
258
259%description tcl-devel
260Header files for Tcl VTK bindings.
261
262%description tcl-devel -l pl.UTF-8
263Pliki nagłówkowe wiązania języka Tcl do VTK.
264
265%package examples
266Summary: C++, Tcl and Python example programs/scripts for VTK
267Summary(pl.UTF-8): Przykładowe programy/skrypty w C++, Tcl-u i Pythonie dla VTK
268Group: Development/Libraries
269Requires: %{name} = %{version}-%{release}
270Requires: %{name}-data = %{version}-%{release}
271
272%description examples
273This package contains all the examples from the VTK source. To compile
274the C++ examples you will need to install the vtk-devel package as
275well. The Python and Tcl examples can be run with the corresponding
276packages (vtk-python, vtk-tcl).
277
278%description examples -l pl.UTF-8
279Ten pakiet zawiera wszystkie przykłady ze źródeł VTK. Do skompilowania
280przykładów w C++ trzeba doinstalować pakiet vtk-devel. Przykłady w
281Pythonie i Tcl-u można uruchamiać przy użyciu odpowiednich pakietów
282(vtk-python, vtk-tcl).
283
284%package test-suite
285Summary: Test programs for VTK
286Summary(pl.UTF-8): Programy testowe dla VTK
287Group: Development/Libraries
288Requires: %{name} = %{version}-%{release}
289Requires: %{name}-data = %{version}-%{release}
290
291%description test-suite
292This package contains all testing programs from the VTK source. The
293source code of these programs can be found in the vtk-examples
294package.
295
296%description test-suite -l pl.UTF-8
297Ten pakiet zawiera wszystkie programy testowe ze źródeł VTK. Kod
298źródłowy tych programów można znaleźć w pakiecie vtk-examples.
299
300%package data
301Summary: Data files for VTK
302Summary(pl.UTF-8): Pliki danych dla VTK
303Group: Development/Libraries
304%if "%{_rpmversion}" >= "5"
305BuildArch: noarch
306%endif
307
308%description data
309This package contains all the data from the VTKData repository. These
310data are required to run various examples from the vtk-examples
311package.
312
313%description data -l pl.UTF-8
314Ten pakiet zawiera wszystkie dane z repozytorium VTKData. Dane te są
315potrzebne do uruchamiania różnych przykładów z pakietu vtk-examples.
316
317%prep
318%setup -q -n VTK-%{version} -b 1
319%patch0 -p1
320
321# Replace relative path ../../../VTKData with destination filesystem path
322grep -Erl '(\.\./)+VTKData' Examples | xargs \
323 perl -pi -e 's,(\.\./)+VTKData,%{_datadir}/vtk-8.1,g'
324
325# Save an unbuilt copy of the Example's sources for %doc
326mkdir vtk-examples
327cp -a Examples vtk-examples
328# Don't ship Win32 examples
329%{__rm} -r vtk-examples/Examples/GUI/Win32
330find vtk-examples -type f | xargs chmod -R a-x
331
332%build
333export CFLAGS="%{rpmcflags} -D_UNICODE -DHAVE_UINTPTR_T"
334export CXXFLAGS="%{rpmcxxflags} -D_UNICODE -DHAVE_UINTPTR_T"
335%if %{with java}
336export JAVA_HOME=%{java_home}
337%ifarch x32
338# getting "java.lang.OutOfMemoryError: Java heap space" during the build
339export JAVA_TOOL_OPTIONS=-Xmx2048m
340%endif
341%endif
342
343# handle cmake & ccache
344# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmake
345# ASM fix: http://lists.busybox.net/pipermail/buildroot/2013-March/069436.html
346if [[ "%{__cc}" = *ccache* ]]; then
347 cc="%{__cc}"
348 cxx="%{__cxx}"
349 ccache="
350 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
351 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
352 -DCMAKE_ASM_COMPILER="${cc#ccache }" \
353 "
354else
355 ccache="
356 -DCMAKE_C_COMPILER="%{__cc}" \
357 -DCMAKE_CXX_COMPILER="%{__cxx}" \
358 -DCMAKE_ASM_COMPILER="%{__cc}" \
359 "
360fi
361
362mkdir -p build
363cd build
364%cmake .. \
365 $ccache \
366 -Wno-dev \
367 -DBUILD_DOCUMENTATION:BOOL=ON \
368 -DBUILD_EXAMPLES:BOOL=ON \
369 -DBUILD_SHARED_LIBS:BOOL=ON \
370 -DBUILD_TESTING:BOOL=ON \
371 -DCMAKE_SKIP_RPATH:BOOL=ON \
372 -DOPENGL_INCLUDE_PATH:PATH=%{_includedir}/GL \
373 -DPYTHON_INCLUDE_PATH:PATH=%{py_incdir} \
374 -DPYTHON_LIBRARY:FILEPATH=%{_libdir}/libpython%{py_ver}.so \
375 -DPYTHON_UTIL_LIBRARY:PATH=%{_libdir}/libutil.so \
376 -DTCL_INCLUDE_PATH:PATH=%{_includedir} \
377 -DTCL_LIBRARY:PATH=%{_libdir}/libtcl.so \
378 -DTK_INCLUDE_PATH:PATH=%{_includedir} \
379 -DTK_LIBRARY:PATH=%{_libdir}/libtk.so \
380 -DVTK_DATA_ROOT:PATH=%{_datadir}/vtk-8.1 \
381 -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
382 -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/vtk \
383 -DVTK_INSTALL_INCLUDE_DIR:PATH=include/vtk \
384 -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/vtk \
385 -DVTK_INSTALL_PACKAGE_DIR:PATH=%{_lib}/cmake/vtk \
386 -DVTK_INSTALL_TCL_DIR:PATH=share/tcl%{tcl_version}/vtk \
387 -DVTK_INSTALL_PYTHON_MODULE_DIR:PATH=%{py_sitedir} \
388 -DVTK_INSTALL_QT_DIR=/%{_lib}/qt5/plugins/designer \
389 -DVTK_FFMPEG_HAS_OLD_HEADER:BOOL=OFF \
390 %{?with_OSMesa:-DVTK_OPENGL_HAS_OSMESA:BOOL=ON} \
391 -DVTK_WRAP_PYTHON:BOOL=ON \
392 -DVTK_PYTHON_SETUP_ARGS="--prefix=/usr --root=$RPM_BUILD_ROOT" \
393 -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
394 -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
395 -DVTK_USE_RENDERING:BOOL=ON \
396 -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
397 -DVTK_USE_SYSTEM_XDMF2:BOOL=OFF \
398 -DVTK_USE_SYSTEM_LIBHARU:BOOL=OFF \
399 %{!?with_system_proj:-DVTK_USE_SYSTEM_LIBPROJ4:BOOL=OFF} \
400 %{!?with_system_gl2ps:-DVTK_USE_SYSTEM_GL2PS:BOOL=OFF} \
401%if %{with java}
402 -DVTK_WRAP_JAVA:BOOL=ON \
403 -DJAVA_INCLUDE_PATH:PATH=$JAVA_HOME/include \
404 -DJAVA_INCLUDE_PATH2:PATH=$JAVA_HOME/include/linux \
405 -DJAVA_AWT_INCLUDE_PATH:PATH=$JAVA_HOME/include \
406%else
407 -DVTK_WRAP_JAVA:BOOL=OFF \
408%endif
409 -DVTK_WRAP_PYTHON:BOOL=ON \
410 %{?with_sip:-DVTK_WRAP_PYTHON_SIP:BOOL=ON} \
411 -DVTK_WRAP_TCL:BOOL=ON \
412 -DVTK_Group_Imaging:BOOL=ON \
413 -DVTK_Group_Qt:BOOL=ON \
414 -DVTK_Group_Rendering:BOOL=ON \
415 -DVTK_Group_StandAlone:BOOL=ON \
416 -DVTK_Group_Tk:BOOL=ON \
417 -DVTK_Group_Views:BOOL=ON \
418 -DModule_vtkFiltersReebGraph:BOOL=ON \
419 -DModule_vtkFiltersStatisticsGnuR:BOOL=ON \
420 %{?with_ffmpeg:-DModule_vtkIOFFMPEG:BOOL=ON} \
421 -DModule_vtkIOGDAL:BOOL=ON \
422 -DModule_vtkIOGeoJSON:BOOL=ON \
423 -DModule_vtkIOMySQL:BOOL=ON \
424 -DModule_vtkIOODBC:BOOL=ON \
425 -DModule_vtkIOParallelExodus:BOOL=ON \
426 -DModule_vtkIOParallelLSDyna:BOOL=ON \
427 -DModule_vtkIOPostgreSQL:BOOL=ON \
428 -DModule_vtkIOVPIC:BOOL=ON \
429 -DModule_vtkIOXdmf2:BOOL=ON \
430 -DModule_vtkInfovisBoost:BOOL=ON \
431 -DModule_vtkInfovisBoostGraphAlgorithms:BOOL=ON \
432 -DModule_vtkRenderingFreeTypeFontConfig:BOOL=ON \
433 -DModule_vtkRenderingMatplotlib:BOOL=ON \
434 -DModule_vtkRenderingParallel:BOOL=ON
435# TODO: -DModule_vtkAcceleratorsDax:BOOL=ON (BR: FindDax.cmake, maybe http://www.daxtoolkit.org/ ?)
436# TODO: -DModule_vtkAcceleratorsPiston:BOOL=ON (on bcond, BR: CUDA)
437# TODO: -DModule_vtkFiltersParallelFlowPaths:BOOL=ON (BR: MPI)
438# TODO: -DModule_vtkFiltersParallelStatistics:BOOL=ON (BR: MPI)
439# TODO: -DModule_vtkInfovisParallel:BOOL=ON (BR: MPI)
440# TODO: -DModule_vtkRenderingParallelLIC:BOOL=ON (BR: MPI)
441
442%{__make}
443%{__make} DoxygenDoc
444
445%install
446rm -rf $RPM_BUILD_ROOT
447install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ld.so.conf.d,%{_examplesdir}/%{name}-%{version}}
448
449%{__make} -C build install \
450 DESTDIR=$RPM_BUILD_ROOT
451
452# ld config
453echo %{_libdir}/vtk > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
454
455for f in $(cd build/ExternalData/Testing ; find Data -type l); do
456 install -Dp build/ExternalData/Testing/$f $RPM_BUILD_ROOT%{_datadir}/vtk-8.1/$f
457done
458
459# Install examples
460for f in \
461AmbientSpheres \
462Arrays \
463BalloonWidget \
464BandedContours \
465Cone \
466Cone2 \
467Cone3 \
468Cone4 \
469Cone5 \
470Cone6 \
471Cube \
472Cylinder \
473Delaunay3D \
474Delaunay3DAlpha \
475DiffuseSpheres \
476DumpXMLFile \
477FilledContours \
478FixedPointVolumeRayCastMapperCT \
479GPURenderDemo \
480Generate2DAMRDataSetWithPulse \
481Generate3DAMRDataSetWithPulse \
482GenerateCubesFromLabels \
483GenerateModelsFromLabels \
484HierarchicalBoxPipeline \
485ImageSlicing \
486LabeledMesh \
487Medical1 \
488Medical2 \
489Medical3 \
490Medical4 \
491MultiBlock \
492ParticleReader \
493RGrid \
494SGrid \
495SimpleView \
496Slider \
497Slider2D \
498SpecularSpheres \
499TubesWithVaryingRadiusAndColors \
500finance ; do
501 install build/bin/$f $RPM_BUILD_ROOT%{_bindir}
502done
503
504# Install test binaries
505for f in build/bin/*Tests build/bin/Test*; do
506 install $f $RPM_BUILD_ROOT%{_bindir}
507done
508
509%if %{with java}
510install -p build/bin/VTKJavaExecutable $RPM_BUILD_ROOT%{_bindir}
511%endif
512install -p build/bin/vtkpython $RPM_BUILD_ROOT%{_bindir}
513
514# unwanted doxygen files and misplaced verdict docs
515%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/vtk-*/{doxygen,verdict}
516
517# only *.pyc are built by default, add *.pyo
518%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/vtk
519%py_postclean
520
521%clean
522rm -rf $RPM_BUILD_ROOT
523
524%post -p /sbin/ldconfig
525%postun -p /sbin/ldconfig
526
527%post qt -p /sbin/ldconfig
528%postun qt -p /sbin/ldconfig
529
530%post java -p /sbin/ldconfig
531%postun java -p /sbin/ldconfig
532
533%post python -p /sbin/ldconfig
534%postun python -p /sbin/ldconfig
535
536%post tcl -p /sbin/ldconfig
537%postun tcl -p /sbin/ldconfig
538
539%files
540%defattr(644,root,root,755)
541%doc README.md vtkLogo.jpg vtkBanner.gif Wrapping/Tools/README*
542%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
543%dir %{_libdir}/vtk
544%attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so.1
545%attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so.1
546%attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so.1
547%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2.so.1
548%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so.1
549%attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so.1
550%attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so.1
551%attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so.1
552%attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so.1
553%attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so.1
554%attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so.1
555%attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so.1
556%attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so.1
557%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so.1
558%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so.1
559%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL2.so.1
560%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so.1
561%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so.1
562%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so.1
563%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PSOpenGL2.so.1
564%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so.1
565%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so.1
566%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so.1
567%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL2.so.1
568%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so.1
569%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL2.so.1
570%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so.1
571%attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so.1
572%attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so.1
573%attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so.1
574%attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so.1
575%attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so.1
576%attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so.1
577%attr(755,root,root) %{_libdir}/vtk/libvtkalglib.so.1
578%attr(755,root,root) %{_libdir}/vtk/libvtkexoIIc.so.1
579%attr(755,root,root) %{_libdir}/vtk/libvtkgl2ps.so.1
580%attr(755,root,root) %{_libdir}/vtk/libvtkglew.so.1
581%attr(755,root,root) %{_libdir}/vtk/libvtklibharu.so.1
582%attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so.1
583%attr(755,root,root) %{_libdir}/vtk/libvtkproj4.so.1
584%attr(755,root,root) %{_libdir}/vtk/libvtksqlite.so.1
585%attr(755,root,root) %{_libdir}/vtk/libvtksys.so.1
586%attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so.1
587%attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so.1
588%if %{with java}
589%exclude %{_libdir}/vtk/libvtk*Java.so.1
590%endif
591%exclude %{_libdir}/vtk/libvtk*Python2?D.so.1
592%exclude %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
593%exclude %{_libdir}/vtk/libvtk*TCL.so.1
594
595%files devel
596%defattr(644,root,root,755)
597%doc Utilities/Upgrading/*
598%attr(755,root,root) %{_bindir}/vtkEncodeString
599%attr(755,root,root) %{_bindir}/vtkHashSource
600%attr(755,root,root) %{_bindir}/vtkWrapHierarchy
601%attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so
602%attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so
603%attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so
604%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2.so
605%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so
606%attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so
607%attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so
608%attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so
609%attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so
610%attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so
611%attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so
612%attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so
613%attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so
614%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so
615%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so
616%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL2.so
617%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so
618%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so
619%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so
620%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PSOpenGL2.so
621%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so
622%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so
623%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so
624%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL2.so
625%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so
626%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL2.so
627%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so
628%attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so
629%attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so
630%attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so
631%attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so
632%attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so
633%attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so
634%attr(755,root,root) %{_libdir}/vtk/libvtkalglib.so
635%attr(755,root,root) %{_libdir}/vtk/libvtkexoIIc.so
636%attr(755,root,root) %{_libdir}/vtk/libvtkgl2ps.so
637%attr(755,root,root) %{_libdir}/vtk/libvtkglew.so
638%attr(755,root,root) %{_libdir}/vtk/libvtklibharu.so
639%attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so
640%attr(755,root,root) %{_libdir}/vtk/libvtkproj4.so
641%attr(755,root,root) %{_libdir}/vtk/libvtksqlite.so
642%attr(755,root,root) %{_libdir}/vtk/libvtksys.so
643%attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so
644%attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so
645%if %{with java}
646%exclude %{_libdir}/vtk/libvtk*Java.so
647%endif
648%exclude %{_libdir}/vtk/libvtk*Python2?D.so
649%exclude %{_libdir}/vtk/libvtkWrappingPython2?Core.so
650%exclude %{_libdir}/vtk/libvtk*TCL.so
651%{_libdir}/vtk/libvtkWrappingTools.a
652%dir %{_includedir}/vtk
653%{_includedir}/vtk/VPIC
654%{_includedir}/vtk/DICOM*.h
655%{_includedir}/vtk/DatabaseSchemaWith2Tables.h
656%{_includedir}/vtk/alglib
657%{_includedir}/vtk/vtkgl2ps
658%{_includedir}/vtk/vtkglew
659%{_includedir}/vtk/vtkkwiml
660%{_includedir}/vtk/vtklibharu
661%{_includedir}/vtk/vtkmetaio
662%{_includedir}/vtk/vtksqlite
663%{_includedir}/vtk/vtksys
664%{_includedir}/vtk/vtkverdict
665%{_includedir}/vtk/vtkxdmf2
666%{_includedir}/vtk/vtk*.h
667%{_includedir}/vtk/vtk*.txx
668%exclude %{_includedir}/vtk/vtkEventQtSlotConnect.h
669%exclude %{_includedir}/vtk/vtkGUISupportQt*.h
670%if %{with java}
671%exclude %{_includedir}/vtk/vtkJavaUtil.h
672%exclude %{_includedir}/vtk/vtkWrappingJavaModule.h
673%endif
674%exclude %{_includedir}/vtk/vtkPython*.h
675%exclude %{_includedir}/vtk/vtkQImageToImageSource.h
676%exclude %{_includedir}/vtk/vtkQt*.h
677%exclude %{_includedir}/vtk/vtkRenderingQtModule.h
678%exclude %{_includedir}/vtk/vtkTcl*.h
679%exclude %{_includedir}/vtk/vtkTk*.h
680%exclude %{_includedir}/vtk/vtkViewsQtModule.h
681%{_libdir}/cmake/vtk
682
683%files qt
684%defattr(644,root,root,755)
685%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so.1
686%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so.1
687%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so.1
688%attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so.1
689%attr(755,root,root) %{_libdir}/qt5/plugins/designer/libQVTKWidgetPlugin.so
690
691%files qt-devel
692%defattr(644,root,root,755)
693%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so
694%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so
695%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so
696%attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so
697%{_includedir}/vtk/QFilterTreeProxyModel.h
698%{_includedir}/vtk/QVTK*.h
699%{_includedir}/vtk/vtkEventQtSlotConnect.h
700%{_includedir}/vtk/vtkGUISupportQt*.h
701%{_includedir}/vtk/vtkQImageToImageSource.h
702%{_includedir}/vtk/vtkQt*.h
703%{_includedir}/vtk/vtkRenderingQtModule.h
704%{_includedir}/vtk/vtkViewsQtModule.h
705
706%if %{with java}
707%files java
708%defattr(644,root,root,755)
709%attr(755,root,root) %{_bindir}/VTKJavaExecutable
710%attr(755,root,root) %{_bindir}/vtkParseJava
711%attr(755,root,root) %{_bindir}/vtkWrapJava
712# common library
713%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so.1
714# java modules
715%attr(755,root,root) %{_libdir}/vtk/libvtkChartsCoreJava.so
716%attr(755,root,root) %{_libdir}/vtk/libvtkCommon*Java.so
717%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryJava.so
718%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2Java.so
719%attr(755,root,root) %{_libdir}/vtk/libvtkFilters*Java.so
720%attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCoreJava.so
721%attr(755,root,root) %{_libdir}/vtk/libvtkIO*Java.so
722%attr(755,root,root) %{_libdir}/vtk/libvtkImaging*Java.so
723%attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*Java.so
724%attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*Java.so
725%attr(755,root,root) %{_libdir}/vtk/libvtkLocalExampleJava.so
726%attr(755,root,root) %{_libdir}/vtk/libvtkParallelCoreJava.so
727%attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreterJava.so
728%attr(755,root,root) %{_libdir}/vtk/libvtkRendering*Java.so
729%attr(755,root,root) %{_libdir}/vtk/libvtkTestingRenderingJava.so
730%attr(755,root,root) %{_libdir}/vtk/libvtkViews*Java.so
731%{_libdir}/vtk/vtk.jar
732
733%files java-devel
734%defattr(644,root,root,755)
735%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so
736%{_includedir}/vtk/vtkJavaUtil.h
737%{_includedir}/vtk/vtkWrappingJavaModule.h
738%endif
739
740%files python
741%defattr(644,root,root,755)
742%doc Wrapping/Python/README*
743%attr(755,root,root) %{_bindir}/vtkWrapPython
744%attr(755,root,root) %{_bindir}/vtkWrapPythonInit
745%attr(755,root,root) %{_bindir}/vtkpython
746%attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so.1
747%attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so.1
748# RenderingMatplotlib requires PythonInterpreter
749%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so.1
750%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingPythonTkWidgets-8.1.so
751%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
752%dir %{py_sitedir}/vtk
753%{py_sitedir}/vtk/*.py[co]
754%dir %{py_sitedir}/vtk/gtk
755%{py_sitedir}/vtk/gtk/*.py[co]
756%dir %{py_sitedir}/vtk/numpy_interface
757%{py_sitedir}/vtk/numpy_interface/*.py[co]
758%dir %{py_sitedir}/vtk/qt
759%{py_sitedir}/vtk/qt/*.py[co]
760%dir %{py_sitedir}/vtk/qt4
761%{py_sitedir}/vtk/qt4/*.py[co]
762%dir %{py_sitedir}/vtk/test
763%{py_sitedir}/vtk/test/*.py[co]
764%dir %{py_sitedir}/vtk/tk
765%{py_sitedir}/vtk/tk/*.py[co]
766%dir %{py_sitedir}/vtk/util
767%{py_sitedir}/vtk/util/*.py[co]
768%dir %{py_sitedir}/vtk/wx
769%{py_sitedir}/vtk/wx/*.py[co]
770%attr(755,root,root) %{py_sitedir}/vtk/vtk*Python.so
771
772%files python-devel
773%defattr(644,root,root,755)
774%attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so
775%attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so
776%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so
777%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so
778%{_includedir}/vtk/PyVTK*.h
779%{_includedir}/vtk/vtkPython*.h
780
781%files tcl
782%defattr(644,root,root,755)
783%doc Wrapping/Tcl/README*
784%attr(755,root,root) %{_bindir}/vtkWrapTcl
785%attr(755,root,root) %{_bindir}/vtkWrapTclInit
786%attr(755,root,root) %{_bindir}/vtk
787%{_datadir}/tcl%{tcl_version}/vtk
788%attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so.1
789
790%files tcl-devel
791%defattr(644,root,root,755)
792%attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so
793%{_includedir}/vtk/vtkTcl*.h
794%{_includedir}/vtk/vtkTk*.h
795
796%files test-suite
797%defattr(644,root,root,755)
798%attr(755,root,root) %{_bindir}/*Tests
799%attr(755,root,root) %{_bindir}/Test*
800
801%files examples
802%defattr(644,root,root,755)
803%attr(755,root,root) %{_bindir}/AmbientSpheres
804%attr(755,root,root) %{_bindir}/Arrays
805%attr(755,root,root) %{_bindir}/Cone
806%attr(755,root,root) %{_bindir}/Cone2
807%attr(755,root,root) %{_bindir}/Cone3
808%attr(755,root,root) %{_bindir}/Cone4
809%attr(755,root,root) %{_bindir}/Cone5
810%attr(755,root,root) %{_bindir}/Cone6
811%attr(755,root,root) %{_bindir}/Cube
812%attr(755,root,root) %{_bindir}/Cylinder
813%attr(755,root,root) %{_bindir}/DiffuseSpheres
814%attr(755,root,root) %{_bindir}/HierarchicalBoxPipeline
815%attr(755,root,root) %{_bindir}/Medical1
816%attr(755,root,root) %{_bindir}/Medical2
817%attr(755,root,root) %{_bindir}/Medical3
818%attr(755,root,root) %{_bindir}/Medical4
819%attr(755,root,root) %{_bindir}/MultiBlock
820%attr(755,root,root) %{_bindir}/RGrid
821%attr(755,root,root) %{_bindir}/SGrid
822%attr(755,root,root) %{_bindir}/SimpleView
823%attr(755,root,root) %{_bindir}/SpecularSpheres
824%attr(755,root,root) %{_bindir}/finance
825%attr(755,root,root) %{_bindir}/BalloonWidget
826%attr(755,root,root) %{_bindir}/BandedContours
827%attr(755,root,root) %{_bindir}/Delaunay3D
828%attr(755,root,root) %{_bindir}/Delaunay3DAlpha
829%attr(755,root,root) %{_bindir}/DumpXMLFile
830%attr(755,root,root) %{_bindir}/FilledContours
831%attr(755,root,root) %{_bindir}/FixedPointVolumeRayCastMapperCT
832%attr(755,root,root) %{_bindir}/GPURenderDemo
833%attr(755,root,root) %{_bindir}/Generate2DAMRDataSetWithPulse
834%attr(755,root,root) %{_bindir}/Generate3DAMRDataSetWithPulse
835%attr(755,root,root) %{_bindir}/GenerateCubesFromLabels
836%attr(755,root,root) %{_bindir}/GenerateModelsFromLabels
837%attr(755,root,root) %{_bindir}/ImageSlicing
838%attr(755,root,root) %{_bindir}/LabeledMesh
839%attr(755,root,root) %{_bindir}/ParticleReader
840%attr(755,root,root) %{_bindir}/Slider
841%attr(755,root,root) %{_bindir}/Slider2D
842%attr(755,root,root) %{_bindir}/TubesWithVaryingRadiusAndColors
843%{_examplesdir}/%{name}-%{version}
844
845%files data
846%defattr(644,root,root,755)
847%dir %{_datadir}/vtk-8.1
848%{_datadir}/vtk-8.1/Data
This page took 0.070697 seconds and 4 git commands to generate.