]> git.pld-linux.org Git - packages/vpb-driver.git/commitdiff
- rel 3 auto/th/vpb-driver-4.2.58-3
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 1 Aug 2017 08:55:43 +0000 (10:55 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 1 Aug 2017 08:55:43 +0000 (10:55 +0200)
- fix building with kernel 4.12
- only build userspace from main Makefile

linux-4.12.patch [new file with mode: 0644]
userspace-only.patch [new file with mode: 0644]
vpb-driver.spec

diff --git a/linux-4.12.patch b/linux-4.12.patch
new file mode 100644 (file)
index 0000000..724a547
--- /dev/null
@@ -0,0 +1,12 @@
+--- vpb-driver-4.2.58/src/vpb/vpb.c~   2014-09-28 20:02:28.000000000 +0200
++++ vpb-driver-4.2.58/src/vpb/vpb.c    2017-08-01 10:53:58.063093297 +0200
+@@ -121,6 +121,9 @@
+ #include <linux/pci.h>
+ #include <linux/delay.h>
+ #include <asm/uaccess.h>
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(4,12,0))
++#include <linux/uaccess.h>
++#endif
+ #if LINUX_VERSION_CODE > KERNEL_VERSION(2,4,9)
diff --git a/userspace-only.patch b/userspace-only.patch
new file mode 100644 (file)
index 0000000..189b16c
--- /dev/null
@@ -0,0 +1,12 @@
+--- vpb-driver-4.2.58/src/Makefile.in~ 2014-09-28 20:02:28.000000000 +0200
++++ vpb-driver-4.2.58/src/Makefile.in  2017-08-01 10:46:21.869784413 +0200
+@@ -7,9 +7,6 @@
+ include $(top_builddir)/Makefile.common
+ subdirs = libtoneg libvpb utils
+-ifeq ($(HOST_OS),linux)
+-subdirs += $(srcdir)/vtcore $(srcdir)/vpb
+-endif
+ all: JBS = $(NJOBS)
+ all install: $(top_srcdir)/Version
index 5eb225aad128c5cf65545a0c0b63aa421ba9e35f..8dae74d6d7052d2096379e1c8a2305a2861242f9 100644 (file)
@@ -21,7 +21,7 @@ exit 1
 
 %define                _duplicate_files_terminate_build        0
 
-%define        rel     2
+%define                rel     3
 %define                pname   vpb-driver
 Summary:       Voicetronix voice processing board (VPB) driver software
 Summary(pl.UTF-8):     Oprogramowanie sterowników dla kart przetwarzających głos (VPB) Voicetronix
@@ -33,6 +33,8 @@ Group:                Libraries
 Source0:       http://www.voicetronix.com.au/Downloads/vpb-driver-4.x/%{pname}-%{version}.tar.gz
 # Source0-md5: f8c85b52e8d01b04d86632e98ac59d19
 Patch0:                %{pname}-make.patch
+Patch1:                userspace-only.patch
+Patch2:                linux-4.12.patch
 URL:           http://www.voicetronix.com.au/downloads.htm#linux
 BuildRequires: rpmbuild(macros) >= 1.701
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
@@ -139,6 +141,8 @@ p=`pwd`\
 %prep
 %setup -q -n %{pname}-%{version}
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %if %{without kernel}
 %{__sed} -i -e 's,subdirs += $(srcdir)/vtcore $(srcdir)/vpb,,' src/Makefile.in
This page took 0.122551 seconds and 4 git commands to generate.