]> git.pld-linux.org Git - packages/vlc.git/commitdiff
upstream patch to fix time tooltip getting focus auto/th/vlc-3.0.2-1
authorJan Palus <atler@pld-linux.org>
Sun, 6 May 2018 19:46:39 +0000 (21:46 +0200)
committerJan Palus <atler@pld-linux.org>
Sun, 6 May 2018 19:47:29 +0000 (21:47 +0200)
vlc-tooltip.patch [new file with mode: 0644]
vlc.spec

diff --git a/vlc-tooltip.patch b/vlc-tooltip.patch
new file mode 100644 (file)
index 0000000..a44412a
--- /dev/null
@@ -0,0 +1,35 @@
+From 58155349a053d38d882d47357b225b8703c696ac Mon Sep 17 00:00:00 2001
+From: Romain Vimont <rom1v@videolabs.io>
+Date: Sat, 21 Apr 2018 20:58:00 +0200
+Subject: [PATCH] qt: make the time tooltip a tooltip
+MIME-Version: 1.0
+Content-Type: text/plain; charset=utf8
+Content-Transfer-Encoding: 8bit
+
+This avoids to lose window focus when the mouse is over the seekbar (on
+XFCE), and should also prevent the tooltip to appear resizeable on
+Unity.
+
+Probably fixes #20316
+
+Signed-off-by: Hugo Beauzée-Luyssen <hugo@beauzee.fr>
+---
+ modules/gui/qt/util/timetooltip.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/modules/gui/qt/util/timetooltip.cpp b/modules/gui/qt/util/timetooltip.cpp
+index 23d47b2528..2e7e97d987 100644
+--- a/modules/gui/qt/util/timetooltip.cpp
++++ b/modules/gui/qt/util/timetooltip.cpp
+@@ -33,7 +33,7 @@
+ TimeTooltip::TimeTooltip( QWidget *parent ) :
+     QWidget( parent )
+ {
+-    setWindowFlags( Qt::Tool                    |
++    setWindowFlags( Qt::ToolTip                 |
+                     Qt::WindowStaysOnTopHint    |
+                     Qt::FramelessWindowHint     );
+-- 
+2.11.0
+
index 551cae437624f8f82fe41e9eab03f29e7a30366d..add1bca3079d2df1dc8c557674a130e3d1ef9610 100644 (file)
--- a/vlc.spec
+++ b/vlc.spec
@@ -74,6 +74,7 @@ Patch1:               %{name}-tremor.patch
 Patch2:                %{name}-mpc.patch
 Patch3:                xmas-sucks.patch
 Patch4:                no-cache.patch
+Patch5:                %{name}-tooltip.patch
 URL:           http://www.videolan.org/vlc/
 # 1.0 for X11 or GLESv1, 1.1 for GLESv2
 BuildRequires: EGL-devel >= %{?with_glesv2:1.1}%{!?with_glesv2:1.0}
@@ -346,6 +347,7 @@ Akcje klienta VLC dla Solid.
 %patch3 -p1
 %endif
 %patch4 -p1
+%patch5 -p1
 
 %build
 %{__libtoolize}
This page took 0.033496 seconds and 4 git commands to generate.