]> git.pld-linux.org Git - packages/vlc.git/commitdiff
up to 3.0.4
authorJan Palus <atler@pld-linux.org>
Sat, 1 Sep 2018 16:26:27 +0000 (18:26 +0200)
committerJan Palus <atler@pld-linux.org>
Sat, 1 Sep 2018 16:28:16 +0000 (18:28 +0200)
- enable wayland explicitly
- dropped patches applied upstream

vlc-build.patch [deleted file]
vlc-fribidi-1.0.patch [deleted file]
vlc.spec

diff --git a/vlc-build.patch b/vlc-build.patch
deleted file mode 100644 (file)
index a246200..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-commit 622360c2c4335fff793f81f5e673326a581f5c0c
-Author: Martin Storsjö <martin@martin.st>
-Date:   Thu Apr 19 18:25:07 2018 +0300
-
-    aom: Remove unsupported pixel formats
-    
-    Support for these was apparently never in the codebase, and the enum
-    values were recently removed from the public headers [1].
-    
-    This fixes build with latest libaom build.
-    
-    [1] https://aomedia.googlesource.com/aom/+/3f29cc20e3a4c348cb41a797c68de856ddb84e12
-
-diff --git a/modules/codec/aom.c b/modules/codec/aom.c
-index 5bb442b5d5..60034158c4 100644
---- a/modules/codec/aom.c
-+++ b/modules/codec/aom.c
-@@ -116,17 +116,6 @@ static const struct
-     { VLC_CODEC_YV12, AOM_IMG_FMT_YV12, 8, 0 },
-     { VLC_CODEC_YUVA, AOM_IMG_FMT_444A, 8, 0 },
--    { VLC_CODEC_YUYV, AOM_IMG_FMT_YUY2, 8, 0 },
--    { VLC_CODEC_UYVY, AOM_IMG_FMT_UYVY, 8, 0 },
--    { VLC_CODEC_YVYU, AOM_IMG_FMT_YVYU, 8, 0 },
--
--    { VLC_CODEC_RGB15, AOM_IMG_FMT_RGB555, 8, 0 },
--    { VLC_CODEC_RGB16, AOM_IMG_FMT_RGB565, 8, 0 },
--    { VLC_CODEC_RGB24, AOM_IMG_FMT_RGB24, 8, 0 },
--    { VLC_CODEC_RGB32, AOM_IMG_FMT_RGB32, 8, 0 },
--
--    { VLC_CODEC_ARGB, AOM_IMG_FMT_ARGB, 8, 0 },
--    { VLC_CODEC_BGRA, AOM_IMG_FMT_ARGB_LE, 8, 0 },
-     { VLC_CODEC_GBR_PLANAR, AOM_IMG_FMT_I444, 8, 1 },
-     { VLC_CODEC_GBR_PLANAR_10L, AOM_IMG_FMT_I44416, 10, 1 },
diff --git a/vlc-fribidi-1.0.patch b/vlc-fribidi-1.0.patch
deleted file mode 100644 (file)
index 0a461e1..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
-From 26e2d3906658c30f2f88f4b1bc9630ec43bf5525 Mon Sep 17 00:00:00 2001
-From: Shaleen Jain <shaleen@jain.sh>
-Date: Sun, 25 Feb 2018 18:42:27 +0530
-Subject: [PATCH] fribidi: update for version 1.0
-
-Update functions deprecated in version 1.0 when building with release 1.0 and
-above.
-
-Signed-off-by: Thomas Guillem <thomas@gllm.fr>
----
- modules/text_renderer/freetype/text_layout.c | 24 ++++++++++++++++++++++++
- 1 file changed, 24 insertions(+)
-
-diff --git a/modules/text_renderer/freetype/text_layout.c b/modules/text_renderer/freetype/text_layout.c
-index 13efd567b46..1a28786d097 100644
---- a/modules/text_renderer/freetype/text_layout.c
-+++ b/modules/text_renderer/freetype/text_layout.c
-@@ -153,6 +153,9 @@ typedef struct paragraph_t
- #ifdef HAVE_FRIBIDI
-     FriBidiCharType     *p_types;
-+#if FRIBIDI_MAJOR_VERSION >= 1
-+    FriBidiBracketType  *p_btypes;
-+#endif
-     FriBidiLevel        *p_levels;
-     FriBidiStrIndex     *pi_reordered_indices;
-     FriBidiParType       paragraph_type;
-@@ -361,6 +364,9 @@ static paragraph_t *NewParagraph( filter_t *p_filter,
- #ifdef HAVE_FRIBIDI
-     p_paragraph->p_levels = vlc_alloc( i_size, sizeof( *p_paragraph->p_levels ) );
-     p_paragraph->p_types = vlc_alloc( i_size, sizeof( *p_paragraph->p_types ) );
-+#if FRIBIDI_MAJOR_VERSION >= 1
-+    p_paragraph->p_btypes = vlc_alloc( i_size, sizeof( *p_paragraph->p_btypes ) );
-+#endif
-     p_paragraph->pi_reordered_indices =
-             vlc_alloc( i_size, sizeof( *p_paragraph->pi_reordered_indices ) );
-@@ -398,6 +404,9 @@ static paragraph_t *NewParagraph( filter_t *p_filter,
- #ifdef HAVE_FRIBIDI
-     if( p_paragraph->p_levels ) free( p_paragraph->p_levels );
-     if( p_paragraph->p_types ) free( p_paragraph->p_types );
-+#if FRIBIDI_MAJOR_VERSION >= 1
-+    if( p_paragraph->p_btypes ) free( p_paragraph->p_btypes );
-+#endif
-     if( p_paragraph->pi_reordered_indices )
-         free( p_paragraph->pi_reordered_indices );
- #endif
-@@ -424,6 +433,9 @@ static void FreeParagraph( paragraph_t *p_paragraph )
- #ifdef HAVE_FRIBIDI
-     free( p_paragraph->pi_reordered_indices );
-     free( p_paragraph->p_types );
-+#if FRIBIDI_MAJOR_VERSION >= 1
-+    free( p_paragraph->p_btypes );
-+#endif
-     free( p_paragraph->p_levels );
- #endif
-@@ -436,10 +448,22 @@ static int AnalyzeParagraph( paragraph_t *p_paragraph )
-     fribidi_get_bidi_types(  p_paragraph->p_code_points,
-                              p_paragraph->i_size,
-                              p_paragraph->p_types );
-+#if FRIBIDI_MAJOR_VERSION >= 1
-+    fribidi_get_bracket_types( p_paragraph->p_code_points,
-+                               p_paragraph->i_size,
-+                               p_paragraph->p_types,
-+                               p_paragraph->p_btypes );
-+    fribidi_get_par_embedding_levels_ex( p_paragraph->p_types,
-+                                      p_paragraph->p_btypes,
-+                                      p_paragraph->i_size,
-+                                      &p_paragraph->paragraph_type,
-+                                      p_paragraph->p_levels );
-+#else
-     fribidi_get_par_embedding_levels( p_paragraph->p_types,
-                                       p_paragraph->i_size,
-                                       &p_paragraph->paragraph_type,
-                                       p_paragraph->p_levels );
-+#endif
- #ifdef HAVE_HARFBUZZ
-     hb_unicode_funcs_t *p_funcs = hb_unicode_funcs_get_default();
index be5d79d9a062fcabfc07874f02ab12671ae38b26..3d1304f97fd6401b7b761616e38b5cf7d62a2ef8 100644 (file)
--- a/vlc.spec
+++ b/vlc.spec
 Summary:       VLC - a multimedia player and stream server
 Summary(pl.UTF-8):     VLC - odtwarzacz multimedialny oraz serwer strumieni
 Name:          vlc
-Version:       3.0.3
-Release:       3
+Version:       3.0.4
+Release:       1
 License:       GPL v2+
 Group:         X11/Applications/Multimedia
 Source0:       http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: cf01d4755c719fe1c8605ceb40d8f1d2
+# Source0-md5: f5e49a0fb9594ab8debf934a710e92f1
 Patch0:                %{name}-buildflags.patch
 Patch1:                %{name}-tremor.patch
 Patch2:                %{name}-mpc.patch
 Patch3:                xmas-sucks.patch
 Patch4:                no-cache.patch
-Patch5:                %{name}-fribidi-1.0.patch
-Patch6:                %{name}-build.patch
 URL:           http://www.videolan.org/vlc/
 # 1.0 for X11 or GLESv1, 1.1 for GLESv2
 BuildRequires: EGL-devel >= %{?with_glesv2:1.1}%{!?with_glesv2:1.0}
@@ -210,6 +208,9 @@ BuildRequires:      tremor-devel
 %{?with_twolame:BuildRequires: twolame-devel}
 %{?with_udev:BuildRequires:    udev-devel >= 1:142}
 %{?with_vsxu:BuildRequires:    vsxu-devel}
+BuildRequires: wayland-devel >= 1.5.91
+BuildRequires: wayland-egl-devel
+BuildRequires: wayland-protocols >= 1.4
 BuildRequires: xcb-util-keysyms-devel >= 0.3.4
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXext-devel
@@ -221,6 +222,7 @@ BuildRequires:      zlib-devel
 BuildRequires: zvbi-devel >= 0.2.28
 Requires(post):        /sbin/ldconfig
 Requires:      lua52-libs > 5.2.3-2
+Requires:      wayland >= 1.5.91
 Requires:      xdg-utils
 Obsoletes:     browser-plugin-vlc
 Obsoletes:     vlc-GGI
@@ -349,8 +351,6 @@ Akcje klienta VLC dla Solid.
 %patch3 -p1
 %endif
 %patch4 -p1
-%patch5 -p1
-%patch6 -p1
 
 %build
 %{__libtoolize}
@@ -428,6 +428,7 @@ Akcje klienta VLC dla Solid.
        %{?with_upnp:--enable-upnp} \
        --enable-v4l2 \
        %{!?with_vsxu:--disable-vsxu} \
+       --enable-wayland \
        %{!?with_x264:--disable-x264} \
        %{!?with_x265:--disable-x265} \
        --with-default-font=/usr/share/vlc/skins2/fonts/FreeSans.ttf \
This page took 0.11778 seconds and 4 git commands to generate.