]> git.pld-linux.org Git - packages/vlc.git/commitdiff
up to 3.0.18
authorJan Palus <atler@pld-linux.org>
Thu, 1 Dec 2022 00:09:11 +0000 (01:09 +0100)
committerJan Palus <atler@pld-linux.org>
Thu, 1 Dec 2022 00:09:11 +0000 (01:09 +0100)
vlc-dav1d.patch [deleted file]
vlc-extern.patch [deleted file]
vlc-libcaca.patch [deleted file]
vlc-live.patch [deleted file]
vlc.spec

diff --git a/vlc-dav1d.patch b/vlc-dav1d.patch
deleted file mode 100644 (file)
index 16808c9..0000000
+++ /dev/null
@@ -1,132 +0,0 @@
-https://code.videolan.org/videolan/vlc/-/merge_requests/1618
-
-From 0efdfe8799b0100f41c5b8d6e1b43451001386cb Mon Sep 17 00:00:00 2001
-From: Steve Lhomme <robux4@ycbcr.xyz>
-Date: Fri, 18 Mar 2022 11:42:49 +0100
-Subject: [PATCH 1/2] dav1d: fix compilation with (upcoming) dav1d 1.0
-
-(cherry picked from commit dbf45cea2a8abdfbef897b8a71f3eb782bb1b712) (edited)
-edited:
-- 3.0 has the 128 pixels padding elsewhere
-- 3.0 has an extra parameter for add_integer_with_range()
-- 3.0 was setting i_extra_picture_buffers further down in the code
-- 3.0 uses 16 threads max
-
-Signed-off-by: Steve Lhomme <robux4@ycbcr.xyz>
----
- modules/codec/dav1d.c | 22 +++++++++++++++++++++-
- 1 file changed, 21 insertions(+), 1 deletion(-)
-
-diff --git a/modules/codec/dav1d.c b/modules/codec/dav1d.c
-index 039165f52ec..cfabbc27cb3 100644
---- a/modules/codec/dav1d.c
-+++ b/modules/codec/dav1d.c
-@@ -63,10 +63,16 @@ vlc_module_begin ()
-     set_category(CAT_INPUT)
-     set_subcategory(SUBCAT_INPUT_VCODEC)
-+#if DAV1D_API_VERSION_MAJOR >= 6
-+    add_integer_with_range("dav1d-thread-frames", 0, 0, DAV1D_MAX_THREADS,
-+                THREAD_FRAMES_TEXT, THREAD_FRAMES_LONGTEXT, false)
-+    add_obsolete_string("dav1d-thread-tiles") // unused with dav1d 1.0
-+#else
-     add_integer_with_range("dav1d-thread-frames", 0, 0, DAV1D_MAX_FRAME_THREADS,
-                 THREAD_FRAMES_TEXT, THREAD_FRAMES_LONGTEXT, false)
-     add_integer_with_range("dav1d-thread-tiles", 0, 0, DAV1D_MAX_TILE_THREADS,
-                 THREAD_TILES_TEXT, THREAD_TILES_LONGTEXT, false)
-+#endif
- vlc_module_end ()
- /*****************************************************************************
-@@ -294,6 +300,11 @@ static int OpenDecoder(vlc_object_t *p_this)
-         return VLC_ENOMEM;
-     dav1d_default_settings(&p_sys->s);
-+#if DAV1D_API_VERSION_MAJOR >= 6
-+    p_sys->s.n_threads = var_InheritInteger(p_this, "dav1d-thread-frames");
-+    if (p_sys->s.n_threads == 0)
-+        p_sys->s.n_threads = (i_core_count < 16) ? i_core_count : 16;
-+#else
-     p_sys->s.n_tile_threads = var_InheritInteger(p_this, "dav1d-thread-tiles");
-     if (p_sys->s.n_tile_threads == 0)
-         p_sys->s.n_tile_threads =
-@@ -303,6 +314,7 @@ static int OpenDecoder(vlc_object_t *p_this)
-     p_sys->s.n_frame_threads = var_InheritInteger(p_this, "dav1d-thread-frames");
-     if (p_sys->s.n_frame_threads == 0)
-         p_sys->s.n_frame_threads = (i_core_count < 16) ? i_core_count : 16;
-+#endif
-     p_sys->s.allocator.cookie = dec;
-     p_sys->s.allocator.alloc_picture_callback = NewPicture;
-     p_sys->s.allocator.release_picture_callback = FreePicture;
-@@ -313,12 +325,20 @@ static int OpenDecoder(vlc_object_t *p_this)
-         return VLC_EGENERIC;
-     }
-+#if DAV1D_API_VERSION_MAJOR >= 6
-+    msg_Dbg(p_this, "Using dav1d version %s with %d threads",
-+            dav1d_version(), p_sys->s.n_threads);
-+
-+    dec->i_extra_picture_buffers = (p_sys->s.n_threads - 1);
-+#else
-     msg_Dbg(p_this, "Using dav1d version %s with %d/%d frame/tile threads",
-             dav1d_version(), p_sys->s.n_frame_threads, p_sys->s.n_tile_threads);
-+    dec->i_extra_picture_buffers = (p_sys->s.n_frame_threads - 1);
-+#endif
-+
-     dec->pf_decode = Decode;
-     dec->pf_flush = FlushDecoder;
--    dec->i_extra_picture_buffers = (p_sys->s.n_frame_threads - 1);
-     dec->fmt_out.video.i_width = dec->fmt_in.video.i_width;
-     dec->fmt_out.video.i_height = dec->fmt_in.video.i_height;
--- 
-GitLab
-
-
-From b9d8c4079c6b0c4f8d8857a81dd3cfb9bdc67601 Mon Sep 17 00:00:00 2001
-From: Steve Lhomme <robux4@ycbcr.xyz>
-Date: Wed, 12 Aug 2020 06:19:06 +0200
-Subject: [PATCH 2/2] contrib: dav1d: update to 1.0.0
-
-(cherry picked from commit c857056738aec2e66d21b54d2d086c60255e6a91) (edited)
-edited:
-- 3.0 had a different way to comment the git URL line
-
-Signed-off-by: Steve Lhomme <robux4@ycbcr.xyz>
----
- contrib/src/dav1d/SHA512SUMS | 2 +-
- contrib/src/dav1d/rules.mak  | 4 ++--
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/contrib/src/dav1d/SHA512SUMS b/contrib/src/dav1d/SHA512SUMS
-index 5d7d593ae20..641f4f75698 100644
---- a/contrib/src/dav1d/SHA512SUMS
-+++ b/contrib/src/dav1d/SHA512SUMS
-@@ -1 +1 @@
--87026f8b14e408ff50fc8f137ec2ede4b14c5f69687e615d2359d0f718ae5cb5176522490786d9ae1f7838182f82615c2674f7c2961b6dcec83f1ee587c3af7c  dav1d-0.9.2.tar.xz
-+a3a7e162e45181449cd42af3a4d36669a850a4ee9ab17641dcd63d84406444566e8ebc7caa55b0620ab581039f36d19a90218a40f52ebbe525b37ed9493fb3f3  dav1d-1.0.0.tar.xz
-diff --git a/contrib/src/dav1d/rules.mak b/contrib/src/dav1d/rules.mak
-index 9b4a508309a..e4583228316 100644
---- a/contrib/src/dav1d/rules.mak
-+++ b/contrib/src/dav1d/rules.mak
-@@ -1,6 +1,6 @@
- # libdav1d
--DAV1D_VERSION := 0.9.2
-+DAV1D_VERSION := 1.0.0
- DAV1D_URL := $(VIDEOLAN)/dav1d/$(DAV1D_VERSION)/dav1d-$(DAV1D_VERSION).tar.xz
- PKGS += dav1d
-@@ -12,7 +12,7 @@ DAV1D_CONF = -D enable_tests=false -D enable_tools=false
- $(TARBALLS)/dav1d-$(DAV1D_VERSION).tar.xz:
-       $(call download_pkg,$(DAV1D_URL),dav1d)
--      #~ $(call download_git,$(DAV1D_URL),,$(DAV1D_HASH))
-+#     $(call download_git,$(DAV1D_GITURL),,$(DAV1D_HASH))
- .sum-dav1d: dav1d-$(DAV1D_VERSION).tar.xz
--- 
-GitLab
-
diff --git a/vlc-extern.patch b/vlc-extern.patch
deleted file mode 100644 (file)
index 1b3223f..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
---- vlc-3.0.10/modules/codec/omxil/omxil_core.h.orig   2020-04-20 09:19:53.000000000 +0200
-+++ vlc-3.0.10/modules/codec/omxil/omxil_core.h        2020-05-20 17:53:47.373898072 +0200
-@@ -34,9 +34,9 @@
- extern OMX_ERRORTYPE (*pf_get_roles_of_component)(OMX_STRING, OMX_U32 *, OMX_U8 **);
- /* Extra IOMX android functions. Can be NULL if we don't link with libiomx */
--OMX_ERRORTYPE (*pf_enable_graphic_buffers)(OMX_HANDLETYPE, OMX_U32, OMX_BOOL);
--OMX_ERRORTYPE (*pf_get_graphic_buffer_usage)(OMX_HANDLETYPE, OMX_U32, OMX_U32*);
--OMX_ERRORTYPE (*pf_get_hal_format) (const char *, int *);
-+extern OMX_ERRORTYPE (*pf_enable_graphic_buffers)(OMX_HANDLETYPE, OMX_U32, OMX_BOOL);
-+extern OMX_ERRORTYPE (*pf_get_graphic_buffer_usage)(OMX_HANDLETYPE, OMX_U32, OMX_U32*);
-+extern OMX_ERRORTYPE (*pf_get_hal_format) (const char *, int *);
- int InitOmxCore(vlc_object_t *p_this);
- void DeinitOmxCore(void);
diff --git a/vlc-libcaca.patch b/vlc-libcaca.patch
deleted file mode 100644 (file)
index 56cbd57..0000000
+++ /dev/null
@@ -1,97 +0,0 @@
---- vlc-3.0.16/modules/video_output/caca.c.orig        2017-11-24 16:29:18.000000000 +0100
-+++ vlc-3.0.16/modules/video_output/caca.c     2022-01-30 19:43:25.433547548 +0100
-@@ -74,9 +74,9 @@ static void Place(vout_display_t *, vout
- /* */
- struct vout_display_sys_t {
--    cucul_canvas_t *cv;
-+    caca_canvas_t *cv;
-     caca_display_t *dp;
--    cucul_dither_t *dither;
-+    caca_dither_t *dither;
-     picture_pool_t *pool;
-     vout_display_event_thread_t *et;
-@@ -153,9 +153,9 @@ static int Open(vlc_object_t *object)
-     if (!sys)
-         goto error;
--    sys->cv = cucul_create_canvas(0, 0);
-+    sys->cv = caca_create_canvas(0, 0);
-     if (!sys->cv) {
--        msg_Err(vd, "cannot initialize libcucul");
-+        msg_Err(vd, "cannot initialize libcaca");
-         goto error;
-     }
-@@ -209,11 +209,11 @@ error:
-         if (sys->pool)
-             picture_pool_Release(sys->pool);
-         if (sys->dither)
--            cucul_free_dither(sys->dither);
-+            caca_free_dither(sys->dither);
-         if (sys->dp)
-             caca_free_display(sys->dp);
-         if (sys->cv)
--            cucul_free_canvas(sys->cv);
-+            caca_free_canvas(sys->cv);
-         free(sys);
-     }
-@@ -235,9 +235,9 @@ static void Close(vlc_object_t *object)
-     if (sys->pool)
-         picture_pool_Release(sys->pool);
-     if (sys->dither)
--        cucul_free_dither(sys->dither);
-+        caca_free_dither(sys->dither);
-     caca_free_display(sys->dp);
--    cucul_free_canvas(sys->cv);
-+    caca_free_canvas(sys->cv);
- #if defined(_WIN32)
-     FreeConsole();
-@@ -266,7 +266,7 @@ static void Prepare(vout_display_t *vd,
-     if (!sys->dither) {
-         /* Create the libcaca dither object */
--        sys->dither = cucul_create_dither(32,
-+        sys->dither = caca_create_dither(32,
-                                             vd->source.i_visible_width,
-                                             vd->source.i_visible_height,
-                                             picture->p[0].i_pitch,
-@@ -284,12 +284,12 @@ static void Prepare(vout_display_t *vd,
-     vout_display_place_t place;
-     Place(vd, &place);
--    cucul_set_color_ansi(sys->cv, CUCUL_COLOR_DEFAULT, CUCUL_COLOR_BLACK);
--    cucul_clear_canvas(sys->cv);
-+    caca_set_color_ansi(sys->cv, CACA_DEFAULT, CACA_BLACK);
-+    caca_clear_canvas(sys->cv);
-     const int crop_offset = vd->source.i_y_offset * picture->p->i_pitch +
-                             vd->source.i_x_offset * picture->p->i_pixel_pitch;
--    cucul_dither_bitmap(sys->cv, place.x, place.y,
-+    caca_dither_bitmap(sys->cv, place.x, place.y,
-                         place.width, place.height,
-                         sys->dither,
-                         &picture->p->p_pixels[crop_offset]);
-@@ -328,7 +328,7 @@ static int Control(vout_display_t *vd, i
-     case VOUT_DISPLAY_CHANGE_SOURCE_CROP:
-         if (sys->dither)
--            cucul_free_dither(sys->dither);
-+            caca_free_dither(sys->dither);
-         sys->dither = NULL;
-         return VLC_SUCCESS;
-@@ -366,8 +366,8 @@ static void Place(vout_display_t *vd, vo
-     vout_display_PlacePicture(place, &vd->source, vd->cfg, false);
--    const int canvas_width   = cucul_get_canvas_width(sys->cv);
--    const int canvas_height  = cucul_get_canvas_height(sys->cv);
-+    const int canvas_width   = caca_get_canvas_width(sys->cv);
-+    const int canvas_height  = caca_get_canvas_height(sys->cv);
-     const int display_width  = caca_get_display_width(sys->dp);
-     const int display_height = caca_get_display_height(sys->dp);
diff --git a/vlc-live.patch b/vlc-live.patch
deleted file mode 100644 (file)
index fc98d24..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- vlc-3.0.11.1/modules/access/live555.cpp.orig       2019-03-29 20:01:15.000000000 +0100
-+++ vlc-3.0.11.1/modules/access/live555.cpp    2021-01-19 06:23:21.598574547 +0100
-@@ -852,7 +852,9 @@
-             if( !p_sys->b_multicast )
-             {
-                 /* We need different rollover behaviour for multicast */
--                p_sys->b_multicast = IsMulticastAddress( sub->connectionEndpointAddress() );
-+                struct sockaddr_storage sa;
-+                sub->getConnectionEndpointAddress( sa );
-+                p_sys->b_multicast = IsMulticastAddress( sa );
-             }
-             tk = (live_track_t*)malloc( sizeof( live_track_t ) );
index cbdecff4fb6b1b3f53b86c7a7516ee05ee0ebb0c..dfae782b5004c8b32b57c489136518963184b8eb 100644 (file)
--- a/vlc.spec
+++ b/vlc.spec
 Summary:       VLC - a multimedia player and stream server
 Summary(pl.UTF-8):     VLC - odtwarzacz multimedialny oraz serwer strumieni
 Name:          vlc
-Version:       3.0.17.4
-Release:       2
+Version:       3.0.18
+Release:       1
 License:       GPL v2+
 Group:         X11/Applications/Multimedia
 Source0:       https://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: 951878d524e089bf4c80614c93c68c0c
+# Source0-md5: f3c031357c0eeffb41e928eca220a803
 Patch0:                %{name}-buildflags.patch
 Patch1:                %{name}-tremor.patch
 Patch2:                %{name}-mpc.patch
 Patch3:                xmas-sucks.patch
 Patch4:                no-cache.patch
 Patch5:                %{name}-fdk_aac.patch
-Patch6:                %{name}-extern.patch
 Patch7:                %{name}-vsxu.patch
 Patch8:                qt-5.15.patch
-Patch9:                %{name}-live.patch
-Patch10:       %{name}-dav1d.patch
 Patch11:       opencv4.patch
-Patch12:       %{name}-libcaca.patch
 URL:           http://www.videolan.org/vlc/
 %{?with_decklink:BuildRequires:        Blackmagic_DeckLink_SDK}
 # 1.0 for X11 or GLESv1, 1.1 for GLESv2
@@ -154,7 +150,7 @@ BuildRequires:      libdc1394-devel >= 2.1.0
 BuildRequires: libdsm-devel >= 0.2.0
 BuildRequires: libdts-devel >= 0.0.5
 BuildRequires: libdvbpsi-devel >= 1.2.0
-BuildRequires: libdvdnav-devel >= 5.0.4
+BuildRequires: libdvdnav-devel > 4.9.0
 BuildRequires: libdvdread-devel >= 4.9.1
 BuildRequires: libebml-devel >= 1.3.6
 BuildRequires: libgcrypt-devel >= 1.6.0
@@ -432,13 +428,9 @@ Akcje klienta VLC dla Solid.
 %endif
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
 %patch7 -p1
 %patch8 -p1
-%patch9 -p1
-%patch10 -p1
 %patch11 -p1
-%patch12 -p1
 
 %build
 %{__libtoolize}
This page took 0.116814 seconds and 4 git commands to generate.