]> git.pld-linux.org Git - packages/vlc.git/blobdiff - vlc.spec
Release 4 (by relup.sh)
[packages/vlc.git] / vlc.spec
index a21e52b65dac6f32c84cca1d33552e17a8e2d821..c8d16b6a2be99e310077051e8d3e3d54e4c81d8b 100644 (file)
--- a/vlc.spec
+++ b/vlc.spec
@@ -5,7 +5,7 @@
 #   ./modules/gui/skins2/parser/builder.cpp:            string path = (*it) + sep + "fonts" + sep + "FreeSans.ttf";
 # - %{_prefix}/lib cleanup for x86_64
 # - configs to /etc (../http/.hosts)
-# - qvlc should be in qt4 or such package not generic X11
+# - qvlc should be in qt5 or such package not generic X11
 # - /usr/share/vlc/utils scripts insecure (use /tmp hardcoded paths)
 # - [recheck old TODO]: flac plugin doesn't work with mono files
 # - --enable-wma-fixed (fixed-point WMA - does it make sense on non-embedded?)
@@ -15,7 +15,6 @@
 # - x262
 # - x26410b (x264 >= 0.153)
 # - evas (ecore >= 1.16)
-# - fluidlite?
 #
 # Conditional build:
 %bcond_without aalib           # aalib video output plugin
 %bcond_with    decklink        # Blackmagic DeskLink output support (BR: proprietary SDK)
 %bcond_without dv              # dv access plugins
 %bcond_with    fdk_aac         # FDK-AAC encoder plugin (GPL 3 incompatible; enable as subpackage?)
+%bcond_with    fluidlite       # FluidLite instead of FluidSynth library in fluidsynth plugin
 %bcond_with    freerdp         # RDP/Remote Desktop client support
 %bcond_with    glesv1          # OpenGL ES v1 support
 %bcond_with    glesv2          # OpenGL ES v2 support
 %bcond_without gnutls          # gnutls misc plugin
+%bcond_without goom            # GOOM! audio visualization
 %bcond_without jack            # jack access/audio output plugin
-%bcond_without kde             # KDE Solid actions
+%bcond_with    kde             # KDE Solid actions
 %bcond_without lirc            # lirc control plugin
 %bcond_without libplacebo      # libplacebo support in gl plugin
 %bcond_without live            # live555 demuxer plugin
 %bcond_without notify          # libnotify notification plugin
 %bcond_without opencv          # OpenCV video filter [needs vlc API update]
 %bcond_with    oss4            # OSSv4
-%bcond_with    qt5             # Qt5 instead of Qt4
 %bcond_with    projectM        # projectm visualization plugin
 %bcond_without sftp            # SFTP file transfer via libssh2
 %bcond_without shout           # shout access output plugin
 %bcond_without smb             # SMB access plugin
+%bcond_without smb2            # SMB2 access plugin
 %bcond_without speex           # speex codec plugin
 %bcond_without static_libs     # don't build static libraries
 %bcond_without svg             # svg text renderer plugin
 Summary:       VLC - a multimedia player and stream server
 Summary(pl.UTF-8):     VLC - odtwarzacz multimedialny oraz serwer strumieni
 Name:          vlc
-Version:       3.0.8
-Release:       11
+Version:       3.0.16
+Release:       4
 License:       GPL v2+
 Group:         X11/Applications/Multimedia
-Source0:       http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: 744442ec0c145453ea1d257914c8072e
+Source0:       https://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.xz
+# Source0-md5: efc5f7331c033bf81536531c6eba5aa5
 Patch0:                %{name}-buildflags.patch
 Patch1:                %{name}-tremor.patch
 Patch2:                %{name}-mpc.patch
 Patch3:                xmas-sucks.patch
 Patch4:                no-cache.patch
 Patch5:                %{name}-fdk_aac.patch
-Patch6:                %{name}-libplacebo.patch
+Patch6:                %{name}-extern.patch
 Patch7:                %{name}-vsxu.patch
+Patch8:                qt-5.15.patch
+Patch9:                %{name}-live.patch
+Patch10:       %{name}-srt.patch
+Patch11:       opencv4.patch
+Patch12:       %{name}-libcaca.patch
 URL:           http://www.videolan.org/vlc/
+%{?with_decklink:BuildRequires:        Blackmagic_DeckLink_SDK}
 # 1.0 for X11 or GLESv1, 1.1 for GLESv2
 BuildRequires: EGL-devel >= %{?with_glesv2:1.1}%{!?with_glesv2:1.0}
 BuildRequires: OpenGL-devel
@@ -109,14 +116,17 @@ BuildRequires:    automake
 %{?with_daala:BuildRequires:   daala-devel}
 BuildRequires: dav1d-devel
 BuildRequires: dbus-devel >= 1.6.0
-%{?with_decklink:BuildRequires:        Blackmagic_DeckLink_SDK}
 BuildRequires: desktop-file-utils
 BuildRequires: faad2-devel >= 2.5
 %{?with_fdk_aac:BuildRequires: fdk-aac-devel}
 # libavcodec >= 57.37.100, libavformat >= 53.21.0, libavutil >= 52.4.0, libswscale, libpostproc
 BuildRequires: ffmpeg-devel >= 3.1
 BuildRequires: flac-devel >= 1.1.3
+%if %{with fluidlite}
+BuildRequires: fluidlite-devel
+%else
 BuildRequires: fluidsynth-devel >= 1.1.2
+%endif
 BuildRequires: fontconfig-devel >= 1:2.11
 %{?with_freerdp:BuildRequires: freerdp-devel >= 1.0.1}
 BuildRequires: freetype-devel >= 2
@@ -135,7 +145,7 @@ BuildRequires:      libass-devel >= 0.9.8
 %{?with_dv:BuildRequires:      libavc1394-devel >= 0.5.3}
 BuildRequires: libbluray-devel >= 0.6.2
 %{?with_bpg:BuildRequires:     libbpg-devel}
-%{?with_caca:BuildRequires:    libcaca-devel >= 0.99-0.beta14}
+%{?with_caca:BuildRequires:    libcaca-devel >= 0.99-0.beta20}
 BuildRequires: libcddb-devel >= 0.9.5
 BuildRequires: libcdio-devel >= 0.78.2
 BuildRequires: libchromaprint-devel >= 0.6.0
@@ -148,7 +158,7 @@ BuildRequires:      libdvdnav-devel >= 4.9.1
 BuildRequires: libdvdread-devel >= 4.9.1
 BuildRequires: libebml-devel >= 1.3.6
 BuildRequires: libgcrypt-devel >= 1.6.0
-BuildRequires: libgoom2-devel
+%{?with_goom:BuildRequires:    libgoom2-devel}
 BuildRequires: libidn-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libkate-devel >= 0.3.0
@@ -171,6 +181,7 @@ BuildRequires:      libsamplerate-devel
 BuildRequires: libsecret-devel >= 0.18
 %{?with_shout:BuildRequires:   libshout-devel >= 2.1}
 BuildRequires: libsidplay2-devel
+%{?with_smb2:BuildRequires:    libsmb2-devel >= 4.0.0}
 %{?with_smb:BuildRequires:     libsmbclient-devel >= 3.6.13}
 %{?with_sftp:BuildRequires:    libssh2-devel}
 BuildRequires: libstdc++-devel >= 6:4.7
@@ -195,15 +206,15 @@ BuildRequires:    libvpx-devel >= 1.5.0
 BuildRequires: libxcb-devel >= 1.6
 BuildRequires: libxml2-devel >= 1:2.5
 %{?with_lirc:BuildRequires:    lirc-devel}
-%{?with_live:BuildRequires:    live-devel >= 2014.07.04}
+%{?with_live:BuildRequires:    live-devel >= 2020.12.23}
 BuildRequires: lua52 >= 5.2
 BuildRequires: lua52-devel >= 5.2
 %{?with_mfx:BuildRequires:     mfx_dispatch-devel}
-BuildRequires: microdns-devel
+BuildRequires: microdns-devel >= 0.1.2
 BuildRequires: minizip-devel
 BuildRequires: musepack-devel
 BuildRequires: ncurses-devel
-%{?with_opencv:BuildRequires:  opencv-devel > 2.0}
+%{?with_opencv:BuildRequires:  opencv-devel > 4}
 BuildRequires: opus-devel >= 1.0.3
 BuildRequires: pkgconfig >= 1:0.9.0
 BuildRequires: protobuf-devel >= 2.5.0
@@ -215,10 +226,12 @@ BuildRequires:    soxr-devel >= 0.1.2
 BuildRequires: spatialaudio-devel
 %{?with_speex:BuildRequires:   speex-devel > 1:1.1.0}
 %{?with_speex:BuildRequires:   speexdsp-devel >= 1.2}
-BuildRequires: srt-devel >= 1.2.2
+BuildRequires: srt-devel >= 1.4.1
 BuildRequires: sysfsutils-devel
 BuildRequires: systemd-devel >= 1:209
 BuildRequires: taglib-devel >= 1.9
+BuildRequires: tar >= 1:1.22
+BuildRequires: tpm2-tss-devel
 BuildRequires: tremor-devel
 %{?with_twolame:BuildRequires: twolame-devel}
 %{?with_udev:BuildRequires:    udev-devel >= 1:142}
@@ -229,10 +242,10 @@ BuildRequires:    wayland-protocols >= 1.4
 BuildRequires: xcb-util-keysyms-devel >= 0.3.4
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXext-devel
-%{?with_qt5:BuildRequires:     xorg-lib-libXi-devel}
 BuildRequires: xorg-lib-libXinerama-devel
 BuildRequires: xorg-lib-libXpm-devel
 BuildRequires: xorg-proto-xproto-devel
+BuildRequires: xz
 BuildRequires: zlib-devel
 BuildRequires: zvbi-devel >= 0.2.28
 Requires(post):        /sbin/ldconfig
@@ -241,7 +254,9 @@ Requires:   SDL_image >= 1.2.10
 Requires:      aribb24 >= 1.0.1
 Requires:      aribb25 >= 0.2.6
 %{?with_svg:Requires:  cairo >= 1.13.1}
+%if %{without fluidlite}
 Requires:      fluidsynth >= 1.1.2
+%endif
 Requires:      fontconfig-libs >= 1:2.11
 %{?with_gnutls:Requires:       gnutls >= 3.3.6}
 Requires:      libarchive >= 3.1.0
@@ -262,6 +277,7 @@ Requires:   libogg >= 1:1.0
 %{?with_libplacebo:Requires:   libplacebo >= 0.2.1}
 %{?with_svg:Requires:  librsvg >= 2.9.0}
 Requires:      libsecret >= 0.18
+%{?with_smb2:Requires: libsmb2 >= 4.0.0}
 Requires:      libtheora >= 1.0
 Requires:      libtiger >= 0.3.1
 Requires:      libvncserver >= 0.9.9
@@ -270,13 +286,14 @@ Requires: libvpx >= 1.5.0
 Requires:      libxcb >= 1.6
 Requires:      libxml2 >= 1:2.5
 Requires:      lua52-libs > 5.2.3-2
+Requires:      microdns >= 0.1.2
 Requires:      opus >= 1.0.3
 Requires:      pulseaudio-libs >= 1.0
 Requires:      schroedinger >= 1.0.10
 Requires:      soxr >= 0.1.2
 %{?with_speex:Requires:        speex > 1:1.1.0}
 %{?with_speex:Requires:        speexdsp >= 1.2}
-Requires:      srt >= 1.2.2
+Requires:      srt >= 1.4.1
 Requires:      taglib >= 1.9
 Requires:      wayland >= 1.5.91
 Requires:      xcb-util-keysyms >= 0.3.4
@@ -342,7 +359,7 @@ Requires:   Qt5X11Extras >= %{qt_ver}
 Requires:      desktop-file-utils
 Requires:      hicolor-icon-theme
 Suggests:      dbus-x11 >= 1.6.0
-Suggests:      libcaca > 0.99-0.beta14.1
+%{?with_caca:Suggests: libcaca > 0.99-0.beta20}
 Obsoletes:     vlc-gnome
 Obsoletes:     vlc-gtk
 
@@ -414,6 +431,11 @@ Akcje klienta VLC dla Solid.
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
+%patch9 -p1
+%patch10 -p1
+%patch11 -p1
+%patch12 -p1
 
 %build
 %{__libtoolize}
@@ -456,12 +478,18 @@ Akcje klienta VLC dla Solid.
        %{?with_fdk_aac:--enable-fdkaac} \
        --enable-faad \
        --enable-flac \
+%if %{with fluidlite}
+       --disable-fluidsynth \
+%else
+       --disable-fluidlite \
+%endif
        %{?with_freerdp:--enable-freerdp}%{!?with_freerdp:--disable-freerdp} \
        --enable-freetype \
        --enable-fribidi \
        %{?with_glesv1:--enable-gles1} \
        %{?with_glesv2:--enable-gles2} \
        %{!?with_gnutls:--disable-gnutls} \
+       --enable-goom%{!?with_goom:=no} \
        %{?with_jack:--enable-jack} \
        %{!?with_libplacebo:--disable-libplacebo} \
        --enable-lirc%{!?with_lirc:=no} \
@@ -482,6 +510,7 @@ Akcje klienta VLC dla Solid.
        --enable-shine \
        --enable-shout%{!?with_shout:=no} \
        --enable-skins2 \
+       %{?with_smb2:--enable-smb2} \
        %{!?with_smb:--disable-smbclient} \
        --enable-sout \
        %{!?with_speex:--disable-speex} \
@@ -616,6 +645,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/vlc/plugins/access/libimem_plugin.so
 # R: libnfs >= 1.10.0
 %attr(755,root,root) %{_libdir}/vlc/plugins/access/libnfs_plugin.so
+%attr(755,root,root) %{_libdir}/vlc/plugins/access/librist_plugin.so
 %attr(755,root,root) %{_libdir}/vlc/plugins/access/libsatip_plugin.so
 %if %{with sftp}
 # R: libssh2
@@ -626,6 +656,10 @@ rm -rf $RPM_BUILD_ROOT
 # R: libsmbclient
 %attr(755,root,root) %{_libdir}/vlc/plugins/access/libsmb_plugin.so
 %endif
+%if %{with smb2}
+# R: libsmb2 >= 3.0.0
+%attr(755,root,root) %{_libdir}/vlc/plugins/access/libsmb2_plugin.so
+%endif
 %attr(755,root,root) %{_libdir}/vlc/plugins/access/libtcp_plugin.so
 %attr(755,root,root) %{_libdir}/vlc/plugins/access/libudp_plugin.so
 %attr(755,root,root) %{_libdir}/vlc/plugins/access/libvdr_plugin.so
@@ -675,6 +709,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/vlc/plugins/access_output/libaccess_output_http_plugin.so
 # R: libgcrypt >= 1.1.94
 %attr(755,root,root) %{_libdir}/vlc/plugins/access_output/libaccess_output_livehttp_plugin.so
+%attr(755,root,root) %{_libdir}/vlc/plugins/access_output/libaccess_output_rist_plugin.so
 %if %{with shout}
 # R: shout >= 2.1
 %attr(755,root,root) %{_libdir}/vlc/plugins/access_output/libaccess_output_shout_plugin.so
@@ -765,7 +800,7 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 # R: flac
 %attr(755,root,root) %{_libdir}/vlc/plugins/codec/libflac_plugin.so
-# R: fluidsynth >= 1.1.2
+# R: fluidsynth >= 1.1.2 or fluidlite
 %attr(755,root,root) %{_libdir}/vlc/plugins/codec/libfluidsynth_plugin.so
 %attr(755,root,root) %{_libdir}/vlc/plugins/codec/libg711_plugin.so
 # R: gstreamer-plugins-base >= 1.0
@@ -1132,7 +1167,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/vlc/plugins/video_filter/liboldmovie_plugin.so
 %if %{with opencv}
 # R: opencv
-%attr(755,root,root) %{_libdir}/vlc/plugins/video_filter/libopencv_example_plugin.so
+#%attr(755,root,root) %{_libdir}/vlc/plugins/video_filter/libopencv_example_plugin.so
 %attr(755,root,root) %{_libdir}/vlc/plugins/video_filter/libopencv_wrapper_plugin.so
 %endif
 %attr(755,root,root) %{_libdir}/vlc/plugins/video_filter/libposterize_plugin.so
@@ -1183,7 +1218,7 @@ rm -rf $RPM_BUILD_ROOT
 # R: OpenGL
 %attr(755,root,root) %{_libdir}/vlc/plugins/visualization/libglspectrum_plugin.so
 # R: libgoom2
-%attr(755,root,root) %{_libdir}/vlc/plugins/visualization/libgoom_plugin.so
+%{?with_goom:%attr(755,root,root) %{_libdir}/vlc/plugins/visualization/libgoom_plugin.so}
 %if %{with projectM}
 # R: libprojectM >= 2.0.0
 %attr(755,root,root) %{_libdir}/vlc/plugins/visualization/libprojectm_plugin.so
@@ -1225,7 +1260,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/vlc/plugins/video_output/libaa_plugin.so
 %endif
 %if %{with caca}
-# R: libcaca >= 0.99-0.beta14
+# R: libcaca >= 0.99-0.beta20
 %attr(755,root,root) %{_libdir}/vlc/plugins/video_output/libcaca_plugin.so
 %endif
 # R: EGL, xorg-lib-libX11
This page took 0.047876 seconds and 4 git commands to generate.