]> git.pld-linux.org Git - packages/vlc.git/blame_incremental - vlc.spec
- converted to UTF-8
[packages/vlc.git] / vlc.spec
... / ...
CommitLineData
1#
2# TODO:
3# - check the altivec patch
4# - add proper package descriptions/translations
5# - bcondize this damn spec! (it should be automated too)
6# - go through the configure --help and add all options with proper
7# reqs and bconds
8# - flac plugin doesn't work with mono files
9#
10# Conditional build:
11%bcond_without aa # build without aalib support
12%bcond_without caca # build without caca support
13%bcond_without dv # build without dv support
14%bcond_without lirc # build without lirc support
15%bcond_without x264 # build without x264 support
16%bcond_without alsa # don't build alsa plugin
17%bcond_without arts # don't build arts plugin
18%bcond_without ggi # don't build ggi plugin
19%bcond_without live # build without live.com support
20%bcond_without speex # don't build speex plugin
21%bcond_with mozilla # build mozilla plugin
22%bcond_with slp # build with slp, broken
23%bcond_with svgalib # build with svgalib video_output
24%bcond_with hal # build with hal support
25#
26Summary: VLC - a multimedia player and stream server
27Summary(pl.UTF-8): VLC - odtwarzacz multimedialny oraz serwer strumieni
28Name: vlc
29Version: 0.8.6
30Release: 5
31License: GPL
32Group: X11/Applications/Multimedia
33# use the bz2 src, its a 4mb difference
34Source0: http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.bz2
35# Source0-md5: 77a275f3408c4c9feae451d4eae47f89
36Source1: %{name}.desktop
37Patch0: %{name}-altivec.patch
38Patch1: %{name}-buildflags.patch
39Patch2: %{name}-defaultfont.patch
40Patch3: %{name}-live.patch
41Patch4: %{name}-pic-mmx.patch
42Patch5: %{name}-real_codecs_path.patch
43Patch6: %{name}-osdmenu_path.patch
44Patch7: %{name}-wx.patch
45Patch8: %{name}-flac.patch
46URL: http://www.videolan.org/vlc/
47BuildRequires: OpenGL-devel
48BuildRequires: SDL_image-devel >= 1.2
49BuildRequires: a52dec-libs-devel
50%{?with_aa:BuildRequires: aalib-devel}
51%{?with_alsa:BuildRequires: alsa-lib-devel >= 0.9}
52%{?with_arts:BuildRequires: artsc-devel}
53BuildRequires: autoconf
54BuildRequires: automake
55BuildRequires: esound-devel
56BuildRequires: faad2-devel >= 2.5
57BuildRequires: ffmpeg-devel >= 0.4.9
58BuildRequires: flac-devel >= 1.1.3
59BuildRequires: fribidi-devel
60BuildRequires: gettext-devel
61%{?with_hal:BuildRequires: hal-devel >= 0.2.97}
62%{?with_dv:BuildRequires: libavc1394-devel}
63%{?with_caca:BuildRequires: libcaca-devel}
64BuildRequires: libcddb-devel
65BuildRequires: libcdio-devel
66BuildRequires: libdts-devel
67%{?with_dv:BuildRequires: libdv-devel}
68BuildRequires: libdvbpsi-devel
69BuildRequires: libdvdcss-devel
70BuildRequires: libdvdnav-devel
71BuildRequires: libdvdread-devel
72BuildRequires: libebml-devel >= 0.7.6
73%{?with_ggi:BuildRequires: libggi-devel}
74BuildRequires: libid3tag-devel
75BuildRequires: libmad-devel
76BuildRequires: libmatroska-devel >= 0.7.5
77BuildRequires: libmodplug-devel
78BuildRequires: libmpcdec-devel >= 1.2.1
79BuildRequires: libogg-devel
80BuildRequires: libpng-devel
81%{?with_dv:BuildRequires: libraw1394-devel}
82BuildRequires: libsmbclient-devel
83BuildRequires: libtheora-devel
84BuildRequires: libtool
85BuildRequires: libvorbis-devel
86%{?with_x264:BuildRequires: libx264-devel}
87BuildRequires: libxml2-devel
88%{?with_lirc:BuildRequires: lirc-devel}
89%{?with_live:BuildRequires: live >= 2005.03.11}
90%{?with_mozilla:BuildRequires: mozilla-devel}
91BuildRequires: mpeg2dec-devel >= 0.3.2
92BuildRequires: ncurses-devel
93%{?with_slp:BuildRequires: openslp-devel}
94BuildRequires: pkgconfig
95%{?with_speex:BuildRequires: speex-devel > 1:1.1.0}
96%{?with_svgalib:BuildRequires: svgalib-devel}
97BuildRequires: vcdimager-devel
98BuildRequires: wxGTK2-unicode-devel >= 2.6.2-2
99BuildRequires: xosd-devel
100BuildRequires: xvid-devel
101BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103%description
104VLC (initially VideoLAN Client) is a multimedia player for various
105audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, MP3, Ogg, ...)
106as well as DVDs, VCDs, and various streaming protocols. It can also be
107used as a server to stream in unicast or multicast in IPv4 or IPv6 on
108a high-bandwidth network.
109
110%description -l pl.UTF-8
111VLC (wcześniej znany pod nazwą VideoLAN Client) jest odtwarzaczem
112multimedialnym dla wielu formatów wideo i dźwięku (MPEG-1, MPEG-2,
113MPEG-4, DivX, MP3, Ogg, ...), płyt DVD, VCD oraz różnych protokołów
114strumieniowych. Może być wykorzystany jako serwer do wysyłania
115strumieni unicast lub multicast w protokołach IPv4 lub IPv6 w
116wysokoprzepustowych sieciach.
117
118%package devel
119Summary: VLC header files
120Summary(pl.UTF-8): Pliki nagłówkowe VLC
121Group: X11/Development/Libraries
122Requires: %{name} = %{version}-%{release}
123
124%description devel
125VLC header files.
126
127%description devel -l pl.UTF-8
128Pliki nagłówkowe VLC.
129
130%package static
131Summary: VLC static libraries
132Summary(pl.UTF-8): Biblioteki statyczne VLC
133Group: X11/Development/Libraries
134Requires: %{name}-devel = %{version}-%{release}
135
136%description static
137VLC static libraries.
138
139%description static -l pl.UTF-8
140Biblioteki statyczne VLC.
141
142%package X11
143Summary: VLC - X11 output plugin
144Summary(pl.UTF-8): Klient VLC - wtyczka wyjścia X11
145Group: X11/Applications/Multimedia
146Requires: %{name} = %{version}-%{release}
147Obsoletes: vlc-gnome
148Obsoletes: vlc-gtk
149
150%description X11
151X11 output plugin for VLC. Contains GUI image/icon resources.
152
153%description X11 -l pl.UTF-8
154Wtyczka wyjścia X11 dla klienta VLC. Zawiera zasoby interfejsu GUI
155(obrazy/ikony).
156
157%package GGI
158Summary: VLC - GGI output plugin
159Summary(pl.UTF-8): Klient VLC - wtyczka wyjścia GGI
160Group: X11/Applications/Multimedia
161Requires: %{name} = %{version}-%{release}
162
163%description GGI
164GGI output plugin for VLC.
165
166%description GGI -l pl.UTF-8
167Wtyczka wyjścia GGI dla klienta VLC.
168
169%package fb
170Summary: VLC - fb output plugin
171Summary(pl.UTF-8): Klient VLC - wtyczka wyjścia fb
172Group: X11/Applications/Multimedia
173Requires: %{name} = %{version}-%{release}
174
175%description fb
176fb output plugin for VLC.
177
178%description fb -l pl.UTF-8
179Wtyczka wyjścia fb dla klienta VLC.
180
181%package SDL
182Summary: VLC - SDL output plugin
183Summary(pl.UTF-8): Klient VLC - wtyczka wyjścia SDL
184Group: X11/Applications/Multimedia
185Requires: %{name} = %{version}-%{release}
186
187%description SDL
188SDL output plugin for VLC.
189
190%description SDL -l pl.UTF-8
191Wtyczka wyjścia SDL dla klienta VLC.
192
193%package esd
194Summary: VLC - EsounD audio output plugin
195Summary(pl.UTF-8): Klient VLC - wtyczka wyjścia dźwięku EsounD
196Group: X11/Applications/Multimedia
197Requires: %{name} = %{version}-%{release}
198
199%description esd
200EsounD audio output plugin for VLC.
201
202%description esd -l pl.UTF-8
203Wtyczka wyjścia dźwięku EsounD dla klienta VLC.
204
205%package alsa
206Summary: VLC - ALSA audio output plugin
207Summary(pl.UTF-8): Klient VLC - wtyczka wyjścia dźwięku ALSA
208Group: X11/Applications/Multimedia
209Requires: %{name} = %{version}-%{release}
210
211%description alsa
212ALSA audio output plugin for VLC.
213
214%description alsa -l pl.UTF-8
215Wtyczka wyjścia dźwięku ALSA dla klienta VLC.
216
217%prep
218%setup -q
219## %patch0 -p1
220%patch1 -p0
221%patch2 -p1
222%patch3 -p1
223%patch4 -p1
224%patch5 -p1
225%patch6 -p1
226%patch7 -p1
227%patch8 -p1
228
229%build
230cp -f /usr/share/automake/config.* .
231%{__gettextize}
232%{__aclocal} -I m4
233%{__autoconf}
234CFLAGS="%{rpmcflags} -DALSA_PCM_OLD_HW_PARAMS_API"
235%configure \
236%ifarch ppc
237 --disable-altivec \
238%endif
239 --%{?with_aa:en}%{!?with_aa:dis}able-aa \
240 %{?with_alsa:--enable-alsa} \
241 %{?with_arts:--enable-arts} \
242 %{!?with_arts:--disable-arts} \
243 --%{?with_caca:en}%{!?with_caca:dis}able-caca \
244 --enable-dsp \
245 --enable-dummy \
246 --%{?with_dv:en}%{!?with_dv:dis}able-dv \
247 --enable-dvb \
248 --enable-dvbpsi \
249 --with-dvdcss \
250 --enable-dvdnav \
251 --enable-dvdread \
252 --enable-esd \
253 --enable-faad \
254 --enable-fb \
255 --enable-freetype \
256 --enable-fribidi \
257 --enable-ffmpeg \
258 --enable-flac \
259 --%{?with_ggi:en}%{!?with_ggi:dis}able-ggi \
260 %{!?with_speex:--disable-speex} \
261 --disable-glide \
262 --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
263 --enable-mad \
264 --enable-mga \
265 %{?with_mozilla:--enable-mozilla } \
266 %{?with_live:--enable-live555 } \
267 %{!?with_live:--disable-live555 } \
268 --with-live555-tree=%{_libdir}/liveMedia \
269 --enable-ncurses \
270 --enable-pvr \
271 --enable-real \
272 --enable-realrtsp \
273 --enable-sdl \
274 --with-sdl=/usr \
275 --enable-skins2 \
276 %{?with_slp:--enable-slp} \
277 %{!?with_slp:--disable-slp} \
278 --enable-smb \
279 %{?with_svgalib:--enable-svgalib} \
280 --enable-tarkin \
281 --enable-theora \
282 --enable-tremor \
283 --enable-v4l\
284 --enable-x11 \
285 %{!?with_x264:--disable-x264} \
286 --enable-xosd \
287 --enable-xvid \
288 --enable-oss \
289 --disable-testsuite \
290 --with-wx-config=wx-gtk2-unicode-config \
291 %{!?with_hal:--disable-hal} \
292 --disable-optimizations # we use own RPM_OPT_FLAGS optimalizations
293
294# echo "CFLAGS += -I/usr/include/ncurses" >> Makefile.opts
295%{__make}
296
297%install
298rm -rf $RPM_BUILD_ROOT
299install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_mandir}/man1}
300
301%{__make} install \
302 DESTDIR=$RPM_BUILD_ROOT
303
304install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
305install doc/vlc.1 $RPM_BUILD_ROOT%{_mandir}/man1
306
307%if "%{_lib}" != "lib"
308install -d $RPM_BUILD_ROOT%{_prefix}/lib
309ln -sf %{_libdir}/vlc $RPM_BUILD_ROOT%{_prefix}/lib
310%endif
311
312%find_lang %{name}
313
314%clean
315rm -rf $RPM_BUILD_ROOT
316
317%files -f %{name}.lang
318%defattr(644,root,root,755)
319%doc AUTHORS MAINTAINERS NEWS README THANKS
320%doc doc/bugreport-howto.txt doc/intf-cdda.txt
321%doc doc/intf-vcd.txt doc/translations.txt
322%attr(755,root,root) %{_bindir}/vlc
323%if "%{_lib}" != "lib"
324%{_prefix}/lib/vlc
325%endif
326%dir %{_libdir}/vlc
327%dir %{_libdir}/vlc/gui
328%dir %{_libdir}/vlc/visualization
329%attr(755,root,root) %{_libdir}/vlc/gui/libncurses_plugin.so
330%attr(755,root,root) %{_libdir}/vlc/visualization/libvisual_plugin.so
331%attr(755,root,root) %{_libdir}/vlc/mux
332%attr(755,root,root) %{_libdir}/vlc/misc
333%attr(755,root,root) %{_libdir}/vlc/control
334%attr(755,root,root) %{_libdir}/vlc/access_output
335%attr(755,root,root) %{_libdir}/vlc/codec
336%attr(755,root,root) %{_libdir}/vlc/demux
337%attr(755,root,root) %{_libdir}/vlc/access
338%exclude %{_libdir}/vlc/access/libscreen_plugin.so
339%attr(755,root,root) %{_libdir}/vlc/video_chroma
340%attr(755,root,root) %{_libdir}/vlc/audio_mixer
341%attr(755,root,root) %{_libdir}/vlc/video_filter
342%dir %{_libdir}/vlc/video_output
343%attr(755,root,root) %{_libdir}/vlc/stream_out
344%attr(755,root,root) %{_libdir}/vlc/audio_filter
345%attr(755,root,root) %{_libdir}/vlc/packetizer
346%attr(755,root,root) %{_libdir}/vlc/access_filter
347%attr(755,root,root) %{_libdir}/vlc/services_discovery
348%dir %{_libdir}/vlc/audio_output
349%exclude %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
350%{?with_alsa:%exclude %{_libdir}/%{name}/audio_output/libalsa_plugin.so}
351%exclude %{_libdir}/%{name}/audio_output/libesd_plugin.so
352%attr(755,root,root) %{_libdir}/vlc/audio_output/*.so
353%dir %{_datadir}/%{name}
354%{_datadir}/%{name}/http
355%{_datadir}/%{name}/osdmenu
356%{_mandir}/man1/vlc.1*
357
358%files devel
359%defattr(644,root,root,755)
360%attr(755,root,root) %{_bindir}/vlc-config
361%dir %{_includedir}/%{name}
362%{_includedir}/%{name}/*
363
364%files static
365%defattr(644,root,root,755)
366%{_libdir}/libvlc.a
367%{_libdir}/%{name}/*.a
368
369%files X11
370%defattr(644,root,root,755)
371%attr(755,root,root) %{_bindir}/svlc
372%attr(755,root,root) %{_bindir}/wxvlc
373%attr(755,root,root) %{_libdir}/vlc/gui/libskins2_plugin.so
374%attr(755,root,root) %{_libdir}/vlc/gui/libwxwidgets_plugin.so
375%attr(755,root,root) %{_libdir}/vlc/access/libscreen_plugin.so
376%attr(755,root,root) %{_libdir}/vlc/video_output
377%{?with_ggi:%exclude %{_libdir}/%{name}/video_output/libggi_plugin.so}
378%exclude %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
379%exclude %{_libdir}/%{name}/video_output/libfb_plugin.so
380%attr(755,root,root) %{_libdir}/vlc/visualization/libxosd_plugin.so
381%{_datadir}/%{name}/skins2
382%{_datadir}/%{name}/vlc*.xpm
383%{_datadir}/%{name}/pda*.xpm
384%{_datadir}/%{name}/vlc*.png
385%{_datadir}/%{name}/vlc*.ico
386%{_desktopdir}/*.desktop
387
388%if %{with ggi}
389%files GGI
390%defattr(644,root,root,755)
391%attr(755,root,root) %{_libdir}/%{name}/video_output/libggi_plugin.so
392%endif
393
394%files SDL
395%defattr(644,root,root,755)
396%attr(755,root,root) %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
397%attr(755,root,root) %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
398
399%files fb
400%defattr(644,root,root,755)
401%attr(755,root,root) %{_libdir}/%{name}/video_output/libfb_plugin.so
402
403%files esd
404%defattr(644,root,root,755)
405%attr(755,root,root) %{_libdir}/%{name}/audio_output/libesd_plugin.so
406
407%if %{with alsa}
408%files alsa
409%defattr(644,root,root,755)
410%attr(755,root,root) %{_libdir}/%{name}/audio_output/libalsa_plugin.so
411%endif
This page took 0.067937 seconds and 4 git commands to generate.