]> git.pld-linux.org Git - packages/virt-viewer.git/commitdiff
- updated to 0.5.6 auto/ti/virt-viewer-0.5.6-1
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 17 Jun 2013 19:27:50 +0000 (21:27 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 17 Jun 2013 19:27:50 +0000 (21:27 +0200)
- removed outdated plugin patch (browser plugin has been removed as obsolete)
- added ovirt support as bcond (depends on DEVEL rest)

virt-viewer-plugin.patch [deleted file]
virt-viewer.spec

diff --git a/virt-viewer-plugin.patch b/virt-viewer-plugin.patch
deleted file mode 100644 (file)
index 58e3378..0000000
+++ /dev/null
@@ -1,212 +0,0 @@
---- virt-viewer-0.5.2/plugin/virt-viewer-plugin.h.orig 2012-03-09 14:42:10.000000000 +0100
-+++ virt-viewer-0.5.2/plugin/virt-viewer-plugin.h      2012-04-26 17:45:39.725500899 +0200
-@@ -46,10 +46,10 @@
- #define PLUGIN_DESCRIPTION  "Virtual machine console viewer plugin"
- typedef struct {
--  uint16 mode;
-+  uint16_t mode;
-   NPWindow *window;
--  int32 x, y;
--  uint32 width, height;
-+  int32_t x, y;
-+  uint32_t width, height;
-   NPP instance;
-   NPBool pluginsHidden;
-@@ -62,7 +62,7 @@
- extern NPError VirtViewerXSetWindow (NPP instance, NPWindow* window);
- extern NPError VirtViewerDestroyWindow (NPP instance);
--extern int16 VirtViewerXHandleEvent (NPP instance, void* event);
-+extern int16_t VirtViewerXHandleEvent (NPP instance, void* event);
- #ifdef ENABLE_DEBUG
- static void
---- virt-viewer-0.5.2/plugin/virt-viewer-plugin.c.orig 2012-03-09 14:42:10.000000000 +0100
-+++ virt-viewer-0.5.2/plugin/virt-viewer-plugin.c      2012-04-26 17:55:14.225488926 +0200
-@@ -111,7 +111,7 @@
- static NPWindow windowlessWindow;
--int16
-+int16_t
- VirtViewerXHandleEvent(NPP instance, void *event)
- {
-   XGraphicsExposeEvent exposeEvent;
---- virt-viewer-0.5.2/plugin/npshell.c.orig    2012-03-09 14:42:10.000000000 +0100
-+++ virt-viewer-0.5.2/plugin/npshell.c 2012-04-26 19:54:27.675339819 +0200
-@@ -84,7 +84,7 @@
- #include <strings.h>
- #include <npapi.h>
--#include <npupp.h>
-+#include <nspr/prtypes.h>
- #include "virt-viewer-plugin.h"
-@@ -94,7 +94,7 @@
-  *
-  ***********************************************************************/
--char *
-+const char *
- NPP_GetMIMEDescription(void)
- {
-   return (char *) MIME_TYPES_HANDLED;
-@@ -150,8 +150,8 @@
- NPError
- NPP_New(NPMIMEType pluginType G_GNUC_UNUSED,
-         NPP instance,
--        uint16 mode,
--        int16 argc,
-+        uint16_t mode,
-+        int16_t argc,
-         char* argn[],
-         char* argv[],
-         NPSavedData *saved G_GNUC_UNUSED)
-@@ -253,7 +253,7 @@
-   return VirtViewerXSetWindow(instance, window);
- }
--int32
-+int32_t
- NPP_WriteReady(NPP instance, NPStream *stream)
- {
-   /*printf("NPP_WriteReady()\n");*/
-@@ -267,9 +267,9 @@
-   return -1L;   /* don't accept any bytes in NPP_Write() */
- }
--int32
-+int32_t
- NPP_Write(NPP instance, NPStream *stream,
--          int32 offset G_GNUC_UNUSED, int32 len G_GNUC_UNUSED,
-+          int32_t offset G_GNUC_UNUSED, int32_t len G_GNUC_UNUSED,
-           void *buffer G_GNUC_UNUSED)
- {
-   /*printf("NPP_Write()\n");*/
-@@ -386,7 +386,7 @@
-     }
- }
--int16 NPP_HandleEvent(NPP instance, void* event)
-+int16_t NPP_HandleEvent(NPP instance, void* event)
- {
-   /*printf("NPP_HandleEvent()\n");*/
---- virt-viewer-0.5.2/plugin/npunix.c.orig     2012-03-09 14:42:10.000000000 +0100
-+++ virt-viewer-0.5.2/plugin/npunix.c  2012-04-26 19:59:30.808666841 +0200
-@@ -57,7 +57,7 @@
- #include <stdio.h>
- #include <npapi.h>
--#include <npupp.h>
-+#include <npfunctions.h>
- #include <glib.h>               /* just for G_GNUC_UNUSED */
-@@ -134,14 +134,14 @@
- NPError
- NPN_PostURL(NPP instance, const char* url, const char* window,
--         uint32 len, const char* buf, NPBool file)
-+         uint32_t len, const char* buf, NPBool file)
- {
-     return CallNPN_PostURLProc(gNetscapeFuncs.posturl, instance,
-                     url, window, len, buf, file);
- }
- NPError
--NPN_PostURLNotify(NPP instance, const char* url, const char* window, uint32 len,
-+NPN_PostURLNotify(NPP instance, const char* url, const char* window, uint32_t len,
-                   const char* buf, NPBool file, void* notifyData)
- {
-     return CallNPN_PostURLNotifyProc(gNetscapeFuncs.posturlnotify,
-@@ -163,8 +163,8 @@
-                     type, window, stream_ptr);
- }
--int32
--NPN_Write(NPP instance, NPStream* stream, int32 len, void* buffer)
-+int32_t
-+NPN_Write(NPP instance, NPStream* stream, int32_t len, void* buffer)
- {
-     return CallNPN_WriteProc(gNetscapeFuncs.write, instance,
-                     stream, len, buffer);
-@@ -190,7 +190,7 @@
- }
- void*
--NPN_MemAlloc(uint32 size)
-+NPN_MemAlloc(uint32_t size)
- {
-     return CallNPN_MemAllocProc(gNetscapeFuncs.memalloc, size);
- }
-@@ -200,7 +200,7 @@
-     CallNPN_MemFreeProc(gNetscapeFuncs.memfree, ptr);
- }
--uint32 NPN_MemFlush(uint32 size)
-+uint32_t NPN_MemFlush(uint32_t size)
- {
-     return CallNPN_MemFlushProc(gNetscapeFuncs.memflush, size);
- }
-@@ -269,8 +269,8 @@
-  ***********************************************************************/
- static NPError
--Private_New(NPMIMEType pluginType, NPP instance, uint16 mode,
--        int16 argc, char* argn[], char* argv[], NPSavedData* saved)
-+Private_New(NPMIMEType pluginType, NPP instance, uint16_t mode,
-+        int16_t argc, char* argn[], char* argv[], NPSavedData* saved)
- {
-     NPError ret;
-     PLUGINDEBUGSTR("New");
-@@ -297,7 +297,7 @@
- static NPError
- Private_NewStream(NPP instance G_GNUC_UNUSED, NPMIMEType type G_GNUC_UNUSED,
-                   NPStream* stream G_GNUC_UNUSED,
--                  NPBool seekable G_GNUC_UNUSED, uint16* stype G_GNUC_UNUSED)
-+                  NPBool seekable G_GNUC_UNUSED, uint16_t* stype G_GNUC_UNUSED)
- {
-     NPError err = NPERR_NO_ERROR;
-     PLUGINDEBUGSTR("NewStream");
-@@ -305,7 +305,7 @@
-     return err;
- }
--static int32
-+static int32_t
- Private_WriteReady(NPP instance, NPStream* stream)
- {
-     unsigned int result;
-@@ -314,8 +314,8 @@
-     return result;
- }
--static int32
--Private_Write(NPP instance, NPStream* stream, int32 offset, int32 len,
-+static int32_t
-+Private_Write(NPP instance, NPStream* stream, int32_t offset, int32_t len,
-         void* buffer)
- {
-     unsigned int result;
-@@ -376,7 +376,7 @@
- }
- #endif
--static int16
-+static int16_t
- Private_HandleEvent(NPP instance, void* event)
- {
-     return NPP_HandleEvent(instance, event);
-@@ -394,7 +394,7 @@
-  *  - Netscape uses the return value to identify when an object instance
-  *    of this plugin should be created.
-  */
--char *
-+const char *
- NP_GetMIMEDescription(void)
- {
-     return NPP_GetMIMEDescription();
index e2d40bc4febf6568439d42a086d34b8ab5bff0ad..1d0370bd55379327d19942b1ffeea8c59d99ee36 100644 (file)
@@ -2,28 +2,24 @@
 # Conditional build:
 %bcond_with    gtk2    # use GTK+ 2.x instead of GTK+ 3.x
 %bcond_without spice   # SPICE support
-%bcond_without plugin  # Mozilla plugin (doesn't work with GTK+ 3)
+%bcond_with    ovirt   # oVirt support [requiring libgovirt, depending on rest >= 1.7.13]
 #
-%if %{without gtk2}
-# plugin is not ready for GTK+ 3
-%undefine      with_plugin
-%endif
 Summary:       Virtual Machine Viewer
 Summary(pl.UTF-8):     Przeglądarka maszyny wirtualnej
 Name:          virt-viewer
-Version:       0.5.5
+Version:       0.5.6
 Release:       1
 License:       GPL v2+
 Group:         X11/Applications/Networking
 Source0:       http://virt-manager.org/download/sources/virt-viewer/%{name}-%{version}.tar.gz
-# Source0-md5: a5516d33a29df5d135611c4667c03f77
-Patch0:                %{name}-plugin.patch
+# Source0-md5: b1f55ad642df062028b24d8a77619ac5
 URL:           http://virt-manager.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: gettext-devel >= 0.14.1
 BuildRequires: glib2-devel >= 1:2.22.0
 BuildRequires: intltool >= 0.35.0
+%{?with_ovirt:BuildRequires:   libgovirt-devel}
 BuildRequires: libtool >= 2:2
 BuildRequires: libvirt-devel >= 0.10.0
 BuildRequires: libxml2-devel >= 1:2.6.0
@@ -39,10 +35,6 @@ BuildRequires:       gtk+3-devel >= 3.0.0
 BuildRequires: gtk3-vnc-devel >= 0.4.3
 %{?with_spice:BuildRequires: spice-gtk-devel >= 0.16.26}
 %endif
-%if %{with plugin}
-BuildRequires: nspr-devel >= 4.0.0
-BuildRequires: xulrunner-devel >= 1.8
-%endif
 Requires(post,postun): gtk-update-icon-cache
 Requires:      glib2 >= 1:2.22.0
 Requires:      hicolor-icon-theme
@@ -59,6 +51,7 @@ BuildRequires:        gtk3-vnc >= 0.4.3
 %endif
 Suggests:      openssh-clients
 Suggests:      gnome-keyring >= 0.4.9
+Obsoletes:     virt-viewer-plugin
 ExclusiveArch: %{ix86} %{x8664} ia64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -74,32 +67,8 @@ Virtual Machine Viewer udostępnia klienta graficznej konsoli do
 SPICE-GTK do zapewnienia obrazu oraz libvirt do odczytu szczegółów
 serwera VNC/SPICE.
 
-%package plugin
-Summary:       Mozilla plugin for the gtk-vnc library
-Summary(pl.UTF-8):     Wtyczka Mozilli do biblioteki gtk-vnc
-Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
-
-%description plugin
-Virtual Machine Viewer provides a graphical
-console client for connecting to virtual machines. It uses the GTK-VNC
-or SPICE-GTK widgets to provide the display, and libvirt for looking
-up VNC/SPICE server details.
-
-This package provides a web browser plugin for Mozilla compatible
-browsers.
-
-%description plugin -l pl.UTF-8
-Virtual Machine Viewer udostępnia klienta graficznej konsoli do
-łączenia z maszynami wirtualnymi. Wykorzystuje widgety GTK-VNC lub
-SPICE-GTK do zapewnienia obrazu oraz libvirt do odczytu szczegółów
-serwera VNC/SPICE.
-
-Ten pakiet dostarcza wtyczkę dla przeglądarek WWW zgodnych z Mozillą.
-
 %prep
 %setup -q
-%patch0 -p1
 
 %{__sed} -i -e 's|PWD|shell pwd|g' icons/*/Makefile.am
 
@@ -111,9 +80,9 @@ Ten pakiet dostarcza wtyczkę dla przeglądarek WWW zgodnych z Mozillą.
 %{__automake}
 %configure \
        --disable-silent-rules \
-       %{__enable_disable plugin} \
        %{__with_without spice spice-gtk} \
-       --with-gtk=%{?with_gtk2:2.0}%{!?with_gtk2:3.0}
+       --with-gtk=%{?with_gtk2:2.0}%{!?with_gtk2:3.0} \
+       %{!?with_ovirt:--without-ovirt}
 
 %{__make}
 
@@ -121,8 +90,7 @@ Ten pakiet dostarcza wtyczkę dla przeglądarek WWW zgodnych z Mozillą.
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       plugindir=%{_libdir}/browser-plugins
+       DESTDIR=$RPM_BUILD_ROOT
 
 %find_lang %{name}
 
@@ -143,13 +111,8 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/%{name}
 %dir %{_datadir}/%{name}/ui
 %{_datadir}/%{name}/ui/*.xml
+%{_datadir}/mime/packages/virt-viewer-mime.xml
 %{_desktopdir}/remote-viewer.desktop
 %{_iconsdir}/hicolor/*/apps/virt-viewer.png
 %{_mandir}/man1/virt-viewer.1*
 %{_mandir}/man1/remote-viewer.1*
-
-%if %{with plugin}
-%files plugin
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/browser-plugins/virt-viewer-plugin.so
-%endif
This page took 0.173912 seconds and 4 git commands to generate.